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Hello!

My name is ‘DIY-booklet’ and I'm glad to see you have picked me up. | am from ZUKEN and it is good
to meet you. If you are wondering where this is, take a look at www.zuken.com/cadstar, my "home"-

page.

With this booklet, you have received a free copy of CADSTAR Express. CADSTAR Express provides a
number of features of the full CADSTAR version, only limited by the number of components (max 50)
and pads (max 300).

To install CADSTAR Express, double click on the executable for set-up and simply follow the
instructions.

If you are seriously thinking about designing a Schematic and Printed Circuit Board (PCB), you have
made the right decision to come to me. You will find out in detail how you can make use of CADSTAR
to design a Schematic and PCB. | will start by showing you a hand drawn electronic circuit and
transforming this to a professional schematic design. Then I'll take you through the process of creating
an error-free transfer of data to a PCB, and then move to layout and routing. The second step | will
show you is how to create and add a component to your library.

Spend some time with me and you will learn a lot in a short time.
It is not difficult to capture a schematic and to design a PCB, but if | was not clear enough, just click on

the camera icon every time you come across it, and watch me (you will need an internet connection for
this)!
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Please Note: This do-it-yourself guide has been revised using a Windows 7 environment. The
software has been installed on the author’'s computer using the default locations and selections

per the CADSTAR Express rev 13 SETUP program. If you are using Windows XP your default
path and file locations will differ from the images displayed in this guide.
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e Introduction to CADSTAR

Let me introduce CADSTAR to you. CADSTAR is an EDA design tool allowing you to draw a
schematic design and transfer the design to a PCB layout environment. After an error-free transfer,
CADSTAR helps to place the components into the board outline.

Placement and Routing is an integral part of a PCB design process. CADSTAR offers much flexibility in
this area by providing both Push-a-side Placement and Routing tools (manual, semi-automatic and
fully automatic) within the Embedded Place & Route Editor or the advanced standalone Place & Route
Editor. The Embedded Place & Route Editor has been developed in general for basic PCB design or
users who don't use a PCB design tool regularly, and the standalone Place & Route Editor is for the
more advanced users who require more powerful functions. For really advanced users (industry users)
high-speed design features (such as lengthening, delay, impedance, cross-talk, overshoot, reflection
etc.) can also be provided in a full standard package or as an optional add-on. The additional add-on’s
that are available to you, include BoardModeler Lite which is a unique 3D verification tool for PCB
design that provides a complete new concept of PCB Design in a 3D environment or the CADSTAR
Variant Manager which enables you to generate variants of a 'master' design (included B.O.M’s and
assembly drawings) without having to maintain separate files for each variant.

The completion of the PCB design will be followed by the generation of manufacturing output data for
PCB fabrication.

I will guide you through the basic design flow of a PCB design and through some very simple PCB
designs using CADSTAR. Try them and have fun!
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Let’'s Get Started!

By now you have probably installed CADSTAR on your PC and are anxious to get started. Start by

clicking the Design Editor Icon in your Start->Programs2>CADSTAR Express menu.

CADSTAR is started you will see the Start page as shown below.

When

File View Libraries Jools Window Help

Start Page - Zuken CADSTAR Design Editor Express

Current Design

{23 Current Design

Open Workspace...

Save New Workspace...

September 23, 2011. After that, the standard price of $450 applies, so
don't miss out on the savings. The Z_DAC Annual Conference is the
company's most important event during the year. It is here that we
have the opportunity to bring together our customers, prospects, and
respected industry professionals in a synergistic environment, that
allows them to focus on sharing insight and experiences, broadening

1 =IA\!

Open File...

New File...

Recent Design Files

their knowledge, and building relationships. Click here for more

details. Americos

CADSTAR Placement Planning

Adding the CADSTAR Placement Planner to your design flow will bridge the gap between the
design concept and the physical layout. Placement Planning is an add-on to CADSTAR
Schematics that helps electronic engineers to communicate their thoughts to the PCB
designer better and faster, without time-consuming editing afterwards, causing expensive
delays. Click here for more details and pricing by contacting your local CADSTAR reseller.

CADSTAR OnLine Library

A new library has been added to the CADSTAR OnLine Library on LinkZ, being:
ST-Microelectronics

As a result the CADSTAR OnLine Library now contains about 250,000 Parts from different

Getting Started
B2 What's New

B CADSTAR Help

4

T cADSTAR Express DIY

CADSTAR OnLine

CADSTAR News & Events

component suppliers.
Click here for more details.

CADSTAR Express S
CADSTAR Express version 12.1 is available now! All the functionality of =~

CADSTAR 12.1 is available; the only limitation is that you can only work

¥ Load this page on application start.

with 300 pins and 50 components.

lirk hara far mara dataile

= =

NEeEHE s B2RX| o o imE@ o -EEEEE
o o
[ Open Desions - o x -
d . \
: M CADSTAR Express Design Editor 13.0 P -
: =
? Recent Workspace Files ™ OnLine CADSTAR News Reader
:
b — Register Now for Z-DAC Americas in San Antonio =
3 . Registration is now open for the Zuken user event Z-DAC Americas,
5 set for November 8-9, 2011 in the Hotel Contessa, San Antonio,
§ - Texas. The Early Bird price of $275 is available until midnight on

MZUKEN _

M start Page x]

Bus Repart

[#] Design Rule Errors

Electrical Rules Cheek

[H] Overlapping Connections

Routing Completion

Unused Companents

3

This page serves as a Concierge. It allows you to;

Access recently opened Workspace Files
Access recently opened Designs,
Access Help and PDF files

pages.

Read up on the latest in CADSTAR News from the World of Zuken.
Access some or On-line Links such as the On-Line Library and our CADSTAR Web

CADSTAR is a Multi-Document Design Environment. Soon you will have schematic designs and PCB

designs all open in the same Design Editor environment.
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e The Basic Design Flow

Library

Schematic

PCB
(Placement)

PCB
(Routing)

Manufactu-
ring Output

Usually you need to start off with a library and to ensure that all the parts (schematic
symbols & PCB footprints) that you will require are available to you. However, to
complete the exercises in this DIY booklet you don't need to worry about the library.
Nevertheless if you are keen on learning more about the CADSTAR library you can try
Chapter 3.

Note: the library provided with CADSTAR Express contains all the parts essential for
the PCB designs described in this 'Do-It-Yourself Book' and some examples of the on-
line CADSTAR Libraries. CADSTAR has made their evaluation software, CADSTAR
EXPRESS, even more user friendly by adding a free download of a 20.000 Parts Library
at our website. Additional libraries are available through the Zuken on-line support
website. The ready-to-download-and-use parts contain all the information you require
including manufacturers' part numbers. They are updated and expanded regularly with
over 250,000 parts currently available. If the part required is not available in these
libraries, you can quickly and easily design your own parts using the supplied wizards
and the Graphical Library Editor.

Access to the on-line CADSTAR Libraries is available as part of annual maintenance
contracts.

It is always advisable to start with a schematic design before moving onto the
PCB design (although CADSTAR does support reverse engineering).

After the successful transfer from schematic, components will be placed within the
board outline.

After placing all the components, we can start routing the critical nets manually and/or
through automatic routing.

The final stage of any PCB design. No matter what your manufacturer requires,

CADSTAR can deliver; extended Gerber (RS274X), extended N.C. Drill (Excellon),
Placement data, Bill of Materials, IPC356-D test data, DXF and ODB++
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e The User Interface

CADSTAR is very Easy to use! The User Interface is very consistent in operations whether you are
editing a Schematic or a PCB Design.

CADSTAR Supports;

Dockable Tool bars can be dragged and docked as needed.

Tool bar Icons that can be allocated as the user wishes.

Customizable Tool bars and Menus are supported for adding user defined reports and
Macros.

Tabbed Document Window support — Most often seen in more modern version of Windows
7 and MS Office ®

“Strokes” - command macros that perform the most common functions for panning and
zooming.

Themes to alter the appearance of CADSTAR when working in a more modern operating
system, “Windows 7”, such as Collapsible Menus for a more condensed menu appearance.
Dockable Active reports - Active reports can be placed anywhere just like any other
dockable window in CADSTAR. The reports you currently have open will appear as tabs in
the Active Report window.
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. Strokes in CADSTAR and the Place & Route Editor

If you are not familiar with Stroke commands, you can use them for;

Indicating operations you wish the application to perform by dragging the right mouse button in the

shape of one of the 'gestures' in the table below.

To make the gesture:

e Use the mouse to position the cursor in the design window

o Click the right mouse button and Hold while moving the mouse so that the cursor follows the
path of the gesture. The application will provide feedback by drawing a white line showing the

path of the cursor

e Release the right mouse button

Note: The shape of the path followed by the cursor is important. The direction which the cursor takes

along the path is also important, since it is often true that each of the two different directions is
associated with a different operation.

(Display all of the
drawing/design or
component/symbol)

Gesture Icon Operation Gesture Icon Operation
F Panup — i 4 Pan left
L Pan down _— i : | Pan right
Zoom in @ Zoom out
Zoom to selected
View all area

(the minimum box
which contains both
the start and end
points)

Redisplay the current
view, repairing any
damage to the
objects displayed

Zoom to selected
area

[see above]

Previous View
Revert to the view
as it was before the
last view-chanaging
command such as
pan or zoom

N
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e Chapter 1 — Design A

Introduction to the LED Flasher

This is an A-stable multi-vibrator circuit to alternately flash two LEDs. The Resistor and the Capacitor
values determine the frequency, which is the flash rate. The formula is as follows:

[+ 24 L4 *

o

LED Flasher

[Time Off = 0.7 x R x C] Rin ohms and C in farads

[Total Time Off = 1/ Frequency] Total Time Off being the total number of seconds that both
transistors are off and Frequency is in hertz.

[Time Half = Total Time Off / 2]

[Capacitor = Time Half / (0.7 * R )] with Capacitor answer in farads.

The design drawn has two 39 k Ohm resistors and 10uF capacitors. However, the two sides do not
have to match. Different values for R and C on each side can give a nice effect for a unique duty-
cycle. The flash-rate for this circuit is about one cycle per second.

The 470 Ohm collector load resistor limits the current flow to ~20mA and also determines the
brightness of the LEDs. 270 or 330 Ohm is recommended for green LEDs. The transistors in this
design are not critical.
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Step 1 - Schematic for Design A

a.

g.

Let's start with going through the hand drawn schematic shown previously - the design of a
simple LED flasher.

You will then have to gather the components being used in the flasher.

From the hand-drawn schematic, you should be able to find twelve (12) parts in the Library.
They are;

Qty. per part

2N3904 NPN Transistor

1N914 Diode

LED HLMP-1585

470 Ohm Resistor

39k Ohm Resistor

10uF/10V Electrolytic Capacitor

NNNNDNDDN

You can use a 9V battery for this power supply.

Once this information is available, you can start within the CADSTAR Design Editor

Click the I icon on the toolbar or select (File>New Schematic Design) and choose one of
the templates in the box. (I like Form A4-euro)

ew x|
Schematic Design | PCB Desian I Schematic Symbaol I PCE Component I Documentation Symbal I
Ss) P =
= = = = =
Defaults Form A1 Form AZ 0 s
r Description
g g g g g Adeuro -Size Sheet
[==1 [==1 [==1 [==] [==]
Form B1 Form B2 Form C1 Form C2 Form D1
e P
[==1 [==1 [==1
Form D2 Form E1 Form E2
Template Folder: [+ View Mew Design Settings
C:\Users\Public’Zuken\CADSTAR BExpress 13.0%Templates

ok | Cacdl | Hep

)

When you select your template you can enter some information using the Attributes that have
been created for you. These will appear in the Title block of the Schematic format. Later you
can easily customize your own attributes and format sheets.
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New SCM Design |

Design Title
&.3-euro -Size Sheet :I
-
4 k
r~ Units
Units: IThousandths of an inch j Number of Decimal Places: I‘I
r~ Display arid
Flay gl 5 v
¥ Displaygid ~ Stem: |1 oo |1 an.a Grid type: IPoints 'I
r— Colour Template
Colour File [[DEFALLT) =]
- Attributes
Doc Sym Referencel Doc Sym Positiond =]
S Attribute Name Attribute Value
Sheett =
[E] FORMAT{&3-EURO) (13000.0,1000.0}
Checked JL
Company name Zuken
Drawn AB
lzsued 09-08-15
Project name: lyg |
Project number S e
Revision 1 hd|

Cancel | Help |

TIP: If you don't like to work with a black background, you can also select from the toolbar, a
different background colour scheme.

(3 | White Background SCM v |

You have just started a new schematic design, however your design is untitled, so why not select the
[File=>Save as...] function and give it a real name.

You can now start calling out the symbols you require by using the Workspace on the left of the
window.
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¥=Z0H h.  Adding parts is as “Easy as ABC"!

¥ DIY_Express01.scm {C:\Program Files'Zukg

feach') - Sheet1 - Scher

File Edit Wiews @&dd Acktions Hierarchy Sebbing

Ned& BB X o~ i

EER®
ri"i_' b gt MR T o Fio DT A
S¥) Libraries

“ B. [Enter] the part name

]
[ : [ i
B 2EERT ~

B 2541025

i M ecuAnE

NBIEE T 10 3]

~
/|

A. Click the Libraries Tab

l salpadold edeuﬁ

Ready

[ |113.0 12272,

Note: The Workspace tab menus for Libraries, Designs, Shape Properties, etc, can be automatically
hidden if you wish. Simply Click the Auto Hide Icon shown above. When you move your cursor off of

the workspace menu it will automatically slide to a hidden position. To show the menu again, drag your
cursor back to the Workspace Tab on the left.

Proceed to place two transistors onto the schematic

Tip: For an advanced library search and filtering select Libraries>Library Searcher>Parts
Library->Parts.lib (or any of the other Parts Libraries you want to search).

Drag the transistor from the Workspace window, i.e. highlight 2N3904, click on it by using the
left-hand mouse button, without releasing the button and drag it out onto the design template.
Don't be frightened about the red markers on the pins as these are just zoom independent
markers to highlight unconnected pins (the markers will disappear once you connect the pins).
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e T

While dragging, you can use the right-hand mouse button <RMB> menu for mirror and/or
rotation commands for the placement of a symbol. You can also use the ‘m’ or ‘r' hotkeys
before the component is placed or use a programmable function key like F3 to rotate. You can
setup the function keys by selecting Tools=>Customise>Keyboard.

Tip: For more information on hot key commands type [ |E
‘?<enter>’ (this will appear on the command line at the lower [ Libraries | Bg shape Pro

left corner of the application). I —— I 5
us Repao i

k. Do the same for the other ten components (you can either

select the through-hole or SMD components):

Qty. per part

Diode>1N914 (or BAS19)
Led>HLMP-1585
Resistor>470E-MRS25-1% (or 470E-r0805-2%)
Resistor>39K-MRS25-1% (or 39K-r0805-2%)
E-Capacitor>10uF-10V-EC (or 10uF-10V-c6032)

HLMP-1585 HLMP-1585
. i

NNDNDNDN

LED1
LED2

R1 R3 R4 R2
470E 39K 38K 470E
c1
10uF
c2
+
TR2 10uF TR1

2N3904@< @2%904
— o
a 1NO14 a 1N914

| placed mine like this.

Eﬂ l. You can move more than one component at a time. Hold down <Ctrl> button on the keyboard
and make your selections and then Click and Drag them.
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You can also use the Polygon and Freehand Selection functions to select everything within an
area. Select the Tool bar icon and draw a polygon/fence around the items you want to select.
When you are ready to select them simply Double Click the Left mouse button to accept the
polygon or if using the freehand selection mode, just release the Left mouse button and then
Click and Drag them.

An additional selection method is available in the _
Tools 2Options 2[Interaction] tab. Here you can System | File Lacations | Library Paths InteractionIDigF
choose between Overlap and Cover selection  Add Seqment Mode  Readabiity—
methods. " Two Segmert - 90 Degrees mAppliez—|
) ] ] * One Segmert - 45 Degrees " Mone
This gives more control over how items are selected Y] e — & Symbo
during Frame Select, Polygon Select and Freehand ~Delete/Cut Al
Select. V¥ Ask on Delete/Cut —
¥ FKeep Eoutes/Connections Dl
e Use Cover to only select items completely Selection Methad © Tapto
covered by the selection shape. & Ovelap  © Cover ' Bation
e Use Overlap to select items partially covered ——

by the selection shape.

A different cursor is displayed to show which selection method is in use. The selection method
can be toggled by right clicking whilst drawing a selection shape. l.e. Holding down the Left
Mouse Button and clicking the Right Mouse Button. Try it!

TIP: After adding the components into the design (like 2N3904), you can select the component
and click on the right-hand mouse button to see a Link: On-line CADSTAR Datasheet. The link
is a hyperlink to an URL on the internet (or intranet), but can also be linked to something
different (i.e. PDF file or Word document). More links can be added to components in the
CADSTAR Parts Library Editor. Be aware that some links might be out of date as the
component has become obsolete.

Note: Parts can be allocated a special attribute value to control “Part Acceptance”.

Parts I Disfinitions |

Part Hame |Number Description |Versi0n |Defi nition |SPICE |Part Acceptance
9K-MR525-1% 232215613903 Metal film resistor MRS 25 39K 1% 2 JK-MREZE-1% Obsalete - Replace with 29K.-10805-2%
39K-10805-2% Chip resistor 0805 33K, 2% 2 39K-0805-1%

470E-MR525-1% 232215614701 Metal film resistor MRS 25 470E 1% 1 470-MRS525-1%

3E3-0805-2% Chip resistor 0805 3E3 2% 1 3E3-0805-1%

HLMP-1525 932201862682 LED GREEM 3MM HLMP-1585 2 HLMP-1585 Only 10,000 pieces in Stock!
EIE High-speed diode 1 1HS14

10uF-100-cE032 10uF 10 T antaal 1 10uF-100-cE032

SOLDEREYE-1kM 241301502201 | Soldereye 1.0 mm 2 SOLDEREYE-1kM

Hale-2 Orirn_Man-Plated Hale 2.0 MK Man-Flated 2 Hale-2 Orrn_Man-Plated Mat a Physical Part for Ordering
Hole-3.0mm_Mon-Plated Hole 3.0 kb Mon-Flated 1 Hole-3.0rmm_Mon-Plated

In the Parts Library image shown above, the column labeled “Part Acceptance” can hold a
unique text reference to communicate a Part’s Life cycle or inventory control measure to the
user. This can be defined by the Librarian. When a part containing a Part Acceptance value is
added to a Schematic design, the following warning dialog will be displayed.

warningt x|
'E Part 39K-MRS525-1%" ;- Obszolete - Replace with 39K-r0805-2%
.

Do pou wizh to continue?

e o |
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Accepting this Part will also store its value in the Design for later reflection in Parts List and

various other report outputs.

i Part Details

Mame  [39K-MAS251%

Mumber  [2322-156-13903

The Property will be reflected in the

Description: IMelaI film rezistor MRS26 39K 1%

A . Library Path: |E:'\F'rogram Files\LukentCADSTAR Express 12 00Librany\Parts.|
Item Properties dialog. e Rt e

Diesian Yersion: Part Pin
= e [~ Mames/Mumbers
Librany Wersion: Wisible

QK I Cancel gttribules...l More. .. | Help

%20kl Let’s Connect the Components together!

You can connect two components simply by placing the connecting terminals (pins) onto each

other or use the Add->Connection ¥= function. Then you can drag them apart to see the
connection. Pins that are connected will be automatically hidden.

CADSTAR allows you to make pin names or numbers visible/invisible so you can see which pin

is number 1 or 2 (useful for engineers to see).

Select Tools>Options>Display from the menu and enable/disable Override Part Pin

Names/Numbers Visibility.

CADSTAR provides an Interactive check for flagging over
lapping connections. Select Tools=>Options—>[Interaction]
tab.

When the Prevent Overlapping Connections selection is
enabled, the check will alert you with the following error when

you attempt to drag a connected terminal of any sort and
place it on top of a connection line of a different net name.

Eror x|

./"_.'\._
'-e-' Cannot complete operation - connections on different nets ovedap

i~ Interaction
[~ Paste Replaces Selection
¥ Copy £nd Paste Yariant Symbals
[~ Copy to Bitmap
[~ Copy ta Metafile
¥ Copy to Design Eile
[ Dynamically Optimize Connections

==

If you do not wish to run the interactive check until a more convenient time, simply disable the
selection. When you are ready to perform a batch check of the design, move the cursor over
the Overlapping Connection active report button to make the report panel open.
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m (LI -
Overlapping Connections
oSN _J
Design: = B ublic\Zuken\CADSTAR Express 13.8\3elf Teach\Example1.scm
Design Title:
A4-euro -Size Sheet
Date: Thursday, July 21, 2811
Time: h:hé PH
% Connection on net: %12 on sheet Sheet1 overlaps with connection on net: s
¢ Connection on net: %12 on sheet Sheetd overlaps with connection on net: £
¢ Connection on net: %12 on sheet Sheetd overlaps with connection on net: s
¢ Connection on net: %12 on sheet Sheetd overlaps with connection on net: s
End of report
A
Bus Report @ Dresign Rule Errors EIed:ricaIRuIesCheckl E Overlapping Connections Routingfompletion Unused Components
Ready ST Thou | Grid: 5.0
Click the Overlapping Connection report button as shown ot Tarcet
above and click the OK button on the report options B
dialog. > :
[ Erint Fepart
. . i Ch File: M
The resulting report contents are hypertext. By selecting a | | 23veRepotToFie _Change Fie Name. |
line item will make the error appear in the schematic :
window. 0K Cancel | Help | thinns...l

After you have added all the components, you can add three AGND symbols. To do so, simply

click the Add->Global Signal Icon = and choose (AGND). You can connect the AGND
terminal and the terminal of the diode (cathode) by placing the terminals onto each other as
shown below.

| N
=104

Library Path

i [}
[DGHD)
[GMD)
[VCC]
VEE]

1N914

— —
Signal Mame: J4GND —
Add Cancel Help
[
After three AGND symbols have been added, search on [s5| pER= . s
soldereye-1mm and add two pins. The purpose of these two

pins is for the wiring connection to the battery pads; hence a
pad is connected as 9V and the other AGND.
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Change the Symbol Details name to VCC9V and AGND respectively. To change the name,
select the pins % and click the Item Properties i icon.

Connect the symbols together in the same way as the hand-drawn schematic is connected
electrically. To connect, click the Add->Connection £ Icon.

vCcav

While connecting, you can also use ont i
the right-hand mouse button to | sew - "
Change Default Net Route Code, | <] @i/SZ”"“P"s“ iga \ [/ HLMP-1585
allowing you to select a different Net =
Route Code (I like Power & GND R Re Ré R2
thicker than signal tracks). 4708 - 3% M

c1

Il

3l

1l1‘.lucF2
Change the net name connected to . “I)LF' .
VCC9V to VCC by selecting the net

* and clicking the Item Properties zNasm@— —@mm

1 jcon.
a Sstu a SZ1N914

If Automatic Version Increment in Tools 2*Options 2[System] tab is enabled, with every future
change of a symbol, component and part, the version increments automatically as it is saved to the
library. You can easily check if a component in your Schematic or PCB design matches the current
Library version. To check, click on Actions 2 Reload Parts/Symbols (Components).

T Reload Parts/Symbols From Library ﬂ

; Reference ) . ) _ Altributes
Action Part Instance Hame Name Alternate Name| Design Version Number | Library Version Number ¥ Reload Values

Unallocated
HLMP-1585
4TOE-MRS525-1%
J9K-MRS525-1%
10uF-10V-EC

= [n3s0a

I” Reset Positions

Retain Local
¥ Feference Mame

I” Reload Pin Names

TR S_NFN S_NPN_1
TR2 S_NFN S_NPN_1

AR R IR RIS
STa=l=l=el=]s
STa=l=l=el=]s

1N914

I” Reload Pin Labels
Reload Part Pin

r Mame Yisibility
Always Fetain

¥ Alternate

Fieset ta Origin
¥ Syrbol Hame

V¥ Label/Mame
V¥ Part Name

Expand Al |
LContract &ll |
Select Out of Date |
Select Al |
Deselect All |

Fepart... Options... p ?.Q"HW _((/ | Cancel | Help |
, 7 7

_ 1»"ﬁeset to Origin
/| ¥ Label/Name
| ¥ Symbol Name
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u.

Tip:

You can also use this function to reset all selected parts, Label, Symbol and Part name attributes to
their original locations as defined in the library by selecting a Reset to Origin option.

When completed, save this schematic design o

In today's market it is important to deliver a B.O.M. (Bill of Materials or in CADSTAR called
Parts List) at an early stage.

To create a Parts List, simply click on Tools = Reports 2 Parts List. Or if you prefer to create
a Parts List in a different format (fully customizable) simply click on Tools 2Report Generator
—“>Manage Reports and open the file part_list.rgf, which you can find in the Reports directory
and just click [Run]. You can customize the Parts List output and list any attribute (wattage,
voltage, tolerance, manufacturer etc.) in any particular order you choose. For the more
advanced users among you who have experience in Visual Basic or C++, you can create, for
example, a user-defined B.O.M in Microsoft Office Excel, by using the OLE automation in
CADSTAR.

To print your schematic design, simply click on File=>Print Icon € and go through the Print and
Page Setup. Alternatively you can print your schematic design to a PDF file, you do not need to
install a PDF writer, CADSTAR has its own native PDF writer.

Enable Alternative text output in the print options, x|
making text searchable when printing to a file | [QueuFie
format SUCh as PDF LU gerghPublichZukenhCAD . \Examplel . pch Browsze... |
Farmat: |PCE Binary j Ab;utl
Categaries... Mptions... | Eormat Help |

Finally, transfer the schematic to PCB through

File->Transfer to PCB. Choose '2 layer 1.6mm.pcb’ | | Seuce shest Sourcsariart
H  Curent Sheet 1 Current Yariant
as PCB Technology. Click [OK] & whot Desi & Al
" Selected Sheets
Select Sheets... |

r~ Transfer Ta FCB
Template Folder:
C:AUzershPublictEuken\CADSTAR Express 1. ATemplates
PLCE technology:
|2 Layer 1.6mm.pch j

v iew Mew Design Settings

V¥ Report Unnumbered Teminals

¥ Report Dangling Connection:

¥ Bliow Single Mode Mamed Mets

™ Pesform Update of Feuse Blocks on Completion

= [ apping File
Browse... |
™| Usekap Create Map.. | Edit Hap... |

Ok I Cancell Help |
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Layers - 1Ol =]
embedding
above
routing bias 0
swap
Layers o—I0 " e ——
o—Jo i
Name Thickness (Thou) | Sub Type PE“;?;&' SL‘:fepr Physical Board Thickness = 63.0th ey |
Top Elec (0.7
Top Profiing Flat 0.0 |(Hone) 1 o sw || op Blec (0.73 Delete Layer |
Top Profiling Mon 0.0 |(Mone) 1 (Mo Swy i Mave Up |
Top Placement 0.0 |Placement 1 Bottom i
Top Azzembly 0.0 |Azzembly 1 Bottam [ Mave Dawn |
Top Glue Spot 0.0 |(Mone) 1 Bottom i
Top Paste 0.0 |Paste 1 Bottom || —lcolumn Di..
Top =ik 0.0 |Silkscreen 1 Bottom 1 —Show Lapers of Type——
Top Solder Resis 0.0 |Solder Resiz |1 Bottom ! ¥ Elechical
Mo tracks 0.0 |(Mone) 1 (Mo Sy i
v P !
Mo vias 0.0 |(Mone) 1 o Sw || I Powerplans
Top Elec 0.7 |[(Mone) 1 Bottom 1 Laminated (51 6 ¥ Man Electrical
LaminateT &1 6 |(Mone) Mo sw |l aminate1 (61.8) ¥ Construction
Bottom Elec 0.7 |(Fone) 2 Top Ele H )
Battom Solder Re 0.0 |Solder Resis |2 Top Sal |1 I¥ Documentation
Bottom zilk 0.0 |Silkscreen 2 Top =ilk ! =
Biottom Paste 0.0 |Paste 2 Top Paz || [ Physical Layers
Bottom Glue Spot 0.0 |(Mone) 2 Top Glu 1 inirunn 1
Bottom Azzembl 0.0 |Azzembly 2 Top Az i Mepfnmm IT
Bottom Placemen 0.0 |Placement 2 Top Pla i
Mechanical Dra (Mone) (Mo Sw |l Apply M azimum |
Letter Drill Dravvi [Mone) (Mo S i
Documentation (Mone) (Mo Sy 1 Biattom Elec: (0.7) — Layer Stack_ Wiew
thim_power_b (Mone) (Mo Sw |l ¥ Show Picture
Blind Via [Unavallatle -] St (el
) ) - ) Copper Colour
Buried “ia IUnava|IahIe j Copy | T Al Layer Pairs
Drill Calour
[V Fit to ‘window
ﬂ —I LI Construction Calour
Repart.. | Materialz... | ak I Cancel | Help... |
Vi
—

E:] Note: If you choose the PCB Technology 'l layer 1.6mm.pcb' during transfer to PCB, this default
technology file is prepared for single sided boards (whereas | prefer larger solder-pads, thicker
track-widths and more spacing). The advantage of the different technology files is that you still
can make use of ONE library as you will experience in Design D.

For an error free transfer from your schematic to PCB, no netlist is necessary!

y. If you didn't complete the schematic design as described above, just open Examplel.scm and
transfer the schematic to PCB through File->Transfer to PCB, choose '2 layer 1.6mm.pcb' as
PCB technology.

The first step showed you how a schematic design can be drawn for Design A. In fact, any schematic
capture can be drawn following the sequence shown. However, a more complicated design will require
more challenging steps. There are many tools within CADSTAR Design Editor that will help designers
like you to design a schematic. You can also add spacing classes, insert a component into a net
without any disconnection, and perform auto-connection of busses. Other tools like Align Symbol,
Design Re-use, Design Variant, Hierarchical Design, etc are also important and are user friendly for
professional design engineers to use. Go ahead and try them out!

You can now move on to PCB Design. You will notice that the CADSTAR Library, Schematic and PCB
design editor run on the same Graphical User Interface, guaranteeing a fast and problem free transfer.
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Step 2 - PCB Placement for Design A

a.

You are now in the PCB Layout area with all the 12 components and 2 pins stacked on top of
each other. Save the New PCB design with a file name of your choice into the ../Self teach/
folder.

You should make sure that the units are set to “Thou” (Thousandth of an Inch) by selecting

Settings 2Units or alternatively by double-clicking the units | Thou Grid: 5.0 = at the bottom of
the CADSTAR window.

[
First, you will have to draw a PCB outline; DXFIO.map does not
r~ Impaort File

include board outline

A board outline can either be drawn within

) ! . B
CADSTAR or imported via DXE format. C:AProgram File...\Boardouting. dsf Browse

Format: | D3<F j Aot
Select (File=Import>Format [DXF]). CEDIF

CaDSTAR ¥ [for DOS) PCE Einary FEormat Help
. . CADSTAR 7 [for OS] PCE Initial D ata
Select the DXF file Boardoutline.dxf.

~ Mapping O1CA0 'PCB' Metlist

pEER )

. . . PCE Archive
For the Mapping-file, you have to select LAPIO0Y PRE ditor 4P Files Bl
dxfio.map, which you can find in the User [ Lse| occnor < H Files EdiMap.. |
folder and just click OK.
If you have chosen to import the DXF " Create Hew Design % fierge into Curent Design
board outline, then skip to step g. x| Cancel | Help |

Note: the board outline that is imported using the DXF data is different from what is described
in step ‘d’. The intent is to demonstrate the support for DXF Line entity styles such as BLOCK,
INSERT, ELLIPSE, SPLINE and POLYLINEs.

CADSTAR also supports Importing and Exporting of IDF 2.0 and 3.0 from most mechanical
CAD systems.

Alternatively you can manually draw the board outline.

Locate the Shape quick-pick toolbar and change the default = L=y B e ) W ey =

to Board as shown to the right, | 4 EE oerau
v .
Next, click the “Add Rectangle” button Q% e and [+ i |copper |
begin drawing a rectangular outline (size 2000x1000 thou). | ..~ Eutﬂut pcb
. rea :

. . T R
Note: Watch the absolute and incremental coordinates at Copper
the bottom of the CADSTAR window when drawing the TF'E?#THE
board outline. =

Tip: From any point in the design you can reset the incremental coordinates by pressing the 'Z'
key, followed by the [Enter] key.
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e.

To modify any outline (board, figures, component outlines etc), simply click on the shape edge
and select one of the grab handles. You can also use the Shape Properties window. By
selecting the outline you can see and modify the absolute or relative coordinates.

=lolx]

¥ Examplela.pch {C:Program Files'Zuken'  CADSTAR Express 11.045elf Teach') - PCB Gold - Zuken CADSTAR Design Editor
File Edit Yew Add Actions Settings Lbraries Tools Window Help

MEEES 4B X« o § MM whiteBackground PCB -E@i@::@@{@{@

F OCTR  ABOND 2 L% %% R owws |

]

LG gt A B 00 =B o G copper

Relative | Closed

Type

-

¥ =

Start Point

3000.0

300000

Line To

s000.0

300000

Line To

S0o0.0

40000

Line To

3000.0

40000

Line To

30o0.0

30000

Cutout Start

on0

3as0.

Clackwise Arc

3000

32500

With Centre

Fo0.0

390000

l suliEag uado) l SBIJEJQHJ { ufizag ]uaun:)l

Clackwise Arc

3000

33500

With Centre

31000

39001

Cutout Start

4300.0

3as0.l

Clackwise Arc

4900.0

32500

With Centre

4300.0

390000

Clackwise Arc

4900.0

33500

With Centre

4900.0

39001

Cutout Start

Fo0.0

30500

Clackwise Arc

3000

31800

With Centre

onn

ool

Clackwise Arc

3000

30500

With Centre

31000

310000

Cutout Start

4300.0

30500

Clackwise Arc

4900.0

31800

With Centre

4300.0

00

Clackwise Arc

4900.0

/4

i Start Page r Examplel.scm - Sheetl r“ Examplel_DIV.pch

¥ Examplela.pch X] 3

30501 |

4

| » _

Ready

[ 56115 41470 I |[Thou |[Grid: 25.0 || | 2

You can also create screw holes or mounting holes if you like. To do this within the board;
locate the Shape quick-pick toolbar and change the default to Cutout, and click any of the

drawing tool icons )X . Click on the board outline and begin drawing a Cutout within the
shape. Place a Circle Cutout in each corner of the board outline as shown above.

If you didn't manage to draw the board outline or to import the board outline through DXF, just
open Examplela.pcb

Once the board outline has been imported or drawn manually you can set an interactive origin,
to reference all X and Y co-ordinates of all design items, and cursor positions, relative to the

new origin. Select Settings—>Interactive Origin % and place the origin at the lower left corner
of the board. When you enable Snap to Endpoint it will be even easier to place the Interactive

Origin. To do so select Settings »Snap = Endpoint |«

Note: If the Snap toolbar is not visible, go to Tools 2Customise 2Toolbars and enable Snap.
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Let’s Place some Components!

Let's start by placing the critical components inside the board outline. In this sample design, the pins
(for 9V and GND) and the LEDs should be placed first. You may consider these components as
Critical where as their location would be described by Mechanical Engineers. This is also possible in
CADSTAR using the BoardModeler Lite application. If you do not have BoardModeler Lite you can use
the Item Properties functions to enter placement criteria such as X, Y Coordinates, Rotation and
Board side. Let’'s Try it!

"Ei:] h. For this step, click the Item Properties i Icon, then select pin VCC9V by clicking on the
outline or just type in “VCC9V” followed by the [Enter] command (it will be highlighted
automatically), then change the X-position to 250,0 and Y-position to 875,0.

Repeat this action for:

Pin AGND, change the X-position to 450.0 and Y-position to 875.0
Component LED1, change the X-position to 250.0 and Y-position to 175.0 and rotate 90°
Component LED2, change the X-position to 1750.0 and Y-position to 175.0 and rotate 90°

Tip: Choose the “Fix” setting to lock the components in place to avoid having them accidentally
moved.

. ) e .
Eﬂ I For the next step, select the Embedded Place and Route Editor Ly tool bar icon or select
Tools>Embedded Place and Route in the menu bar.

Enter <Ctrl+A> to select all components.

Select the Placement-> Stack off-Board function or click the tool bar icon B . This will result
in all the components that are currently unfixed to be randomly placed around the perimeter of
the outline.

. 1. X (B3

'y
j- Select the Move tool baricon % and the Component mode focus icon.

Select the component “TR1” and move the cursor inside the board
outline. Click the Right Mouse Button and you will see a list of Cancel
assist commands as shown to the right. >

Clockwise

AntiClockwise

Swap

Align
Push
Toggle Errors Allowed

Toggle Dynamic Pushing
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Selecting Clockwise or Anti-Clockwise will rotate the component accordingly. You can do so
by pressing ‘C’ or ‘A’ on the keyboard to gain the same result.

Selecting Swap will mirror the component shape to the opposite placement side.
The Embedded Placement tool will aid in error free placement. However, there are times when

an error is needed temporarily. Such as, to place a component back outside of the board outline
temporarily. This can be achieved by toggling “Errors Allowed” in the “Routing Options”.

If the default action is to push other components, the opposite |*=“== x|
behavior can be chosen by toggling the Dynamic pushing function. 7 Bimamic pushing
¥ Springback
To set the default action, see Settings>Placement>Push-Aside Pushefort  [5 =]
. . . . . . oK I Cancel | Help
Practice using this to achieve some preliminary results.

After the placement of all the critical components and some preliminary placement is complete,
you can Exit the Embedded Place and Route Editor and place the remaining components by

selecting Actions 2Placement 2Automatic Placement = in the menu bar. You can Enable
all Auto Rotation angle in the Automatic Placement window before placing the components
(depending on your design rules). Try the different settings and experiment with the different
results.

) @ o2}
/

H
——

@) R ) : )

L

If you didn't manage to place the components, just open Examplelb.pcb

You can also move the components manually if you wish, and change to a smaller working Grid

Thou  Grid: 5.0 ' to suit your placement needs (just double-click on the grid button at the bottom
of the window).

Note: you can select any footprint in PCB by simply selecting the particular symbol in the
schematic. In CADSTAR, we call it Cross-Probing. To try it out, select Window 2New Vertical
Tab Group in the menu bar first. To continue with the next exercise, you should activate and
enlarge the PCB Design window.
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Create a Partial Powerplane

E;] g. Finally to create a partial power-plane, create a template by selecting the board outline,
choosing Actions ?Duplicate Shape W in the menu bar and change the type to Template

and the Layer to Bottom Elec.

Note: Copper pour will be generated automatically in the Embedded Place and Route or stand-
alone Place & Route Editor on solder side based on the template area. Copper shapes will be
created to fill in the empty space within the template outline connected, for example, to AGND.

o = After the template has been created, you should set
the properties for this template. To do this, select the

template and click on the Item Property # icon.

You can set the properties as follows:
Name Template: Bottom AGND
Relief Copper Code: 10

Layer: Bottom Elec

Signal Name: AGND

Clearance Width: 10

Thermal Relief: Enable On Pads (Angle45°)
Note: Automatic Pour is ENABLED!

[These are the important parameters you need to set]

]
Mame: IBottom AGHD [~ Fired
Line Width Code: ~ [(ine 1 o =
Fil Type: [(ciean o =
LCopper Code: |1D j EI
Relief Copper Code: |1D j EI
Layer. IBottom Elec j
Signal Mame: |G =]
Clearance Width: |1 on [~ Allgw In Mo Routing Areas

Box |zolated Fins

Additional |zolatior: IUU— :; ,;gtomatlcF'our
Sliver width: Joo I Target For Autorouting

Retain Poured Copper

Themal R elisf

Angle
Greater Than v 0OnPads: |45.D
I lsolated: [0 ™ OnVies  [450
I Disieint:  [100.0 Felief Type: |cms |
QK. I Cancel I Attributes.... | Help I

The steps that were mentioned in this chapter are again a typical sequence. There are other tools
such as Radial Placement, Gate and Pin Swap, Replicate Placement etc., to help designers like you to

achieve a correct placement of components.

After the completion of the placement you can now start to route the PCB. Select Tools 2 Embedded
Place and Route or click the Embedded Place and Route i icon in the menu bar, to go to the

embedded place and route environment.

If you didn't manage to create the template, just open Examplelc.pcb, before going to the routing

environment.
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Step 3 - PCB Routing for Design A

|’E:] You are likely to be at the Embedded Place and Router by now, but before starting any routing |
advise you to check the Routing Options. Setting the Routing Options is very important before
any routing!
a. Select Tools =2 Routing Options... in the menu bar or click the Routing Options icon.
Routing Setup g|
General | Trunking Options
Process Interaction
® Raoute (O Smacth [W] Ask before rebuilding Router results into layout
Options Angle Track
Bt
[JErrars Allowed ()30 Degress  (8) 45 Degrees (O Fee Style © Staight
() Curved
[¥] On Line DRC
Active 45 (@) Optimal
Passes |10 ~ [v] Active 45 Degree Fouting width () Necked
Effort |10 e Tidy Rectangle Size: 00 Thau O Typed Thou
ia Equispace
[v]vias Allowed ] Change Length With Equispace
[Jwias Under Single Layer Pads [JEquispace While Fefine Routing
Pusher Fouting Parameters
[¥]Enakile Pusher [v] Slide Along
[V] Springhack [ Automatic Pour
V| Allow S t Break: v Angled Aut ti
ow Segment Breaks ngled Autarauting
l [0]:4 ‘ l Cancel ] l Help ]

The "Routing Options" box contains several options for the routing process: Route Width,
Routing Parameters (for autoroute), Routing Angle, On-Line Design Rule Check, Push Aside,
Activ-45 Degree Routing etc. Make sure that at least On-line DRC, Angled Autorouting, Angle
45 Degrees, Activ-45 Degree Routing are Enabled. You can use these options to create the
result you want.

b. You can start with manual routing by clicking two icons on the toolbar, Item Focus 2. and
Manual Route = as shown. Try out the Activ-45 Degree Routing and Automatic Pour starting
on the Solderside (Bottom Elec), by selecting a net just once and moving the cursor to the other
end of the net — quite easy!

C. You can change the active routing layer from Top Elec TopElec  to Bottom Elec | Bottom Elec
(by clicking the Top Elec button at the bottom of the window and changing the current layer to
Bottom Elec).

d. While routing, you can insert a Via by using the right-hand mouse button and select Change
Layer.
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You can change the route width on the fly from Optimal to Necked or Change Width using the
right-hand mouse button and select Change Width (you can choose a width between Min and
Max, depending on your Route Assignments).

You can also use the automatic routing features (usually designers like you will leave this step
to the last, as manual or semi-automatic routing is usually necessary for the critical

nets/connections). The two icons used are Net Focus <L and Autoroute & and you can auto-
route either by net or just drag an area around the whole board outline.

Copper pour will be generated automatically on solder side (Bottom Elec), saving lots of time!
When you have enabled automatic pour!!!

Note: the copper poured into the template will have followed the properties you have set. The
copper will also have automatically avoided the cut-out of the board outline.

After completion, you can go back to the PCB Design Editor window by selecting File->Exit
Embedded Place and Route in the menu bar or by clicking the Exit Embedded Place and Route
td icon. Don't forget to rebuild the router results into the layout. You can now see a design
similar to the PCB shown below.

215 4 az""“ o

For a different view of the PCB use the View->Mix Colours
(transparency) mode. This will display multiple layers so that all
items are visible.

Note: This is best viewed using a Black Background.

If you required a mirrored view of the PCB design you may select View—->Mirrored View. This
view option allows work to be performed as if you are working on the bottom side of the PCB.

At this stage, you can save the file =

If you didn't manage to route the design, just open Exampleld.pcb to have a look.

This is probably the last stage of the PCB design. It requires some careful considerations as to how the
board can be routed, what are the critical nets and what nets have to be routed manually etc. For
advanced users, more routing features and high-speed routing are to be considered.
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Step 4 - Manufacturing data for Design A

At this stage, you can also create the manufacturing data (Gerber, N.C.Drill, Parts List, Placement
data, Drill Drawing, etc.) for the manufacturing of the PCB. If you want to output the coordinates in
millimeters you have to change the Units by selecting Settings = Units in the menu bar.

"Iﬂﬂ Let's start by creating a Drill drawing with an associated Drill table as shown below..

O& £ £ O
£ Ea ZEOE Drill Tahble
Size |[Length |Plate Thraugh |Letter [Caunt
C
ce £ 9.7 @.a YES A I
c £ @ @ 27 6 2.a YES a a8
o
15 aa YES C 16
C C B8 C C
© © OEO © © 35.4 a.a YES i} 4
D @ D 39.4 0.a YES E 2
O oD oc oc oD O
P
I

Drill holes marked with letters that correspond to a hole count in a table or legend.

Example 1d.pch (C:\Users\Publicl?]

a. Load the colour file called Drill Drawing. This is found in the raries  Tools Window Help
pull-down menu adjacent to the colour palette Icon. m (%) (DEFAULY s
[DEFALULT)

all :
Elack Background PCH
EBottom Elec [
Bottom paste mask
Bottom silk screen

Bottom solder mask

b. Select the Settings—>Drill Letters/Table function. Defaults

Dirill Drawing
nrill 1 atters and Drill Table x|

| Diil Draving Dl Table | Dril Letters |
= - Fandar DL etter Association

This can also be loaded by typing [col drill drawing <enter>]
at the command line

Autornatic Crill Letter Sssociation: X X
] 0.0 0.0 - v utomatic Diill Letter Associatiore SeIeCt AUtO m_atl_c Drl”
g ;gg gg = b et Dil e Letter Association
- s ozt Frequently Used Drill Az W' -
C o0 00 e option as shown.
i 280 oo
E 320 oo : ;
F 250 0.0 [~ Mirmared Drill Letters
G 47.0 oo
H £30 0o [ Dill Dptimization
| Fall oo
J 7.0 0o ™ Dutput Slatted Holes
k. ar.a oo
L 340 0.0 ™ Only Dutput Slatted Holes
b4 3.0 0.0
M 110.0 0.0 =
a 180 oo [~ Dutput Mot-Fitted Items
F 126.0 0.0
[#] 130.0 0.0 LI Laver Pairs
Code: I[Through Huole) j
Change Drill Dianmeter... | [ Inclde Equivalents

r~ Selections File
& |se Defaults | SpecifyFile
o File Selected

Open... Save... | Save az Defaults |

kK I Cancel | Help
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Select the Settings—>[Drill
Table] tab.

Change the Layout, Layer
to Letter Drill Drawing

Select the Show Dirill
Settings option. This will
show pertinent settings that
are useful for the
Fabrication of the PCB.

Click to [Add Drill Table]
button. This will make the
drill table appear on your
cursor.

Drill Letters and Nrill Tabla

Dril Drawirly Dl Table | chil Letters |

~Position————————— ~ Properties
Origin .
Fixed
Pozition % I [N S & B e
y s e [~ Mimared
9 e Orientation IU.U i’
rlapout————— T T T ommommommommo—=  Contral
Lavfs |LetterDriIIDrawing ﬂl
———————— —-—
Test Code  [Text Size S0/50/10 | El

Line Code [Border] ILine 5

Line Code (Grid] __|Line6 _ __ __

[ o |

Cancel Help

Move the table to the right of the PCB board outline and <click> to release it as shown below.

25 48mm ———

Drill Tahl=
Q GF CF BC m‘: Q Sizm (Lmngth |Platem Through (Lmttmr (Count
£ c B 4.7 a.a YES A 1
s BB 27 8 aa YES g a
IS aa YES [ 16
£ £ 35.4 e.a YES 0 4
. £ £ 33 + ea YES E 2
£ £ £ BA £ £ Unite=Thau. Dr il Ootimicatian =N,
un D A By Only Slattad Halas=N,
o B e c o0 Laver Paira-{Thrauall Kol
J';‘ 2 S4mm
f S5d.9@mm
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E:] h. You can continue and select File>Manufacturing Export-> Batch Process £ in the menu
bar.

i. In the Batch Process window you select [Open] and choose Manufacturing Output 2 Layer.ppf,
which you can find in the ../Self Teach/ directory, then click [START].

You can easily add more rows to create layers that you would like to post-process. In this
design, since it is a 2-layer board, the layers that are to be generated are;

Top Elec

Bottom Elec,

Top Solder Mask,
Bottom Solder Mask
Top Silkscreen

(all in Extended Gerber RS274-X format).

4= Batch Process - [C:\Users)Public\Zuken \CADSTAR Express 13.0\Self Teach\Manufacturing Output 2 Layer.ppf *] |
. ) Process | Colour/Report Dievice ) ) Hew |
Use Description Yariant Type File Type Device Selections Cutput
1 ¥ |Gerber Copper pattern Component [<MNO VA Artwork | Top Elec.col Photo Pl |rs27¥d-xusr  |Afwork.sel Gerber-Cu-Co Open... |
2 ¥ |Gerber Copper pattern Solderside [=MNO VA Arnwork  |Bottom Elec.co  |Photo Pl |rs274-xusr  |Arwork.sel Gerber-Cu-Sol
3 ¥ |Gerber Solderresist Componentsid [<MNO VA Anwork  |Topsolderma  |Photo Pl |rs274-xusr  |Arfwork.sel Gerber-Solderr - |
4 ¥ |Gerber Solderresist Solderside =MD WA Arnwork  |Bottom solder Photo Pl |rs274-xusr |Afworksel Gerber-Solderr =
5 ¥ |Gerber Silkscreen Componentside |<NO VA Artwork  |Top silk scree Photo Pl |rs274-xusr  |Artwork sel Gerber-Silkscr Saveds.. |
6 ¥ |POF Assembly Componentside =NO VA Anwork | Top Assembly.  |PDFFile  |<None= pdf.sel PDF-Assembly
7 [ |Partlisting =NO VA Report =Parts List= TextFile  |<Mone= =MNone= Parslistrep
a ¥ |Placementdata <NOVA  |Report |Placement2rg |TextFile |=Mone= “hNone= Placement.rep Add Fow I
9 [ |Drilldata (Plated Through Holes) =MNO WA N.C.Dri  |Defaults.col MCDrill excellon2.u Drill_Plated.se |Drill-Plated.drl
10 [+ |Drilldata (Mon-Plated Through Hole [<MO VA MN.C.Dri  |Defaults.col MCDrill excellon2.u Drill_MonPlate  |Drill-Mon-Plate Delate Rows |
11 [ |FOF Drill Drawaing =MNO VA Artwork  |Drill Drawing.c  |PDF File  |=None= pdf.sel Drill_drawing.
[¥ | Hide Dialog
Edit File... |
Output Directary: |E:\Users\F‘uinc\Zuken\D’-‘«DSTAH Exprezs 13.040utput!, Browse... | Extensions... |
Fiepart... | Check PCE Start LCloze I Help |
Ready. Y

Other additional manufacturing data that CADSTAR can generate which is necessary for
manufacturing are;

Parts Lists,
Placement Data
Drill Drawing
Extended Drill Data

All manufacturing data will be saved in the Output directory.

There are other tools such as Associated Dimensioning (Orthogonal, Angular, Radial etc.), Snap,
Component Rename etc., to help designers like you to create all the necessary manufacturing data.

\ M ZUKEN



http://www.zuken.com/cadstar
http://www.zuken.com/
http://www.zuken.com/movies/cadstar12/CADSTAR_12_Batch_processing_Manufacturing_data/CADSTAR_12_Batch_processing_Manufacturing_data.html

Step 5 — Saving your Design for future Reuse

Of course you will want to save your design, maybe even “reuse” it with other designs. CADSTAR
offers functionality for managing your reusable circuits. This makes it possible to load the designs into
a new design as a Reusable Block.

For instance; if you display both your Schematic and PCB Design in CADSTAR | will show you how.

a. Select the electrical contents of your schematic using a simple

. = . CADSTAR Express 13.0
framing method. P

, Colours

b. Select Actions>Reuse Blocks>Create Reuse Block. The ' :hra”’
default location for reusable blocks is in the Reuse Files folder. ' Oatcm:
, Outpu
c. Choose a valid meaningful name for the file. l.e. | PREditor Configurations
Flasher_V1.SCM and then select [OK]. _ Reports
B Reuse Files
d. Enter the same name for the Reuse Block name. | Selections
, Self Teach
e. Repeat the process for the PCB circuit data i.e. ; Templates
Flasher_V1.PCB | User
f. Select Actions>Reuse Blocks>Manage Reuse Blocks. Your new block name will be listed.
I - - -
Reuse Block Manager Copper will not be included in Reuse
Block.
Block Mame —Item L
|E All Reuse Blucksi File path IEH‘!,CADST.AR Express 13.0'\Reuse Files\Flashpe—iccm 1 | I
Settings Actions Do fixed items become unfixed wher
v Grouped
[ Fixed |
[~ Mirrored
Qrientation: I 0.0 :I
Rename... | K I Cancel | Help |

Note: Since the Reuse Block files are hamed, this functionality will allow you to manage them within
the \Reuse Files\ folder. If you decided to make changes to the blocks, update both the Flasher_V1
SCM and PCB files. Then for any designs that used the Flasher_V1 circuit, you can simply update
them by double clicking on them and selecting the Actions>Reuse Blocks>Update Reuse Block
function.

In the next project Design-B, you may insert the Flasher_V1.PCB block into the PCB design during the
Placement process. Simply select Actions>Reuse Blocks=>Insert Reuse Block and select
Flasher_V1

You should also add the Flasher_V1 schematic block to the second page of your Design-B Schematic
project so the Schematic and PCB will match each other.
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PEEE B

Congratulations on completing your first design with CADSTAR Express!

| hope you found this quite interesting?

Add the power of 3D to your design.

You can also checkout BoardModeler Lite, supporting import/export of STEPS AP203, AP214,
ACIS,STL and IDF formats, providing you an optimized solution for the placement and verification of a
PCB Design in its own 3D environment, including:

a. Replacing board shapes and modifying component placements which are smoothly back
annotated.

b. Creating detailed 3D models using the 3D parts creation wizard

C. Importing Mechanical Enclosures (or other PCB designs).

d. Measuring Distances and Checking Clearances.

e. Running Batch collision checks.

BoardModeler Lite is more than just a 3D viewer!!!

You can find more information at;
http://www.zuken.com/products/cadstar/physical/board-modeler-lite.aspx

Mechanical CAD CADSTAR

31:- B pe Tt bea o 2 izl Taue
LAH CUPIEASH NS BEN GG AaeHo A S .

RIS o e o S 13 et

Corsbord Catree Ton Ak (118 FrFlacemeri
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e Chapter 2 — Design B

If you want to continue practicing, go on to Design B.

478 é

! 2H3E53
il 232 128auF
4 | o & Ohm
o Speaker
L]

* {N4148 9 3

5, & Hé
L ZNZ985A

o I " 2383
ITnput
47UF
1.5K 22

Transistor Audio Amp (50 mW)

Information on Design B - Transistor Audio Amplifier

Here is a little audio amplifier, similar to what you might find in a small transistor radio. The input stage
is biased so that the supply voltage is divided equally across the two complimenting output transistors,
which are slightly biased in conduction by the diodes between the bases.

A 3.3 Ohm resistor is used in series with the emitters of the output transistors to stabilize the bias
current so it doesn't change much with temperature or with different transistors and diodes. As the bias
current increases, the voltage between the emitter and base decreases, thus reducing the conduction.

Input impedance is about 500 Ohm and voltage gain is about 5 with an 8 Ohm speaker attached. The
voltage swing on the speaker is about 2V without distorting and power output is in the 50mW range. A
higher supply voltage and the addition of heat sinks to the output transistors would provide more
power. The circuit draws about 30mA from a 9V supply.
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Step 1 - Schematic for Design B

In Design B, you will have to decide what to do based on the knowledge you have gained from your
work on Design A. | will guide you through it to give you some tips. The sequence is the same as

Design A.

a. Study the schematic.

b. Collect and note information on the components.

C. From the hand-drawn schematic, you should be able to locate the eighteen (18) components
needed. They are:
Qty. per Part
2 2N3053 NPN Transistor 1 470 Ohm Resistor (470E-MRS25-1%)
1 2N2905A PNP Transistor 1 1.5k Ohm Resistor (1K5-MRS25-1%)
2 1N4148 Diode 1 5.6k Ohm Resistor (5k6-MRS25-1%)
2 3.3 Ohm Resistor (3E3-MRS25-1%) 1 47uF/10V Elec. Cap (47uF-10V-EC)
1 22 Ohm Resistor (22E-MRS25-1%) - 1 1000uF/50V Elec. Cap (1000uF-50V-EC)
5 SOLDEREYE 1MM (for Input, Speaker and 9V supply)

d. Create a new schematic sheet (I like Form A4-euro) M'flgo

e. Pick out components from the Library Workspace window

f. Place the components on the schematic sheet

g. Connect the components &

h. Change any net information (remember, | like a different Net Route Code for Power & GND)

i Save the design &

j- Create the Parts List

K. Print the design £

Transfer the schematic design to PCB (choose '2 layer 1.6mm.pcb' as PCB technology)

If you didn't complete the schematic design as described above, just open Example2.scm and transfer
the schematic to PCB through File 2>Transfer to PCB, choose '2 layer 1.6mm.pcb' as PCB technology.
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Step 2 - PCB Placement for Design B

I assume that completing the schematic design was a breeze. You can now start to place and arrange
the components on the PCB after the transfer. Again, | will give you some important points to follow in
order to complete the PCB placement.

a.

J.

Check and/or change the Units & Grid (25 thou is preferred)

Change in the shape toolbar the Default Shape Type to |Board ke

Draw a board outline (size 2000x1500 thou). If you didn't manage to draw the board outline, just
open Example2a.pch 0 @ &

Using Item Properties manually place the critical components inside the board outline:

Place VCC9V at X-position 150.0 and Y-position to 150.0
Place INPUTGND at X-position 150.0 and Y-position to 1050.0
Place INPUT at X-position 150.0 and Y-position to 1350.0
Place SPK at X-position 1850.0 and Y-position to 1350.0
Place SPKGND at X-position 1850.0 and Y-position to 1050.0

Fix the position of VCC9V, INPUTGND, INPUT, SPK and SPKGND =1
Cross-probe if it is necessary
Select the “Embedded Place and Route” tool bar button.

T

Arrange components around the Board Outline using the Placement-> Stack Off-board e

* o
. : [EY|
Select the Move tool baricon % and the Component mode focus icon. N Pt Fpe § :

Manually place the other components. If you didn't manage to place the components, just open
Example2b.pcb

Exit the Embedded Place and Route.

Draw one or more templates ¥ (remember the Duplicate Shape function and do not forget to
allocate the signal name AGND to the template). If you didn't manage to create the template, just
open Example2c.pcb, before going to the routing environment.

Transfer the PCB to the Embedded Place and Route 3
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Step 3 - PCB Routing for Design B

You are now at the final stages of the PCB design. Again, simply follow the steps and you will complete
your design very soon.

a. Manually route any critical nets <l
b. Automatically route all other nets L &
c. Exit Embedded Place and Route L3

If you didn't manage to complete the design, just open Example2d.pcb to have a look.

ZUKEN
EXAMPLEZ

Design B after Placement & Routing

Step 4 - Manufacturing Data for Design B

You can select File> Manufacturing Export-> Batch Process 2 [Open] select Manufacturing
Output 2 Layer.ppf ) in the menu bar to create the manufacturing data.

WELL DONE! You have now completed the PCB design
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At this point you might want to check out the capabilities of BoardModeler Lite. It supports
import/export of STEPS AP203, AP214, ACIS STL and IDF formats; providing you an optimized
solution for the placement and verification of a PCB Design in its 3D environment. You can replace the
board outline, modify component placements, which are smoothly back annotated, import other PCB
designs and housings, then build it all together and run a complete collision check.

It's not just a viewer!

You can find more information at;

http://www.zuken.com/products/cadstar/physical/board-modeler-lite.aspx
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e Chapter 3 - Library

The CADSTAR Library Editor ensures that design integrity is maintained between the symbol, the
footprint and the part information, and also supports multiple libraries.

The library provided with CADSTAR Express contains only a few parts essential for the PCB designs
described in this '‘Do-It-Yourself Book' and some examples of the on-line CADSTAR Libraries. More
libraries are available through the Zuken Global support site. The ready-to-download-and-use parts
contain all the information you require including manufacturers' part numbers. They are updated and

expanded regularly with over 250,000 parts currently available.

If the part required is not already

available in these libraries, you can quickly and easily design your own parts using the supplied
wizards and the Graphical Library Editor. Access to the on-line CADSTAR Libraries is available as part

of the maintenance contract.

Server 3

Server 2

3D Symbels .

Parts Library

Jut —
Simlib YaVAV

Schematie

Server 1

4 | CADSTAR Component Database

[

PCB Documentatiomn
Qumhala Coamnanents Qumhals

F I I
: Concept :: Schemat :: Analyze :: Layout :: Verify :: Manufac :
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Step 1 - PCB Component / BGA Wizard

You shall start with going through the BGA Creation Wizard. The component to create is a 64 pad ball
BGA.

E]a.

Click D on the Toolbar (File->New [PCB Component]) and choose the BGA Wizard
in the box.

BGA Wizard

Fill in a {Component} Reference Name (for example: bga64). You
can also fill in an Alternate Name (for example: reflow) height —l

Change the units from Thousandths of an Inch to Millimeters. This is
handy when you have components to create that are documented in
MM or Thou.

i

code

You can fill in the component Height if you want to run a Design Rule
Check on the height, which can be checked against placement areas as defined in the Design
Editor, or you can run a collision check in BoardModeler Lite.

As this is a new component, the version will be 1. If Automatic Version Increment in Tools 2
Options [System] is enabled, with every future change of the component the version increments
automatically and you can easily check if the component in the design is the latest version as in the
library.

Select [NeXt >] BGA Creation Wizard g|
Dimensions
The Second Step iS to enter Enter component dimensions.
the component dimensions:
Jmersiens Dimension Value
Set B to: 15 mm B 51000
Set D to: 10 mm « B ) (]
Set E to: 1 mm L3 = o
Set Fto: 1 mm ' : _ ‘ L R 8
Set Nx to: 8 SPED+EOD = ’
$es Soeii
D W{ |FF++F++
CODTDDD
OO T-DODD
| DDD+ DD D

<Back || New> | [ cancal | [ Hep

Select: [Next >]

The third step is to enter a Pin One Marker detail (that will ensure the correct
mounting of the device). Select in this case: Mitre, the Pin One Marker Size can
be 1.0 mm and the Pin One Position should be set in the corner.
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d. The last step is to enter the
assignments to be used for pads Assignments

and outlines.

Enter assignments to be used for pads and outlines.

Pads: Choose for the Pads the
pre-defined pad Code bga64r.

Side: When you are creating
an SMD component seen from
Top View you must select the
Min side to place the SMD
pads on component side.

Origin: The component Origin
should be placed for SMD
components at centre.

For Silkscreen, Placement
and Assembly Outlines: The
Code specifies the thickness of
the line you are drawing. For
Layer you should select a
corresponding layer as shown.

Exit Directions pertain to how
the tools in the Embedded

Router and P.R.Editor will exit
traces from the BGA pads.

Pads
r Exit Directions:
Fin One Code: [ Use defautt
IbgaEdr j EI [~ Free Angle
Code: NW N ME
|
IhgaEdr j _IE r r
w E
[rientation: I: 0 = W Use default
:I |2
Side: % Min; ¢ Max " Through Hole Sw S SE
r~ Silkscreen Outlines —Origin
Code: |Silkscreen Outline =] El " &t pin one
La*,'er:ITop silke j ' at centrs
r Placement Outlines
Code: I Placement Outline j _IE
La‘ferilTDp Placement ﬂ
¥ Enclose Silkscreen and Assembly Outlines
 Assembly Outlines
Code: IAssernbh' Outline j El
La'_,"erZITop Assembly j
< Back I Finish I Cancel Help

At this stage, you can [Finish] the wizard and the bga64 will be created.

 Laipress_12 - Untithed - DAL (Reflow) - Component - 2uken CALS TAR Deskan Litor

-F ODOTE

CEFRE D BARa

AdLEED W

M ststage [ 8 unttiead -shees’ S Unbtiec - BGARS (Refiow)

99

Companent Name

You can still modify the PCB component manually if needed. When done, save the PCB Component.

Click on the toolbar Libraries 2 PCB Components — [Save Comp].
If the component already exists in the library you can decide to overwrite it if you wish.
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Step 2 - Schematic Symbol / Block Wizard

We shall start with going through the Schematic Block Creation Wizard twice. The symbol to create is a
StrataFlash® Embedded Memory device. This device is built up with 2 schematic symbols therefore we
will use the multiple gate functionality.

=H a Click [O on the Toolbar (File *>New [Schematic Symbol]) and choose the Block
Wizard in the box. You'll start first by creating the power device and then creating EBlock Wizard
the logic device in one go.

b. You can choose a different template-file. In addition you can also fill in the version number (1 as
this is a new symbol). [Units] can also be changed to suite your specification

Select [Next 5 e —

C. The second step is to enter the

symbol dimensions: —— T vave |

A min (Thou) 100.0
Set A to: 100 (Thou) Y Sﬁi}
Set B to: 100 (ThOU) l | | : : : | ¢ E (Thou) :g%gl
Set C to: 200 (Thou) Cap— L '
Set D to: 200 (Thou) T_ A
Set E to: 100 (Thou) T T
Set F to: 100 (Thou) — —

—h—

Select [NEXt >] [ <Back || New> | [ Cancal | [ Hep

d. The third step is to add Gates,
Number of Pins, define the Pin

Schematic Block Creation Wizard

locations and to fill in the Reference | e gue snerpn ocatons snaex
Name. In addition you can also fill in :
the Alternate Name . I;i:lmE Refereg;::ENamei Allern%ex:‘lamei ~ B
_gm RCA8F4400POVT00-P ‘ POWER_BLOCK
e =
Select Gates — [Add] one Gate. 15 oo 2
2 * Number of Pins
3 L]
Fill in the Reference Name for GATE - L2 59
A as RC48F4400P0OVTO00-P and 5 Top = —
Alternate Name POWER BLOCK : .
T * Pin Information
For GATE B you can fill in the T .
Reference Name RC48F4400P0VT00 GATE B :giﬁaii::gpowoo <alt name> S symool Tex
Set the Number of Pins to 59 and i . Gates
select [Update]. C : vy
16 L]
Select the Pin Sequence numbers 1 E . I
until 4 by using the CTRL/SHIFT key ¢ >
and then drag and drop the Pin
Sequence column to Bottom of GATE <gack || New> | [ cancel ] [ reip

A, as shown to the right
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Select Pin Sequence numbers 5 until 10 by using the CTRL/SHIFT key, then drag and drop the
Pin Sequence column to Top of GATE A as shown above.

Select the Pin Sequence numbers 11 until 43 by using the CTRL/SHIFT key, then drag and
drop the Pin Sequence column to left of GATE B as shown above.

Select Pin Sequence numbers 44 until 59 by using the CTRL/SHIFT key, then drag and drop
the Pin Sequence column to right of GATE B.

SeIeCt [NeXt >] _ h tic Block Creation Wizard

Pin Hame/Label Drigins
Setup pin name and label origing

The fourth step is to enter the Pin
Name/Number and Pin Label Origins.

The position of the Pin Name/Numbers Koo 727274 =]

and Pln Labels are related to the flnal Side Orientation Alignment Offset (Thou) Direction

pin pOSition. L&t 0.0 |Botom Left oo 2700
Biotiom 40,0 Botiom Left [ 1800
Right 0.0 | Bottom Right [ 0.0
Top 90.0 |Bottom Right oo oo

By default the Wizard will place Pin
Name/Number and Pin Label Origins - P Latel Oigs
intuitively, with Pin Names outside the R e

. . . ode: | Airied ot E
block, and Pin Labels inside. Cade: [l F176/4 =]
Side Orientation Alignment Offset (Thou) Direction

Ensure the settings are = the same as Lef 0.0 Certrs Let 250 500

Bottom 900 |Centre Left 250 on
the example_ Right 0.0 | Centre Right 25.0 270.0

Top 90.0 |Centre Right 250 1800
Select [Next >]
The next step is to enter assignments cgack [ Wets | camest | Hep |

to be used for terminals and outlines.

Schematic Block Creation Wizard

. Assignmen_ls .
Term | naIS . Set the Enter assignments to be used for terminals and outlines.
Terminal Codes to N
Terminal. Teminal | Terminal v| =
QOne Code
. . Code Terminal ~| B
Outlines: The Outline
Code specifies the Je
thickness of the line
drawing. You should o
Sele.Ct SymbOI Code Line 4 v =]
Outline.
Orﬁg_in: The symbol o
Orlgln ShOUld be f;"attermma\ﬂne ":"atcemre
placed at terminal
one. _
Multi-gate file
<Back | Finsh | [ cancel | |
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At this stage, you can [Finish] the wizard and the symbols will be created.

Note: Select [No] if you are asked to set  [RiELL

the multlple gate flle, thIS IS Only \?/ There are gates defined, however the multi-gate file is not set. Do you wish to setthe multi-gate file?
needed when reading an Aldec
FPGA pin list file (CSV). Yes | [ No | [ Hep |

You can still modify the Schematic Symbols manually if needed. When done, save each

Schematic Symbol. Click on the Toolbar or select Libraries=>Schematic Symbols [Save
Symbol.] If the symbol already exists in the library you can decide to overwrite it if you wish.

Now you can go through the Schematic Block Creation Wizard again and create
another device if you wish. Block Wizard

Step 3 - Parts Library Editor

Now that you have created the PCB component and the schematic symbols you can generate the Part
definition that will link the schematic symbols and PCB component together.

=iH a

Click 'r'ﬂ on the Toolbar or select Libraries>Library Editor. In the Library Editor, click Ii'FH
on the toolbar (File->Open), browse the Library directory and open “Parts.lib”.

Parts,LIB (C:Wsers\Public\Zuken\CADSTAR Express 13.0'Library\) - Parts Library - Zuken CADSTAR Library Editor Express - =X
File Edit VWiew Settings Libraries Tools Window Help
. .
NEEH&E $EB@R X« o im§ oerum - E&
= = 5 A = 2] AL TET =
= =S Al BB S alllTzsre e B
Parts | Definitions I
Part Name Number Description Version Definition SPICE Part Acceptance ﬂ
BOK-MRS25-1% 2322-155-13503 | Metal film resistor MRS25 38K 1% |2 39K-MR525-1% Obsolete - Replace with 39K-r0805-2%
39K-r0805-2% Chip resistor 0805 38K 2% 2 39K-r0805-1%
4T0E-MRS25-1% 2322-155-14701 | Metal film resistor MRS25 47T0E 1% |1 470-MRS25-1%
470E-r0305-2% Chip resistor 0805 470E 2% 1 470E-r0805-1%
10E-r0805-2% Chip resistor 0805 10E 2% 1 10E-r0805-1%
1KS-MRS525-1% 2322-155-11502 | Metal film resistor MRS25 1KS 1% |1 1KES-MR525-1%
1KS-ri805-2% Chip resistor 0805 1K5 2% 1 1K5-ri805-1%
Z2E-MRS25-1% 2322-158-12208 | Metal film resistor MR325 22E 1% 1 ZZE-MRSZ25-1%
Z2E-rl205-2% Chip resistor 0805 22E 2% 2 Z2E-r0205-1%
SKE-MRS25-1% 2322-155-15502 | Metal film resistor MRS25 5K6 1% 1 SKE-MRS525-1%
SKE-ri805-2% Chip resistor 0805 3K 2% 1 SKE-rig05-1%
3E3-MRS25-1% 2322-158-13308 | Metal film resistor MRS25 3E3 1% 1 3E3-MRS25-1%
3E3-r0805-2% Chip resistor 0805 3E3 2% 1 3E3-r0805-1%
HLMP-1585 832201852682 | LED GREEN 3MN HLMP-1585 2 HLMP-1585 COnby 10,000 pieces in Stock!
1ND14 High-speed diode 1 1ND14 |
M start Page. Parts.LIB b

b.

Click on the Toolbar icon += for Edit>Add New Row
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When creating Part definitions,you must fill in both the Part Name and Definition column fields
(as shown below.) In addition you can fill in the Description if you want to run a more detailed
Parts List of the used components in your design.

Part definitions represent the highest level of a library part. The definition can be referenced by
more than one part name. However, it is more likely that every Part definition will have only one
part name due to the complexity of attributes that are trying to be used, making each part name
require a unique definition.

i Parts.LIB (C:\Wsers\Public\Zuken\CADSTAR. Express 13.0'LibraryY) - Parts Library - Zuken CADSTAR Library Editor Express R 4
File Edit Wiew Settings Libraries Tools Window Help
D& $EBR@ X« o { 3@ o - B|E
= =8 2] = 2] AL T g
E=E A DS EFall LETFEarpp 5
Parts | Definitions I
Part Hame | Number Description Version| Definition | SPICE Part Acceptance |
SMBIM1ZCA Transzient Voltage Suppressor, Birdir|1 SMBJM1ZCA
CAP Z200UF 25V AXIAL 35mm Pitch, 16mm wide 1 CAP 2200UF 25V
10NF-20/230% SMD0S05 10NF 0805 SMD CAP (XTR) 1 10NF-20/30% SMDj
10K-1%-CRGO205 10K CRG0205 THICK FILM 1% 1 10K-1%-CRGO205
S5K1-1%-CRGO205 EK1 CRG0205 THICK FILM 1% 1 SK1-1%-CRGO205
TAL-22U08.3V ELECTROLYTIC CAPACITOR TAJB2 |1 TAL-Z2U8.3V
22K-1%-CRG0205 22K CRGO20S THICK FILM 1% 1 22K-1%-CRG0205
LP2G37 500 m& Low Dropout Regulator 1 LP2G37
TAJ-10.0U/8.3V ELECTROLYTIC CAPACITOR TAJB1 |1 TAJ-10.0UE.3V
100E-1%-CRG0205 100R CRGO205 THICK FILM 1% 1 100E-1%-CRG0S0
100NF-20420% SMDO205 100NF 0305 SMD CAP (X7R) 1 100NF-20480% SM
4K7-1%-CRGO20S 4K7 CRGO205 THICK FILM 1% 1 4K7-1%-CRGO20S
880E-1%-CRGO&05 S80R CRGOB05 THICK FILM 1% 1 8B0E-1%-CRGO&0
Example 1 An Example Part 1 Example This is an Exmple part - Do not use
-
4 M startPage. [ Partsis < b
210 Parts.

Select the new part name “Example”

iParts.LIB (C:\sers\Public\Zuken\CADSTAR Express 13.0\LibraryY) - Example -PartsLibr... = =

. i gm File Edit View Actions Settings Libraries Tools Window Help
and click on the toolbar icon or Ns HS % BREX| o imm® orun - B@|

select Edit-> Edit Part Definition (or = =t 0 B il EEE e b e S

use the right mouse button menu).

Componert |Sy1'nbo|5 I Pins I Gate + Pin Swapping | Aftributes I

From the Component tab, click the (i Aoply
[Select] button - and choose the PCB Reference: jooa6¢ —
Component (bga64) that you created Atemate: |refow

by using the BGA Wizard in the Select...

previous exercise.

i Max Eldctrical Pin: |E4 Name Stem: IU

Set the Name Stem to: U

bgab4 Ireflow)

COoM”

The Name Stem specifies the
alphabetic character(s) that will be
common to all component names
when this part is added to the design.

This is the prefix for the Reference
Designator that will be used when the
part is added to a Design.

4 i Start Page L Parts.I_I\B\ Parts.LIB - Example > I
Converting design C\Users\Public Zuken \CADSTAR Express 13.0\Templates\defaults.cmp ot
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Select the Symbols tab and click on the toolbar icon *= or select Edit>Add New Row.
Repeat this for one additional row to support Gates A and B

Now you can double click in the
Symbol Name field or use the right
mouse button menu [Select Symbol..]
and select, for Gate A, the symbol
RC48F4400P0OVTO0-P you created by
using the Schematic Block Creation
Wizard in the previous exercise.

Tip: Start typing the symbol name and
the searcher will take you quickly to
the symbol name

For Gate B select
RC48F4400P0OVTOO.

the Symbol

Select the Pins tab and click on the
Toolbar Actions—> Import Pin Labels

s

Change the Files of Type to CSV
(Comma delimited).

Tip: A pin list can be often down-
loaded from the component
manufacturer’s website or you can
extract it from the component
manufacturer datasheet in
spreadsheet software (for example MS
Excel).

Select the file name: pinlist.csv and
click [OK]. This can be found in the
..ISelf Teach/ folder.

If the Pin list has less pins then what in
the Pins tab you will get the Warning
shown below.

iParts.LIB (C:\sers\Public\ZukenCADSTAR. Express 13.0\Libraryy) - Example - PartsLibr... — = ¢

File Edit Wiew Actions Settings Libraries Tools Window Help
D EHES $B@ X |« o i @ orun - BE
E=E a5 EFal REEdrewr 5%

. — }
Companent ':SyTﬂ_de.l Ping I Gate + Pin Swapping I AtribLtes I
Gate| Symbol Name| Terminals

A |RCABF4400POV (10
B JRC42F4400P0W] 45

bgab4 (reflow]

came

4 M start Page | Parts.LIE, Parts.LIB - Example b
Converting design C\Users\Public\Zuken\CADSTAR Express 13.0\Templates\defaults.sym

iParts.LIE {C\sers\Public\Zuken\CADSTAR Express 13.0\LibraryY) - Example - Parts Library - Zuken CADSTAR Library Edito... — = 3
File Edit View Actions Settings Libraries Tools Window Help

DS & R@X <ol im8emn - FE
Bl %Y 2 anBEzuree Y

- —— =
Component | Symbols y Pirs_ |jGate + Fin Swapping | Attbutes |

Pin| Hame | Label| Signal| Terminal| Type | Load| Position -

5l

2 AB [V Part Pin Names/Numbers Visible
3 AB

4 PP

5 AT3

L3 VCC

7 A18

8 AZ2

9 A2

10 V3 =l

"~ [|select PIN file 21 x|

Loak jn: I I3 Self Teach

%‘ imdatjmlist.csv

4q B start Page L

Converting design Ci\Usel

warning x|

! 5 The impart file containg less than 64 pinz. Mat all pine will be labellad.

File name: Ipinhst ooy j Dpen I
Files of type: ICSV [Comma delimited) j Cancel |
¥ Change Directory
v
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The next step is to select pins 1 — 8 in the Name column and select Actions=>Name Pins
(BGA'’s have Pin-Names instead of Pin-Numbers!). (You can also select this from the Right

Mouse Button menu)

Enter for the First Pin Name the
value: Al and click [OK]. The

pin names should appear as

shown. =

Note: If you click in the Name
cell for pin 9, you will see ‘A9’

fill the cell. This is the
Increment continuing as
defined.

.Ccmpnnm I Symbole  Pins | Gate + Fin Swapping I Attributes |

Pin| Name| Label| Signal | Te x|
1 1 Al First Firi M &+ Increment

2 A bl ' Decrement

3 AB

4 VPP 0K I Cancel | Help

5 A3

6 VCC

T A8

] AZ2

9 AZ

10 V55 j

Select pins 9-16. Click the <RMB> and select Name Pins. Enter B1 and click [OK]

Repeat this action for the Pins:

17 — 24 starting with C1
25 — 32 starting with D1
33 — 40 starting with E1
41 — 48 starting with F1
49 — 56 starting with G1
57 — 64 starting with H1

Al
Az

When you used the Schematic Block Wizard for the creation of the first symbol
(RC48F4400P0OVTO0O0-P) a total of 10 terminals were placed on the bottom and top side of the
symbol and if you remember, they are always numbered from left to right. Usually the VSS is

placed at the bottom of the power symbol and the VCC at the top.

e
Terminal Numbers ()
D= = o = o >
ul o fres o = =
zEZEEZEZ|Z =|T |2 la
il vl o ol
n o~ O o & Lo ooo
e R R Map CcOoOOOoOQ
IELCLELIELELEL > =00 0
== >
= 0 M - Ly owownown
U N R | Ly owowoWwn
o oL O 2= D= =
sEiZIZl4 mlziziz
Numbered form Left to Right [ )

—-

L] 1 2 3 5 6 7 8

AT TN Y ."' -""‘.
__—J—k:""‘?‘ -.- o \.‘ '».-’
-’\‘J J'\d VPP A]J VCC Al AZ 2
.' \ '\f‘\f ‘\f \

N s L
S Aﬂ ("Fw AH A28 A9 RFU

N Y
1818181 1 1010
A3 AT AID A1Z AIS WPE AZ0 A21
;"-f\_f\_n‘\,-“-,"‘-f\_f\
D A AR A A A A )
M A5 ATl RSTEVOCOWVOOO A1E AIT
R Y PN ."\.‘ ."“\.. -f!.
SOLIGIOLO LSOOI
D38 DA1 DB D43 DA4 CIK DAIS RFU
W W W '\-'"‘\ "'.f‘\f'\
FAAA A JA A A
RFU DOO D10 DA DO2 ADVE WAIT OEs

3010101 10101010

AZ3 RFU DQ2 VCCOQ DOS DO6 DOQ14 WEE
oX 1 1 181 1010
i/ L Ll
RFU V8§ VCC VS5 D13 VSS DQ7T A4

Easy BGA

64-Ball Easy BGA Ballout (64/128/256/512-Mbit)
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The next step is to map the symbol
terminals with the accompanying
Pin Numbers/Names (and Labels).

iParts.LIB (C:\Users\Public\Zuken\CADSTAR Express 13.0\Library\) - Example - Parts Library -Zuken ... — = X
File Edit View Actions Settings Libraries Tools Window Help
DEE $BEe X o o i@ orun e L=

s all B Eal EELZrep B

.Component I Symbals  Fins |Gate + Pin Swapping I Attributes I

Pin| Hame | Label| Signal| Terminal| Type | Load | Position| +

¥ Part Pin Names/Numbers Visible

In other words you will start with the
pin/ball B2 (Label VSS) assigning it 1[ar At
to Terminal A.1 = {Gate A. symbol R
terminal 1} 4las VPP

5 |A Al

6 [AB VCC
Select the Terminal field belonging Lo 2
to Pin Name B2 (Label VSS), and s [az
select Edit> Assign Terminals i

dolalalalalalalalala

T

7 or use the right mouse button
menu and select Assign
Terminals.

Now you can finish the mapping for
the power symbol by selecting, in | [

Gate B - AC45F4484

bgab4 (reflowl

COrP

NEE |

the correct order, the next power |« . M startPpage

pII’IS Ready...

Assign Terminals x| A

Look for pin/ball H2 (Label VSS) and just click in the
terminal field. You will notice that automatically A.2
will be assigned.

Tip:  If you make a mistake during the allocation
of the terminals, don’t worry - just press the
[Escape] key and restart in the correct box
with the new start sequence!

Now assign the following:

- pin/ball H4 (Label VSS) assign to A.3

- pin/ball H6 (Label VSS) assign to A.4

- pin/ball A4 (Label VPP) assign to A.5

- pin/ball A6 (Label VCC) assign to A.6

- pin/ball H3 (Label VCC) assign to A.7

- pin/ball D5 (Label VCCQ) assign to A.8
- pin/ball D6 (Label VCCQ) assign to A.9
- pin/ball G4 (Label VCCQ) assign to A.10

Note: As you Assign the terminals the Pin labels
will appear on the Gate A symbol in the preview
pane

Enter the firzt gate and terminal
zpecifier using the format 4.3

o]

Cancel | Help |

4 M startpage [E Parts.LIVy Parts.LIB - Exa

Cnmponentl Symbals  Fins Gate + Pin Swappingl Aftribt

Pin | Hame | Label | Signal Terminal| T}lpel Luadl 14
55 [G7 Da14
56 (G8 "wE'
57 [H1
58 (H2 Y55 b2
59 (H3 YCC b7
60 (H4 Y55 b3
61 [H5 Doz
62 [HE Y55 b4 —
{qu rﬁ" Ny LI_
Gate A - AI
- - =~
( K
BB
Eogdooao B
=000
== =

W55
Y35
W55
VY33

1
\
[P

T T ol
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wW="ooc3cZ2" 9353730

Continue assigning the terminals for Gate B (RC48F4400P0VTO00). Just click in the terminal
field of pin/ball A1 (Label Al) and you will notice that automatically B.1 ={Gate B .Symbol
Terminal 1} will be assigned.

When you used the Schematic Block Wizard for the creation of the second symbol
(RC48F4400P0VTO00), a total of 49 terminals were placed at the left and right side of the symbol
and if you remember, they are always numbered from top to bottom.

You can assign following pins/balls for Gate B:

- pin/ball A1 (Label Al) assign to B.1 - pin/ball B4 (Label ‘CE’) assign to B.26
- pin/ball B1 (Label A2) assign to B.2 - pin/ball C6 (Label ‘WP’) assign to B.27
- pin/ball C1 (Label A3) assign to B.3 - pin/ball D4 (Label ‘RST’) assign to B.28
- pin/ball D1 (Label A4) assign to B.4 - pin/ball E6 (Label CLK) assign to B.29
- pin/ball D2 (Label A5) assign to B.5 - pin/ball F6 (Label ‘ADV’) assign to B.30
- pin/ball A2 (Label A6) assign to B.6 - pin/ball F7 (Label WAIT) assign to B.31
- pin/ball C2 (Label A7) assign to B.7 - pin/ball F8 (Label ‘OE’) assign to B.32
- pin/ball A3 (Label A8) assign to B.8 - pin/ball G8 (Label ‘WE’) assign to B.33
- pin/ball B3 (Label A9) assign to B.9 - pin/ball F2 (Label DQO) assign to B.34
- pin/ball C3 (Label A10) assign to B.10 - pin/ball E2 (Label DQ1) assign to B.35
- pin/ball D3 (Label A11) assign to B.11 - pin/ball G3 (Label DQZ2) assign to B.36
- pin/ball C4 (Label A12) assign to B.12 - pin/ball E4 (Label DQ3) assign to B.37
- pin/ball A5 (Label A13) assign to B.13 - pin/ball E5 (Label DQ4) assign to B.38
- pin/ball B5 (Label A14) assign to B.14 - pin/ball G5 (Label DQ5) assign to B.39
- pin/ball C5 (Label A15) assign to B.15 - pin/ball G6 (Label DQ®6) assign to B.40
- pin/ball D7 (Label A16) assign to B.16 - pin/ball H7 (Label DQ7) assign to B.41
- pin/ball D8 (Label A17) assign to B.17 - pin/ball E1 (Label DQ8) assign to B.42
- pin/ball A7 (Label A18) assign to B.18 - pin/ball E3 (Label DQ9) assign to B.43
- pin/ball B7 (Label A19) assign to B.19 - pin/ball F3 (Label DQ10) assign to B.44
- pin/ball C7 (Label A20) assign to B.20 - pin/ball F4 (Label DQ11) assign to B.45
- pin/ball C8 (Label A21) assign to B.21 - pin/ball F5 (Label DQ13) assign to B.46
- pin/ball A8 (Label A22) assign to B.22 - pin/ball H5 (Label DQ13) assign to B.47
- pin/ball G1 (Label A23) assign to B.23 - pin/ball G7 (Label DQ14) assign to B.48
- pin/ball H8 (Label A24) assign to B.24 - pin/ball E7 (Label DQ15) assign to B.49

- pin/ball B6 (Label A25) assign to B.25

64-Ball Easy BGA Ballout (64/128/256/512-Mbit)

~—
~
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Select the Gate + Pin Swapping
tab and click on the External
Swapping Group containing 49
pins then expand the Element
contained within.

Select the pins with the labels {Al}
— {A25} as shown and click on the

toolbar icon **  or select Right
Mouse Button menu 2>
Equivalent Pins

Repeat the action for the pins with
the labels DQO — DQ15. If you do
so it will help you to optimize the
routing pattern in the Design Editor

Componentl S_l,lmbolsl Pinsd  Gate + Pin Swapping lAttributesI

. E-[> Element: 10 pins RCFISFIHMPIFTON-PTPOWER BLOCK)-A
E[{}P External Swapping Group  RC45F4400P0YTO0-B
=)-[=> Element: 48 pins RC48F4400P0YTO0-B

Equivalent Pins

+ Terminal
Create Swap Element
Create Swap Group

Exbernal Swap Group

Terminal B.6

Terminal B.8
} Terminal 6.9

Urgraup
Remaove All Swapping
Set Default Swapping

[Make Gates [dentical

Import Multigate data

6} Terminal B.16
Terminal B, 17
+ Terminal B.18

Terminal B.19

----- i 0+ Terminal B.20

and/or P.R.Editor XR.

4} Terminal B.

m. Select the Attributes tab and click
on the text field Value. Add the
value RC48F4400P0OVTOO.

A5 Terminal B.25
" {'CE'} Terminal B.26

Ul T il o

You can fill in more attributes if you like. Attribute values can be set as Read Only so you can't
change their value in the Design Editor.

Tip: You can create user-defined attributes by clicking on the Settings—=> Attribute Names.

4 M start Page r Parts.l.IV Parts.LIB - Example x]
~==mn

Componentl Symbolsl Pins I [Gats + Fin Swapping Attributes ||
Attribute T:axl_ - Read Only |Type
Yalue R C48F4400P0WT OO EH Symbol and Component
Wattage Mo Symbal and Component
Tolerance Mo Symbol and Component
Yoltage Mo Symbal and Companent
Height/Inches Mo Part Definition
Availability Mo Symbol and Component
Alternative Part Mo Symbal and Component
Price Mo Symbol and Component
M anufacturer Mo Symbal and Component
Manufacturers Part Number Mo Symbol and Component
link Manufacturer Mo Part Definition
link URL to manufacturers PDF datasheet Mo Part Definition
link On-line CADSTAR Datasheet Mo Part Definition
Designed Mo Symbal and Component
Designer Mo Symbol and Component
Sign OFff D ate Ma Syrbal and Component
Signed OFF Mo Symbaol and Component
Automatic insertion Mo Component
Package bgak4 Yes Part D efinition
Technology Mo Part Definition

If you finished adding a part click on the Toolbar File=> Save and Close the file.

If you didn’t manage to add the part without errors or warnings you can browse the Library folder
.\..\Zuken\CADSTAR Express 13.0\Library and delete the Parts.lib. Then rename the file Parts.bak
to Parts.lib and repeat the last action in the Library Editor to click on the Toolbar Libraries> Parts
and select [Parts Index]. You should have no errors or warnings.
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Congratulations on creating your first complex part in CADSTAR!

Why not try and add it to a sample schematic?
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CADSTAR FPGA

If you want to skip most steps as described above you can also use a CSV (Aldec FPGA Data) file.

To learn more you can check out CADSTAR FPGA, supporting Actel, Altera, Lattice, Quicklogic and
Xilinx flows from one universal project manager that controls all the design files for simulation,
synthesis, place and route and pin assignment to the PCB.

Pin synchronization is often far from optimal for PCB routing; this new integrated solution supports
the 1/0O synchronization between the FPGA device and the PCB board. CADSTAR FPGA
supports forward- and back-annotate pin assignment changes in order to optimize PCB routing.

Note: In the movies we will use a bga363 package, but for the following exercises you need to use the
bga64 package. The principal is the same!

a. You can run the Schematic Symbol Block Wizard again and read this time the pin list of the
StrataFlash® Embedded Memory device as exported by Active-HDL from Aldec. Choose the
file format CSV (Aldec FPGA Data) and select the file ‘Aldec_pinlist.csv'. This time export as
well a Multi-gate file using the Schematic Symbol Block Wizard that will help you to create the
CADSTAR FPGA Part almost automatically.

b. Create a CADSTAR FPGA Part using the Multi-gate data file (CSV) as created by the
Schematic Symbol Block Wizard. The package does already exist in the PCB Component
Library — bga64 (reflow).

C. Add the FPGA device into your schematics design, transfer to PCB, place the components,
optimize your PCB routing by swapping pins on the fly in the Place & Route Editor and back
annotate to your schematics and the FPGA device.

A new collaborative product combining Aldec’s; Active-HDL Lite and Zuken’s CADSTAR in one
universal project manager.

You can find more information at:

http://www.zuken.com/products/cadstar/system/fpga.aspx

If you require any support during evaluation, please contact your local CADSTAR distributor.

http://www.zuken.com/products/cadstar/where-to-buy.aspx
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e Chapter 4 — Design C (Standalone Place & Route Editor)

Design C has been created for the more advanced users, allowing you to make use of the Standalone
Place & Route Editor XR2000. Power Users of CADSTAR tend to prefer the more powerful features
such as those available within the Standalone P.R.Editor XR2000, which provides placement and
routing functionality and much more. By the way, all exercises completed for Design A and Design B in
the Embedded Place & Route solution, can as well be designed in the Standalone Place & Route
Editor XR2000!

Also in this design we will learn how to create an Intelligent Bus and the use of Signal Reference Links.

Step 1 - Schematic for Design C

To keep it simple | have already draw most of the schematics of Design C for you. Just open
Example3a.scm.

CADSTAR is capable of creating intelligent busses; you can restrict the signals connecting to a bus
according to the signal names. The property sheet for a bus contains a signal tab where connections to
a bus can be defined. If you set a bus to be none restrictive you can connect any net.

Signal reference links are used to view and ‘jump’ to the other signal references of the same net
throughout the (hierarchical) design.

a. We shall start to create an intelligent address (ADO-7) bus on sheet 1 between U1, U2 and U3,

by selecting Add>Bus !

Select the start point for this bus and draw the bus. To insert a corner click left mouse button, to
finish the bus double click the left mouse button.

b. To add the bus name and signal names to the bus, select the bus % and click the Item
Properties i icon, fill in the bus name ADO-7,

Item Properties - Bus §|
General Signals
Bus Transter Bus to PCB
Restrictive [CIFixed
(@) Don't transfer
Line Code: | Ling 15 ~| EH
Segment(s) Length: 14500
Bus M
us Mame % v
ADO-T Position: 223175 74675
Orientation: 0.0 =
[CJUse Alignment
Alignment Justification
(@) Left
() Centre
) Right
O~rig [ Fixed
Text Code:
Text Size 60/50/8 ~| E

oK | cancel | [ Heb
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Select the Signals TAB, click on Add and fill in AD[0-7] then press OK.

You can now connect connections to the bus. Select % U3-B select the Move ¥/ icon and
move U3-B towards the bus until the terminals are on top of the bus, drop U3-B by pressing the
left mouse button, the next window pops up

Auto Connect to Bus

Set this window as follows:
Start Signhal Name: ADO
Start Pin Position: 9

End Pin Position: 2 Start Signal Name:
Press OK Start Fin Posgition:

Connecting between Symbol ''U3-B' and Bus "'

End Fin Position:

Move U3-B back to its original position

Repeat this for U1-B and U2-B

To connect single connections to the bus

select the Add>Connection ¥ Icon, start at the pin to be connected, than drag the wire to
the bus and single select to finish. The system will ask which signal name to add.

Signal reference links are used to view and/or ‘jump’ to another associated signal reference
elsewhere in the design. The visibilty and format of the link is configured via the

Settings->Defaults B dialog under the links tab.

pefaus x|

Generall Shapel Text I Connectinnl Fin I Bus Link |

Link Defaults

v iLlze Signal Reference Links

~ Properties
A t Justification—
Code: |driel 39/39/4 | gtz Lstiication
B I I e Left
Offzet: |2D.D cocor @ Bl
Angle: ID-U [~ Use Alignment & CcrC " Right
— Formatting
Style———— [ Suppress Same Sheet Previzw
" Zone ¥ Usze Sheet Mumber Far a Signal Reterence
- heet 'Top Sheet"
{" Sheet i - r an
. S-heet Zone Separator: I " A1 201208
- == Link Separator: I u Line
Zone. Sheet bl agirnunn Line Length: |1 on

Cancel | Help
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To specify the location of the link, zones
can be used. Zones split the sheets into

horizontal and/or

vertical

segments.

Zones configuration is controlled via the
Settings—>Zones dialog T,

Click the button [Get Coordinates from

Sheet]

Set the remaining window as follows:

Make sure units are set to mm

Horizontal:
Number of zones: 6
Start character: 1

Vertical:
Number of zones: 4
Start character: A

Select [Apply to all Sheets]

In the Display section, check the options
for Left, Right, Top and Bottom

Sheet Zones

Horizonta!

FLASH Start Coordinate:
End Coordinate:
Number of Zones: l:l
Start Character:
Size of Zone: 47.833
Vertical
Start Coordinate:
End Coordinate:
Number of Zones:
Start Character:
Size of Zone: 50.000

’ Apply to All Sheets... l ’ Get Coordinates from Sheet ]

Display Reference

Text Code: |Text Size 75/753/12 A | @ Horizontal-Vertical
Left Right V] Top Bottom () vertical-Horizontal
[ oK l ’ Cancel l i Help ]

Set the Reference setting to Horizontal-vertical and select [OK]

Now check the signal reference VCC in the lower left corner of the sheet it should look like this

you didn't manage to transfer the schematics design, just
open Example3a.pcb before going to Step 2.

Assignments...

1:4B-1:5B-1:6B-2:2C & Previous View SHIFT+F8
View Al ALT+F8
{ Item Properties...
¥ Cut CTRL+X
Copy CTRL+C
_ _ % Delete DELETE
You are now able to jump to the several VCC reference links 4
in this design by double clicking on for example 1:6B or by g Fi
selecting the Signal Reference % then pressing the right 3¢ Unfix _
mouse button and selecting one of the reference links. = L1 View Selection
Deselect Al
£+ Move F2
If you don't see the Signal Reference Links, just open | Edit Svmbol
Example3.scm to have a look. o i
& Edit Part
=== ~
| 1:4B |
I 1:58 !
| |
: . 1:68
Transfer the schematic to PCB through File->Transfer to : I :
PCB, choose ‘Eurocard-160x100.pcb’ as PCB technology. If | « 2" - _ _ _ _ Y,
£ Attribute...
=
@

Colours...
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Step 2 — Placement for Design C

a. Before transferring to Standalone Place & Route Editor XR2000, create a rough manual
placement here in the Design Editor. Place all IC’s as shown below. SMD components can be
I’E:] easily placed on both layers, select capacitor C1 (you have many options to do so), move C1 to
the preferred place, click the right mouse button and select ‘Mirror’ from the pull down menu.

Place all capacitors at the solder side of the board.

_[w @

;=4

-

- n

| i |

=

-

-

-.

- |

- |

el

-

-

- i

- g

RRRRRRRRNNE§ A

TP2
L)

Note: The color of components when swapped to the other side of the board, do change! If you
didn't manage to place the components, just open Example3b.pcb before moving on.

Tip: to see highlighted the nets that connect to an component. press “T” on the keyboard to
toggle the associated nets to a Highlighted color.

x|
— Twpe of Swap When b Stop
v QateSwaﬁ ¢ Run to Completion
¥ Fin Swap ™ Summary &fter Each Pass
b. Some connections between Ul and U2 are
crossing! To solve this, select Actions=>Gate and Choose Nets ta Minimise...
Eﬂ Pin Swap->Automatic Gate and Pin Swap and | | WhattoSwap

[~ Swap Fixed It
select [Start] 2008 wap Fixed Items

" Selected Components

Note: You can also swap pins on the fly in the = Wiithin Area : | (Board Outine) |
Standalone Place & Route Editor XR2000. Try it!

Start | Cancel Help |
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Using CADSTAR you can decide to use schematics as master or the PCB design as master.
CADSTAR supports full back annotation. No matter what your choice will be, do not forget to
run a Back Annotation when you have changed something in your PCB design, like pin and
gate swap, renamed components, added, modified or deleted components, connections or
attributes. If you didn't manage to do Gate and Pin Swap, just open Example3c.pcb before
going on.

Back Annotation x|

— Back Annotation Source

Open the schematics design Example3.scm C:A\UsersyPubli \Example3. poh Eruwse...l
. . g

and select File=»Back Annotation  m .

¥ | Eerform jnitial Back Srnotation with detected RIME file

—Add new symbolz on zhest

In the Back Annotation window select the PCB Shest] Gelect.. |
design Example3.pcb as source.

— Comparizon Options

If you have added new components in the PCB Exclusions... | Advanced Configuration... |
design that do not exist in the Schematics you
can select the sheet on which you want to add
these components (in this case just select
Sheetl).

v Perform Library Feload on completion
¥ Fetain Local Reference Mame
¥ Eetain connection paths [add danglers] on symbal deletion
[~ #lways add Single Mode Connections
[ Update Pin Labels
[ Transfer Reuse Blocks

The exclusion file can contain components that
do not exist in the schematics, like mechanical
holes or other components that you don’'t want

to appear in the schematics. Just select [T Ferfomm U pdate of Fewse Blocks on completion
Example3.Cig. ~ Remove [kems after successful completion

v Urused symbal gates/connector pins
Now select [OK] to run the back annotation. W Unused global signals/signal references

v Disconnected blocks

- Source PEE Ophions
™| Update Yariant Hierarzhy

" | Feplace Het Foute Codes

[{et Boute Code Azzignments
™ Replace Minax Festictions
" Replace Optimal/Hecked Widths

(1] I Cancel | Help |

X

RIF Export Options
Open Example3c.pcb and go to the Standalone

Place & Route Editor XR by selecting
Tools>PREditor XR El

[[JUse Routing Grid as Systerm Grid

Write Part Information
When transferring to the P.R.Editor a RIF Export
Option window will be showed automatically.

Be sure to enable Always Transfer Colours. Showthis dislog on transfer to PREditar R (HS) as well
as through File Expor{Options

Select [OK]

[ QK l I Cancel ] I Help ]
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Step 3 - PCB Routing for Design C

Welcome to the Standalone Place & Route Editor XR Environment!

Before starting any
routing or further

Ei:]a.

placement | suggest —Optons - Track
you check the e _ @ Straight
; . lﬁ I™ angled Autorouting e
ConﬂgureeRoutlng ™ Allow Pin Swaps " Curved
Setup dialogs ez Actv-45  Necked
(CTR L_T) . Passes |10 A [~ Enable Activ-45 width: " Optimal
Effort 10 hd Tidy Rectangle Size: |0.000 " Typed: |0.50800
—Via Fixed Items
¥ vias Allowed ™ Respect Fixed Fan-outs
Settl ng the routing Vias Under Single Layer Pads: IOff LI
Optlons |S Very I~ Enable Snap 25 Legal Distance: IE-.E-E-E-
im portant before any e e [Relu E] I Respect Fixed Escape Routing
routing! Ensure the Post-Tool Tos — % Save Best.

settings are equal to
the example. {If you
don't like copper to be
poured automatically
disable Auto Pour}

If you don't like routes
to be pushed by other
objects you can
disable the Pusher

[E Routing Setup

el

Manual [ Autorouting | Pusher I Trunking | Composition I Fan-out | Testpoints I Radial | Spiral Vias I Autorouting Costs | Grldsl

™ Auto Pour

™ Auto Teardrop

—Freehand

™ Enable Freehand

[~ change Length With Equispace

[~ Equispace Whilst Refine Routing

I™ Frechand Tidy

Priority according to:

[¥] Completion

[ Number of Fails

[ Wumber of Physical Errors
[ Humber of Vias

[ Number of Segments

st

J—

™ Use the best pass as the final autorouting result

Standard |

Description: I v Always Generate Auto |
Open... Save As... oK I Cancel | Help |
fﬁkﬂuting Setup |

Manual [ Autorouting

¥ Enable Pusher
¥ springback

Pusher | Trunking | Composition | Fan-out I Testpoints I Radial | Spiral Vias | Autorouting Costs I Grids'

[V Allow Segment Breaks

— Previ

Description: |

Open...

Save As... |

¥ Always Generate Auto
oK I

Cancel | Help |
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I’E:] P.R.Editor cannot not only be used for routing your design, but =11 x|

also for changing your placement without the need to go back ¥ Allow Component Move
to the Design Editor. Before starting any placement | advise I™ Minimum Force Indicator
that you check the Interactive Move and Push Aside options. I Route Selection after Move

[~ Align Components
b. Set the options for moving components by selecting

Configure=>Interactive Move in the menu bar
™ Errors Allowed

|3 "'| Effort to Find Legal Position

¥ ©nLine DRC
W Use Working Gri

Ok I Siandardl Can::ell

Help |

Setting the placement functions behavior is very important before
any placement is started.

¥ Springback
Eﬂ c. Select Configure>Placement>Push Aside in the menu Push effort |4 -]

bar. Ensure the settings are equal to the example.

QK I Can::ell Help |

d. Select a component and click the Move tool bar icon . Notice that other components are
I’E::I being pushed aside and when there is enough space the selected component jumps over other

components. Components can also be swapped '€ to the other side of the board or rotated | &
This can also be performed using the Right Mouse Button menu.

As this board is a 6 layer board with 2 power planes GND & VCC, we will first start with stub routing for
the GND & VCC.

e. Select Whole Net Mode <, Auto route & and select the GND signal at a pin location
(repeat the same for VCC).

:
[EERRRLRT

w—l e
i

GND ——
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The Place & Route Editor XR will help you in routing your designs by using several auto-routing
technologies on a single net, a group of nets or within a certain area.

Note: By using the customizable Function Keys F5 or F6 you can scroll through the layers from top to
bottom or the other way around (Try it).

h.

The next step is to create a Fan-out for a BGA. A Fan-out is a route template that can be
applied to an SMD component. It enables routes to “breakout' from a surface mounted pad
using a pattern that is efficient on space and gets the route to an inner layer as soon as
possible. Fan-outs are often used and can be easily re-used for BGA's, QFP’s or other devices.

x|
B Ml LNl L=l | FE

Note: If the Fan-out toolbar is not visible go to View->Toolbars-> select Fan out.

Before creating the actual Fan-out, select Configure-> Routing Setup [Fan out] tab - ensure
the settings are equal to the example shown below.

21X

Manual / Autorouting I Pusher I Trunking | Composition Fan-out | Testpoints I Radial I Spiral Vias I Autorouting Costs I Gridsl

—Fan-out Process

1V Simple Fan-out 2: [T Autorouter Fan-out

—Fan-out Settings

Simple Fan-out | Autorouter Fan-out I

Direction IDutwards vl r— Via Position
J I First Length
B E——
— Via Properties A
¥ Gridded
- -
Via Mame ICirde 20/10(via) ;I Second Length
|1 (Top Elec) LI
Layer Pair
|11 (Bottom Elec) LI
Spiral Vias IDisaIIuw -
" Minimum Spacing
&+ Absolute First Length |0.?00
™ Incrementsl | Second Length ID.?DD
Description: IEf‘fBrt: 10, Via: Cirde 20/10{via), Layer Pair: 1-11, Lengths: 0.700 0.700 ¥ Always Generate Auto
Open... | Save As... Ok I Cancel | Help |

Select Configure>Routing Setup [General tab] and change the Width from Necked to Type
and enter a value 0.152 mm.

Note: If your Units are set to Thou., as indicated at the bottom of the Place & Route Editor window,
double click on the unit shown and change it to Millimeters with 3 decimals for precision.

\ M ZUKEN
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I

Select Routing=>Fan-out->Perform Fanout =% in the menu

bar and click to frame an area around the component U4 |77 =5 2e=e
(bga64) or just a number of pads. SGR component U4, 26 pans
Fan-out attempting 26 pins...
Simple fan-out routed 26 pins
Outwards Inwards Completed
W% % % o AR TPRE
::kéq: ::. o0 e 00000
(IO eeo e
R v 1 AR R
R NI coeo0oo00o00 (HTML Fan-out report dialog)
LN I N ) RN NN NN
ec0es0000 eeedecee
2 " 80 ° o *Pfe™N oo
Manual [ Autorouting | Pusher | Trunking | Compositon  Fan-out |
—Fan-out Process
1: ¥ Simple Fan-out
If you would like to change the direction of the - Fan-out Settings

fanned out traces from Outwards to Inwards, select
Configure> Routing Setup [Fan-out] tab and

Simple Fan-out | Autorouter Fan-out |

change the direction from Outwards to Inwards. Directon |‘F"I‘:""""‘5 ]
Exit
Select the [OK] button on the menu and Undo the

Via Properties— Outwards
N

previous Fan out.
[V Gridded NE

E
Select Routing>Fan-out>Perform Fan out =% in -

S
the menu bar and click to frame an area around the Layer pair ﬁfi)"’ %
component U4 (bga64) or just a number of pads. E
This time the pattern c\should be opposite. soalvias.__[osalion T

When you are happy with the Fan-out you can save it for reuse, by selecting Routing->Fan-

out->Save ﬁp(Iocated on the Fan-out tool bar) and click to frame an area around the created
Fan-out, so you can re-use it within other designs. Save the Fan-out as ‘bga64.fpt’.

Let's test it!

Zoom-in on component U4 and Unroute “«|the created Fan-out.

Select Configure>Routing Setup [Fan-out] tab and change the direction to File. Click the file
browse button and open the file bga64.fpt as shown on the next page.

\ M ZUKEN
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fﬁ Routing Setup

Manual [ Autorouting | Pusher | Trunking I Composition Fan-out I
 Fan-out Process 51
(U(? ‘ - Lightning_data - macros ~ - ml Search macros ¥
1: ¥ Simple Far'—=——=
Organize ~  Mew folder =~ [ @
— Fan-out Settings = Name =~ | Date modified | Type | Size
| plot 8/3/2009 9:10 PM  Fle folder
Simple Fan-out | Autorouter Fan-out ] 4 . wizards 8/3/2009 8:33 PM  Fie folder
S 6/23/2010 12:3... FPT Fie |
Direction IFiIe - - _| Connector.fpt 9/2/2009 1:28 PM  FPT Fe
_I Eta,."macrosfbgaé—‘l.fpt Q
Via Properties .
e
=lal [
File name: [ bgasd fpt = [ &l

Open I Cancel |

Select the [OK] button on the
Routing Setup menu

BN

Undo the previous fan out.

Select Routing>Fan-out>Perform Fan out #% in the menu bar and click to frame an area
around the component U4 (bga64) or just a number of pads. This time the pattern will come
from the fan out file.

Tip: Once a design is fully “fanned out” the entire design can be saved to one fan out file.
Each components’ reference shapes’ fanned out pin data will be saved. If the design ever
needed to be rerouted using a different placement, the fan outs can easily be restored.

2%

Manual / Autorouting | Pusher | Trunking | Composion  Fan-out I Testpoints | Radial | Spiral vies | <|>

Let’s try another Direction

r—Fan-out Proce:

1: ¥ Simple Fan-out 2: [ Autorouter Fan-out

Select the Configure>Routing
Setup [Fan-out] tab. Change the

—Fan-out Setting:

Simple Fan-out | Autorouter Fan-out |

Direction to [Exit] and change the
Via Position to Minimum Spacing
as shown -

Select Routing>Fan-out>Perform

Fan out or click the icon "= located
on the Fan-out tool bar and frame an

Direction vl —Via Position
J SMD t iz Spading
- =
— Via Properti P—
[V Gridded 1

Via Mame IClrdE 20/10(via)

I 1 (Top Elec)

Layer Pair
I 11 (Bottom Elec)

(KN ENNEY

' Minimum Spacing

area around the component U3. spralves - [osslor | C pte | Festlengin [0
" Incemental | Second Length | 0,700
- 1
- Lo
- <«
.,- Description: IPasses: 10, Effort: 10, Angle: 45, Errors Allowed: On, Pushing: On W Always Generate Auto
e I Open... Save As... oK I Cancel | Help |
ol —
- e « ) ] ] o ) ]
N This option uses the default pin exit directions for the various pad
L i shapes as a guide to create the fan out entities.
<l
- - This can be used on all SMD components to quickly and easily fan

out an entire design. Try it!
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For the next exercise open Example3d.pcb in the Design Editor and go to the P.R.Editor XR by
selecting Tools>PR Editor XR

The Place & Route Editor XR will help you to complete your design step-by-step by using advanced
auto-route technologies. For instance; Trunk Routing will help you to complete data and address lines
easier.

What is Trunk Routing? TR | Tk Vb st

i

Trunk Routing introduces the concept of the
intelligent trunk object, allowing you to route any
given set of signals in an intuitive manner and
with as little effort as possible.

N Via in Trurk

Trurk End

/ Trurk Path

Trunk Contact i

ol

Trurk Segment

Eﬂ l. Selecting which connections are to be '
Trunk Routed A e

Trunk System

€ Busses of data and address lines can be pre-
designated in a schematic design (as done in
Example3.scm) and transferred to PCB and Place &
Route Editor XR. A named bus (trunk) can be selected by
its’ bus marker.

Zoom in on the bus marker. Select Manual Route |
and (Shift + Click) on the round marker. This will start the
action.

Alternatively you can double click on one of the =
pads as marked by the bus marker, before selecting

Manual Route | .

Note: All pads as marked will be selected and

highlighted.
.
1
€ When no bus marker is visible you can drag a multiple
| selection around a set of pins or connection wires before
-» ur selecting Manual Route | to start Trunk Routing.
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E:]m.

Before starting any trunk routing we advise you to check the Trunking Options located in the
Configure>Routing Setup [Trunking] tab.

Manual / Autorouting I Pusher Trunking | Composition I Fan-out I Testpoints I Radial | Spiral Vias Autorouting Costs | Grids I
— Automatic End Routing —Routing
—5mall Trunks ——— —Large Trunks ¥ Automatically Minimize
¥ Continuous More Than lz— Signals Crossed-connections
™ Dynamic Ends Only I~ Continuous
[~ Dynamic Ends Only Default Corner Style

IUse Routing Angle ;I

Via Pattern Style

Method: Method: IBDX LI

IUSE Routing Angle LI ILIse Routing Angle ;I [~ Allow 5ame Net Errors

Distance From Target: Distance From Target:

|Medium j IMEdiUFﬂ ;I Width Change Style

|Use Routing Angle j
—Guides
Width

W Active Snapping W Single Click Finish On Snap Line
Snap Distance IMedium VI Bus Marker Size IMedium VI % Necked ¢ Optimal
Snap Auxis Length IMedium j' ™ optimal Intra-trunk Spacing

Description: | v Always Generate Auto |
Open... | Save As... OK I Cancel | Help |

Simple Manual Routing of a Trunk on a Single Layer

In order to aid routing, snap axes and trunk-end routing areas will be drawn on the canvas
around each of the target sets of pins for the trunk. You will see Twist Arrows drawn on the
canvas showing the best entry angle for the trunk to the target pins, this allows minimization of
connections crossed at each end. You will also notice that you have a Gather Point for the
trunk that is now dynamic on the end of your cursor. The Gather Point defines the start for the
trunk where all of the parallel tracks will be considered as a single object.

To start routing the trunk you can place the Gather Point by clicking the left mouse button in the
position that you want to start routing the trunk from. Trunk segments are now introduced
towards the cursor position as you move the mouse on the canvas. Use the left mouse button
to confirm trunk segments that you have added. A corner can be added by changing direction
of movement of the cursor after a left mouse click.

Note: There are different styles of corners that can be added during trunk routing. This can be
changed by using the Right Mouse Context Sensitive menu.
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When you have added the required trunk path, it is possible to finish trunk routing in several
ways:
e The 'Escape’ key can be used in order to finish trunk routing at the last added corner
position or using the Right Mouse Context Sensitive menu Cancel option.
o With the ‘Single Click Finish on Snap Line’ option selected on the Trunking Options
dialog, a single click when positioned over a shap axis will also finish the trunk.
Remember to select Configure = Routing Setup 2[Trunking] tab in the menu bar.

It is also possible to restart the Trunk Router on a previously added trunk. This can be easily
done by selecting the manual routing icon ™ and then picking the trunk on the canvas, or

selecting the manual routing icon ™ with the trunk item already selected *
Note: Try also the ‘Backspace’ key (remove previous Item).

During routing of a trunk, the trunk contents will dynamically reorder to maintain the least
number of crossed connections at each of the ends. This is done to give the best routing
pattern for each end. This option can be configured using the Trunking Options dialog
Minimise Crossed Connection setting.

Adding Vias while Trunk Routing

To place a trunk via pattern while using the trunk router, you can double click the left mouse
button or choose a different layer using the Layer option on the Right Mouse Context Sensitive
menu. It is also possible to change the trunk via pattern style to a number of predefined styles
using the Right Mouse Context Sensitive menu during trunk routing or by pressing the 'Tab' key
in order to cycle through the predefined trunk via patterns.

Manual Reordering of Trunks and Via Patterns

It is possible to reorder the contents of a trunk manually, by manual selection of a single track
inside the trunk using selection preview. Hold down the ‘Shift’ key and press the Left mouse
button. It is possible to switch to one of the other items by pressing the 'Tab' key. Each time the
'Tab' key is pressed the next item will be highlighted. You can then drag this track interactively
to another position inside the trunk.

Manual Trunk End Routing

You can use the Manual and Activ-45 routers to interactively route the connections up to the
end of the trunk. During the routing process you can still re-order the trunk if necessary.
Automatic Trunk End Routing

While you are trunk routing, it is possible to automatically route the ends of a trunk using the
trunk end router. Routing will be attempted for all trunk ends that are inside a trunk end routing

target area. Select Configure>Routing Setup—=2>[Trunking] tab and ensure the settings are
equal to the example shown below.
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Manual { Autorouting I Pusher Trunking ] Composition ] Fan-out I Testpaoints I Radial ] Spiral Vias Autorouting Costs ] Grids]

Automatic End Routing Routing
Small Trunks Large Trunks ¥ Automatically Minimize
¥ Continuous More Than |2 Signals Crossed-connections

™ Dynamic Ends Only ¥ Continuous

™ Dynamic Ends Cnly Default Corner Style

|Use Routing Angle ﬂ

Via Pattern Style

Method: Method: |Box j

Use Routing Angle = UUse Routing Angle ™ Allow Same Met Errors

Distance From Target: Distance From Target:

Medium - Medium < Width Change Style

|Use Routing Angle j
Guides
Width
[+ Active Snapping ¥ Single Click Finish On Snap Line
Snap Distance Medium = | Bus Marker Size [Medium = * Meceed ¢ Optimal
Snap Axis Length |Medium - [ Optimal Intra-trunk Spacing
Description: | [¥ Always Generate Auto

Open... | Save As... | 0K | Cancel ‘ Help ‘

In some circumstances you may wish to decompose trunk objects that you have added to your
design into individual routes. For example, you may want to split a segment of a bus into routes
so that you can route the bus around an obstacle. To do this, select the trunk items that you
wish to decompose and then use the Decompose function on the Right Mouse Button menu.

°
°
&
9
®
®
¢
&
°

P
®
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Note: Once a trunk has been decomposed, it is not always possible to compose these items
back into a trunk. If they have been modified beyond their closest spacings you can use the
Trunk routing, manual and Activ-45 routers to interactively route the connections to the trunk
end and finish the board.

If you didn't manage to complete the trunk routing then exit the P.R.Editor XR without saving
and you will automatically return to the Design Editor and open Example3e.pcb

Auto Routing

For the next exercise you should open Example3f.pcb in the Design Editor and go to the
P.R.Editor XR by selecting Tools>PR Editor XR E

Before starting any auto routing | suggest you change the [General] Routing Setup options
(CTRL-T). Setting them correctly is very important before any routing! Ensure the settings are
the same as in the example shown.

fE Routing Setup

2]

Manual / Autorouting | Pusher I Trunking I Composition I Fan-out I Testpoints I Radial I Spiral Vias | Autorouting Costs I Gridsl

—Options — Angle —Track

[V Errors Allowed ¥ Straight

|45 j [~ Angled Autorouting Style:

™ Allow Pin Swaps " Curved

¥ On-ine DRC — Activ-45 (¥ Necked

Passes |10 hd ™ Enable Activ-45 Width: { Optimal

Effort 10 = Tidy Rectangle Size: [0.000 " Typed: |0.50800
—Via —Fixed Items

v vias Allowed ¥ Respect Fixed Fan-outs

Vias Under Single Layer Pads: |Off

I” Enable Snap Vias Legal  Distance: IEI.IJIJD

Spiral Vias IDisaIIow vI

™ Use Maximum Length

Max Fan-out Length: I 5,000

™ Respect Fixed Escape Routing

—PostTool Tasks—

[~ Auto Pour

[~ Auto Teardrop

—Freehand

[~ Enable Freehand
[~ Freehand Tidy

- ¥ save Best Pass

—Equispace

[~ change Length With Equispace

[~ Equispace Whilst Refine Routing

Priority according to:

Completion

I MNumber of Fails
[INumber of Physical Errors
I MNumber of Vias

M MNumher nf Senments

[~ Use the best pass as the final autorouting result

j:l
Ina

Standard |

Description: I

Open... | Save As...

o |

V¥ Always Generate Auto

Cancel | Help

Note: Although errors are allowed, you should first allow the router to make some errors. In

combination with Effort 10 the router will continue routing till no errors are left.
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Select Routing=>Autoroute 2 from the menu bar and drag an area around the whole board
outline or part of the board you would like to auto route. The auto router will stop automatically
once all connections have been routed. The routing might not be optimal, and therefore you can
run a Refine Routing Pass.

Select Routing—>Refine Routing |§| from the menu bar and drag an area around the whole
board outline or part of the board you would like to refine.

Note: As a result of the Refining Pass the number of vias and segments will be reduced.

If you didn't manage to complete the autorouting then exit the Place & Route Editor XR without saving,
you will automatically return to the Design Editor where you can open Example3g.pcb, before going to
the next step.

For the next exercise you should open Example3g.pcb in the Design Editor and go to the
P.R.Editor XR by selecting Tools>PREditor XR =

For test reasons you can decide to automatically generate a testpoint on every node (or as
many as possible). Before starting any allocation of testpoints, select Configure>Routing
Setup—>[ Testpoints] tab and ensure the settings are equal to the example. Do not forget to
select ‘(Bottom Elec)’ in the Layers section option!

Manual [ Autorouting I Pusher I Trunking I Compasition I Fan-out Testpoints | Radial I Spiral Vias I Autorouting Costs I Grids I
—Usable Pads —Layers
Use Name Typ= Use Layer

1 Circle 20/10(via) Via 1|0 |1 (Top Elec)
2 | O |Circle 10{max) Surface Mc 2 11 (Bottom Elec)
3 | O |Circle 10{min) Surface Mt
4 Circle 47(max) Surface Mt
5 | (O |Circle 47(min) Surface Mc
6 | (1 |Rectangle 1.3x1.2(min)@90000 |Surface Mc
7 | [0 |Rectangle 24x74{max) Surface Mc
8 | [J |Rectangle 24x74(min) Surface Mt
9 | [J |Rectangle 74x24{max) Surface Mt
10| [0 |Rectangle 74x24{min) Surface Mt
11| [0 |bgad4r(max) Surface Mc
12| [0 |bgag4r(min) Surface Mc —Pads for Added Testpoints
13| [ | c0805r(max) Surface Mg Both Layers: ICirde 20/10{via) :I
14| [ |cO805r(min) Surface Mi—
15| [0 | s0 28x56r(min)@90000 Surface Mc mEEGE | [~
16| [ |Circle 40/20(via) Through Hi Bottom Layer: ICirde 47(max) j
17| [0 |Circle 55/28(via) Through Hi
18| O |Circle 60/32(via) Through Hi _ FEseEin
T B e Center to Center Distance: [0.127

Description: Iirde 47(max), Top Layer Pad: , Both Layer Pad: Cirde 20/10{via), Center to Center Distance: 0,127 | Always Generate Auto

Cpen... | Save As... | 0K I Cancel | Help |

\ M ZUKEN



http://www.zuken.com/cadstar
http://www.zuken.com/
http://www.zuken.com/movies/cadstar/Preditor_Auto_Route/Preditor_Auto_Route.html
http://www.zuken.com/movies/cadstar/Preditor_Refine_Route/Preditor_Refine_Route.html

Now click on Select=>All from the menu bar or you may use <Ctrl+A>, and all will be selected.

Select Routing>Testpoint>Allocate | # and the testpoints will be added automatically. Select
Utilities>Reports>Testpoints to create a testpoint report as in the example.

R
Met V Type |Layer |X Position |Y Position Required | Testpoint On Grid | Error Mear Pad Requirementil
Number | Mumber Met

GMD (Via) Bottom 107.442 75.311 1 Unused Yes = 0.000 U4-60 YESJ
GMD (Via) Bottom 109.855 70.485 1 Unused Yes = 0.000 4-2 Ye:
GMND (Via) Bottom 109.474 73.311 1 1 Yes = 0.000 U4-62 Ye:
AD7 (Via) Bottom 67.310 61.595 1 Unused Yes = 0.000 U1-57 Vet
AD7 (Via) Bottom 83.439 61.595 1 Unused Yes = 0.000 u2-2 Yes
AD7 (Via) Bottom 101.981 61.595 1 1 Yes = 0.000 u3-2 Ye:
AD6 (Via) Bottom 86.741 60.833 1 Unused Yes > 0.000 u2-3 Yes
ADG (Via) Bottom 101.981 60.833 1 Unused Yes > 0.000 u3-3 Yes
ADG (Via) Bottom 67.818 60.071 1 1 Yes = 0.000 U1-56 Yes
ADS (Via) Bottom 68.326 58.055 1 Unused Yes > 0.000 U1-55 Ye:

qI ANS  Mial  RBntbnm 1in1 a1 SR 472N 1 Inncad Yac = N 00N 1132-4 I v_:lll

Now that you have finished the design, you can select File Exit from the menu bar and rebuild the
results. If you didn't manage to finish the testpoint creation, just open Example3h.pcb to see the
finished results.

RIF Import Options

¥ | Impart BIE Changes anly

v Group Trunks
¥ Fix Grouped Trunks

Do MOT
r Reconnect

™ Show thiz dialog on return from PRE ditor <R [HS] az
well as through File Import/0 ptions

Cancel

{ —
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Step 4 - Manufacturing Data for Design C

If you like, you can create the manufacturing data for this design by just selecting File->Manufacturing

Export>Batch Process £ in the menu bar. In the Batch Process window select [Open] >
Manufacturing Output 6 Layer.ppf, which you can find in the Self teach directory and click [START].

WELL DONE! You have now completed the PCB design and experienced
several features of the advanced Standalone Place & Route Editor XR2000.

Check CADSTAR Place & Route Editor XR - Functionality Matrix on:

ROUTING MATRIX
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1N4148 =
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| o & Ohm
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L > IN4148 33
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Input HL

o woF |
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Transistor Audio Amp (50mWw)

Information on Design D - Transistor Audio Amplifier

Design D is based on the same schematics as Design B (a little audio amplifier). But this time you will
create a SINGLE SIDED board and | will show you how to add jumpers on the fly. Typically, a jumper
is used to bridge across other routes, the jumpers discussed here are non-functional jumpers and do
not appear in the schematics. | will guide you through it to give you some tips. The sequence is the
same as before.

Step 1 - Design D
a. Open Example2.scm and transfer the schematic to PCB through File>Transfer to PCB..., but
now choose '1 layer 1.6mm.pcbh' as PCB technology instead. This is a default technology file

that | have already prepared for you; notice that although I'm using the same library, the solder-
pads are larger, there are thicker track-widths and more spacing has been defined.

Step 2 - PCB Placement for Design D

You can now start to place and arrange the components on the PCB after the transfer. Again, | will give
you some important points to follow in order to complete the PCB placement or you can go
immediately to Step 2.i.

When creating a single board design a good placement is highly important to avoid crosses in the
connections, so take your time. Don’'t worry as you will be able in Place & Route Editor XR to add
jumpers on the fly, just like adding a via.

a. Check and/or change the Units & Grid (25 thou is preferred)

b. Change in the shape toolbar the Default Shape Type to |Beard
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Draw a board outline (size 2000x1500 thou). If you didn't manage to draw the board outline, just
open Example4a.pch O @

Arrange components around the Board Outline

Manually place the critical components inside the board outline:
Place VCC9V at X-position 150,0 and Y-position to 150,0
Place INPUTGND at X-position 150,0 and Y-position to 1050,0
Place INPUT at X-position 150,0 and Y-position to 1350,0
Place SPK at X-position 1850,0 and Y-position to 1350,0

Place SPKGND at X-position 1850,0 and Y-position to 1050,0

Fix the position of VCC9V, INPUTGND, INPUT, SPK and SPKGND =

Cross-probe if it is necessary

Automatically place the other components. 2 If you didn't manage to place the components,
just open Example4db.pch

Before going to the routing environment check out Settings=> Defaults=>General and ensure
Jumper support is enabled.

x

General IShape I Text I Routes I Copper F‘ourl Dimension I Dimension Line | Dimension Text I

Jumper Support

r Test Lands — Components
Code: [Crcle 60/32 =] | T Mo
r Design Options

 Documentation Symbols

¥ Uumper Support Enabled:

Layer: IDocumemaﬁon j [ e kvt
¥ Legacy Constraint b anagement
r Pads/\Vias
Cirill Orversize: W v Tidy Connections
Thermal Relief " By Option
lrl:lgamnce: IW Relief Width: IW % By tem

OK I Cancel Help
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Also before going to the routing environment check out Libraries>PCB Components f
you expand the contents of the PCB.LIB (as shown below) you will see a sub folder for
Jumpers. | have already created some pre-defined jumpers, which you will be able to select in
Place & Route Editor XR on the fly.

Library Manager x|

Current Library

Path: IE:‘\Users'\Puinchken'\E&DST.&H Eupress 13.08Libran, j

Type: PCE Components

File Mame: pch.lib Browze... | Create... |

Add Folder | Fename Folder Dielete Folder ¢ Lopate |

Edit =8 peblib £ JUMPERNF-lead0.8 [1015) I Use Mapping file

[N i A28 Jumpers £ JUMPERMNF-leadl 8 [1270) Add File... |

Temporary | € JUMPERMF-l2ad0.3 [1524)

Delete £ JUMPERMF-lead0.8 [1773)
£ JUMPERNF-leadl 8 [2032) S ave Comp... |
Archive £ JUMPERMF-r0E03 [reflow_PC)

£ JUMPERMNF-r0805 [reflow_|PC) Tidy Library |
Repart..

£ JUMPERMNF-r1206 [reflow_|PC) ;
driginz... Agzignments.. |
W ErSIOnE.. . Uzer Attributes... |

Lapers... |
Selectall | | o | N

{ Show subfolder contents 0 Selected From 8 Listed LI
&+ Show selected folder only
LCloze I Help |

MR

g

Open Example4b.pcb and go to the Place & Route Editor XR2000 by selecting
Tools>PREditor XR... &
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Step 3 - PCB Routing for Design D

You are now at the final stages of the PCB
design. Simply follow the steps and you will
complete your PCB design very soon. When
transferring to the Standalone Place & Route
Editor XR a RIF Export Option window will be
showed automatically. Ensure that Write
Jumpers from Library is enabled.

RIF Export Options

X

[W]:&lways Transfer Colours:

[ Use Routing Grid a5 Systerm Grid

Write Part Infarmation

- ~

i
( [V]'rite Jumpers from Library \;
~ 7

~

-~ I

ﬁhowthis dialog on transter to PREditor XR (HS) as well
as through File Export/Options

[ Cancel ] ’ Help l

Before starting any routing | advise you to check the Routing Setup options. Select Configure
2Routing Setup [General] tab in the menu bar (or use CTRL-T).

Ensure the settings are

equal to the example. If you don't like copper to be poured automatically disable it. If you don’t
like routes to be pushed you can disable the Pusher or reduce the Effort in which case less

routes will be pushed aside.

—Options

[E Routing Setup

Manual / Autorouting I Pusher | Trurking | Compasition I Fan-out | Testpoints | Radial I Spiral Vias I Autorouting Costs I Gridsl

21

— Angle —Track

[~ Errors Allowed ; & straight
|45 vI [ Angled Autorouting Style:

¥ Allow Pin Swaps " Curved

¥ On-ine DRC _ Activ-45

% Necked

e hd ™ Enable Activ-45 Width: © Optimal

Effort 10 4 Tidy Rectangle Size: |0.000 " Typed: |0.50800
—Via —Fixed [tems

¥ Vias Allowed [~ Respect Fixed Fan-outs

Vias Under Single Layer Pads: |Of‘f ;l I~ | Use Maximum Length

[~ Enable Snap Viss Legal  Distance: ID.EIEIIII

Spiral Vias IDisaIIow - I

Max Fan-out Length: I 5.000

[~ Respect Fixed Escape Routing

—Post-Toal Tasks

—Equispace

|_ Auto Pour

- ¥ Save Best Pass

Priority according to:

I™ Auto Teardrop [~ change Length With Equispace

—Freehand

I~ Enable Freehand [™ Equispace Whilst Refine Routing

[ Freehand Tidy

V] Completion

O Number of Fails
[JMumber of Physical Errors
[ Number of Vias

M Mumher nf Senments

[~ Use the best pass as the final autorouting result

j:l
[~

Standard |

Open... | Save As...

Description: layer Pad: Cirde 47(max), Top Layer Pad: , Both Layer Pad: Cirde 20/10{via), Center to Center Distance: 0,127 [v Always Generate

Auto

OK I Cancel | Help |

\ M ZUKEN



http://www.zuken.com/cadstar
http://www.zuken.com/
http://www.zuken.com/movies/cadstar/Transfer2pred/Transfer2pred.html
http://www.zuken.com/movies/cadstar/Preditor_Routing_Options/Preditor_Routing_Options.html

Tip: By using the customizable Function Keys F5 or F6 you can scroll through the layers from top to
bottom or the other way around. Select in the menu bar Layer, change the Current Layer to Bottom
Elec and click OK.

Preset: I LI on | Off |
Layer | Currentl Active | Display | Bias |
1 (Top Jumper) i Jumper
2 (Top Elec) i Y bias
B |4 (Bottom Elec) i ¥ bias
5 (Bottom Ju... r Jumper
QK I Apply | Close | Help |

Manually route [=k/-l L~ the net PR
between resistor R2 and capacitor C2 If ‘F*—%’F‘-i
as in the example on the Bottom Elec pa—

layer. _—
L1 L

In the next step you will add a jumper on the fly by manually routing <l L ™ the net
between transistor TR1 and resistor R2 as shown in the example below on the Bottom Elec
layer.

Route to the location you want to add the first pad of the

jumper and double click, select Top Jumper. Now move the ’ﬁ
cursor to the location you want to add the second pad of the
jumper. P.R.Editor XR will show you a thin line representing the || | 2 '”'E"T'
pitch of the pre-defined jumpers depending on the available 5 [EIDEDm f—
space. Double click again and you will add the jumper and you

can continue routing. P.R.Editor XR will show you only a list of Cancel

pre-defined jumpers if more than one jumpers with the same

pitch have been defined in the library. It's as easy as adding a
via!
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Now route all the connection on Bottom Elec layer and insert jumpers if necessarily till no
connections are left.

Once you have finished the design you can select File->EXxit from the menu bar. All routing and
jumpers will be back annotated to the PCB Design. Running an ECO update won’t remove
jumpers and the jumpers will appear normally in the Part List and placement data.

If you didn't manage to complete the design, just open Example4c.pcb to have a look.

O

SPKGND

Design D after Placement & Routing
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=7

Step 4 - Manufacturing Data for Design D

At this stage, you can also create the manufacturing data (Gerber, N.C.Drill, Parts List, Placement data
etc.) for the manufacturing of the PCB (as you did for Design A) by selecting File->Manufacturing
Export->Batch Process £ .. in the menu bar. In the Batch Process window you select [Open] and
use Manufacturing Output 2 Layer.ppf, which you can find in the User directory and click [START].

4+~ Batch Process - [C:\Users\Public\Zuken\CADSTAR Express 13.0\5elf

Lse Drescription WVariant Fr_?_;pe:s
1 [T |Gerber Copper pattern Component |<MNO WA Artwiark
2 W |Gerber Copper pattern Solderside  |<NO WA Artwiark
3 [ |Gerber Solderresist Componentsid |<MNO WA Artwork,
4 ¥ |Gerber Solderresist Solderside =MNO WA Artwiark
5 [+ |Gerber Silkscreen Componentside |<MNO WA Artwiark
& ¥ |PDF &ssembly Componentside =M WA Artwiark
ri Partlisting =M WA Report
g ¥ |Placementdata =MD WA Report
9 [+ |Drilldata (Plated Through Holes) =M WA M.C. D
10 [ |Drilldata (Mon-Plated Through Hole | <MNO WA M.C. D
11 [# |PDF Crill Drawaing =M WA Artwork,

You can easily disable the rows that you do not wish to post-process. In this design, since it is a single
layer board, the layers that are to be generated are Bottom Elec, Top Solder Mask, Bottom Solder
Mask and Top Silkscreen (all in Extended Gerber RS274-X format). Other additional manufacturing
data that CADSTAR can generate which is necessary for manufacturing are Parts Lists, Placement
Data and Drill Data. All manufacturing data will be saved in the Output directory.

Alternatively you might want to produce an ODB++ output file. ODB++ is one of the most intelligent
CAD/CAM data exchange formats available today, capturing all CAD/EDA, assembly and PCB
fabrication knowledge in one single, unified database.

WELL DONE! You have now completed the PCB design.
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e Chapter 6 - Design E (Reusing Circuits to build a Double sided Board
Design)

The exercises that you have done so far are fairly easy, but they still take time to create. It is always
good to save circuits for Reuse at a later date.

In this chapter you are going to build a design that uses two completed design circuits into one board.
In Chapter 1, if you saved your circuit as a Reuse Block you are on your way. If not, they are available
for you to use

Reuse Blocks are stored in the ..\Reuse Files\ folder. However they can be stored and read from
Network Locations. See Tools 2Options 2[File Locations] tab.

x
Systemn  File Locations |Li|:urar_l,I Pathsl Interactionl Displa_l,ll Constraintsl Cross Prnhingl Hepnrt$| Toals I Macrnsl Debugl

File types Lacation:

Colour Files CoaldzergsPublichZukenh CADSTAR Express 13.0MColoursh, ;I
Initial Deszign Directory C:A\JzershPublich\Zuken\CADSTAR Express 13.0085elf Teachh

Macros CAUzers'\PublichZuken\CADSTAR Express 13.0%Macrash

M anufacturing Output CAUzers'PublichZuken\CADSTAR Express 13.0%0 utputh,

Output Datashest Files Tl zershPubicheukens CADSTAR Express 13050 utput'

Output Report Files CoaldzergsPublichZukenhCADSTAR Express 13.0MR eports',
PRE ditor Configurations C \LISers‘\Publlc\Zuken\C&DSTAH Exprezz 13.05PRE ditor Configurations',
Reuse Files LA PublichZuken TAR Ex 3.0%F euze Filesh
Selection Files C:AUzers'Publichuken\CADSTAR Express 13.0M5electionsh
Sirnulation Libranies C:A\Program Files [#86]%uken CADSTAR Express 13.04
Template Files CoaldzergsPublichZukenhCADSTAR Express 13.00 T emplatesh,
Uszer Files CoaldzergsPublichZukenhCADSTAR Express 1300 zer’,
=
C:AlsgershPublichukent\CADSTAR Express 13.00Reuse Files todify... |

0k, I Cancel | Help |

Tip: It is recommend that for each reusable schematic circuit that is stored away, the corresponding
PCB Circuit be saved in the same location and by the same name. Inthe CADSTAR Express install
tree “../Reuse files/” you will find Flasher.SCM and Flasher.PCB as well as Amplifier.SCM and
Amplifier.PCB.

a. Open the sample file Exercise5a.SCM. This file has a sectioned off area for each circuit.
However, If you want to create your own new schematic design you may do so.

b. Add the “Flasher” Reuse circuit to the new sheet. Select [Actions>Reuse blocks2>Insert Reuse
Block]

c. Select the Flasher circuit and click [OK]
d. Place the circuit into the Flasher area on the sheet.
e. Repeat the process for the Amplifier circuit.

That's it for the Schematic!
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f. Run [Transfer to PCB] and select PCB Technology Exercise5_2 Layer pcb.

g. During the Schematic Collating process, you will be prompted to [Add New Code] or [Choose
Existing Code] until you are presented with a report. For this example simply select [Add New

Code] and [Yes] for all options.

Collating Schematic Design - Line Widt

Inable ta find a match for this assignment code:

Type: Line

M armne: Azzembly Outline
"idth: 6.0

Line Shyle: Solid

becauze no azzignment code of that name exizsts.

Choosze E xizting Eu:ude...l Cancel |

x|

Hep |

Collating Schematic Design x|

Lo pou wizh to automatically add all other
unmatzhed items of this type?

Mo Help

Note: That during this process the schematic design assignments are being compared to the Design
Assignments that are in the Template files. Adding them is important unless you are choosing from the

existing assignments.

h. Review the report and then click [Close].

Your new PCB design will display all components in the lower left corner of the window.

=-Z3 Current Design
[EI Areas

-] Board

-] Components
Iﬁl Groups
[:l--- Mets

E@ Reuse Blocks
1 Amplifier
- [ Templates
:|--- Testpoints

EI Views

T+

| [][17.4 3535

i. Open the Workspace, Current Design window and expand the list of Reuse Blocks and you will see

Amplifier and Flasher as shown above.

j-  Click the Flasher circuit and then click the [Move] tool bar icon to move the Flasher components out

of the pile away from Zero, Zero.
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k. Repeat for the Amplifier Components.

I. Click the Flasher circuit and then click the [R.M.B] to
Update the Reuse Block.

Read the Notes below before proceeding.

You will now be presented with the opportunity to map
the layers that are used in the reuse PCB blocks to the
Layer stack-up of the new design.

If the Circuit was designed on a 2 layer board and you
are importing it onto a 4 layer board then you may use
the [Choose Existing Layer] option and select the correct
layer until all are properly mapped.

You will also be presented with options to choose how to handle matching Signal names.

E Reuse Blocks
i Amplifier

omme
EI Templa
Testpoi
L] views

W 7AWl X e

Item Properties...

Cut Ctrl+X

Copy Ctrl=C

Delete Delete

Fix
Unfix

View Selection

Open Flasher.PCB

[

Update Reuse Block

*

Remove Reuse Association

le. If

GND is used in one block and DGND is used in another you could always address that with a

Starpoint component.

However if GND is used in both blocks it is possible that each ground is

supporting a higher voltage potential and should not be joined, In that case choose the option to

[Rename Net]

The remaining options should always be reviewed since they pertain to Pad Code and Route Width
code assignments from the Reuse Blocks. To properly maintain the integrity of the block(s) you
should typically select the [Add New Code] option for all of the selections.

Holes with those on the new PC board shape

shape.

Place the Flasher block on the lower half of the PCB Design and attempt to align the Mounting

i?epeat Steps ‘I' and ‘m’ for the Amplifier block and place it on the upper half of the PCB board

From this point forward with real designs, you would complete the necessary steps to finish any
Interconnect routing between the blocks that may have resulted from the Joined Nets and use the
Embedded Place and Route Editor to re-pour the copper templates.
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WELL DONE! You have now completed a PCB design
using Reusable Circuit Blocks!
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e Conclusion

After these six exercises you should now be more familiar with the basics of PCB design. In the near
future you may even be designing a more complex PCB using CADSTAR.

With this booklet, you have received a free copy of CADSTAR Express. CADSTAR Express provides a
number of features of the full CADSTAR version, only limited by the number of components (max 50)
and pads (max 300).

For further information on pricing or if you require any support during evaluation or prefer to receive a
detailed demonstration, please contact your local CADSTAR distributor:

http://www.zuken.com/products/cadstar/where-to-buy.aspx

There are also other CADSTAR tools that help Schematic and PCB designers to create board layouts.
Check for more information on CADSTAR products:

http://www.zuken.com/cadstar

I hope to see you again when we talk about some of our other, more advanced products:

See you soon!
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