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About This Manual
This manual is for those of you who are upgrading to Master
Designer 8.7. It explains all the new features and changes that have
been made since Master Designer 8.6. By reading this manual, you’ll
be able to see at a glance what’s new and different in Master
Designer 8.7.

This manual consists of four chapters and five appendixes. A
conventions page follows this section.

Chapter 1 "What’s New" describes what’s new throughout Master
Designer 8.7, such as automatic assignment of
reference designators, Level push/pop into padstacks,
and snap to pin in Symbol and Part Editors.

Chapter 2 "What’s New in the Utilities" describes what’s new in the
Master Designer 8.7 utilities, including the reference
designator use report, alpha numeric sorting of wire list,
and the reporting of unassigned pins shorted to inner
layer planes

Appendix A "System Limits" describes name length limits;
maximums for database items such as pins,
components, and nets; and ranges for other items.

Appendix B "Filename Extensions" lists the P-CAD filename
extensions and the tools that produce the files.

Appendix C "Reserved Words" lists DOS reserved device names
and P-CAD attribute keywords.

Appendix D "Button Menu Tree" contains a graphical menu tree for
the Button Menus.

Appendix E "Command Cross Reference" contains a command
cross-reference, a list of default hot-key functions, and
a chart of the keys available for hot-key assignment.
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Conventions
This manual uses the following conventions:

→ or ! Connects commands. Commands following the arrow
appear on submenus. For example

File!Load  or  FileÕLoad

* One or more characters can occupy the asterisk’s
position. Also known as a wildcard.

* In text, introduces a procedure that explains how to do

a task.

 Press the keys simultaneously. For example

The return key. Press this key after typing data in a data
entry box or on a message line or to accept a default. You
can click left in many P-CAD tools instead of pressing        .

Enter or ↵ Indicates you need to press          after typing data.

The space bar. You can use this key to digitize a point
within the drawing area.

italics Indicates variable characters.

boldface Indicates characters you enter from the keyboard;

for example

Enter sheet7 in the data entry box.

−

Shift F1−

↵

↵

↵

Space
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boldface italics Indicates variable characters you enter from

the keyboard; for example

Enter filename in the data entry box.

Click left Press and release the left button (button 1) on the
mouse.

Click middle Press and release the middle button (button 2) on
the mouse.

Click right Press and release the right button (button 3) on the
mouse. If you are using a two-button mouse, press

        and button 2 simultaneously to clickright.

Cycle Click left repeatedly on a cycle box until the item
you want is selected. A cycle box is indicated by
    .

Select Move the cursor to an item or point and press        ,
            , or click left.

Ctrl

Space

↵
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What’s New 1
P-CAD Master Designer 8.7 (MD 8.7) gives you the power and
flexibility to create electronic circuit designs and PCB (printed circuit
board) layouts from start to finish. With its many enhancements,
however, MD 8.7 lets you complete your designs even faster than
before.

Graphic Editors

Zoom controls using the unshifted “+” and “-“
keys

To improve the capability to view areas of the design file at various
zoom levels, two additional hot keys have been added to the zoom
controls:

• unshifted “+” (plus) key - used to zoom in on a area of
    the design.

• unshifted “-“ (minus) key -  used to zoom out.

The zoom function remains unchanged from previous versions of
the product, the addition of the unshifted “+” and “-“ keys are
provided to allow greater flexibility in how the zoom controls are
accessed.

Snap to Object in Measure

Master Designer 8.7 now allows the capability of snapping to off-grid
design objects when using the Measure command.  The snap to
object feature is available in all Editors (Symbol, Parts, Schematic,
and PCB) and can be enable or disabled using the new /rsnp
keyboard command.

To use the snap feature for Measure

1. From any Editor, select Display→Measure.  The system prompts

Select point to measure from
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2. Move the cursor near the location of an object from which you
wish to begin measuring.

3. At this point the System will display, on the status line, the RX,
RY, and Actual measurements from the beginning object to the
current cursor location.

4. Enter           - s

Note:  In order to snap to objects, insure that Caps Lock is not
enabled.

2. The cursor will snap to the nearest object and this will be the
start point for Measure.

3. Move the cursor near the location of an object from which you
wish to end measuring.

4. Enter           - s.

5. The cursor will snap to the nearest object and this will be the end
point for Measure.

6. The status line will now display the RX, RY, and Actual Distance
between the two points.

The addition of the snap feature allows snapping to the following
objects:

Drawn Line
Drawn Arc
Drawn Circle and Filled Circle
Drawn Rectangle and Filled Rectangle
Drawn Polygon
Entered Polygon
Polygonal Void
Circular Void
Wire segment
Curve wire
Pin center location if no padstack attached
Via center location if no padstack attached
All flash shapes except Thermal, Special, and Target
Center points of Thermal, Special, and Target flash shapes
Bounding box of drawn text
Stand alone flash center location (Part Editor Only)

Note: Snap to object will not snap to free standing flashes in the
PCB Editor.

Shift

Shift
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If there are more than one object within snap tolerance,  the
program will snap to the object closer to the cursor. If two or more
objects within snap tolerance are equally distant to the start point,
the program will snap to the object with higher layer priority. The
priorities of layers are:

1.  Active
2.  Able
3.  On

If two or more objects have the same distance and the same layer
priority, the program will snap to the one first found in the database.

When snapping to an object, the program can actually snap to the
center, the edge, or the vertex of a line or an arc depending on user
option. The /rsnp  will let you set this option.  When using the /rsnp
you will be presented with a new dialog box (see the figure below)
which will present you will three options.

Figure 1.1

The three available options are described below:

• Vertex - The measure command will snap the cursor to the
nearest vertex.  This is the default setting and will always be
selected until changed by the user.

• Center - The measure command will snap the cursor to the
center of a line or arc.

• Edge - The measure command will snap the cursor to the edge
of a line, arc, or circle, etc..
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Symbol Editor and Part Editor

Snap to Pin for entering pin sequence, naming
pins, query pin, and editing pin types

The Enter Pin Sequence, Name Pin, Query Pin, and Edit Pin Type
commands have been improved to allow the automatic snapping to
off-grid pins.  This provides improved productivity by allowing a
greater latitude in pin selection, especially for fine pitch devices or
those devices having inconsistent pad spacing.

The Pin Sequence  and Name Pin operations will now  provide the
capability to snap the cursor to the center of the closest pin, rather
then the current requirement of placing the cursor at the exact pin
center.  The current snap tolerance will be used to determine what
pin is being selected.  If the point selected is outside of the pin’s
current snap tolerance, “No Pin Found” will be displayed on the
status line.

If the point selected is within the snap tolerance of two pins, the
cursor will snap to the closest pin center. If the point selected is
within the snap tolerance of two pins and an equal distance between
both pin centers, the Pin Sequence command will attempt to
determine the direction of sequencing and select the pin that should
be sequenced next.  If this is not possible, than the next pin in the
database will be selected.

PCB Editor

Level Push and Level Pop on Padstacks
MD 8.7 now offers the capability to allow Level Push and Level Pop
commands to operate on a pin or via Padstack, similar to the
Symbol and Part Level Push and Level Pop commands.

A new  subcommand “Push Padstack” has been added to the File
menu.  When this command is invoked you will be prompted to
select a pin or via.  A selection of a valid pin or via, with an attached
padstack, results in a level push into the padstack.  An invalid
selection causes the PCB editor to display an “No pin or via found”
error message on the status line and you are prompted to make
another selection.
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When pushing into a Padstack, the PCB Editor will change from the
PCB Editor to the Part Editor and load the padstack file (.PS) for the
pin or via selected.  The user can then return to PCB Editor by using
the Level Pop command.  If the loaded padstack was modified prior
to selecting Level Pop, the user will be prompted to save the edited
padstack and, if saved, replace all occurrences in the existing
design file.

The padstack can only be saved under it’s original name.  If you
need to modify a padstack and save it under a different name, then
the Part Editor should be used, rather then File→ Push Padstack.

Note: If you are using a System Directory configuration, the Push
Padstack command will search for padstack files in the current
System Directory, unless the Special Symbol File uses pathing to
indicate the location of the padstacks. If the selected padstack file
can’t be located by either of these methods, a “padstack.ps not
found” error message will be displayed on the status line.  To locate
the proper padstack file you will need to identify the System
Directory used to initially attach the padstack to the database.

Maintain link with padstack files when
“Cancel” is selected from Attach Padstacks

Master Designer 8.7 now allows the link to existing padstacks to be
maintained when selecting the Cancel button during the
Environment Attach Padstacks command.  The cancel button will
now allow you to cancel the Environment→Attach Padstacks
command and select a new command, without removing the existing
link to attached padstacks.

Note:  To remove the link to the existing padstacks in the current
design, use the backspace key to highlight the current Special
Symbol File filename, and then enter the return key.  This will erase
the current Special Symbol File filename and unlink the current
padstack files.
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Schematic Editor

Automatic Assignment of Reference
Designators

Master Designer 8.7 can now automatically assign reference
designator and section numbers to symbols as you enter them in the
Schematic Editor.  The system also remembers the last reference
designator and section number entered for each symbol.  This
feature is useful because it saves you from having to manually
specify the reference designator and section numbers after entering
the symbol.  You also don’t have to worry about remembering the
last reference designator and section numbers entered.  Master
Designer assigns and increments them automatically.

The automatic assignment of reference designators is accomplished
based on the PREFIX attribute assigned to the symbol.  You can
assign the PREFIX attribute to symbols individually or a utility
introduced in MD 8.7 can be used to assign the PREFIX attribute to
all symbols in a directory, or all symbols in a library (.SLB).  For a
more detailed explanation on how to use the utility for assigning the
PREFIX attribute see Assign Reference Designator Prefix under
Prevue in What’s new in Utilities.

To assign the PREFIX attribute to an individual symbol

1. From the Symbol Editor, select File→Load.  The system
prompts

Enter file name:

2. Enter the name of the desired component, or select PICKLIST to
choose the component from the picklist.  Remember that you
can change directories if the desired component is in a different
directory.

3. Click ENTER.

4. Select Enter→Attribute.  The system prompts

 Select location (Text attributes OK?)
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5. Select the location for the new Attribute.  The system prompts

 Type in attribute spec.

6. Enter prefix = * ; where * indicates the reference designator
prefix that you would like to assign to the symbol.

7. Select File→Save the symbol.

Note:  For symbols in an existing schematic you can use the
File→Level Push and File→Level Pop commands to add a PREFIX
attribute to individual symbols.

To automatically assign reference designators

1. From the Schematic Editor, Select Enter→Component.  The
system prompts

Enter component name:

2. Enter the name of the desired component, or select PICKLIST to
choose the component from the picklist.  Remember that you
can change directories if the desired component is in a different
directory.

3. Click ENTER.

After you enter the symbol name in the response area or choose
a symbol from the picklist, the system displays the component
outline.  Master Designer also displays a Refd checkbox in the
status area and prompts

Select location to place filename. (Orientation OK?)

4. Change the status area options as needed.

5. Click the Refd checkbox.  A button appears next to the Refd
checkbox, which displays the next available Reference
Designator and section number. This is the Reference
Designator button, which you can use to assign a reference
designator and section number to a component that is different
then the next sequential assignment.

Note:  If you enter a reference designator and section number that is
different than what is indicated as being the next available, all
subsequent assignments will begin from the reference designator
and section number that you enter.  Skipped reference designators
and section numbers can be assigned by entering the reference
designator and section number for those that have been skipped.
The next available reference designator and section numbers will
increment to the next available skipped gate until all skipped gates
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are assigned and then incrementing will continue after the highest
reference designator and gate section assigned.

 

7. Select the location of the component.  Master Designer places
the component and displays its reference designator and pin
number information.

8. Repeat step 7 for each component you want to place.  As you
place each component, the system increments the Reference
Designator button, indicating the reference designator and
section of the component you’re about to place.

9. Click CANCEL or select another command when done.

Prevue

Assign Reference Designator Prefix Attribute

A new utility has been added to Master Designer 8.7 that provides
the capability to add a new PREFIX attribute to All symbols in a user
specified directory or All symbols in a user specified library file
(.SLB).  The Assign Reference Designator Prefix utility is available
from the Library Manager area of the Prevue and will automatically
locate all of the symbols,  determine the correct symbol/part
mapping and use the part’s SCAT value to determine the Ref Des
prefix to be assigned to the symbols.  The directory and/or symbol
libraries (.SLB) to be processed are determined by the symbol
search path and the libraries specified in Set Libs. & Search Paths
settings in Prevue.  For an example of the location of the Assign Ref
Des Prefix  utility see the figure below:
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Figure 1.2

Note:  The Assign Ref Des Prefix utility will use one of three ways to
accomplish finding part-symbol match. It first searches for a part
attribute on the symbol. If it can’t find part attribute, it will read the
cross-reference file (.FIL) to see if the symbol name is included.  If a
match still can not be made after trying first two approaches, the
program will use “same name” method to determine the part file to
be used.  If a prefix definition exists in the cross reference file, the
Assign Reference Designator Prefix utility will use that information,
rather then the SCAT value to define “PREFIX” attribute.   The
PREFIX attribute will be added on the “ATTR2” layer. The layer
visibility of “ATTR2” will not be changed because of adding
“PREFIX” attribute.

The Assign Ref Des Prefix dialog allows you to confirm search
paths, part libraries, and symbol libraries.  If any of the settings need
to be changed, this can be accomplished by using Library Managers,
Set Libs & Search Paths.  For an example of the Assign Ref Des
Prefix dialog, see the figure below:
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Figure 1.3

Note:  All warning or error messages will be listed in the PCAD.LOG
file.
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What’s New in the Utilities 2
This chapter describes the enhancements to the following MD 8.7
utilities

• Design Rules Checking

• Report Generator

• Autorouter

General

Recognition of “.” (period) as a valid character
in PWGD attribute values

All utilities in Master Designer 8.7 now recognize the use of a “.”
(period) in PWGD attribute values or the PWGD information defined
in the Pin/Net section of the Cross-Reference file, as a valid
character.  In the case where PWGD information is defined in both
the PWGD Attribute of a schematic symbol and in the Cross-
Reference PWGD information for the same symbol, the schematic
symbol’s PWGD Attribute definition will supersede that of the Cross-
Reference file.

Design Rules Checking

Reporting of uncommited pins shorted to
inner planes
Design Rules Checking has been enhanced, in MD 8.7, to report
uncommitted pins that are shorted to internal planes. Currently DRC
can only report a pin shorted to an internal plane if that pin is part of
a signal net.  Design Rules Checking will take uncommitted pins into
account when checking inner plane connectivity.

If an uncommitted pin is found shorted to an inner plane, the DRC
Error report will record this information and let the user easily find
which pin is causing the short by adding a new section to the DRC
report that lists the reference designator, pin number and pin
location of the uncommitted pin.  The figure below provides an
example of the new INNER PLANE AND UNCOMMITTED PIN
CONNECTIVITY section included in the Design Rules Error report.
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Figure 2.1. Inner Plane and Uncommitted Pin Connectivity

Note: For Design Rules Checking of uncommitted pins to occur, the
appropriate inner plane Flash layers must be included in the DRC
Check Passes.

Report Generator

Alpha-numeric Sorting of Wire List

The Report Generator now sorts the Wire List report that is
generated from a Master Designer Schematic or PCB netlist in
alpha-numeric order, by net name.  As an example, if the nets listed
in Wire List report were Net1 through Net100, the order of the nets
in the report will be Net1, Net2, Net3, ....., Net10, Net11,......., Net20,
Net21, ......, Net 30, Net31,...., Net100.

The general format of the Wire List Report continues to be
consistent with previous revisions of Master Designer.

Reference Designation Use Report

Master Designer’s Report Generator has been enhanced to include a
Reference Designator Use report, which will generate a report from
a Schematic netlist, identifying the last used reference designator,
not used reference designators, and spare gates.

You can select the Reference Designator Use report from the
Schematic Tools Report Generator button.  See the figure below for
an example of the dialog where the selection of the report is
available.

Inner Plane and Uncommitted Pin Connectivity:
---------------------------------------------
Aperture Value COMP PIN COORDINATES
-------------- ---- --- ------------
        9 U12   6 1250    2000

 15 unnamed 9  400    1600
 18 U3  13 1850    2100
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Figure 2.2

When the Create Ref Des Use List button is checked, Report
Generator will create a P-CAD Reference Designator Use List
report.  For an example of this report see figure 2.3 below:
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%*********************************************************************
%                                                                    *
%     Program  :   pc-form VERSION 8.7                               *
%     Date     :   Jun 24 1997                                       *
%     Time     :   04:42:55 PM                                       *
%     File In  :   t.nlt                                             *
%     File Out :   t.rdu                                             *
%     Format   :   P-CAD Reference Designator Use LIST               *
%                                                                    *
%*********************************************************************

Prefix   Last Used RefDes   Unused RefDes      Spare Gates
------   ----------------   ----------------   -----------------------

C        C3                 C2                 C1/A C1/C C3/B

R        R2

U        U30                U3 U7 U9 U15 U16   U2/C U2/D U10/A U11/B
                            U17 U20 U21 U27    U11/C U11/D
                            U28 U29

Figure 2.3

This Reference Designator Use List report describes the following
information:

• Prefix - This column identifies all of the reference designator
prefixes that are contained in the netlist.

• Last Used Ref Des - This column identifies the highest
numbered reference designator assigned in the netlist for each
reference designator prefix.

• Unused Ref Des - This column identifies any reference
designators that have not been assigned in the netlist.

• Spare Gates - This column identifies gates that are not being
used in the netlist.  A gate is considered to be spare when it is
not included in the netlist (placed in the schematic).  As an
example, if U1 is a 4 gate device and gates U1/A, U1/C, and
U1/D are placed in a schematic, gate U1/B would be listed as a
spare gate.

The Reference Designator Use report can be generated from Prevue
using Design Manager Tool→ Report Generator, or Schematic
Tool→Report Generator.  It can also be generated from the
command line using the -R option.  The default filename extension
will be .RDU.
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Autorouter

Activation of the Rip-up Pass

MD 8.7 Autorouter will be enhanced to provide for the activation of
the rip-up passes when using the parallel port security device.
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System Limits A
This appendix lists the supported system limits for P-CAD Master
Designer version 8.6.

Table A-1 lists name length limits. Table A-2 lists maximums. Table
A-3 lists other ranges.

Table A-1.  Name Length Limits
Parameter Limit

Attribute keyword 23

Attribute value 255

Bus name (input buffer length) 79

Bus net name length 23

Component name (internal, user assigned) 23

Critical path name length 8

Device name for library member 8

External filename length (including path) 63

Footprint name length 23

Group name length 8

Layer name length 6

Net name (internal, user assigned) 23

Packaging ID (nonhomogeneous parts) 15

Pin name (internal, user assigned) 23

Pin number (alphanumeric) 7

Reference designator length 23

Reference designator prefix  length 3

Schematic sheet ID length 4

Section name length 3

Symbol or part external filename, DOS 8.3

Symbol or part external filename, UNIX 255
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Table A-2.  Maximums
Items Practical Theoretical
Aliases per component 1882
Apertures, number of, Gerber Laser Model 999
Apertures, number of, Gerber Model 32, 33, 41 24
Apertures, number of, Gerber RS-274-X 999
Apertures, number of, MDA Fire 2000 999
Apertures, size, Gerber Laser Model, RS-274-X,
 MDA Fire 2000 .500
Apertures, size, Gerber Model 32, 33, 41 .240
Association distance (placement) 1000
Characters in an aperture macro name 12
Characters in a text string (line) 255
Clearance for placement 1000
Components 32,000 (2,147,483,447)
Components per library archive 800
Filled circle radius 255
Gate types per package 9
Gates per package 5000
Grid spacing 2000
Input buffer, aperture list, Environment!
 Set Inner Plane Aperture 255

Lattice spacing (placement) 5000
Lattices for placement 10
Layer support 100
LEQ codes 127
Message character buffer, /intr 44

Nets 64,000 (2,147,483,447)
Picture blocks 250,000 (2,147,483,447)
Pin count, by wire, Display!Control Ratsnest 512

Pin types (parts) 1000
Pins 250,000 (2,147,483,447)
Pins per component 5000
Polygon aperture width 250
Polygon clearance value 500
Polygon + merged void vertices 10,000
Polygon size (sq. DBUs) 10,240,000
Polygon vertices 10,000
Polygonal void vertices 10,000
Programmable function keys 40
Repeat copy count 255
Snap tolerance value 1000
Stitchable layers 32
Text size (height) 5000
Unique components 32,000  (2,147,483,447)
Via types 50
Wire/line width 255
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Table A-3.  Other Ranges
Type Range Default

Angle range, component rotation -359 to 359

ASCII key code range for hot keys 33-126

Bus bits number range 128

Cartesian coordinates range -30,000 to 30,000

Display range, flash size, PCB Editor 4 to 150 DBUs (60)

Display range, pin size, PCB Editor 4 to 100 DBUs (40)

Display range, pin size, Schematic Editor 1 to 50 DBUs (10)

Display range, solder dot, Schematic Editor 1 to 50 DBUs (10)

Display range, via size, PCB Editor 4 to 100 DBUs (40)

Pin type range (symbols) 0 to 6, 16 to 63

Range, histogram routing grid .01 to 2,000 (50)

Range, histogram signal layers 1 to 20 (2)

Range of D-codes 10-1008

Range of polygon aperture vertices  (or sides) 3-10

Range of ties in a thermal shape description 1-10

Scaling factor range, components 1 to 10,000

Scaling factor range, text 1 to 10,000
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Filename  Extensions B
Table B-1.  Filename Extensions
Extension Description Generated By

.alt Netlist input User (for netlist conversion)

.am Aperture description macro User (for PCB aperture table editor)

.apl Apertures used in design PCB Editor

.apr Aperture table Hardcopy

.atr Attribute Engineering Change Order

.asr Apertures used in plot file Hardcopy

.atr Attribute Engineering Change Order

.bck Back-annotation instruction file PC-PACK

.bka Back-annotation command Engineering Change Order

.bnl Annotated netlist Package Schematic

.cc CalComp plotter vector Hardcopy

.cfg Configuration Any program run from P-CAD 
graphic user interface

.cir Spice file Spice Circuit Writer

.cmd Packaging command log file Package Schematic

.cmd Command log file Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.cm$ Backup command log file Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.cmp Component list report Report Generator

.cth C. Itoh printer format Hardcopy

.ctl Autorouter control (strategy) Autorouter

.dbg Editor debugging Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.dmp Houston Instruments plotter Hardcopy vector

.drc Design rule check report Design Rules Check

.drl Numerically controlled drill data Drill

.dxf DXF format input/output file DXF Reader
DXF Writer

.eco Compare/Analyze phase report Engineering Change Order
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Table B-1.  Filename Extensions (cont’d)

Extension Description Generated By

.edf EDIF fomat input/output file EDIF Reader
EDIF Writer

.eps Epson format Hardcopy

.erc Electrical rule check report Electrical Rules Check

.fil Cross-reference  (ASCII) User (for Package Schematic)

.gbr Gerber format Hardcopy

.his Histogram report PCB Editor

.hp Hewlett-Packard plotter Hardcopy

.hpp Hewlett-Packard  LaserJet Hardcopy
printer format

.ibm IBM printer/plotter format Hardcopy

.icc Interleaf (CC960) format Hardcopy

.ins Component insertion Auto-Insertion

.key Saved function key file User (created in any
graphics editor)

.lgr Gerber laser photoplotter format Hardcopy

.lgx RS-274-X photoplotter format Hardcopy

.log Message log file (DOS) Any program run from P-CAD 
graphic user interface and 
command line

.LOG Message log file (UNIX) Any program run from P-CAD 
graphic user interface and 
command line

.mac macro file User (created in graphics

editor or text editor)

.map DXF translation map file DXF Reader

DXF Writer

.mat Materials list report Report Generator

.mda MDA Fire 2000 photoplotter Hardcopy
format

.mfg NC drill table Drill

.nde Netlist report Report Generator

.nlc Report Netlist Comparison

.nlt Schematic netlist Package Schematic

.nz Bruning (Nicolet) Zeta plotter Hardcopy

.oki Okidata printer format Hardcopy

.out Component name change report Engineering Change Order

.pas Check pass file Design Rules Check (DRC)
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Table B-1.  Filename Extensions (cont’d)

Extension Description Generated By

.pbk Backup PCB Engineering Change Order 
Autorouter

.pdf Database  (ASCII) PDIF  Writer

.pin Pin Information List PCB Editor

.pkg Packaged PCB database Package Schematic

.pkl Packaging list report Report Generator

.plc Placed PCB database User

.plt Plot instruction file (binary) Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.plb PCB part library archive Library Maintenance

.pnl Packaged PCB netlist  (binary) Package Schematic

.ppp plot device configuration file Hardcopy

.prt PCB part Part Editor

.ps Padstack Part Editor

.psc Postscript format Hardcopy

.pty Pin type report  Generate Reports

.rcf Autorouter control  file Autorouter

.rdu Ref des use list report Report Generator

.rep Autorouter report  Autorouter

.rhf Autorouter history file Autorouter

.rpt Part/symbol pin information Component Editor
table report

.rpt Swap report log file PCB Editor

.rp1 Report Convert Netlist to PCB

.rp2 Report Convert Netlist to PCB

.rp3 Report Convert Netlist to PCB

.rp4 Report Convert Netlist to PCB

.rte Autorouter extraction Autorouter

.rts Autorouter solution Autorouter

.rul Design rules file Design Rules Check (DRC)

.sbk Backup schematic database Schematic Editor

.sch Schematic database Schematic Editor

.sdt Solder dot special symbol User

.si Source specification User

.slb Schematic symbol library Library Maintenance
archive

.ssf Special symbol file User (for PCB Editor)

.swr Improve placement log PCB Editor
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Table B-1.  Filename Extensions (cont’d)

Extension Description Generated By

.sym Schematic symbol Symbol Editor

.tbl NC drill table Drill

.upd Update command file Engineering Change Order (ECO)

.wrl Wire list Report Generator

.xnl Expanded schematic netlist Package Schematic

.xrf Nodes cross-reference file Spice Circuit Writer



What’s New for MD 8.7 33

Reserved Words      C
This appendix lists DOS reserved device names and attribute
keywords.

DOS Reserved Device Names
Don’t use the following DOS reserved device names in filename
prefixes:

aux

com1

com2

com3

com4

con

lpt1

lpt2

lpt3

nul

prn

Refer to your DOS manual for more information.
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Attribute Keywords
Certain keywords have predefined functions in specific tools. Table
C-1 lists the keywords and tools.

Table C-1.  Reserved Keywords With Predefined Functions
Keyword Tool

CARDx (where x is a number) SPICE Circuit Writer

COMPARE=MECH Part Editor, PCB Editor

DEVICE EDIF Netlist Reader
EDIF Netlist Writer

FP Part Editor
PCB Editor

INCLx (where x is a number) SPICE Circuit Writer

NET Symbol Editor
Schematic Editor

PACKAGE EDIF Netlist Reader
EDIF Netlist Writer

PCERC Electrical Rules Check

PGCONN EDIF Netlist Reader
EDIF Netlist Writer
Electrical Rules Check

PINATT? EDIF Netlist Reader
EDIF Netlist Writer

PNAME SPICE Circuit Writer

PREFIX Symbol Editor

PRT Symbol Editor
Schematic Editor
Package Schematic

PWGD Symbol Editor
Schematic Editor
Package Schematic
Component Editor

PWGDi (where i is a number) Symbol Editor
Schematic Editor
Package Schematic
Component Editor

REFDPRE SPICE Circuit Writer
EDIF Netlist Writer

RVALUE Electrical Rules Check

SHEET Symbol Editor
Schematic Editor
Electrical Rules Check

SNAME SPICE Circuit Writer

S$P SPICE Circuit Writer

SPCC SPICE Circuit Writer
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Table C-1.  Reserved Keywords With Predefined Functions (con’t)
Keyword Tool

SPGN SPICE Circuit Writer

SPINIT SPICE Circuit Writer

SPMI SPICE Circuit Writer

SPPx (where x is a number)  SPICE Circuit Writer

SPTI SPICE Circuit Writer

SPVC SPICE Circuit Writer

TARGET Auto-Insertion
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Button Menu Trees D
This appendix contains menu trees for button menus that appear in
a graphics editor when you choose the MnBtn option in the status
area.
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Symbol Editor

Save

Load

Plot

Clear Db.

Level Push

Level Pop

Print

Quit

File

Text
Line
Rectangle

Filled Rect

Circle

Filled Circ

2 Pt. Arc

3 Pt. Arc

Draw
Add Vertex
Move Vertex

Del. Vertex
Attribute

Del Segment

Pkg. Data

Pin Type

Seg. Layer

Mov Segment

Keyword

Edit

Pin Sequenc

Comp. Type

Pin

Attribute

Origin

Pkg. Data

Pin Type

Enter

Object
Pin
Properties

Query

Pin

Name
Object

Objects

Window

Attribute

Undo

Move
Object

Objects

Window

Copy
Object

Objects

Window

Attribute

Chg.
Layer

Object
Objects
Window

Undo

Rotate
Object
Objects
Window

Attribute

Undo

Delete

Store View

Recall View

Long Pan

Measure

Display

Environment
DOS Shell (DOS only)
Change Unit
Statistics

Snap Tol.

Mask Items

Detail Mode

Figure D-1.  The Symbol Editor Button Menu Tree
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Schematic Editor

Save
Load
Plot
Save Block

Load Block
Clear Db.
Level Push
Level Pop

Print
Quit

File

Text
Line
Rectangle
Filled Rect

Circle
Filled Circ
2 Pt. Arc
3 Pt. Arc

Draw

Move All
Wire
Add Vertex
Move Vertex

Del. Vertex
Attribute
Del Segment
Seg. Layer

Mov Segment
Keyword
Net Attr

Edit

Wire
Bus
Component
Uncomm. Pin

Attribute
Repl. Comp
RefDes/Sect
Global Net

Enter

Object
Net
Component
Pin

Crit. Path
Group
Properties

Query

Net
Subnet
Component

Name

Object
Objects
Window
Component

Attribute
Undo
Crit. Path
Group

Move

Object
Objects
Window

Copy

Object
Objects
Window

Attribute

Chg.
Layer

Object
Objects
Window
Component

Undo

Rotate

Object
Objects
Window
Attribute

Undo

Delete

Add Gate
Remove Gate
Change Name
Break Link

Remove Def.

Crit. Path

Add Gate
Remove Gate
Change Name

Remove Def.

Group

Environment

DOS Shell (DOS only)
Change Unit
Statistics
Snap Tol.

Attach Dots
Mask Items
Symbol Mode

Store View
Recall View
Long Pan
PthGrp Vis.

Measure

Display

Figure D-2.  The Schematic Editor Button Menu Tree
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Part Editor

Save

Load

Plot
Clear Db.
Level Pop

Print
Quit

File

Text

Line
Rectangle
Filled Rect
Circle

Filled Circ

2 Pt. Arc
3 Pt. Arc
Polygon

Flash
Circ. Void

Poly. Void

Draw
Add Vertex

Move Vertex
Del. Vertex
Attribute
Undo

Pkg. Data

Pin Type
Seg. Layer
Mov Segment

Del Segment
Keyword

Edit

Pin Sequenc

Comp. Type

Pin
Attribute
Mixed Pkg.

Origin
Jumper

Pkg. Data
Pin Type

Enter

Object

Pin
Properties

Query

Pin

Name

Object

Objects

Window
Attribute
Undo

Move

Object

Objects

Window

Copy

Object

Objects

Window
Attribute

Chg.
Layer

Object

Objects
Window
Undo

Rotate
Object

Objects
Window
Attribute
Undo

Delete

Store View

Recall View

Long Pan
Measure

Display

Environment
DOS Shell (DOS only)

Change Unit
Statistics
Snap Tol.
Aper. Table

Figure D-3.  The Part Editor Button Menu Tree
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PCB Editor

Save

Load

Plot

Save Block

Load Block

Clear Db.

Push Padstack
Level Push

Print

Quit

File

Text

Line

Rectangle

Filled Rect

Circle

Filled Circle

2 Pt. Arc

3 Pt. Arc

Polygon

Flash

Circ. Void

Poly. Void

Draw

Move All

Wire

Add Vertex

Move Vertex

Del. Vertex

Attribute

Trace

Undo

Add Via

Move Via

Delete Via

Seg. Layer

Mov Segment

Del Segment

Trace Width

Keyword

Net Attr

Edit

Wire

Ratsnest

Component

Uncomm. Pin

Attribute

Repl. Comp

Origin

Polygon

Enter

Object

Net

Net Pins

Component

Pin

Via

Trace

Net Vias

Polygon

Poly Window

Crit. Path

Group

Padstack

Apertures

Properties

Query

Net

Subnet

Component

Reseq Refd.

Reseq Wind.

Name

Object

Objects

Window

Component

Attribute

Undo

Crit. Path

Group

Move

Object

Objects

Window

Trace

Copy

Object

Objects

Window

Component

Attribute

Chg.
Layer

Object

Objects

Window

Component

Undo

Rotate

Object

Objects

Window

Attribute

Trace

Undo

Delete

Add Gate

Remove Gate

Change Name

Break Link

Remove Def.

Crit. Path

Add Gate

Remove Gate

Change Name

Remove Def.

Group

Component

Pin

Gate

Undo

Swap

Dimension

Configure

Point

Datum

Leader

Center One

Center All

Diameter

Radius

Angular

Adjust

Bind

Unbind

Figure D-4.  The PCB Editor Button Menu Tree
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PCB Editor (con’t)

Store View
Recall View
Long Pan
PthGrp Vis.
Ctrl Rats.
Measure

DisplayEnvironment

DOS Shell (DOS only)
Change Unit
Statistics
Snap Tol.
Attach Pads
Mask Items
Layer Pairs
Void Merge
Min PolySiz
Min PolyClr
Inr Pln Apr
Set Min Apr
Aper. Table
Clear Flash
Min FlshClr

Objects
Window
Component
Undo

Align Placement

Spacing
Def. Comps
Clearances
Association
Barriers
Cutlines
Fix
Unfix
Autoplace
Histogram

➨

➨

Enter
Delete

Barriers

Window
Component

Fix

Window
Component

Unfix

Configure
Grid
Gen. Stats
Reset Merit

Histogram

Component
Gate

Improve Plc

➨

Figure D-4.  The PCB Editor Menu Tree (cont’d)
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Command Cross Reference E
This appendix contains a command cross-reference, a list of default
hot-key functions, and a chart of the keys available for hot-key
assignment.

Table E-1 contains a complete cross-reference of MD 5.0 and MD
8.7 graphic editor commands and keyboard-equivalent  commands.
Refer to the Command Reference manual for a complete description
of each command.

Commands are listed in alphabetical order by the MD 8.7
commands. Commands that appear in lower case, such as /rctl,
have no equivalent menu command for the P-CAD version they’re
listed under. Keyboard and keyboard-equivalent commands are not
case-sensitive.

Table E-1.  Command Cross Reference
MD 8.7 Keyboard

MD 5.0 Command MD 8.7 Command Equivalent

a (wire bend hot key) a a
a a /bend
n/a /ably /ably
ALGN Align→Components ALGN
ALGN/IDEN Align→Objects ALGN/IDEN
ALGN/UNDO Align→Undo ALGN/UNDO
ALGN/WIN Align→Window ALGN/WIN
/alyr /alyr /alyr
ATTR/DATR Delete→Attribute DEL/ATRB
c (curved wire hot key) c c
c c /wcrv
/cfil /cfil /cfil
n/a Chg. Layer→Attribute CLYR/ATRB
CLYR/COMP Chg. Layer→Component CLYR/COMP
FLIP Chg. Layer→Component CLYR/COMP
CLYR Chg. Layer→Object CLYR
CLYR/IDEN Chg. Layer→Objects CLYR/IDEN
CLYR/WIN Chg. Layer→Window CLYR/WIN
COPY Copy→Object COPY
COPY/IDEN Copy→Objects COPY/IDEN
COPY/TRCE Copy→Trace COPY/TRCE
COPY/WIN Copy→Window COPY/WIN
/cpos /cpos /cpos
CPTH/TAG Crit. Path→Add Gate CPTH/TAG
CPTH/UNLK Crit. Path→Break Link CPTH/UNLK
CPTH/RNAM Crit. Path→Change Name CPTH/RNAM
CPTH/RSET Crit. Path→Remove Definition CPTH/RSET
CPTH/UTAG Crit. Path→Remove Gate CPTH/UTAG
ATTR/DATR Delete→Attribute DEL/ATRB
DEL Delete→Object DEL
DEL/IDEN Delete→Objects DEL/IDEN
DEL/TRCE Delete→Trace DEL/TRCE
DEL/UNDO Delete→Undo DEL/UNDO
DEL/WIN Delete→Window DEL/WIN
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 n/a Dimension→Adjust ADIM/AJST
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Table E-1.  Command Cross Reference (cont’d)
MD 8.7 Keyboard

MD 5.0 Command MD 8.7 Command Equivalent
n/a Dimension→Angular ADIM/ANGL
n/a Dimension→Bind ADIM/DGRP
n/a Dimension→Center All ADIM/CALL
n/a Dimension→Center One ADIM/CONE
n/a Dimension→Configure ADIM/CNFG
n/a Dimension→Datum ADIM/DATM
n/a Dimension→Diameter ADIM/DIAM
n/a Dimension→Leader ADIM/LEAD
n/a Dimension→Point ADIM/PONT
n/a Dimension→Radius ADIM/RADI
n/a Dimension→Unbind ADIM/UGRP
/rctl Display→Control Ratsnest RCTL
/lpan Display→Long Pan LPAN
/rulr Display→Measure RULR
/pctl Display→Path/Group Visiblity PCTL
RCL Display→Recall View RCL
n/a Display→Recall View 1 RC1
n/a Display→Recall View 2 RC2
n/a Display→Recall View 3 RC3
n/a Display→Recall View 4 RC4
n/a Display→Recall View 5 RC5
n/a Display→Recall View 6 RC6
n/a Display→Recall View 7 RC7
n/a Display→Recall View 8 RC8
n/a Display→Recall View 9 RC9
n/a Display→Recall View 10 RC10
STO Display→Store View STO
n/a Display→Store View 1 ST1
n/a Display→Store View 2 ST2
n/a Display→Store View 3 ST3
n/a Display→Store View 4 ST4
n/a Display→Store View 5 ST5
n/a Display→Store View 6 ST6
n/a Display→Store View 7 ST7
n/a Display→Store View 8 ST8
n/a Display→Store View 9 ST9
n/a Display→Store View 10 ST10
DRAW/ARC Draw→2-Point Arc DRAW/ARC
DRAW/ARCP Draw→3-Point Arc DRAW/ARCP
DRAW/CIRC Draw→Circle DRAW/CIRC
DRAW/CVOD Draw→Circular Void DRAW/CVOD
n/a Draw→Filled Circle DRAW/FCIR
DRAW/FREC Draw→Filled Rectangle DRAW/FREC
DRAW/FLSH Draw→Flash DRAW/FLSH
DRAW/LINE Draw→Line DRAW/LINE
DRAW/POLY Draw→Polygon DRAW/POLY
DRAW/PVOD Draw→Polygonal Void DRAW/PVOD
DRAW/RECT Draw→Rectangle DRAW/RECT
DRAW/TEXT Draw→Text DRAW/TEXT
n/a /dly /dly
/drc /drc /drc
/dyn /dyn /dyn
EDIT/ADDV Edit→Add Vertex EDIT/ADDV
EDIT/AVIA Edit→Add Via EDIT/AVIA
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ATTR/SCHG Edit→Attribute EDIT/ATRB
EDIT/DELS Edit→Delete Segment EDIT/DELS
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Table E-1.  Command Cross Reference (cont’d)
MD 8.7 Keyboard

MD 5.0 Command MD 8.7 Command Equivalent
n/a Edit→Delete Trace EDIT/TRCE
EDIT/DELV Edit→Delete Vertex EDIT/DELV
EDIT/DVIA Edit→Delete Via EDIT/DVIA
n/a Edit→Keyword EDIT/KWD
EDIT/MOVA Edit→Move All EDIT/MOVA
EDIT/MOVS Edit→Move Segment EDIT/MOVS
EDIT/MOVV Edit→Move Vertex EDIT/MOVV
EDIT/MVIA Edit→Move Via EDIT/MVIA
n/a Edit→Net Attr EDIT/NATR
SCMD/EPKG Edit→Packaging Data EPKG
SCMD/EPNL Edit→Packaging Data EPNL
n/a Edit→Pin Type EDIT/SPAT
EDIT/LAYS Edit→Segment Layer EDIT/LAYS
n/a Edit→Trace Width EDIT/TWID
/undo Edit→Undo Delete Segment UNDO
EDIT/WIRE Edit→Wire EDIT/WIRE
ATTR/ACOM Enter→Attribute ENTR/ATRB
ENTR/ORG Enter→Board Origin ENTR/ORG
ENTR/BUSB Enter→Bus ENTR/BUSB
ENTR/COMP Enter→Component ENTR/COMP
SCMD/SCAT Enter→Component Type ENTR/SCAT
SCMD/SNAT Enter→Global Net ENTR/SNAT
SCMD/JMPR Enter→Jumper ENTR/JMPR
SCMD/NPKG Enter→Nonhomogeneous Pkg ENTR/NPKG
ENTR/ORG Enter→Origin ENTR/ORG
SCMD/PNLC Enter→Packaging Data ENTR/PNLC
SCMD/SPKG Enter→Packaging Data ENTR/SPKG
ENTR/PIN Enter→Pin ENTR/PIN
ENTR/SEQ Enter→Pin Sequence ENTR/SEQ
SCMD/SPAT Enter→Pin Type ENTR/SPAT
ENTR/POLY Enter→Polygon ENTR/POLY
ENTR/RATN Enter→Ratsnest ENTR/RATN
NAME/REFD Enter→Ref.Des.& Section ENTR/PNUM
SCMD/PNUM Enter→Ref.Des.& Section ENTR/PNUM
/repl Enter→Replace Component REPL
ATTR/ACOM Enter→Sheet Number ENTR/SHID
ENTR/UCOM Enter→Uncommit Pin ENTR/UCOM
ENTR/WIRE Enter→Wire ENTR/WIRE
SCMD/LPAR Environment→Assign Layer Pairs LPAR
SCMD/GSSF Environ.→Attach Cust.Sold.Dots GSSF
SCMD/GSSF Environment→Attach Padstacks GSSF
SCMD/UNIT Environment→Change Units UNIT
SYS/DOS Environment→DOS Shell DOS
DETL Environment→Detail Mode DMOD
SYS/STAT Environment→Display Statistics STAT
n/a Environment→Edit Aperture Table ATE
SCMD/SIPC Environ.→Inner Plane Apertures SIPC
/mask Environment→Mask Items MASK
/msk Environment→Mask Items MSK
SCMD/VMRG Environ.→Merge Polygon Voids VMRG
n/a Environ.→Merge Voids by Layer VMBL
n/a Environ.→Merge Voids by Poly VMBP
SCMD/PSIZ Environment→Min. Polygon Size PSIZ



Command Cross Reference

50 What’s New for MD 8.7

SCMD/PCLR Envir.→Polygon Wire Clearance PCLR
n/a Environ.→Set Minimum Aperture MAPW
/sgat Environment→Set Snap Tolerance SGAT
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Table E-1.  Command Cross Reference (cont’d)
MD 8.7 Keyboard

MD 5.0 Command MD 8.7 Command Equivalent
SYMB Environment→Symbol Mode SMOD
/exe /exe /exe
/exec /exec /exec
n/a /fast /fast
FILE/ZAP File→Clear Database FILE/ZAP
SYS/PLOT File-Create Plot File FILE/PLOT
FILE/POP File→Level Pop FILE/POP
LEVL/POP File→Level Pop FILE/POP
FILE/PUSH File→Level Push FILE/PUSH
LEVL/PUSH File→Level Push FILE/PUSH
FILE/LOAD File→Load FILE/LOAD
FILE/BKLD File→Load Block FILE/BKLD
n/a File→Print FILE/PRINT
n/a File→Push Padstack FILE/PUPS
SYS/QUIT File→Quit FILE/QUIT
FILE/SAVE File→Save FILE/SAVE
FILE/BKSV File→Save Block FILE/BKSV
/fit Fit View FIT
/fitv Fit View FITV
n/a /grid /grid
GRP/TAG Group→Add Gate GRP/TAG
GRP/RNAM Group→Change Name GRP/RNAM
GRP/RSET Group→Remove Definition GRP/RSET
GRP/UTAG Group→Revome Gate GRP/UTAG
IMPR/COMP Improve Plc→Components IMPR/COMP
IMPR/GATE Improve Plc→Gates IMPR/GATE
/intr /intr /intr
/lang /lang /lang
/lsty /lsty /lsty
/lwid /lwid /lwid
/lyrn /lyrn /lyrn
n/a Last View PREV
/mac /mac /mac
n/a Main Menu /main
/mend /mend /mend
n/a /menu /menu
MOVE/ATRB Move→Attribute MOVE/ATRB
MOVE/COMP Move→Component MOVE/COMP
MOVE/APTH Move→Critical Path MOVE/CPTH
MOVE/AGRP Move→Group MOVEAGRP
MOVE Move→Object MOVE
MOVE/IDEN Move→Objects MOVE/IDEN
MOVE/UNDO Move→Undo MOVE/UNDO
MOVE/WIN Move→Window MOVE/WIN
NAME/COMP Name→Component NAME/COMP
NAME/NET Name→Net NAME/NET
NAME/PIN Name→Pin NAME/PIN
NAME/RSEQ Name→Reseq. Ref. Desd NAME/RSEQ
n/a Name→Reseq. Window NAME/SEQW
NAME/SUBN Name→Subnet NAME/SUBN
/ofly /ofly /ofly
n/a /only /only
n/a /osel /osel
PAN Pan PAN
Pan Bars Shift Pan [SHIFT]+[Btn 1]
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/pdel /pdel /pdel
/pend /pend /pend
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Table E-1.  Command Cross Reference (cont’d)
MD 8.7 Keyboard

MD 5.0 Command MD 8.7 Command Equivalent
/pkey /pkey /pkey
/pkld /pkld /pkld
/pksv /pksv /pksv
/pzap /pzap /pzap
PLCE Placement→Automatic Placement PLCE
BARR/DEL Placement→Define Barriers→Delete BARR/DELB
BARR/DELB Placement→Define Barriers→Delete BARR/DELB
BARR Placement→Define Barriers→Enter BARR
ASSC Placement→Define Lattices→ ASSC

Associate Discretes
LATC Placement→Define Lattices→ LATC

   Define Components
LATP Placement→Define Lattices→ LATP

   Enter Spacing
CLR Placement→Define Lattices→ CLR

   Specify Clearance
CUT Placement→Enter Cutlines CUT
FIX Placement→Fix→Component FIX
FIX/WIN Placement→Fix→Window FIX/WIN
HIST/CNFG Placement→Histogram→Configure HIST/CNFG
HIST/GRID Placement→Histogram→Define Grid HIST/GRID
HIST/STAT Placement→Histogram→ HIST/STAT

   Generate Statistics
HIST/RSET Placement→Histogram→ HIST/RSET

   Reset Merit Factor
UNFX Placement→UnFix→Component UNFX
UNFX/WIN Placement→UnFix→Window UNFX/WIN
n/a Query→Apertures QRY/APRS
QRY/COMP Query→Component QRY/COMP
QRY/APTH Query→Critical Path QRY/APTH
QRY/AGRP Query→Group QRY/AGRP
QRY/NET Query→Net QRY/NET
QRY/NPIN Query→Net Pins QRY/NPIN
n/a Query→Net Vias QRY/NVIA
QRY Query→Object QRY
QRY/PSTK Query→Padstack QRY/PSTK
QRY/PIN Query→Pin QRY/PIN
n/a Query→Polygon QRY/POLY
n/a Query→Polygon Window QRY/PWIN
n/a Query→Properties QRY/PROP
n/a Query→Trace QRY/TRCE
QRY/VIA Query→Via QRY/VIA
/rcmn n/a n/a
RCL Recall View RCL
REDR Redraw REDR
n/a /regn /regn
/resu /resu /resu
n/a /rnsp /rsnp
ROT/COMP Rotate→Component ROT/COMP
ROT Rotate→Object ROT
ROT/IDEN Rotate→Objects ROT/IDEN
ROT/UNDO Rotate→Undo ROT/UNDO
ROT/WIN Rotate→Window ROT/WIN
/stgl /stgl /stgl
SWAP/COMP Swap→Component SWAP/COMP
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Table E-1.  Command Cross Reference (cont’d)
MD 8.7 Keyboard

MD 5.0 Command MD 8.7 Command Equivalent
SWAP/GATE Swap→Gate SWAP/GATE
SWAP/PIN Swap→Pin SWAP/PIN
SWAP/UNDO Swap→Undo SWAP/UNDO
n/a /tmod  /tmod
/ucp /ucp /ucp
/undo /undo /undo
VLYR View Layer VLYR
VSAV n/a n/a
VWIN View Window VWIN
/wait /wait /wait
x (full screen cursor x (full screen cursor hot key) x
  hot key)
x x /xhar
ZIN Zoom In ZIN
ZOUT Zoom Out ZOUT
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Table E-2 describes the default hot-key assignments for MD 8.7
commands or functions. Hot keys for subcommands will be
recognized only if the main menu command has already been
executed. For example, to move a wire vertex, press E to activate
Edit, then G to execute the Move→Vertex command.

Table E-2.  Default Hot Key Key Functions
Key Command or Function

a Toggle wire bend
b Delete Vertex
c Toggle curved wire (PCB Editor only)
d Delete
e Edit
f File
g Move Vertex
h Delete Segment
 i Wire
 j Move Segment
 k Component
 l Load
m Move
n Enter
o Objects
p Pan
q Query
r Rotate
Alt+R rotate clockwise
Ctrl+R rotate counterclockwise
Shft+s Snap to Object (Measure)
s Save
t Trace (PCB Editor only)
u Undo
v Add Vertex
w Window
x Cursor type (regular, vertical or diagonal cross hair)
y Segment Layer
z, +,= Zoom In
Z*, - Zoom Out

* Note:  Except for Z only lower-case keys have default functions.
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Table E-3 contains a chart of the ASCII characters available for hot-
key assignment in MD 8.7.

Table E-3.  ASCII Key Codes Available For Hot Key Assignment
ASCII Key Codes

↓ Left Right
Digit Digit 0 1 2 3 4 5 6 7 8 9

3 ! ” # $ % & ’
4 ( ) * + , - . n/a 0 1
5 2 3 4 5 6 7 8 9 : ;
6 < = > ? @ A B C D E
7 F G H I J K L M N O
8 P Q R S T U V W X Y
9 Z [ \ ] ^ - ‘ a b c
10 d e f g h I j k l m
11 n o p q r s t u v w
12 x y z { | } ˜

ASCII key codes range from 00 to 127. The following characters or
ASCII key codes aren’t available for hot-key assignment:

• 00 to 31 and 127 aren’t available because they’re nonprintable
control characters

• 47 (/) is reserved for initiating keyboard commands
• 32 represents a blank and isn’t available for user assignment
• Shift, Ctrl, Alt, ◊, <, and > can’t be used to assign commands or

functions to P-CAD hot keys

This appendix lists a command cross-reference, default hot key
functions, and a chart of keys available for hot keys.
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