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About This Manual
This manual is for those of you who are upgrading to Master
Designer 8.6. It explains all the new features and changes that have
been made since Master Designer 8.5. By reading this manual, you'll
be able to see at a glance what's new and different in Master
Designer 8.6.

This manual consists of four chapters and five appendixes. A
conventions page follows this section.

Chapter 1 "What's New" describes what's new throughout Master
Designer 8.6, such as an improved selection
mechanism, enhanced file selectors, standard design
files, new net attributes, selecting components by
name, centering horizontal text, deleting unused layers,
and auto-incrementing reference designators.

Chapter 2 "What's New in the Utilities" describes what's new in the
Master Designer 8.6 utilities, including enhanced net
attribute support in DRC, AIX support for online
documentation, scaling apertures, plotting multiple plot
files, and a pin information list.

Chapter 3 "Updated Commands" describes the commands
updated for Master Designer 8.6.

Chapter 4 "New Commands" describes the new menu and
keyboard commands for Master Designer 8.6.

Appendix A "System Limits" describes name length limits;
maximums for database items such as pins,
components, and nets; and ranges for other items.

Appendix B "Filename Extensions" lists the P-CAD filename
extensions and the tools that produce the files.

Appendix C "Reserved Words" lists DOS reserved device names
and P-CAD attribute keywords.

Appendix D "Button Menu Tree" contains a graphical menu tree for
the Button Menus.

Appendix E "Command Cross Reference" contains a command
cross-reference, a list of default hot-key functions, and
a chart of the keys available for hot-key assignment.
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Conventions
This manual uses the following conventions:

→ or ! Connects commands. Commands following the arrow
appear on submenus. For example

File!Load  or  FileÕLoad

* One or more characters can occupy the asterisk's
position. Also known as a wildcard.

* In text, introduces a procedure that explains how to do
a task.

 Press the keys simultaneously. For example

The return key. Press this key after typing data in a data
entry box or on a message line or to accept a default. You
can click left in many P-CAD tools instead of pressing        .

Enter or ↵↵ Indicates you need to press          after typing data.

The space bar. You can use this key to digitize a point
within the drawing area.

italics Indicates variable characters.

boldface Indicates characters you enter from the keyboard;

for example

Enter sheet7  in the data entry box.

−

Shift F1−

↵

↵

↵

Space
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boldface italics Indicates variable characters you enter from

the keyboard; for example

Enter filename  in the data entry box.

Click left Press and release the left button (button 1) on the
mouse.

Click middle Press and release the middle button (button 2) on
the mouse.

Click right Press and release the right button (button 3) on the
mouse. If you are using a two-button mouse, press

        and button 2 simultaneously to clickright.

Cycle Click left repeatedly on a cycle box until the item
you want is selected. A cycle box is indicated by
    .

Select Move the cursor to an item or point and press        ,
            , or click left.

Ctrl

Space

↵
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What's New 1
P-CAD Master Designer 8.6 (MD 8.6) gives you the power and
flexibility to create electronic circuit designs and PCB (printed circuit
board) layouts from start to finish. With its many enhancements,
however, MD 8.6 lets you complete your designs even faster than
before.

Graphic Editors

Improved Selection Mechanism

With many commands, the selection mechanism now selects the
object closest to the cursor on the active layer that is within snap
tolerance.  This makes it easier for you to predict which object will
be selected first.  The affected commands are:

• Change Layer→Object

• Change Layer→Objects

• Copy→Object

• Copy→Objects

• Delete→Object

• Delete→Objects

• Delete→Trace

• Edit→Move Vertex

• Edit→Delete Vertex

• Edit→Move Segment

• Edit→Delete Segment

• Edit→Move Via

• Edit→Delete Via

• Edit→Segment Layer

• Edit→Delete Trace

• Edit→Trace Width
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• Move→Object

• Move→Objects

• Query→Trace

• Query→Net

• Query→Object

• Query→Via

• Query→Properties

• Rotate→Object

• Rotate→Objects

For those objects that Master Designer does not apply snap
tolerance to, such as components, attributes, or polygons, Master
Designer lets you select these objects when the cursor is within their
boundaries.

If more than one object is within snap tolerance and at the same
distance from the cursor, Master Designer prioritizes which objects
to select.  The order of priority is (from highest to lowest):

• objects on the active layer

• objects on the ABL layer

• objects on any layer set to ON

• components

• vias, in the following order of priority

 objects on the active layer

 objects on the ABL layer

 objects on any layer set to ON

• nets, in the following order of priority

 objects on the active layer

 objects on the ABL layer

 objects on any layer set to ON

• draw objects, in the following order of priority

• objects on the active layer

• objects on the ABL layer

• objects on any layer set to ON
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You can use the new /osel keyboard command to switch between
the new selection method and to the selection method used in
previous versions of Master Designer.

If your existing Master Designer macros require the old selection
method, you can also use the /osel command in your existing Master
Designer macros to switch between the old and new selection
methods, as in the example below:

MACRO 850 -400
Opcode 192 0
Text osel
Text 1
B1 850 -450
B1 900 -750
Opcode 192 0
Text osel
Text 0
Opcode 192 0
Text mend
END_MACRO

In this example, the statements

Text osel
Text 1

activate the old selection method by setting osel to 1.  Conversely,
the statements

Text osel
Text 0

reactivate the new selection method by setting osel to 0.

Improved Toggling Between Selected and
Unselected Objects

MD 8.6 features improved selection abilities for any command that
selects groups of objects or windows of objects.  Using any of these
commands, you can now deselect any selected object.  The first
time you click on an object, MD 8.6 adds the object to the list of
selected objects and indicates this by highlighting the object.  The
second time you click on it, Master Designer deselects it and
removes it from the selection group.  Deselected objects are
unhighlighted as they are removed from the selection group.  The
affected commands are:

• Change Layer→Objects

• Copy→Objects

• Delete→Objects
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• Move→Objects

• Rotate→Objects

If you’re selecting a window of objects, Master Designer prompts you
for another point after you select the window coordinates.  To select
or deselect an object, press the Ctrl  key and click on the desired
object.  Repeat this process until you have selected or deselected all
desired objects.  Once you click on a point without pressing the Ctrl
key, Master Designer accepts this as the requested point.  The
affected commands are:

• Copy→Window

• Move→Window

• Rotate→Window

If you use the Delete→Window command, then after you select the
window coordinates, Master Designer displays the prompt:

OK to Delete? Yes, No or Modify

At this message, select Yes, No, or Modify.  If you select Yes,
Master Designer deletes all objects in the window.  If you select No,
Master Designer exits the command.  If you select Modify, you can
select or deselect more objects, then click Mouse Button 2 to
redisplay the prompt.

If you use the Chg. Layer→Window command, then after you select
the window coordinates, Master Designer displays the prompt:

OK to Change? Yes, No or Modify

At this message, select Yes, No, or Modify.  If you select Yes,
Master Designer changes all the layers of objects in the window to
the active layer.  If you select No, Master Designer exits the
command.  If you select Modify,  you can select or deselect more
objects, then click Mouse Button 2 to redisplay the prompt.

Enhanced File Selectors

In Master Designer 8.6, all file selectors and picklists let you change
directories when prompting you for a filename.  You can now either
load a file from the current directory, or switch to another directory
and load a file from there.  The enhanced file selectors and picklists
make it easier for you to load designs from different directories.
This feature applies to all commands that use file selectors, such as
Environment→Attach Padstacks, Environment→Edit Aperture
Table→Load Aperture Table, and File→Load.
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Design Manager

Standardizing Design Files

To support corporate design standards, the Design Manager lets you
specify a single location for the following design files:

• special symbol files (.ssf)

• aperture table files (.apr)

• design rules files (.rul)

• check pass files (.pas)

• padstack files (.ps)

• NC drill table files (.tbl)

The Design Maintenance Screen, shown in Figure 1-1 now includes
a System Directory field which lets you specify a System Directory
where these design files reside.  Master Designer adds this
information to the pcad.cfg file.  When you run any command that
accesses any of the files listed above, such as Environment→Attach
Padstacks, Master Designer automatically checks the System
Directory for the appropriate file.  If the file is not in the system
directory, Master Designer checks the current design directory.

The System Directory field is a global option that applies to all
design directories under which you run Master Designer.  This is
unlike the cross-reference file (.fil), which can be different for each
design directory.  When you change the System Directory field, it
applies to all design directories.

Note:   In the case of Environment→Attach Padstacks, Master
Designer looks for padstack files in the same directory as the special
symbol file, unless the special symbol file contains a path pointing to
a different directory along with the padstack file name.
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Figure 1-1:  Design Maintenance Screen

Also, each time you create a new design, the Design Manager
automatically copies the caps.cfg and cards.cfg files from the
directory specified in the PCAD_CFG environment variable (either
the system directory or the current design directory) to the new
design directory.

Acceptable Filename Characters

Master Designer lets you use a wide range of characters for file
names, part names, part numbers, and pin names and numbers.
Table 1-1 lists the acceptable characters for file names.

Table 1-1.  Acceptable Characters for Filenames
Alphanumeric Acceptable Characters
File names 0-9  A-Z _ -
Part number 0-9  A-Z all characters except blank
Pin/net name 0-9  A-Z _ - ' ~
Pin number 0-9  A-Z

The characters : and . act as DOS functions and therefore can’t be
used in file names.

PCB Editor

Selecting Components By Name

More commands in Master Designer 8.6 let you select a component
by name, just as the Query→Component command does, by
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selecting the ByName button in the Status Area and entering a
name.  The affected commands are:

• Rotate→Component (both PCB and Schematic editors)

• Chg. Layer→Component

• Align→Component

• Placement→Fix→Component

• Placement→UnFix→Component

Chapter 3, “Updated Commands” explains how you can select
components by name using these commands.

Hot keys for Rotating Components

Master Designer 8.6 features new hot keys for rotating components
90 degrees clockwise or counterclockwise.  The hot keys for rotating
components are:

• Ctrl-R  - for rotating clockwise

• Alt-R  - for rotating counterclockwise

These hot keys work with the Move→Component and
Enter→Component commands.

Hot keys for Zooming

You can also use hot keys for zooming in and zooming out of the
current cursor position.  The hot keys for zooming are:

• + (plus) - for zooming in

• - (minus) - for zooming out

New Net Attributes

Master Designer 8.6 now includes new system net attributes to
enhance Design Rules Checking on a net by net basis.  You can
enter these net attributes while in the Schematic Editor, then
package them into a PCB design.  Or you can just enter them
directly into the PCB design in the PCB Editor.  Then, when you run
online DRC, the program can use these values to override the
default clearances set for the nets that have net attributes attached
to them.  You can also use the net attributes in CCT SPECCTRA
Router.
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Table 1-2:  New System Net Attributes

Net Attribute Description

CLEARANCE Overrides the general DRC (trace-to-trace,
pad-to-trace, trace-to-board edge, and
pad-to-board edge) spacing.

PAD-TO-EDGE Overrides the pad-to-board edge DRC
spacing.

PAD-TO-TRACE Overrides the pad-to-trace DRC spacing.

TRACE-TO-EDGE Overrides the trace-to-board edge DRC
spacing.

TRACE-TO-
TRACE

Overrides the trace-to-trace DRC spacing.

VIATYPE Specifies the via type to be used during
the Enter→Wire command.

The Edit→Net Attribute and Query→Properties commands can be
used to edit or check the values of the net attributes.  The
commands will check that their values are valid.

The Net Attributes dialog box features a list box containing keywords
for all of the system net attributes.  To use any of these net
attributes, select the desired keyword from the keyword list box, or
you can just enter a net attribute keyword and value.  If you select a
net attribute keyword from the keyword list box, Master Designer
copies the keyword to the Keyword edit box and prompts you for a
new value, as shown in Figure 1-2:
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Figure 1-2:  Net Attributes dialog box

With any net in your design, you can use any of the net attributes
separately or in any combination with each other.

Also, when you run DRC, system net attributes overrule DRC’s own
default values, in the following order of importance.

1. net attributes TRACE-TO-TRACE, PAD-TO-TRACE,
TRACE-TO-EDGE, and PAD-TO-EDGE, all of which have
equal priority and override the CLEARANCE net attribute

2. CLEARANCE net attribute, which overrides the default DRC
spacing values

3. default DRC spacing values

See the Design Rules Checking section of Chapter 2 for more
details about how DRC supports the new net attributes.

Enhanced Ratsnest Display Performance

Master Designer 8.6 features an improved ratsnest display.  In
addition to turning dynamic ratsnest display on and off, you can now
use the /dly command to configure the time delay for the ratsnest
rubberband.  This feature is useful because it lets you adjust the
ratsnest display to better suit how you want the system to perform.

To set the dynamic ratsnest delay

1. Enter /dly.  The system prompts
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 Dynamic Ratsnest Delay=n. New value=

2. Enter a number between .01 and 1 (in seconds).  Or you can

press ↵↵ to accept the current value.

Entering a number between .01 and 1 sets the dynamic ratsnest
delay (in seconds) at that number.

The /dly keyboard command applies to these commands:

• Enter→Wire

• Edit→Enter Wire

• Move→Component

Dimensions: Centered Horizontal Text

Master Designer 8.6 now displays and plots horizontal text that is
centered between vertical dimension lines.  To do this, the system
calculates the space between vertical dimension lines and places
the dimension text in the center of that space.

Deleting Unused Layers

Master Designer 8.6 lets you delete unused layers while running
PDIF Writer or the new Delete Unused Layers program in the PCB
and Schematic Tools.  Now you can have Master Designer
automatically delete unused layers for you.  Both the Schematic
Tools module and PCB Tools module now feature a Delete Layers
button.  Clicking this button displays the Delete Layer screen, shown
in Figure 1-3:

Figure 1-3:  Delete Unused Layer screen

This screen prompts you for the following information:
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• the input database, which contains the layers you want to delete

• the output database, which is new filename for the modified
database

• the layers to delete

The screen also has four buttons:

• Layer Selection, which displays the Layer Selection pop-up
window

• RUN, which runs the Delete Layer program

• Exit

• DOS Shell, which takes you to the DOS prompt

To delete layers through the Delete Layer screen

1. In the PCB Tools module, select Delete Layer.  The Delete
Layer screen appears.

2. In the Input Database field, enter the name of the database
containing the layers you want to delete.

3. In the Output Database field, enter the name of the new
database.  By default, Master Designer adds a “_dl” to the
filename before the extension.  If the filename is too long, the
system truncates it.

 You must specify both an input and output database filename
before selecting your layers.  Otherwise, Master Designer
displays a warning message.

4. Click the Layer Selection button.  A pop-up window appears,
displaying all the layers in the PCB or Schematic design.  Figure
1-4 displays the Layer Selection pop-up window.

 

 Figure 1-4:  Layer Selection pop-up window

5. Select the layers to you want to delete.
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 or

 Click CANCEL if you don’t want to delete any layers.  Clicking
CANCEL returns you to the Delete Layer screen.

6. Select RUN.  Master Designer edits the input database,
generates a PDIF file, deletes the unused layers, and saves the
PDIF file as a new database, using the name specified in the
Output Database field.  The input database is unchanged.

 You must click Layer Selection and select layers to delete.
Otherwise, when you select RUN, Master Designer displays a
warning message indicating layers have not been selected.

7. Select EXIT when done.

You can also delete layers from within the PDIF File Writer screen.
The difference with this process is that Master Designer creates a
PDIF file and deletes the specified layers from this file, but does not
regenerate a Master Designer database under a new name.  You
must use the PDIF File Reader to do this.

The PDIF File Writer screen features an option for deleting unused
layers, as shown in Figure 1-5:

Figure 1-5:  PDIF File Writer Screen

To delete layers from the PDIF File Writer screen

1. In the PCB Tools module, select PDIF File Writer.  The PDIF
File Writer screen appears.

2. Check Delete Unused Layers.  Then click the Layer Selection
button.  A pop-up window appears, displaying all the layers in
the PCB or Schematic design.

3. Select the layers to you want to delete.

 or
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 Click CANCEL if you don’t want to delete any layers.  Clicking
CANCEL returns you to the PDIF File Writer screen and
deselects the Delete Unused Layers option.

4. Select RUN.  Master Designer generates a PDIF file, deletes the
unused layers, and saves the modified PDIF file.  The original
database is unchanged.

 You must click Layer Selection and select layers to delete.
Otherwise, when you select RUN, Master Designer displays a
warning message indicating layers have not been selected.

5. Select EXIT when done.

Note:   In a Schematic database, you can delete any unused layer,
including autoswitching layers.  An autoswitching layer is a layer to
which Master Designer automatically stores certain data, then
makes the active layer.  For example, if you enter a pin name,
Master Designer automatically enters the pin name on the PINNAM
layer and makes the PINNAM layer the active layer.  If you delete
an autoswitching layer in the Schematic Editor, Master Designer
stores any data meant for that layer on the current active layer.  For
example, if you delete the PINNAM layer and have the layer ATTR
as the active layer, the system puts the pin name on the ATTR
layer.
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Updated Opcodes

In macros, several status area options and Master Designer
commands are represented by numbers called opcodes.  The list of
opcodes has been updated to reflect the changes in Master Designer
8.6.  Table 1-3 lists the opcodes and their meanings.

Table 1-3:  Updated Opcode List

Opcode Operation

 51 Set net name.

 55 Select ByName option.

RCW 58 Rotate component clockwise.

RCCW 59 Rotate component counterclockwise.

 60 Set component name.

 62 Select component orientation (toggle).

 63 Select component mirror (toggle).

 65 Select ByName when using Enter→Replace Component.

 66 Copy pin name.

110 Select  show grid toggle.

111 Select snap to grid toggle.

112 Select XY option.

115 Select snaptopin (toggle).

120 Set pin type.

121 Set pin logical equivalence.

127 Set attribute option when using Enter→Replace Component.

129 Text scale edit field for Enter→Component.

134 Component scale edit field for Enter→Component.

140 Set text size.

141 Set text orientation (toggle).

142 Select text mirror (toggle).

143 Mask components (toggle).

144 Mask wires (toggle).

145 Select text horizontal justification (toggle).

146 Select text vertical justification (toggle).

150 Select After/Before/Split (toggle when using Crit. Path→Add Gate).

151 Select Crit. Path→Add Gate path name.

152 Select On/Off (toggle when using Display→Path/Group Visibility).

153 Select Path/Group (toggle when using Display→Path/Group Visibility).

155 Select ENTER button for any screen.

156 Select LOAD button for any screen.

157 Select CANCEL button for any screen (File→Load, Enter→Component,
message area).

158 Select PICKLIST button in status area.

159 Select ADD button for any screen.

160 Select DELETE button for any screen.
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Opcode Operation

161 Select OK button for any screen (response area).

167 Select a file in Picklist screen.

179 Edit the current file in the Picklist screen.

183 Select EXIT button for any screen.

184 Select the Add Layer button in View Layer.

187 Select line style (toggle).

190 Press Esc .

192 / (initiate keyboard command).

196 Press Backspace  (display last message).

197 Press X to toggle cursor crosshair display.

198 Resume execution from file.

199 Interrupt command file.

ZINC 208 Zoom in at current cursor position.

ZOTC 209 Zoom out at current cursor position.

219 Dynamic ratsnest display delay.

227 Pan with Shift -left mouse button.

274 Old selection method.

Schematic Editor

Auto-Incrementing Reference Designators

Master Designer 8.6 can now automatically assign reference
designator and section numbers to symbols as you enter them in the
Schematic Editor.  The system also remembers the last reference
designator and section number entered for each symbol.  This
feature is useful because it saves you from having to manually
specify the reference designator and section numbers after entering
the symbol.  You also don’t have to worry about remembering the
last reference designator and section numbers entered.  Master
Designer increments them automatically.

To auto-increment reference designators

1. Select Enter→Component.  The system prompts

Enter component name:

2. Enter the name of the desired component, or select PICKLIST to
choose the component from the picklist.  Remember that you
can change directories if the desired component is in a different
directory.

3. Click ENTER.
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After you enter the part name in the response area or choose a
part from the picklist, the system displays the component
outline.  Master Designer also displays a Refd checkbox in the
status area and prompts

Select location to place filename. (Orientation OK?)

4. Change the status area options as needed.

5. Click the Refd checkbox.  A button marked unnamed appears
next to the Refd checkbox.  This is the Reference Designator
button, which you use to assign a reference designator and
section number to a component.

 If the design already has a component of the same type with a
reference designator and section name assigned, then the
Reference Designator button displays the next available
reference designator and section for that component type(for
example, U2/B, U3/C).

6. Click the Reference Designator button.  The system prompts

Component name

7. Enter a valid reference designator and section number (for
example U1/A).  The name you entered now appears on the
Reference Designator button.  You can click this button again to
change the reference designator before placing the component.

8. Select the location of the component.  Master Designer places
the component and displays its reference designator and pin
number information.

9. Repeat step 8 for each component you want to place.  As you
place each component, the system increments the Reference
Designator button, indicating the reference designator and
section of the component you’re about to place.

10. Click CANCEL or select another command when done.
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What’s New in the Utilities 2
This chapter describes the enhancements to following MD 8.6
utilities

• Design Rules Checking

• UNIX Installation

• Hardcopy

• CCT SPECCTRA Router Interface

• PC-WinPlot

• Report Generator

Design Rules Checking

Enhanced Support for Net Attributes

Master Designer 8.6 lets you override default DRC spacing values
with net attributes assigned to nets or a single net in the PCB design
file.  When you run DRC, it prioritizes net attributes over the values
specified in the design rules file, in the following order of
importance.

1. net attributes TRACE-TO-EDGE, TRACE-TO-TRACE,
PAD-TO-TRACE, and PAD-TO-EDGE, all of which have
equal priority and override the CLEARANCE net attribute

2. CLEARANCE net attribute, which overrides default DRC
spacing values

3. default DRC spacing values

The following sample scenarios show how DRC checks your design
without and with net attributes.

• Scenario 1:  No Net Attributes:   In this scenario, DRC uses
the default DRC spacing values specified in the design rules
file.

• Scenario 2:  CLEARANCE net attribute specified:   In this
scenario, DRC uses the CLEARANCE net attribute value to
override the DRC spacing values in the design rules file.

• Scenario 3:  TRACE-TO-EDGE, or TRACE-TO-TRACE, or
PAD-TO-TRACE, or PAD-TO-EDGE net attribute
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specified:   In this scenario, each net attribute overrides a
specific DRC design rule spacing value as it relates to the
system net attributes.  All other values set by the
CLEARANCE net attribute are still valid.

• Scenario 4:  TRACE-TO-EDGE and CLEARANCE net
attributes specified:   In this scenario, TRACE-TO-EDGE
overrides the trace-to-board edge spacing value, and
CLEARANCE overrides the other DRC design rule spacing
values, except for trace-to-board edge.

The Design Rules error report now includes a NET ATTRIBUTE
ERRORS section, formerly the WIDTH ATTRIBUTE ERRORS
section.  This section lists the violations for all defined net attributes,
as shown in the sample report below:

************************************************
*                                              *
*    Program  :  PC-DRC VERSION 8.6            *
*    Date     :  Aug 15 1996 12:38:35 PM       *
*    Database :  x.pcb                         *
*                                              *
************************************************
Net ATTRIBUTES:
----- --------- -
   Net Name
   ----- --------

    NET1 WIDTH = 15
  SIG1 TRACE-TO-TRACE = 40

PAD-TO-TRACE = 10
VIATYPE = 10

  SIG2 WIDTH = 20
TRACE-TO-TRACE = 50

  SIG3 WIDTH = 50
VIATYPE = 51

Figure 2-1.  Sam ple Design  Rules Error Report

LAYERS GROUPED:
----- --------- -
COMP
PADCOM
FLGCON

DESIGN RULES SET:
----- --------- ---
Pad size............................... 60
Nonround pad size...................... 60
Via size............................... 50
Trace width.............................12
Pad to pad spacing......................10
Pad to trace spacing................... 10
Trace to trace spacing................. 10
Pad to board edge spacing............. 125
Trace to board edge spacing........... 125

INNER PLANE CONNECTIVITY:
----- --------- --------- --
APERTURE VALUES      NETS
---------------      ----
       1
       2
    3
    4
   10                NET1  GND

*  Program   :  PC-DRC VERSION 8.6              *
*  Date      :  Aug 15 1996                     *
*  Database  :  x.pcb                           *
*  Pass      :  pass_1                          *
*************************************************

*************************************************



What’s New in the Utilities

What’s New for MD 8.6 27

STATISTICS:
-----------------

Number of pads processed                                851
Number of vias processed                                  4
Number of traces processed                               50
Number of other shapes processed                          2
Number of pad size errors                                 0
Number of via size errors                                 0

Number of trace width errors                              4
Number of WIDTH attribute errors                          1
Number of pad to pad errors                               0
Number of pad to trace or shape errors                    4

Number of trace to trace or shape errors                  0

Number of pad to board edge errors                        0

Total number of entities processed                      907
Total number of size violations                           4
Total number of spacing violations                        4
Total number of violations                                8

Time finished:  12:45:03PM

Figure 2-1.  Sample Design Rules Error Report (cont'd)

MESSAGES:
---------

1. Layers not found:
PADVIA
2. No special symbol found - (uncommitted pin).
Location:  4688,  2410    Type:  6
3. No special symbol found - (committed pin).
Location:  21872,  24527    Type:  20

NET ATTRIBUTE ERRORS:
---------------------

                     NET NAME     VALUE       X1            Y1           X2           Y2
-------------------------------------------------------------------------------------------

1                       NET1     12.00     -440.00      -130.00       -400.00     -130.00

         TYPE    VALUE   ITEM       X1         Y1       X2       Y2
          ----    -----  -----       --         --       --       --
 1     SIZE      7    TRACE     1000       3533      940     3593
 2     SIZE      7    TRACE      940       3593      760     3593
 3     SIZE      8    TRACE      760       3593      700     3533
 4     SIZE      7    TRACE      700       3533      700     2833
 5     SPACE     0    TRACE      680        993      660     1013
                      PAD        670       1003      730     1063
 6     SPACE     0    TRACE      680        993      660     1013
                      PAD        670       1003      730     1063
 7     SPACE     6    TRACE      660       1013      660     1133
                      PAD        670       1003      730     1063
 8     SPACE     6    TRACE      660       1013      660     1133
                      PAD        670       1003      730     1063

WIDTH attribute errors:

TRACE-TO-TRACE attribute errors:
--------------------------------
No trace to trace attribute errors were found on this pass.

PAD-TO-TRACE attribute errors:
------------------------------
No pad to trace attribute errors were found on this pass.

PAD-TO-EDGE attribute errors:
-----------------------------
No pad to edge attribute errors were found on this pass.

TRACE-TO-EDGE attribute errors:
-------------------------------
No trace to edge attribute errors were found on this pass.

VIATYPE attribute errors:

---------------------------------
No viatype attribute errors were found on this pass.

Number of VIATYPE attribute errors                        0

Number of PAD-TO-TRACE attribute errors                   0

Number of TRACE-TO-TRACE attribute errors                 0

Number of PAD-TO-EDGE attribute errors                    0
Number of trace or shape to board edge errors             0
Number of TRACE-TO-EDGE attribute errors                  0

-----------------------

In this report, only the WIDTH attribute has any errors, which are
noted in the NET ATTRIBUTE ERROR section, and listed in the
STATISTICS section.  DRC also indicates if there are no net
attribute errors.  Also, when reporting any VIATYPE net attribute
errors, DRC reports only the first location of each VIATYPE net
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attribute error for each via type value that is different from the value
defined by the VIATYPE net attribute.

Note:    In order to run DRC correctly, you must have an aperture
table defined and attached to your database.  You must also have a
padstack attached to your database to run DRC correctly.  For more
information on how to run DRC correctly, see PCB Tools, Volume 2,
Chapters 5 and 6.

Graphics on the $ATT Layer

DRC marks any net attribute violations by highlighting them in
magenta and adding graphics to the $ATT layer.  The net attribute
graphics on the $ATT layer are represented differently, depending
on the type of violation, but they are the same size as the objects in
the database.  The list below indicates how DRC represents each
type of violation.

• VIATYPE - solid boundary of the shape

• PAD-TO-TRACE - a dashed-outline of a circle and a dashed line

• TRACE-TO-TRACE - two dashed lines

• TRACE-TO-EDGE - a dashed line and a solid line representing
the board edge

• PAD-TO-EDGE - a dashed boundary of a pad shape and a solid
line representing the board edge

If there are no violations, DRC displays a message indicating it
found no violations.

UNIX Installation

Installing the Software on UNIX

You can now install Master Designer 8.6 for UNIX from a CD-ROM.
Instead of the current, two-step process of copying an install script
and running it to install Master Designer from tape, you run an install
program directly from the CD-ROM.  This installation program
extracts the tar files from the CD, lets you select the programs to
install, and installs them to your UNIX system.  See the Installation
Guide - UNIX Systems for more details.
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Installing Master Designer Online
Documentation

Master Designer 8.6 now features a Master Index for the entire
online documentation set.  This file resides on the CD-ROM in the
online documentation directory.  You can view it using Adobe
Acrobat Reader.

AIX Support for Online Documentation

Master Designer 8.6 now includes the latest Adobe Acrobat Reader
(version 2.1) for AIX, which lets AIX users view the online
documentation.

Hardcopy

Scaling Apertures
Hardcopy now lets you scale apertures when generating pen plots
from your Master Designer plot file.  To do this, use the “Plot” format
in Hardcopy and select the Plot Scale field on the Hardcopy screen.
The Hardcopy screen specifies the ratio of the hardcopy plot image
size to the original database image size and aperture size, which
Master Designer reads from the aperture table file.

Note:   This feature applies to HP pen-plotters and Postscript printers
only.  To scale apertures using any other plotter, use PC-WinPlot.

This feature does NOT apply to photoplotting.  That is, you cannot
set the plot scale for photoplots.  If you try this, everything in the
photoplot scales except the apertures.

CCT SPECCTRA Router Interface

Master Designer’s CCT SPECCTRA Interface now supports net
attributes and uses them in the SPECCTRA router.  With this
support, the router can use net attributes to override general spacing
design rule values.  When you send a design with net attributes to
the SPECCTRA router, SPECCTRA writes the appropriate net
attribute information to the .do file.

For example, suppose a design has a net SIG20 with a net attribute
TRACE-TO-TRACE=60.  The TRACE-TO-TRACE net attribute
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overrides the wire-to-wire spacing value.  Therefore, SPECCTRA
adds the line

rule net  SIG20 (clear 60(type wire_wire))

to the design’s .do file.

Note:    Master Designer now uses the .do file extension instead of
.pdo for the DO filename extension.

The table below lists the supported net attributes:

Net Attribute Description

CLEARANCE Overrides the general DRC (trace-to-trace,
pad-to-trace, trace-to-board edge, and pad-
to-board edge) spacing.

PAD-TO-EDGE Overrides the pad-to-board edge DRC
spacing.

PAD-TO-TRACE Overrides the pad-to-trace DRC spacing.

TRACE-TO-EDGE Overrides the trace-to-board edge DRC
spacing.

TRACE-TO-
TRACE

Overrides the trace-to-trace DRC spacing.

The CCT SPECCTRA Interface does not support the VIATYPE net
attribute.

PC-WinPlot

Plotting Multiple Plot Files (batch plotting)

PC-WinPlot now lets you select and plot multiple plot files in a single
session.  You need only configure PC-WinPlot once, select the
desired plot file(s), then select your output device (printer or plotter).
You can also deselect plot files from the list before plotting.  To plot
multiple plot files with PC-WinPlot, you must

• configure PC-WinPlot

• select the plot files

• select the output device
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You can select a set of plot files at the Open dialog box by using the
standard Windows selection key combinations.  The selection set
can be either a single file, a group of files, or all files in the file list.
The table below explains how to select files for batch plotting.

Use this mouse-key combination To select

Left mouse button a single file

Shift -Left mouse button all files between the last
selected (highlighted) file and
the file you click on

Ctrl -Left mouse button add single files to or subtract
single files from the selection
set

After selecting your plot file(s), click OK to continue.  You can
always select File Open  again to see which plot files you selected.

Before batch plotting, you should check the files you wish to plot to
make sure they will meet the desired configuration, especially your
scale setting.  If a selected plot file doesn’t conform to the printer
setup, PC-WinPlot notifies you of this discrepancy and skips to the
next plot file.  Suppose that you select the Limit to One Page option
at the Configuration dialog box, then set the Plot Scale to 3.5 for the
first of a series of plot files.  If the third plot file can only be fitted to
a page up to a scale of 2.0, PC-WinPlot skips this file and moves on
to the next plot file.  However, this does not apply if you set the Fit
to Page option.  In this case, PC-WinPlot automatically sets the
scale so that each plot is either enlarged or reduced to fit on exactly
one page.

When you’re batch plotting, PC-WinPlot displays a message in the
Status Bar indicating that the program is in batch plot mode.  See
the PC-WinPlot Online Help for more details.

Defining Text Stroke Widths

PC-WinPlot also lets you define the text stroke width for zero-width
text lines.  You can specify a value between 0 and 100 mils.  See
the PC-WinPlot Online Help for more details.
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Report Generator

Master Designer now lets you generate a Pin Information List for
your PCB design.  The Pin Information List can be run either from
the command line or in the Report Generator in the PCB Tools
module.  The Pin Information List has the file extension .pin.

The report includes the following information:

• the names and reference designators of all components

• the pins attached to that component

• the pin number

• the X-Y location of the pins

• the net connected to each pin

If a pin has no nets attached to it, the NETNAME field has a “?”.
The figure below shows an example of a Pin Information List.

%*********************************************************************

%                                                                                              *

%     Program  :   PC-PIN       VERSION 8.6                            *

%     Date        :   Aug 15 1996                                                 *

%     Time        :   10:16:33 AM                                                 *

%     File In      :   inter.pcb                                                       *

%     File Out   :   inter.pin                                                        *

%     Format     :   PIN INFORMATION LIST                            *

%                                                                                              *

%*********************************************************************

%
% COMPONENT/
% REF-DES
%                  PIN LOCX LOCY NETNAME

   74LS00:U23
                      1 100.00 200.00 NETNAME1
                      2 200.00 200.00 NETNAME2

   74LS00:U50
                      1 100.00 200.00 NETNAME11
                      2 200.00 200.00 NETNAME22

   74LS00:U60
                      1 500.00 500.00 NETNAME3
                      2 600.00 600.00 NETNAME4

Figure 2-2.  Pin Information List

%

%
%

%

                      3 700.00 700.00 NETNAME5
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To generate a Pin Information List

• At the DOS prompt, enter

PCPIN [options] <PCB filename> [<output pinlist>]

where

PCPIN executes the program.

options is one of the options listed below.

◊ -h displays the help message, which indicates how to use

the program. The -h is optional.

PCB filename specifies the PCB design used to generate the Pin
Information List.

output pinlist specifies the output filename for the Pin
Information List (.pin).

As an example, the command line

PCPIN test1.pcb test1.pin

runs the Pin Information List program, generates a report of all pins
in the PCB design test1.pcb, and saves the report to the file
test1.pin.
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Updated Commands 3
This chapter describes the updated commands for MD 8.6. Menu
commands are discussed first, followed by keyboard commands.
The updated commands are:

• Align→Component

• Change Layer→Component

• Edit→Net Attr

• Enter→Component

• Placement→Fix→Component

• Placement→UnFix→Component

• Rotate→Component

• Query→Properties

• Rotate→Component

• /dyn
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PCB Editor Align
Component

Aligns one component with a reference point.

Using This Command
To align a single component

1. Select Align→Component. The response area prompts

Select component.

2. Select the component.

or

Select ByName in the status area and enter the component
name in the response area.

The system highlights the component and the response area
prompts

Select alignment point.

 If the component you want to select doesn’t exist, Master
Designer displays a warning message and prompts you again to
select a component.

3. Cycle to Horiz or Vert in the status area.

4. Select the point with which you want to align the component.
The system aligns the origin of the component with the
alignment point.

5. Select another component.

or

Select another non-nested command to exit Align→Component.

Things to Remember
The alignment commands move objects along one axis at a time.

You cannot select a fixed component. If you do, the system displays
the message

Component is fixed

In this case, select another component that isn't fixed.

Wires attached to aligned components won't rubberband, and the
nets become disjointed.
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Align
Component

To align components in a column, cycle to Horiz in the status area,
and select an alignment point to the right or left of the column.

To align components in a row, cycle to Vert in the status area, and
select an alignment point above or below the row.

The system aligns the origin of the component (usually pin 1) with
the alignment point you select.

If alignment results in overlapping components, use
Move→Component to make corrections, or use Align→Undo.
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PCB Editor Chg. Layer
Component

Flips a component between the paired top and bottom graphics layers of the board.

Using This Command
To successfully flip a component between layers, the system
requires correct layer pairing. Refer to “Things to Remember”.

To flip a component between the top and bottom layers

1. Select Chg. Layer→Component. The response area prompts

 Select a component.

2. Select a component.

 or

 Select ByName in the status area and enter the component
name in the response area.

3. The system highlights the component, flips it to the other side of
the board, and prompts you to select another component.

 If the component you want to select doesn’t exist, Master
Designer displays a warning message and prompts you again to
select a component.

 If you attempt to flip a through-hole component without first
correctly pairing the layers, the response area displays

 Comp can't be flipped

4. Select another component to flip.

 or

 Select a non-nested command to exit Chg. Layer→Component.
Refer to Things to Remember (next section) for correct layer
pairing.

Things to Remember
Chg. Layer→Component applies only to SMT components or
through-hole components whose layers are paired correctly in the
PCB design file.

Use Environment→Assign Layer Pairs to verify that the component's
graphics have been assigned to an appropriate layer pair. Refer to
the Environment→Assign Layer Pairs description or the PCB Tools
manual for a list of appropriate layers.
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Chg. Layer
Component

You cannot select a fixed component. If you do, the system displays
the message

Component is fixed

In this case, select another component that isn't fixed, or select
Placement→Unfix→Component.

Three restrictions apply to Chg. Layer→Component:

• Graphics layers for the top and bottom of the board must first be
paired with the Environment→Assign Layer Pairs. At least one

pair of graphics layers in the part must be paired. For example,
if you want to flip an SMD, the SLKTOP and SLKBOT layers are
paired. If you want to flip a through-hole component, you need to
pair one of the component's graphics layer with a layer on the
bottom of the board. For example, you can pair a through-hole
component's SLKSCR layer with the SLKBOT layer.

• No wires can connect to the component at the time you flip it.

• The system doesn't flip components between stitchable layers.
Stitchable layers are layers reserved for traces.

For more information on mapping layer pairs, see Environment→
Assign Layer Pairs.
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PCB Editor Edit
Schematic Editor Net Attr

Lets you add, modify, and delete net attributes.

Using This Command
To add a net attribute

1. Select Edit→Net Attr. The system prompts

Select a net

2. Select the desired net.

 or

 Select ByName in the status area and enter the net name in the
response area. The Net Attributes dialog box appears.

3. Click ADD. The system highlights the Keyword field.

4. Type the attribute keyword in the keyword field, then press Enter
or Tab. The system highlights the Value field.

or

Select the keyword from the system keywords list box. The
system copies the selected keyword to the Keyword edit box and
prompts you for a value.

5. Type the attribute value, then press Enter or Tab. The system
adds the new attribute to the list.

6. Click OK to save your changes, or click CANCEL to abort.

To change a net attribute value

1. Select Edit→Net Attr. The system prompts

Select a net

2. Select the desired net.

 or

 Select ByName in the status area and enter the net name in the
response area. The Net Attributes dialog box appears.

3. Scroll to the desired attribute from the Attributes list box. The
system displays the selected attribute keyword and its value in
the Keyword and Value fields, respectively.

4. Click on the Value field and enter the new value.

or
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Edit
Net Attr

 Select the keyword from the system keywords list box. The
system copies the selected keyword to the Keyword edit box and
prompts you for a value.

5. Repeat steps 1 through 4 to edit another attribute value.

6. Click OK to save your changes or click CANCEL to abort.

To change a net attribute keyword

1. Select Edit→Net Attr. The system prompts

Select a net

2. Select the desired net.

 or

 Select ByName in the status area and enter the net name in the
response area. The Net Attributes dialog box appears.

3. Scroll to the desired attribute from the Attributes list box. The
system displays the selected attribute keyword and its value in
the Keyword and Value fields, respectively.

4. Click on the Keyword field and enter the new value.

5. Repeat steps 1 through 4 to edit another attribute keyword.

6. Click OK to save your changes or click CANCEL to abort.

To delete a net attribute

1. Select Edit→Net Attr. The system prompts

Select a net

2. Select the desired net. The Net Attributes dialog box appears.

 or

 Select ByName in the status area and enter the net name in the
response area. The Net Attributes dialog box appears.

3. Scroll to the desired attribute from the Attributes list box and
select it. The system displays the selected attribute keyword and
its value in the Keyword and Value fields, respectively.

4. Click DELETE. The system deletes the selected attribute.

5. Click OK to save your changes, or click CANCEL to abort.
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Edit
Net Attr

Things to Remember
The Edit→Net Attr command checks the values of all supported
system net attributes which include WIDTH, CLEARANCE, TRACE-
TO-TRACE, PAD-TO-TRACE, TRACE-TO-EDGE, PAD-TO-EDGE,
and VIATYPE.

If you change the value of a system attribute, Master Designer
checks the new value to see if it's valid. If the value is either invalid
or out of range, the system displays the warning message

Attribute out of range. Enter anyway?  Yes, No

If you select No, the system does not enter or change anything. If
you select Yes, the system changes the attribute value.
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Schematic Editor Enter
PCB Editor Component

Enters components in a database

Using This Command

To enter a component

1. Select Enter→Component. The response area prompts

Enter component name.

2. Enter the component filename.

or

Select PICKLIST.

To select a component in the Picklist window
1) Select a library or path from the Libraries list box.

2) Select a symbol or part from the Symbol or Part list box.

3) Select ENTER to enter the component in the design.

or

Select CANCEL to exit the Picklist window without selecting
a component.

Note:  You can double click left on the component name to
enter it into the design, instead of selecting the name, then
selecting ENTER.

If the selected part contains layers that aren't in the database, a
decision box prompts

New layers may be added. Continue?

Yes No

Select Yes to add the component. The system adds only layers
that contain data.

or

Select No to return to the prompt in step 1.
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Enter
Component

Note:  If Display Verbose Warnings on the Editor Configuration
screen is disabled, the message

New layers may be added. Continue?

doesn’t appear.

After you enter the part name in the response area or choose a part
from the picklist, the system displays the component outline.

The response area prompts

Select location to place filename. (Orientation OK?)

3. Change status area options as needed.

To rotate the component

Select the Deg cycle for one of four orthogonal angles.

or

Select Angle in the status area and enter an angle in the
response area. The system allows positive or negative integers.
(In the Schematic Editor, only multiples of 45 degrees are
accepted.)

Note:  The Angle option overrides the Deg cycle option.

4. Select a location for the component.

5. Continue to select locations if you require multiple instances of
the component.

or

Click middle to end the current operation and return to the step 1
prompt. If you used the Picklist, you're returned to the Picklist
window.

6. Select CANCEL or another command to exit
Enter→Component.
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Enter
Component

To change the name of a component or add a name to an
unnamed component during entry

1) Select the unlabeled Component Name box in the status
area or press F4 before you position the component. The
response area prompts

Component name:

Note:  In the Schematic Editor, the component name you
assign with Enter→Component in step [1] isn't a reference
designator. To assign a reference designator interactively in
the Schematic Editor, use Enter→Ref. Des. & Section.

2) Enter a new name such as the device name. The system
returns to the component location prompt in step 2. For
important information on component names in the
Schematic Editor and the PCB Editor, refer to Things To
Remember.

3) Select a location for the component.

If the component was created with units of measure different
from the units of measure in the schematic database, a
decision box prompts

Converting comp to Metric/English unit.

Continue? Yes No

• Select Yes to convert the units of measurement to the units

used in the schematic database.

or

Select No to return to the prompt for a component name.

Things to Remember

A component is an entity created in the Symbol Editor or Part Editor.
It may or may not be archived in a library. If you don't know how to
make a part library available to the current design or how to find the
part, refer to the Library Manager manual.



Updated Commands

48 What’s New  for MD 8.6

Enter
Component

To ensure consistency, the system permits only one version of a
component in a database. Each time you enter a component, the
system checks to make sure its origin and pin information are the
same as the origin and pin information for all other components in
the design with the same filename.

If you update a library symbol or part and want to enter it in a
database that has previous versions of the component, use
Enter→Replace Component.

The default filename extension for components is .sym in the
Schematic Editor and .prt in the PCB Editor. When you're entering
components in a design, you don't have to type the extension if
you're using the default.

When you are setting up dimensions, you can use
Enter→Component to search component library files for arrowheads,
providing that these files reside in the specified search path.  See
the Library Manager manual for details on setting up your search
paths.

Status Area Options

The status area options for Enter→Component let you select:

• orthogonal degrees of rotation (Deg cycle box)

• an Angle option for entering degrees of rotation

• an unlabeled Component Name box

• the Mirror check box (Schematic Editor)

• the Top or Bottom of the board (PCB Editor)

• the AutoNm check box (PCB Editor)

• the Refd check box (Schematic Editor)

Orthogonal Rotation Angles

The setting of the orthogonal rotation angle stays the same until you
change it or select another command.



Updated Commands

What’s New for MD 8.6 49

Enter
Component

Entering an Angle in the Response Area

The Angle option lets you specify any angle of component rotation.
The Angle option overrides the orthogonal degrees of rotation. The
entered angle stays the same until you end the command or select
another angle.

The Component Name Box

The unlabeled Component Name box displays unnamed while you
enter a component. You can select this box and enter a component
name in the response area. The system doesn’t display the name
until you execute Name→Component.

In the Schematic Editor

Component Mirroring in the Schematic Editor

When you fill the Mirror check box in the Schematic Editor, the
system mirrors the pin arrangement of the component along the X-
axis. The Y-axis value for the pin locations doesn’t change with
mirroring. Mirror doesn’t change the appearance of the symbol
name.

In the PCB Editor

Selecting the Top or Bottom of a PCB

A status area cycle in the PCB Editor allows you to choose the Top
or Bottom of the board for component placement.

Note:  To place a component on the bottom of the board, the
component's graphic (nonstitchable) layers must be paired for the
top and bottom of the board. See Environment→Assign Layer Pairs.

Automatic Component Naming

As you enter components in the PCB layout, you can automatically
define a reference designator naming pattern by enabling the
AutoNm check box in the status area before placing the component.
For each subsequent component entered, the number in the pattern
increases by one.  For example, if you use R1 as the first reference
designator, the next components entered would be named R2, R3,
R4 and so on.
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The Component Name box in the status area shows the next
available name in the sequence as long as the AutoNm check box is
filled.

If you use Name→Reseq. Ref. Des. or Name→Reseq. Window
commands (or if you use the AutoNm check box when entering
components) anytime during the current editor session, the last
name used by any of these commands sets the pattern for the next
reference designator in the sequence, whenever you use these
commands to automatically name components.

You can override the existing pattern anytime by selecting the
Component Name box in the status area and entering a new name
pattern.

You can disable the automatic naming feature at any time during
component entry by emptying the AutoNm check box.

Auto-Incrementing Reference Designators

When you click the Refd check box, you can automatically assign
reference designator and section numbers to symbols as you enter
them in the Schematic Editor.  The system also remembers the last
reference designator and section number entered for each symbol.

To auto-increment reference designators

1. Select Enter→Component.  The system prompts

Enter component name:

2. Enter the name of the desired component, or select PICKLIST to
choose the component from the picklist.  Remember that you
can change directories if the desired component is in a different
directory.

3. Click ENTER.

After you enter the part name in the response area or choose a
part from the picklist, the system displays the component
outline.
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Master Designer also displays a Refd checkbox in the status
area and prompts

Select location to place filename. (Orientation OK?)

4. Change the status area options as needed.

5. Click the Refd checkbox.  A button marked unnamed appears
next to the Refd checkbox.  This is the Reference Designator
button, which you use to assign a reference designator and
section number to a component.

 If the design already has a component of the same type with a
reference designator and section name assigned, then the
Reference Designator button displays the next available
reference designator and section for that component type(for
example, U2/B, U3/C).

6. Click the Reference Designator button.  The system prompts

Component name

7. Enter a valid reference designator and section number (for
example U1/A).  The name you entered now appears on the
Reference Designator button.  You can click thes button again to
change the reference designator before placing the component.

8. Select the location of the component.  Master Designer places
the component and displays its reference designator and pin
number information.

9. Repeat step 8 for each component you want to place.  As you
place each component, the system increments the Reference
Designator button, indicating the reference designator and
section of the component you’re about to place.

10. Click CANCEL or select another command when done.

Using the Picklist

The Symbol and Part list boxes show the symbols or parts available
for the library highlighted in the Libraries list box. You can select a
component by entering its filename in the Symbol or Part data entry
box, or by selecting it in the list box.
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The Libraries list box shows the libraries made available by the
Library Manager. You can either select a library from the Libraries
list box or add a component library in the Current Library data entry
box. After you enter the entire library path in the Current Library box,
the Libraries list box displays the component library name. After you
exit the editor, the system adds the new paths or libraries to the Set
Libs. and Search Paths list in the Library Manager.

The Search Pattern data entry box lets you control the scope of
component filenames displayed in the Symbol or Part list boxes.
The default pattern is *.prt in the PCB Editor and *.sym in the
Schematic Editor, which displays all symbols or parts. For example,
to display only the low-power Schottky devices in the TTL library,
you would enter ??ls*.prt or ??ls* in the Search Pattern data entry
box.

In the Schematic Editor

In the Schematic Editor Picklist window you can

• Switch between directories.

• Select the component library.

• Select the symbol or part file.

• Enter a filter to narrow the list of displayed filenames.

• Scale the size of the selected symbol up or down.

• Scale the size of the symbol's associated text up or down.

If a symbol or part is not available in the current library, you can
switch between different directory and load the desired symbol or
part from that directory.  This makes it easier for you to load designs
or borrow symbols and parts from other designs.

The scaling factor for the symbol or its text is 1% through 10,000%.
The default is 100%. If you change the scale, the system returns to
the default setting after you've entered the component in a
schematic.

In the PCB Editor

In the PCB Editor Picklist window you can

• select the component library.
• select the part filename.
• enter a filter to narrow the list of displayed files.

Assigning Component Names

The following two sections explain the meaning of the user-assigned
names in the Schematic and PCB Editors.
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In the Schematic Editor

The system automatically assigns a unique name to each instance
of a component entered in a schematic. A typical system-assigned
name could be UC00030004. The first four numbers represent the
sheet number in the design, the last four numbers are the
component number or instance. Use Query→Component to see the
system-assigned name.

You may want to override the system-assigned name. The most
common reason for overriding the system-assigned name in the
Schematic Editor is to identify gate sections to a logic simulator. You
can assign a name while you enter the component with
Enter→Component, or assign it with Name→Component after you
enter a component. This assignment is NOT the same as assigning
a reference designator and section. To assign a reference
designator and section, use Enter→Ref. Des. & Section.

You can use Query→Component to display a component's reference
designator and section in the status area.

When entering components, the pin outline is visible as a visual aid
in placing the components in the design. If the symbol or part
contains more than 175 pins, only a box outline is shown.

In the PCB Editor

If you used the Package Schematic to create the PCB database, the
system has already assigned names to the components. In the PCB
context, these component names are either system-assigned
reference designators or the reference designators you assigned
with Enter→Ref. Des. & Section in the Schematic Editor.

• You can use Query→Component to display a component's
reference designator in the status area.

• You can change a component name with Name→Reseq. Ref.
Des. or Name→Reseq. Window.

• When entering components, the pin outline is visible as a visual
aid in placing the components in the design. If the symbol or
part contains more than 175 pins, only a box outline is shown.

If you didn't use the Schematic Packager to create the PCB
database, you can assign a component name when you interactively
enter the component with Enter→Component or by using
Name→Component.
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PCB Editor Placement
Fix

Component

Fixes the location of a component to prevent the system from relocating it during automatic placement.

Using This Command
To fix the location of one or more components

1. Select Placement→Fix→Component. The system highlights all
components currently fixed in the database. The response area
prompts

Select a component.

2. Select each component you want to fix.

 or

 Select ByName in the status area and enter the component
name in the response area.

3. The system highlights and displays each fixed component in the
graphics area.

 If the component you want to select doesn’t exist, Master
Designer displays a warning message and prompts you again to
select a component.

4. Select another component.

or

Select a non-nested command to exit
Placement→Fix→Component.

Things to Remember
Placement→Fix→Component affects automatic placement and
automatic swapping. This command doesn't prevent you from using
any of the move or rotate commands to move or rotate fixed
components.

You can't swap a component on a fixed component. Swap→Gate
and Swap→Pin give you the option to swap gates or pins of a fixed
component in case each pin on the part is a separate gate.

Improve Plc.→Component and Improve Plc.→Gate don't swap fixed
components or gates.



Updated Commands

56 What’s New  for MD 8.6

Placement
Fix

Component

Always fix connectors before you use Placement→Automatic
Placement or Placement→Improve Placement. The system uses
connectors as reference components during automatic placement; it
considers a component with a component ID type in the range of
12000-12999 to be a connector. In addition, you need to fix any
other parts that are restricted because of mechanical fitting, heat
emission, radio interference, or other critical conditions.

To unfix a component, select Placement→UnFix→Component.
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Component

Unfixes a component previously fixed with Placement→Fix→Component.

Using This Command
To unfix one or more components

1. Select Placement→UnFix→Component. The system highlights
all fixed components. The response area prompts

Select a component

2. Select one of the highlighted components.

 or

 Select ByName in the status area and enter the component
name in the response area.

3. The system unhighlights the display and unfixes the component.

 If the component you want to select doesn’t exist, Master
Designer displays a warning message and prompts you again to
select a component.

4. The system unfixes the component and returns you to the
prompt in step 1.

5. Select another component.

or

Select a non-nested command to exit
Placement→UnFix→Component.

Things to Remember
Select Placement→UnFix→Component to make components
available for automatic placement and swapping operations.
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Symbol Editor Query
Schematic Editor Properties
Part Editor
PCB Editor

Lets you view and change the properties of any selectable object in your design.

Using This Command

You can view and change the properties of any selectable object in
your schematic or PCB design. A cycle box on the status line lets
you view properties by either selecting an object or an attribute or a
net. The properties available for viewing and changing depend on
what object you select. For example, where an arc has radius and
line width properties, a filled circle has only a radius property.

To change properties

1. Select Query→Properties. A cycle box appears on the status
area.

2. Cycle to ByObj (the default) to select an object. The system
prompts

Select object.

If you cycle to ByAttr, the system prompts

Select an attribute or net.

3. Select the desired object. The system highlights the selected
object and displays a dialog box showing that object's properties.

The properties dialog box has combinations of picklists, edit
boxes, check boxes, or cycle boxes depending on the properties
available.

If you cycle to ByAttr and select a net, the system displays the
Net Attributes dialog box with the attributes for the selected net.

If you cycle to ByAttr and select an attribute, the system displays
that attribute’s properties in a dialog box.

4. Change the desired properties.

5. Click OK to accept the changes, or click CANCEL to discard
them.

Note :  If you try to select an object where there is none,
Master Designer displays the error message

No object found.
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Things to Remember

Like the Edit→Net Attr command, the Query→Properties command
checks the values of all supported net attributes which include
WIDTH, CLEARANCE, TRACE-TO-TRACE, PAD-TO-TRACE,
TRACE-TO-EDGE, PAD-TO-EDGE, and VIATYPE.

The tables below list the selectable objects and their included
properties. Also, where possible, the tables list the acceptable
values for the properties you can change. In the tables below, any
property marked ”label" is read-only and cannot be changed.

Table 3-1.  Rectangle (unfilled)
Property Acceptable Value/Range
Layer pick list of ABL layers
Line Style solid, dotted, dashed
Width (0-255)
Point A label (lower left coordinate)
Point B label (upper right coordinate)

Table 3-2.  Rectangle (filled)
Property Acceptable Value/Range
Layer pick list of ABL layers
Point A label (lower left coordinate)
Point B label (upper right coordinate)

Table 3-3.  Text
Property Acceptable Value/Range
Layer pick list of ABL layers
Horizontal Justification cycle (left, right, center)
Vertical Justification cycle (top, center, bottom)
Text Size (Height) edit box (2-5000)
Mirror check box
Rotation cycle (ortho: 0 90 180 270)
Edit Text (Content) edit box (up to 255 characters.)
Location (insertion point) label (XY coordinates)

Table 3-4.  Line Segment
Property Acceptable Value/Range
Layer pick list of ABL layers
Line Style cycle (solid, dotted, dashed)
Width edit box (0-255)
Point A label (segment start point)
Point B label (segment end point)
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Table 3-5.  Circle (unfilled)
Property Acceptable Value/Range
Layer pick list of ABL layers
Line Style cycle (solid, dotted, dashed)
Width edit box (0-255)
Radius edit box (.01-10,000,000)
Center label (XY coordinates)

Table 3-6.  Circle (filled)
Property Acceptable Value/Range
Layer pick list of ABL layers
Radius edit box (0.01-255)
Center label (XY coordinates)

Table 3-7.  Arc
Property Acceptable Value/Range
Layer pick list of ABL layers
Line Style cycle (solid, dotted, dashed)
Width edit box (0-255)
Radius label (radius value)
Center label (XY coordinates)
Start Angle label (starting angle value)
Ending Angle label  (ending angle value)

Table 3-8.  Polygon (PCB Editor)
Property Acceptable Value/Range
Layer pick list of ABL layers
Poly Fill cycle (solid, hatched)
Aperture Width edit box (0-250)
Net name label (Entered Polygon)
# vertices label
Net Attributes button displays the Net Attributes dialog box

Table 3-9.  Flash (standalone or Part Editor)
Property Acceptable Value/Range
Layer pick list of ABL layers only
Aperture # edit box (1-999)
Rotation cycle (ortho: 0 90 180 270)
Location label (center point, XY coordinates)
Shape label (round, square, rectangle, thermal,

oval, target, polygon)
Shape Labels
     Rounlabel (diameter)
     Square label (width)
      Rectangle label (width, height)
    Thermal label (outer diameter, inner diameter)
     Oval label (width, height)
     Polygon label (number of sides)
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Table 3-10.  Wire, segment
Property Acceptable Value/Range
Layer pick list of stitchable layers
Net Name label (if applicable; can be "unnamed")
Wire Width edit box (0-255)
Attribute Button leads to picklist of attributes assigned to net.
Point A label (segment start point)
Point B label (segment end point)

Table 3-11.  Component (PCB Editor)
Property Acceptable Value/Range
Reference Designator edit box (Reference Designator)
Surface Mount Device label (YES, NO)
Side cycle (Top, Bottom)
No. of pins label
SCAT Code label
Fixed checkbox
Angle edit box (-359 to 359)
Location label (insertion point, XY coordinates)
Attribute Button leads to picklist of attributes assigned

to component.
Part Name label (part filename)

Table 3-12.  Component (Schematic Editor)
Property Acceptable Value/Range
Reference Des/Section edit box
Component Name (Instance) edit box (Component Name)
No. of pins label
SCAT Code label
Mirror checkbox
Angle cycle (ortho+45: 0 45 90 135 180 225 270 315)
Location label (insertion point, XY coordinates)
Attribute Button leads to picklist of attributes assigned

to component.
Symbol Name label (symbol filename)

Table 3-13.  Pin (Symbol, Part, and Schematic Editors)
Property Acceptable Value/Range
Layer pick list of ABL layers only
Pin Name label
Pin Number, Alphanum label
Pin Type edit box  (PCB: 1-1000, SCH: 0-6, 16-63)
Sequence # label (pin entered in sequence)
LEQ edit box ( 0-127 )
Location label (insertion point, XY
coordinates)
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Table 3-14.  Pin (PCB Editor)
Property Acceptable Value/Range
Layer pick list of ABL layers only
Pin Name label
Pin Number, Alphanum label
Pin Type edit box  (PCB: 1-1000, SCH: 0-6, 16-63)
Sequence # label
LEQ edit box (0-127)
Location label (insertion point, XY coordinates)
Padstack filename label

Table 3-15.  Attribute (Schematic and PCB Editors)
Property Acceptable Value/Range
Layer pick list of ABL layers only
Keyword edit box (max 23 chars.)
Value edit box (max 255 chars.)
Location label (insertion point, XY coordinates)
Text Properties (as listed above, under Text object)
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Schematic Editor Rotate
PCB Editor Component

Specifies a final rotation angle for the component.

Using This Command
To rotate a component

1. Select Rotate→Component. The response area prompts

Enter angle:

2. In the Schematic Editor, enter a multiple of 45 degrees. Your
entry is the final angle at which the selected component resides.
Accepted entries are plus or minus 0, 45, 90, 135, 180, 225,
270, 315, 360.

or

In the PCB Editor, enter a multiple of 90 degrees.  You can
enter a component at any angle at 1-degree increments, ranging
from -359 to 359 degrees.  The system will rotate the
component in 90-degree increments from the specified starting
point.

The response area prompts

Select center of rotation.

3. Select the center of rotation for one component.

 or

 Select ByName in the status area and enter the component
name or its reference designator in the status area.  When you
select ByName in the status area, Master Designer rotates the
named component at the specified angle using the center of the
component as the center of rotation.

 If the component you want to select doesn’t exist, Master
Designer displays a warning message and prompts you again to
select a component.

When you select the center of rotation, the system rotates the
component about the point you select a specified number of
degrees relative to the component's starting  position. For
example, if you first rotate a component to 45 degrees from the
vertical axis, but then decide to rotate it 45 degrees more, you
need to specify 90 degrees as the final angle. Degrees of
rotation are measured from the starting point.
After the component rotates, the response area continues to
prompt

Select center of rotation

4. Select another component to rotate to the same angle.
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or

Click middle or press Esc  once to return to the prompt in step 1.

or

Click middle twice or press Esc  twice, then select another
command.

To restore rotated components to their original positions

• Select Rotate→Undo immediately after you rotate a component
to restore it to the previous position.

Things to Remember
When you try to restore components to their original positions,
whether the component returns to the exact same position depends
on the center of rotation you select and the original angle of rotation.
If it doesn't return to the exact same position, the problem may be
that the component is off-grid or you may not have selected the
exact same center of rotation.  You can use Move→Component to
select the component's origin point and move the component back
on grid.

If the rotation of the component was other than zero degrees before
trying to restore its position by entering zero as the final angle, the
component will still be restored to zero degrees when you enter zero
for the angle of rotation.

Use Query→Component to determine the angle of rotation for a
component, before or after using Rotate→Component.

The Rotate Text in Four Directions option in the Editor Configuration
window determines one of two possible modes of component text
rotation. If the Rotate Text in Four Directions check box is filled, the
component text rotates with the same rotation as the component or
other object. If the Rotate Text in Four Directions check box is
empty, the text remains right side up when the associated object is
upside down. If you change the Rotate Text in Four Directions option
while the corresponding editor is open, you must close and reopen
the editor before it recognizes the change in text rotation. Examples
of component text are the component name, reference designator,
and component attributes.
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Flash aperture rotation is distinct from component rotation. There
are certain restrictions and considerations about apertures that can
be rotated when you rotate a component.

• You can specify an angle of rotation for the flash aperture itself
by using the Rotate field in the Aperture Table Editor. This
applies only to rectangular or oval shapes, and can be used only
if you are using an RS-274-X photoplotting device that supports
flash rotation.

• You can also specify a rotation value for each flash instance by
selecting Degree in the status area when using Draw→Flash.
This angle of rotation will be added to any angle defined for the
aperture in the aperture table.

• The flash will be rotated along with the component, regardless of
the rotation angle you specify for the flash when you define the
shape for the aperture. This applies if your rotated flash is in a
padstack, built into the SMT component file, or if the component
is placed on the top or bottom of the board.

• Thermal and target shapes do not appear rotated in your PCB
database because a generic shape is used to display this type of
flash shape in the PCB Editor and on a penplot. They will,
however, be rotated in the actual photoplot.

• You must enable the Rotate Padstacks option on the PCB Editor
Configuration screen if you want padstacks to rotate with the
component when the component is rotated in the PCB database.

• If you don't have access to an RS-274-X photoplotter, you will
have  to define different flash aperture shapes for each type of
rotated flash shape you want to use in your design. If you forget
to do this, and you're using photoplotters that don't support
Extended Gerber photoplotting format, you may not get accurate
results.

All plots that you generate from the database show component text
exactly as it appears in the drawing area.

Use whole numbers to specify an angle of rotation. Fractions are not
allowed.
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When you query a component, the angle of rotation is shown as a
positive value; for example, -45 degrees is shown as 315 degrees.

You cannot select a fixed component. If you do, the system displays
the message

Component is fixed

In this case, select another component that isn't fixed.

- In the Schematic Editor

You can only rotate a component in multiples of 45 degrees. The
angle you specify is the final angle of rotation for the component.
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Controls the dynamic ratsnest display.

Using This Command
To control dynamic ratsnest display

1. Enter /dyn .  The system prompts

 Dynamic Ratsnest Delay? Yes, No

2. Select Yes, No,.

Entering Yes enables the default dynamic ratsnest delay interval set
using the /dly command.  Entering No disables dynamic ratsnest
display.

Things to Remember
You can control the dynamic ratsnest display at any time when the
Enter→Wire or Edit→Enter Wire commands are active. When this
feature is enabled, the dynamic ratsnest display constantly updates
to show the shortest path from the cursor to the nearest
unconnected segment or pin in the net. If all pins in the net are
already connected, the dynamic ratsnest will point to the nearest pin
in the net.

This is a nested command and can be used at any time during
Enter→Wire without interrupting wire entry.  This command also
affects the Move→Component command.

See also Display→Control Ratsnest for other ways to control the
ratsnest display.
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New Commands 4
This chapter describes the new commands for MD 8.6. Menu
commands are discussed first, followed by keyboard commands.
The new keyboard commands are:

• /dly

• /osel
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/dly
PCB Editor

Sets the dynamic ratsnest delay (in seconds).

Using This Command
To set the dynamic ratsnest delay

1. Enter /dly.  The system prompts

 Dynamic Ratsnest Delay=n. New value=

2. Enter a number between .01 and 1 (in seconds).  Or you can

press ↵↵ to accept the current value.

Entering a number between .01 and 1 sets the dynamic ratsnest
delay (in seconds) at that number.

Things to Remember
You can set a dynamic ratsnest delay without enabling dynamic
ratsnest display.  When you enable the dynamic ratsnest display
again, the system uses the delay last set with the /dly command.

The /dly keyboard command applies to these menu commands:

• Enter→Wire

• Edit→Enter Wire

• Move→Component



New Commands

74 What’s New for MD 8.6



New Commands

What’s New for MD 8.6 75

/osel
Symbol Editor

Schematic Editor

Part Editor

PCB Editor

Switches between Master Designer’s current selection method and that used by previous versions of
Master Designer.

Using This Command
The current selection mechanism selects the object closest to the
cursor on the active layer that is within snap tolerance.  This makes
it easier for you to predict which object will be selected first.

To change to the old object selection method

1. Enter /osel.  The system prompts

Use old selection method?

Yes No

2. Select Yes to switch to the selection method used by Master
Designer versions 8.5 and earlier.

or

Select No to use the selection method used by Master Designer
versions 8.6 and later.

Things to Remember

With many commands, the selection mechanism selects the object
closest to the cursor on the active layer that is within snap tolerance.
This makes it easier for you to predict which object will be selected
first.  The affected commands are:

• Change Layer→Object

• Change Layer→Objects

• Copy→Object

• Copy→Objects

• Delete→Object

• Delete→Objects

• Delete→Trace
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• Edit→Move Vertex

• Edit→Delete Vertex

• Edit→Move Segment

• Edit→Delete Segment

• Edit→Move Via

• Edit→Delete Via

• Edit→Segment Layer

• Edit→Delete Trace

• Edit→Trace Width

• Move→Object

• Move→Objects

• Query→Trace

• Query→Net

• Query→Object

• Query→Via

• Query→Properties

• Rotate→Object

• Rotate→Objects

For those objects that Master Designer does not apply snap
tolerance to, such as components, attributes, or polygons, Master
Designer lets you select these objects when the cursor is within their
boundaries.

If more than one object is within snap tolerance and at the same
distance from the cursor, Master Designer prioritizes which objects
to select.  The order of priority is (from highest to lowest):

• objects on the active layer

• objects on the ABL layer

• objects on any layer set to ON

• vias

• nets

• components

• draw objects
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You can use the new /osel keyboard command to switch between
the new selection method and to the selection method used in
previous versions of Master Designer.

If your existing Master Designer macros require the old selection
method, you can also use the osel command in your existing Master
Designer macros to switch between the old and new selection
methods, as in the example below:

MACRO 850 -400
Opcode 192 0
Text osel
Text 1
B1 850 -450
B1 900 -750
Opcode 192 0
Text osel
Text 0
Opcode 192 0
Text mend
END_MACRO

In this example, the statements

Text osel
Text 1

activate the old selection method by setting osel to 1.  Conversely,
the statements

Text osel
Text 0

reactivate the new selection method by setting osel to 0.
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System Limits A
This appendix lists the supported system limits for P-CAD Master
Designer version 8.6.

Table A-1 lists name length limits. Table A-2 lists maximums. Table
A-3 lists other ranges.

Table A-1.  Name Length Limits
Parameter Limit

Attribute keyword 23

Attribute value 255

Bus name (input buffer length) 79

Bus net name length 23

Component name (internal, user assigned) 23

Critical path name length 8

Device name for library member 8

External filename length (including path) 63

Footprint name length 23

Group name length 8

Layer name length 6

Net name (internal, user assigned) 23

Packaging ID (nonhomogeneous parts) 15

Pin name (internal, user assigned) 23

Pin number (alphanumeric) 7

Reference designator length 23

Reference designator prefix  length 3

Schematic sheet ID length 4

Section name length 3

Symbol or part external filename, DOS 8.3

Symbol or part external filename, UNIX 255
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Table A-2.  Maximums
Items Practical Theoretical
Aliases per component 1882
Apertures, number of, Gerber Laser Model 999
Apertures, number of, Gerber Model 32, 33, 41 24
Apertures, number of, Gerber RS-274-X 999
Apertures, number of, MDA Fire 2000 999
Apertures, size, Gerber Laser Model, RS-274-X,
 MDA Fire 2000 .500
Apertures, size, Gerber Model 32, 33, 41 .240
Association distance (placement) 1000
Characters in an aperture macro name 12
Characters in a text string (line) 255
Clearance for placement 1000
Components 32,000 (2,147,483,447)
Components per library archive 800
Filled circle radius 255
Gate types per package 9
Gates per package 5000
Grid spacing 2000
Input buffer, aperture list, Environment!
 Set Inner Plane Aperture 255

Lattice spacing (placement) 5000
Lattices for placement 10
Layer support 100
LEQ codes 127
Message character buffer, /intr 44

Nets 64,000 (2,147,483,447)
Picture blocks 250,000 (2,147,483,447)
Pin count, by wire, Display!Control Ratsnest 512

Pin types (parts) 1000
Pins 250,000 (2,147,483,447)
Pins per component 5000
Polygon aperture width 250
Polygon clearance value 500
Polygon + merged void vertices 10,000
Polygon size (sq. DBUs) 10,240,000
Polygon vertices 10,000
Polygonal void vertices 10,000
Programmable function keys 40
Repeat copy count 255
Snap tolerance value 1000
Stitchable layers 32
Text size (height) 5000
Unique components 32,000  (2,147,483,447)
Via types 50
Wire/line width 255
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Table A-3.  Other Ranges
Type Range Default

Angle range, component rotation -359 to 359

ASCII key code range for hot keys 33-126

Bus bits number range 128

Cartesian coordinates range -30,000 to 30,000

Display range, flash size, PCB Editor 4 to 150 DBUs (60)

Display range, pin size, PCB Editor 4 to 100 DBUs (40)

Display range, pin size, Schematic Editor 1 to 50 DBUs (10)

Display range, solder dot, Schematic Editor 1 to 50 DBUs (10)

Display range, via size, PCB Editor 4 to 100 DBUs (40)

Pin type range (symbols) 0 to 6, 16 to 63

Range, histogram routing grid .01 to 2,000 (50)

Range, histogram signal layers 1 to 20 (2)

Range of D-codes 10-1008

Range of polygon aperture vertices  (or sides) 3-10

Range of ties in a thermal shape description 1-10

Scaling factor range, components 1 to 10,000

Scaling factor range, text 1 to 10,000
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Filename  Extensions B
Table B-1.  Filename Extensions
Extension Description Generated By

.alt Netlist input User (for netlist conversion)

.am Aperture description macro User (for PCB aperture table editor)

.apl Apertures used in design PCB Editor

.apr Aperture table Hardcopy

.atr Attribute Engineering Change Order

.asr Apertures used in plot file Hardcopy

.atr Attribute Engineering Change Order

.bck Back-annotation instruction file PC-PACK

.bka Back-annotation command Engineering Change Order

.bnl Annotated netlist Package Schematic

.cc CalComp plotter vector Hardcopy

.cfg Configuration Any program run from P-CAD 
graphic user interface

.cir Spice file Spice Circuit Writer

.cmd Packaging command log file Package Schematic

.cmd Command log file Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.cm$ Backup command log file Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.cmp Component list report Report Generator

.cth C. Itoh printer format Hardcopy

.ctl Autorouter control (strategy) Autorouter

.dbg Editor debugging Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.dmp Houston Instruments plotter Hardcopy vector

.drc Design rule check report Design Rules Check

.drl Numerically controlled drill data Drill

.dxf DXF format input/output file DXF Reader
DXF Writer

.eco Compare/Analyze phase report Engineering Change Order
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Table B-1.  Filename Extensions (cont'd)

Extension Description Generated By

.edf EDIF fomat input/output file EDIF Reader
EDIF Writer

.eps Epson format Hardcopy

.erc Electrical rule check report Electrical Rules Check

.fil Cross-reference  (ASCII) User (for Package Schematic)

.gbr Gerber format Hardcopy

.his Histogram report PCB Editor

.hp Hewlett-Packard plotter Hardcopy

.hpp Hewlett-Packard  LaserJet Hardcopy
printer format

.ibm IBM printer/plotter format Hardcopy

.icc Interleaf (CC960) format Hardcopy

.ins Component insertion Auto-Insertion

.key Saved function key file User (created in any
graphics editor)

.lgr Gerber laser photoplotter format Hardcopy

.lgx RS-274-X photoplotter format Hardcopy

.log Message log file (DOS) Any program run from P-CAD 
graphic user interface and 
command line

.LOG Message log file (UNIX) Any program run from P-CAD 
graphic user interface and 
command line

.mac macro file User (created in graphics

editor or text editor)

.map DXF translation map file DXF Reader

DXF Writer

.mat Materials list report Report Generator

.mda MDA Fire 2000 photoplotter Hardcopy
format

.mfg NC drill table Drill

.nde Netlist report Report Generator

.nlc Report Netlist Comparison

.nlt Schematic netlist Package Schematic

.nz Bruning (Nicolet) Zeta plotter Hardcopy

.oki Okidata printer format Hardcopy

.out Component name change report Engineering Change Order

.pas Check pass file Design Rules Check (DRC)
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Table B-1.  Filename Extensions (cont'd)

Extension Description Generated By

.pbk Backup PCB Engineering Change Order 
Autorouter

.pdf Database  (ASCII) PDIF  Writer

.pin Pin Information List PCB Editor

.pkg Packaged PCB database Package Schematic

.pkl Packaging list report Report Generator

.plc Placed PCB database User

.plt Plot instruction file (binary) Schematic Editor
PCB Editor
Symbol Editor
Part Editor

.plb PCB part library archive Library Maintenance

.pnl Packaged PCB netlist  (binary) Package Schematic

.ppp plot device configuration file Hardcopy

.prt PCB part Part Editor

.ps Padstack Part Editor

.psc Postscript format Hardcopy

.pty Pin type report  Generate Reports

.rcf Autorouter control  file Autorouter

.rep Autorouter report  Autorouter

.rhf Autorouter history file Autorouter

.rpt Part/symbol pin information Component Editor
table report

.rpt Swap report log file PCB Editor

.rp1 Report Convert Netlist to PCB

.rp2 Report Convert Netlist to PCB

.rp3 Report Convert Netlist to PCB

.rp4 Report Convert Netlist to PCB

.rte Autorouter extraction Autorouter

.rts Autorouter solution Autorouter

.rul Design rules file Design Rules Check (DRC)

.sbk Backup schematic database Schematic Editor

.sch Schematic database Schematic Editor

.sdt Solder dot special symbol User

.si Source specification User

.slb Schematic symbol library Library Maintenance
archive

.ssf Special symbol file User (for PCB Editor)

.swr Improve placement log PCB Editor
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Table B-1.  Filename Extensions (cont'd)

Extension Description Generated By

.sym Schematic symbol Symbol Editor

.tbl NC drill table Drill

.upd Update command file Engineering Change Order (ECO)

.wrl Wire list Report Generator

.xnl Expanded schematic netlist Package Schematic

.xrf Nodes cross-reference file Spice Circuit Writer
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Reserved Words      C
This appendix lists DOS reserved device names and attribute
keywords.

DOS Reserved Device Names
Don't use the following DOS reserved device names in filename
prefixes:

aux

com1

com2

com3

com4

con

lpt1

lpt2

lpt3

nul

prn

Refer to your DOS manual for more information.



Reserved Words

88 What’s New for MD 8.6

Attribute Keywords
Certain keywords have predefined functions in specific tools. Table
C-1 lists the keywords and tools.

Table C-1.  Reserved Keywords With Predefined Functions
Keyword Tool

CARDx (where x is a number) SPICE Circuit Writer

COMPARE=MECH Part Editor, PCB Editor

DEVICE EDIF Netlist Reader
EDIF Netlist Writer

FP Part Editor
PCB Editor

INCLx (where x is a number) SPICE Circuit Writer

NET Symbol Editor
Schematic Editor

PACKAGE EDIF Netlist Reader
EDIF Netlist Writer

PCERC Electrical Rules Check

PGCONN EDIF Netlist Reader
EDIF Netlist Writer
Electrical Rules Check

PINATT? EDIF Netlist Reader
EDIF Netlist Writer

PNAME SPICE Circuit Writer

PRT Symbol Editor
Schematic Editor
Package Schematic

PWGD Symbol Editor
Schematic Editor
Package Schematic
Component Editor

PWGDi (where i is a number) Symbol Editor
Schematic Editor
Package Schematic
Component Editor

REFDPRE SPICE Circuit Writer
EDIF Netlist Writer

RVALUE Electrical Rules Check

SHEET Symbol Editor
Schematic Editor
Electrical Rules Check

SNAME SPICE Circuit Writer

S$P SPICE Circuit Writer

SPCC SPICE Circuit Writer
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Table C-1.  Reserved Keywords With Predefined Functions (con’t)
Keyword Tool

SPGN SPICE Circuit Writer

SPINIT SPICE Circuit Writer

SPMI SPICE Circuit Writer

SPPx (where x is a number)  SPICE Circuit Writer

SPTI SPICE Circuit Writer

SPVC SPICE Circuit Writer

TARGET Auto-Insertion
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Button Menu Trees D
This appendix contains menu trees for button menus that appear in
a graphics editor when you choose the MnBtn option in the status
area.
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Symbol Editor

Save

Load
Plot
Clear Db.
Level Push

Level Pop
Print

Quit

File

Text
Line
Rectangle

Filled Rect
Circle
Filled Circ
2 Pt. Arc

3 Pt. Arc

Draw

Add Vertex
Move Vertex
Del. Vertex
Attribute
Del Segment
Pkg. Data
Pin Type

Seg. Layer

Mov Segment
Keyword

Edit

Pin Sequenc

Comp. Type
Pin
Attribute
Origin

Pkg. Data
Pin Type

Enter

Object
Pin
Properties

Query

Pin

Name
Object

Objects
Window
Attribute
Undo

Move
Object

Objects
Window

Copy
Object

Objects
Window
Attribute

Chg .
Layer

Object
Objects
Window

Undo

Rotate

Object
Objects
Window

Attribute
Undo

Delete

Store View

Recall View
Long Pan
Measure

Display

Environment

DOS Shell (DOS only)
Change Unit
Statistics

Snap Tol.
Mask Items
Detail Mode

Figure D-1.  The Symbol Editor Button Menu Tree
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Schematic Editor

Save
Load
Plot
Save Block

Load Block
Clear Db.
Level Push
Level Pop

Print
Quit

File

Text
Line
Rectangle
Filled Rect

Circle
Filled Circ
2 Pt. Arc
3 Pt. Arc

Draw

Move All
Wire
Add Vertex
Move Vertex

Del. Vertex
Attribute
Del Segment
Seg. Layer

Mov Segment
Keyword
Net Attr

Edit

Wire
Bus
Component
Uncomm. Pin

Attribute
Repl. Comp
RefDes/Sect
Global Net

Enter

Object
Net
Component
Pin

Crit. Path
Group
Properties

Query

Net
Subnet
Component

Name

Object
Objects
Window
Component

Attribute
Undo
Crit. Path
Group

Move

Object
Objects
Window

Copy

Object
Objects
Window

Attribute

Chg.
Layer

Object
Objects
Window
Component

Undo

Rotate

Object
Objects
Window
Attribute

Undo

Delete

Add Gate
Remove Gate
Change Name
Break Link

Remove Def.

Crit. Path

Add Gate
Remove Gate
Change Name

Remove Def.

Group

Environment

DOS Shell (DOS only)
Change Unit
Statistics
Snap Tol.

Attach Dots
Mask Items
Symbol Mode

Store View
Recall View
Long Pan
PthGrp Vis.

Measure

Display

Figure D-2.  The Schematic Editor Button Menu Tree
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Part Editor

Save

Load

Plot
Clear Db.
Level Pop

Print
Quit

File

Text

Line
Rectangle
Filled Rect
Circle

Filled Circ

2 Pt. Arc
3 Pt. Arc
Polygon

Flash
Circ. Void

Poly. Void

Draw

Add Vertex

Move Vertex
Del. Vertex
Attribute
Undo

Pkg. Data

Pin Type
Seg. Layer
Mov Segment

Del Segment
Keyword

Edit

Pin Sequenc

Comp. Type

Pin
Attribute
Mixed Pkg.

Origin
Jumper

Pkg. Data
Pin Type

Enter

Object

Pin
Properties

Query

Pin

Name

Object

Objects

Window
Attribute
Undo

Move

Object

Objects

Window

Copy

Object

Objects

Window
Attribute

Chg.
Layer

Object

Objects
Window
Undo

Rotate

Object

Objects
Window
Attribute
Undo

Delete

Store View

Recall View

Long Pan
Measure

Display

Environment

DOS Shell (DOS only)

Change Unit
Statistics
Snap Tol.
Aper. Table

Figure D-3.  The Part Editor Button Menu Tree
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PCB Editor

Save

Load

Plot

Save Block

Load Block

Clear Db.

Level Push

Print

Quit

File

Text

Line

Rectangle

Filled Rect

Circle

Filled Circle

2 Pt. Arc

3 Pt. Arc

Polygon

Flash
Circ. Void

Poly. Void

Draw

Move All

Wire

Add Vertex

Move Vertex

Del. Vertex

Attribute

Trace

Undo

Add Via

Move Via
Delete Via

Seg. Layer

Mov Segment

Del Segment

Trace Width

Keyword

Net Attr

Edit

Wire

Ratsnest

Component

Uncomm. Pin

Attribute

Repl. Comp

Origin

Polygon

Enter

Object

Net

Net Pins

Component

Pin

Via

Trace

Net Vias

Polygon

Poly Window
Crit. Path

Group

Padstack

Apertures

Properties

Query

Net

Subnet

Component

Reseq Refd.

Reseq Wind.

Name

Object

Objects

Window

Component

Attribute

Undo

Crit. Path

Group

Move

Object

Objects

Window

Trace

Copy

Object

Objects

Window

Component

Attribute

Chg.
Layer

Object

Objects

Window

Component

Undo

Rotate

Object

Objects

Window

Attribute

Trace

Undo

Delete

Add Gate

Remove Gate

Change Name

Break Link

Remove Def.

Crit. Path

Add Gate

Remove Gate

Change Name

Remove Def.

Group

Component

Pin

Gate

Undo

Swap

Dimension

Configure

Point

Datum

Leader

Center One

Center All

Diameter

Radius

Angular

Adjust
Bind

Unbind

Figure D-4.  The PCB Editor Button Menu Tree
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PCB Editor (con’t)

Store View
Recall View
Long Pan
PthGrp Vis.
Ctrl Rats.
Measure

DisplayEnvironment

DOS Shell (DOS only)
Change Unit
Statistics
Snap Tol.
Attach Pads
Mask Items
Layer Pairs
Void Merge
Min PolySiz
Min PolyClr
Inr Pln Apr
Set Min Apr
Aper. Table
Clear Flash
Min FlshClr

Objects
Window
Component
Undo

Align Placement

Spacing
Def. Comps
Clearances
Association
Barriers
Cutlines
Fix
Unfix
Autoplace
Histogram

➨➨

➨➨

Enter
Delete

Barriers

Window
Component

Fix

Window
Component

Unfix

Configure
Grid
Gen. Stats
Reset Merit

Histogram

Component
Gate

Improve Plc

➨➨

Figure D-4.  The PCB Editor Menu Tree (cont'd)
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Command Cross Reference E
This appendix contains a command cross-reference, a list of default
hot-key functions, and a chart of the keys available for hot-key
assignment.

Table E-1 contains a complete cross-reference of MD 5.0 and MD
8.6 graphic editor commands and keyboard-equivalent  commands.
Refer to the Command Reference manual for a complete description
of each command.

Commands are listed in alphabetical order by the MD 8.6
commands. Commands that appear in lower case, such as /rctl,
have no equivalent menu command for the P-CAD version they're
listed under. Keyboard and keyboard-equivalent commands are not
case-sensitive.

Table  E-1.  Command Cross Reference

MD 8.6 Keyboard
MD 5.0 Command MD 8.6 Command Equivalent

a (wire bend hot key) a a
a a /bend
n/a /ably /ably
ALGN Align→Components ALGN
ALGN/IDEN Align→Objects ALGN/IDEN
ALGN/UNDO Align→Undo ALGN/UNDO
ALGN/WIN Align→Window ALGN/WIN
/alyr /alyr /alyr
ATTR/DATR Delete→Attribute DEL/ATRB
c (curved wire hot key) c c
c c /wcrv
/cfil /cfil /cfil
n/a Chg. Layer→Attribute CLYR/ATRB
CLYR/COMP Chg. Layer→Component CLYR/COMP
FLIP Chg. Layer→Component CLYR/COMP
CLYR Chg. Layer→Object CLYR
CLYR/IDEN Chg. Layer→Objects CLYR/IDEN
CLYR/WIN Chg. Layer→Window CLYR/WIN
COPY Copy→Object COPY
COPY/IDEN Copy→Objects COPY/IDEN
COPY/TRCE Copy→Trace COPY/TRCE
COPY/WIN Copy→Window COPY/WIN
/cpos /cpos /cpos
CPTH/TAG Crit. Path→Add Gate CPTH/TAG
CPTH/UNLK Crit. Path→Break Link CPTH/UNLK
CPTH/RNAM Crit. Path→Change Name CPTH/RNAM
CPTH/RSET Crit. Path→Remove Definition CPTH/RSET
CPTH/UTAG Crit. Path→Remove Gate CPTH/UTAG
ATTR/DATR Delete→Attribute DEL/ATRB
DEL Delete→Object DEL
DEL/IDEN Delete→Objects DEL/IDEN
DEL/TRCE Delete→Trace DEL/TRCE
DEL/UNDO Delete→Undo DEL/UNDO
DEL/WIN Delete→Window DEL/WIN
 n/a Dimension→Adjust ADIM/AJST
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Table E-1.  Command Cross Reference (cont’d)
MD 8.6 Keyboard

MD 5.0 Command MD 8.6 Command Equivalent
n/a Dimension→Angular ADIM/ANGL
n/a Dimension→Bind ADIM/DGRP
n/a Dimension→Center All ADIM/CALL
n/a Dimension→Center One ADIM/CONE
n/a Dimension→Configure ADIM/CNFG
n/a Dimension→Datum ADIM/DATM
n/a Dimension→Diameter ADIM/DIAM
n/a Dimension→Leader ADIM/LEAD
n/a Dimension→Point ADIM/PONT
n/a Dimension→Radius ADIM/RADI
n/a Dimension→Unbind ADIM/UGRP
/rctl Display→Control Ratsnest RCTL
/lpan Display→Long Pan LPAN
/rulr Display→Measure RULR
/pctl Display→Path/Group Visiblity PCTL
RCL Display→Recall View RCL
n/a Display→Recall View 1 RC1
n/a Display→Recall View 2 RC2
n/a Display→Recall View 3 RC3
n/a Display→Recall View 4 RC4
n/a Display→Recall View 5 RC5
n/a Display→Recall View 6 RC6
n/a Display→Recall View 7 RC7
n/a Display→Recall View 8 RC8
n/a Display→Recall View 9 RC9
n/a Display→Recall View 10 RC10
STO Display→Store View STO
n/a Display→Store View 1 ST1
n/a Display→Store View 2 ST2
n/a Display→Store View 3 ST3
n/a Display→Store View 4 ST4
n/a Display→Store View 5 ST5
n/a Display→Store View 6 ST6
n/a Display→Store View 7 ST7
n/a Display→Store View 8 ST8
n/a Display→Store View 9 ST9
n/a Display→Store View 10 ST10
DRAW/ARC Draw→2-Point Arc DRAW/ARC
DRAW/ARCP Draw→3-Point Arc DRAW/ARCP
DRAW/CIRC Draw→Circle DRAW/CIRC
DRAW/CVOD Draw→Circular Void DRAW/CVOD
n/a Draw→Filled Circle DRAW/FCIR
DRAW/FREC Draw→Filled Rectangle DRAW/FREC
DRAW/FLSH Draw→Flash DRAW/FLSH
DRAW/LINE Draw→Line DRAW/LINE
DRAW/POLY Draw→Polygon DRAW/POLY
DRAW/PVOD Draw→Polygonal Void DRAW/PVOD
DRAW/RECT Draw→Rectangle DRAW/RECT
DRAW/TEXT Draw→Text DRAW/TEXT
n/a /dly /dly
/drc /drc /drc
/dyn /dyn /dyn
EDIT/ADDV Edit→Add Vertex EDIT/ADDV
EDIT/AVIA Edit→Add Via EDIT/AVIA
ATTR/SCHG Edit→Attribute EDIT/ATRB
EDIT/DELS Edit→Delete Segment EDIT/DELS
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Table E-1.  Command Cross Reference (cont’d)
MD 8.6 Keyboard

MD 5.0 Command MD 8.6 Command Equivalent
n/a Edit→Delete Trace EDIT/TRCE
EDIT/DELV Edit→Delete Vertex EDIT/DELV
EDIT/DVIA Edit→Delete Via EDIT/DVIA
n/a Edit→Keyword EDIT/KWD
EDIT/MOVA Edit→Move All EDIT/MOVA
EDIT/MOVS Edit→Move Segment EDIT/MOVS
EDIT/MOVV Edit→Move Vertex EDIT/MOVV
EDIT/MVIA Edit→Move Via EDIT/MVIA
n/a Edit→Net Attr EDIT/NATR
SCMD/EPKG Edit→Packaging Data EPKG
SCMD/EPNL Edit→Packaging Data EPNL
n/a Edit→Pin Type EDIT/SPAT
EDIT/LAYS Edit→Segment Layer EDIT/LAYS
n/a Edit→Trace Width EDIT/TWID
/undo Edit→Undo Delete Segment UNDO
EDIT/WIRE Edit→Wire EDIT/WIRE
ATTR/ACOM Enter→Attribute ENTR/ATRB
ENTR/ORG Enter→Board Origin ENTR/ORG
ENTR/BUSB Enter→Bus ENTR/BUSB
ENTR/COMP Enter→Component ENTR/COMP
SCMD/SCAT Enter→Component Type ENTR/SCAT
SCMD/SNAT Enter→Global Net ENTR/SNAT
SCMD/JMPR Enter→Jumper ENTR/JMPR
SCMD/NPKG Enter→Nonhomogeneous Pkg ENTR/NPKG
ENTR/ORG Enter→Origin ENTR/ORG
SCMD/PNLC Enter→Packaging Data ENTR/PNLC
SCMD/SPKG Enter→Packaging Data ENTR/SPKG
ENTR/PIN Enter→Pin ENTR/PIN
ENTR/SEQ Enter→Pin Sequence ENTR/SEQ
SCMD/SPAT Enter→Pin Type ENTR/SPAT
ENTR/POLY Enter→Polygon ENTR/POLY
ENTR/RATN Enter→Ratsnest ENTR/RATN
NAME/REFD Enter→Ref.Des.& Section ENTR/PNUM
SCMD/PNUM Enter→Ref.Des.& Section ENTR/PNUM
/repl Enter→Replace Component REPL
ATTR/ACOM Enter→Sheet Number ENTR/SHID
ENTR/UCOM Enter→Uncommit Pin ENTR/UCOM
ENTR/WIRE Enter→Wire ENTR/WIRE
SCMD/LPAR Environment→Assign Layer Pairs LPAR
SCMD/GSSF Environ.→Attach Cust.Sold.Dots GSSF
SCMD/GSSF Environment→Attach Padstacks GSSF
SCMD/UNIT Environment→Change Units UNIT
SYS/DOS Environment→DOS Shell DOS
DETL Environment→Detail Mode DMOD
SYS/STAT Environment→Display Statistics STAT
n/a Environment→Edit Aperture Table ATE
SCMD/SIPC Environ.→Inner Plane Apertures SIPC
/mask Environment→Mask Items MASK
/msk Environment→Mask Items MSK
SCMD/VMRG Environ.→Merge Polygon Voids VMRG
n/a Environ.→Merge Voids by Layer VMBL
n/a Environ.→Merge Voids by Poly VMBP
SCMD/PSIZ Environment→Min. Polygon Size PSIZ
SCMD/PCLR Envir.→Polygon Wire Clearance PCLR
n/a Environ.→Set Minimum Aperture MAPW
/sgat Environment→Set Snap Tolerance SGAT
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Table E-1.  Command Cross Reference (cont’d)
MD 8.6 Keyboard

MD 5.0 Command MD 8.6 Command Equivalent
SYMB Environment→Symbol Mode SMOD
/exe /exe /exe
/exec /exec /exec
n/a /fast /fast
FILE/ZAP File→Clear Database FILE/ZAP
SYS/PLOT File-Create Plot File FILE/PLOT
FILE/POP File→Level Pop FILE/POP
LEVL/POP File→Level Pop FILE/POP
FILE/PUSH File→Level Push FILE/PUSH
LEVL/PUSH File→Level Push FILE/PUSH
FILE/LOAD File→Load FILE/LOAD
FILE/BKLD File→Load Block FILE/BKLD
n/a File→Print FILE/PRINT
SYS/QUIT File→Quit FILE/QUIT
FILE/SAVE File→Save FILE/SAVE
FILE/BKSV File→Save Block FILE/BKSV
/fit Fit View FIT
/fitv Fit View FITV
n/a /grid /grid
GRP/TAG Group→Add Gate GRP/TAG
GRP/RNAM Group→Change Name GRP/RNAM
GRP/RSET Group→Remove Definition GRP/RSET
GRP/UTAG Group→Revome Gate GRP/UTAG
IMPR/COMP Improve Plc→Components IMPR/COMP
IMPR/GATE Improve Plc→Gates IMPR/GATE
/intr /intr /intr
/lang /lang /lang
/lsty /lsty /lsty
/lwid /lwid /lwid
/lyrn /lyrn /lyrn
n/a Last View PREV
/mac /mac /mac
n/a Main Menu /main
/mend /mend /mend
n/a /menu /menu
MOVE/ATRB Move→Attribute MOVE/ATRB
MOVE/COMP Move→Component MOVE/COMP
MOVE/APTH Move→Critical Path MOVE/CPTH
MOVE/AGRP Move→Group MOVEAGRP
MOVE Move→Object MOVE
MOVE/IDEN Move→Objects MOVE/IDEN
MOVE/UNDO Move→Undo MOVE/UNDO
MOVE/WIN Move→Window MOVE/WIN
NAME/COMP Name→Component NAME/COMP
NAME/NET Name→Net NAME/NET
NAME/PIN Name→Pin NAME/PIN
NAME/RSEQ Name→Reseq. Ref. Desd NAME/RSEQ
n/a Name→Reseq. Window NAME/SEQW
NAME/SUBN Name→Subnet NAME/SUBN
/ofly /ofly /ofly
n/a /only /only
n/a /osel /osel
PAN Pan PAN
Pan Bars Shift Pan [SHIFT]+[Btn 1]
/pdel /pdel /pdel
/pend /pend /pend
/pkey /pkey /pkey
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Table E-1.  Command Cross Reference (cont’d)
MD 8.6 Keyboard

MD 5.0 Command MD 8.6 Command Equivalent
/pkld /pkld /pkld
/pksv /pksv /pksv
/pzap /pzap /pzap
PLCE Placement→Automatic Placement PLCE
BARR/DEL Placement→Define Barriers→Delete BARR/DELB
BARR/DELB Placement→Define Barriers→Delete BARR/DELB
BARR Placement→Define Barriers→Enter BARR
ASSC Placement→Define Lattices→ ASSC

Associate Discretes
LATC Placement→Define Lattices→ LATC

   Define Components
LATP Placement→Define Lattices→ LATP

   Enter Spacing
CLR Placement→Define Lattices→ CLR

   Specify Clearance
CUT Placement→Enter Cutlines CUT
FIX Placement→Fix→Component FIX
FIX/WIN Placement→Fix→Window FIX/WIN
HIST/CNFG Placement→Histogram→Configure HIST/CNFG
HIST/GRID Placement→Histogram→Define Grid HIST/GRID
HIST/STAT Placement→Histogram→ HIST/STAT

   Generate Statistics
HIST/RSET Placement→Histogram→ HIST/RSET

   Reset Merit Factor
UNFX Placement→UnFix→Component UNFX
UNFX/WIN Placement→UnFix→Window UNFX/WIN
n/a Query→Apertures QRY/APRS
QRY/COMP Query→Component QRY/COMP
QRY/APTH Query→Critical Path QRY/APTH
QRY/AGRP Query→Group QRY/AGRP
QRY/NET Query→Net QRY/NET
QRY/NPIN Query→Net Pins QRY/NPIN
n/a Query→Net Vias QRY/NVIA
QRY Query→Object QRY
QRY/PSTK Query→Padstack QRY/PSTK
QRY/PIN Query→Pin QRY/PIN
n/a Query→Polygon QRY/POLY
n/a Query→Polygon Window QRY/PWIN
n/a Query→Properties QRY/PROP
n/a Query→Trace QRY/TRCE
QRY/VIA Query→Via QRY/VIA
/rcmn n/a n/a
RCL Recall View RCL
REDR Redraw REDR
n/a /regn /regn
/resu /resu /resu
ROT/COMP Rotate→Component ROT/COMP
ROT Rotate→Object ROT
ROT/IDEN Rotate→Objects ROT/IDEN
ROT/UNDO Rotate→Undo ROT/UNDO
ROT/WIN Rotate→Window ROT/WIN
/stgl /stgl /stgl
SWAP/COMP Swap→Component SWAP/COMP
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Table E-1.  Command Cross Reference (cont’d)
MD 8.6 Keyboard

MD 5.0 Command MD 8.6 Command Equivalent
SWAP/GATE Swap→Gate SWAP/GATE
SWAP/PIN Swap→Pin SWAP/PIN
SWAP/UNDO Swap→Undo SWAP/UNDO
n/a /tmod  /tmod
/ucp /ucp /ucp
/undo /undo /undo
VLYR View Layer VLYR
VSAV n/a n/a
VWIN View Window VWIN
/wait /wait /wait
x (full screen cursor x (full screen cursor hot key) x
  hot key)
x x /xhar
ZIN Zoom In ZIN
ZOUT Zoom Out ZOUT

Table E-2 describes the default hot-key assignments for MD 8.6
commands or functions. Hot keys for subcommands will be
recognized only if the main menu command has already been
executed. For example, to move a wire vertex, press E to activate
Edit, then G to execute the Move→Vertex command.

Table E-2.  Default Hot Key Key Functions
Key Command or Function

a Toggle wire bend
b Delete Vertex
c Toggle curved wire (PCB Editor only)
d Delete
e Edit
f File
g Move Vertex
h Delete Segment
 i Wire
 j Move Segment
 k Component
 l Load
m Move
n Enter
o Objects
p Pan
q Query
r Rotate
Alt +R rotate clockwise
Ctrl +R rotate counterclockwise
s Save
t Trace (PCB Editor only)
u Undo
v Add Vertex
w Window
x Cursor type (regular, vertical or diagonal cross hair)
y Segment Layer
z, + Zoom In
Z*, - Zoom Out

* Note:  Except for Z only lower-case keys have default functions.
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Table E-3 contains a chart of the ASCII characters available for hot-
key assignment in MD 8.6.

Table E-3.  ASCII Key Codes Available For Hot Key Assignment
ASCII Key Codes

↓↓ Left Right
Digit Digit 0 1 2 3 4 5 6 7 8 9

3 ! ” # $ % & ’
4 ( ) * + , - . n/a 0 1
5 2 3 4 5 6 7 8 9 : ;
6 < = > ? @ A B C D E
7 F G H I J K L M N O
8 P Q R S T U V W X Y
9 Z [ \ ] ^ - ‘ a b c
10 d e f g h I j k l m
11 n o p q r s t u v w
12 x y z { | } ˜

ASCII key codes range from 00 to 127. The following characters or
ASCII key codes aren't available for hot-key assignment:

• 00 to 31 and 127 aren't available because they're nonprintable
control characters

• 47 (/) is reserved for initiating keyboard commands
• 32 represents a blank and isn't available for user assignment
• Shift , Ctrl , Alt , ◊◊, <, and > can't be used to assign commands or

functions to P-CAD hot keys

This appendix lists a command cross-reference, default hot key
functions, and a chart of keys available for hot keys.
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Index
—$—

$ATT Layer
net attribute graphics, 28

—A—
Apertures

scaling, 29
arrow, 7
asterisk, 7
attribute keywords (P-CAD)

attribute keywords (P-CAD), 87

—B—
button menu trees, 91
ByName

selecting components, 14

—C—
CCT SPECCTRA

net attribute support, 29
Changing directories

with file selectors, 12
command cross reference, 99
Components

consistency, 48
definition, 47
selecting by name, 14
updating in database, 48

cycle, 8
cycle symbol, 8

—D—
Deleting

unused layers, 18
Design Manager

standardizing design files, 13
Design Rules Checking

enhanced net attribute support, 25
net attribute graphics on $ATT

layer, 28
device names (DOS), 87
Dimensioning

centered horizontal text, 18

DOS
reserved device names, 87

—F—
File Selectors

enhancements, 12
filename extensions, 83
Filenames

when entering components, 47
Files

acceptable characters for names,
14

standardizing in Design Manager,
13

—H—
Hardcopy

scaling apertures, 29
Hot keys

rotating components, 15
zooming, 15

—I—
Improved selection mechanism

defined, 9
Installing

Master Designer UNIX from CD-
ROM, 28

—K—
keywords

attribute, 87

—L—
Layers

deleting unused, 18

—M—
Master index, 29
menus

slide-off, 7
Move component

enhanced ratsnest display, 17



Index

108 What’s New for MD 8.6

—N—
Net attributes

CCT SPECCTRA support, 29
new for MD 8.6, 15

New net attributes
CLEARANCE, 15
PAD-TO-EDGE, 15
PAD-TO-TRACE, 15
TRACE-TO-EDGE, 15
TRACE-TO-TRACE, 15
VIATYPE, 15

—O—
Object selection commands

improved selection mechanism, 9
toggling between (un)selected

objects, 11
Online documentation

AIX support, 29
master index, 29

Opcodes
updated list, 22

—P—
P-CAD

P-CAD
attribute keywords, 87

PC-WinPlot
defining text stroke widths, 31
multiple plot files, 30

Pins
information report, 32

Plot files
plotting muliple files, 30

—R—
Ratsnest display

enhanced performance, 17
Reference Designators

auto-incrementing, 23, 50
Report Generator

pin information report, 32
reserved words, 87
Rotating components

hot keys, 15

—S—
Schematic Editor

auto-incrementing reference
designators, 23, 50

Selecting components by name, 14
Selecting objects

improved selection mechanism, 9
toggling between selected and

unselected, 11
system limits, 79

—W—
wildcard, 7

—Z—
Zooming

hot keys, 15
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