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Настоящее пособие не раскрывает всех возможностей программы Mi-
crowave Office 2009. Его цель – помочь быстрее освоить основы рабо-
ты в среде моделирования этой программы на конкретных примерах. 
Пособие составлено с использованием Getting Started, входящего в со-
став документации Microwave Office 2009 и которое содержит приме-
ры по различным видам моделирования. К этим примерам добавлен ряд 
других, чтобы показать дополнительные особенности работы в среде 
моделирования, которые полезно освоить уже при первом знакомстве с 
работой программы. 

Е.Е. Дмитриев 

 

Введение 
Одним из популярных программных продуктов, используемых для проектирования радиочас-

тотных устройств и устройств СВЧ, является AWR DESIGN ENVIRONMENT (AWRDE) компании Ap-
plied Wave Research. Он включает в себя три инструментальных средства: Microwave Office (MWO), Vis-
ual System Simulator (VSS) и Analog Office (ANO). Эти средства интегрированы в единую среду проекти-
рования и могут использоваться вместе, не выходя из этой среды. Это пособие включает информацию 
только о Microwave Office. 

Среда проектирования AWR использует единую объектно-ориентированную модель данных, 
синхронизирующую работу над проектом без использования промежуточных трансляторов. Это обеспе-
чивает доступ ко всем необходимым данным независимо от того, чертите вы схему, выполняете её ана-
лиз или формируете топологию. 

Microwave Office позволяет создавать схемы, состоящие из элементов схем (сосредоточенных и 
распределённых) и электромагнитных структур. Схемы могут иметь сложную иерархическую структуру, 
включающую множество подсхем на различных уровнях иерархии. В качестве подсхем могут использо-
ваться ранее созданные схемы или электромагнитные структуры, а также списки цепей, файлы данных 
или элементы из библиотек сторонних пользователей. Для создания схем имеется обширная библиотека 
встроенных схемных элементов. 

Для моделирования можно использовать один из методов: линейное моделирование, одночас-
тотный и многочастотный гармонический баланс, ряды Вольтера, электромагнитное моделирование и др. 
Результаты могут выводиться в различных графических формах или в таблице в зависимости от цели 
проводимого анализа. Имеется множество измеряемых величин, которые можно отобразить на графиках. 
Если же нужной величины в этом множестве всё-таки нет, можно составить уравнение для её вычисле-
ния, и она будет выведена на график. 

Можно настраивать или оптимизировать электрические схемы, созданные в проектах, и все из-
менения немедленно и автоматически отражаются на графиках и в топологии. Теперь появилась возмож-
ность настраивать и оптимизировать и электромагнитные структуры, используя экстракцию, т.е. извле-
чение электромагнитных структур из элементов схемы или из топологии схемы. 

В AWR имеется возможность интеграции программ сторонних производителей. Интерфейс EM 
Socket (двусторонний канал связи) даёт возможность непосредственно из проекта AWR использовать 
вычислительные модули различных производителей программного обеспечения для электромагнитного 
моделирования, поддерживающих этот интерфейс. Анализ топологии устройства, созданной в Microwave 
Office, может быть выполнен с помощью вычисляющих блоков программ CST, Sonnet, Zeland и др. 

Справочная система Microwave Office обеспечивает информацию обо всех окнах, пунктах меню, 
и концепциях. К справочной системе можно обратиться через Пуск>Программы>AWR 
2009>MWO_Help.exe, или выбрав Help из выпадающего меню, или нажав клавишу F1. 

Если вы обновляете версию Microwave Office, то сохраните старую версию до тех пор, пока не 
проверите, работают ли ваши проекты в новой версии. Файл лицензии для версии v9.0 пригоден также и 
для версий v8.X и v7.X. 

При переносе проектов в версию v9.0 из более старых версий, могут возникнуть проблемы. Не-
которые из них устраняются просто. Например, если вы в версии v8.X создали какие-то сценарии, вы 
можете перенести их в версию v9.0 просто скопировав все ваши файлы *.bas из папки Appdata80/scripts 
в папку Appdata90/scripts. 

Если вы настраивали AWRDE v8.X в окне Customize (Tools>Customize или Tools>Hot Keys 
Tools) и хотите сохранить эти настройки в v9.0, скопируйте из папки Appdata80 в папку Appdata90 сле-
дующие файлы: 

o Customizations.xml – содержит установки горячих клавиш, 
o UCustomizatin.xml – содержит установки меню. Однако при копировании этих файлов новые 

или изменённые меню могут быть потеряны в новой версии. Но вы всегда можете перейти к ме-
ню по умолчанию в v9.0. 

o UDockingLayout.xml – содержит установки для закреплённых окон в среде проектирования. 
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o UToolBarLayout.xml – содержит установки панели инструментов. Здесь также есть риск поте-
рять панели инструментов, но всегда можно перейти к панелям по умолчанию. 
Если в версии v8.X вы заполнили Х-модели и хотите их использовать в v9.0, скопируйте все 

файлы с расширением *.emx из папки Appdata80/em_models в папку Appdata90/em_models. 
Более подробную информацию о переносе проектов из более старых версий можно найти в ру-

ководстве пользователя. 
 
 



1 Среда проектирования Microwave Office 

1.1 Запуск Microwave Office 
Чтобы запустить Microwave Office нажмите кнопку Пуск в Windows и выберите Програм-

мы>AWR2009>AWR Design Environment. Откроется главное окно Microwave Office, показанное на рис. 
1.1. 

Альтернативно можно запустить файл MWOffice.exe, который по умолчанию находится в папке 
C:\Program Files\AWR\AWR2009. Для удобства значок этого файла можно вывести на рабочий стол. 
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1.2 Компоненты среды проектирования 
Главное окно Microwave Office содержит все компоненты, которые составляют среду проектиро-

вания. Именно через это окно проектируются линейные и нелинейные схемы, устанавливаются электро-
магнитные структуры (EM), создаются топологии, исполняется моделирование, и отображаются графи-
ки. Основные компоненты среды проектирования описаны ниже: 
Компонент Описание 
Меню Строка выпадающих меню, расположенная в верхней части окна, для выполнения раз-

личных задач Microwave Office. В выпадающих меню слева от команды отображается 
соответствующий этой команде значок на панели инструментов, а справа – горячая 
клавиша. 

Панель инст-
рументов 

Строка значков, расположенных ниже выпадающего меню, которые обеспечивают дос-
туп к часто используемым командам типа создания новых схем, выполнения моделиро-
вания, или настройки значений параметров или переменных.  

Окно просмот-
ра проекта 

Древовидная структура групп и модулей, которая определяет активный проект Micro-
wave Office, включая схемы, электромагнитные структуры (ЕМ), частоты моделирова-
ния и выходные графики. Это окно активно при загрузке программы или после щелчка 
по панели Project в нижней части левого окна. 

Рабочее поле Зона, в которой проектируются схемы, электромагнитные структуры (EM), отобража-
ются и редактируются топологии, и выводятся графики. Размер рабочего поля можно 
изменять, если установить курсор мышки на левую или нижнюю границу поля, и пере-
мещать мышку с нажатой левой кнопкой. 

Панели Строка панелей, расположенная в нижней части левого окна, которая позволяет пере-
ключать содержимое этого окна. 
Project – включает окно просмотра проекта. 
Elements – включает окно просмотра элементов для формирования схем. 
Layout – включает окно менеджера топологии, которое позволяет определить парамет-
ры для черчения и просмотра топологии. 

Окно статуса В этом окне отображается ход выполнения моделирования и возникающие ошибки. 

Строка заголовка 
Главнее меню 

Панель инструментов 

Окно просмотра 
проекта 

Рабочее поле 

Окно статуса 
Панели 

Рис. 1.1 
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Многие функции и команды, доступные из меню, также доступны через панель инструментов 
и/или окно просмотра проекта. 

Вид и состав меню и панели инструментов динамически изменяются в зависимости от открытого 
активного окна. Чтобы узнать команду, с которой связан значок на панели инструментов, установите 
курсор мышки на этот значок и подержите несколько секунд. 

Окно просмотра проекта всегда активно после загрузки Microwave Office. Щёлкните правой 
кнопкой мышки по группе в окне просмотра проекта, чтобы вызвать всплывающее меню с соответст-
вующими этой группе командами. 

В пределах рабочего поля вы можете перемещаться, используя вертикальную и горизонтальную 
полосы скроллинга и изменять размеры внутри окна, используя значки на панели инструментов. Вы мо-
жете щёлкать по элементам схемы правой кнопкой мышки, чтобы вызвать всплывающее меню с соответ-
ствующими командами. Вы можете также копировать и вставлять элементы, порты и проводники из од-
ной схемы или проекта в другие, используя значки копирования и вставки на панели инструментов. 

На вкладке Project левого окна проекта отображается дерево групп и модулей, которые уже ис-
пользуются, а также могут быть использованы в данном проекте. Сюда входят: 

 
o модуль примечаний к проекту (Design Notes); 
o модуль задания глобальных опций проекта (Project Options); 
o модуль глобальных выражений (Global Equations); 
o модуль использования внешних файлов данных (Data Files); 
o группа используемых схем системы для VSS, если VSS инсталлировано (System Diagrams); 
o группа используемых схематических модулей (Circuit Schematics); 
o группа используемых электромагнитных структур (EM Structures); 
o модуль выходных уравнений (Output Equations); 
o группа отображения результатов анализа (Graphs); 
o группа целей оптимизации (Optimizer Goals); 
o группа целей статистического анализа (Yield Goals); 
o список выходных файлов (Output Files); 
o группа мастеров (Wizards); 
o группа папок, которые может создавать пользователь (User Folders) для группирования и хране-

ния отдельных частей проекта (схемы, графики и т.д.) в сложных проектах. 
 

Чтобы раскрыть группу, содержащую подгруппы, нужно щёлкнуть мышкой по значку “+” слева 
от группы. У раскрытой группы значок “+” меняется на “-”, щелчок мышкой по которому сворачивает 
группу. 

Двойной щелчок мышкой по группе или модулю вызывает различные действия в зависимости от 
назначения группы или модуля. Двойной щелчок по Design Notes, Global Definitions и Output Equations 
открывает соответственно окна для создания примечаний к проекту (это одно из немногих мест в Micro-
wave Office, где можно использовать русские буквы), создания глобальных определений проекта и соз-
дания выходных соотношений. Двойной щелчок по Project Options открывает диалоговое окно для оп-
ределения опций проекта. Двойной щелчок по остальным группам и модулям не вызывает никаких дей-
ствий. 

Щелчок правой кнопкой мышки по любой группе или модулю, а также по любому объекту про-
екта, открывает контекстные меню, предлагающие на выбор список возможных дальнейших действий. 

Контекстное меню, появляющееся при щелчке правой кнопкой мышки по элементу, даёт воз-
можность изменить отображение элементов в окне, а также содержит команду вызова справки об этом 
элементе. 

Группа отображения результатов анализа на вкладке Project предлагает наглядную демонстра-
цию результатов расчета на диаграммах различного типа в зависимости от выбранного типа анализа. 

Здесь возможно простое отображение S-параметров схем на диаграммах Смита, графиках в пря-
моугольных и полярных координатах, а также более сложная прорисовка форм и спектров сигналов в 
различных точках схемы или диаграмм направленности антенн, да еще и в диапазоне частот. 

Заметим также, что именно эта группа, совместно с используемыми моделями элементов и сиг-
нальных портов, является определяющей при выборе того метода анализа, который будет использоваться 
в вашем проекте. Кроме того, в одном проекте могут комбинироваться различные методы анализа, а их 
результаты отражаться на одних и тех же графиках. 

Группа оптимизации содержит список назначенных целей оптимизации текущей схемы. Под це-
лью оптимизации здесь подразумевается некоторая граница изменения какой-либо характеристики ана-
лизируемой схемы, к которой должен стремиться выбранный метод оптимизации при изменении опреде-
ленных параметров элементов. 

Каждая введенная цель оптимизации сразу же отображается на соответствующем графике, что 
позволяет в последующем легко проверить ее параметры, а также легко изменить их тут же на графике с 
помощью мышки. 

Заметим, что оптимизация и настройка не работают в электромагнитном моделировании, кото-
рое позволяет выполнить анализ созданной топологии на электродинамическом уровне, если только 



электромагнитная структура создана вручную, а не получена с помощью экстракции (т.е. извлечения) из 
имеющейся в проекте схемы. 

Электромагнитная структура представляет собой набор проводящих и резистивных полигонов, а 
также межслойных соединений произвольной геометрической формы. Она может анализироваться в ре-
шающих устройствах (симуляторах) EMSight, AXIEM или в решающих устройствах сторонних произво-
дителей. Если используется EMSight, структура анализируется внутри ограниченной многослойной об-
ласти прямоугольной формы. Боковые границы этой области всегда идеально проводящие, а верхняя и 
нижняя границы могут быть заданы тремя различными способами: проводящая поверхность с потерями 
(или без них), эквивалент открытого пространства и бесконечного волновода. Количество анализируе-
мых слоев, межслойных соединений и внешних портов теоретически неограниченно. В AXIEM боковые 
стенки отсутствуют. 

Графические возможности модуля электродинамического анализа позволяют пользователю на-
блюдать цветное трехмерное анимационное изображение токов высокой частоты, на котором отобража-
ется не только амплитуда, но и направление этих токов. 

На вкладке Elements отображается дерево используемых библиотек "зашитых" моделей элемен-
тов построения схематических модулей: портов, источников, сосредоточенных и распределенных, ли-
нейных и нелинейных, идеальных и неидеальных элементов, а также внешних импортируемых библио-
тек моделей и подсхем. Все модели объединены в соответствующие группы, содержание которых ото-
бражается в нижней части окна. Добавление того или иного элемента в схему проекта производится при-
вычным методом Drag-and-Drop (возьми-и-брось), а редактирование параметров – или в списке прямо на 
схеме, или в специальном диалоговом окне, открывающемся при двойном щелчке по элементу. 

1.3 Интерфейс пользователя 
Начиная с 7-ой версии, интерфейс пользователя сделан более гибким, и пользователь может из-

менять отображение элементов главного окна. Часть этих нововведений некоторые пользователи счита-
ют “архитектурными излишествами”, однако иметь представления о них нужно, например, если потре-
буется максимально увеличить площадь рабочего поля. Или, если случайным щелчком мышки будет 

изменён интерфейс и воз-
никнет вопрос, как вер-
нуться обратно. 
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Вкладки Project, 
Elements, Layout и окно 
статуса теперь могут ав-
томатически скрываться, 
освобождая при необхо-
димости больше места для 
рабочего поля. Если вы 
хоте скрыть какое-либо из 
этих окон, щёлкните по 
значку Auto Hide  в 
авом верхнем углу со-

ответствующего окна. 
Когда окна скрыты, имена 
вкладок Project, Elements 
и Layout отображаются в 
левой части основного 
окна, а имя окна статуса – 
в левой нижней части 
(рис. 1.2). 

пр

Чтобы открыть 
скрытое окно, достаточно 
подвести на его имя кур-

сор мышки. Открытое таким образом окно можно временно закрепить, щёлкнув в нём мышкой. Или вос-
пользоваться командами меню View. После временного закрепления окно автоматически скрывается при 
щелчке мышкой в любом месте вне окна. 

Рис. 1.2 

Вновь открыть и постоянно закрепить скрытое окно можно, если открыть его и щёлкнуть мыш-
кой по значку Auto Hide  или дважды щёлкнуть по заголовку открытого окна. 

Если дважды щёлкнуть мышкой по строке заголовка окна или по имени окна на панели в нижней 
части окна, оно приобретает вторую форму, меняет цвет и теряет возможность автоматически скрывать-
ся. Размеры таких окон можно изменять в любом направлении. Для этого нужно установить курсор на 
соответствующую границу окна так, чтобы курсор отображался в виде двойной стрелки. Затем нажать 
левую кнопку мышки и перемещать границу. Если установить курсор на заголовок окна и нажать левую 
кнопку мышки, окно можно переместить в другое место. При этом на экране отображаются маркеры, 



указывающие направления, в которых можно двигать окно. Если при перемещении нажать клавишу Ctrl, 
то маркеры исчезают. 

Таким же образом можно перемещать и основной вид окон. Однако при этом окно автоматиче-
ски приобретает вторую форму. 

Заметим, что при втором виде окон, часть рабочего поля скрывается под таким окном, что обыч-
но неудобно, т.к. скрывается часть окна, расположенного на рабочем поле (схемы, графика и т.д.). 

Чтобы вернуть первоначальный вид окон, нужно снова дважды щёлкнуть мышкой по заголовку 
окна или по имени окна в нижней части. 

Все эти окна можно вообще удалить, щёлкнув мышкой по значку  в правой верхней части ок-
на. Вновь открыть окно можно, воспользовав-
шись командами меню View. 

Панели инструментов можно переме-
щать на другое место обычным, принятым в 
Windows способом, установив курсор на нача-

ло панели так, чтобы курсор отображался в виде скрещенных стрелок (рис. 1.3), и нажав левую кнопку 

мышки. Если щёлкнуть по значку Toolbar Options  в конце панели инструментов, то можно добавить 
новые или удалить имеющиеся значки. 

Рис. 1.3 

Если дважды щёлкнуть по началу панели инструмен-
тов, то вид панели изменяется, у неё появляется заголовок (рис. 
1.4). Изменить набор значков в такой панели можно аналогич-
но, щёлкнув по значку Toolbar Options. Щёлкнув по значку 

Close, можно удалить панель. Чтобы её восстановить снова, нужно выбрать в меню Tools>Customize. 
Переместить панель можно, установив курсор на заголовок панели и нажав левую кнопку мышки. Вер-
нуть панели прежний вид можно, щёлкнув по её заголовку. 

Рис. 1.4 

 

Настройку меню и панелей инструментов можно выполнить в диалоговом окне Customize. Что-
бы открыть это окно, щёлкните правой кнопкой мышки по строке меню или по любой панели инстру-
ментов и выберите Customize. Или выберите в меню команду Tools>Customize. Диалоговое окно Cus-
tomize поддерживает настройку только меню и панелей инструментов. Для настройки горячих клавиш 
выберите Tools>Hotkeys. 

Рис. 1.5 
По умолчанию тип открытых панелей инст-

рументов и их содержимое зависит от имеющихся в 
проекте рабочих окон. Обычно это бывает достаточ-
ным для моделирования. Но при необходимости 
можно добавить или убрать какие-то панели, ис-
пользуя вкладку Toolbars окна Customize (рис. 1.5). 
Щёлкнув по кнопке New, вы можете создать собст-
венную панель инструментов. 

Рис. 1.6

Используя вкладку Commands (рис. 1.6), 
можно изменить содержимое панели инструментов. 
Чтобы добавить команду на панель инструментов, 
выберите категорию команды, затем перетащите 
нужную команду на панель инструментов. Чтобы 
удалить команду с панели инструментов, просто 
стащите её с панели. Или при открытом окне Cus-
tomize щёлкните по значку команды на панели ин-
струментов правой кнопкой мышки и выберите De-
lete. 

Рис. 1.7
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Строка меню автоматически изменяется в зависимости от открытого активного окна на рабочем 
поле. Но вы можете изменить строку меню при желании, воспользовавшись вкладкой Menus окна Cus-
tomize (рис. 1.7). Щёлкните по кнопке в конце поля Show Menu и выберите нужную строку меню. 

Когда диалоговое окно Customize открыто, команды меню и значки на панели инструментов 
приобретают новые функциональные возможности. Щёлкнув правой кнопкой мышки по команде меню 
или по значку на панели инструментов, вы можете изменить его отображение (например, отображать 
только значок или значок с текстом). Можете вообще выбрать другой значок или отредактировать 
имеющийся и изменить цвет. 

Например, щёлкните правой кнопкой мышки по команде меню View>View All. Откроется спи-
сок операций, которые вы можете выполнить. Если выбрать Text Only (или нажать клавишу T), то в ме-
ню исчезнет значок команды. Если выбрать Image and Text, то ничего не изменится, т.к. значок и текст 
отображаются в меню по умолчанию (Default Style). Если выбрать Change Button Image, откроется на-
бор значков, которыми можно заменить значок, установленный по умолчанию. Новый значок будет 
только в команде меню, на панели инструментов он останется прежним. Вернуть прежний значок можно, 
выбрав Reset Button Image. Если выбрать Edit Button Image, откроется окно редактора кнопки, в кото-
ром вы можете отредактировать изображение значка и его цвет. 

Все эти операции можно выполнить и над значком панели инструментов, если щёлкнуть по нему 
правой кнопкой мышки. В этом случае при выборе Image and Text значок на панели будет отображаться 

вместе с текстом, поясняющим назначение соответствующей команды (рис. 1.8). Вер-
нуться к отображению только значка можно, выбрав Default Style. 

Вы можете изменить порядок расположения пунктов в строке меню и команд во 
всплывающем меню, нажав клавишу Alt и перетаскивая их на новое место мышкой. Точ-

но также вы можете изменить порядок расположения значков на панели инструментов. Эту операцию 
можно выполнить и при закрытом окне Customize, но только в строке меню и на панели инструментов, 
изменить порядок команд в меню не получится. 

Рис.1.8 

Если щёлкнуть правой кнопкой мышки по строке меню или по панели инструментов и выбрать 
Options, или выбрать в меню 
Tools>Options откроется окно De-
sign Environment Options (рис. 1.9). 
В области Theme вы можете изме-
нить вид (тему) окна проекта: 
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Classic – подобно Microsoft 
Office 2000; 

Contemporary – подобно 
Microsoft Visual Studio 2005; 

Modern – подобно Microsoft 
Office 2003 с опциями для несколь-
ких различных цветов. 

Если отмечено Tabbed 
Workspace, появляется панель с 
именем для каждого создаваемого в 
проекте рабочего окна. Обычно это 
делается по умолчанию, что облег-
чает работу с окнами. Если отмечено 
Multirow tabs, то при большом ко-
личестве окон их имена располага-
ются на нескольких строках. В про-

тивном случае они располагаются в одной строке с возможностью их скроллинга. В поле ввода Location 
можно выбрать, где будет располагаться панель с именами окон (вверху рабочего поля, внизу, слева или 
справа). 

Рис. 1.9 

Если отмечено Hide tabs as group, то при щелчке по значку Auto Hide в одном из окон (окна 
просмотра проекта, просмотра элементов или менеджера топологии) автоматически скрывается вся эта 
группа окон. Если отмечено Close tabs as group, то при закрытии одного из указанных окон закрывается 
вся группа этих окон. 

В Microwave Office можно создавать копии схемы, электромагнитной структуры или графика. 
Для этого нужно просто перетащить мышкой имя соответствующего окна на имя соответствующей 
группы в окне просмотра проекта. Например, чтобы создать копию схемы, нужно перетащить её имя на 
имя группы Circuit Schematics. По умолчанию копии присваивается то же самое имя с добавлением но-
мера копии. Например, копия схемы с именем Schematic 1 получит имя Schematic 1_1. Созданная копия 
является новым самостоятельным документом проекта. Она появляется в окне просмотра проекта, её 
можно редактировать независимо от первоисточника, её можно анализировать и её характеристика ото-
бражается на графике. В Window имеется команда New Window и соответствующий этой команде зна-

чок  на стандартной панели инструментов. Выбор этой команды или щелчок по значку на панели 
инструментов открывает новое окно, полностью идентичное активному окну, для всех рабочих окон про-



екта, кроме текстовых окон. Однако это окно не является копией активного окна, оно скорее является 
дубликатом. В отличие от копии оно получает то же 
имя, но с номером через двоеточие. Например, для 
схемы Schematic 1 второму окну будет присвоено 
имя Schematic 1:2. Это окно не появляется в окне 
просмотра проекта, ему нельзя изменить имя, для 
него не проводится анализ и для него не отображает-
ся отдельная характеристика на графике. Но содер-
жимое этого окна можно редактировать и все изме-
нения отображаются в первом окне (и наоборот). 

В меню также имеется команда Win-
dow>Windows. Выбор этой команда открывает окно 
со списком всех имеющихся в проекте окон (рис. 
1.10). Выбрав имя окна в списке, можно выполнить 
над ним некоторые операции, щёлкнув по одной из 
кнопок в правой части окна. Например, можно сде-
лать окно активным, щёлкнув по кнопке Activate. 
Это может быть удобным, если в проекте много окон. 
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Открыть любой документ проекта (схему, 
график, 

алоговые окна введена 
фильтрация

вы можете сортировать в этом столбце имена приме-

им
ь с

ожно загрузить. Но количество 
таких пр

icrowave Office используются проекты, организуемые и управляемые 
из древо

й набор моделей и может включать одну или бо-
лее лин

Рис. 1.10 

электромагнитную структуру, глобальные 
определения и т.д.) можно, щёлкнув правой кнопкой 
мышки в любом месте окна просмотра проекта и вы-
брав Open Project Item. Откроется диалоговое окно 
(рис. 1.11) со списком всех имеющихся в проекте 
документов. Выберите документ, который нужно 
открыть, и нажмите OK. 

В некоторые ди
 текста для облегчения поиска. Например, 

если вы хотите просмотреть какой-то пример, выбе-
рите в меню File>Open Example. Откроется диало-
говое окно со всеми имеющимися примерами (рис. 
1.12). Щёлкая мышкой по заголовку столбца Name, 

ров в алфавитном или обратном 
алфавитном порядке. То же самое 
можно сделать и в столбце ключе-
вых слов Keyword. В поле ввода в 
нижней части окна вы можете вве-
сти текст для фильтрации, напри-
мер filter, если хотите найти при-
мер моделирования фильтров. В 
списке останутся только примеры 
фильтров. Или можете ввести клю-
чевое слово, напр ер MWO, что-
бы оставит  в писке только при-
меры MWO, или ключевое слово 
new, чтобы оставить в списке толь-
ко новые примеры. 

В нижней части выпадаю-
щего меню File имеется перечень 
ранее открытых проектов, откуда 
их м

Рис. 1.11 

оектов ограничено. Можно 
открыть один из предыдущих про-
ектов и другим способом, выбрав в 

меню File>More Projects. Откроется окно со списком предыдущих проектов. Выберите нужный проект и 
нажмите OK. 

Рис. 1.12 

1.4 Работа с проектами 
В среде проектирования M
видной структуры в окне просмотра проектов. 
Проект представляет собой любой желательны
ейных схем, нелинейных схем, и/или электромагнитных структур. Проект также включает всё 

связанное с проектом, типа глобальных значений параметров, импортированных файлов, топологий и 
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вывать свои замыслы. Вы можете генерировать топо-
логию э

е для вы-
полнени

 различными 
способа

р й
 

выходных графиков. При сохранении проекта автоматически сохраняется всё связанное с ним. Проекты 
в Microwave Office сохраняются как *.emp файлы. 

После создания проекта вы можете реализо
того проекта и выводить её в DXF, GDSII или Garber файлах. Вы можете выполнить анализ про-

екта и просмотреть результаты на ряде графиков, которые вы определили. После этого вы можете на-
страивать или оптимизировать значения параметров или переменных. Так как все части Microwave Office 
интегрированы, все ваши модификации автоматически отображаются на схеме и в топологии. 

В этом разделе описаны только основные окна, пункты меню и команды, необходимы
я основных задач Microwave Office, таких как: создание проекта, схемы, рисунка электромагнит-

ных структур, топологий, выполнение моделирования и отображение выходных графиков. 
Многие, описанные здесь операции по созданию проекта, могут быть выполнены
ми: из основного меню, из панели инструментов, из всплывающих меню и/или окна просмотра 

проекта. В этом руководстве не описываются все способы выполнить определённую операцию. 
1.4.1 Создание, открытие и запись проектов. 

Создание про-
екта – пе вы  шаг к 
формированию и моде-
лированию ваших про-
ектов. Организация и 
управление проектом и 
всем связанным с ним 
производится в древо-
видной структуре групп 
и модулей в окне про-
смотра проектов при 
нажатой панели Project. 
После запуска Micro-
wave Office по умолча-
нию загруженным или 
активным является про-
ект без названия (Unti-

tled Project). Имя активного проекта отображается в заголовке основного окна (рис. 1.13). 

Создать новый проект 

Для создания нового проекта нужно выбрать в меню File>New Project. Затем нужно дать имя 
новому проекту, выбрав File>Save Project As в том же меню. Имя проекта отображается в заголовке ок-
на. 

Для открытия существующего проекта нужно выбрать File>Open Project.  
Для сохранения текущего проекта нужно выбрать File>Save Project. 

1.4.2 Создание схем и списка цепей. 
Схемы – это графическое изображение схем, а список цепей – это текстовое описание схем. Про-

ект Microwave Office может включать множество линейных и нелинейных схем и/или списков цепей, а 
также электромагнитных структур. 

Чтобы создать новую схему или список цепей, нужно щёлкнуть правой кнопкой мышки по груп-
пе Circuit Schematics и выбрать New Schematic или New Netlist (рис. 
1.14). Альтернативно, можно в меню выбрать Project>Add Sche-
matic>New Schematic или Project>Add Netlist >New Netlist, или щёлк-
нуть по значку Add New Schematic  на панели инструментов.  от-
крывшемся поле ввода, ввести имя схемы или списка цепей (рис. 1.15). 
Если на жёстком диске имеется файл, который содержит схему, то схему 
из этого файла можно импортировать в проект. В этом случае схема 
включается в состав проекта. Для этого нужно выбрать Import Sche-
matic. Или можно связать схему из файла с проектом, выбрав Link To 
Schematic. В этом случае схема не включается в проект, а осуществля-
ется только связь с ней и файл со связанной схемой нельзя удалять или 
переносить в другую директорию, чтобы эта связь не оборвалась. Ана-
логичные операции можно выполнять и для списков цепей. 

Если в проекте создано много схем и/или списков 
цепей, и

В

х можно сгруппировать в папки. Вы можете соз-
дать дерево своих папок, щёлкая правой кнопкой мышки 
по группе User Folder в окне просмотра проекта или по 
уже созданной папке и выбирая Add New>Folder. Чтобы 
поместить схему (график, электромагнитную структуру и 
т.д.), установите курсор на имя схемы в окне просмотра 
проекта, нажмите левую или правую кнопку мышки и 
перетащите схему в нужную папку. 

Создать новый проект с библиотекой 
Открыть существующий проект 

Открыть пример 
Закрыть проект 

Сохранить текущий проект 

Дать имя проекту 

Переслать проект 

Рис. 1.13

Рис. 1.14

Рис. 1.15
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vironment Options, в открывшемся окне вы можете отредактировать 
опции с

емы или списка цепей, на рабочем поле открывается пустое 
окно сх

 в схему. 
бходимо в левом окне проекта открыть вкладку просмот-

ра элеме
жатии на 

значок 

 поместить нужный элемент в схему, поместите курсор на элемент, нажмите левую кнопку 
мышки 

мы рядом с элементом. Чтобы изменить значение ка-
кого

ры элемента и нажать левую кнопку мышки, мож-
но п

ментов и Х-
мод

Выбрав в меню Options>En
реды. Если в этом окне на вкладке Project отметить Show options as sub-nodes, эти опции будут 

включены в группу Circuit Schematics как подгруппа с именем Default Ckt Options. Дважды щёлкнув по 
этой подгруппе левой кнопкой мышки, или щёлкнув правой кнопкой и выбрав Edit, можно редактиро-
вать эти опции из окна просмотра проекта. 

После того, как определено имя сх
емы или списка цепей, в заголовке которого отображается присвоенное имя, а в окне просмотра 

проектов отображается новая схема или список цепей, как подгруппа в группе Circuit Schematics. Под-
группа новой схемы или списка цепей содержат все параметры и опции, которые определяют и описы-
вают схему или список цепей. Кроме того, меню и панель инструментов отображают новый специфиче-
ский набор команд и инструментов для формирования и моделирования схемы или списка цепей. 

1.5. Работа со схемами. 
1.5.1. Добавление элементов

Чтобы добавить элементы в схему, нео
нтов, щёлкнув левой кнопкой мышки по панели Elements в нижней части левого окна. 
Нажимая значки + или – возле группы, можно развернуть или свернуть группу, а при на
желательной подгруппы, например, Capacitor (Конденсатор) или Inductor (Индуктивность), в 

нижней части окна просмотра элементов отображаются доступные элементы из этой подгруппы 
(рис.1.16). 

Чтобы

Значок для добавления земли Развернуть или 
свернуть группу Значок для добавления порта

Перетащить нуж-
ный элемент в 
схему 

Открыть окно про-
смотра элементов 

Рис. 1.16

и, не отпуская кнопки, переместите его в окно схемы. Здесь, в любом свободном месте окна, от-
пустите кнопку. Щёлкая правой кнопкой мышки, можно вращать элемент, чтобы получить нужную ори-
ентацию. Затем, не нажимая кнопок мышки, элемент нужно поместить в соответствующее место и за-
фиксировать его, щёлкнув левой кнопкой мышки. 

Параметры элемента располагаются в окне схе
-либо параметра, нужно дважды щёлкнуть левой кнопкой мышки по этому параметру. Откроется 

поле ввода, в котором можно отредактировать значение параметра. Или можно дважды щёлкнуть левой 
кнопкой мышки по элементу. В этом случае открывается диалоговое окно свойств элемента, в котором 
можно изменить значения всех параметров элемента. 

Если поместить курсор на отображаемые парамет
ереместить отображение параметров в любое другое место для удобства чтения схемы. 
Кроме обычных элементов в Microwave Office включён ряд “интеллектуальных” эле
елей. “Интеллектуальные” (ICell) элементы отличаются тем, что они не требуют ввода никаких пара-

метров. Все значения параметров они автоматически получают от подключённых к ним других элемен-
тов. В окне просмотра элементов такие элементы на конце имеют символ $. Х-модели являются элемен-
тами, параметры которых определены с помощью электромагнитного моделирования и сохраняются в 
специальных таблицах. Эти элементы на конце имеют символ Х. Х-модели позволяют совместить высо-
кую точность модели, быстроту анализа и возможность настройки и оптимизации. Однако перед приме-
нением Х-модели должны быть заполнены, что занимает значительное время. Но однажды заполненная 
Х-модель затем может использоваться в любом проекте. В Microwave Office включены Х-модели, уже 
заполненные для некоторых распространённых диэлектриков. Файлы Х-моделей имеют расширение 
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жки в

ore Elements или щёлкните 

EMX и хранятся в папке EM_Models. Например, имя файла Microstrip_10p2_MOPENX.EMX говорит о 
том, что это Х-модель разомкнутого конца в отрезке микрополосковой линии на диэлектрике с диэлек-
трической проницаемостью 10.2. Наличие готовых Х-моделей даёт возможность вместо заполнения Х-
модели использовать готовую для диэлектрика с близким значением диэлектрической проницаемости, 

возможно с небольшой потерей в точ-
ности. Например, если в параметрах 
элемента подло вести Er=10 и 
ErNom=10, и в схеме имеется Х-
модель, например модель скачка ши-
рины проводника MSTEPX, то анализ 
выполняться не будет. В окне статуса 
появится сообщение, что Х-модель не 
заполнена. Но если изменить значение 
ErNom и в параметрах подложки вве-
сти Er=10 и ErNom=10.2, то анализ 
будет выполнен. Заметим, что значе-
ние ErNom используется только для Х-
моделей. Если в схеме Х-моделей нет, 
то значение ErNom может быть лю-
бым. 

Добавить элемент в схему можно 
и другим способом. Выберите в меню 
Draw>M
по значку Element  на панели инст-
рументов. Откроется окно Add Circuit 
Element со списком имеющихся моде-
лей элементов (рис 1.17). Выберите 

нужный элемент и нажмите OK. 
1.5.2. Добавление подсхем в схему 

. 

в виде блоков, что позволяет создавать 

му, нужно щёлкнуть мышкой по Subcircuits в окне просмотра элементов. 
Доступн

л данных как подсхему, он должен быть сначала импортирован и добавлен к 
проекту

емы, при необходимо-
сти пов

rcuit или щёлкните по значку Subcircuit

Рис. 1.17 

В Microwave Office в схему можно включать подсхемы 
иерархические структуры схем. Таким блоком могут быть схемы, списки цепей, электромагнитные 
структуры или файлы данных. 

Чтобы добавить подсхе
ые подсхемы отображаются в нижней части этого окна. Они включают все схемы, списки цепей 

и электромагнитные структуры, связанные с проектом, а также любые импортированные файлы данных, 
определённые для проекта. 

Чтобы добавить фай
 как объект. Чтобы сделать это, выберите Project>Add Data File>Import Data File в окне про-

смотра проекта. Или щёлкните правой кнопкой мышки по группе Data Files в окне просмотра проекта и 
выберите Import Data File. Любые импортированные файлы данных автоматически отображаются в пе-

речне доступных подсхем в окне просмотра элементов. 
Для размещения желательной подсхемы, её нужно 

просто перетащить мышкой в окно сх
ернуть, щёлкая правой кнопкой мышки, и установить 

в нужное место. 
Добавить подсхему можно и иначе. Выберите в меню 

Draw>Add Subci   
на пане

д

дсхемы. Очевидный способ для этого 
– откры

нуть по подсхеме правой кнопкой и вы-
брать E

ли инструментов. Откроется окно со списком имею-
щихся в проекте подсхем (рис. 1.18). Выберите нужную по -
схему и нажмите OK. 

Иногда возникает необходимость отредактировать 
параметры элементов по

ть окно схемы (списка цепей, электромагнитной 
структуры и пр.), которая используется в качестве подсхемы, 
и выполнить редактирование. Однако редактировать подсхе-
му можно и, не выходя из окна схемы, включающей подсхе-
му. 

Для редактирования параметров подсхемы нужно щёлк

Рис. 1.18 

dit Subcircuit во всплывающем меню. Отредактировать подсхему можно так же, если выделить 
её, щёлкнув по подсхеме левой кнопкой мышки, и затем выбрать  меню Schematic>Edit Subcircuit или 
щёлкнуть по значку Edit Subcircuit  на панели инструментов, который станет активным. При выборе 
этой команды окно схемы заменяется кном подсхемы для её редактирования. Чтобы после выполнения 
редактирования вернуться в окно семы, выберите в меню Schematic>Exit Subcircuit или щёлкните по 

 о

значку Exit Subcircuit  на панели инструментов. 
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вл
ся окно свойств. В строке Net будет отображе-

но имя 

Если в схему по ошибке добавлена не та подсхема, вы можете 
исправить это очень просто. Дважды щёлкните по неверно вста ен-
ной подсхеме. Откроет

выбранной подсхемы. Щёлкните по этому имени левой кноп-
кой мышки. В правом конце за именем появится кнопка . Щёлкните 
по этой кнопке, в выпавшем списке имеющихся в проекте подсхем 
(рис. 1.19) выберите нужную и нажмите кнопку OK в нижней части 
окна. Неверно добавленная подсхема будет заменена треб емой. 

1.5.3. Добавление портов и земли в схему. 
Чтобы добавить в схему обычный порт для линейного моделирования, щёлкните по группе Ports

у

 
RT в окно схемы, при необходимости разверните 

его, щёл

Рис. 1.19

в окне просмотра элементов, перетащите элемент PO
кая правой кнопкой мышки, установите в нужное место схемы и щёлкните левой кнопкой мыш-

ки, чтобы зафиксировать порт. Этот порт можно так же добавить в схему, щёлкнув по значку Port  
на панели инструментов. Или выберите в меню Draw>Add Port. 

жно
нуть левой кнопкой мышки по нужной 

подгруппе портов. Доступные типы портов будут отображ

два порта к одной 
точке, н

у порту присваивается 
п

 цифровому 

дключения в схеме, но не для возбуж-

Чтобы добавить специальный порт к схеме, например, порт для гармонического баланса, ну  
раскрыть группу Ports в окне просмотра элементов, затем щёлк

ены в нижней части левого окна. 
Нельзя подключать два порта к одной точке. 

Например, в схеме рис 1.20 порты 1 и 2 подключены к 
одной точке. Анализ такой схемы выполняться не бу-
дет с выводом сообщения об ошибке. Если всё-таки 
есть необходимость подключить 

ужно между портами включить резистор с со-
противлением 0 Ом (рис. 1.21). 

Отредактировать параметры порта можно 
двойным щелчком мышки по порту в окне схем. От-
кроется диалоговое окно свойств порта, в котором 
можно ввести новые значения параметра. 

По умолчанию каждомРис. 1.21 Рис. 1.20 
номер в орядке его добавления в 
схему. Для любого порта в окне 
свойств имеется параметр PIN_ID. 
При желании вы можете к
номеру порта добавить имя, опреде-
лив этот параметр. Обычно это быва-
ет удобно, если предполагается схему 

использовать в качестве подсхемы. Например, в схеме рис. 1.22 параметры PIN_ID портов определены 
как input и output. В этом случае в соответствующей подсхеме вместо номеров портов будут отобра-
жаться их имена (рис. 1.23). 

Любой тип порта в подсхеме используется только для по

Рис. 1.22 Рис. 1.23

дения. Возбуждаются подсхемы только через порты схемы самого высокого уровня иерархии. 
Чтобы добавить в схему землю, щёлкните по значку Ground  на панели инструментов. 

1.5.4. С
мый в схему элемент с 

уже име

 другом непосредст-

оединение элементов в схеме. 
Чтобы соединить очередной добавляе
ющимся в схеме элементом, поместите добавляемый элемент 

так, чтобы его узел присоединился к узлу уже имеющегося элемента. 
При правильном соединении общий узел отображается в виде маленько-
го зелёного квадрата (рис. 1.24). Если сразу соединить элементы не уда-
лось, нажмите нужный элемент левой кнопкой мышки и, не отпуская 
кнопки, переместите элемент в надлежащее место. 

Часто в схеме соединить элементы друг с
Рис. 1.24 

венно сложно. В этом случае можно соединить элементы проводами. 
Для этого установите курсор возле точки элемента схемы, к которой 
нужно подключить начало провода. Курсор должен отображаться в виде 

соленоида . Нажмите в этой позиции левую кнопку мышки, чтобы 
зафиксировать начало провода, и, отпустив кнопку мышки, двигайте 
мышкой к месту, где нужно сделать изгиб провода. Щёлкните снова ле-

вой кнопкой, чтобы зафиксировать изгиб. Изгибов можно делать сколько угодно. Чтобы закончить под-
ключение провода, щелкните по другому элементу, к которому нужно присоединить провод, или по дру-
гому проводу (рис. 1.25). Для отмены выполнения соединения проводом нажмите клавишу Esc. Удалить 
провод можно, щёлкнув по нему левой кнопкой мышки и затем

Рис. 1.25 

 нажав клавишу Delete. 



В сложных схемах соединить различные точки схемы проводом бывает затруднительно. В таком 
случае можно использовать соединения 
по именам. Для этого ко всем точкам, 
которые должны быть соединены вме-
сте, необходимо подключить элемент 
NCONN, который находится в группе 

Interconnects в окне просмотра элементов. Этот эле-
мент является соединителем и имеет только один 
параметр, определяющий имя соединителя. На рис. 
1.26а показано соединение двух резисторов прово-
дом. На рис. 1.26б показано эквивалентное этому 

соединение двух резисторов по именам. Здесь к соединяемым концам резисторов подключены соедини-
тели NCONN с одинаковыми именами A. Для ввода имени дважды щёлкните по элементу NCONN или 

щёлкните правой кнопкой мышки и выберите 
Properties. В открывшемся окне введите нужное имя 
элемента (рис. 1.27), в нашем случае это A. Имейте в 
виду, что имена чувствительны к регистру. 

Рис. 1.26а Рис. 1.26б

Рис. 1.27 

Когда элементы в схеме соединены по именам, 
нет возможности проверить правильность соединения. 

Поэтому для проверки правильности выполненных соединений имеется возможность подсветки соеди-
нений. Можно проверить правильность различных соединений, выбрав различные цвета подсветки для 
различных соединений. Однако это можно сделать, если хотя бы один элемент NCONN в соединении 
подключён к точке соединения не непосредственно, а проводом (рис. 1.28). Щёлкните правой кнопкой 

точно по проводу, соединяющему элемент NCONN с рези-
стором, и выберите Net Highlight On, в открывшемся окне 
выберите цвет и нажмите OK. Для удаления подсветки снова 
щёлкните правой кнопкой точно по проводу и выберите Net 
Highlight Off. 

Рис. 1.28
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пример, в схеме имеется три цепочки, каждая из которых со-

Если в схеме имеется несколько одинаковых парал-
лельно соединённых цепочек, черчение схемы можно упро-
стить, используя векторные привязки (Vector Instances). На-

стоит их двух резисторов, как показано на рис. 1.29. Эти три пары резисторов можно заменить одной 
парой, используя векторные привязки элементов, что будет эквивалентно черчению трёх пар. Схема 
должна выглядеть, как показано на рис. 1.30. 

Рис.1.29 Рис. 1.30

В этом примере идентификаторы элементов, выглядят как векторы. Синтаксис их должен быть в 
виде: [0:N], где N – количество однотипных элементов на один больше, чем число N. На рис. 1.28 иден-
тификаторы элементов имеют параметр [0:2]. Это означает, что в действительности в каждой паре име-

ется по три резистора и по три элемента соединителя. 
Обратите внимание на следующее. На рис. 1.29 

все три цепочки независимы. Величина сопротивлений у 
всех резисторов может быть разной. К каждой цепочке 
можно подключить порты и анализ для каждой из цепо-
чек будет выполняться отдельно. На схеме рис. 1.30 си-
туация иная. Т.к. порт не поддерживает векторные при-
вязки, то на входе и выходе можно подключить только 
по одному порту. Т.е. схема рис. 1.30 возможна только 
для параллельно соединённых цепочек. Иными словами, 
схема рис 1.30 эквивалентна схеме рис. 1.31. Элементы в 
цепочке могут быть различные, но в каждой группе 
(здесь тройки резисторов) элементы должны быть оди-
наковые и иметь одинаковые параметры. Векторный 
параметр в элементе создаёт копии этого элемента в ко-
личестве, указанном в N. Параллельное соединение в 
схеме рис. 1.30 создаётся автоматически. 

Рис. 1.31 

Чтобы определить векторный параметр для эле-
мента NCONN, дважды щёлкните по этому элементу и 
введите имя A[0:2]. Чтобы определить этот параметр для 

резистора, дважды щёлкните по резистору, откройте вкладку Vector и введите [0:2] (рис. 1.32). 

Рис. 1.32 



Для организации соединений из нескольких проводов, можно использовать шины (Busses), кото-
рые могут содержать один или несколько 
проводов. На рис. 1.33 показано соедине-
ние трёх пар резисторов шиной. Здесь в 
имени элементов NCONN у резисторов в 
квадратных скобках должен быть указан 
номер провода в шине, который будет ис-
пользоваться для соединения данного рези-
стора. Обратите внимание, что здесь номи-
налы резисторов разные, поэтому объеди-
нить их в одну эквивалентную схему, по-
хожую как на рис. 1.30 не получится. 
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Если тройки резисторов имеют одинаковое 

Чтобы создать шину, добавьте в 
схему на свободном месте (между тройка-

ми резисторов) два элемента NCONN с векторными идентификаторами с именами, например in[0:2] и 
out[0:2]. Т.е. шина должна иметь три провода, которым присваиваются номера 0, 1 и 2. Имена этих эле-
ментов NCONN должны совпадать с соответствующими именами элементов NCONN у резисторов (in и 
out). Установите курсор на узел одного из добавленных элементов NCONN, щёлкните мышкой, перемес-
тите курсор к узлу второго элемента NCONN и снова щёлкните мышкой, чтобы соединить эти элементы 
проводом. Т.к. элементы NCONN имеют векторные идентификаторы, то вместо провода будет автома-
тически создана шина с нужным количеством проводов. Шину в этом случае можно разместить на лю-
бом свободном месте в окне схемы. 

Рис. 1.33 

сопротивление и цепочки нужно соединить парал-
лельно, то их соединение можно заменить одной парой 
сопротивлений, соединённых шиной, определив их иден-
тификаторы в векторном виде (рис. 1.34). Соедините эти 
резисторы проводом, шина с нужным количеством прово-
дов будет создана автоматически. Схема на рис. 1.34 экви-

валентна схеме на рис. 1.30. 
Рис. 1.34

Векторный параметр шины должен быть таким же, как и векторные параметры элементов. Если 
это не соблюдается, точки соединений отображаются пере-
чёркнутыми (рис. 1.35), что говорит об отсутствии соеди-
нения. На рис. 1.35 показано неверное соединение троек 
резисторов шиной с двумя проводами. Чтобы отредактиро-
вать параметр шины, нужно по нему дважды щёлкнуть 
мышкой. 

Если вы соединяете элемент с векторным параметром и элемент без векторного параметра, вы 
должны использовать соединение проводом вместо шины. На рис. 1.36 показано такое соединение трой-

ки резисторов с одиночным резистором. Соединяя прово-
дом тройку резисторов с одиночным резистором, вы авто-
матически получите соединение шиной, у которой правый 
конец будет перечёркнут. Чтобы превратить шину в про-
вод, дважды щёлкните по её параметру и удалите вектор-

ный параметр, оставив только имя (B1 на рис. 1.36). Та-
кое соединение эквивалентно схеме, показанной на рис. 
1.37. 

Рис. 1.35

Рис. 1.36

При необходимости превратить любой провод в 
шину можно, щёлкнув по проводу правой кнопкой 
мышки и выбрав Create BusNet. 

Если в схеме имеется несколько элементов, со-
единённых параллельно, изображение схемы можно уп-
ростить и другим способом, используя возможность 
многообразия (multiplicity) элемента. Для этого в пара-

метрах элемента устанавливается коэффициент многообразия M, который определяет, сколько экземпля-
ров (копий) элемента в схеме требуется создать. Этот параметр устанавливается в диалоговом окне 
Element Options на вкладке Layout в поле ввода Multiplicity parameter. Этот же параметр определяет 
количество создаваемых топологических элементов в топологии и масштабный множитель для значений 
параметров элемента, определённых на вкладке Parameters. Например, для резисторов величина сопро-
тивления будет уменьшена в M раз. Все созданные копии элемента автоматически соединяются парал-
лельно. Масштабирование значений параметров элемента приводит к тому, что хотя в топологии созда-
ётся заданное количество топологических элементов, но для анализа в решающее устройство передаётся 
один элемент с измененными значениями параметра. Благодаря этому время анализа и необходимое ко-
личество памяти при использовании метода многообразия элементов не увеличивается, по сравнению с 
методом использования векторных параметров в идентификаторах элементов, при котором обрабатыва-
ются все созданные копии элемента. 

Рис. 1.37 



Рассмотрим использование метода многообразия на простом примере резистора. 

 15

1.38).  

1. Щёлкните по группе Ports в окне просмотра элементов. 

ME 

 иерархии. 

Допустим, в схеме нужно иметь два одинаковых сопротивления, соединённых параллельно (рис. 

В место этой пары сопротивлений вы можете ввести в 
схему только один элемент Res (рис. 1.39). Затем сделайте сле-
дующее. Дважды щёлкните по элементу Res. В открывшемся ок-
не свойств на вкладке Parameters введите требуемое значение 
сопротивления, например 100 Ом. Откройте вкладку Layout. В 
поле Multiplicity parameter введите 2 и нажмите OK. Теперь в 
топологии схемы будут создаваться два параллельно соединён-
ных топологических элемента, при условии, что топологический 
элемент для элемента схемы существует (для элемента RES его 

сначала нужно создать). Однако решающему устройству будет пе-
редан для анализа один элемент RES с сопротивлением 50 Ом (т.е. в 
2 раза меньше). 

Рис. 1.38

Метод многообразия можно использовать и для подсхем. 
Для подсхемы можно определить коэффициент многообразия. Рас-
смотрим пример использования схемы того же резистора в сравне-

нии метода использования векторных параметров и коэффициента многообразия (в схеме резистора ко-
эффициент многообразия не установлен). 

Рис. 1.39 

На рис. 1.40а показано использо-
вание подсхемы с векторными парамет-
рами [0:1], т.е. будет создано два парал-
лельно соединённых транзистора. На рис 
1.40б показана схема, которая будет пе-
редана решающему устройству для ана-
лиза. 

На рис. 1.41а показано использо-
вание подсхемы с коэффициентом мно-

гообразия M=2. На рис. 1.41б показана схема, 
которая будет передана решающему устрой-
ству для анализа. 

Рис. 1.40а
Рис. 1.40б

Если в схеме имеются параллельно 
связанные одинаковые цепочки и возникнет 
необходимость (или желание) упростить изо-
бражение схемы, придётся решать, какой из 

методов выбрать. Использование коэффициента многообразия уменьшает время анализа и требуемое 
количество памяти. Однако анализ схемы выполняется достаточно быстро и, скорее всего, эта разница 
будет заметна разве что для очень сложных схем. Элементы с коэффициентами многообразия не могут 
работать с шинами. Есть и другие нюансы, не чётко прописанные в руководстве пользователя. Например, 
указывается, что при использовании iNet (интеллектуальные цепи) для элементов с коэффициентом мно-
гообразия можно извлечь корректно емкостное сопротивление цепи, но активное и индуктивное сопро-
тивления будут не верными. В любом случае при использовании описанных методов нужно быть очень 
внимательным. 

Рис. 1.41бРис. 1.41а 

В AWR есть ещё один способ соединения цепей по имени. В группе Ports в окне просмотра эле-
ментов имеется элемент порта PORT_NAME. Это специализированный порт. Для этого порта не опре-
делён импеданс, и он не предназначен для возбуждения цепи. Как и элемент NCONN, этот порт имеет 
только один параметр – имя, определяющее точку подключения. Элемент PORT_NAME можно исполь-
зовать только в схемах, которые предполагается использовать в качестве подсхем. 

Чтобы добавить PORT_NAME в схему: 

2. Перетащите 
элемент 

PORT_NA
в схему, помес-
тите его в нуж-
ном месте и 
щёлкните мыш-

кой, чтобы закрепить. 
Рис. 1.42 

Если в качестве подсхемы используется схема с портами PORT_NAME, символ подсхемы 
выглядит иначе, чем для схемы, использующей обычные порты. В символе такой подсхемы нет точек 
подключения для её непосредственного подключения в схеме, в которой она используется. Соединить 
такую подсхему с элементами схемы можно, только используя соединители NCONN. На рис. 1.42 
показан пример такой подсхемы и её включение в схему верхнего уровня



В подсхеме имеется два элемента PORT_NAME, левый с именем in и правый с именем out. В 
символе этой подсхемы не отображается ника-
ких точек для её подключения. Она отображает-
ся в схеме просто как прямоугольник. Подклю-
чение к подсхеме выполняется с помощью эле-
ментов NCONN, имеющих такие же имена. 
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При желании символ подсхемы можно 
изменить так, чтобы он имел точки подключе-
ния, как и подсхемы с обычными портами. Для 
этого нужно воспользоваться мастером генера-
ции символа. 

1. В окне просмотра проекта раскройте 
группу Wizards. 

2. Дважды щёлкните по AWR Symbol 
Generator Wizard. Откроется окно 
мастера создания символов (рис. 1.43). 

3. В поле Choose a document type (Вы-
брать тип документа) введите Sche-
matic Design (Схема проекта), щёлк-

нув по кнопке в правом конце этого поля. В поле Choose a document аналогично введите имя 
вашей схемы. В поле Style введите Block. 

Рис. 1.43 

4. Нажмите кнопку Named Ports (Имена портов). Откроется 
окно Choose Ports to Connect by Name (Имена портов 
для соединения), которое содержит список имён портов, 
имеющихся в схеме (рис. 1.44). Отметьте нужные имена 
портов и нажмите OK. 

5. Нажмите OK в окне рис. 1.43. 
6. Дважды щёлкните по символу подсхемы или щёлкните по 

нему правой кнопкой мышки и выберите Properties. В 
открывшемся окне свойств откройте вкладку Symbol 

(рис. 1.45). В верхнем по-
ле ввода над списком 
имеющихся символов 

введите Project. В этом 
случае в списке символов будут отображаться только те символы, которые вы создали в проек-
те и проще будет найти нужный символ. 

Рис. 1.44 

Рис Рис. 1.46 . 1.45 

7. В списке символов отметьте символ, который вы создали для подсхемы и нажмите OK. 
Теперь символ подсхемы будет выглядеть, как показано на рис. 1.46. К такому символу вы мо-

жете подключать другие элементы (например, порты) непосредственно или проводом, не используя эле-
менты NCONN. 

1.6 Создание топологии схем. 
Топология – это изображение физического представления цепей, в котором каждому компоненту 

схемы соответствует элемент топологии. В объектно-ориентированной среде Microwave Office топология 
тесно связана со схемой и электромагнитной структурой, которую она представляет, это просто другой 
вид тех же самых цепей. Любые изменения, сделанные в схеме или электромагнитной структуре, автома-
тически и немедленно отображаются в соответствующей топологии. 

Для создания топологии схемы, щёлкните по схеме, чтобы сделать её активной и выберите 
View>View Layout в меню или щёлкните по значку View Layout  на панели инструментов. На рабо-
чем поле откроется окно топологии с автоматически созданной топологией схемы, если для элементов 

схемы имеются соответствующие элементы топологии. Однако 
элементы топологии могут быть соединены между собой невер-
но или не соединены вовсе, как показано на рис. 1.47, при этом 
пунктирными красными линиями указываются общие точки со-
единения элементов топологии, т.е. точки, в которых эти эле-
менты должны быть соединены. Чтобы правильно скомпоновать 

Рис. 1.47 



топологию, выберите в меню Edit>Select All или установите курсор левее и выше топологии, нажмите 
левую кнопку мышки и переместите курсор правее и ниже топологии так, чтобы вся топология попала в 
образовавшийся прямоугольник, отпустите кнопку, чтобы выделить все элементы топологии. Затем вы-
берите в меню Edit>Snap Together или щёлкните по значку Snap Together  на панели инструментов. 

Топология будет скомпонована 
автоматически, как показано на 
рис. 1.48. При желании это 
можно сделать и вручную. Для 

этого установите курсор на элемент, который нужно переместить в другое место, нажмите левую кнопку 
мышки и, не отпуская кнопки, переместите элемент. 

Рис. 1.48 

Когда после выполнения команды View>View Layout создана топология схемы, элементы топо-
логии автоматически назначаются для тех элементов схемы, у которых имеется элемент топологии, соот-
ветствующий электрическому элементу. Это такие элементы, как элементы симметричной и микропо-
лосковой линии, компланарного волновода и т.п. На схеме элементы, для которых в топологии создан 
топологический элемент, будут отображаться сиреневым цветом. Те элементы схемы, для которых нет 
топологического представления (например, транзистор), в схеме будут отображаться синим цветом. 

Для элементов схемы, у которых нет соответствующих топологических элементов, вы должны 
их создать сами или импортировать через менеджера топологии (Layout Manager), как будет описано 
далее. 

Изменять атрибуты топологии, свойства черчения и создавать новые элементы топологии, кото-
рых нет среди задаваемых по умолчанию, можно нажав панель Layout в нижней части левого окна. Ме-

Группа Layer Setup (Установка Слоёв) в менеджере топологии о

неджер топологии заменит при этом окно просмотра проектов (рис. 1.49). 

пределяет атрибуты, такие как 
свойств

топологии позволяет создавать шаб-
лоны яч

т-
ривать и

Щёлкнуть правой кнопкой мышки,
чтобы изменить атрибуты тополо-
гии или импортировать LPF

Щёлкнуть правой кнопкой мышки,
чтобы импортировать библиотеку
ячеек или создать новую ячейку

Щёлкнуть правой кнопкой
мышки, чтобы отобразить ячей-
ки топологии из библиотеки

Активный слой для ото-
бражения и черчения 

Щёлкнуть по панели Lay-
out, чтобы открыть менед-
жер топологии

Рис. 1.49

а черчения (цвет линии, рисунок слоя и т.д.), 3-х мерные свойства (толщина и т.д.) и положение 
слоёв. Чтобы изменить атрибуты слоя, щёлкните правой кнопкой мышки по Layer Setup и выберите Edit 
Drawing Layers (Редактирование слоёв черчения) во всплывающем меню. Вы можете также импортиро-
вать файл обработки слоя (LPF) для определения его атрибутов, щёлкнув правой кнопкой мышки Layer 
Setup и выбирая Import Process Definition из всплывающего меню. 

Группа Cell Libraries (Библиотека элементов) в Менеджере 
еек для элементов, которых нет в задаваемых по умолчанию. Редактор элементов включает такие 

возможности, как покоординатный ввод, булевы операции для вычитания и объединения форм, копиро-
вание массива, произвольное вращение, группировку и инструментальные средства совмещения. Вы мо-
жете так же импортировать библиотеки шаблонов элементов типа CDSII или DXF в Microwave Office. 

Как только библиотеки элементов топологии созданы или импортированы, их можно просма
 выбирать необходимые элементы для включения в топологию. Нажмите обозначения + или – , 

чтобы развернуть или свернуть библиотеки элементов топологии и выберите необходимый элемент. 
Доступные элементы топологии отображаются в нижней части левого окна. Чтобы поместить элемент 
топологии в окно топологии, просто нажмите на него левой кнопкой мышки и переместите в окно топо-
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логии. Отпустив кнопку мышки, позиционируйте его и щёлкните левой кнопкой мышки, чтобы зафикси-
ровать. 

Ячейка топологии может выводиться в файл в формате GDSII или DXF. Для экспортирования 
ячейки в файл, щёлкните правой кнопкой мышки по её имени в Менеджере топологии и выберите Export 
Layout Cell. 

Вся топология схемы также может выводиться в файлах GDSII или DXF. Для вывода топологии 
сделайте активным окно топологии схемы, и выберите в меню Layout>Export. 

1.7. Создание электромагнитных структур (ЕМ). 
Электромагнитная структура представляет собой набор из одного или нескольких диэлектриче-

ских слоёв, расположенных в прямоугольном корпусе (EMSight) или без корпуса (AXIEM). На каждом из 
диэлектрических слоёв могут быть нанесены слои материала для топологических форм (проводящих и 
резистивных полосок или полигонов, межслойных перемычек). Чтобы можно было отличить слои друг 
от друга, диэлектрическим слоям назначаются номера (нумерация слоёв начинается с верхнего слоя). 
Слоям материалов назначаются индивидуальные имена для каждого типа материалов. При этом нужно 
различать два типа слоёв материалов: 

o Слои модели (Model Layers), которые содержат информацию для параметризированных ячеек 
топологии и для ячеек топологического чертежа (фотошаблона). 

o Слои черчения (Drawing Layers), которые используются для вычерчивания топологических 
форм и для экспорта топологии. Эти слои содержат информацию, необходимую для выполнения 
чертежа (тип и толщина линий, текстура и цвет заполнения и т.п.). 
Слои модели и слои черчения обычно имеют одни и те же имена, хотя это и не обязательно. 
Номер слоя диэлектрика, на котором вычерчиваются формы топологии, указывается в поле EM 

Layer в окне свойств каждой из форм или в окне менеджера топологии. Имя материала для каждой топо-
логической формы указывается в поле Material в указанных выше окнах. 

Поскольку на одном и том же диэлектрическом слое могут быть размещены топологические 
формы из разных материалов, для каждого из материалов должен быть назначен свой слой черчения. 
Этот слой указывается в поле Drawing Layer в окне свойств топологической формы. Конкретные спосо-
бы назначения слоёв и материалов будут показаны далее в примерах моделирования электромагнитных 
структур. 

Выполненная установка слоёв и материалов достаточна для выполнения анализа электромагнит-
ной структуры. Однако этого может оказаться не достаточно для выполнения некоторых других опера-
ций, например, для импорта топологии из DXF или GDSII файлов. Имена слоёв должны быть записаны в 
DXF файле. Кроме того, должны быть созданы таблицы соответствия между слоями: 

o Model Layer Mapping – таблица соответствия между слоями модели (Model Layer) и слоями 
черчения (Drawing Layer). 

o EM Layer Mapping – таблица соответствия между слоями черчения (Drawing Layer) и слоями 
диэлектрика (EM Layer). 

o File Export Mapping – таблица соответствия между слоями черчения (Drawing Layer) и слоями, 
записываемыми в файл (File Layer). 
Эти таблицы доступны выбором в меню Options>Drawing Options. 
Чтобы создать новую электромагнитную структуру, щёлкните правой кнопкой мышки по группе 

EM Structures в окне просмотра проектов и выберите New EM Structure. Или щёлкните левой кнопкой 
мышки по значку New EM Struc-

ture  на панели инструментов 
(рис. 1.50). Откроется диалоговое 
окно, в котором нужно присвоить 
имя создаваемой электромагнитной 
структуре и выбрать решающее уст-
ройство для анализа структуры 
(рис. 1.51). 

В области Initialization Op-
tions имеются опции начальной за-
грузки для создаваемой электро-
магнитной структуры (слои, табли-
цы соответствия и пр.): 

Создать новую 
электромагнитную 
структуру 
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o При выборе Default загру-
жается файл default.lpf и 
таблица соответствия EM 
Mapping, имеющаяся в 
этом файле. 

Рис. 1.50 



o При выборе From LPF вы можете выбрать загрузку любого пользовательского lpf файла (если 
они есть) и таблицы EM Mapping из имеющихся таблиц в выбранном файле. Заметим, что вы-

бор переключателя From 
LPF и затем выбор De-
fault в полях Use LPF и 
Use EM Mapping экви-
валентно выбору пере-
ключателя Default. 

o Переключатель From 
Stackup доступен только 
в том случае, если в гло-
бальных определениях 
(Global Definition) име-
ется один или несколько 
элементов STACKUP из 
группы Substrates окна 
просмотра элементов. 
Этот элемент представ-
ляет собой многослой-
ную подложку, в кото-
рой определены все 
слои, материалы и т.д. В 
окне рис. 1.51 вы можете 
выбрать любой из 
имеющихся элементов 

STACKUP для загрузки начальных свойств электромагнитной структуры. Этот метод может 
быть предпочтительным при создании многослойных структур, т.к. элемент STACKUP проще 
для формирования, чем LPF файл. 
Сделав все необходимые установки в окне рис. 1.51, нажмите кнопку Create. На рабочем поле 

открывается пустое окно электромагнитной структуры и в окне просмотра проекта отображается новая 
электромагнитная структура, как подгруппа в группе EM Structures. Подгруппа новой электромагнит-
ной структуры содержит все параметры и опции, которые определяют и описывают её. Кроме того, в 
меню и на панели инструментов появляются новые пункты для черчения и моделирования электромаг-
нитных структур. 

Прежде чем начертить электромагнитную структуру, необходимо определить параметры корпу-
са. Параметры корпуса определяются краевыми условиями и диэлектрическими материалами каждого 
слоя структуры. 

Для определения параметров корпуса дважды щёлкните по подгруппе Enclosure (Корпус) в окне 
просмотра проектов (рис. 1.52). Откроется диалоговое окно, в котором можно ввести необходимую ин-
формацию. 

Если выбрано решающее устройство EMSight, необходимо задать размеры корпуса. Если вы-

брано AXIEM, в котором нет боковых стенок, размеры корпуса не задаются, топология вычерчивается 
на “бесконечной” плате. 

После определения параметров корпуса можно чертить проводники, выбрав Draw (Рисовать) в 
выпадающем меню, чтобы отобразить опции рисования, или, щёлкая соответствующие значки на панели 
инструментов. Можно чертить элементы топологии типа проводников различной формы, межслойных 

Рис. 1.51 

Просмотр 2-х и 3-х 
мерных структур 
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Чертить провод-
ники и добавить
поты 

Дважды щёлкнуть, 
чтобы определить 
корпус 

Значки для добавления 
портов и перемычек 

Определить кор-

Рис. 1.52 



перемычек и портов. Так же можно вычерчивать дополнительные элементы топологии, такие как репер-
ные знаки, технологические площадки, текстовые надписи и т.п. 

Электромагнитные структуры можно просматривать в 3-х мерном отображении, выбрав в меню 
команду View>View 3D EM Layout или щёлкнув по значку View 3D EM Layout  на панели инстру-
ментов. 

Если используется компьютер с многоядерным процессором, необходимо установить опции для 
распараллеливания вычислений. В Microwave Office имеется три решающих устройства, для которых 
можно определить эти опции: AXIEM, APLAC и EMSight. 

Для AXIEM выберите в меню Options>Default EM Options и в открывшемся окне EM Options 
на вкладке AXIEM в области Solver Options отметьте Use all CPUs. Это будет глобальная установка, 
действующая для всех структур в проекте. Можно эту установку сделать и локальной для какой-то кон-

кретной структуры. Щёлкните правой кнопкой мыш-
ки по имени структуры в окне просмотра проекта и 
выберите Options. В открывшемся окне Options на 
вкладке AXIEM в области Solver Options отметьте 
Use all CPUs. AXIEM распараллеливает вычисления 
на всех этапах анализа. 

Для гармонического баланса APLAC вы мо-
жете выбрать в меню Options>Default Circuit Op-
tions или щёлкнуть правой кнопкой мышки по имени 
схемы в окне просмотра проекта и выбрать Options. 
На вкладке APLAC в окне списка опций имеется 
опция NTHREADS (количество потоков), значение 
которой вы можете определить. 

Для EMSight, нужно установить две систем-
ные переменные. Чтобы сделать это, выберите 
Пуск>Панель управления>Производительность и 
обслуживание, дважды щёлкните по значку Систе-
ма и откройте вкладку Дополнительно. В нижней 
части этой вкладки нажмите на кнопку Переменные 
среды. Откроется диалоговое окно Переменные 
среды (рис. 1.53). Щелкните по кнопке Создать ни-
же области Системные переменные, чтобы доба-
вить новые переменные. Необходимо установить 

переменные MKL_NPROCS и 
OMP_NUM_THREADS. Если используется два про-
цессора, значение этих переменных должно быть 2 
(рис. 1.54). Если процессоров больше, аналогично ус-
тановить значение, равное количеству процессоров. 

EMSight не использует 100 % процессорного 
времени в процессе выполнения анализа. Есть три эта-
па электромагнитного анализа: создание функций 
Грина, заполнение матрицы и решение матрицы. Все 

ядра используются только на третьем этапе решения матрицы. Процент времени, затраченного на этот 
этап, от общего времени зависит от конкретной задачи. 

Заметим, что (по крайней мере, на некоторых компьютерах с двухядерным процессором) распа-
раллеливание вычислений выполняется и без установки указанных системных переменных. 

Рис. 1.53 

Рис. 1.54 

1.8. Создание выходных графиков и добавление единиц измерения. 
Microwave Office даёт возможность просматривать результаты моделирования в виде различных 

графиков. Перед выполнением моделирования необходимо создать график. Необходимо так же опреде-
лить данные или единицы измерения, которые вы хотите видеть на графике, типа усиления, шумов или 
коэффициентов отражения. 

Чтобы создать график, выберите в меню Project>Add Graph или щёлкните правой кнопкой 
мышки по группе Graphs в окне просмотра проекта и выберите New Graph из всплывающего меню. Или 
щёлкните левой кнопкой мышки по значку Add New Graph  на панели инструментов. Появится диа-
логовое окно, в котором нужно задать имя графика и его тип. Пустой график появится на рабочем поле, и 
имя графика появится как подгруппа в группе Graphs в окне просмотра проекта. Доступны следующие 
виды графиков: 
Тип графика  Описание 
Rectangular Прямоугольный Отображает измеряемые величины по осям X – Y, обычно по частоте 
Smith Chart Диаграмма Смита Отображает импедансы или адмитансы на круговой диаграмме 
Polar Полярный Отображает величины и углы измеряемых величин  

 20



Histogram Гистограммы Отображает измеряемые величины в виде гистограммы 
Antenna Plot Антенный гра-
фик 

Отображает измеряемые величины в виде диаграммы направленности 

Tabular Таблица Отображает измеряемые величины в виде таблицы, обычно по частоте 
3D Plot 3-х мерный график Отображает измеряемые величины на 3-х мерном графике 

Чтобы определить, какие данные вы хотите видеть на графике, выберите в меню Project> Add 
Measurement, или щёлкните правой кнопкой мышки по имени нового графика в окне просмотра проекта 
и выберите Add Measurement во всплывающем меню. Альтернативно можно щёлкнуть правой кнопкой 
мышки в окне графика и выбрать Add New Measurement, или щёлкнуть по значку Add New Measure-
ment  на панели инструментов. Откроется диалоговое окно, в котором можно выбрать необходимое 
из списка измеряемых величин. 

Чтобы просмотреть справку о различных параметрах единицы измерения, выделите представ-
ляющую интерес единицу измерения в диалоговом окне Add Measurement и нажмите Meas. Help. 

Полученный после выполнения анализа график можно закрепить, чтобы его можно было срав-
нить с другими вариантами моделирования, например, при каких-то изменениях в схеме. Чтобы закре-
пить график выберите в меню Graph>Freeze Traces при активном окне графика. Затем выполните изме-
нение в схеме и выполните анализ снова. Чтобы снять закрепление графика выберите в меню 
Graph>Clear Frozen. 

1.9. Установка частот для анализа и выполнение моделирования. 
Чтобы установить частоты для 

моделирования, дважды щёлкните по 
группе Project Options в окне про-
смотра проектов или выберите в меню 
Options>Project Options. Откроется 
диалоговое окно, на вкладке Frequen-
cies которого можно определить часто-
ты для моделирования (рис. 1.55). По 
умолчанию все созданные в проекте 
схемы используют для анализа часто-
ты, установленные в этом окне. Для 
любой схемы или электромагнитной 
структуры проекта вы можете отме-
нить использование частот проекта и 
назначить индивидуальные частоты 
для анализа данной схемы или струк-
туры. Для этого щёлкните правой 
кнопкой мышки по имени схемы или 
электромагнитной структуры в окне 
просмотра п оекта и вы ери  Options. 

В открывшемся диалоговом окне, на вкладке Frequencies снимите “галочку” в Use project defaults и 
введите частоты, которые будут использоваться только для выбранной схемы или структуры. 

Рис. 1.55 р б те

Чтобы выполнить моделирование созданного проекта, выберите в меню Simulate>Analyze или 
щёлкните левой кнопкой мышки по значку Analyze  на панели инструментов. 

Microwave Office выполнит моделирование автоматически выполняя соответствующий метод 
моделирования для различных частей проекта, т. е. линейное моделирование, гармонический баланс, 
моделирование нелинейными рядами Вольтера, или моделирование электромагнитной структуры. 

После окончания моделирования, результаты можно просматривать на созданных графиках и за-
тем настраивать и/или оптимизировать при необходимости. Блок настройки Microwave Office в режиме 
реального времени позволяет сразу же наблюдать изменение выходных параметров на графике при из-
менении параметров схемы движком тюнера или при проведении оптимизации. При настройке или оп-
тимизации автоматически изменяется схема и связанные с изменяемыми параметрами элементы тополо-
гии. Для настройки схемы нажмите значок Tune Tool  на панели инструментов и выберите параметры 
в схеме, которые вы желаете настроить. Затем нажмите значок Tune , чтобы их настроить. 

1.10. Установка единиц измерения, используемых по умолчанию 
Чтобы установить единицы измерения, которые будут использоваться в проекте по умолчанию, 

выберите в меню Options>Project Options. Откроется диалоговое окно Project Options. В этом окне от-
кройте вкладку Global Units (рис. 1.56). 

В большинстве примеров моделирования, описываемых в этом пособии, используется метриче-
ская система измерений и единицы измерения, показанные в окне рис. 1.56. В этих примерах не описы-
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вается, как установить единицы измерения для создаваемого проекта. Если используются другие едини-
цы измерения, описание их установки включено в пример. 

Состав проекта, загружаемый при запуске Microwave Office, определяется lpf-файлом. При за-
грузке системы обычно загружается default.lpf. При желании этот файл можно отредактировать (как и 
любой другой lpf-файл). Файл default.lpf расположен в корневом каталоге программы, обычно в 
C:\Program Files\AWR\AWR2009. Для редактирования этого фала снимите атрибут Только для чтения и 
откройте файл в текстовом редакторе, например в Блокноте. Если вы чаще всего используете единицу 
измерения GHz для частот, тогда в lpf-файле в группе $DEFAULT_UNITS_BEGIN в начале файла в 

строке FREQ замените стоящую справа букву на G (рис. 1.57). Сохраните отредактированный файл и 
установите атрибут Только для чтения. 

Рис. 1.57 
Рис. 1.56 

1.11. Сценарии и мастера 
Сценарии и мастера позволяют автоматизировать и расширить функциональные возможности 

Microwave Office. 
Сценарии – это программы Basic, которые пользователи могут записывать, чтобы, например, ав-

томатизировать задачи формирования схемы в Microwave Office. Чтобы получить доступ к созданию 
сценариев, выберите в меню Tools>Scripting Editor, или Scripts>Global Scripts, или Scripts>Project 
Scripts. 

Мастера – это файлы динамически загружаемых библиотек (DLL), которые можно использовать, 
как добавочные инструментальные средства, например, для синтеза фильтров. Мастера отображаются 
как подгруппы в группе Wizards в окне просмотра проекта. 

В ASWRDE 2009 включены следующие мастера: 
o AWR APPLAC Import Wizards – используется для импорта и конвертирования файлов 

APPLAC в AWR. 
o AWR Filter Synthesis Wizard – программа для синтеза фильтров. Вы можете синтезировать по-

лосно-пропускающие (Bandpass), полосно-заграждающие (Bandstop) фильтры, фильтры верх-
них (Highpass) и нижних (Lowpass) частот, используя характеристики Баттерворда, Чебышева и 
Бесселя-Томсона. Фильтры могут синтезироваться из сосредоточенных элементов и из отрезков 
некоторых линий передачи. Схема синтезированного фильтра передаётся в Microwave Office, где 
создаётся график и выполняется анализ схемы. При этом схема готова для выполнения настрой-
ки или оптимизации. 

o AWR Load Pull Wizard – Позволяет выполнить моделирование полной нагрузки устройства. 
Используется инструмент настройки для настройки импеданса. Кроме того, имеется AWR Load 
Pull Script, который содержит ряд опций, усиливающих возможности AWR Load Pull Wizard. 
AWR Load Pull Script не отображается в группе Wizards. Чтобы его открыть, выберите в меню 
Scripts>Global Scripts>Load_Pull (Main). 

o AWR Symbol Generator Wizard – позволяет создавать пользовательские символы для подсхем. 
o iFilter Filter Wizard – является программой для синтеза фильтров. Этот мастер отображается в 

группе Wizards, если у вас имеется лицензия для выполнения этого мастера. 
o Если у вас установлена программа Nuhertz Filter, она также отображается в группе Wizards. 
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1.12. Помощь 
Страницы помощи Microwave Office обеспечивают необходимую информацию об окнах, пунк-

тах меню, диалоговых окнах, а так же обо всех элементах Microwave Office. 
Для получения справки выберите в меню Help или нажмите клавишу F1. Кроме того доступна 

также следующая контекстная помощь: 
o Кнопки помощи Help имеются в большинстве диалоговых окон. 
o Помощь по каждому элементу схемы можно получить, если выделить элемент на схеме и нажать 

Alt+F1. Или дважды щёлкнуть по элементу на схеме левой кнопкой мышки и в открывшемся 
окне щёлкнуть по кнопке Element Help. Или в окне просмотра элементов щёлкнуть по элементу 
правой кнопкой мышки и выбрать Element Help. 

o Помощь по любой измеряемой величине для графиков можно получить, если щёлкнуть правой 
кнопкой мышки по имени графика в окне просмотра проекта, выбрать Modify Measurement и в 
открывшемся окне щёлкнуть по кнопке Meas Help. Или щёлкнуть правой кнопкой мышки по 
имени измеряемой величины в окне просмотра проекта, выбрать Properties и в открывшемся 
окне щёлкнуть по кнопке Meas Help. 

 
 



2 Импорт файлов данных 2 Импорт файлов данных 
Этот пример показывает, как импортировать файлы данных в формате Touchstone и использо-

вать их в моделировании. Файлы данных часто используются для сравнения расчётных характеристик с 
измеренными, или для сравнения характеристик, рассчитанных в различных программных продуктах. В 
примере демонстрируются следующие шаги: 

Этот пример показывает, как импортировать файлы данных в формате Touchstone и использо-
вать их в моделировании. Файлы данных часто используются для сравнения расчётных характеристик с 
измеренными, или для сравнения характеристик, рассчитанных в различных программных продуктах. В 
примере демонстрируются следующие шаги: 

o Импортирование файла S-параметров. o Импортирование файла S-параметров. 
o Создание единиц измерения. o Создание единиц измерения. 
o Добавление файла данных в схему. o Добавление файла данных в схему. 
o Назначение символа файлу данных. o Назначение символа файлу данных. 
o Настройка схемы для моделирования. o Настройка схемы для моделирования. 

2.1 Создание нового проекта 2.1 Создание нового проекта 
Сначала нужно создать новый проект. Для его создания сделайте следующее: Сначала нужно создать новый проект. Для его создания сделайте следующее: 

1. Выберите в меню File>New Project (Файл>Новый проект). 1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалоговое 

окно Save As. 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалоговое 

окно Save As. 
3. Наберите имя проекта (например, datafile) и нажмите Сохранить. 3. Наберите имя проекта (например, datafile) и нажмите Сохранить. 
По умолчанию Microwave Office обычно предлагает сохранить проект в папке Мои 

документы\AWR Project. Чтобы изменить папку, предлагаемую по умолчанию, выберите в меню Op-
tions>Environment Options (Опции>Опции среды). В открывшемся окне на вкладке File Locations (Раз-
мещение файлов) в текстовом поле Default Design Directory: (Директория, назначаемая по умолчанию:) 
введите путь к нужной папке, например, E:\USER\AWR2009, или нажмите кнопку Browse (Просмотр) 
справа от этого поля и выберите нужную папку. 

По умолчанию Microwave Office обычно предлагает сохранить проект в папке Мои 
документы\AWR Project. Чтобы изменить папку, предлагаемую по умолчанию, выберите в меню Op-
tions>Environment Options (Опции>Опции среды). В открывшемся окне на вкладке File Locations (Раз-
мещение файлов) в текстовом поле Default Design Directory: (Директория, назначаемая по умолчанию:) 
введите путь к нужной папке, например, E:\USER\AWR2009, или нажмите кнопку Browse (Просмотр) 
справа от этого поля и выберите нужную папку. 

2.2 Импортирование файла данных 2.2 Импортирование файла данных 
Щёлкните правой 

кнопкой мышки по группе 
Data Files в окне просмотра 
проекта и выберите Import 
Data File. В открывшемся окне 
ввода файлов данных (рис. 2.1) 
в поле Тип файлов выберите 
Touchstone Files. 

Щёлкните правой 
кнопкой мышки по группе 
Data Files в окне просмотра 
проекта и выберите Import 
Data File. В открывшемся окне 
ввода файлов данных (рис. 2.1) 
в поле Тип файлов выберите 
Touchstone Files. 
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Найдите файл 
N76038a, который находится в 
папке …\AWR2009\Examples\, 

и щёлкните мышкой по этому файлу. Или выберите этот файл и 
нажмите кнопку Отрыть. Имя файла данных появится в окне 
просмотра проекта в группе Data Files (рис. 2.2). 

Найдите файл 
N76038a, который находится в 
папке …\AWR2009\Examples\, 

и щёлкните мышкой по этому файлу. Или выберите этот файл и 
нажмите кнопку Отрыть. Имя файла данных появится в окне 
просмотра проекта в группе Data Files (рис. 2.2). 

Добавлен-
ный файл
данных 

Рис. 2.2 

Рис. 2.1 

2.3 Отображение S-параметров файла дан-
ных 
2.3 Отображение S-параметров файла дан-
ных 

Выберите в меню Project>Add Graph, или щёлкните по 
значку Add New Graph 

Выберите в меню Project>Add Graph, или щёлкните по 
значку Add New Graph  на панели инструментов, или щёлкни-
те правой кнопкой мышки по группе Graphs в окне просмотра 
проекта и выберите New Graph. Откроется окно New Graph (рис. 
2.3). В поле ввода имени графика введите s21 Data File. Отметьте 
тип графика Rectangular (Прямоугольный) и нажмите OK. На 
рабочем поле откроется окно графика. 

Теперь нужно добавить измеряемую величину для ото-
бражения на созданном графике. 

Рис. 2.3 



Щёлкните правой кнопкой 
мышки по имени графика s21 Data 
File в окне просмотра проекта и вы-
берите Add Measurement. Или 
щёлкните по значку Add New Meas-
urement  на панели инструментов. 
Откроется диалоговое окно Add 
Measurement для добавления изме-
ряемой величины рис. 2.4. В области 
Measurement Type разверните груп-
пу Linear и отметьте Port Parame-
ters. В области Measurement отметь-
те S. В поле Data Source Name (Имя 
источника данных) введите имя фай-
ла данных N76038a, чтобы на схеме 
отобразить график только для файла 
данных, щёлкнув по кнопке в правом 
конце этого поля. В поле To Port 
Index введите 2, в поле From Port 
Index введите 1. В поле Sweep Freq 

(FDOC) введите Use for x-axis. В левой 
нижней части окна отметьте Mag и dB. 
Нажмите OK. Имя измеряемой величины 
появится в окне просмотра проекта в под-
группе s21 Data File. 

Рис. 2.4 

Чтобы выполнить анализ, выбери-
те в меню Simulate>Analyze, или щёлкните 
по кнопке Analyze на панели инструмен-
тов. Рассчитанный график показан на рис. 
2.5. Заметим, что в этом примере нет необ-
ходимости определять частоты для моде-
лирования. Эти частоты берутся из файла 
данных. 

Допустим, нужно отобразить гра-
фик S11 на диаграмме Смита. Для этого 
можно создать новый график, определить 
его тип Smith Chart и добавить новую из-
меряемую величину. Но можно это сделать 
и иначе. Рис.2.5 

Щёлкните правой кнопкой мышки 
по имени графика s21 Data File в окне про-
смотра проекта и выберите Duplicate 
as>Smith. В окне появится новый график с 
именем s21 Data File 1 и на рабочем поле 
откроется окно нового графика (рис. 2.6). 
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Щёлкните правой кнопкой мышки 
по имени графика s21 Data File 1 в окне 
просмотра проекта и выберите Rename 
Graph. В открывшемся окне измените имя 
графика на S11 Smith и нажмите OK. 

Теперь нужно изменить измеряемую 
величину. Дважды щёлкните по измеряемой 

величине N76038a:S(2,1) в окне просмотра под графиком S11 Smith. Откроется окно Modify Measure-
ment, аналогичное окну рис. 2.4. В поле To Port Index введите 1 и нажмите OK. Щёлкните по кнопке 
Analyze на панели инструментов. Рассчитанный график показан на рис. 2.6. 

Рис. 2.6 

2.4. Добавление файла данных в схему 
Чтобы создать схему, выберите в меню Project>Add Schematic>New Add Schematic или щёлк-

ните по значку Add New Schematic  на панели инструментов. В открывшемся окне введите имя схемы 
Amp и нажмите OK. Откроется пустое окно схемы и в окне просмотра проекта в группе Circuit Sche-
matics появится подгруппа схемы Amp. 

Выберите в меню Draw>Add Subcircuit или щёлкните по значку Subcircuit  на панели инст-
рументов. Откроется окно со списком всех имеющихся подсхем (рис. 2.7). В нашем примере имеется 



только одна подсхема – файл данных. Выберите файл данных в этом списке, отметьте Explicit ground 
node (Явный узел земли) и нажмите OK. Поместите подсхему в окне схемы в нужное место и щёлкните 

левой кнопкой мышки, чтобы закрепить её. 
Обратите внимание, в окне рис. 2.7 имеется область 

Grounding Type (Тип заземления) с 3-мя опциями, которые опре-
деляют, как будет отображаться подсхема в схеме. Если отметить 
Normal, подсхема будет отображена с количеством контактов 
(входов-выходов), которые явно определены в подсхеме для под-
ключения других элементов к этой подсхеме. Если подсхема – 
четырёхполюсник, то в схеме элемент подсхемы будет отобра-
жаться в виде прямоугольника с двумя контактами. Если отметить 
Explicit ground node, то подсхема будет отображаться прямо-
угольником с тремя контактами, один из которых соединяется с 
землёй. Это может пригодиться для более наглядного представле-
ния, например, если файл данных содержит S-параметры транзи-
стора или микросхемы, измеренные как для четырёхполюсника. 
Если отметить Balanced ports, то подсхема будет отображена 

прямоугольником с четырьмя контактами, два из которых соединяются с землёй. Все эти опции влияют 
только на наглядность отображения подсхемы и никак не влияют на отображение графика S-параметров 
файла данных. Кроме того, отображение подсхемы, вставленной в схему, можно изменить в любое вре-
мя. Для этого дважды щёлкните по элементу подсхемы и в открывшемся окне свойств откройте вкладку 
Ground. 

Рис. 2.7 

Добавить подсхему можно и иначе. Откройте окно просмотра элементов, отметьте группу Sub-
circuits и перетащите нужную подсхему в окно схемы. 
Выберите в меню Draw>Add Port или щёлкните по значку Port  на 
панели инструментов. Поместите порт в схеме так, чтобы его контакт 
соединялся с контактом 1 подсхемы и щёлкните левой кнопкой мышки, 
чтобы закрепить порт. Снова щёлкните по значку Port, два раза щёлкни-
те правой кнопкой мышки, чтобы развернуть порт на 180 градусов, и 
подключите порт к контакту 2 подсхемы. 
Выберите в меню Draw>Ground или щёлкните по значку Ground  на 
панели инструментов. Подключите землю к контакту 3 подсхемы. Долж-
на получиться схема, показанная на рис. 2.8. Рис. 2.8 

2.5. Определение частот и выполнение анализа схемы. 
Для отображения S-

параметров файла данных опреде-
лять частоты не требовалось, т.к. 
они заданы в самом файле данных. 
Однако для других элементов схемы 
эти частоты недоступны. Поэтому, 
чтобы выполнить анализ схемы, мы 
должны определить частоты, на ко-
торых необходимо выполнить ана-
лиз. 
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Выберите в меню Op-
tions>Project Options, или дважды 
щёлкните мышкой по группе Project 
Options в окне просмотра проекта, 
или щёлкните правой кнопкой мыш-
ки по группе Project Options в окне 
просмотра проекта и выберите Edit. 
Откроется окно опций проекта (рис. 
2.9). 

Отметьте Replace (Заме-
нить). В поле Start(GHz) введите 2, в поле Stop(GHz) введите 10, в поле Step(GHz) введите 0.1. Нажми-
те Apply и OK. 

Рис. 2.9 

Дважды щёлкните по имени графика s21 Data File в окне просмотра проекта, чтобы сделать ак-
тивным окно графика. 

Щёлкните правой кнопкой мышки по имени этого графика в окне просмотра проекта и выберите 
Add Measurement. Или щёлкните по значку Add New Measurement  на панели инструментов. В от-
крывшемся окне Add Measurement сделайте такие же установки, как и в окне рис. 2.4, но в поле Data 
Source Name введите имя схемы Amp. Нажмите Apply и OK. 



Выберите в меню Simulate>Analyze или щёлкните по значку Analyze  на панели инструмен-
тов. Полученный график показан на рис. 2.10. 

График схемы отображается довольно грубо и не совпадает с графиком файла данных. Выберите 
в меню Options>Project Options и в отрывшемся окне опций откройте вкладку Interpolation/Passivity 
(рис. 2.11). В области Coordinate System по умолчанию отмечено Cartesian (Декартовый). Отметьте в 
этой области Polar и нажмите OK. Щёлкните по значку Analyze на панели инструментов. Полученный 
график показан на рис. 2.12. 

Рис. 2.10 Рис. 2.11 

Примечание. Если бы при добавлении изме-
ряемой величины при создании графика (см. рис. 2.4) 
в поле Data Source Name мы ввели не имя файла 
данных N76038a, а All Sources (Все источники), то 
после создания схемы нам не пришлось бы добавлять 
к графику новую характеристику Amp. Она была бы 
добавлена автоматически. Однако в описанном слу-
чае, когда для каждой схемы (электромагнитной 
структуры, файла данных) к графику добавляется но-
вая измеряемая величина, есть своё преимущество. 
Если в проекте много схем и характеристики отобра-
жаются на одном графике (например, для сравнения), 
то можно любую из характеристик скрыть. Для этого 
нужно щёлкнуть правой кнопкой по имени характе-
ристики под графиком в окне просмотра проекта и 
выбрать Toggle Enable (Переключатель активности). 
Чтобы вновь отобразить скрытую характеристику, 

нужно снова выбрать Toggle Enable. 

Рис. 2.12 
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3. Линейное моделирование 
Линейное моделирование для определения характеристик электрической цепи использует метод 

узловых напряжений. Оно может применяться для цепей типа усилителей в линейном режиме, фильтров, 
направленных ответвителей, делителей мощности и других, чьи элементы могут быть описаны матрицей 
полных проводимостей. Для линейного моделирования характерно определение измеряемых величин 
типа усиления, устойчивости, коэффициента отражения, коэффициента передачи. 

В блок линейного программирования включён блок настройки в реальном масштабе времени, 
который позволяет настраивать элементы схемы и сразу наблюдать результаты настройки. Имеется воз-
можность также выполнить оптимизацию различными методами и статистический анализ. 

Следующие примеры иллюстрируют некоторые из основных особенностей линейного модели-
рования в Microwave Office. 

3.1. Моделирование ФНЧ на сосредоточенных элементах 
Этот пример показывает, как использовать Microwave Office для моделирования ФНЧ на базо-

вых сосредоточенных элементах, используя линейное моделирование. Такое моделирование включает 
следующие основные шаги: 

• Создание схемы; 
• Добавление графиков и измеряемых величин; 
• Анализ схемы; 
• Настройка схемы; 
• Создание переменных для оптимизации; 
• Оптимизация схемы. 

3.1.1. Создание нового проекта. 
Сначала нужно создать новый проект. Для его создания сделайте следующее: 

1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалоговое 

окно Save As. 
3. Наберите имя проекта (например, linear-example) и нажмите Сохранить. 

3.1.2. Установка единиц измерения, используемых по умолчанию. 
Чтобы установить единицы измерения, которые будут использоваться в проекте по умолчанию: 

1. Выберите в меню Op-
tions>Project Options. 
Откроется диалоговое 
окно Project Options 
(рис. 3.1). 
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2. Откройте вкладку Global 
Units (Глобальные еди-
ницы измерения) в верх-
ней части диалогового 
окна. 

3. Установите нужные еди-
ницы измерения, щёлкая 
по стрелкам, справа от 
поля ввода соответст-
вующей единицы так, 
чтобы они соответство-
вали показанным на рис. 
3.1, снимите флажок в 
поле Metric units (Мет-
рические единицы), ус-
тановите mil в поле 

Length type и нажмите OK. 
Рис. 3.1 

3.1.3. Создание схемы. 
Чтобы создать схему: 

1. Выберите Project>Add Schematic>New Schematic (Проект>Добавить схему>Новая схема) в 
выпадающем меню или щёлкните по значку Add New Schematic  на панели инструментов. 
Откроется диалоговое окно Create New Schematic (Создание новой схемы). 

2. Наберите имя схемы, например, lpf и нажмите OK. Откроется пустое окно схемы на рабочем 
поле и имя схемы появится, как подгруппа lpf в группе Circuit Schematics (Схемы цепи) в окне 
просмотра проекта. 

 



3.1.4. Размещение элементов в схеме. 
Чтобы разместить элементы в схеме: 

1. Нажмите на панель Elements в нижней части левого окна, чтобы открыть окно просмотра эле-
ментов (см. рис. 3.2). 

2. Щёлкните по значку + слева от группы Circuit Elements, чтобы развернуть группу элементов 
цепи. 
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кните левой кнопкой 

IND и, не отпуская кнопки мышки, 

 подключая каждую индуктив-

угим элементом, вы должны помес-

r (Конденсаторы) в окне просмотра элементов. В нижней части 

кая кнопки мыш-

ксируйте, 

жды, соеди-
онденсатор, как показано на рисунке 3.5. 

а и внизу окна схемы, чтобы отобразить в окне ту 

3. В категории Circuit Elements разверните группу сосредоточенных элементов (Lumped Ele-
ment), щёлкнув по значку 
+ слева от этой группы. 

4. Щёл
мышки по подгруппе In-
ductor (Индуктивности) в 
окне просмотра элемен-
тов. В нижней части окна 
появятся изображения 
доступных индуктивно-
стей. Вы можете изме-
нить отображение эле-
ментов, щёлкнув в ниж-
ней части окна просмотра 
элементов и выбрав одну 
из опций (рис. 3.3). Если 
выбрать Show Details, то 
элементы будут отобра-
жаться с их кратким опи-
санием. Если выбрать 
Element Help, то откро-
ется окно помощи по 
элементу, на который 
указывает курсор мышки. 

5. Нажмите левой кнопкой м

Окно просмотра 
элементов 

Модели 
элементов 

Рис. 3.2 
ышки на модель индуктивности 

перетащите её в окно схемы. Отпустите кнопку мышки, поместите эле-
мент, как показано на рисунке 3.2 и зафиксируйте, щёлкнув левой кноп-
кой мышки. 

6. Повторите шаг 5 три раза, совмещая и
ность, как показано на рисунке 3.4. 

7. Чтобы соединить один элемент с др
тить элемент так, чтобы его узел присоединился к узлу другого элемен-
та. При правильном соединении узел отображается в виде маленького 

зелёного квадрата. Если сразу 
соединить элементы не удалось, 
нажмите нужный элемент левой 
кнопкой мышки и, не отпуская 
кнопки, переместите элемент в 
надлежащее место. 

8. Теперь щёлкните левой кнопкой 
мышки по подгруппе Capacito

Рис. 3.3 

Рис. 3.4 

окна появятся изображения дос-
тупных конденсаторов. 

9. Нажмите на модель конденсатора 
CAP и, не отпус
ки, перетащите её в окно схемы, 
отпустите кнопку, щёлкните пра-
вой кнопкой мышки, чтобы по-
вернуть элемент на 90 градусов, 
поместите его, как показано на 
рисунке 3.5 и зафи
щёлкнув левой кнопкой мышки. 

10. Повторите шаг 8 два
Рис. 3.5 

няя каждый к
Примечания. 

 Используйте полосы скроллинга справ
часть схемы, с которой вы работаете. 



 Чтобы увеличить часть схемы, щёлкните по значку View Area  (Показать область) на 
панели инструментов, курсор будет отображаться в виде лупы с крестиком. Переместите 
курсор в окно схемы, поместите курсор крестиком в левый верхний угол участка схемы, 
который надо увеличить, нажмите на левую кнопку мышки и, не отпуская кнопки, пе-

 Отпустите кнопку мышки. 
реместите курсор в правый нижний угол выделяемого участка (выделяемая часть схемы 
будет обводиться прямоугольником).

 Чтобы уменьшить изображение схемы, щёлкните по значку Zoom Out  (Уменьшить 
масштаб) на панели инструментов. 

 Чтобы отобразить всю схему, щёлкните по значку View All  (Показать всё) на панели 
инструментов. 

 Чтобы удалить элемент из схемы, щелкните левой кнопкой мышки по этому элементу в 
вишу Delete. 

ать начало 
рсор к нижней клемме второго конденсатора С2, затем к нижней клем-

 снова щёлкните левой кнопкой мышки (рис. 3.7). 

схеме, чтобы выделить его, и нажмите кла
3.1.5. Соединение проводом. 

тобы соединить нижние клеммы конденсаторов: Ч
1. Поместите курсор возле нижней клеммы первого конденсатора C1. Курсор будет отображаться 

в виде соленоида, как показано на рисунке 3.6. 
Щёлкните (т. е. нажмите и отпустите) левой кнопкой мышки, чтобы зафиксиров2. 
провода, перетащите ку
ме последнего конденсатора C3 и
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3.1.6. Размещение портов. 
Чтобы разместить порты (входы): 

Рис. 3.6 Рис. 3.7 

1. Выберите в меню Draw>Add 
Port (Чертить>Добавить порт) 
или щёлкните левой кнопкой 
мышки по значку Port  на 
панели инструментов. 

2. Переместите курсор в окно 

ите порт к правой клемме последней индуктивности и зафиксируйте, 
ис. 3.8). 

схемы, поместите порт на ле-
вой клемме первой индуктив-
ности и щёлкните левой кноп-
кой мышки, чтобы зафикси-
ровать его. 

3. Повторите шаги 1 и 2, чтобы подключить порт к последней индуктивности, но после переме-
щения его в окно схемы, щёлкните два раза правой кнопкой мышки, чтобы

Рис. 3.8 

 развернуть порт на 
180 градусов. Подвед
щёлкнув левой кнопкой (р

3.1.7 Размещение земли. 
Чтобы подключить землю: 

1. Выберите в меню Draw>Add 
Ground (Рисовать>Добавить 
землю) или щёлкните левой 
кнопкой мышки по значку 
Ground  на панели инстру-
ментов. 

2. Переместите курсор в окно схе-

е конденсатора C1 и за-
мы, поместите землю на нижней 
клемм
фиксируйте, щёлкнув левой 

кнопкой мышки (см. рис. 3.9). 
3.1.8. Редактирование параметров элементов. 

Рис. 3.9 

Чтобы отредактировать параметры элементов: 
1. Поместите курсор на элемент IND L1 (на катушку) в окне схемы и дважды щёлкните левой 

кнопкой мышки. Откроется диалоговое окно Element Options (Опции элемента) 
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-

ь значение параметра непосредственно в 
схеме. Изменив значение параметра, щёлкните где-нибудь на свободном  окне

левого окна, чтобы от-
мотра проекта. 

 Дважды щёлкните по группе Project 
Options (Опции проекта). Откроется 
диалоговое окно Project Options. 

 В этом окне откройте вкладку Fre-
quencies (Частоты). 

 В области Data Entry Units (Ввод 
единиц измерения данных) установи-
те MHz, щёлкая по кнопкам в правом 
конце этого поля. 

 Отметьте Replace (Заменить). Набе-
рите 100 в поле Start (Начальная час-
тота), 1000 в поле Stop (Конечная час-
тота) и 10 поле Step (Шаг). Нажмите 
Apply (Применить). В области Cur-
rent Range (Текущий диапазон) ото-
бражается частотный диапазон с за-
данным шагом по с. 3.11). 
Нажмите OK. 

 ввода можно делать, щёлкая левой кнопкой мышки по 

1. Щёлкните правой кнопкой 

росмотра 

щёлкните по 
значку Add New Graph

2. На вкладке Parameters этого окна в текстовое поле, расположенное в столбце Value (Значение) 
напротив значения индуктивности (L), введите 15 и нажмите OK. Изменение будет отражено 
на схеме (рис. 3.10). Альтернативно, можно дважды щёлкнуть левой кнопкой мышки по значе
нию параметра в схеме (в данном случае по параметру L=1 nH индуктивности ID=L1). Откро-
ется поле редактирования, которое позволяет изменит

 месте в  схемы. 
3. По аналогии 

с шагами 1 и 
2 редакти-
руйте значе-
ния индук-
тивностей и 

емкостей 
так, чтобы 
их значения 
были таки-
ми, как пока-
зано на ри-
сунке 3.10.  

Рис. 3.10 

3.1.9. Задание частот для моделирования. 
Чтобы задать частоты для моделирования: 

1. Щёлкните левой кнопкой мышки по панели Project в нижней части 
крыть окно прос

2.

3.

4.

5.

 частоте (риРис. 3.11 

Примечание. Переход между полями
нужному полю или нажимая клавишу Tab. 

3.1.10. Создание графика. 
Чтобы создать график: 

мышки по группе Graphs 
(Графики) в окне п
проекта и выберите New 
Graph во всплывающем 
меню или 

  
на панели инструментов. 
Откроется диалоговое окно 
New Graph. 

2. Наберите s21 and s11 в поле 
ввода имени графика. От-
метьте Rectangular в пере-
ключателе типа графика и 
нажмите OK. Окно графика 
создаётся на рабочем поле, 
и имя графика появляется 

как подгруппа в группе Graphs в окне просмотра проекта (рис. 3.12). 
 

Подгруппа 
графика 

Рис. 3.12 
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Чтобы добавить измеряемые величины к графику: 

Mag (Модуль) и dB  в области Complex 
именить). 

,1]|) и lpf.DB(|S[2,1]|) появятся как подгруппы 
1 в окне просмотра проекта. 

3.1.12. 

ен

ышки по 

3.1.11. Добавление к графику измеряемых величин. 

1. Щёлкните правой кнопкой 
мышки по имени графика S21 
and S11 в окне просмотра про-
екта и выберите Add Measure-
ment (Добавить измеряемую ве-
личину) во всплывающем меню. 
Или щёлкните левой кнопкой 
мышки по значку Add Meas-
urement на панели инструмен-
тов. Откроется диалоговое окно 
Add Measurement (см. рис. 
3.13). 

2. Выберите Linear и затем Port 
Parameters (Параметры порта) 
в области Meas Type (Тип из-
меряемых величин). Выберите S 
в области Measurement (Изме-
ряемая величина). Выберите lpf 
(т.е. имя схемы, которое вы ей 
дали) в поле Data Source Name 
(Имя источника данных, т. е. 
имеется в виду имя схемы), на-
жимая на стрелку, справа от 
этого поля. Выберите 1 в поле 

To Port Index (Индекс входного порта), и в поле From Port Index (Индекс выходного порта), 
нажимая на стрелки, 

Рис. 3.13 

справа от этих полей. Отметьте 
Modifier (Представление комплексной величины) и нажмите Apply (Пр

3. Измените значение в поле To Port Index на 2 и нажмите Apply. 
Нажмите OK. Измеряемые величины lpf.DB(|S[14. 
в группе S21 and S1
Анализ схемы. 
Чтобы выполнить анализ схемы: 

Выберите в м ю Simu-
late>Analyze (Моделирование>Анализ) 
или щёлкните левой кнопкой м
значку Analyze  на панели инструмен-
тов. Результаты анализа отображаются на 
графике рис. 3.14. 

На графике в прямоугольнике 
отображается, какая кривая какой изме-
ряемой величине соответствует. Размеры 
этого прямоугольника можно изменять. 
Для этого щёлкните по нему левой кноп-
кой мышки, установите курсор на ромбик 
в середине любой стороны или на квадра-
тик в углу (курсор при этом должен ото-
бражаться в виде двойной стрелки), на-
жмите левую кнопку мышки и, не отпус-
кая её, двигайте курсор. Размер шрифта 
при этом изменяется автоматически. Весь 
этот прямоугольник можно переместить в 

любое место графика, если по к (курсор при этом должен отображаться в 
виде перекрестия) и затем, наж

местить курсор в прямоугольни
ав левую кнопку мышки и не отпуская её, двигать мышкой. 

Рис. 3.14 

3.1.13. Настройка схемы. 
Чтобы настроить схему: 

1. Щёлкните левой кнопкой мышки по окну схемы, чтобы сделать его активным. Или дважды 
щёлкните левой кнопкой мышки по имени схемы в окне просмотра элементов. 

2. Сначала нужно указать параметры элементов, которые необходимо изменять при настройке. 
Чтобы сделать это, щёлкните по значку Tune Tool  (Инструмент настройки) на панели инст-
рументов или выберите в меню Simulate>Tune Tool. 
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перекрестия, как показано на рис. 
ие в чёрном 

и по 
араметру L, чтобы активизировать 

режим выбора переменных для настройки. 
ь его активным. 

8. Выб

3. Поместите курсор на параметр L индуктивности IND L1. Курсор должен отображаться в виде 

3.15 (белое перекрест
кружке). 

4. Щёлкните левой кнопкой мышк
п
его для настройки. Цвет этого пара-
метра изменится на синий. 

5. Повторите шаги со 2-го по 4-ый для 
индуктивности L4 и конденсаторов 
C1, C3. 

6. Щёлкните мышкой где-нибудь на свободном месте в окне схемы или щёлкните по значку Tune 
Tool на панели инструментов, чтобы о

ы сделат

Рис. 3.15

тменить 
7. Щёлкните по окну графика, чтоб

ерите в меню Simulate>Tune или щёлкните по значку Tune  на панели инструментов. 
Откроется окно Vari-
able Tuner (Блок на-

 

и. 

, 
 

. Для среднего 

стройки переменных), 
показанное на рис. 3.16. 

9. Нажмите левой кноп-
кой мышки на бегунок 
настройки и, не отпус-
кая кнопки, двигайте 
его вверх и вниз. Ре-
зультаты настройки пе-
ременных наблюдайте 
на графике. 

10. Передвиньте бегунки 
настройки переменных 
в положения, указан-
ные на рисунке 3.16. 
Нажмите кнопку Sweep 
(Изменить) в левой 

части окна настройки, это оптимизирует отображение графика, изменив масштаб по оси Y. 
11. Закройте окно Variable Tuner. 

Чтобы отменить параметры переменных для настройки, нужно по этим параметрам снова 
щёлкну

Рис. 3.16

ть инструментом Tune Tool. 
3.1.14. Создание переменных параметров для оптимизаци

Фильтры – это типично симметричные схемы. Т.е. в процессе оптимизации параметры симмет-
ричных элементов должны изменяться на одинаковую величину. Поэтому оптимизируемый параметр 

ары тех симметричных элементов, коткаждой п орые должны быть включены в процесс оптимизации
нужно заменить одним общим переменным параметром. Для этого сначала необходимо создать такой
переменный параметр для каждой пары оптимизируемых симметричных элементов и затем заменить 

м параметромсозданны  соответствующие параметры у обоих симметричных элементов
элемента, если он в схеме один (в данном случае конденсатор C2) это делать не обязательно. 

Чтобы создать переменные параметры: 
Щёлкните по окну схемы, чтобы сделать его активным. 1. 

2. Выберите в меню Draw>Add Equation (Чертить>Добавить уравнение) или щёлкните по значку 
Equation  на панели инструментов. 

3. Переместите курсор в окно схемы. Появится окошко редактора в виде небольшого квадрата. 
4. Поместите окошко редактора выше схемы и щёлкните левой кнопкой мышки, чтобы зафикси-

ровать его. 
5. Наберите IND=15 в 

окошке редактора и 
щёлкните мышкой вне 
этого окна. 

6. Повторите шаги со 2-го 
по 5-ый, чтобы открыть 
второе окошко редакто-
ра, но наберите CAP=8, 
и щёлкните мышкой вне 
этого окошка. Результат 
показан на рис. 3.17. 

Рис. 3.17 
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 и в от-

арамет-
ментов с ука-

метров элементов, отметьте столбец Constrained 

er и Upper. На рис. 3.18 показано окно Variables с открытым до-

ложения столбцов можно и мышкой. Для этого ус-

ия переменных для оптимизации не является единственным. 
ом окне можно назначить для оптимизации сразу все 

но использовать и в качестве альтернативного способа на-
еского анализа и ста-

тистической оптимизации. 
3.1.15. Добавление целей оптимизации. 

Под целью оптимизации подразумевается некоторая граница изменения какой-либо характери-
стики анализируемой схемы, к которой должен стремиться выбранный метод оптимизации при измене-
нии определённых параметров элементов. 

Чтобы добавить цели оптимизации: 

7. Дважды щёлкните по параметру L значения индуктивности IND L1. Появится окошко редак-
тора. Наберите значение IND и щёлкните левой кнопкой мышки вне окошка редактора. 

8. Повторите шаг 7, чтобы заменить параметр L индуктивности IND L4 на IND, и параметры 
конденсаторов CAP C1 и CAP C3 на CAP, как показано на рисунке 3.17. Переменные IND и 
CAP нужно назначить для оптимизации. 

Чтобы назначить переменные для оптимизации: 
1. Выберите в меню View>Variable Browser. Или выберите в меню Simulate>Optimize

крывшемся окне щёлкните левой кнопкой мышки по панели Variables в левой нижней части 
окна. Откроется 
вкладка Variables 
(рис. 3.18), в которой 
перечислены все пе-
ременные и п
ры эле
занием схемы, к ко-
торой они относятся. 
Обратите внимание, в 
столбце Element ука-
зывается тип элемен-
та (в данном случае 
ёмкость или индук-
тивность), а в столбце 
ID (Идентификатор) 
указывается иденти-
фикатор (т.е. имя 
элемента) на схеме. 
Для переменных в 
столбце Schematic 
указывается имя схе-
мы, к которой отно-

сится данная переменная. 
2. В столбце Optimize отметьте переменные @lpf IND, @lpf CAP и параметр C для идентифика-

тора C2 элемента CAP, чтобы назначить их для оптимизации. Закройте окно переменных. 
ния. 

• В данном случае мы не накладываем никаких ограничений на значения переменных и па-
раметров элементов, изменяемых в процессе оптимизации. В тоже время на практике час-
то желательно ограничить пределы возможных изменений параметров, например, чтобы 
не получить нереализуемые значения размеров топологии. Чтобы ограничить пределы из-
менения значений переменных и пара

Рис. 3.18 

Замеча

(Ограничить). В столбце Lower (Нижний) введите нижний допустимый предел изменения 
параметра, а в столбце Upper (Верхний) введите верхний допустимый предел изменения 
параметра. Если этих столбцов нет в окне Variables, щёлкните правой кнопкой мышки по 
строке имён столбцов в верхней части окна и в открывшемся дополнительном окне от-
метьте Constrained, Low
полнительным окном для установки недостающих столбцов или для удаления ненужных 
столбцов. 

• Если щёлкнуть левой кнопкой мышки по нижней строчке More (Больше) в дополнитель-
ном окне, то дополнительно можно изменять ширину столбцов или менять порядок их 
расположения. Изменить порядок распо
тановите курсор на имя столбца, нажмите левую кнопку мышки и просто перетащите 
столбец на новое место. 

• Указанный способ назначен
Он удобен тем, что в одном диалогов
необходимые переменные и параметры элементов. Другой способ, в котором каждая пе-
ременная или параметры каждого элемента назначаются для оптимизации индивидуально, 
мы рассмотрим в следующем примере. 

• Окно Variables рис. 3.18 мож
значения переменных и параметров для настройки или для статистич
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диалоговое 

e (Предел), введите 500 

 Range, введите 500 в поле Stop, вве-

поле Min в области Range, введите 700 в поле Start, вве-
дите –30 в поле Goal и нажмите OK. 

осы пропускания, 700 MHz – это 

 желательное предельное значение коэффициента передачи S21 в полосе про-

желательное предельное значение коэффициента передачи S21 в полосе загражде-

направлении. Изменять цель 
при это

триховки у цели на графике указывает на недопустимые 

1. Откройте вкладку Project в левом окне проекта и откройте окно графика. 
2. Введите цель для коэффици-

ента отражения в полосе 
пропускания. Для этого 
щёлкните правой кнопкой 
мышки по Optimization 
Goals (Цели оптимизации) и 
выберите Add Optimizer 
Goal (Добавить цель опти-
мизации) во всплывающем 
меню. Откроется 
окно New Optimization Goal 
(Новая цель оптимизации), 
показанное на рис. 3.19. 

3. Выделите lpf:DB(|S[1,1]|) в 
окне списка измеряемых ве-
личин Measurement. От-
метьте Meas<Goal (Изме-
ряемая величина<Цель) в 
области Goal Type (Тип це-
ли), уберите “галочку” в 
квадратике Max в области 
Rang
в поле Stop, введите –17 в 

поле Goal (Цель), и нажмите OK. 
4. Введите цель для коэффициента передачи в полосе пропускания. Для этого повторите шаги 2 и 

3, но выделите lpf: DB(|S[2,1]|) в окне списка измеряемых величин, отметьте Meas>Goal в об-
ласти Goal Type, убер

Рис. 3.19 

ите “галочку” в поле Max в области
дите –1 в поле Goal и нажмите OK. 

5. Введите цель для коэффициента передачи в полосе заграждения. Для этого повторите шаги 2 и 
3 снова, но введите lpf: DB(|S[2,1]|) в окне списка измеряемых величин, отметьте Meas<Goal в 
поле Goal Type, уберите “галочку” в 

 
Примечание. Ведённые значения означают следующее: 

 500 MHz – это верхняя (максимальная) частота пол
нижняя (минимальная) частота полосы заграждения. 

 -17 – желательное предельное значение коэффициента отражения S11 в полосе пропус-
кания; -1 –
пускания. 

 -30 – 
ния. 

Цели оптимизации отображаются на 
графике в виде границ со штриховкой (см. рис. 
3.20) и могут быть изменены. Для изменения 
цели оптимизации щёлкните правой кнопкой 
мышки по имени цели в окне просмотра проек-
та и выберите Properties. Откроется диалого-
вое окно для изменения цели, аналогичное окну 
рис. 3.19, в котором можно изменить цель оп-
тимизации. Цель оптимизации можно изменить 
и непосредственно на графике. Чтобы изменить 
цели оптимизации непосредственно на графи-
ке, щёлкните по нужной цели левой кнопкой 
мышки. Затем поместите курсор на заштрихо-
ванный участок цели на графике (курсор ото-
бражается в виде перекрестия), или поместите 
курсор на квадратик в уголке цели (курсор ото-
бражается в виде двойной стрелки), нажмите 
левую кнопку мышки и, не отпуская её, дви-
гайте в нужном 

м можно как по величине параметра, 
так и по частоте. 

Обратите внимание, что направление ш
Рис. 3.20 

значения измеряемой величины. 
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3.1.16. 

Simu-

0

 

Save Project (Файл>Сохранить проект) или щёлкнув 
левой кнопкой мышки по значку Save Project

Оптимизация схемы. 
Чтобы выполнить оптимизацию: 

1. Выберите в меню 
late>Optimize (Моделирование > 
Оптимизация). Откроется диало-
говое окно Optimizer (рис. 3.21). 

2. Выберите метод оптимизации 
Random (Local) (Случайный (Ло-
кальный)) в области Optimization 
Methods (Методы оптимизации), 
щёлкая по стрелке в правом конце 
этого поля, наберите 500  в поле 
Maximum Iteration (Максимум 
итераций), и нажмите Start, чтобы 
начать оптимизацию. 

3. Когда оптимизация закончится, 
закройте диалоговое окно Opti-
mize. Результаты оптимизации
отображаются на графике и на 
схеме, как показано на рисунках 
3.22 и 3.23. 

В заключение вы можете, при же-
лании, сохранить вашу боту, выбрав в меню File>

Рис. 3.21 
ра

  на панели инструментов. 

Рис. 3.23 

Рис. 3.22 

3.2. Моделирование микрополоскового заграждающего фильтра 
3.2.1. Создание нового проекта. 

Для создания нового проекта сделайте следующее: 
1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалоговое 

окно Save As. 
3. Наберите имя проекта (например, Fil-z) и нажмите Сохранить. 

3.2.2. Создание схемы. 
Чтобы создать схему: 

1. Щёлкните по значку New Schematic  на панели инструментов. 
2. Наберите имя схемы, например, zfil и нажмите OK. 

3.2.3. Размещение элементов в схеме. 
1. Нажмите панель Elements в нижней части левого окна. 
2. Щёлкните по значку + слева от группы Microstrip (Микрополоска) в окне просмотра элемен-

тов. 
3. Щёлкните по подгруппе Lines (Линии) в окне просмотра элементов. 
4. Найдите модель MLIN, пользуясь полосой скроллинга, переместите её в окно схемы и зафик-

сируйте, щёлкнув левой кнопкой мышки. 
5. Щёлкните по подгруппе Junction (Соединения) в окне просмотра элементов. 
6. Найдите модель MTEE$, переместите её окно схемы, подсоедините к правому концу элемента 

MLIN и зафиксируйте, щёлкнув левой кнопкой мышки. 
7. Щёлкните по подгруппе Lines (Линии) в окне просмотра элементов. 



8. Найдите модель MLEF, переместите её окно схемы, щёлкните три раза правой кнопкой мыш-
ки, чтобы повернуть элемент, подсоедините его к плечу 3 элемента MTEE$ и зафиксируйте, 
щёлкнув левой кнопкой мышки. 

9. Нажмите клавишу Shift и, не отпуская её, щелкните по очереди по моделям MLIN (ID=TL1), 
MTEE$ (ID=TL2) и MLEF (ID=TL3), затем отпустите клавишу Shift. 

10. Щёлкните по значку Copy (Копировать) на панели инструментов. 
11. Щёлкните по значку Paste (Вставить)  на панели инструментов. 
12. Подключите скопированную группу к плечу 2 элемента MTEE$ (ID=TL2) и зафиксируйте её, 

щелкнув левой кнопкой мышки. 
13. Снова щёлкните по значку Paste на панели инструментов, подключите скопированную группу 

к плечу 2 элемента MTEE$ (ID=TL6) . и зафиксируйте её, щёлкнув левой кнопкой мышки. 
14. Щёлкните по подгруппе Lines (Линии) в окне просмотра элементов. 
15. Найдите модель MLIN, переместите её в окно схемы, подсоедините её к плечу 2 последнего 

элемента MTEE$ (ID=TL6) и зафиксируйте её, щёлкнув левой кнопкой мышки. 
3.2.4. Размещение портов. 

1. Щёлкните по значку Port  на панели инструментов. 
2. Поместите порт на левом конце первого элемента MLIN. 
3. Снова щёлкните по значку Port на панели инструментов. 
4. Поместите порт на правом конце последнего элемента MLIN, предварительно развернув его на 

180 градусов, щёлкая правой кнопкой мышки. 
3.2.5. Определение параметров подложки. 

1. Щёлкните по группе Substrates (Подложки) в окне просмотра элементов. 
2. Перетащите элемент MSUB в окно схемы, поместите его на свободном месте, например, ниже 

схемы. 
3. Дважды щёлкните по элементу MSUB в окне схемы. Откроется окно редактирования. Введите: 

• Er=10.44 – относительная диэлектрическая проницаемость; 
• H=0.5 – толщина подложки; 
• T=0.005 – толщина проводника; 
• Rho=1 – удельное сопротивление металла проводника, нормированное к золоту; 
• Tang=0.0001 – тангенс угла потерь; 
• ErNom=10.44 – номинальная диэлектрическая проницаемость; 
• Name=SUB1 – имя подложки. 

4. Нажмите OK. 
Замечание. Х-модели в проекте не используются, поэтому значение ErNom можно и не изменять. 
3.2.6. Добавление переменных. 

При настройке или оптимизации одинаковым образом должны изменяться параметры второго и 
третьего элементов MLIN (расстояний между шлейфами), а так же параметры первого и третьего эле-
ментов MLEF. Поэтому добавим в схему следующие переменные: 

1. Щёлкните левой кнопкой мышки по значку Equation  на панели инструментов. 
2. Переместите курсор в окно схемы и щёлкните левой кнопкой мышки на свободном месте выше 

схемы. В открывшееся  поле введите LL=3.5 (длина второго и третьего элементов MLIN) и 
щёлкните левой кнопкой мышки вне этого поля. 

3. Повторяя шаги 1 и 2, введите переменные WL=0.45 (ширина второго и третьего элементов 
MLIN), L1=3.5 и W1=0.45 (длина и ширина первого и третьего элементов MLEF). 

3.2.7. Редактирование параметров элементов. 
1. Дважды щёлкните по первому элементу MLIN. В открывшемся окне (рис. 3.24) введите 

W=0.45 mm (т.е. введите 0.45 в поле Value параметра W) и L=3 mm. Нажмите OK. Такие же 
значения параметров введите для последнего четвёртого элемента MLIN. 

2. Аналогично введите 
W=WL mm, L=LL mm 
для второго и третьего 
элементов MLIN. 

3. Дважды щёлкните по 
первому элементу MLEF. 
Введите W=W1 mm, 
L=L1 mm. Нажмите OK. 
Такие же значения пара-
метров введите для по-
следнего третьего эле-
мента MLEF. 

Рис. 3.24 

4. Аналогично введите W=0.45 mm, L=3.5 mm для второго элемента MLEF. 
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5. Полученная схема показана на рис. 3.25. 

Рис. 3.25

3.2.8. Задание частот для моделирования. 
1. Нажмите панель Project в нижней части левого окна, чтобы открыть окно просмотра проекта. 
2. Дважды щёлкните по группе Project Options (Опции проекта). Откроется диалоговое окно 

Project Options. 
3. Щёлкните левой кнопкой мышки по Frequencies (Частоты), чтобы открыть эту вкладку, если 

она не открыта. 
4. Наберите 4 в поле Start (Начальная частота), 12 в поле Stop (Конечная частота) и 0.25 поле 

Step (Шаг), отметьте Replace (Заменять), отметьте Linear (Линейная). Нажмите Apply (При-
менить). В окне Current Range (Текущий диапазон) отображается частотный диапазон и шаг 
по частоте. Нажмите OK. 

3.2.9. Создание графика и добавление измеряемых величин. 
1. Щёлкните по значку Add New Graph  на панели инструментов. 
2. Введите имя графика, например Graph 1, выберите тип графика Rectangular (Прямоугольный) 

и нажмите OK. 
3. Щёлкните правой кнопкой мышки по подгруппе Graph 1 в окне просмотра проекта и выберите 

Add Measurement. 
4. Выберите Port Parameter в списке Measurement Type, S в списке Measurement, zfil в поле 

Data Source Name, 2 в поле To Port Index (Индекс входного порта), 1 в поле From Port Index 
(Индекс выходного порта), нажимая на стрелки справа от этих полей. В области Complex 
Modifier (Модификатор комплексного числа) отметьте Mag и dB, нажмите Apply и затем OK. 

3.2.10. Анализ схемы. 
1. Щёлкните левой кнопкой мышки по значку Analyze  на панели инструментов.  
2. Щёлкните правой кнопкой мышки по полученному графику и выберите Properties. Откроется 

диалоговое окно свойств графика (рис. 3.26). 
На вкладке Axes этого окна в области Choose axis (Выбрать ось) отметьте ось x. В области Divisions (Де-
ления) снимите “галочку” в Auto divs и в поле Step (Шаг) введите 0.5. Это будет шаг по оси частот. На-
жмите Apply и OK. Результаты анализа отображаются на графике рис. 3.27. 

Рис. 3.26 Рис. 3.27 
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3.2.11. Назначение переменных и параметров для оптимизации. 
Здесь мы рассмотрим другой способ назначения переменных и параметров, отличный от спосо-

ба, описанного в предыдущем примере. 
1. Откройте окно схемы. Щёлкните пра-

вой кнопкой мышки по переменной 
LL=3.5 и выберите Properties. Откро-
ется окно редактирования переменной 
Edit Equation (рис. 3.28). В поле Vari-
able Name отображается имя перемен-
ной, а в поле Variable Value отобра-
жается значение этой переменной. При 
желании здесь вы можете изменить 
имя переменной и её значение. В об-
ласти Tuning/Optimization Mode (ре-
жим настройки/оптимизации) отметьте 
Optimize. На вариации значений дли-
ны мы не будем накладывать ограни-
чений, поэтому не отмечайте Con-
strain (Ограничить). Нажмите OK. 

Рис. 3.28 
2. Аналогично с такими же параметрами 

назначьте для оптимизации перемен-
ную L1=3.5. 

3. Щёлкните правой кнопкой мышки по 
переменной WL=0.45 и выберите 
Properties. В открывшемся окне (рис. 
3.29) отметьте Optimize. Здесь мы ог-
раничим ширину полоски, поэтому 
отметьте Constrain. В поле Upper 
bound (Верхняя граница) введите 1, а 
в поле Lower bound (Нижняя грани-
ца) введите 0.1. Нажмите OK. 

4. Аналогично с такими же параметрами 
назначьте для оптимизации перемен-
ную W1=0.45. 

5. Дважды щёлкните по второму эле-
менту MLEF, или щёлкните по нему 
правой кнопкой мышеи и выберите 
Properties. Откроется диалоговое ок-
но свойств элемента (рис. 3.30). Для 
параметра W отметьте столбцы Opt и 
Limit (Предел). В столбце Lower 
(Нижний) введите 0.1, а в столбце 
Upper (Верхний) введите 1. Значение 
длины мы ограничивать не будем, по-
этому для параметра L отметьте толь-
ко столбец Opt. Нажмите OK. 

Рис. 3.29 

Рис. 3.30 
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3.2.12. Установка целей оптимизации. 
1. Откройте окно графика. Уста-

новите цель оптимизации в 
полосе заграждения. Щёлкни-
те правой кнопкой мышки по 
Optimizer Goals в левом окне 
проекта и выберите Add 
Optimizer Goal. В открыв-
шемся окне рис. 3.31 в облас-
ти Goal Type отметьте 
Meas<Goal, в области Range 
(диапазон) снимите “галочки” 
в квадратиках Min и Max. В 
поле Start введите 7.5, в поле 
Stop введите 8.5. В поле Goal 
start в нижней части окна 
введите -50. Нажмите OK. 

Рис. 3.31 
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. Снова щёлкните правой кнопкой 

овите цель оптимизации в верхней полосе пропускания. Снова щёлкните правой кнопкой 

вленные цели будут отображены как подгруппы в группе Optimizer Goals в левом окне 
просмот

зации. 
 

выберит

т ь

2. Установите цель оптимизации в нижней полосе пропускания
мышки по Optimizer Goals в левом окне проекта и выберите Add Optimizer Goal. В открыв-
шемся окне в области Goal Type отметьте Meas>Goal, в области Range (диапазон) снимите 
“галочку” в квадратике Max. и в поле Stop введите 5.5. В поле Goal start введите -1. Нажмите 
OK. 

3. Устан
мышки по Optimizer Goals в левом окне проекта и выберите Add Optimizer Goal. В открыв-
шемся окне в области Goal Type отметьте Meas>Goal, в области Range (диапазон) снимите 
“галочку” в квадратике Min, в поле Start введите 10 и в поле Goal start введите -1. Нажмите 
OK. 

Устано
ра проекта и на графике. 

3.2.13. Выполнение оптими
Чтобы выполнить оптимизацию
е в меню Simulate>Optimize. От-

кроется диалоговое окно Optimizer (рис. 
3.32). В этом окне в области Optimization 
Methods выберите метод оптимизации 
Pointer - Robust Optimization, щёлкая по 
кнопке в правом конце этого поля ввода. В 
поле ввода Maximum Iterations введите 
максимальное количество итераций 500. В 
окне Relative Goal Cost (Относительная 
стоимость цели) указывается в виде гисто-
граммы относительная значимость цели, 
т.е. насколько далека поставленная цель от 
имеющегося значения характеристики. В 
нашем случае наибольшую значимость 
имеет в орая цель, т.е. наибол шее откло-
нение от заданной величины ослабления 
имеется в верхней полосе пропускания, а 

наименьшую значимость имеет третья цель, т.е. ближе всего к заданному значению ослабления характе-
ристика имеет в нижней полосе пропускания. Это можно видеть и на графике фильтра. При желании 
значимость целей можно уровнять, щёлкнув левой кнопкой мышки по кнопке Equalize Goals (Выров-
нять цели) в окне, это приведёт к выравниванию столбцов гистограммы и изменению веса каждой цели 
так, чтобы изменение параметров вносили одинаковый вклад в изменение целевой функции. В процессе 
оптимизации высота столбцов гистограммы будет изменяться. 

Рис. 3.32 

В окне Cost History (Хронология значимости) отображается график изменения целевой функции 
в зависимости от выполненного количества итераций. 

Ниже указанных областей в процессе оптимизации выводятся выполненное количество итераций 
анализа (Simulator Iter) и оптимизации (Optimizer Iter), а так же значение целевой функции (Cost), 
которое при отимизации должно стремитья к нулю. 

Если установить «галочку» в квадратике Show all iteration (Показывать все итерации), то на 
графике будут отображаться (мелькать) характеристики каждой итерации. 

Чтобы начать выполнение оптимизации, щёлкните левой кнопкой мышки по кнопке Start в окне. 
График, полученный после оптимизации показан на рис. 3.33, а новые значения переменных и 
параметров элемента MLEF на рис. 3.34. 

Рис. 3.34 

Рис. 3.33 



3.2.14. Вывод результатов в файл. 
1. Щёлкните правой кнопкой мышки по группе Output Files (Выходные файлы). 
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OK. Откроется новое окно рис. 3.36. 

ype (Тип данных). Выберите Mag/Ang в области For-

ой находится файл моделируе-

начку Analyze на панели инструментов. 

 
Щёлкните левой кнопкой 

 Lay-

2. Выберите Add Output File (Добавить выходной файл), откроется окно New Output File (рис. 
3.35), в котором нужно выбрать тип выходного файла. Отметьте Port Parameter и нажмите 

3. Выберите S Parameter в области Data T

Рис. 3.35 
Рис. 3.36

mat. В поле Select Data Source (Выберите источник данных) отметьте имя схемы (если в про-
екте их несколько), график которой вы хотите вывести в файл. 

4. По умолчанию файл результатов будет создан в папке, в котор
мого проекта. При желании вы можете сохранить этот файл в любой другой папке или изме-
нить имя файла, предлагаемое по умолчанию, щёлкнув левой кнопкой мышки по Set file 
name…(Установить имя файла…). 

5. Нажмите OK и затем щёлкните по з
3.2.15. Создание топологии схемы. 

1. ткройте окно схемы. 
2. 

О

мышки по значку View
out (Показать топологию) 

 на панели инструментов, 
чтобы открыть окно тополо-
гии на рабочем поле. В этом 
окне будут отображены все 
элементы топологии, соот-
ветствующие каждому эле-
менту схемы. Однако распо-
ложение топологических 

элементов может быть беспорядочным, как, например, показано на рис. 3.37. Как правильно 
должны соединяться элементы топологии на этом рисунке показывают красные линии. 

3. Установите курсор мышки левее и выше топологии, нажмите левую кнопку мышки и, не от-
пуская кнопки, 

Рис. 3.37 

переместите 
курсор правее и ниже топо-
логии, чтобы выделить все 
элементы топологии, отпус-
тите кнопку. Или в меню 
выберите Edit>Select All. 

4. Щёлкните по значку Snap 
Together (Привязать вместе) 

 на панели инструментов 
или выберите в меню 
Edit>Snap Together. Распо-

 очень простая и состоит только из проводников, расположенных на 
ь все опции экспорта топологии по умолчанию. Выберите в 

ложение элементов тополо-
гии будет упорядочено и топология будет иметь вид, показанный на рис. 3.38. 

3.2.16. Экспорт топологии в файл. 
В данном случае топология

Рис. 3.38 

одном уровне. Поэтому можно использоват
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меню L

Save Project

ayout>Export. Откроется диалоговое окно Export Layout. В этом окне выберите папку, в кото-
рой вы хотите сохранить файл топологии, и введите имя файла или согласитесь с предлагаемым по 
умолчанию. В поле Тип файла выберите тип файла, в котором вы сохраняете топологию, например, 
DXF[DXF Flat,*.dxf]. Щёлкните мышкой по кнопке Сохранить. В AutoCAD сохранённая топология 
будет иметь вид, показанный на рис. 3.39. 

Сохранённая топология состоит из отдельных соприкасающихся топологических элементов, в 
данном случае прямоугольников. В некот

Рис. 3.39 Рис. 3.40 

орых случаях удобнее соприкасающиеся топологические эле-
менты объединить (например, для некоторых типов координатографов). Это можно сделать при экспорте 
топологии, установив соответствующую опцию экспорта. Выберите в меню Options>Layout Options. На 
вкладке Export/LPF открывшегося окна отметьте Union layout shapes (Объединить формы топологии) и 
нажмите OK. Повторите экспорт топологии. Теперь в AutoCAD сохранённая топология будет иметь вид, 
показанный на рис. 3.40. 

При желании можно сохранить проект, выбрав в меню File>Save Project (Файл>Сохранить про-
ект) или щёлкнув левой кнопкой мышки по значку   на панели инструментов. 

3.3. Моделирование микрополоскового аттенюатора на резисторах 

New Project (Файл>Новый проект). 
как) в. Откроется 

3.3.2. Созд
ентов. 

 atr20 и нажмите OK. 

rostrip в окне просмотра элементов. 
. 

мы и зафик-

но схемы, отпустите кнопку мышки, подключите мо-
ышки. 

урсор в окно схемы, подключите скопированные элементы к правому выводу 

к правому выводу 
ы зафиксировать их. 

е её к правому выводу по-

 конце первого элемента MLIN. 
тов. 

IN, предварительно развернув его на 

ому проводнику ID=TL1. Откроется диалого-

3.3.1. Создание нового проекта. 
Сначала нужно создать новый проект. Для его создания сделайте следующее: 

1. Выберите в меню File>
2. Выберите в меню File>Save Project As (Файл>Сохранить проект 

диалоговое окно Save As. 
3. Наберите имя проекта At20 и нажмите Сохранить. 

ание схемы. 
1. Щёлкните по значку Add New Schematic  на панели инструм
2. Наберите имя схемы
3. Нажмите панель Elements в нижней части левого окна. 
4. Щёлкните по значку + слева от группы Mic
5. Щёлкните по подгруппе Lines в окне просмотра элементов
6. Найдите модель MLIN, пользуясь полосой скроллинга, переместите её в окно схе

сируйте, щёлкнув левой кнопкой мышки. 
7. Щёлкните по подгруппе Components (Компоненты) в окне просмотра элементов. 
8. Найдите модель TFR, переместите её в ок

дель к правому выводу элемента MLIN и зафиксируйте, щёлкнув левой кнопкой м
9. Нажмите клавишу Shift и, не отпуская её, щёлкните левой кнопкой мышки по элементам 

MLIN и TFR. 
10. Щелкните по значку Copy и затем по значку Paste на панели инструментов. 
11. Переместите к

элемента TFR и щёлкните левой кнопкой мышки, чтобы зафиксировать их. 
12. Щелкните по значку Paste на панели инструментов. 
13. Переместите курсор в окно схемы, подключите скопированные элементы 

элемента TFR и щёлкните левой кнопкой мышки, чтоб
14. Повторите п. 12 и 13, чтобы подключить ещё одну пару элементов. 
15. Щёлкните по подгруппе Lines в окне просмотра элементов. 
16. Найдите модель MLIN, переместите её в окно схемы и подключит

следнего элемента TFR. 
17. Щелкните по значку View All на панели инструментов, чтобы видеть всю схему. 

3.3.3. Размещение портов. 
1. Щёлкните по значку Port  на панели инструментов. 
2. Поместите порт на левом
3. Снова щёлкните по значку Port на панели инструмен
4. Поместите порт на правом конце последнего элемента ML

180 градусов, щёлкая правой кнопкой мышки. 
3.3.4. Редактирование параметров элементов. 

Дважды щёлкните левой кнопкой мышки по пе1. рв
вое окно Element Options. 
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етры введите для последнего проводника ID=TL9. 
орому проводнику ID=TL3 и в открывшемся 

проводнику ID=TL5 и в открывшемся 

 ID=TL6 введите параметры W=0.4, 

Substrates мотра элементов. 
оместите его на свободном месте, например, ниже 

r=10.55 – относительная диэлектрическая проницаемость; 

ние металла проводника, нормированное к золоту; 
ь. 

ются. 

3.3.6. З
1.  левого окна, чтобы открыть окно просмотра проекта. 

s. Откроется диалоговое окно Project Options. 

На-
Current Range  отображается частотный диапазон и шаг по частоте. На-

о значку Add New Graph на панели инструментов. 

о под-

eas. 

2. Введите W=0.456 mm, L=5 mm и нажмите OK. 
3. Аналогично такие же парам
4. Дважды щёлкните левой кнопкой мышки по вт

окне введите W=1.009 mm, L=2.022 mm, нажмите OK. 
5. Аналогично такие же параметры введите для предпоследнего проводника ID=TL7. 
6. Дважды щёлкните левой кнопкой мышки по среднему 

окне введите W=1.883 mm, L=1,953 mm, нажмите OK. 
7. Дважды щёлкните левой кнопкой мышки по первому резистору ID=TL2 и в открывшемся окне 

введите W=0.4 mm, L=0.545 mm, RS=50, нажмите OK. 
8. Аналогично такие же параметры введите для последнего резистора ID=TL8. 
9. Аналогично для двух средних резисторов ID=TL4 и

L=0.215, PS=50. 
3.3.5. Определение параметров подложки. 

Щёлкните по груп1. пе  в окне прос
2. Перетащите элемент MSUB в окно схемы, п

схемы. 
3. Дважды щёлкните по элементу MSUB в окне схемы. Откроется окно редактирования. Введите: 

 E
 H=0.5 – толщина подложки; 
 T=0.005 – толщина проводника; 
 Rho=1 – удельное сопротивле
 Tang=0.0001 – тангенс угла потер

Заметим, что значение ErNom изменять не обязательно, т.к. Х-модели в схеме не использу
Полученная схема показана на рис. 3.41. 

Рис. 3.41

адание частот для моделирования. 
 Нажмите панель Project в нижней части

2. Дважды щёлкните по группе Project Option
3. Нажмите Freqencies. 
4. Наберите 4 в поле Start, 18 в поле Stop  и 1 поле Step, отметьте Replace, отметьте Linear. 

жмите Apply. В окне 
жмите OK. 

3.3.7. Создание графика, добавление измеряемых величин и анализ схемы. 
1. Щёлкните п

2. Отметьте Rectangular и нажмите OK. 
3. Щёлкните правой кнопкой мышки п

группе Graph 1 в окне просмотра проекта 
и выберите Add Measurement. 

4. Выберите Port Parameter в списке M
Type, S в списке Measurement, atr20 в по-
ле Data Source Name, введите 1 в полях 
To Port Index, и From Port Index, нажи-
мая на стрелки, справа от этих полей, от-
метьте dB и Mag в области Complex 
Modifier, нажмите Apply. 

5. Введите 2 в поле To Port Index и нажмите 
Apply и нажмите OK. 

6. Щёлкните левой кнопкой мышки по знач-
ку Analyze на панели инструментов. Ре-
зультаты анализа отображаются на графи-
ке рис.3.42. Рис. 3.42 
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гут быть определены при анализе схе-
t. Для линейных схем обычно в каче-

стве вы

 для их определения. Делается это следующим образом. 

 
вводом 

: |S[1,1]|, где atr20 – имя схемы. 

Такая з авлен в соответствие модуль элемента S[1,1] 
матрицы т.е. переменной S11 присваивается значение элемента S[1,1]. При этом может быть присвоено 
комплек

S12= atr20:S[1,2] 

 
Заметим ременные являются комплексными числами. Затем необходимо опре-

делить эффициент отражения от нагрузки, т.е. присвоить значение коэффициента отражения некото-
рой пер

Затем за е для определения коэффициента отражения по входу схемы: 

И, нако stU: 

Переме  для построения графика, вывода в виде таблицы или в 
файл. 

операторах и функциях, которые можно использовать в уравнениях, см. Руководство пользователя Mi-
crowave

жды щёлкните левой кнопкой 

ле откроется окно уравнений 

Measurement 

3.3.8. Создание выходных параметров и уравнений. 
писок выходных параметров по умолчанС ию, которые мо

мы, перечислены в области Measurement в окне Add Measuremen
ходных параметров выбирают S-параметры схемы. Но иногда бывает удобнее определить не эле-

менты S-матрицы, а другие параметры. 
В Microwave Office имеется возможность добавить к имеющимся по умолчанию выходным па-

раметрам другие параметры и уравнения
Определяется какая-либо переменная и ставится в соответствие одному из выходных параметров 

схемы, определяемому в процессе анализа, например, какому-либо элементу S-матрицы. Это делается
выражения типа: 
 

S11=atr20
 

апись означает, что переменной S11 пост
, 
сное значение, или только его действительная часть, или только мнимая, или модуль. Опреде-

лённую новую переменную S11 уже можно использовать в любом уравнении. Использовать непосредст-
венно значение S[1,1] в уравнениях нельзя, т.к. это значение не связано ни с какой переменной. Напри-
мер, чтобы определить и построить график KstU при работе схемы на несогласованную нагрузку, нужно 
определить следующие переменные: 

 
S11= atr20:S[1,1] 

S21= atr20:S[2,1] 
S22= atr20:S[2,2] 

, что здесь все пе
ко
еменной, например 

Gn=0.01+j*0.05 
 

писать уравнени
 

G=S11+S12*S21*Gn/(1-S22*Gn) 
 

нец, уравнение для определения K
 

KstU=(1+abs(G))/(1-abs(G)) 
 

нную KstU можно использовать

Примечание. Более подробно о переменных и уравнениях, а так же о синтаксисе уравнений, об 

 Office 2009. 
В этом примере мы рассмотрим оп-

ределение KstU и Ldb для схемы аттенюа-
тора atr20 при работе на согласованную на-
грузку. 

1. Два
мышки по группе Output Equa-
tions (Выходные уравнения) в ок-
не просмотра проекта. На рабочем 
по
Output Equations. 

2. Выберите в меню Draw>Add 
Output Equation или щёлкните по 
значку Output Equation на пане-
ли инструментов. Откроется диа-
логовое окно Add 
Equation, показанное на рис. 3.43. 
В текстовом поле Variable name 
(Имя переменной) введите S11. В 
области Measurement Type от-
метьте Port Parameters, в области 

Рис. 3.43 



Measurement отметьте S. В поле Data Source Name введите atr20, введите 1 в оба поля To 
Port Index и From Port Index, установите “галочку” в Mag в области Complex Modifier, сни-
мите “галочку” в DB, если она установлена, нажмите OK. В окне уравнений появится поле 
ввода. Двигая мышку, установите это поле в верхней части окна уравнений и щёлкните левой 
кнопкой мышки, чтобы закрепить. Появится выражение 

 
S11=atr20:|S[1,1]| 
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Это означает, что поставлен в соответствие модуль элемента S-матрицы S[1,1]. 
Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами выражения для S11. 

Щёлкни ки в любом месте окна уравнений за пределами выраже-
ния для S21. 

 
 переменной S11 

3. Снова выберите в меню Draw>Add Output Equation. В открывшемся окне в текстовом поле 
Variable name введите S21, в области Measurement Type отметьте Port Parameters, в области 
Measurement отметьте S, в поле Data Source Name введите atr20, введите 2 в поле To Port In-
dex и 1 в поле From Port Index, щёлкая по кнопкам справа от этих полей, установите “галоч-
ку” в Mag в области Complex Modifier, снимите “галочку” в DB, если она установлена, на-
жмите OK. В окне уравнений появится поле ввода. Двигая мышку, установите это поле ниже 
предыдущего уравнения и щёлкните левой кнопкой мышки. Появится выражение 

 
S21=atr20: |S[2,1]| 

 
те левой кнопкой мыш

4. Выберите в меню Draw>Add Equation или щёлкните левой кнопкой мышки по значку Equa-
tion  на панели инструментов. 

5. Переместите курсор в окно уравнений. В этом окне появится поле ввода. Установите его, дви-
гая мышкой, ниже предыдущего уравнения и щёлкните левой кнопкой мышки, чтобы зафикси-

кой мышки вне этого поля или нажмите 
лавишу Enter. 

7.
 инструментов и поместите новое поле ниже предыду-

и щёлкните левой кнопкой мышки вне этого поля или нажмите клавишу Enter. 
Окончательный вид уравнений в окне показан на рис. 3.44. 

3.3.9. Создание графика, добавление измеряемых величин и анализ. 
1. Щёлкните по значку 

h на па-
. 

те имя графика 

смотра проекта 

urement 

ровать. 
6. Введите в поле вода уравнение: 

 
KstU=(1+S11)/(1-S11) 

 
и щёлкните левой кноп

к
 Снова щёлкните левой кнопкой мышки по значку Equation на 
панели
щих уравнений. 

8. Введите в поле вода уравнение: 
 Рис. 3.44            Ldb=20*log10(1/S21) 

 

Add New Grap
нели инструментов

2. Введи
Graph 2, выберите Rec-
tangular и нажмите 
OK. 

3. Щёлкните правой 
кнопкой мышки по 
подгруппе Graph 2 в 
окне про
и выберите Add Meas-
urement. 

4. В открывшемся окне 
(рис. 3.45) выберите 
Output Equations в об-
ласти Meas
Type. В поле ввода 
Equation Name выбе-
рите KstU, щёлкнув по 
кнопке справа. Отметь-Рис. 3.45 
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 Apply. 

 мышки по 
 на панели инструмен-

 

 2-х диодного аттенюатора 

ect As. Сохраните проект под именем Atr. 
ентной схемы диода. 

тов (Lumped Element), щёлкнув по значку + слева 

ображения доступных конденсаторов. 

осмотра элементов. В нижней части окна 

ки, чтобы зафиксировать начало провода, перетащите 

ереместите курсор в 
ки, чтобы зафикси-

о схемы, два раза щёлкните правой кнопкой мышки, чтобы развернуть порт, помес-

тащите 

етров элементов в эквивалентной схеме диода. 
ементу CAP (конденсатор) в окне схемы. Откро-

. 

рованная эквивалентная схема диода показана 

 взяты для диода 2А553В-3. 

те переключатель Mag в области 
Complex Modifier. Уберите “галочку” 
в DB, если она установлена. Нажмите 
Apply. 

5. В поле ввода Equation Name выбери-
те Ldb и нажмите

6. Нажмите OK. 
7. Щёлкните левой кнопкой

значку Analyze
тов. Результаты анализа отображают-
ся на графике рис. 3.46. 

 
 

Рис. 3.46  

3.4. Моделирование микрополоскового
3.4.1. Создание нового проекта. 

1. Выберите в меню File>New Project. 
2. Выберите в меню File>Save Proj

3.4.2. Создание упрощенной эквивал
1. Щёлкните по значку Add New Schematic на панели инструментов. 
2. Наберите имя схемы Diode и нажмите OK. 
3. Нажмите панель Elements в нижней части левого окна. 
4. Разверните группу сосредоточенных элемен

от этой группы. 
5. Щёлкните по подгруппе Конденсаторы (Capacitor) в окне просмотра элементов. В нижней части 

окна появятся из
6. Нажмите на модель конденсатора CAP и перетащите её в окно схемы. 
7. Щёлкните по подгруппе Резисторы (Resistor) в окне пр

появятся изображения доступных резисторов. 
8. Нажмите на модель резистора RES и, не отпуская кнопки мышки, перетащите её в окно схемы, 

поместите резистор ниже конденсатора. 
9. Поместите курсор возле левой клеммы конденсатора так, чтобы курсор отображался в виде со-

леноида. Щёлкните левой кнопкой мыш
курсор к левой клемме резистора, и снова щёлкните левой кнопкой мышки. 

10. Аналогично соедините проводом правые клеммы конденсатора и резистора. 
11. Щёлкните левой кнопкой мышки по значку Port на панели инструментов. П

окно схемы, поместите порт слева от схемы и щёлкните левой кнопкой мыш
ровать его. 

12. Снова щёлкните левой кнопкой мышки по значку Port на панели инструментов. Переместите 
курсор в окн
тите порт справа от схемы и щёлкните левой кнопкой мышки, чтобы зафиксировать его. 

13. Поместите курсор на клемму первого порта PORT P=1 так, чтобы курсор отображался в виде 
соленоида. Щёлкните левой кнопкой мышки, чтобы зафиксировать начало провода, пере
курсор к проводу, соединяющему конденсатор и резистор, и щёлкните левой кнопкой мышки, 
чтобы зафиксировать его. 

14. Аналогично подключите к схеме второй порт.  
3.4.3. Редактирование парам

1. Дважды щёлкните левой кнопкой мышки по эл
ется диалоговое окно Element Options. 

2. В текстовое поле Value значения ёмкости (C), введите 
0.025 pF и нажмите OK. Изменение будет отражено на 
схеме. 

3. Дважды щёлкните левой кнопкой мышки по элементу 
RES  в окне схемы. Откроется диалоговое окно Element 
Options

4. В текстовое поле Value значения резистора (R), введите 
0.6 Ohm и нажмите OK. 

5. Отредакти
на рис. 3.47. 
Примечание. Параметры

Рис. 3.47  
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ы аттенюатора. 
1. струментов. 

. 
е по значку + слева от группы Microstrip  

ой скроллинга, переместите её в окно схемы и зафикси-

а элементов. 

жмите клавишу Shift и щёлкните по элементу SUBCKT 

овать 

ированные элементы к правому узлу схе-

кните по значку Copy и по значку Paste на панели ин-

местите курсор в окно схемы и подсоедините скопированный элемент к правому узлу схе-

ументов. Переместите курсор в 

ировать его. 

й узел схемы и щёлкните левой кнопкой мышки, чтобы зафиксировать его. 

. 

0.46 mm (т.е. введите 0.46 в поле Value параметра W), L=3 и нажмите OK. 
 MSUB так, чтобы 

Откроется диалоговое окно Project Options. 

. Нажмите Apply. В области Current Range отображается частотный 

ний Output Equations. 
ументов. Откроется диалоговое окно 

 S, в поле Data Source Name 

3.4.4. Создание схем
Щёлкните по значку Add New Schematic на панели ин

2. аберите имя схемы At и нажмите OK
3. В окне просмотра элементов щёлкнит

Н

4. Щёлкните по подгруппе Lines в окне просмотра элементов. 
5. Найдите модель MLIN, пользуясь полос

руйте, щёлкнув левой кнопкой мышки. 
6. Щёлкните по группе Subcircuits (Подсхемы) в окне просмотр
7. Переместите подсхему Diode в окно схемы и соедините её с правым узлом отрезка линии. 
8. Щёлкните по элементу MLIN, затем на

(т.е. по подсхеме), чтобы выделить оба этих элемента. 
9. Щёлкните по значку Copy и затем по значку Paste на панели инструментов, чтобы скопир

и вставить оба выделенных элемента. 
10. Переместите курсор в окно схемы и подсоедините скоп

мы. 
11. Щёлкните по элементу MLIN, затем щёл

струментов, чтобы скопировать и вставить выделенный элемент. 
12. Пере

мы. 
13. Щёлкните левой кнопкой мышки по значку Port на панели инстр

окно схемы, поместите порт на левый узел схемы и щёлкните левой кнопкой мышки, чтобы за-
фикс

14. Снова щёлкните левой кнопкой мышки по значку Port на панели инструментов. Переместите 
курсор в окно схемы, два раза щёлкните правой кнопкой мышки, чтобы развернуть порт, помес-
тите порт на правы

15. Щёлкните по группе Substrates (Подложки) в окне просмотра элементов. 
16. Перетащите элемент MSUB в окно схемы, поместите его на свободном месте, например, ниже 

схемы. 
3.4.5. Редактирование параметров элементов в схеме аттенюатора

1. Дважды щёлкните левой кнопкой мышки по первому элементу MLIN. В открывшемся окне вве-
дите W=

2. Аналогично отредактируйте параметры всех элементов MLIN и подложки
значения их параметров соответствовали значениям, указанным на схеме рис. 3.48. 

3.4.6. Задание частот для моделирования. 

Рис. 3.48 

1. Щёлкните левой кнопкой мышки по панели Project в нижней части левого окна, чтобы открыть 
окно просмотра проекта. 

2. Дважды щёлкните по группе Project Options. 
3. На вкладке Frequencies. Введите 8 в поле Start, 12 в поле Stop и 0.5 поле Step, отметьте 

Replace, отметьте Linear
диапазон и шаг по частоте. Нажмите OK. 

3.4.7. Создание выходных параметров и уравнений. 
1. Дважды щёлкните левой кнопкой мышки по группе Output Equations  в окне просмотра проек-

та. На рабочем поле откроется окно уравне
2. Щёлкните по кнопке Output Equation на панели инстр

Measurements Equation. В текстовом поле Variable name  введите S11, в списке Measurement 
Type отметьте Port Parameters, в списке Measurement отметьте
введите At, введите 1 в оба поля To Port Index и From Port Index, щёлкая по кнопкам справа от 
этих полей, отметьте Mag в области Complex Modifier, снимите “галочку” в dB, если она уста-



новлена, нажмите OK. В окне уравнений появится поле ввода. Двигая мышку, установите это 
поле в верхней части окна уравнений и щёлкните левой кнопкой мышки. Появится выражение 

 
S11=At: |S[1,1]| 
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Это означае ой S11 поставлен в соответствие модуль элемента S-матрицы S[1,1]. 
Щёлкните левой кнопкой мышки в любом месте окна уравнений за пределами выражения для S11. 

-

Щёлкни й мышки в любом месте окна уравнений за пределами выражения для 
S21. 
4. 

а панели инструментов. 

его уравнения и щёлкните левой кнопкой мышки, чтобы зафиксиро-

пкой мышки вне этого поля или нажмите клавишу 
nter. 

инструментов и поместите новое поле ниже предыдущих уравнений. 

stU=(1+S11)/(1-S11) 

и щёлкните левой кнопкой мышки вне этого поля или нажмите клавишу 
E

Окончательный вид окна уравнений показан на рис. 3.49. 
3.4.8. Создан яемых 
велич

 инструментов. Результаты анали-

 
т, что переменн

3. Снова щёлкните по кнопке Output Equation на панели инструментов. В открывшемся окне в 
текстовом поле Variable name введите S21. В списке Measurement Type отметьте Port Parame
ters, в списке Measurement отметьте S. В поле Data Source Name введите At, введите 2 в поле 
To Port Index и 1 в поле From Port Index, отметьте Mag в области Complex Modifier, снимите 
“галочку” в dB, если она установлена, щёлкните OK. В окне уравнений появится поле ввода. 
Двигая мышку, установите это поле ниже предыдущего уравнения и щёлкните левой кнопкой 
мышки. Появится выражение 

 
S21=At: |S[2,1]| 

 
те левой кнопко

Выберите в меню Draw>Add Equation или щёлкните левой кнопкой мышки по значку Equation 
н

5. Переместите курсор в окно уравнений. В этом окне появится поле ввода. Установите его, двигая 
мышкой, ниже предыдущ
вать. 

6. Введите в поле вода уравнение: 
 

Ldb=20*log10(1/S21) 
 

и щёлкните левой кно
E

7. Снова щёлкните левой кнопкой мышки по значку Equation на панели 

8. Введите в поле вода уравнение: 
 

                    K
 

Рис. 3.49 
nter. 

ие графика вносимого ослабления и KstU, добавление измер
ин и выполнение анализа. 

1. Щёлкните по значку Add New 
Graph на панели инструментов. 

2. Введите имя графика Loss, от-
метьте Rectangular  и нажмите 
OK. 

3. Щёлкните правой кнопкой мыш-
ки по подгруппе Loss в окне про-
смотра проекта и выберите Add 
Measurement. 

4. Выберите Output Equations в 
списке Measurement Type. В ок-
не списка Measurement отметьте 
Eqn. В поле ввода Equation 
Name выберите KstU, щёлкнув 
по кнопке справа от этого поля. 
Отметьте переключатель Mag в 
области Complex Modifier. Убе-
рите “галочку” в DB, если она 
установлена. Нажмите Apply. 

5. В поле ввода Equation Name выберите Ldb и нажмите Apply. 
6. Нажмите OK. 

Рис. 3.49 

7. Щёлкните левой кнопкой мышки по значку Analyze на панели
 на графике рис. 3.49. за отображаются
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чтобы сделать активным окно 

uit. Или щёлкните один раз по этому элементу и затем щёлкните по значку Edit 

3.4.9. Редактирование подсхемы и настройка аттенюатора. 
Дважды щёлкните по имени схемы At 1. в окне просмотра проекта, 
этой схемы. 

2. Щёлкните правой кнопкой мышки по первому элементу подсхемы SUBCKT ID=S1 и выберите 
Edit Subcirc
Subcircuit  на панели инструментов. Откроется окно с копией схемы диода, в котором можно 
редактировать эту схему. 

3. Щёлкните по значку Tune Tool 
 (Инструмент настройки) на 

панели инструментов. 
Поместите курсор на пара4. метр R 
резистора. Курсор должен ото-
бражаться в виде белого пере-
крестия в чёрном кружке. 

ся си-

значку Exit Subcir-

5. Щёлкните левой кнопкой мыш-
ки, чтобы активизировать пара-
метр R для настройки. Этот па-
раметр будет отображать
ним цветом. 

6. Щёлкните правой кнопкой мыш-
ки в окне с копией схемы диода 
и выберите Exit Subcircuit или 
щёлкните по 
cuit на панели инструментов, 

чтобы закрыть это окно и вернуться к окну схемы аттенюатор. 
7. Щёлкните по значку Tune Tool на панели инструментов. 

Рис. 3.50 

8. Поместите курсор на параметр L (длина отрезка) среднего отрезка линии MLIN ID=TL2 и 

чтобы сделать его активным. 
щёлкните левой кнопкой мышки. 

9. Щёлкните левой кнопкой мышки по окну графика Loss, 
 на панели инструментов. Откроется Variable Tuner10. Щёлкните по значку Tune  (Блок на-

, двигайте его вверх 

вке кривые на графике выходят за пределы графика, щёлкните 
левой кн

огии. 
ра, необходимо элементу эквивалентной схемы диода 

присвои

кно схемы и нажмите левой кнопкой мышки на 

мышки щёлкните по Cell Libraries (Библиотеки эле-

ому выше 

неджера то-
пологии

ть по 
имени и

стройки переменных), показанный на рис. 3.50. В полях ввода Max и Min введите допустимые 
пределы регулировки резистора и длины отрезка, как показано на рис. 3.50. 

11. Нажмите левой кнопкой мышки на бегунок настройки и, не отпуская кнопки
и вниз. Результаты настройки переменных наблюдайте на графике. Одновременно все изменения 
отображаются на обеих схемах. 
Примечание. Если при регулиро
опкой мышки по значку Analyze на панели инструментов, чтобы повторить анализ, или щёлкни-

те по кнопке Sweep в блоке настройки. 
3.4.10. Черчение элемента топол

Чтобы получить топологию аттенюато
ть элемент топологии, представляющий собой зазор для пайки диода. Такого топологического 

элемента в Microwave Office нет. Поэтому его необходимо начертить и присвоить элементу схемы 
SUBCKT. Microwave Office поддерживает формат черчения GDSII и DXF. Начерченные элементы топо-
логии хранятся соответственно в библиотеках ячеек (Cell Libraries) GDSII или DXF. Библиотеки GDSII 
сохраняются в файлах с расширением gds, а библиотеки DXF сохраняются в файлах с расширением dxf. 
Причём в библиотеке GDSII может храниться несколько разных ячеек, а в библиотеке DXF только одна. 
Чтобы создать (начертить) новую ячейку топологии, можно воспользоваться имеющейся библиотекой 
или создать новую. В Microwave Office имеется библиотека packages (пакет) в формате GDSII, которая 
находится по адресу AWR\AWR2009\Examples\packages.gds. Чтобы импортировать эту библиотеку в 
проект, сделайте следующее: 

1. Сделайте активным о
панель Layout в нижней части левого окна, чтобы открыть окно менед-
жера топологии. 

2. Правой кнопкой 
ментов) в менеджере топологии и выберите Import GDSII Library 
(Импортировать библиотеку GDSII) во всплывающем меню. 

3. В открывшемся окне найдите файл packages.gds по указанн
адресу и дважды щёлкните по нему левой кнопкой мышки. 
Импортированная библиотека будет отображена в окне ме
 как подгруппа в группе Cell Libraries, как показано на рис. 3.51. 
Теперь, чтобы создать новый элемент топологии, нужно щёлкну
мпортированной библиотеки правой кнопкой мышки и выбрать New 

Layout Cell (Новая ячейка топологии). Рис. 3.51 



Если вместо импортирования библиотеки хотите соз-
дать свою библиотеку, щёлкните правой кнопкой мышки по 
Cell Libraries и выберите New GDSII Library или New DXF 
Library. Откроется окно, в котором нужно ввести имя созда-
ваемой библиотеки (например, My Library) и нажать OK. Имя 
вновь создаваемой библиотеки появится в окне менеджера 
топологии (рис. 3.52). В этой библиотеке отображается первая 
ячейка с именем New_GDS_Cell. Щёлкнув правой кнопкой 
мышки по этому имени ячейки и выбрав Rename Layout Cell, 
вы можете переименовать ячейку (например, Diode). Щёлкнув 
правой кнопкой мышки по имени созданной библиотеки My 

Library, вы можете добавить сколько угодно новых ячеек. 
Чтобы начертить элемент топологии: 

Рис. 3.53 Рис. 3.52 

1. Дважды щёлкните мышкой по имени ячейки Diode. В нижней части 
окна менеджера топологии появится список слоёв, в которых можно 
чертить элемент топологии (рис. 3.54) и на рабочем поле откроется 
окно для черчения ячейки топологии. 

 50

2. Щёлкните левой кнопкой мышки по квадрату 1_0->Copper (Медь) в 
нижней части окна менеджера, чтобы назначить медь для активного 
слоя, как показано на рис. 3.54 (не щёлкайте по лампочке, т.к. такой 
щелчок определяет слой для показа или скрытия). 

3. Щёлкните левой кнопкой мышки по окну рисования на рабочем поле, 
чтобы сделать его активным. 

4. По умолчанию размер сетки для черчения равен 0.1 мм. Щёлкните ле-
вой кнопкой мышки по кнопке справа от значка Grid Spacing (Интер-
вал сетки) на панели инструментов и в выпавшем списке выберите 

множитель 0.1x (рис. 3.55), чтобы сделать размер сетки 0.01 мм. 

Рис. 3.54 

5. Щёлкните левой кнопкой мышки по значку View Area и в окне топологии выделите 
участок окна так, чтобы была видна сетка. Возможно, это придётся сделать несколь-
ко раз. 

6. Щёлкните левой кнопкой мышки по значку Polygon  на панели инструментов (эта 
панель обычно расположена в нижней части экрана). 

7. Переместите курсор в окно рисования и щёлкните левой кнопкой мышки, чтобы за-
фиксировать начало топологии. Рис. 3.55 

8. Переместите курсор вправо, пока будет отображено dx:0.16 и щёлкните левой кнопкой мышки. 
Переместите курсор вниз, пока будет отображено 
dy:-0.1 и щёлкните левой кнопкой мышки. Пере-
местите курсор влево, пока будет отображено 
dx:-0,15 и щёлкните левой кнопкой мышки. Пе-
реместите курсор вниз, пока будет отображено 
dy:-0.36 и щёлкните левой кнопкой мышки. Пе-
реместите курсор влево, пока будет отображено 
dx:-0.01 и щёлкните два раза левой кнопкой 
мышки, чтобы завершить черчение. 

9. Щёлкните левой кнопкой мышки по значку Copy, 
и затем по значку Paste, чтобы скопировать и 
вставить элемент. Переместите курсор в окно то-
пологии и два раза щёлкните правой кнопкой 
мышки, чтобы развернуть скопированный эле-
мент. Поместите скопированный элемент напро-
тив 1-го так, чтобы величина зазора была равна 

0.4. Величину этого зазора можно измерить, щёлкнув левой кнопкой мышки по значку Measure 

 (Измерение величины) на панели инструментов. Полученный элемент топологии зазора по-
казан на рис.3.56. Величину зазора можно также измерить, щёлкнув мышкой по значку Ruler  
на панели инструментов. В этом случае линейка будет отображаться на топологии, как показано 
на рис. 3.56. Однако в этом случае предварительно нужно выбрать в меню Options>Layout Op-
tions и на вкладке Ruler открывшегося окна в поле Ruler spacing ввести расстояния меду деле-
ниями линейки 0.1 mm. Чтобы удалить линейку из топологии, нужно щёлкнуть по ней левой 
кнопкой мышки, чтобы выделить линейку, и затем нажать клавишу Delete. 
К начерченному элементу топологии необходимо добавить входной и выходной порты. Чтобы 

сделать это: 

Рис. 3.56 

1. Выберите в меню Draw>Cell Port (Чертить>Порт элемента) или щёлкните мышкой по  значку 
Cell Port  на панели инструментов. 



2. Переместите курсор в окно черчения. Нажав и 
удерживая клавишу Ctrl, поместите курсор на 
нижний левый угол  левого проводника так, 
чтобы небольшой квадратик появился на этом 
углу.  

3. Не отпуская клавишу Ctrl, нажмите левую 
кнопку мышки и, не отпуская её, двигайте кур-
сор к верхнему левому углу проводника, пока 
другой квадрат появится на этом углу. Отпус-
тите кнопку мышки и клавишу Ctrl. 

4. Повторите шаги с 1-го по 3-ий, чтобы помес-
тить порт на противоположной стороне рисун-
ка, но начните с верхнего правого угла и дви-
гайте курсор к правому нижнему углу. Щёлк-
ните мышкой на свободном пространстве окна, 
чтобы снять выделение порта. Полученная то-
пология показана на рис. 3.57. 

Рис. 3.57 

5. Закройте окно черчения. Будет выведен запрос, хотите ли вы сохранить нарисованный элемент. 
Нажмите Yes, чтобы сохранить.  
 
Примечание. Созданная библиотека по умолчанию сохраняется только в том проекте, в котором 

создана. Но при желании библиотеку с созданным элементом топологии можно сохранить, чтобы его 
использовать в других проектах. Для этого щёлкните правой кнопкой мышки по имени библиотеки в 
левом окне просмотра топологии и выберите Export Cell Library (Экспортировать библиотеку элемен-
тов). Аналогично можно сохранить не всю библиотеку, а только созданный элемент топологии. 
3.4.11. Назначение элемента топологии Diode элементам схемы SUBCKT. 

1. Щёлкните левой кнопкой 
мышки по окну схемы атте-
нюатора, чтобы сделать его 
активным. 

2. Дважды щёлкните левой 
кнопкой мышки по первому 
элементу схемы SUBCKT в 
окне схемы. Откроется окно 
Element Options (Опции 
элемента). 

3. Нажмите на панель Layout в 
верхней части этого окна 
(рис. 3.58). 

4. В поле ввода Library Name 
введите имя вашей библио-
теки My Library, щёлкнув 
по кнопке в правом конце 
этого поля. Выберите имя 
созданного элемента тополо-
гии Diode в правой области 
окна и нажмите OK (рис. 
3.58). 

Рис. 3.58 

5. Аналогично назначьте элемент топологии второму элементу схемы SUBCKT. 
3.4.12. Создание топологии схемы и экспортирование топологии. 

1. Выберите в меню View>Layout View  или щёлкните левой кнопкой мышки по значку View Lay-
out  на панели инструментов. 
Топология схемы будет отобра-
жена на рабочем поле, но распо-
ложение элементов топологии 
может быть беспорядочным (рис. 
3.59). Правильное соединение 
элементов топологии на этом 
отображении указывается крас-

ными линиями. 

Рис. 3.59 

2. Чтобы упорядочить полученную топологию, выделите всю топологию. Для этого поместите 
курсор мышки левее и выше топологии, нажмите левую кнопку мышки и переместите курсор 
правее и ниже топологии так, чтобы вся топология попала в образовавшийся прямоугольник. 
Или выберите в меню Edit>Select All (Редактировать>Выделить всё). Затем выберите в меню 
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Edit>Snap Together (Редактировать>Привязать вместе) или щёлкните по значку Snap Together 
 на панели инструментов. Полученная топология показана на рис. 3.60. 

3. Выберите в меню Options>Layout Options. На вкладке Export/LPF открывшегося окна отметьте 
Union layout shapes (Объединить формы топологии) и нажмите OK. 

Рис. 3.60 

4. Выберите в меню Layout>Export. Выберите тип файла DXF(DXF Flat, *.dxf) и нажмите кнопку 
Сохранить. В AutoCAD сохранённая топология будет иметь вид, показанный на рис. 3.61. 

Здесь создана и экспортирована топология только проводников аттенюатора. При необходимо-
сти вы можете создать топологию всей платы. 

Рис. 3.61

1. Щёлкните левой кнопкой мышки по значку Measure (Измерение), установите курсор на левый 
верхний угол первого проводника топологии, нажмите левую кнопку мышки и, не отпуская 
кнопки, переместите курсор на верхний правый угол последнего проводника топологии. Изме-
ренная длина топологии получилась 9.46 мм. Исходя из полученной длины топологии, выберем 
размер платы 10х4 мм. 

о центру платы (рис. 

, дважды щёлкнув в столбце Fill. 

2. Щёлкните по значку Rectangle на панели инструментов, 
поместите курсор в окно топологии и нажмите клавишу 
Tab. В открывшемся окне Enter Coordinates (Ввод коор-
динат) введите 0 в поля x и y (рис. 3.62). Нажмите OK и 
затем клавишу Tab. Во вновь открывшемся окне введите 
10 в поле dx и 4 в поле dy (рис.3.63). Нажмите OK. На по-
ле схемы появится прямоугольник платы, который будет 
выделен. 

Рис. 3.62 

3. Щёлкните по выделенному прямоугольнику правой кноп-
кой мышки и выберите Shape Properties. В открывшемся 
окне свойств в поле Draw Layers введите Board (Плата), 

щёлкнув мышкой по кнопке в 
правом конце этого поля (рис. 
3.64.) Нажмите OK. 

Рис. 3.63 
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4. Установите курсор левее и выше 
топологии, нажмите левую кноп-
ку мышки (курсор должен нахо-
диться вне прямоугольника пла-
ты, иначе будет выделена плата), 
перетащите курсор правее и ни-
же топологии так, чтобы вся то-
пология попала в образовавший-
ся прямоугольник, отпустите 
кнопку мышки. Вся топология 
должна быть выделена. 

5. Установите курсор мышки на 
любой элемент выделенной то-
пологии и переместите тополо-

гию так, чтобы она располага-
лась п
3.65). 
Замечание. Можно вместо 

перемещения топологии переместить 
прямоугольник платы, предварительно 
выделив его, щёлкнув мышкой. Одна-
ко, по умолчанию, прямоугольник 
платы зафиксирован и его нельзя ни 
выделить, ни переместить. Чтобы 

снять фиксацию платы, выберите в меню Options>Drawing Layers. Откроется окно опций черчения сло-
ёв (рис. 3.66). В левой части окна отметьте Drawing Layers 2d, если не отмечено. В правой части окна в 
строке Board в столбце Freeze по умолчанию установлена “галочка”, снимите её. В столбце Fill (Запол-
нение) не указан тип заполнения платы, поэтому она отображается бесцветным прямоугольником. При 
желании вы можете выбрать цвет и тип заполнения

Рис. 3.64 

Рис. 3.65 



6. На созданной плате вы можете теперь создать дополнительные топологические объекты, не свя-
занные с электрической схемой, например реперные знаки и надписи. Щёлкните левой кнопкой 
мышки по значку Polygon на панели инструментов, поместите курсор на левый верхний угол 
платы и щёлкните левой кнопкой мышки. Затем перемещайте курсор, щёлкая мышкой после ка-

ждого перемещения: на 0.5 вправо, на -
0.2 вниз, на -0.3 влево, на -0.3 вниз, на -
0.2 влево и здесь дважды щёлкните ле-
вой кнопкой мышки, чтобы замкнуть 
многоугольник. Щёлкните по много-
угольнику правой кнопкой (много-
угольник должен быть выделен) и вы-
берите Shape properties. В открывшем-
ся окне свойств в поле Draw Layers 
введите Copper (Медь), щёлкнув мыш-
кой по кнопке в правом конце этого по-
ля. Нажмите OK. Щёлкните по значку 
Copy на панели инструментов. Щёлкая 
по значку Paste на панели инструмен-
тов и правой кнопкой мышки, чтобы 
развернуть скопированный много-
угольник, установите реперные знаки 
на остальные углы платы. 

Рис 3.66

7. Выберите в меню Options>Layout Op-
tions. В открывшемся окне опций топо-
логии на вкладке Layout Font отметьте 

Draw as polygons (Чертить как полигоны) и выберите имя и высоту шрифта, например, как по-
казано на рис. 3.67. Нажмите OK. 

Рис. 3.67
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8. Выберите в меню Draw>Text. Поместите курсор на плату и щёлкните левой кнопкой мышки. В 
образовавшемся поле ввода наберите Attenuator и щёлкните мышкой вне этого поля. Установив 
курсор на надпись и нажав левую кнопку мышки, можно переместить надпись в любое свобод-
ное место на плате. Созданная плата показана на рис. 3.68. Заметим, что по умолчанию тополо-

Рис. 3.69 Рис. 3.68 



гические элементы чертятся на слое Error. Поскольку в DXF файл не записывается никаких 
свойств слоя, кроме его координат, то этот слой можно и оставить. Этот же слой можно оставить 
и для реперных знаков и других вспомогательных элементов топологии при условии, что они 
малы и расположены достаточно далеко от проводников, чтобы не влиять на характеристики. 
Слой черчения можно изменить в окне менеджера топологии Layout, например, на Copper. 

9. Щёлкните по значку View 3D 
Layout  на панели инстру-
ментов, чтобы просмотреть 3-х 
мерное изображение платы 
(рис. 3.69). 

10. Сделайте активным окно топо-
логии схемы и выберите в меню 
Layout>Export. Выберите тип 
файла DXF(DXF Flat, *.dxf) и 
нажмите Сохранить. Тополо-
гия в AutoCAD будет выгля-

деть, как показано на рис. 3.70. 
В сохранённом dxf файле записались только элементы топологии, размещённые на плате. Это 

объясняется тем, что в таблице соответствия слоёв черчения и слоёв, записываемых в DXF файл, слой 
топологии Board по умолчанию не установлен для записи в файл. Если вы хотите записать в файл и кон-

тур платы, сделайте следующее: 

Рис. 3.70 

 54

1. Выберите в меню Op-
tions>Drawing Layers. В 
левой части открывшего-
ся окна (рис. 3.71) щёлк-
ните мышкой по File Ex-
port Mappings и затем 
по DXF(DXF). В правой 
части окна отметьте 
столбец Write Layer 
(Записать слой) для слоя 
Board. Нажмите OK. 

2. Выберите в меню 
Layout>Export. В от-
крывшемся окне выбери-
те тип файла DXF(DXF 
Flat, *.dxf) и нажмите 
Сохранить. В AutoCAD 
топология будет выгля-

деть, как показано на рис. 
3.72. 
 
 
 
 
 
 
 
 
 

 
 
 

Рис. 3.71

Рис. 3.72 



4. Нелинейное моделирование 
Для выполнения анализа в нелинейном моделировании используется гармонический баланс, ко-

торый является эффективным методом для анализа усилителей мощности, смесителей, умножителей и 
генераторов. 

Моделирование с помощью гармонического баланса производится просто. Ввод схемы, изме-
ряемые величины и анализ выполняются аналогично линейному моделированию. Отличие состоит в том, 
что для выполнения гармонического баланса требуется наличие источников напряжения, тока или мощ-
ности. Имитатор гармонического баланса позволяет определять одночастотное и многочастотное возбу-
ждение портов, чтобы выполнить одно- и многосигнальный анализ. Всякий раз, когда источник гармо-
нического баланса определён в схеме, имитатор гармонического баланса вызывается автоматически при 
моделировании. 

Одночастотный анализ с использованием гармонического баланса включает в себя моделирова-
ние на одной основной частоте из множества частот и с постоянной составляющей тока. Этот анализ 
требует, чтобы вы определили основную частоту и общее количество гармоник. 

Двух- и многочастотный анализ с помощью гармонического баланса используется, чтобы опре-
делить реакцию на выходе схемы при возбуждении её портов разными частотами. Типичным примером 
являются смесители, на которые подаются частоты радиосигнала и гетеродина. Или определение интер-
модуляционных искажений при подаче близко расположенных частот в усилителях. 

Microwave Office содержит большое количество функций постобработки для отображения ре-
зультатов в частотной и временной области. Здесь предлагается полная система нелинейных измеряемых 
величин, которая включает в себя S-параметры при большом сигнале, мощность, напряжение и ток в 
произвольных узлах и точках пересечения, КПД суммирования мощности. Поскольку анализ с помощью 
гармонического баланса даёт решение для мощности и частоты в каждой гармонике, используются ин-
дексы, чтобы отличать различные параметры. 

Следующие примеры иллюстрируют некоторые из основных особенностей нелинейного моде-
лирования в Microwave Office. 

4.1. Моделирование усилителя мощности. 
Этот пример показывает, как использовать Microwave Office, чтобы моделировать схему усили-

теля мощности, используя нелинейный гармонический баланс. Для этого необходимы следующие шаги: 
o Использование нелинейных моделей из библиотеки элементов; 
o Создание измеряемых величин вольтамперной характеристики; 
o Создание цепи смещения транзистора и измеряемых величин напряжения и тока; 
o Добавление к схеме аннотации; 
o Импортирование входной и выходной согласующих цепей; 
o Добавление к схеме портов гармонического баланса; 
o Создание схемы с иерархической структурой, содержащей подсхемы; 
o Создание измеряемых величин выходной мощности; 
o Создание измеряемых величин характеристики динамической нагрузки; 
o Добавление двухчастотного порта гармонического баланса. 

Создайте новый проект и сохраните его с именем Amplifier. 
4.1.1. Установка единиц измерения, используемых по умолчанию. 

Чтобы установить единицы измерения, 
которые будут использоваться в проекте по умол-
чанию: 

1. Выберите в меню Options>Project Op-
tions или дважды щёлкните по группе 
Project Options в окне просмотра проек-
та. Откроется диалоговое окно Project 
Options (рис. 4.1). 

2. Нажмите панель Global Options  в верх-
ней части диалогового окна. 

3. Установите нужные единицы измерения, 
щёлкая по стрелкам, справа от поля ввода 
соответствующей единицы так, чтобы 
они соответствовали показанным на рис. 
4.1, снимите флажок в поле Metric units 
(Метрические единицы), установите mil в 
поле Length type и нажмите OK. 

Рис. 4.1 

4.1.2. Импортирование схемы. 
Создать схему можно обычным образом, выбрав в меню Project>Add Schematic>New Schematic 

или щёлкнув мышкой по значку Add New Schematic на панели инструментов. Затем в окне просмотра 
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элементов раскрыть группу Nonlinear, щёлкнуть по подгруппе BJT (Биполярный плоскостной транзи-
стор), перетащить в схему модель GBJT и отредактировать её параметры, щёлкнув мышкой по кнопке 
Show Secondary. В этом примере рассмотрим импорт уже имеющийся схемы с отредактированными па-
раметрами модели. 

1. В окне просмотра проекта щёлкните правой кнопкой мышки по 
группе Circuit Schematics и выберите Import Schematic. В открыв-
шемся окне зайдите в директорию C:\Program 
Files\AWR\AWR2009\Examples. Выделите файл nonlin-
ear_start.such и нажмите кнопку Открыть. Схема будет импорти-
рована в проект и в окне просмотра проекта появится подгруппа 
схемы с именем nonlinear_start. 

2. Щёлкните правой кнопкой мышки по имени схемы в окне просмотра 
и выберите Rename Schematic (Переименовать схему). В открыв-
шемся окне введите имя IV Curve и нажмите OK. Должна получить-
ся схема, показанная на рис. 4.2. 

Рис. 4.2 

4.1.3. Размещение измерителя вольтамперной характеристики. 
Чтобы поместить измеритель вольтамперной характеристики в нелинейном элементе: 

1. Найдите в окне просмотра элементов группу Meas Devices (Средства измерения) и дважды 
щёлкните по ней левой кнопкой мышки, чтобы развернуть группу. Щёлкните левой кнопкой 
мышки по подгруппе IV. Модели измерителей отображаются в нижней части левого окна. 

2. Нажмите левой кнопкой мышки на модель IVCURVEI и, не отпуская кнопки мышки, перетащи-
те её в окно схемы, отпустите кнопку мышки, позиционируйте элемент как показано на рис. 4.3 
и щёлкните левой кнопкой мышки, чтобы зафиксировать его. 

3. Поместите курсор возле узла Step (Шаг) элемента 
IVCURVEI так, чтобы курсор отображался в ви-
де соленоида. Щёлкните левой кнопкой мышки, 
чтобы зафиксировать начало провода, затем пере-
тащите курсор к узлу 1 транзистора GBJT и 
щёлкните левой кнопкой мышки, чтобы зафикси-
ровать провод. 
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4. Повторите шаг 3, чтобы подключить узел Sweep 
(Смещение) элемента IVCURVEI к узлу 2 тран-
зистора GBJT. 

5. Щёлкните левой кнопкой мышки по значку 
Ground на панели инструментов и подключите 
землю к узлу 3 транзистора GBJT и щёлкните ле-

вой кнопкой мышки, чтобы её зафиксировать. 

Рис. 4.3

4.1.4. Редактирование 
параметров измерите-
ля вольтамперной ха-
рактеристики. 

Чтобы определить 
параметры IV CURVEI: 

1. Дважды щёлкните 
левой кнопкой мыш-
ки по элементу 
IVCURVEI в окне 
схемы. Откроется 
диалоговое окно 
Свойства: Element 
Options (Опции эле-
мента). 

2. Установите пределы 
измерений для на-
пряжения и тока. Для 
этого измените зна-
чения полей Value 
(Значение) как пока-
зано на рис. 4.4 и 
нажмите OK. 

 Рис. 4.4 
 

 



4.1.5. Создание графика вольтамперной характеристики. 
Чтобы создать график и добавить измеряемые величины к измерителю вольтамперной характе-

ристики: 
1. Щёлкните левой кнопкой мышки по панели Project в нижней части левого окна, чтобы открыть 

окно просмотра проекта. 
2. Правой кнопкой мышки щёлкните по группе Graphs (Графики) и выберите New Graph (Новый 

график). Или щёлкните левой кнопкой мышки по значку Add New Graph  на панели инстру-
ментов. Откроется окно New Graph. 

3. Наберите IV BJT в поле Graph Name (Имя графика), выберите Rectangular (Прямоугольный) и 
нажмите OK. График отобразится на рабочем поле. 

4. Щёлкните правой кнопкой мышки по подгруппе IV BJT в группе Graphs в окне просмотра про-
екта и выберите Add Measurement (Добавить измеряемую величину) во всплывающем меню. 
Откроется диалоговое окно Add Measurement. 

5. Выберите Nonlin-
ear>Current (Нелиней-
ный>ток) в окне списка 
Measurement Type (Тип 
измеряемой величины), 
выберите IV Curve в 
окне списка Measure-
ment, выберите 
IVCurve в поле Data 
Source Name (Имя ис-
точника данных), на-
жмите Apply и OK. 

6. Выберите в меню Simu-
late>Analyze (Модели-
рование>Анализ) или 
щёлкните по значку 

Analyze на панели инструментов . Результат моделирования отображается на графике рис. 4.5. 
Замечание. На правой стороне графика отображаются маркеры. Вы можете изменить их вид 

отображения или совсем убрать. Для этого щёлкните правой кнопкой по графику и выберите Properties 
(Свойства). В открывшемся окне на вкладке Markers снимите “галочку” в Param markers in legend, 
чтобы изменить вид маркеров, или снимите “галочку” в Param markers enabled, чтобы убрать маркеры, 
нажмите Apply и OK. 

Рис. 4.5 

4.1.6. Создание электрической цепи смещения. 
Чтобы создать цепь смещения: 

1. Откройте окно просмотра проекта. Установите курсор мышки на имя схемы IV Curve в окне 
просмотра проекта, нажмите левую кнопку мышки и, не отпуская кнопки, переместите курсор на 
Circuit Schematics, отпустите кнопку мышки. Или щёлкните по имени схемы и выберите Dupli-
cate Schematic. Будет создана копия схемы с именем IV Curve_1. 

2. Щёлкните правой кнопкой мышки по имени новой схемы и выберите Rename Schematic. В от-
крывшемся окне введите имя DC Bias (Постоянный ток смещения) и нажмите OK. 

3. В окне схемы IV Curve щёлкните левой кнопкой мышки по элементу IVCURVEI, чтобы выде-
лить его. Нажмите клавишу Delete, чтобы удалить этот элемент. 

4. Откройте окно просмотра элементов Elements. 
5. Дважды щёлкните левой кнопкой мышки по группе Lumped Element (Сосредоточенные эле-

менты), чтобы развернуть её. Щёлкните левой кнопкой мышки по подгруппе Inductor (Индук-
тивности) в группе Lumped Element. Доступные модели катушек индуктивности будут отобра-
жены в нижней части левого окна. Нажмите левой кнопкой мышки на модель IND и, не отпуская 
кнопки мышки, перетащите её в окно схемы, отпустите кнопку мышки, позиционируйте элемент 
выше и левее транзистора GBJT, как показано на рис. 4.6, и щёлкните левой кнопкой мышки, 
чтобы зафиксировать элемент. 

6. Поместите курсор на узле 1 транзистора GBJT так, чтобы курсор отображался в виде соленоида. 
Щёлкните левой кнопкой мышки, чтобы зафиксировать начало провода, перетащите курсор к 
правому узлу элемента IND, щёлкните левой кнопкой мышки, чтобы зафиксировать конец про-
вода. 

7. Дважды щёлкните левой кнопкой мышки по элементу IND в окне схемы. Откроется диалоговое 
окно Element Options. Введите 1 в поле Value для индуктивности (L) и нажмите OK. 

8. Нажмите клавишу Ctrl, установите курсор на землю, нажмите левую клавишу мышки и сдвинь-
те землю куда-нибудь в сторону так, чтобы не было соединения земли с элементом GBJT. От-
пустите кнопку мышки и клавишу. Если все-таки соединение проводом осталось, щёлкните по 
проводу и нажмите клавишу Delete. 
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9. Щёлкните левой кнопкой мышки по подгруппе Resistor в группе Lumped Element. Доступные 
модели резисторов будут отображены в нижней части левого окна. Нажмите левой кнопкой 
мышки на модель RES и, не отпуская кнопки мышки, перетащите её в окно схемы, отпустите 

кнопку мышки, щёлкните правой кнопкой мышки, чтобы 
повернуть элемент, позиционируйте его на узле 3 транзи-
стора GBJT, как показано на рис. 4.6, и щёлкните левой 
кнопкой мышки, чтобы зафиксировать элемент. 

10. Дважды щёлкните левой кнопкой мышки по элементу 
RES в окне схемы. Откроется диалоговое окно Element 
Options. Введите 0.5 в поле Value для резистора (R) и на-
жмите OK. 

11. Установите курсор на элементе земли, нажмите левую 
кнопку мышки и подключите землю к нижнему узлу рези-
стора RES, как показано на рис. 4.6. 

12. Щёлкните по значку Ground на панели инструментов и 
подключите землю к узлу 4 транзистора GBJT, как пока-
зано на рис. 4.6. 

13. Найдите в окне просмотра элементов группу Sources (Ис-
точники) и дважды щёлкните по ней, чтобы развернуть. 
Щёлкните левой кнопкой мышки по подгруппе DC (По-
стоянный ток). Модели доступных источников отобража-
ются в нижней части окна. Нажмите левой кнопкой мыш-

ки на модель DCVS и, не отпуская 
кнопки мышки, перетащите её в окно 
схемы, отпустите кнопку мышки, 
позиционируйте элемент на левом 
узле индуктивности IND ID=L1, как 
показано на рис. 4.7, и щёлкните 
левой кнопкой мышки, чтобы зафик-
сировать элемент. 

Рис. 4.6 
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14. Щёлкните левой кнопкой мышки по 
значку Ground на панели 
инструментов, двигайте курсор в 
окно схемы, позиционируйте землю 
на нижнем узле элемента DCVS, как 
показано на рис. 4.7, и щёлкните 
левой кнопкой мышки, чтобы зафик-
сировать. 

15. Дважды щёлкните левой кнопкой 
мышки по элементу DCVC в окне 
схемы. Откроется диалоговое окно 

Element Options. Введите 1 в поле Value и нажмите OK. 

Рис. 4.7 

16. Щёлкните левой кнопкой мышки по элементу Ind, чтобы выделить его. Щёлкните левой кноп-
кой по значку Copy  и затем по значку Paste  на панели инструментов, чтобы скопировать 
его. Поместите скопированный элемент правее и выше элемента CBJT и соедините с узлом 2 
элемента CBJT, как показано на рис. 4.7. 

17. Нажмите клавишу Shift, щёлкните левой кнопкой мышки по элементу DCVS и подключённой к 
нему земле. Скопируйте эти элементы и подключите их к последнему элементу Ind, как показа-
но на рис. 4.7. 

18. Дважды щёлкните левой кнопкой мышки по второму элементу DCVS в окне схемы. Откроется 
диалоговое окно Element Options. Введите 6 в поле Value и нажмите OK. 

 
Примечание. Возле каждого элемента располагается поле с его параметрами. Чтобы перемес-

тить параметры элемента в другое место, если это необходимо, нажмите на поле параметров левой кноп-
кой мышки и, не отпуская кнопки мышки, перетащите параметры в другое место. 

 
Заметим, что это не единственный способ создания схемы DC Bias. Можно было создать новую 

схему, щёлкнув по значку Add New Schematic на панели инструментов. Затем выделить элемент CBJT в 
схеме IV Curve и скопировать его в схему DC Bias, используя значки Copy и Paste на панели инстру-
ментов. 
4.1.7. Добавление в схему отображения рассчитанных напряжений и токов. 

В схему можно добавить отображение рассчитанных при анализе напряжений и токов, которые 
будут показаны в каждой точке разветвления. Чтобы сделать это: 



1. Щёлкните правой кнопкой мышки по имени схемы DC Bias в левом окне просмотра проекта и 
выберите Add Annotation. Откроется окно рис. 4.8. В области Measurement этого окна отметьте 
напряжение постоянного тока DCVA_N и нажмите Apply. 

2. Затем отметьте в этой же области постоянный ток DCIA и нажмите Apply. 
3. Нажмите OK. 
4. Выберите в меню Simulate>Analyze или щёлкните по значку Analyze на панели инструментов. 

После выполнения анализа схема будет выглядеть, как показано на рис. 4.9. Если поместить кур-
сор на отображаемые напряжение или ток и нажать левую кнопку мышки, то эти отображения можно 
переместить в другое место схемы. 

Добавленные аннотации отображаются в окне просмотра проекта как подгруппы в схеме DC 
Bias. Любую аннотацию можно скрыть. Для этого щёлкните правой кнопкой мышки по имени аннотации 
в окне просмотра проекта и выберите Toggle Enable. Затем щёлкните по значку Analyze на панели инст-
рументов. Чтобы вновь отобразить скрытую аннотацию, снова выберите Toggle Enable для этой аннота-
ции и щёлкните по значку Analyze на панели инструментов. 

Скрыть можно и все аннотации сразу. Для этого щёлкните правой кнопкой мышки по имени 
схемы DC Bias в окне просмотра проекта, выберите Disable All Annotations и щёлкните по значку Ana-
lyze на панели инструментов. Чтобы вновь отобразить скрытые аннотации, снова щёлкните правой кноп-
кой мышки по имени схемы в окне просмотра проекта, выберите Enable All Annotations и щёлкните по 
значку Analyze на панели инструментов. 

Любую аннотацию можно удалить, если щёлкнуть правой кнопкой мышки по её имени в окне 
просмотра проекта и выбрать Delete. 

Рис. 4.9 
Рис. 4.8 

4.1.8. Добавление блокировочных конденсаторов. 
Добавьте в схему конденсаторы на входе и выходе транзистора, а также параллельно резистору. 

Для этого: 
1. Щёлкните левой кнопкой мышки по панели Elements в нижней части левого окна, чтобы от-

крыть окно просмотра элементов. 
2. Дважды щёлкните левой кнопкой мышки 

по группе Lumped Element, чтобы развер-
нуть её. Щёлкните левой кнопкой мышки 
по подгруппе Capacitor в группе Lumped 
Element. Нажмите левой кнопкой мышки 
на модель CAP и перетащите её в окно 
схемы. Отпустите кнопку мышки, пози-
ционируйте элемент на клемме 1 транзи-
стора GBJT, как показано на рис. 4.10, и 
щёлкните левой кнопкой мышки, чтобы 
зафиксировать элемент. 

3. Дважды щёлкните левой кнопкой мышки 
по элементу CAP в окне схемы. Откроется 
диалоговое окно Element Options. Введите 
100 в поле Value для ёмкости (C) и нажми-
те OK. 

4. Щёлкните левой кнопкой мышки по эле-
менту CAP в окне схемы. Нажмите клави-
ши Ctrl+C и затем Ctrl+V, чтобы скопи-Рис. 4.10 
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ровать и вставить элемент. Подключите скопированный элемент к узлу 2 транзистора GBJT, как 
показано на рис. 4.10, и щёлкните левой кнопкой мышки, чтобы зафиксировать элемент. 

5. Снова нажмите клавиши Ctrl+V, щёлкните правой кнопкой мышки, чтобы развернуть скопиро-
ванный элемент и установите его слева от резистора Res, как показано на рис. 4.10. 
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4.1.9. Добавление порта гармонического 
бы добавить порт гармонического ба-

ланса: 
Дважды щёлкните левой кнопкой мышки по 

й мышки по 

деление частот нелинейного моделирования. 

 Options и в открывшемся окне 
опций проекта ввести нужные частоты на вкладке

ра документа и 

  

 

 

6. Поместите курсор на верхней клемме элемента CAP ID=C3. Курсор должен отображаться в виде 
соленоида. Щёлкните левой кнопкой мышки и затем перетащите курсор к клемме 3 транзистора 
GBJT и щёлкните левой кнопкой мышки, чтобы зафиксировать провод. Аналогично соедините 
проводом нижнюю клемму элемента CAP ID=C3 с землёй. Схема будет выглядеть, как показано 
на рис. 4.10. 

баланса. 
Что

1. 
группе Ports в окне просмотра элементов, 
чтобы развернуть её. Щёлкните левой кноп-
кой мышки по подгруппе Harmonic Balance 
в группе Ports. Доступные модели портов 
отображаются в нижней части левого окна. 
Нажмите левой кнопкой мышки на модель 
PORT1 и, не отпуская кнопки мышки, пере-
тащите её в окно схемы. Отпустите кнопку 
мышки, подключите элемент к левой клем-
ме элемента CAP ID=C1, как показано на 
рис. 4.11, и щёлкните левой кнопкой мыш-
ки, чтобы зафиксировать порт. 

2. Дважды щёлкните левой кнопко
порту PORT1 в окне схемы. Откроется диа-
логовое окно Element Options. Введите 23 в 
строку Pwr в поле Value и нажмите OK. 

3. Щёлкните левой кнопкой мышки по значку 
PORT на панели инструментов. Двигайте 

курсор в окно схемы, щёлкните правой кнопкой мышки два раза, чтобы повернуть порт, под-
ключите его к правой клемме выходного конденсатора CAP ID=C2, как показано на рис. 4.11, и 
щёлкните левой кнопкой мышки, чтобы зафиксировать порт. 

4.1.10. Опре

Рис. 4.11 

Определить частоты для анализа можно несколькими способами: 
1. Как глобальные частоты проекта, выбрав в меню Options>Project

 Frequencies. 
2. Как локальные частоты, определён-

ные только для данной схемы, щёлк-
нув правой мышкой по имени схемы 
в левом окне просмот
выбрав Options. 

3. Из левого окна просмотра элементов 
поместить в схему элемент 
SWPFRQ, который находится в 
группе Simulation Control. 
Мы воспользуемся вторым способом. 

1. В окне просмотра проекта щёлкните 
левой кнопкой мышки по значку + 
слева от группы Circuit Schematics, 
чтобы развернуть её. 

2. Щёлкните правой кнопкой мышки по
подгруппе DC BIAS и выберите Op-
tions. Откроется диалоговое окно 
Options (рис. 4.12). 

3. На вкладке Frequencies снимите “га-
Рис. 4.12 

лочку” в переключателе Use Project Frequencies (Использовать частоты проекта). 
4. Установите GHz в поле Data Entry Unit, щёлкая левой кнопкой мышки по стрелке справа от

этого поля, введите 1.5 в поле Start, введите 2.5 в поле Stop, введите 0.2 в поле Step, выберите 
Replace (Заменить) и нажмите Apply (Применить). Диапазон частот отображается в окне списка
Current Range (см. рис. 4.12). Нажмите OK. 
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Microwave Office позволяет вы-
коэ раж

личину
го

портиро

4.1.11. Создание диаграммы Смита и добавление измеряемой величины коэффи-
циента отражения большого сигнала. 

числить ффициент от ения большо-
го сигнала и отобразить его на диаграмме 
Смита. 

Чтобы создать диаграмму Смита: 
1. Щёлкните правой кнопкой мыш-

ки по группе Graphs и выберите 
New Graph (Добавить график). 
Откроется диалоговое окно New 
Graph. 

 Введите Input reflection (Коэф-2.
фициент отражения по входу) в 
поле Graph Name, выберите 
Smith Chart (Диаграмма Смита) 
в области Graph Type и нажми-
те OK. Диаграмма будет ото-
бражена на рабочем поле. 

Чтобы добавить измеряемую ве-
 коэффициента отражения большо-

 сигнала: 
1. Щёлкните правой кнопкой мыш-

Рис. 4.13 

ки по имени графика Input reflection в группе Graphs в 
окне просмотра проекта и выберите Add measurement 
(Добавить измеряемую величину) во всплывающем меню. 
Откроется диалоговое окно Add measurement (Рис. 4.13). 

2. Раскройте группу Nonlinear в окне списка Meas Type (Тип 
измеряемых величин) и отметьте Parameter. Выберите 
Gcomp (Компонент отражённого сигнала) в окне списка 
Measurement. Выберите DC Bias в поле Data Source 
Name, выберите PORT_1 в поле Measurement Component 
(Компонент измеряемой величины), введите 1 в поле 
Harmonic Index (Индекс гармоники), щёлкая по стрелке 
справа от этого поля. Отметьте Complex и нажмите Apply 
и OK. 

3. Выберите в меню Simulate>Analyze или щёлкните по 
значку Analyze на панели инструментов. Результаты ана-
лиза отображаются на диаграмме Смита рис. 4.14. 

Рис. 4.14 

4.1.12. Импортирование согласующих входной и выходной схем. 
Входную и выходную согласующие схемы импортируем из схемы, созданной ранее. Чтобы им-
вать входную согласующую схему: 

1. Щёлкните правой кнопкой 
мышки по группе Circuit 
Schematics в окне просмотра 
проекта и выберите Import 
Schematic  во всплывающем 
меню. Откроется диалоговое 
окно Browse For File (Рис. 
4.15). 

2. Щёлкните левой кнопкой 
мышки по кнопке справа от 
поля Папка и установите в 
этом поле папку C:\Program 
Files\AWR\MWO2009\Examp
les. 

3. Щёлкните левой кнопкой 
мышки по файлу input math и 
нажмите кнопку Открыть. На 
рабочем поле будет отобра-
жена схема, показанная на 
рис. 4.16. 

Рис. 4.15 



4. Чтобы импортировать выходную согласующую схему, повторите пункты с 1-го по 3-ий, но вы-
берите файл output math. На рабочем поле будет отображена схема, показанная на рис. 4.17. 

 62

4.1.13. Добавление подсхем к схеме. 
Рис. 4.17 Рис. 4.16 

Всякий раз, когда к n – ному порту схемы подключается другая созданная или импортированная 
схема, то подключённая схема автоматически становится n – подсхемой. Такие подсхемы могут подклю-

чаться к другим подсхемам, создавая, таким образом, 
иерархическую структуру электрической цепи. Чтобы 
добавить согласующие схемы на входе и выходе уси-
лителя: 

1. В левом окне просмотра проекта в группе 
Circuit Schematics дважды щёлкните левой 
кнопкой мышки по подгруппе DC Bias, 
чтобы отобразить эту схему. 

2. Щёлкните левой кнопкой мышки по эле-
менту PORT1 в окне схемы. Нажмите кла-
вишу Shift и, удерживая её, щёлкните левой 
кнопкой мышки по элементу CAP ID=C1. 
При этом и PORT1 и CAP ID=C1 будут 
выделены. 

3. Нажмите и удерживайте клавишу Ctrl. На-
жмите левой кнопкой мышки на выбранные 
элементы и, не отпуская кнопки мышки, пе-
ретащите их влево от электрической цепи, 
чтобы разорвать связь между CAP ID=C1 и 
транзистором, как показано на рис. 4.18. 

Рис. 4.18 

4. Нажмите на панель Elements в нижней час-
ти левого окна, чтобы открыть окно про-
смотра элементов. 

5. Щёлкните левой кнопкой мышки по группе 
Subcircuit (Подсхемы) в окне просмотра 
элементов. Доступные подсхемы будут ото-
бражены в нижней части левого окна. 

6. Нажмите левой кнопкой мышки подсхему 
input match и, не отпуская кнопки, перета-
щите её в окно схемы, отпустите кнопку 
мышки и подключите к узлу 1 транзистора, 
щёлкните левой кнопкой мышки, чтобы за-
фиксировать её.  

7. Нажмите клавишу Shift и, удерживая её, 
щёлкните левой кнопкой мышки по элемен-
там PORT1 и CAP ID=C1, чтобы выделить 
их. Установите курсор на один из выделен-

ных элементов, нажмите левую кнопку мышки и подключите эти элементы к узлу 1 подсхемы 
input match, как показано на рис. 4.19. 

Рис. 4.19 

8. Щёлкните левой кнопкой мышки по элементу PORT2. Нажмите и, удерживая клавишу Shift, 
щёлкните левой кнопкой мышки по элементу CAP ID=C2. При этом PORT2 и CAP ID=C2 бу-
дут выделены. 



9. Нажмите клавишу Ctrl. Нажмите выделенные 
элементы левой кнопкой мышки и, не отпуская 
кнопки мышки, перетащите их вправо и вниз от 
схемы, чтобы разорвать связь между CAP 
ID=C2 и проводом, как показано на рис. 4.20. 
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4.1.14. Создание графика выходной мощности. 

ости (в дБ/Мвт) в зависимости от частоты и 

авой кнопкой мышки по группе Graphs и выбе-

e, выберите Rectangular в области 

 в окне просмотра про-

ите в меню Simulate>Analyze, или щёлкните по значку Analyze на панели инструментов. 

10. Нажмите левой кнопкой мышки на подсхему 
output match и, не отпуская кнопки, перетащи-
те её в окно схемы, отпустите кнопку мышки, 
щёлкните два раза правой кнопкой мышки, 
чтобы развернуть подсхему на 180 градусов, 
подключите подсхему узлом 2 к узлу 2 транзи-
стора GBJT и щёлкните левой кнопкой мышки, 
чтобы зафиксировать. 

11. Нажмите клавишу Shift и, удерживая её, щёлк-
ните левой кнопкой мышки по элементам 
PORT2 и CAP ID=C1, чтобы выделить их. Ус-
тановите курсор на один из выделенных эле-
ментов, нажмите левую кнопку мышки и под-
ключите эти элементы к узлу 1 подсхемы out-

put match, как показано на рис. 4.21. 

Рис. 4.20 

12. Дважды щёлкните левой кнопкой мышки по значению параметра Pwr=23 dBm элемента 
PORT1. Откроется окно редактирования значения. Наберите 18, чтобы изменить значение 23 
на 18 dBm. Полученная схема показана на рис. 4.21. 

13. В левом окне просмотра проекта дважды щёлкните по имени графика диаграммы Смита, чтобы 
сделать это окно активным. 

14. Щёлкните левой кнопкой мышки по значку Analyze на панели инструментов. Полученный 
график показан на рис. 4.22. 

Чтобы создать график зависимости выходной мощн
добавит

Рис. 4.22 
Рис. 4.21

ь измеряемую величину выходной мощности: 
1. В левом окне просмотра проекта щёлкните пр

рите New Graph. Откроется диалоговое окно New Graph. 
2. Наберите Pout (Выходная мощность) в поле Graph Nam

Graph Type и нажмите OK. График будет отображён на рабочем поле. 
3. Правой кнопкой мышки щёлкните по подгруппе Pout в группе Graphs

екта и выберите Add Measurement во всплывающем меню. Откроется диалоговое окно Add 
Measurement (рис. 4.23). 

4. В области Measurement Type раскройте группу Nonlinear и отметьте Power. Выберите Pcomp 
в области Measurement. Введите DC Bias в поле Data Source Name, введите PORT_2 в поле 
Measurement Component, введите 1 в поле Harmonic Index, в поле Sweep Freq(FDOC) введи-
те Use for x-axis, отметьте dBm в области Complex Modifier и нажмите Apply и OK (рис. 
4.23). 

5. Выбер
Результаты анализа отображаются на графике рис 4.24. 
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4.1.15. Создание графика динамической нагрузки. 

Рис. 4.24 

Рис. 4.23 

График динамической нагрузки наносится на график вольтамперной характеристики устройства. 
Чтобы создать измеряемые величины динамической нагрузки: 

1. В левом окне просмотра проек-
та дважды щёлкните левой 
кнопкой мышки по имени гра-
фика IV BJT в группе Graph, 
чтобы открыть график вольт-
амперной характеристики на 
рабочем поле. 

2. Щёлкните правой кнопкой 
мышки по имени графика IV 
BJT в группе Graphs в окне 
просмотра проекта и выберите 
Add Measurement. Или щёлк-
ните правой кнопкой мышки в 
окне графика и выберите Add 
New Measurement. Откроется 
диалоговое окно Add Meas-
urement (рис. 4.25). 

3. Выберите Nonlinear>Current в 
области Measurement Type. В 
области Measurement отметьте 

IVDLL. Теперь нужно из-
менить содержимое полей 
Voltage Measure Compo-
nent и Current Measure 
Component. Щёлкните 
мышкой по кнопке “…” 
справа от поля Voltage 
Measure Component (на 
рис. 4.25 показана стрел-
кой). Откроется окно со 
схемой DC Bias (рис. 4.26). 
В списке в левом нижнем 
углу этого окна отметьте 
GBJT.GP1@2 и нажмите 
OK в левом верхнем углу 
окна. 

Рис. 4.25 

4. Аналогично введите это 
же значение GBJT.GP1@2 
в поле Current Measure 
Component. Рис. 4.26 

5. В поле Sweep Freq (FDOC) введите Freq=1.5 GHz (рис. 4.25). 



6. Нажмите Apply и OK. 
7. Выберите в меню Simu-

late>Analyze или щёлкните по 
значку Analyze на панели инст-
рументов. Результаты анализа 
отображаются на графике рис 
4.27. 

4.1.16. Копирование схемы в окне 
просмотра проекта. 

Чтобы выполнить двухчастотный 
анализ, требуется та же самая схема, но с 
двухчастотным портом гармонического 
баланса. Мы не будем изменять порт в 
имеющейся схеме, а создадим новую, ис-
пользуя возможность в Microwave Office 
создавать копии схем. Рис. 4.27

1. Установите курсор на имя схемы DC Bias в группе Circuit Schematics в левом окне проекта, 
нажмите левую кнопку мышки и, не отпуская кнопки, переместите курсор на имя группы Cir-
cuit Schematics. Будет создана копия схемы с именем DC Bias_1. 

2. Щёлкните правой кнопкой мышки по имени скопированной схемы DC Bias_1 в левом окне 
проекта и выберите Rename Schematic (Переименовать схему). 

3. В открывшемся окне введите новое имя для скопированной схемы Two Tone Amp и нажмите 
OK. 

4.1.17. Добавление двухчастотного порта гармонического баланса. 
Обычно измеряемые величины, 

используемые для характеристики уси-
лителя мощности, являются тремя по-
следовательностями составляющих 
интермодуляции относительно переда-
ваемой мощности. Чтобы создать эти 
измеряемые величины, на вход необхо-
димо подать две, близко расположен-
ные частоты. Для добавления двухчас-
тотного порта гармонического баланса: 

1. В активном окне схемы  Two 
Tone Amp дважды щёлкните 
левой кнопкой мышки по 
элементу PORT1. Откроется 
диалоговое окно Element Op-
tions (Рис. 4.28). 

2. Откройте вкладку Port диа-
логового окна, щёлкнув 
мышкой по вкладке Port в 
верхней части этого окна. 

Рис. 4.28 

3. В области Port Type отметьте 
Source (Источник) и Swept 
Power (Вариация частоты), в 
поле Simulator type (Ре-
шающее устройство) введите 
Harmonic Balance. В поле  
Tone Type введите Tone 
1&2. В области Source exci-
tation  (Источник возбужде-
ния) выберите Excite funda-
mental frequency (Возбужде-
ние фундаментальной часто-
ты). 

4. Откройте вкладку Parame-
ters. В поле Fdelt введите 0.2, 
в поле Pstart введите -10, в 
поле Pstop введите 25, в поле 
Pstep введите 5, как показано 
на рис. 4.29. Затем нажмите 
OK. Рис. 4.29 
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4.1.18. Добавление измеряемой величины третьей составляющей интермодуляции. 
Чтобы добавить измеряемую величину третьей составляющей интермодуляции: 

1. Сначала создайте график. Для 
этого в левом окне просмотра 
проекта щёлкните правой 
кнопкой мышки по группе 
Graphs и выберите New 
Graph, или щёлкните левой 
кнопкой мышки по значку Add 
New Graph на панели инстру-
ментов. Откроется диалоговое 
окно New Graph. 

2. Наберите IM3 (Интермодуля-
ция 3) в поле ввода Graph 
Name, отметьте Rectangular в 
области Graph Type и нажми-
те OK. На рабочем поле будет 
отображён график. 

3. Правой кнопкой мышки щёлк-
ните по подгруппе IM3 в 
группе Graphs в окне про-
смотра проекта и выберите 
Add Measurement во всплы-
вающем меню. Откроется диа-

логовое окно Add Measurement 
(Рис 4.30). 

Рис. 4.30 
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4. Выберите Nonlinear>Power в об-
ласти Measurement Type, выбе-
рите Pcomp в области Measure-
ment, введите Two Tone Amp в 
поле Data Source Name, введите 
PORT_2 в поле Measurement 
Component, введите 2 и -1 в поля 
Harmonic Index, введите 
Freq=1.5 GHz в поле Sweep Freq 
(FDOC), введите Use for x-axis в 
поле PORT_1, отметьте dBm, 
нажмите Apply. 

5. Повторите п.4, но в поля Har-
monic Index введите 0 и 1. На-
жмите Apply и OK. 

6. Выберите в меню Simu-
late>Analyze или щёлкните по 
значку Analyze на панели инст-

рументов. Результаты отображаются на графике рис. 4.31. 

Рис. 4.31 

4.2. Моделирование балансного смесителя на диодах. 
Выполнить моделирование балансного смесителя с частотой сигнала 4.25 ГГц, частотой гетеро-

дина 3.75 ГГц, промежуточная частота 0.5 ГГц. 
 

4.2.1. Создание нового проекта. 
Чтобы создать новый проект: 

1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется диалоговое 

окно Save As. 
3. Наберите имя проекта BDMixer и нажмите Сохранить. 

 
4.2.2. Определение единиц измерения и частот проекта. 

1. Выберите в меню Options>Project Options (Опции>Опции проекта) или дважды щёлкните 
мышкой по Project Options в левом окне проекта. Откроется диалоговое окно Project Options. 

2. В открывшемся окне опций проекта откройте вкладку Global Options и определите глобальные 
единицы измерения, как показано на рис. 4.32. 



3. Откройте вкладку Frequencies. Введите 2 в поле Start, 5 в поле Stop, 0.03 в поле Step. Отметь-
те Replace и нажмите Apply. Диапазон частот отображается в окне списка Current Range, как 
показано на рис.4.33. 

4. Нажмите OK. 
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4.2.3. Создание схемы и анализ ответвителя Ланге. 
Рис. 4.32 Рис. 4.33 

В проекте будут несколько схем, использующие одну и ту же подложку. Поэтому поместим эле-
мент подложки в глобальные определения, откуда он будет доступен для всех схем. 

1. В окне просмотра проекта дважды щёлкните по Global Definitions, откроется окно глобальных 
определений. 

2. В левом окне откройте окно просмотра элементов, щёлкнув мышкой по кнопке Elements в 
нижней части левого окна. 

3. Щёлкните мышкой по группе Substrates, чтобы отобразить элементы подложек. 
4. Перетащите элемент MSUB в окно глобальных определений и щёлкните левой кнопкой мыш-

ки, чтобы закрепить его. 
5. Дважды щёлкните мышкой по элементу MSUB и в открывшемся окне свойств элемента введи-

те: Er=6, H=1.25 mm, T=0.025 mm, Tand=0.001 и ErNom=6. Нажмите OK. 
Теперь создадим схему ответвителя Ланге. Эта схема будет состоять только из одного элемента, 

и её будем использовать, чтобы правильно подобрать значения параметров этого элемента. 
1. Щёлкните мышкой по значку Add New Schematic 

на панели инструментов и создайте схему с именем 
Lange Coupler. 

2. В окне просмотра элементов раскройте группу Mi-
crostrip и щёлкните мышкой по подгруппе PwrDi-
vider. 

3. Перетащите в окно схемы элемент MLANGE в ок-
но схемы и щёлкните левой кнопкой мышки, чтобы 
закрепить его. 

4. Щёлкните мышкой по значку Port на панели инст-
рументов и подключите порт к плечу 1 элемента MLANGE. Аналогично подключите порт к 
плечу 2. Затем подключите порты к плечам 3 и 4, два раза щёлкая мышкой, чтобы развернуть 
эти порты на 180 градусов. Полученная схема показана на рис. 4.34. 

Рис. 4.34

5. Щёлкните мышкой по значку Tune Tool на панели инструментов и, щёлкая мышкой, назначьте 
параметры W, S и L элемента MLANGE для настройки. 

6. Щёлкните мышкой по значку Add New Graph на панели инструментов и создайте прямо-
угольный график с именем Lange Coupler S Parameters. 

7. Откройте окно просмотра проекта, щёлкнув мышкой по панели Project в левой нижней части 
окна. 

8. Щёлкните правой кнопкой мышки по имени созданного графика в окне просмотра проекта и 
выберите Add Measurement. 

9. В открывшемся окне в области Measurement Type отметьте Linear>Port Parameters, в облас-
ти Measurement отметьте S, в поле Data Source Name введите Lange Coupler, в поля To Port 
Index и From Port Index введите 1, отметьте dB и нажмите Apply. Затем в поле To Port Index 
поочерёдно введите 2, 3 и 4, нажимая после каждого ввода Apply. 

10. Нажмите OK. 
11. Щёлкните по значку Analyze на панели инструментов. 
12. Чтобы прямоугольник с обозначениями измеряемых величин на графике не затемнял характе-

ристики, установите курсор на этот прямоугольник, нажмите левую кнопку мышки и перемес-
тите этот прямоугольник выше графика. Затем установите курсор на ромбик посередине левой 



стороны прямоугольника и сдвиньте эту сторону до левого края графика. Аналогично сдвиньте 
правую сторону прямоугольника до правого края графика. Установите курсор на ромбик посе-
редине верхней стороны и сдвиньте эту сторону вниз так, чтобы измеряемые величины разме-
щались в одной строке. Поместите полученный новый прямоугольник над графиком и щёлкни-
те по значку View All на панели инструментов. 

13. Щёлкните по значку Tune на панели инструментов и, двигая движки переменных на блоке на-
стройки, добейтесь нужной характеристики (рис. 4.35). Щёлкните по кнопке Sweep, закройте 
блок настройки и, щёлкнув мышкой по значку Tune Tool на панели инструментов, отмените 
настройку для переменных W, S и L элемента MLANGE. 

4.2.4. Создание эквивалентной схемы диода. 
Рис. 4.35 

Создадим эквивалентную схему диода, учитывающую “паразитные” параметры корпуса диода в 
дополнение к SPICE модели диода. 

1. Щёлкните по значку Add New Schematic на панели инструментов и создайте схему с именем 
Diode. 

2. Откройте окно просмотра элементов, раскройте группу Lumped Element и щёлкните мышкой 
по подгруппе Inductor. 

3. Перетащите элемент IND в окно схемы и щёлкните левой кнопкой мышки, чтобы закрепить 
его. 

4. Два раза повторите п. 3, подключая элементы последовательно. 
5. Раскройте группу Nonlinear и 

щёлкните мышкой по подгруппе 
Diode. 

6. Перетащите элемент SDIODE в ок-
но схемы, щёлкните правой кнопкой 
мышки, чтобы развернуть его, и 
подключите диод к точке между 
второй и третьей индуктивностями. 
Если дважды щёлкнуть мышкой по 
элементу SDIODE и затем в от-
крывшемся окне щёлкнуть по кноп-
ке Show Secondary, можно отредак-
тировать параметры диода. Мы бу-
дем использовать параметры по 
умолчанию. 

7. Щёлкните мышкой по любому эле-
менту IND, чтобы выделить его. 
Щёлкните по значку Copy и затем 
по значку Paste на панели инстру-
ментов, переместите курсор в окно 
схемы, щёлкните правой кнопкой 
мышки, чтобы развернуть скопиро-
ванный элемент, и подключите его к 
нижнему выводу диода. 

Рис. 4.36
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8. Раскройте группу Lumped Element и щёлкните мышкой по подгруппе Capacitor. 
9. Перетащите элемент Cap в окно схемы и поместите его над второй и третьей индуктивностя-

ми. 
10. Снова перетащите элемент Cap в окно схемы, щёлкните правой кнопкой мышки, и подключите 

элемент к точке между первой и второй индуктивностями. 
11. Повторите п. 10 и подключите элемент Cap к свободному выводу последней индуктивности. 
12. Установите курсор на левый вывод первого элемента Cap так, чтобы курсор отображался в ви-

де соленоида, щёлкните левой кнопкой мышки и соедините этот вывод конденсатора с точкой 
между первой и второй индуктивностями. Аналогично соедините второй вывод этого конден-
сатора с правым выводом последней индуктивности. 

13. Таким же образом соедините проводом нижние выводы двух параллельных конденсаторов и 
диода. 

14. Щёлкните мышкой по значку Port на панели инструментов и подключите вход к левому выво-
ду первой индуктивности. Затем подключите порт к свободному нижнему выводу последней 
индуктивности, предварительно развернув его на 90 градусов. Должна получиться схема, пока-
занная на рис. 4.36. 

15. Дважды щёлкая по элементам индуктивностей и емкостей, отредактируйте их параметры, как 
показано на рис. 4.36. 

4.2.5. Создание схемы фильтра нижних частот. 
1. Щёлкните по значку Add New Schematic на панели инструментов и создайте схему с именем 

LPF. 
2. Откройте окно просмотра элементов, раскройте группу Microstrip и щёлкните мышкой по 

подгруппе Lines. 
3. Перетащите элемент MLIN в окно схемы и щёлкните левой кнопкой мышки, чтобы закрепит 

его. 
4. Раскройте группу Lumped Element и щёлкните мышкой по подгруппе Inductor. 
5. Перетащите элемент IND в окно схемы и подключите его к правому выводу элемента MLIN. 
6. Повторите п. 5 и подключите второй элемент IND к правому выводу первого элемента. 
7. Щёлкните мышкой по подгруппе Capacitor, перетащите элемент CAP в окно схемы и подклю-

чите этот элемент к правому выводу второго элемента IND. 
8. Перетащите второй элемент CAP в окно схемы, разверните его на 90 градусов, щёлкнув правой 

кнопкой мышки, и подключите к точке между элементами MLIN и IND. 
9. Щёлкните мышкой по значку Copy и затем по значку Paste на панели инструментов (послед-

ний вставленный элемент CAP должен быть выделен). Подключите скопированный элемент к 
точке соединения между двумя элементами IND. 

10. Поместите курсор на нижний узел ёмкости C2 так, чтобы он отображался в виде соленоида, и 
щёлкните левой кнопкой мышки, чтобы зафиксировать начало провода. Переместите курсор к 
нижнему узлу ёмкости C3 и щёлкните левой кнопкой мышки, чтобы зафиксировать провод. 

11. Щёлкните по значку Ground на панели инструментов, переместите курсор в окно схемы и 
подключите к проводу, соединяющему ёмкости C2 и C3. 

12. Щёлкните по значку Port на панели инструментов, переместите курсор в окно схемы, подклю-
чите порт ко входу схемы и щёлкните левой кнопкой мышки, чтобы зафиксировать. 

13. Снова щёлкните по значку Port на панели инструментов, переместите курсор в окно схемы, 
щёлкните два раза правой кнопкой мышки, чтобы повернуть порт и подключите его к выходу 
схемы. 

14. Дважды щёлкая по элементам схемы, отредактируйте их параметры, как показано на рис. 4.37. 

Рис. 4.37 
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4.2.6. Создание графика и анализ фильтра нижних частот. 
1. Откройте окно просмотра проекта, щёлкнув мышкой по кнопке Project в левой нижней части 

окна. 
2. Щёлкните левой кнопкой мышки по значку Add New Graphs на панели инструментов и в от-

крывшемся окне введите имя графика LPF S Parameters. Нажмите OK.  
3. Щёлкните левой кнопкой мышки по значку Add New Measurement на панели инструментов. 

Откроется диалоговое окно Add Measurement. 
4. В окне списка Measurement Type отметьте Linear>Port Parameters, в окне списка Measure-

ment отметьте S. в поле ввода Data Source Name введите LPF, в поле ввода To Port Index вве-
дите 2, в поле ввода From Port Index введите 1, щёлкните левой кнопкой мышки по переклю-

чателям Mag и dB, нажмите 
Apply. 
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5. Введите 1 в поля ввода To Port 
Index и From Port Index, нажмите 
Apply. 

6. Нажмите OK. 
7. Щёлкните правой кнопкой мышки 

по имени схемы LPF в группе Cir-
cuit Schematics в левом окне про-
смотра проекта и выберите Op-
tions. 

8. В открывшемся окне опций на 
вкладке Frequencies снимите “га-
лочку” в Use project defaults, в по-
ле Start (GHz) введите 0.5, в поле 
Stop (GHz) введите 5, в поле Step 
(GHz) введите 0.05, отметьте Re-
place, нажмите Apply и OK. 

9. Щёлкните левой кнопкой мышки 
по значку Analyze на панели инструментов. Полученный график показан на рис. 4. 38. 

Рис. 4.38 

4.2.7. Создание схемы смесителя. 
При создании схемы смесителя, созданные ранее схемы будем использовать в качестве подсхем. 

1. Щёлкните по значку 
Add New Schematic 
на панели инстру-
ментов и создайте 
схему с именем Diode 
Mixer. 

2. Откройте окно про-
смотра элементов и 
щёлкните мышкой по 
Subcircuits (Подсхе-
мы). 

3. Перетащите в окно 
схемы элемент Lange 
Coupler и щёлкните 
левой кнопкой мыш-
ки. По умолчанию 
все подсхемы ото-
бражаются в виде 

прямоугольника. 
Можно изменить вид 
подсхемы, чтобы он 
был более нагляд-
ным. Для этого дваж-
ды щёлкните по эле-
менту Lange Coupler 

в окне схемы и в открывшемся окне свойств элемента откройте вкладку Symbol. В правой 
верхней строке ввода введите all или system.syf. В правом окне списка символов отметьте 
MLANG@system.syf (рис. 4.39) и нажмите OK. 

Рис. 4.39 

4. Щёлкните по элементу ответвителя Ланге правой кнопкой мышки, выберите Rotate и поверни-
те элемент на 90 градусов против часовой стрелки. 



5. Снова щёлкните по элементу ответвителя Ланге правой кнопкой мышки, выберите Flip и, вра-
щая мышкой против часовой стрелки, создайте зеркальное отображение элемента. Элемент 
должен выглядеть, как показано на рис. 4.40. 

6. Раскройте группу Lumped Element и отметьте Capacitor. Перетащи-
те элемент CAP в окно схемы и подключите его к плечу 3 ответвите-
ля Ланге. 

7. Дважды щёлкните мышкой по элементу CAP и в окне свойств эле-
мента на вкладке Parameters введите C=1.85 pF. Нажмите OK. 

8. Щёлкните по значку Copy и затем по значку Paste на панели инстру-
ментов (элемент CAP должен быть выделен). Подключите скопиро-
ванный элемент к плечу 2 ответвителя Ланге.  

9. Перетащите в окно схемы элемент Diode из группы Subcircuits в ок-
не просмотра элементов и поместите его на свободном месте. 

Рис. 4.40 

10. Дважды щёлкните по элементу Diode и в открывшемся окне свойств элементов откройте 
вкладку Symbol. В правой верхней строке ввода введите all или system.syf. В правом окне спи-
ска символов отметьте Diode@system.syf и нажмите OK. Подключите диод к свободному пра-
вому выводу верхнего конденсатора CAP. 

11. Щёлкните по значку Copy и затем по значку Paste на панели инструментов (элемент диода 
должен быть выделен). Два раза щёлкните правой кнопкой мышки, чтобы развернуть скопиро-
ванный элемент на 180 градусов, и подключите его к свободному правому выводу нижнего 
конденсатора CAP. 

12. В окне просмотра элементов раскройте группу Lumped Element и отметьте Inductor. Перета-
щите элемент Ind в окно схемы и, щёлкнув правой кнопкой мышки, чтобы развернуть элемент, 
подключите его к точке между конденсатором и диодом в нижней цепи смесителя. 

13. Дважды щёлкните мышкой по элементу Ind и в окне свойств элемента на вкладке Parameters 
введите 1.66 nH. 

14. Скопируйте элемент Ind и подключите его к точке между конденсатором и диодом в верхней 
цепи смесителя, предварительно развернув на 180 градусов. 

15. Щёлкните по значку Ground на панели инструментов и подключите землю к свободному ниж-
нему выводу нижней индуктивности. Аналогично подключите землю к свободному верхнему 
выводу верхней индуктивности, предварительно два раза щёлкнув правой кнопкой мышки. 

16. Установите курсор на свободный правый вывод диода так, чтобы курсор отображался в виде 
соленоида, щёлкните левой кнопкой мышки, переместите курсор к правому выводу нижнего 
диода и снова щёлкните мышкой. 

17. Щёлкните мышкой по группе Subcircuits в окне просмотра элементов. Перетащите элемент 
LPF в окно схемы и подключите его к середине провода, соединяющего диоды. 

18. В окне просмотра элементов раскройте группу Ports и отметьте Harmonic Balance. Перетащи-
те порт PORTF в окно схемы и подключите его к плечу 1 ответвителя Ланге. 

19. Перетащите порт PORT_PS1 в окно схемы и подключите его к плечу 4 ответвителя Ланге. 
20. Щёлкните по значку PORT на панели инструментов, разверните его на 180 градусов и под-

ключите его к выходу схемы. 
21. При желании вы можете допол-

нить схему поясняющим текстом. 
Выберите в меню Draw>Add 
Text, переместите курсор в окно 
схемы, где вы собираетесь помес-
тить текст, и щёлкните мышкой. В 
образовавшемся поле ввода вве-
дите нужный текст и затем щёлк-
ните мышкой вне поля ввода. 
Щёлкнув правой копкой по вве-
дённому тексту и выбрав Proper-
ties, вы можете изменить тип 
шрифта и его высоту. Обратите 
внимание, здесь можно использо-
вать русские буквы. 

22. Дважды щёлкните по порту 
PORTF и в открывшемся окне 
свойств введите Freq=4.25 GHz 
(частота сигнала), Pwr=-10 dBm. 
Нажмите OK. 

Рис. 4.41 

23. Дважды щёлкните по порту PORT_PS1 и в открывшемся окне свойств введите PStart=6 dBm, 
PStop=18 dBm, PStep=3 dB (мощность гетеродина). Нажмите OK. 

Должна получиться схема, показанная на рис. 4.41. 
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Откройте окно просмотра проекта, щёлкните правой кнопкой мышки по имени созданной схемы 
Diode Mixer и выберите Options. В открывшемся окне опций схемы на вкладке Frequencies снимите 
“галочку” в Use project defaults, отметьте Replace (Заменить) и Single point (Одна точка). В поле Point 
(GHz) введите 3.75 (частота гетеродина), нажмите Apply и OK. 
4.2.8. Создание графика потерь преобразования. 

1. Щёлкните левой кнопкой 
мышки по значку Add New 
Graph на панели инструмен-
тов и создайте прямоуголь-
ный график с именем Con-
version Loss. 

2. Щёлкните левой кнопкой 
мышки по значку Add 
Measurement на панели ин-
струментов. Откроется диа-
логовое окно Add Measure-
ment (Рис.4.42). 

3. В окне списка Measurement 
Type отметьте Nonlin-
ear>Power, в окне списка 
Measurement отметьте 
LSSnm, в поле ввода Data 
Source Name введите Diode 
Mixer, в поле ввода Port 
(To) введите PORT_3, в по-
ле ввода Port (From) введите 
PORT_1, в верхних полях 

Harmonic Index введите –1 и 1, в 
нижних полях Harmonic Index 
введите 0 и 1, щёлкая по стрелкам 
справа от этих полей, в поле ввода 
Sweep Freq (FDOC) введите 
Freq=3.75 GHz, в поле PORT_2 
введите Use for x-axis, щёлкните 
левой кнопкой мышки по пере-
ключателям dB и Mag, нажмите 
Apply и OK. 

Рис. 4.42 

4. Щёлкните левой кнопкой мышки 
по значку Analyze на панели инст-
рументов. Рассчитанный график 
показан на рис. 4.43. 

Рис. 4.43  
4.2.8. Создание графика изменения выходного напряжения промежуточной часто-
ты во времени. 

1. Щёлкните левой кнопкой мышки по значку Add New Graph на панели инструментов и создай-
те прямоугольный график с именем Mixer IF Output Voltage. 

2. Щёлкните левой кнопкой мышки по знач-
ку Add New Measurement на панели ин-
струментов. Откроется диалоговое окно 
Add Measurement. 

3. В окне списка Measurement Type отметь-
те Nonlinear>Voltage, в окне списка 
Measurement отметьте Vtime, в поле вво-
да Data Source Name введите Diode 
Mixer, в поле ввода Measurement Com-
ponent введите PORT_3, в поле ввода 
Offset введите None, в поле ввода Sweep 
Freq (FDOC) введите Freq=3.75 GHz, в 
поле PORT_2 введите Select with tuner, 
чтобы сразу подключить настройку, на-
жмите Apply и OK. 

4. Щёлкните левой кнопкой мышки по знач-
ку Analyze на панели инструментов. Рас-
считанный график показан на рис. 4.44. Рис. 4.44 
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5. Щёлкнув по значку Tune на панели инструментов и двигая движок переменной Pwr на блоке 
настройки, вы можете наблюдать изменение выходного напряжения в зависимости от мощно-
сти входного сигнала Pwr. 

4.2.9. Спектральный анализ. 
1. Щёлкните левой кноп-

кой мышки по значку 
Add New Graph на па-
нели инструментов и 
создайте прямоуголь-
ный график с именем 
Mixer IF Output Power 
Spectrum. 
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2. Щёлкните по значку 
Add New Measurement 
на панели инструмен-
тов. 

3. В окне списка Meas-
urement Type отметьте 
Nonlinear>Power, в ок-
не списка Measurement 
отметьте Pharm, в поле 
ввода Data Source 
Name введите Diode 
Mixer, в поле ввода 

Measurement Component введите PORT_3, в поле ввода Sweep Freq (FDOC) введите 
Freq=3.75 GHz, в поле PORT_2 введите Select with tuner, отметьте Mag и dBm, нажмите Ap-
ply и OK. 

Рис. 4.45 

4. Щёлкните левой кнопкой мышки по значку Analyze на панели инструментов. Рассчитанный 
график показан на рис. 4.45. 

5. Щёлкнув по значку Tune на панели инструментов и двигая движок переменной Pwr на блоке 
настройки, вы можете наблюдать изменение спектра в зависимости от мощности входного сиг-
нала Pwr. 

 
 



5. Создание топологии схемы 
В Microwave Office для создания топологии схемы используется эффективный объектно-

ориентированный метод программирования. При этом топология тесно связана со схемой и электромаг-
нитными структурами. Топология – это фактически другое представление схемного решения и любые 
модификации, которые делаются в схеме, автоматически и немедленно отображаются и в соответствую-
щей её топологии и наоборот. Это исключает необходимость в сложной синхронизации соответствия 
схемы и её топологии перед моделированием. 

В Microwave Office имеется много возможностей, которые позволяют создавать сложные топо-
логии, типа монолитных СВЧ микросхем (MMIC) и различных типов многослойных структур. Приводи-
мый здесь пример показывает некоторые основные возможности создания топологии. 

Создание топологии в Microwave Office включает следующие основные шаги: 
o Импортирование файла обработки слоя (*.lpf); 
o Редактирование базовой единицы измерения и размера сетки по умолчанию; 
o Импортирование библиотеки элементов топологии; 
o Импортирование и размещение файла данных в схемном решении; 
o Замена изображения схемного элемента в схеме; 
o Размещение микрополосковых проводников в топологии; 
o Назначение элемента топологии элементу схемы; 
o Просмотр топологии; 
o Закрепление элемента топологии; 
o Создание элемента топологии; 
o Управление элементом MTRACE2 (элемент, которым можно чертить изогнутые проводники, 

например, меандровую линию) в топологии; 
o Экспортирование топологии. 

Чтобы создать новый проект: 
1. Выберите в меню File>New Project. 
2. Выберите в меню File>Save Project As. Откроется диалоговое окно Save As. 
3. Наберите имя проекта Layout и нажмите Сохранить. 

5.1. Определение глобальных единиц измерения в проекте. 
Выберите в меню Options>Project Options и в открывшемся окне для частоты введите единицу 

измерения GHz, снимите отметку в Metric units и в поле Length type введите mil. Нажмите OK. 
5.2. Импортирование файла слоя. 

Файл оформления слоя (LPF – Layer Process File) определяет установки по умолчанию для пред-
ставления топологии, включая рисунок слоёв, соединения между слоями, информацию о 3-х мерном 
отображении топологии и отображении электромагнитных структур. Чтобы импортировать файл *.lpf: 

1. Щёлкните левой кнопкой мышки по панели Layout (Топология) в 
нижней части левого окна, чтобы открыть менеджер топологии 
(Layout Manager). 
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2. Правой кнопкой мышки щёлкните по Layer Setup (Установка слоя) 
в менеджере топологии и выберите Import Process Definition (Им-
порт процесса определения). Откроется диалоговое окно Import 
Process Definition. 

3. Найдите папку …\AWR\AWR2009 и дважды щёлкните по ней левой 
кнопкой мышки, чтобы открыть папку. 

Рис. 5.1 

4. Выделите файл MIC_english.lpf и нажмите Открыть. Окно менеджера топологии будет вы-
глядеть, как показано на рис. 5.1. В нижней части окна менеджера топологии отображаются 
слои черчения в том случае, если на рабочем поле открыто окно схемы. 

5.3. Редактирование базовой единицы измерения и размера сетки по умолчанию. 
Базовые единицы измерения являются минимальными единицами измерения, определяющими 

точность топологии. Установленное значение базовых единиц измерения в дальнейшем не должно изме-
няться в процессе работы над проектом. Их изменение может вызвать погрешности округления, что мо-
жет вызвать проблемы в файле топологии. 

Размер сетки важен потому, что размеры многих элементов топологии должны быть кратны раз-
мерам сетки. Размер сетки должен быть равен или больше базовых единиц измерения. При создании то-
пологии схемы вы можете изменять размер сетки, увеличивая или уменьшая его до 10 раз, вводя соот-
ветствующий множитель на панели инструментов при открытом окне топологии схемы. Поэтому размер 
сетки нужно устанавливать в 10 раз больше базовых единиц измерения, чтобы не допустить наличие бо-
лее мелкой сетки, чем базовые единицы измерения. 
Чтобы установить базовые единицы измерения и размер сетки: 

1. Выберите в меню Options>Layout Options или дважды щёлкните левой кнопкой мышки по 
Layout Options в окне менеджера топологии. 



2. В открывшемся окне опций то-
пологии на вкладке Layout (рис. 
5.2) в поле Grid spacing (Интер-
вал сетки) введите 0.1 mil, в поле 
Database unit size (Размер базо-
вой единицы измерения) введите 
0.01 mil. В поле Snap together 
введите Auto snap on parameter 
changes (Автопривязка при из-
менении параметра). Нажмите 
OK. 

5.4. Импортирование библиотеки 
элементов GDSII. 
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Чтобы импортировать библиотеку 
элемент

пкой мышки щёлк-

папку 
WR2009

Библиотеки элементов топологии 
используются в Microwave Office, чтобы 
обеспечивать создание, как многослойных 
физических структур, так и полосков пе-
чатных плат или обработки гибридных 
устройств, а так же для стандартных гра-
фических работ, используемых при обра-
ботке монолитных СВЧ микросхем 
(MMIC) и высокочастотных интегральных 
схем (RFIC). Microwave Office поддержи-
вает формат файлов GDSII для чертежей. 

Рис. 5.2 

ов GDSII: 
1. Правой кно

ните по Cell Libraries (Библио-
теки элементов) в менеджере 
топологии и выберите Import 
GDSII Library (Импортировать 
библиотеку GDSII). Откроется 
диалоговое окно Import GDSII 
Library (Рис. 5.3). 

2. Откройте 
…\AWR\A \Examples и 
дважды щёлкните левой кноп-

кой мышки по файлу packages.gds, чтобы импортировать этот 
файл. 

Рис. 5.3 

3. Если откроется окно предупреждений, нажмите OK. Импортиро-
ванная библиотека будет отображена в окне менеджера топологии, 
как показано на рис. 5.4. 

5.5. Импортирование файла данных. 
Чтобы импортировать файл данных: 

Рис. 5.4 1. Щелкните мышкой по Project в нижней части левого окна. 
2. Правой кнопкой мыш-

ки щёлкните по группе 
Data Files в окне про-
смотра проекта и выбе-
рите Import Data File. 
Откроется диалоговое 
окно Browse For File 
(Рис. 5.5). 

3. Откройте папку 
…\AWR\AWR2009\Exa
mples и дважды щёлк-
ните по файлу 
N76038a.s2p, чтобы 
импортировать его. 
Или выделите этот 
файл и нажмите кнопку 
Открыть. 

 
 Рис. 5.5 



5.6. Создание схемы. 
Чтобы создать схему: 

1. Правой кнопкой мышки щёлкните по группе Circuit Schematics  в окне просмотра проекта и 
выберите New Schematic или щёлкните по значку Add New Schematic на панели инструмен-
тов. 

2. В открывшемся окне введите имя схемы qs layout и нажмите OK. 
5.7. Размещение файла данных в схеме и добавление точки заземления. 
Как только вы импортировали файл данных, он появляется в группе Data Files в окне просмотра проекта 

и как элемент подсхемы Subcircuits в окне просмотра 
элементов, как показано на рис. 5.6. Теперь вы може-
те файл данных вставить в качестве подсхемы в лю-
бую схему, создаваемую в проекте. 
По умолчанию подсхемам присваивается символ 
прямоугольника, который имеет столько узлов, 
сколько имеется портов в исходной схеме. В нашем 
случае подсхема файла данных, которая представляет 
собой S-параметры транзистора, имеет только два 
узла, хотя для транзистора их должно быть три. Для 
подобных случаев Microwave Office предоставляет 

возможность добавить третий узел, который назван Explicit ground node (Явный узел земли). Т.е. нам 
нужно вставить в схему элемент подсхемы N76038a с добавленным третьим узлом. Сделать это можно 
двумя способами. 

Рис. 5.6 

Чтобы поместить файл данных в схеме: 
1. Щёлкните мышкой по панели Elements в ниж-

ней части левого окна, чтобы отрыть окно про-
смотра элементов. 
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2. Щёлкните левой кнопкой мышки по группе 
Subcircuits (Подсхемы). Модели подсхем ото-
бражаются в нижней части левого окна. 

3. Нажмите левой кнопкой мышки на модель 
N76038a и, не отпуская кнопки мышки, пере-
тащите её в окно схемы, отпустите кнопку 
мышки, поместите элемент в окне схемы и 

щёлкните левой кнопкой мышки, чтобы его зафиксировать. 

Рис. 5.7 

4. В окне схемы дважды щёлкните мышкой по вставленному элементу N76038a. 
5. В открывшемся окне свойств элемента откройте вклад-

ку Ground (рис. 5.7). В области Grounding Type от-
метьте Explicit ground node и нажмите OK. Элемент 
подсхемы будет выглядеть, как показано на рис. 5.6. 

Второй способ, возможно, более удобный, поскольку не 
требуется переходить в окно просмотра элементов, заключается в 
следующем: 

1. Щёлкните левой кнопкой мышки по значку SUB  на 
панели инструментов. 

2. Откроется окно Add Subcircuit Element со списком 
всех имеющихся в проекте подсхем (рис. 5.8). 

3. Отметьте N76038a в списке подсхем, затем отметьте 
Explicit ground node и нажмите OK. Результат будет 
таким же, как показано на рис. 5.6. 

 
Рис. 5.8  

5.8. Замена символа элемента. 
Символ подсхемы может быть изменён на FET, чтобы можно было видеть, какие узлы соответ-

ствуют затвору, стоку и истоку. Чтобы изменить символ: 
1. Дважды щёлкните левой кнопкой мышки по элементу подсхемы в окне 

схемы. Откроется диалоговое окно Element Options. 
2. В открывшемся окне опций элемента откройте вкладку Symbol. 
3. В верхней строке ввода типов символов введите all (все) или system.syf, 

щёлкнув по кнопке в правом конце этой строки. В расположенном ниже 
списке символов выделите FET@system.syf и нажмите OK. Результат 
показан на рис. 5.9. 

 
Рис. 5.9  



5.9. Размещение микрополосковых элементов в схеме для топологии. 
Микрополосковые элементы имеют по умолчанию соответствующие им элементы топологии. 

Элементам топологии автоматически присваиваются параметры и размеры в соответствии со значения-
ми, определёнными для каждого параметра. 

Чтобы разместить микрополосковые элементы: 
1. Дважды щёлкните левой кнопкой мышки по подгруппе Microstrip в 

окне просмотра элементов. 
2. Щёлкните левой кнопкой мышки по подгруппе Lines. Модели линий 

отображаются в нижней части левого окна. 
3. Нажмите левой кнопкой мышки на модель MLIN и, не отпуская 

кнопки мышки, перетащите элемент в окно схемы, отпустите кнопку, 
поместите элемент на узле 1 подсхемы N76038a и щёлкните левой 
кнопкой мышки, чтобы зафиксировать его (Рис.5.10). 

Рис. 5.10 

4. Теперь щёлкните левой кнопкой мышки по подгруппе Junctions (Сочленения) в группе Micro-
strip в окне просмотра элементов. Модели сочленений отображаются в нижней части левого 
окна. 

 
Примечание. Элементы, имеющие на конце имени $, наследуют параметры от других элемен-

тов, с которыми они соединяются. Элементы, имеющие на конце имени X, созданы электромагнитным 
моделированием с параметрами, сведёнными в таблицу. Например, MTEEX$ – это Т – сочленение в мик-
рополосковой линии, созданное электромагнитным моделированием, которое наследует ширину полосок 
от линий, с которыми оно соединяется. 
 

5. Нажмите левой кнопкой мышки на модель MTEE$ и, не отпуская кнопки мышки, перетащите 
элемент в окно схемы, отпустите кнопку, поместите элемент так, чтобы соединить его с левым 
узлом элемента MLIN, как показано на рис. 5.11 и щёлкните левой кнопкой мышки, чтобы за-

фиксировать его. 
6. Щёлкните левой кнопкой мышки по подгруппе 

Lines, перетащите элемент MTRACE2 в окно 
схемы и соедините его с узлом 1 элемента 
MTEE$ и щёлкните левой кнопкой мышки, 
чтобы зафиксировать элемент. 

7. Перетащите элемент MLEF в окно схемы, 
щёлкните три раза правой кнопкой мышки, что-
бы повернуть элемент, поместите его на узел 3 
элемента MTEE$ и щёлкните левой кнопкой 
мышки, чтобы зафиксировать (рис. 5.12). 

8. Дважды щёлкните левой кнопкой мышки по 

Рис. 5.11
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элементу MTRACE2 в окне схемы, чтобы от-
крыть диалоговое окно Element Options. На 
вкладке Parameters введите следующие пара-
метры: W=10 mil, L=200 mil, BType=2 и M=0.6. 
Нажмите OK. 

9. Дважды щёлкните мышкой по элементу MLIN, 
затем по элементу MLEF, и отредактируйте их 

параметры следующим образом. Для элемента MLIN введите W=10 mil, L=100 mil. Для эле-
мента MLEF введите W=20 mil, L=150 mil. 

Рис. 5.12 

10. Щёлкните левой кнопкой мышки по подгруппе Substrates (Подложки) в окне просмотра эле-
ментов. Модели подложек отображаются в нижней части левого окна. 

11. Нажмите левой кнопкой мышки на модель 
MSUB и, не отпуская кнопки мышки, перета-
щите элемент в окно схемы, отпустите кноп-
ку, поместите элемент, как показано на 
рис.5.13 и щёлкните левой кнопкой мышки, 
чтобы зафиксировать. 

12. Дважды щёлкните левой кнопкой мышки по 
элементу MSUB в окне схемы, чтобы открыть 
диалоговое окно Element Options. Введите 
Er=9.8, H=10 mil, T=0.1 mil, Rho=1, Tand=0 
и ErNom=9.8. Нажмите OK. Рис. 5.13 



13. Щёлкните левой кнопкой мышки по значку Port на панели инструментов, переместите курсор 
в окно схемы, поместите порт на левом узле элемента MTRACE, как показано на рис. 5.14 и 
щёлкните левой кнопкой мышки, чтобы зафиксировать. 

14. Снова щёлкните левой кнопкой мышки по 
значку Port на панели инструментов, пере-
местите курсор в окно схемы, щёлкните три 
раза правой кнопкой мышки, чтобы развер-
нуть порт, поместите его на узле 2 элемента 
SUBCKT и щёлкните левой кнопкой мыш-
ки, чтобы зафиксировать. 

15. Чтобы закончить схему, щёлкните левой 
кнопкой мышки по значку Ground на пане-
ли инструментов, переместите курсор в ок-
но схемы, поместите землю на узле 3 эле-

мента SUBCKT и щёлкните левой кнопкой мышки, чтобы зафиксировать (Рис. 5.14). 

Рис. 5.14 

5.10. Назначение топологического чертежа ячейки элементу схемы. 
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сделать это: 
Элементу схемы может быть поставлен в соответствие топологический чертёж ячейки. Чтобы 

1. Дважды щёлкни-
те по элементу 
N76038a в окне 
схемы, чтобы от-
крыть диалоговое 
окно Element Op-
tions. 

2. Откройте вкладку 
Layout этого ок-
на (рис. 5.15). 

3. В поле ввода Li-
brary Name вве-
дите packages, 
щёлкнув мышкой 
по кнопке в пра-
вом конце этого 
поля, и в списке 
топологических 

ячеек отметьте 
Alpha_212_3. 

Нажмите OK. Рис. 5.15 

5.11. Просмотр топологии. 
Чтобы просмотреть топологию: 

1. При активном окне схемы выберите в меню View>View Layout или щёлкните левой кноп-
кой мышки по значку View Layout  на панели инструментов. Топология будет показана в 
окне топологии на рабочем поле. Она может отображаться в беспорядочном виде, где пра-
вильные соединения отдельных топологических элементов показаны красными линиями. В 

таком случае сделайте следующее: 
2. Установите курсор мышки левее и 

выше топологии, нажмите левую 
кнопку мышки и, не отпуская 
кнопки, переместите курсор правее 
и ниже топологии так, чтобы вся 
топология попала в образовавший-
ся прямоугольник. Или выберите в 
меню Edit>Select All. Вся тополо-
гия должна быть выделена. 

3. Выберите в меню Edit>Snap To-
gether (Редактировать>Связать 
вместе) или щёлкните по значку 

Snap Together  на панели инструментов, чтобы связать вместе все элементы топологии и 
тем самым упорядочить топологию. Созданная топология показана на рис. 5.16. 

Закрепление элемента топо

Рис. 5.16 

5.12. логии. 
ыми свойствами, которые определяют, каким образом 

каждый
Элементы топологии обладают определённ
 элемент топологии соединяется с другими элементами при упорядочении топологии. Одним из 

таких свойств является возможность закрепить элемент топологии на установленном месте. Причём воз-
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д

 В окне топологии схемы щёлкните левой кноп-
по топологическому элементу 

Anchor и нажмите OK. 

можны два варианта такого закрепления: Anchor (Прикрепить) и Freeze (Зафиксировать). Если ис-
пользовать закрепление Anchor, то при любых 
изменениях в расположении элементов в схеме 
или изменении их параметров с последующим 
редактированием топологии командой Snap To-
gether, чтобы снова соединить вместе изменён-
ное расположение соответствующих элементов 
топологии, то закреплённые элементы будут ос-
таваться на прежнем месте. Все остальные эле-
менты топологии будут “подгоняться” под закре-
плённые элементы. Однако закреплённый этим 
способом элемент топологии можно перемещать 
мышкой или координатным вво ом. Если же 
элемент топологии закрепить командой Freeze, 
то такой элемент нельзя переместить никаким 
способом. 

Чтобы закрепить элемент топологии: Рис. 5.17 
1.

кой мышки 
Alpha_212_3, чтобы выделить его. Затем щёлк-
ните по этому элементу правой кнопкой мышки 
и выберите Shape Properties (Свойства формы). 
Откроется диалоговое окно Cell Options (рис. 
5.17). 

2. На вкладке Layout этого окна отметьте Use for Рис. 5.18 

Элемент топологии теперь закреплён и отображается в топологии с символом закрепления, как 
показано на рис. 5.18. 
5.13. Черчение топологического чертежа элемента топологии. 

Чтобы создать топологический чертёж элемента топологии: 
1. Щёлкните левой кнопкой мышки по панели Layout в нижней части левого окна, чтобы ак-

тивизировать менеджер топологии. 
2. Щёлкните правой кнопкой мышки по подгруппе packages (многослойные структуры) в 

группе Cell Libraries (Библиотеки элементов) и выберите New Layout Cell (Новый элемент 
топологии) во всплывающем меню. Откроется диалоговое окно Create New Layout Cell 
(Создание нового элемента топологии). 

3. Введите chip cap (чип конденсатора) в поле Enter the name of the cell 
(Ввод имени элемента) и нажмите OK. На рабочем поле откроется окно 
для черчения. Возможно, в библиотеке packages такой элемент уже есть. 
В этом случае щёлкните по нему правой кнопкой мышки и выберите De-
lete Layout Cell, чтобы создать этот элемент заново. 

4. Щёлкните мышкой по кнопке в правом конце поля ввода Grid Spacing на 
панели инструментов и введите в это поле множитель 10х (рис.5.19). Этот 
множитель определяет размер клеток сетки. По умолчанию при выбран-
ной системе единиц измерения длины он равен 0.1 mil. Множитель 10х 
увеличивает размер клеток сетки в 10 раз, т.е. он будет равен 1 mil. Если 
этого поля на панели инструментов нет, щёлкните правой кнопкой мышки 
по панели инструментов и отметьте Cell Edit. 

Рис. 5.19 

5. Щёлкните левой кнопкой мышки по квадрату 1_0->Copper (Медь) в ниж-
ней части окна менеджера, чтобы назначить медь для активного слоя, как 
показано на рис. 5.20 (не щёлкайте по лампочке, т.к. такой щелчок опре-

деляет слой для показа или скрытия). 
Рис. 5.20 

6. Щёлкните левой кнопкой мышки по окну черчения на ра-
бочем поле, чтобы сделать его активным. 

7. Выберите в меню Draw>Rectangle (Чер-
тить>Прямоугольник) или щёлкните по значку Rectangle 
на панели инструментов. Рис. 5.21 

8. Переместите курсор в окно черчения, затем нажмите кла-
вишу Tab на клавиатуре. Откроется диалоговое окно En-
ter Coordinates (Ввод координат, рис. 5.21). 

9. Введите значения 0 и 10 в поля x и y соответственно и 
нажмите OK. 

10. Нажмите клавишу Tab снова, чтобы открыть диалоговое 
окно Enter Coordinates (рис. 5.22). 
Рис. 5.22 



11. Введите значения 10 и -10 в поля dx и dy соответственно и нажмите OK. Полученный ри-
сунок показан на рис. 5.23. 

12. Щёлкните левой кнопкой 
мышки по квадрату 10_0-
>Footprint (Контур) в нижней 
части окна менеджера, чтобы 
создать контур пустого прямо-
угольника на плате. 

13. Выберите в меню 
Draw>Rectangle или щёлкните 

по значку Rectangle на панели инструментов. 

Рис. 5.23 Рис. 5.24 

14. Переместите курсор в окно черчения, затем нажмите клавишу Tab или Space на клавиатуре. 
Откроется диалоговое окно Enter Coordinates. 

15. Введите значения 10 и 10 в поля x и y соответственно и нажмите OK. 
16. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter Coordinates. 
17. Введите значения 20 и -10 в поля dx и dy соответственно и нажмите OK. Полученный чер-

тёж показан на рис. 5.24. 
18. Щёлкните левой кнопкой мышки по лево-

му медному квадрату в окне рисунка и на-
жмите клавиши Ctrl+C и затем Ctrl+V или 
щёлкните левой кнопкой мышки по значку 
Copy и затем по значку Paste на панели 
инструментов, чтобы скопировать и вста-
вить прямоугольный проводник. Нажмите 

левой кнопкой мышки на скопированный проводник и, не отпуская кнопки мышки, пере-
местите его к правому краю пустого прямоугольника топологии и щёлкните левой кнопкой 
мышки, чтобы зафиксировать. Полученная топология показана на рис. 5.25. 

Рис. 5.25 

5.14. Добавление портов к созданному элементу топологии. 
Порты в элементе топологии определяют грани, по которым данный элемент соединяется с дру-

гими топологическими элементам. Направление стрелки порта показывает направление, по которому 
происходит соединение топологического элемента с соседними топологическими элементами. 

Чтобы добавить порты к соз-
данному элементу топологии: 

1. Выберите в меню 
Draw>Cell Port (Чер-
тить>Порт элемента) или 
щёлкните левой кнопкой 
мышки по значку Cell 
Port на панели инстру-

ментов. 

Рис. 5.27 Рис. 5.26 Рис. 5.28

2. Переместите курсор в окно черчения. Нажав и удерживая клавишу Ctrl, поместите курсор 
на нижний левый угол левого квадратного проводника так, чтобы небольшой квадратик 
появился на этом углу.  

3. Не отпуская клавишу Ctrl, нажмите ле-
вую кнопку мышки (соответствующее 
изображение показано на рис. 5.26) и, не 
отпуская её, двигайте курсор к верхнему 
левому углу проводника, пока другой 
квадрат появится на этом углу (рис. 5.27). 
Отпустите кнопку мышки и клавишу 
Ctrl. Щелкните мышкой на свободном 

месте в окне черчения. Добавленный порт показан на рис. 5.28. 

Рис. 5.29 

4. Повторите шаги с 1-го по 3-ий, чтобы поместить порт на противоположной стороне рисун-
ка, но начните с верхнего правого угла и двигайте курсор к правому нижнему углу. 

5. Закройте окно черчения. Будет выведен запрос, хотите ли вы сохранить нарисованный эле-
мент. Нажмите Yes, чтобы сохранить. Полученная топология показана на рис. 5.29. 

5.15. Добавление в схему конденсатора и назначение ему элемента топологии chip 
cap. 

Чтобы добавить в схему конденсатор и назначить ему элемент топологии chip cap: 
1. В окне схемы установите курсор на входной порт, нажмите и удерживайте клавишу Ctrl, 

нажмите левую кнопку мышки и, не отпуская её, переместите порт на свободное место в 
схеме, прервав его связь со схемой. 

2. Нажмите панель Elements в нижней части левого окна, чтобы открыть окно просмотра эле-
ментов. 
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3. Дважды щёлкните левой кнопкой мышки по группе Lumped Element (Сосредоточенные 
элементы), чтобы раскрыть её, затем щёлкните левой кнопкой мышки по подгруппе Capaci-
tor (Конденсаторы), чтобы отобразить элементы конденсаторов в нижней части левого ок-

на. 
4. Нажмите левой кнопкой мышки 

на элемент CAP и, не отпуская 
кнопки мышки, перетащите его 
в окно схемы, отпустите кнопку 
мышки, подключите элемент 
CAP к левому узлу элемента 
MTRACE и щёлкните левой 
кнопкой мышки, чтобы зафик-
сировать. Рис. 5.30 

5. Установите курсор на входной 
порт, нажмите левую кнопку 
мышки и подключите порт ко 
входу схемы. Должна получить-
ся схема, показанная на рис. 
5.30. 

6. Дважды щёлкните левой кноп-
кой мышки по элементу CAP в 
окне схемы. Откроется окно 
Element Options (Опции эле-
мента). 

7. В этом окне откройте вкладку 
Layout. 

8. В поле Library Name введите 
packages и в списке элементов 
отметьте chip cap (рис. 5.31). 
Нажмите OK. 
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.32). 

виши Esc отменяет процесс трассировки). 

9. Выберите в меню View>View 
Layout (Показать>Показать то-
пологию) или щёлкните по 
кнопке View Layout на панели 

инструментов. Новая топология будет 
отображена на рабочем поле (рис. 5

Рис. 5.31

10. Если топологические элементы не соеди-
нены должным образом, о чём говорит 
наличие красных линий на топологии, вы-
берите в меню Edit>Select All и затем 
щёлкните по значку Snap Together на па-
нели инструментов. Рис. 5.32

5.16. Трассировка элемента MTRACE2 в окне топологии. 
Элемент MLIN – это прямоугольный элемент, чья ширина задаётся и может изменяться в топо-

логии, но редактировать форму этого элемента (например, делать изгибы) нельзя. Элемент MTRACE2 – 
это элемент, топология которого может быть отредактирована, чтобы иметь изгибы со скошенными 
краями. Элемент MCTRACE – это элемент, топология которого может быть отредактирована, чтобы 

иметь изгибы со скруглёнными краями. 
Чтобы выполнить трассировку топологии элемента 

MTRACE2: 
1. Дважды щёлкните левой кнопкой мышки по 

элементу топологии MTRACE2. На проводни-
ке появятся синие ромбики, как показано на 
рис. 5.33. 

Рис. 5.33 2. Поместите курсор на крайний правый ромбик 
так, чтобы он отображался в виде двойной 
стрелки. Дважды щёлкните левой кнопкой 
мышки, чтобы активизировать инструмент 
трассировки. 

3. Переместите курсор, не нажимая кнопки мыш-
ки, в желательную точку и щёлкните левой 
кнопкой мышки, чтобы зафиксировать (рис 
5.34). (Щелчок правой кнопкой мышки удалит 
последнюю точку трассировки, нажатие кла-Рис. 5.34
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вки к точкам нужного маршрута, щёлкая левой 

ие 

5.17. . 
и-

ов топологии в различных 
конфигу

а-

out Cell Snap Op-

 некоторых элементов топологии. Устано-

вую кнопку мышки и переместите этот элемент, как показано на рис. 5.37. 

о грани этих элементов не соединены. 

и соединены вместе. 

Вся топология будет 

4. Продолжайте двигать инструмент трассиро
кнопкой мышки, чтобы фиксировать точки 
изгиба, затем дважды щёлкните левой кнопкой 
мышки, чтобы закончить трассировку. Пример 
полученной топологии показан на рис. 5.35. 

5. Если топологические элементы не соединены 
должным образом, о чём говорит налич
красных линий на топологии, выберите в меню 
Edit>Select All и затем щёлкните по значку 

Snap Together на панели инструментов. 
Опции привязки элементов топологии

Рис. 5.35 

Опции привязки определяют соед
нения элемент

рациях. Эти опции вы можете уста-
новить в диалоговом окне Layout Options. 

1. Выберите в меню Options> 
Layout Options. Откроется ди
логовое окно Layout Options 
(рис. 5.36). 

2. На вкладке Layout этого окна в 
области Lay
tions (Опции привязки элемен-
тов топологии) в поле Snap to-
gether (Привязать вместе) вве-
дите Manual snap for selected 
objects only (Привязка вручную 
только для выделенных объек-
тов), щёлкнув по кнопке в конце 
этого поля. Нажмите OK. 

3. Чтобы просмотреть действие 
этой установленной опции

Рис. 5.36 
, изменим положение

вите курсор на элемент топологии, соответствующий элементу схемы MLEF, нажмите ле-

4. Повторите п. 3 для элементов MTRACE2 и конденсатора chip cap, как показано на рис 
5.38. Красные линии показывают, чт

Рис. 5.38 Рис. 5.37 

5. Чтобы соединить элементы, нажмите клавишу Shift и щёлкните мышкой по элементам 
MLEF, MTRACE2 и MTEE$ в окне топологии. 

Рис. 5.40 
Рис. 5.39 

6. Щёлкните мышкой по значку Snap Together на панели инструментов. Результат показан на 
рис. 5.39. Заметьте, что не все элементы топологи

7. Нажмите клавиши Ctrl+A, чтобы выделить всю топологию. 
8. Щёлкните мышкой по значку Snap Together на панели инструментов. 

соединена (рис. 5.40). 
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способ u fit (подогнать привязку). При выполнении этой команды изменяет-
ся марш

Если элемент конденсатора не соединён с элементом MTRACE2, их можно соединить и другим 
ом, используя команду snap t
рут элемента MTRACE2, чтобы обеспечить соединение, вместо того, чтобы переместить эле-

мент конденсатора, как в предыдущем случае. Это может выглядеть следующим образом. 
1. Установите курсор на элемент конденсатора, нажмите левую кнопку мышки и переместите 

этот элемент, как показано на рис. 5.41. 
2. Щёлкните мышкой по элементу топологии MTRACE2, чтобы выделить его. 

Щёлкните мышкой по значку Snap to fi  3. t на панели инструментов. Результат
рис. 5.42. 

 показан на 

ю Op-

),  

 

топол
жете
меню

Рис. 5.41 Рис. 5.42 
5.18. Экспорт топологии. 

Чтобы экспортировать топологию: 
1. Выберите в мен

tions>Drawing Layers (Оп-
ции>Слои черчения  чтобы
определить слои, которые 
надо экспортировать в файл. 
Откроется диалоговое окно 
Drawing Layer Options 
(Опции слоя черчения). 

2. В левой части окна щёлкни-
те мышкой по File Export 
Mappings (Соответствие 
файла экспорта) и отметьте
DXF. В столбце Write 
Layer (Записать слой) от-
метьте Copper (Медь) и 
снимите все остальные “га-
лочки” (рис. 5.43). Нажмите 
OK. 

3. Выберите в меню Lay-
out>Export (Тополо-
гия>Экспорт). Откроется 
диалоговое окно Export 

Рис. 5.43 

Layout (рис. 5.44). 
4. В поле Тип файла введите 

DXF (Flat*.dxf), щёлкнув 
левой кнопкой мышки по 
кнопке в правом конце этого 
ляпо . 

5. В поле Имя файла введите 
qs Layer и нажмите Сохра-
нить, чтобы экспортировать 
слой меди в файл DXF. 

На этом пример моделирования 
огии закончен. При желании вы мо-

 сохранить свою работу, выбрав в 
 File>Save Project . 

 

Рис. 5.44 



 84 84

6. Электромагнитное моделирование (EMSight) 
Электромагнитное моделирование (EM) использует уравнения Максвелла для определения ха-

рактеристик устройства по его заданной физической геометрии. Для выполнения электромагнитного мо-
делирования можно использовать встроенные решающие устройства или решающие устройства из про-
граммных продуктов других производителей, поддерживающих интерфейс “EM Socked” (“Канал элек-
тромагнитного моделирования”). 

Решающее устройство EMSight использует метод моментов для электромагнитного анализа 
электромагнитных структур. Могут анализироваться структуры с неограниченным количеством слоёв и с 
неограниченным числом портов. Структура анализируется в прямоугольном корпусе. При анализе авто-
матически создаётся электрическая сетка с различным размером ячеек. В местах, где плотность тока из-
меняется, создаются ячейки с малыми размерами. Там, где плотность тока не изменяется, устанавлива-
ются ячейки с большими размерами. Пользователь может просмотреть автоматически созданную сетку 
и, при необходимости, изменить её плотность. Минимальный размер ячеек электрической сетки опреде-
ляется размером ячеек геометрической сетки, которые задаются установкой параметров Grid_X и 

Grid_Y в свойствах корпуса. Все топологиче-
ские формы электромагнитной структуры 
должны совпадать с геометрической сеткой. 
Чем меньше размер ячеек сетки, тем точнее 
выполняется анализ, но тем больше времени 
требуется для анализа. Поэтому рекомендуется 
сначала выполнять анализ по возможности с 
крупными ячейками сетки, затем размер ячеек 
уменьшить. Хорошая точность анализа обеспе-
чивается при размерах сетки меньше 1/10 дли-
ны волны на верхней частоте диапазона анали-
за. Кроме того, на размер ячеек электрической 
сетки влияют опции встраивания сетки, кото-
рые определены на вкладке Mesh диалогового 
окна EM Options (рис. 6.1). Чтобы открыть это 
окно выберите в меню Options>Default EM 
Options. 

В области Meshing Density (Плотность 
сетки) вы можете определить плотность 
), или High (Высокая). По умолчанию установ-

 точность, можно использовать плотность High 
все ячейки сетки имеют одинаковый минималь-
внизу окна в области Cells per subsection limits 

 сетки. 
т для всех электромагнитных структур в проек-

вы можете установить эти опции, которые будут 
го щёлкните правой кнопкой мышки по имени 
, откройте вкладку Mesh и снимите “галочку” в 
 эти опции для любой топологической формы в 
 левой кнопкой мышки по выбранной топологи-
 ней правой кнопкой мышки, выберите Shape 

Properties, откройте вкладку Mesh и снимите “галочку” в Use default properties. 
Просмотреть встраиваемую сетку до выполнения анализа можно, щёлкнув правой кнопкой 

мышки по имени структуры в окне просмотра проекта и выбрав Add Annotation. В диалоговом окне Add 
Annotation выберите EM_MESH в области Measurement. Сетка отображает только в 3-х мерном пред-
ставлении структуры. 

Для возбуждения электромагнитной структуры должны быть установлены порты. Порт пред-
ставляет собой две клеммы для возбуждения входов и выходов устройства. Физически порт – это зазор, к 
которому подключается источник напряжения для возбуждения токов. Токи затем вычисляются при ана-
лизе электромагнитной структуры. Линейные параметры порта (например, S-параметры) определяются 
из вычисленных токов. 

В EMSight имеется три вида портов: порты края (edge ports), порты перемычки (via ports) и внут-
ренние порты (internal ports). 

Порт края можно добавить только к краю проводника, который совпадает с краем корпуса. Что-
бы добавить порт края, при активном окне электромагнитной структуры выберите в меню Draw>Add 
Edge Port или щёлкните по значку Edge Port на панели инструментов. Поместите курсор на край про-
водника, на который нужно установить порт, так, чтобы отображался небольшой прямоугольник, и 
щёлкните мышкой, чтобы закрепить порт. Нумерация портов делается автоматически по мере их уста-
новки. Если нужно изменить нумерацию портов, удалите все порты и затем снова установите их в 

встраиваемой сетки Low (Низкая), Normal (Нормальная
лена плотность Normal. Если требуется очень высокая
или No Variable Mesh. При выборе No Variable Mesh 
ный размер. Минимальные и максимальные установки 
определяют минимальный и максимальный размеры ячеек

Опции, установленные в окне рис. 6.1, действую
те. Для любой электромагнитной структуры в проекте 
действовать только для выбранной структуры. Для это
структуры в окне просмотра проекта, выберите Options
Use default properties. Более того, вы можете установить
любой электромагнитной структуре. Для этого щёлкните
ческой форме, чтобы выделить её. Затем щёлкните по

Рис. 6.1 
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нужном порядке. Чтобы удалить порт, щёлкните по квадратику порта мышкой, чтобы выделить его, и 
 порты мож-

лкните по квад-

котором установлен порт. Чтобы сместить референс-

стояния
плоско с
установ
ках, то

такую же 
тов, установленных на этой стороне. 

Любой установленный порт может быть опреде
оконечная нагрузка (termination). Вычисление S-параметр
числение плотности тока и анализ антенны зависит. Чтоб
вите или снимите “галочку” в Excitation Port в окне рис.
лить относительную мощность и фазу в области Excitati
ance. Для порта оконечной нагрузки можно определить 
Возможность использовать порты оконечной нагрузки д
падающей волны в структуре. Но для вычисления S-пара
та 50 Ом. Если нужно выполнить анализ работы на другу
туру в схему в качестве подсхемы и там измените парамет

Порты перемычки используются, чтобы организо или вывод) через верхнюю или ниж-
нюю крышки корпуса. Например, такой порт может использов
зонд. 

ны использоваться с осторожностью. 
Чтобы 

ждый внутренний порт 

азан простейший пример внутреннего порта для подключения элементов с двумя 

казано, как подключить резистор к внутреннему порту. Конец резистора, 

порта, должен быть соединён с землёй в схеме. Если выполнить анализ 

нажмите клавишу Delete. Перенумеровать
но и не удаляя их. Просто дважды щё
ратику порта и в открывшемся окне Properties (рис. 
6.2) в области Port Attributes введите новый номер 
порта в поле Port Number. После установки порта 
референсная плоскость устанавливается на краю, на 

ную плоскость, щёлкните мышкой по квадратику пор-
та, установите курсор на сторону квадратика, которая 
лежит на грани корпуса так, чтобы курсор отображал-
ся в виде двойной стрелки, нажмите левую кнопку 
мышки и сместите курсор внутрь корпуса на нужную 
величину. Можно сместить референсную плоскость и 
иначе. В окне рис. 6.2 в области De-embedding Op-
tions в поле Ref. Plane Distance введите величину рас-

, на которое нужно сдвинуть референсную 
сть. Е ли на одной и той же стороне корпуса 
лено несколько портов на разных проводни-

 при смещении референсной плоскости на лю-
величину автоматически смещается у всех пор-

лён как порт возбуждения (excitation) или как 
ов порта от этой установки не зависит, но вы-
ы установить указанный характер порта устано-
 6.2. Для порта возбуждения вы можете опреде-
on, а также полный импеданс в области Imped-
только полный импеданс в области Impedance. 
аёт возможность просмотреть анимацию токов 
метров всегда используется сопротивление пор-
ю нагрузку, вставьте электромагнитную струк-
ры порта схемы. 
вать ввод (

Рис. 6.2

бом из этих портов, референсная плоскость на 

аться для возбуждения антенны через 

Чтобы установить такой порт, в окне менеджера топологии отметьте Via. Затем в меню выберите 
Draw>Add Via Port или щёлкните по значку Via Port на панели инструментов. Затем поместите курсор 
мышки на элемент топологии, где нужно установить порт и начертите прямоугольник. После создания 
порта вы можете изменить его размеры, дважды щёлкнув мышкой по порту. 

Внутренние порты являются самыми сложными и долж
создать внутренний порт, щёлкните по многоугольнику, который должен быть отрицательной 

клеммой для внутреннего порта, чтобы его выделить, и затем выберите в меню Draw>Add Internal Port. 
Переместите курсор на сторону многоугольника, на которой должен быть 
расположен порт, и щёлкните левой кнопкой мышки. Положительная 
клемма будет обозначена знаком “+”. 

Внутренние порты обычно используются для подключения в схе-
ме сосредоточенных элементов (резисторов, диодов и др.), размеры кото-
рых должны быть много меньше длины волны. Ка
имеет свою собственную землю, не связанную с землёй всех других пор-
тов. Землёй для внутреннего порта является отрицательная клемма этого 
порта. 

На рис. 6.3 пок

Рис. 6.3

клеммами. Должно быть два многоугольника, расположенных рядом. 
Внутренний порт должен быть установлен на общей стороне этих много-
угольников. Устанавливать внутренний порт на свободной стороне много-
угольника нельзя, т.к. результаты будут бессмысленными. На рис. 6.4. по-

который должен быть подключён к отрицательной клемме внутреннего 

этой схемы на достаточно низкой частоте, на которой распределённая 
часть электромагнитной структуры мала, рассчитанные S-параметры бу-
дут такими, как будто резистор включён между портами 1 и 2. Т.е. между 
сторонами многоугольников как бы создаётся зазор, в который включается 
резистор. 

Любой порт имеет неоднородность, на которой возбуждаются Рис. 6.4 
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используется процедура исключения неоднородн
ществить в порте края (Edge Port). 

Имеется два метода исключения неодноро
При стандартном методе референсные п

большом удалении от края корпуса, чтобы возник
ний затухли до референсной плоскости. Обычно
мендуют брать примерно равным двум толщинам
ный анализ топологии и подводящих отрезков в 
подводящих линий берётся равной удвоенному ра
матрицы топологии исключаются результаты ана
дуре исключения неоднородностей результирую
ренсными плоскостями без подводящих отрезков
референсная плоскость расположена в точке подк
порта. Этот метод может терпеть неудачу, если 
четверти длины волны на анализируемой частот
пользуется при любом количестве портов на одной

Быстрый метод исключения неоднородно
Его недостаток в  этот метод можно испо
ется только один и на одной стороне к

корпуса. Но если недалеко от порта имеется неоднородность, то 
получен

выберите Options. На 

embed (1 port/side). 

х случаях исключить неод-

 на рис. 6.6, и затем создать схему, 

 AFS, выберите в меню 

умолчанию частотный диапазон тот же, 

высшие типы волн. Это вносит погрешность в результаты анализа. Чтобы устранить эту погрешность, 
ости (de-embedding). Проще всего эту процедуру осу-

дности порта: стандартный и быстрый. 
лоскости должны быть расположены на достаточно 
ающие в неоднородности порта высшие типы колеба-

 расстояние от порта до референсной плоскости реко-
 подложки. В этом методе отдельно выполняется пол-
корпусах разного размера. Длина корпуса для анализа 
сстоянию от порта до референсной плоскости. Затем из 
лиза подводящих отрезков. Таким образом, при проце-
щая матрица получается для структуры между рефе-
. Если удаляемый отрезок имеет нулевую длину (т.е. 
лючения порта), то устраняется только неоднородность 
расстояние от порта до референсной плоскости равно 
е. Стандартный метод является универсальным и ис-
 стороне корпуса. 
сти не требует отдельного анализа подводящих линий. 
льзовать только, если на каждой стороне корпуса име-
орпуса портов несколько, автоматически используется 

стандартный метод. При использовании быстрого алгоритма референсная плоскость не обязательно 
должна быть установлена далеко от края 

 том, что
порт. Есл

ные результаты будут иметь некоторую погрешность из-за взаимодействия этой неоднородности 
с неоднородностью порта. Этот метод может терпеть неудачу, если длина корпуса близка к половине 
длины волны на анализируемой частоте. Если такая ситуация встречается, выводится окно с предупреж-
дением. По умолчанию быстрый метод исключения отключён. Чтобы его включить, выберите в меню 

Options>Default EM 
Options или щёлкните 
правой кнопкой мышки 
по имени структуры в 
окне просмотра проекта, 

вкладке EMSight (рис. 
6.8) отметьте Use fast de-

Для портов пе-
ремычки автоматическо-
го исключения неодно-

родности порта нет, и это влияет на результаты анализа. Однако в некоторы

Рис. 6.5 
Рис. 6.6

нородность можно вручную, создав дополнительную 
структуру и затем создав схему с обеими структурами. 
Например, требуется выполнить анализ структуры Struc-
ture, показанной на рис. 6.5. Чтобы исключить неодно-
родность порта перемычки, нужно создать структуру 
Standard, показаннуюРис. 6.7 
показанную на рис. 6.7. 

Для ускорения анализа электромагнит-
ных структур введено усовершенствованное 
свиппирование частоты (Advanced Frequency 
Sweep – AFS). По умолчанию эта опция отклю-
чена. Чтобы включить
Options>Default EM Options и на вкладке EM-
Sight отметьте Enable AFS. Опция будет дейст-
вовать для всех структур в проекте. Можно 
включить/отключить эту опцию для любой 
структуры в проекте. Для этого щёлкните пра-
вой кнопкой мышки по имени структуры в окне 
просмотра проекта, выберите Options и на 
вкладке EMSight отметьте Enable AFS (рис. 
6.8). 

Здесь можно установить следующие 
опции: 

• Частотный диапазон (Start, Stop). По 

что определён для анализа электромаг-Рис. 6.8 
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r Tol (dB)). Определяет допустимую ошибку аппроксимации. По 

•

шибка интерполяции. Выполняется 

6.1. Моделирование встречноштыревого микрополоск
Этот пример показывает, как использовать электромагнитное моделиро

для проектирования встречноштыревого микрополоскового фильтра. Такое 
следующие основные шаги: 

o Создание электромагнитной структуры; 
o Определение корпуса; 
o Создание топологии; 
o Моделирование межслойных переходов; 
o Просмотр структуры в трёхмерном изображении; 

еделение портов и установка референсных плоскостей; 
o Конфигурирование структуры сетк

o Выполнение усовершенствованной ра
o Добавление электромагнитной структ

6.1.1. Создание нового проекта. 
Чтобы создать новый проект: 

1. Выберите в меню File>New Proje
2. Вы  меню File>Save Pro

вое e As. 
3. Наберите имя проекта (например, EM-example) и на

6.1.2. Импорт файла обработки слоя LPF (La
1. Выберите в меню Project>Process Library

Definition. 
2. Откройте корневой каталог программы (по 
3. Выберите Blank.lpf и нажмите Открыть, з

Да, чтобы заменить существующий LPF. 
6.1.3. Создание электромагнитной структуры

Чтобы создать новую электромагнитную структу
1. Выберите в меню Project>Add EM Struc

кнопкой мышки по значку Add New EM Str

нитной структуры. Но для AFS диапазон можно изменить, отметив Specify AFS Band. 
• Количество точек сетки (# Grid Pts). Определяет качество вычислений, по умолчанию 200. 
• Условие сходимости (Erro
умолчанию -40 dB. 

 Метод определения погрешности сходимости (Error Type). Может быть абсолютным (Absolute) 
или относительным (Relative). 
Алгоритм работы AFS следующий: 

1. Вычисления производятся на частотах f=fmin, f=1/2 (fmin+fmax), и fmax. 
2. Выполняется интерполяция 1-го порядка. 
3. Если ошибка больше -10 dB, добавляются частотные точки в середине каждого проме-

жутка между частотами и снова выполняется аппроксимация. Этот процесс выполняется, 
пока ошибка интерполяции будет меньше -10 dB. 

4. Добавляется ещё две частотные точки, в которых наибольшая разность между итерация-
ми k и k-1. 

5. Делается новая итерация/экстраполяция с учётом добавленных точек, порядок итерации 
увеличивается на 1. 

6. Ищется частота, на которой возможна наибольшая о
анализ на этой частоте и делается переход к шагу 5. 

7. Сравнивается интерполяция/экстраполяция в операциях k и k-1, используя абсолютный 
или относительный критерий сходимости. 

8. Если критерий выполняется, анализ прекращается. В противном случае делается переход 
к шагу 4. 

Можно добавить сколько угодно частот между fmin и fmax, чтобы, например, уточнить частоту 
резонанса. Это не увеличивает существенно время анализа.  

Некоторые особенности моделирования в EMSight рассмотрим на следующих примерах. 

ового фильтра 
вание в Microwave Office 
моделирование включает 

o Опр
и; 

o Просмотр плотности тока и электрических полей; 
звёртки частоты (AFS – Advanced Frequency Sweep). 
уры в схему и анализ. 

ct (Файл>Новый проект). 
ject As (Файл>Сохранить проект как). Откроется диалого-берите в

 окно Sav
жмите Сохранить. 

yer Process File). 
>Import LPF. Откроется окно Import Process 

умолчанию C:\Program Files\AWR\AWR2009). 
атем в следующем открывшемся окне нажмите 

. 
ру: 
ture>New EM Structure или щёлкните левой 
ucture  на панели инструментов. 
ревой фильтр) в поле Enter a name for the EM 
ой стр

2. Наберите Interdigital Filter (Встречношты
Structure (Ввод имени для электромагнитн уктуры), отметьте AWR EMSight Simula-
tor и нажмите Create. На рабочем поле откроется 
6.9). 

окно электромагнитной структуры (рис. 
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ис-
 для 

лучше использовать по возможности 

уменьшает время моделирования. 
Здесь нужно искать компромисс меж-

вания и точно-
стью. 

даются все диэлектрические материа-

нитной структуре, краевые условия, 

размер сетки, который будет исполь-

Чтобы определить корпус: 

Options>Project Options 

мышкой по Project Op-

t Options. 
pe вве-

дите mm и нажмите OK. 
 

группе Enclosure (Корпус) в дереве стержневого 
фильтра Interdigital Filter (в группе EM Struc-
tures) в окне просмотра проекта или щёлкните ле-
вой кнопкой мышки по значку Substrate Informa-

Информация о подложке) 

Примечание. EMSight 
пользует прямоугольную сетку
представления структуры. Для проекта 

более грубую сетку, поскольку это 

ду временем моделиро

6.1.4. Определение корпуса. 
При определении корпуса за-

лы для каждого из слоёв в электромаг-

все физические размеры структуры и 

зоваться. 

1. Выберите в меню 

или дважды щёлкните 

tions в левом окне про-
смотра проекта. Откроется диалоговое окно Pro

Рис. 6.9 

jec
2. На вкладке Global Units этого окна в поле Frequency введите GHz, в поле Length ty

3. Выберите в меню Options>Layout Options. Откроется диалоговое окно Layout Options. На
вкладке Layout этого окна в области Grid Options (Опции сетки) в поле Grid Spacing (Ин-
тервалы сетки) введите 1 mm, в поле Database unit size введите 0.01 mm и нажмите OK. 

4. Дважды щёлкните левой кнопкой мышки по под-

tion (  на панели инст-
кроется диалоговое окно свойств 

 структуры. 
 Enclosure открывшегося окна (рис. 

 поля 

 Add для Dielectric Definitions, что-
ектрика. Откроется дополнительное диалоговое окно Add Di-

вка) введите Alumina, щёлкнув 

 мышкой 
 кнопке Add для 

о-
я 

диалоговое окно 
Add Conductor 
(рис. 6.12). В поле 

остальные 

а свойств электромагнитной структуры должна выглядеть, как показано на рис. 6.13. 

рументов. От
электромагнитной

Рис. 6.10 5. На вкладке
6.10) в поля X_Dim и Y_Dim введите 12, в

Grid_X и Grid_Y введите 0.2. 
ёлкните мышкой по кнопке6. На вкладке Material Defs щ

иэлбы добавить материал д
electric (рис. 6.11). В поле Preset (Предварительная устано
мышкой по кнопке в правом конце этого поля. В поле Er введите 9.8, в поле TanD введите 
0.001, нажмите OK. 

7. Щёлкните
по
Conductor Defini-
tions, чтобы доба-
вить материал пр
водника. Откроетс

дополнительное 

Presets введите 
Gold, 

поля этого окна заполнятся автоматически. Нажмите OK. 
8. Дважды щёлкнув мышкой в соответствующих столбцах Color, можно изменить цвет, кото-

рым будут окрашиваться (заполняться) начерченные на этих слоях элементы топологии. 
Снова щёлкнув мышкой в столбцах Color, можно выбрать цвет заполнения. Вкладка Mate-
rial окн

Рис. 6.11 Рис. 6.12
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 2 
в колонке Thickness введит

дите 4, чтобы удобнее было 
структуры. Вкладка Dielectric Layers

Layers выбором материала в полях Top Boundary (Верхняя граница) и Bottom Boundary (Ниж-
няя граница). В этом примере используются значения по умолчанию. 

9. На вкладке Dielectric Layers (Диэлектрические слои) для слоя 1 в колонке Thickness (Тол-
щина) введите 5, в колонке Material Definition введите Air (Воздух), щёлкнув левой кноп-
кой мышки по этому полю, в колонке Draw Scale (Масштаб черчения) введите 1. Для слоя

Рис. 6.13

е 0.636, в колонке Material Definition введите Alumina, щёлк-
ому полю, в колонке Draw Scale (Масштаб черчения) вве-

просматривать трёхмерное отображение электромагнитной 
 должна выглядеть, как показано на рис. 6.14. 

нув левой кнопкой мышки по эт

Примечание. Граничные условия для боковых стенок корпуса в электромагнитной структуре 
всегда идеальные и не могут быть изменены. Верхняя и нижняя стенки корпуса также являются 
идеальными проводниками по умолчанию, но они могут быть изменены на вкладке Dielectric 

Рис. 6.14
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10. На вкладке Materials определяются материалы для проводников и межслойных перемычек. 
Щёлкните мышкой по кнопке Insert на этой вкладке. В столбце Name замените появившее-
ся имя Trace1 на Gold Line, в столбце Material Definition введите Gold, щёлкнув мышкой 
по этому полю, в столбце Thickness введите 0.001 (рис. 6.15). Нажмите OK. 

этом примере мы создадим топологию микрополоскового встречноштыревого фильтра, используя редак-
тор топологии. 

Microwave Office поддерживает абсолютные координаты и относительные. Абсолютные коорди-
наты относятся ко всему корпусу (подложке) электромагнитной структуры, а относительные только к 
отдельному элементу структуры, например, к прямоугольному проводнику. Абсолютная координата x=0 

соответствует левому краю корпуса электромагнитной структуры, а координа-
та y=0 – нижнему краю корпуса. Относительная координата x=0 соответствует 
левому краю элемента, например, прямоугольного проводника, а y=0 – ниж-
нему краю элемента. 

Чтобы созда гию: 

6.1.5. Создание топологии. 
Чтобы создать топологию для моделирования, можно использовать редактор топологии, имею-

щийся в Microwave Office. Можно так же импортировать структуры непосредственно из топологии схе-
мы, созданной в проекте, или импортировать структуры из файлов формата AutoCAD DXF или GDSII. В 

Рис. 6.15

ть тополо
1. Щёлкните мышкой по панели Layout в нижней части левого ок-

на, чтобы открыть в этом окне менеджер топологии и отметьте 
Conductor. В поле EM Layer введите 2, щёлкнув по кнопке в 
правом конце этого поля. В поле Material введите Gold Line, 
щёлкнув по кнопке в правом конце этого поля (рис. 6.16). 

2. Выберите в меню Draw>Rectangle (Чертить>Прямоугольник) 
или щёлкните левой кнопкой мышки по значку Rectangle  на 
панели инструментов. 

3. Поместите курсор в окно электромагнитной структуры и нажми-
те клавишу Tab на клавиатуре. Откроется диалоговое окно Enter 

Coordinates (Ввод координат), показанное на рис. 
6.17. 

4. Введите 0 в поле x, введите 7.8 в поле y и нажмите 
OK. 

Примечание. Переход между полями ввода можно делать, 
щёлкая левой кнопкой мышки по нужному полю ввода или нажи-
мая клавишу Tab на клавиатуре. 

5. Нажмите клавишу Tab снова, чтобы снова открыть 
диалоговое окно Enter Coordinates (рис. 6.18). Уста-
новите флажок в переключателе Rel, чтобы активизи-
ровать относительные координаты. Введите 2.2 в поле 
dx, и 0.6 в поле dy, нажмите OK. Проводник прямо-

угольного сечения отображается в окне электро-
магнитной структуры (рис. 6.19). 

Примечание. Чтобы удалить неверно вставленный 
проводник, щёлкните по нему левой кнопкой мышки и нажмите 
клавишу Delete. 

Создайте второй проводник прямоугольного сечения: 
6. Выберите в меню Draw>Rectangle или щёлкните 

левой кнопкой мышки по значку Rectangle на па-
нели инструментов. 

7. Поместите курсор в окно электромагнитной струк-
 нажмите клавишу Tab. Откроется диалого-

 

Рис. 6.16 

Рис 6.17 

Рис. 6.18 

туры и
вое окно Enter Coordinates. Введите 4 в поле x, 
введите 1.4 в поле y и нажмите OK. 

8. Нажмите клавишу Tab, чтобы снова открыть диа-
логовое окно Enter Coordinates. Установите фла-
жок в переключателе Rel, чтобы активизироватьРис. 6.19
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я в окне элек-
тромагнитной структуры (рис. 6.20). 

9. Установите курсор на второй провод-
ник, нажмите левую кнопку мышки и, 
не отпуская кнопки, переместите вто-
рой проводник так, чтобы появившиеся 
относительные координаты смещения 
были равны dx:-1.8 и dy:1. Оба про-
водника должны соединиться, как по-
казано на рис. 6.21. 

относительные координаты. Введите 
1.2 в поле dx, 7.2 в поле dy и нажмите 
OK. Второй проводник прямоугольно-
го сечения отображаетс

Рис. 6.20 Рис. 6.21 

 или Ruler (Линейка) Примечание. Щёлкните по значку Measure (Измерение) на панели 
инструментов, чтобы измерить размеры проводников, смещения или зазоры в топологии электромагнит-
ной структуры. 
6.1.6. Добавление межслойных перемычек (металлизированных отверстий). 

Межслойные перемычки осуществляют связь между слоями структуры. Мы должны добавить
заземление одной стороны вертикального проводника на основание корпуса. Что-
бы сделать это: 

1. Откройте менеджер топологии. 
2. В менеджере топологии отметьте Via.В поле EM Layer введите 2, в 

поле Material введите Gold Line и в поле Extent (Протяжённость) 
введите 1 (рис. 6.22). 

3.

 

ку Rectangle на панели инструментов. 
4.  

 

7. Поместите
Ко
в

8. Щёлкните
9. 

ле
рис. 6.

Замечание
один  цвет, то пере
курсор мышки на 
Щелчок мышкой, когд

10. Установите кур
те ле

ниже созданных п
прямоугольник. Отпустите к

11. Выберите в меню Draw>Modi
мы>Объедин

 Щёлкните мышкой по знач
 Поместите курсор в окно электромагнитной структуры и нажмите
клавишу Tab. Откроется диалоговое окно Enter Coordinates. Введи-
те 2.6 в поле x, введите 9.4 в поле y и нажмите OK. 

5. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter 
Coordinates. Установите флажок в переключателе Rel, чтобы акти-

нвизировать от осительные координаты. Введите 0.4 в поле dx, -0.8 в 
поле dy и нажмите OK. Выделенная прямоугольная перемычка поя-
вится на вертикальном проводнике (рис. 6.23). 

берите в меню Edit>C6. Вы opy и затем выберите Edit>Paste или
щёлкните мышкой мышки по значку Copy и затем по значку Paste 
на панели инструментов. 

 курсор мышки в окно электромагнитной структуры. 
рован

Рис. 6.22 

нтур скопи ного межслойного перехода будет отображаться 
 окне. 

авой кн пр опкой мышки, чтобы его развернуть. 
Нажмите клавишу Tab, чтобы отобразить диалоговое окно Enter 
Coordinates. Снимите галочку в переключателе Rel, чтобы устано-
вить абсол нРис. 6.23 ют ые координаты. Введите 2.8 в поле x, введите 9 в по-

 y и нажмите OK. Новая электромагнитная структура показана на 
24. 
. Т.к. проводники и перемычки из одного материала и имеют 
мычки, если они не выделены, не будут видны. Если подвести 
перемычку, её контур будет отображаться пунктирной линией. 

а курсор находится на перемычке, выделяет эту перемычку. 
р левее и выше вертикального проводникасо , нажми-

вую кнопку мышки и, не отпуская кнопки, переместите курсор 
еремычек так, чтобы обе перемычки попали в образовавшийся 
нопку мы

Рис. 6.24 

правее и 
шки. Обе перемычки будут выделены. 

fy Shapes>Union (Чертить>Модифицировать фор-
ить) или щёлкните по значку Union  на панели инст-

чтобы объединить обе перемычки. Созданная перемычкарументов,  
будет выгляде

Примечания. 1. Точн
дрическое отверстие межсло
двух пересекающихся 
дать с центром отверсти
2. Межслойную пер

se. Такой вариант пер
6.1.7. Просмотр 3-х мерной структуры. 

ть, как показано на рис. 6.25. 
ость моделирования обычно будет достаточной, если цилин-

йного перехода аппроксимировать призмой в виде 
прямоугольников (рис. 6.25). Центр призмы должен совпа-
я. 

емычку можно сделать и круглой, используя инструмент El-
емычки используется в примере 6.4. Рис. 6.25 lip
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В Microwave Office поддерживается 2-х мерное
структур. Чтобы создать 3-х мерное представление: 

1 Выберите в меню View>View 3D EM Layo

 и 3-х мерное представления электромагнитных 

ut или щёлкните мышкой по значку View 3D EM 
Layout  на панели инструментов. На рабочем 
поле появится трёхмерное изображение, как по-

1 

Примеч ения 3-х мерной 
ну

область), Zoom Out (Уменьшить область) и Auto View (По-
нуть по 

6.1.8. Добавление п ка референсных плоскостей. 
При электромагнитно рические порты на краю платы 

(т.е. внешние порты) или
Чтобы определить

1. Щёлкните левой нтальному проводнику в окне электромагнит-
ной структуры ч-
но на левом

ки по значку 

казано на рис. 6.26. 
Выберите в меню Window>Tile Vertical (Ок-
но>Не перекрывающееся вертикальное распо-
ложение) или Window>Tile Horizontal. Окна с 
3-х мерным и 2-х мерным отображениями рас-
полагаются рядом. Затем выберите Win-
dow>Cascade. 

ание. Изменить вид отображ
структуры можно, щёлк в правой кнопкой мышки в окне 3-
х мерной структуры, и затем выбрать Zoom Area (Увеличить 

казать всё) во всплывающем меню. Или можно щёлк
соответ

Рис. 6.26 
ствующему значку на панели инструментов. Чтобы вращать 3-х мерную структуру, нажмите её 

ой мышки и, не отпуская кнопки, перемещайте мышку. 
ортов и установ

левой кнопк

м моделировании можно определять элект
 как зонд, проходящий через нижнюю или верхнюю крышки (т.е. Via Port). 

 внешний порт: 
 кнопкой мышки по горизо

. Обратите внимание, что этот проводник должен быть позиционирован то
 краю подложки (X=0) прежде, чем добавлять внешний порт. 

2. Выберите в меню Draw>Add Edge Port (Чертить>Добавить 
внешний порт) или щёлкните левой кнопкой мыш
Edge Port  на панели инструментов. 

3. Поместите курсор на левый край горизонтального проводника, 
пока не отобразится квадрат, и щёлкните левой кнопкой мышки, 
чтобы зафиксировать порт. Маленькая площадка с номером 1 
появится на левом краю проводника (рис. 6.27). 

Чтобы установить референсную плоскость для порта 1: 
4. Щёлкните правой кнопкой мышки в окне электромагнитной 

 выберите в меню View Area (Увел

Рис. 6.27 

структуры и ичить размер области) или нажмите зна-
чок View Area  на панели инструментов. Курсор будет отображаться в виде лупы. 

курсор чуть выше и левее верхнего левого угла входного проводника, на-
 мышки и, не

5. Поместите 
жмите левую ому ниж-
нему углу

6.

бражался в виде

 

Чтобы определить
1. Нажмите панель

та. 
2. Правой 

выберит
3. Щёлкни

 кнопку  отпуская кнопки, переместите курсор к прав
 этого проводника так, чтобы выделить весь проводник с портом и отпустите 

кнопку мышки. 
 Щёлкните левой кнопкой мышки по порту 1. По углам порта отобразятся 
четыре небольших квадратика. 

7. Установите курсор мышки на правый край порта так, чтобы курсор ото-
йной стрелки (

Рис. 6.28

 дво рис. 6.28). 
8. Нажмите левую 

кнопку мышки и, не 
отпуская кнопки 
мышки, перетащите 
курсор вправо, пока не
будет отображено 
dx:1.6, dy:0 (рис. 6.29). 
Отпустите кнопку 

мышки, чтобы зафиксировать референсную плоскость. 
Рис. 6.29 

 частот для моделирования. 
 частоты: 

 Project в нижней части левого окна, чтобы открыть окно просмотра проек-

6.1.9. Определение

кнопкой мышки щёлкните по объекту Interdigital Filter в группе EM Structures и 
е Options во всплывающем меню. Откроется диалоговое окно Options. 
те панель Frequencies (Частоты) в верхней части окна. 
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 переключателе Use Project Frequency (Использовать 

ные частоты имели преимущество 

ns в окне просмотра 

6.1.10. 

rdigital Filter в 

иске Measurement отметьте 

й по значку 

4. Снимите галочку (если она стоит) на
частоты проекта), чтобы локаль-

перед глобальными частотами 
проекта (рис. 6.30). 

5. Установите GHz в области Data 
Entry Unit, щёлкая по стрелкам в 
правом конце этого поля. 

6. Введите 1 в поле Start (Начало), 
ведите 5 в поле Stop (Конец) и 
введите 1 в поле Step (Шаг). 

7. Щёлкните Apply (Применить). В 
окне списка Current Range (Те-
кущий диапазон) отображается 
частотный диапазон и частотные 
точки с шагом, которые вы только 
что определили. 

8. Нажмите OK. 
Примечание. Microwave Office позво-

ляет определять частоты моделирования гло-
ptioбально (через Project O

проекта) или локально для каждой схемы и электромагнитной структуры. Для эл

Рис. 6.30 

ектромагнитной струк-
туры часто лучше использовать локальные частоты с количеством частотных точек меньшим, чем для 
линейных схем. 

П сро мотр ячеек сетки. 
Структура сетки очень важна для моделирования, т.к. она влияет на время и точность моделиро-

вания. Рекомендуется начинать с грубой сетки 
и затем делать её более мелкой до тех пор, по-
ак  результаты анализа перестанут заметно из-
меняться при дальнейшем уменьшении ячеек 
сетки. Просмотреть сетку можно в трёхмерном 
отображении, добавив аннотацию к структуре. 

Чтобы просмотреть ячейки сетки: 
1. Щёлкните правой кнопкой мыш-

ки по имени электромагнитной 
структуры Inte
окне просмотра проекта и выбе-
рите Add Annotation. 

2. В открывшемся окне (рис. 6.31) в 
сп
EM_MESH, остальные парамет-
ры установите, как показано на 
рис. 6.31 и нажмите OK. 

3. Щёлкните мышко

View EM 3D Layout  и затем 
по значку Top (Верх)  

Рис. 6.31 
на панели инс

как показано на рис. 6.32. 
4. Щёлкнув правой кнопкой мышки по имени

ter:EM_MESH в группе Annotations в окн
Toggle Enable, можно отменить показ стр
этой команды возобновляет показ структур

 
 

6.1.11. 

структур резонансную частоту первого резонатора фильтра, можно выполнить электромаг-
. 

 структуры: 

го фильтра (Interdigital Filter) в группе EM Structures. Откроется диалоговое окно 

 па-
лиза. Ознакомившись с эти-

ми данными, закройте окно, нажав OK. 

трументов. Сетка будет отображена, 

 аннотации Interdigital Fil-
е просмотра проекта и выбрав 

уктуры сетки. Повторный вызов 
ы сетки. 

Рис.
Выполнение электромагнитного моделирования. 
Электромагнитное моделирование  выполняется очень быстро для небольших электрических 
. Чтобы найти 

6.32

нитное моделирование для одного резонатора стержневого фильтра
Чтобы выполнить моделирование

1. Дважды щёлкните левой кнопкой мышки по подгруппе Information (Информация) стерж-
нево
Solver Information (Информация решающего устройства). В этом окне (рис. 6.33) на вклад-
ке Summary отображается доступное (Available) и необходимое (Required) количество
мяти на компьютере для моделирования и оценочное время ана



2. Выберите в меню Simulate>Analyze 
(Моделирование>Анализ) или щёлк-
ните левой кнопкой мышки по знач-
ку Analyze 

Рис. 6.33 

 на панели инструмен-
тов. Откроется окно, в котором ото-
бражается процесс анализа. Когда 
это окно исчезает, анализ закончен. 
бражение результато6.1.12. 

граф

нео
ражения
сделать

не просмотра про-

Ото в на 
ике. 
Для определения резонансной частоты 

бходимо построить график коэффициента от-
 в электромагнитной структуре. Чтобы 

 это: 
1. Выберите в меню Project>Add 

Graph (Добавить график), или 
щёлкните правой кнопкой мышки по 

группе Graphs в ок
екта и выберите New Graph, или 
щёлкните левой кнопкой мышки по 
значку Add New Graph  на панели 
инструментов. Откроется диалоговое 
окно Create Graph (Создать график). 

2. В поле Graph Name введите имя гра-
фика Filter Response, отметьте Rec-

ки по имени графика Filter Re-
вы-

Add New 

tangular (Прямоугольный) в области 
Graph Type (Тип графика) и нажмите 
OK. Окно графика откроется на рабо-
чем поле. 

3. Выберите в меню Project>Add Meas-
urement (Добавить измеряемую вели-
чину), или щёлкните правой кнопкой 
мыш
sponse в окне просмотра проекта и 
берите Add Measurement, или щёлк-
ните левой кнопкой мышки по значку 

Measurement 

Рис. 6.34 

 на панели инст-
ментов. Откроется диалоговое окно Add 

ent (рис. 6.34). 
ру

те
ters.
ment 

Index

инструментов. Резуль-
таты анализа отображаются на графике, 

но на рисунке 6.35. 
е

ите правой кнопкой мышки объект 
 

Measurem
4. В окне списка Measurement Type раскрой-

 группу Linear и выберите Port Parame-
 Выберите S в окне списка Measure-

(Измеряемая величина), введите In-
 Filter в поле Data Sourcterdigital e Name 

(Имя источника данных), в поля To Port 
 и From Port Index введите 1, отметь-

те Mag и dB в области Complex Modifier 
(Представление комплексной величины) и 
нажмите Apply (Применить). 

5. Нажмите OK. 
6. Выберите в меню Simulate>Analyze или 

щёлкните левой кнопкой мышки по значку 
Analyze на панели 

Рис. 6.35 
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как показа
Чтобы определить р зонансную частоту более 

точно, необходимо изменить частотный диапазон и шаг 
по частоте. Чтобы сделать это: 

7. Щёлкн
Interdigital Filter в группе EM Structures
и выберите Options. Откроется диалоговое 
окно Options. 

8. Нажмите панель Frequencies в верхней 
части этого окна. Рис. 6.36 
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9. Отметьте Replace, введите 3 в поле Start, введит
Apply. В окне списка Current Range будет ото
которые вы только что определили. 

10. Нажмите OK. 
11. Выберите Simulate > Analyze в выпадающе

значку Analyze на панели инструментов, чтобы
анализа отображаются на графике, как показано

6.1.13. Просмотр анимации токов и Е – поля. 

 характеристик. Токи и 
 

шемся окне 

на рис. 6.37 и нажмите 

е 5 в поле Stop и 0.1 в поле Step. Нажмите 
бражён новый частотный диапазон с шагом, 

м меню или щёлкните левой кнопкой мышки по 
 выполнить новый анализ схемы. Результаты 
 на рисунке рис. 6.36. 

Просмотр токов и полей 
электромагнитной структуры может 
быть полезен при изучении её фи-
зических
электрические поля добавлены к 
аннотации электромагнитных 
структур и могут быть просмотрены 
в 3-х мерном отображении струк-
тур. 

Чтобы просмотреть токи на 
проводниках: 

1. Щёлкните правой 
кнопкой мышки по 
имени электромагнит-
ной структуры Inter-
digital Filter в окне 
просмотра проекта и 
выберите Add Annota-
tion. 

2. В открыв
(рис. 6.37) в списке 
Measurement отметьте 
EM_CURRENT, ос-
тальные параметры ус-
тановите, как показано 

OK. 
3. Сделайте активным 

окно электромагнит-
ной структуры и щёлкните мышкой по знач-
ку View EM 3D Layout на панели инстру-
ментов. 

4. Щёлкните мышкой по значку Animate Play 

Рис. 6.37 

 на панели инструментов. Анимация токов 
в трёхмерном представлении будет отобра-
жена на рабочем поле (рис. 6.38). 

5. Щёлкните левой кнопкой мышки по значку 
Animate Stop  на панели инструментов, 
чтобы остановить анимацию. 

6. Щёлкнув правой кнопкой мышки по имени 
аннотации Interdigital Fil-

ter:EM_CURRENT в группе Annotations 
в окне просмотра проекта и выбрав Tog-
gle Enable, можно отменить показ

Рис  . 6.38

 токов. 
Повторный вызов этой команды возоб-
новляет показ токов. 

Чтобы просмотреть электрическое поле: 
1. Щёлкните правой кнопкой мышки по 

имени электромагнитной структуры In-
terdigital Filter в окне просмотра проекта 
и выберите Add Annotation. 

2. В открывшемся окне в списке Measure-
ment отметьте EM_E_Filed и нажмите 
OK. 

3. В окне просмотра проекта щёлкните пра-
вой кнопкой мышки по имени аннотации 

Рис. 6.39 
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шки по значку Ana-
инструментов, чтобы вычислить электрические поля. 

Animate Stop на панели инструментов, чтобы 

7. Чтобы прекратить вычисление и показ электрическо
мышки по имени аннотации Interdigital Filter:EM_E
просмотра проекта и выберите Toggle Enable. 

6.1.14. Завершение топологии фильтра. 
Чтобы завершить топологию фильтра, мы будем использова е усо

особенности редактирования в окне электромагнитной структуры. 
Чтобы добавить небольшой проводник на

1. Щёлкните по окну электромагнитно уктуры Interdigital Filter, что-
бы сделать его активным. 

2. Выберите в меню Draw>Rectan ямоугольник) или 
щёлкните левой кнопкой мышки по 
ментов. 

3. Поместите курсор в окно Interdigital Filter
клавиатуре. Откроется диалоговое окно
динат). 

4. Введите 2.2 в поле x, введите 2.4 в поле 
5. Нажмите клавишу Tab снова, чтобы отк

ordinates. Отметьте переключатель Rel  относитель-
ные коо
введите 0.2
моугольный
окне электро
6.40). 

Чтобы начертить
6. Выберите в

ровать>Выделить
сор левее
вую кнопку
правее и ниж

ки. 

ро-
вать>Вставить
Появится контур

8. Переместите курсор уры, нажмите 
клавишу Ctrl
кальное отображ
ную копию резон
проводника совпал с
туры (рис. 6.41) 

Чтобы создать средний рез
9. Установите курсор

резонатора, нажмите пки, 
переместите курсор к правому нижнему уг
весь резонатор, отпустите кнопку мышки
ходом будет выбран (6.42). 

10. Выберите в меню Edit>Copy, затем выб
11. Двигайте курсор к середине окна электро

пированный образец в середину окн
щёлкнув правой кнопкой мышки, чтобы
резонатора. 

12. Нажмите клавишу Tab, Чтобы откр

Interdigital Filter:EM_CURRENT в группе Annotations и выберите Toggle Enable. 
4. Выберите в меню Simulate>Analyze или щёлкните левой кнопкой мы

lyze на панели 
5. Выберите Animate>Animate Play в выпадающем меню или щёлкните левой кнопкой мыш-

ки по значку Animate Play на панели инструментов, чтобы просмотреть анимацию поля 
(рис. 6.39). Этот вид зависит от конфигурации вашего компьютера. 

6. Щёлкните левой кнопкой мышки по значку 
остановить анимацию. 

го поля, щёлкните правой кнопкой 
_Filed в группе Annotations в окне 

ть некоторы вершенствованные 

 конце входного резонатора: 
й стр

gle (Чертить>Пр
значку Rectangle на панели инстру-

 и нажмите клавишу Tab на 
 Enter Coordinates (Ввод коор-

y и нажмите OK. 
рыть диалоговое окно Enter Co-
, чтобы установитьРис. 6.40 

рдинаты. Введите -0.4 в поле dx, 
 в поле dy и нажмите OK. Пря-
 проводник будет отображён  в 
магнитной структуры (рис. 

 выходной резонатор: 
 меню Edit>Select All (Редакти-

ё). Или устан вс овите кур-
 и выше топологии, нажмите ле-

 мышки и переместите курсор 
е топологии так, чтобы вся то-

пология попала в образовавшийся прямо-
угольник. Отпустите кнопку мыш

7. Выберите в меню Edit>Copy (Редактиро-
вать>Копировать) или щёлкните по значку 
Copy на панели инструментов. Затем выбе-
рите в меню Edit>Paste (Редакти

) или щёлкните по значку Paste на панели инструментов. 
 топологии. 

 в окно электромагнитной структ
 и щёлкните правой кнопкой мышки. Будет создано зер-

ение скопированной топологии. Переместите создан-
атора вправо так, чтобы правый край горизонтального 

 правым краем корпуса электромагнитной струк-

онатор: 
 несколько выше верхнего левого угла входного 

Рис. 6.41 

Рис. 6.42 
левую кнопку мышки и, не отпуская кно
лу е р зонатора так, чтобы выделение охватило 

. Вертикальный проводник с межслойным пере-

ерите Edit>Paste.  
магнитной структуры, чтобы переместить ско-

а, затем поверните образец на 180 градусов, дважды 
 заземляющая перемычка была в нижней части 

ыть окно Enter Coordinates. 
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 галочку (если она есть) на пере-

дите 6 в поле x, введи-

гнитной структуры, не-

добавить порт и установить референсную плоскость: 

структуры, чтобы выделить его. 
2. Выберите в меню Draw>Add Edge Port или 

ort

13. Уберите
ключателе Rel, чтобы установить абсолют-
ные координаты. Вве
те 5 в поле y и нажмите OK. Новая тополо-
гия показана на рис. (6.43). 

Для завершения электрома
обходимо добавить порт к выходному проводнику. Чтобы 

1. Щёлкните левой кнопкой мышки по выход-
ному проводнику в окне электромагнитной 

щёлкните левой кнопкой мышки по значку 
Edge P   на панели инструментов. 

 про-

 зафиксировать порт. Небольшой квадрат с 
цифр

4. Чтобы 
5. Щёлкните  мышки по порту 2. В его углах отобразятся четыре квадрата. 
6. Установите

стрелки
7. Нажмите ышки и, не отпуская кнопки, переместите курсор влево, пока dx 

и dy ксировать по-
ложение

овить рефер
дважды щёлкните по нему мышкой. Откроется окн
введите 1.6 mm и нажмите OK. Законченная топология

6.1.15. Улучшенная
Решающее устро

 В окне просмотра проекта щёлкните 

 3, 5 и 0.05 соответственно. 

 части окна, чтобы от-
 (рис. 6.46). В об-

ласти Advanced Freq Sweep в левой 

3. Переместите курсор к правому краю
водника, пока не будет отображён квадрат, 

й кнопкой мышки, чтобы

Рис. 6.43 

и щёлкните лево
ой 2 будет отображён на правом краю проводника. 
установить референсную плоскость порта: 

 левой кнопкой
 курсор на левый край порта так, чтобы он отображался в виде двойной 

. 
 левую кнопку м

 получат значения dx:-1.6, dy:0. Отпустите кнопку мышки, чтобы зафи
 референсной плоскости. 
енсную плоскость порта можо и другим способом. После добавления порта 

о свойств порта рис. 6.44. В поле Ref. Plane Distance 
 показана на рис. 6.45. 

Устан

 вариация частоты (AFS – Advanced Frequency Sweep). 
йство EMSight может выполнять улучшенную вариацию частоты (AFS). Заметь-

те, что токи и электрические поля не вычисляются 
при выполнении AFS. 

Чтобы выполнить AFS: 

Рис. 6.45 
Рис. 6.44 

1.
правой кнопкой мышки по имени 
электромагнитной структуры Inter-
digital Filter и выберите Options. 

2. На вкладке Frequencies открывшегося 
окна опций в поля Start, Stop и Step 
введите
Щёлкните мышкой по кнопке Apply, 
чтобы отобразить введённый диапа-
зон в Current Range. 

3. Щёлкните мышкой по кнопке EM-
Sight в верхней
крыть эту вкладку

Рис. 6.46 
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нижней части окна отметьте Ena
4. Нажмите OK. 
5. В окне просмотра проекта щёлкните

sponse и выберите Add Measureme
(рис. 6.47). 

ти Complex Modifier 
(Представление комплексной величины), нажмите Apply (Применить) и OK. 

7. Сделайте активным окно графика и щёлкните мышкой по значку Analyze на панели ин-
струментов. Рассчитанный график показан на рис. 6.48. 

6.1.16. Добавление электромагнитной структуры в схему и моделирование. 
Вы можете добавить электромагнитную структуру в схему так же, как добавляется любая под-

схема. 
1. Создайте новую схему, выбрав в меню Project>Add 

Schematic>New Schematic или щёлкнув мышкой по 
значку Add New Schematic 

ble AFS (Включить AFS). 

 правой кнопкой мышки по имени графика Filter Re-
nt. Откроется диалоговое окно Add Measurement 

6. В окне списка Measurement Type раскройте группу Linear и выберите Port Parameters. 
Рис. 6.47 

Рис. 6.48 

Выберите S в окне списка Measurement (Измеряемая величина), выберите Interdigital 
Filter в поле Data Source Name (Имя источника данных), введите 2 в поле To Port Index, 
введите 1 в поле From Port Index, отметьте Mag и dB в облас

 на панели инструментов. 
В открывшемся окне введите имя схемы Schematic us-
ing EM и нажмите OK. 

2. Щёлкните мышкой по значку Subcircuit  на панели 
инструментов или выберите в меню Draw>Add Subcir-
cuit. Откроется диалоговое окно с перечнем всех 
имеющихся в проекте подсхем ). 

3. Щёлкните мышкой по имен мой подсхемы In-
е OK. Или 

4. П
и и, чтобы зафиксиро-
вать. 

5. Щёлкните
установите по
порт на выходе
правой кн
сов. Созданная
6.50. 

6. Щёлкните пр
мы Schematic using E

окне просмотра проекта и выберите Options
7. На вкладке Frequencies открывшегося ок

faults, в поле Start введите 3, в поле Stop
мышкой Apply и затем OK. 

8. Создайте прямоугольный график с именем Filter Sche

 (рис. 6.49
и добавляе

terdigital Filter, чтобы выделить её, и нажмит
просто дважды щёлкните мышкой по имени добавляе-
мой подсхемы. 
еремещая мышку, установите подсхему в окне схемы 
щёлкните левой кнопкой мышк

Рис.6.49 
 мышкой по значку Port на панели инструментов и 

рт на входе схемы. Аналогично установите 
 схемы, предварительно два раза щёлкнув 

наопкой мышки, чтобы развернуть порт  180 граду-
 схема должна иметь вид, показанный на рис. 

авой кнопкой мышки по имени созданной схе-
M в группе Circuit Schematics в левом 

. 
 

Рис. 6.50 

на опций схемы снимите отметку в Use project de-
 введите 5 и в поле Step введите 0.05. Щёлкните 

matic. 
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 активном окне вновь создан-
ного графика щёлкните мышкой 

крывшемся окне введите такие 
же параметры, какие были введе-
ны при создании предыдущего 
графика рис. 6.47, только в поле 
Data Source Name введите 
Schematic using EM. Нажмите 
Apply и OK. 

10. Щёлкните мышкой по значку 
Analyze на панели инструментов. 
Рассчитанный график показан на 
рис. 6.51. Он такой же, как и гра-
фик электромагнитной структу-
ры. 

11. На этом заканчивается пример 
моделирования электромагнит-

сохранить проделанную вами работу, выбрав в ме-

6.2. Моделирование микрополоскового аттенюатора

лёнными
пользовалась
нейно
ны (ок
6.2.1. 

диалого-

4. Выберите в меню Options>
tions в левом окне прос

5. На вкладке Global Units этого
дите mm и нажмите OK. 

6.2.2. Создание электромагнитной структ
ой мышки по значку Add New 

9. При

по значку Add New Measurement 
на панели инструментов. В от-

Рис. 6.51 

ной структуры. При желании вы можете 
ню File>Save Project. 

 
Этот пример пока к выполнить электромагнитное моделирование для структуры с напы-

 резисторами. Здесь выполняется моделирование такой же структуры аттенюатора, которая ис-
 для линейного моделирования в примере 3.3, чтобы можно было сравнить результаты ли-

го и электромагнитного моделирования. Однако размеры элементов топологии несколько измене-
руглены) так, чтобы все размеры были кратны размерам ячеек сетки. 

зывает, ка

Создание нового проекта. 
1. Выберите в меню File>New Project (Файл>Новый проект). 
2. Выберите в меню File>Save Project As (Файл>Сохранить проект как). Откроется 

вое окно Save As. 
3. Наберите At20 и нажмите Сохранить. 

Project Options или дважды щёлкните мышкой по Project Op-
мотра проекта. Откроется диалоговое окно Project Options. 

 окна в поле Frequency введите GHz, в поле Length type вве-

уры. 
1. Щёлкните левой кнопк

EM Structure  на панели инструментов. 
2. Наберите Atr20 в поле Enter a name for the EM Struc-

ture (Ввод имени для электромагнитной структуры), 
отметьте AWR EMSight Simulator и нажмите Create. 

вкладке Enclosure открывшегося ок-

оговое окно Add Conductor (рис. 6.52). В поле 

OK. Снова щёлкните мышкой по кнопке Add, 

х столбцах ещё раз, можно изменить штриховку слоёв. На-
ано на рис. 6.54. 

На рабочем поле откроется окно электромагнитной 
структуры. 

3. Щёлкните по значку Substrate Information на панели 
инструментов. На 

Рис. 6.52 на в поле X_Dim введите 13.4, в поле Y_Dim введите 
6.9, в поле Grid_X введите 0.1 и в поле Grid_Y введите 
0.05. 

4. На вкладке Material Defs в области Dielectric Defini-
tions для диэлектрического слоя Diel_1 введите 
Er=10.55, TanD=0.0001. Для области Conductor Defini-
tions щёлкните мышкой по кнопке Add, чтобы доба-
вить материал проводника. Откроется дополнительное 
диал
Presets (Предварительные установки) введите Alumi-
num, щёлкнув по кнопке в правом конце этого поля, и 
нажмите 

Рис. 6.53 

в поле Name введите Resist (рис. 6.53), в поле Conductivity (S/m) введите 67000. Дважды 
щёлкнув в столбцах Color, можно изменить цвет, которым будут отображаться слои метал-
ла в топологии. Щёлкнув в эти
жмите OK. Вкладка Material Defs будет выглядеть, как показ
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 (Масштаб черчения) введите 4, 

териал 1 oz Cu. 

6.  Materials щёлкните

этому полю. 
Вкладка Materials будет выглядеть, как показано на рис. 6.55. Нажмите OK. 

5. На вкладке Dielectric Layers (Диэлектрические слои) для слоя 1 в колонке Thickness (Тол-
щина) введите 7, в колонке Material Definition введите Air (Воздух), щёлкнув левой кноп-
кой мышки по этому полю, в колонке Draw Scale (Масштаб черчения) введите 1. Для слоя 2

е 0.5, в колонке Material Definition

Рис. 6.54

в колонке Thickness введит  введите Diel_1, щёлкнув ле-
вой кнопкой мышки по этому полю, в колонке Draw Scale
чтобы удобнее было просматривать трёхмерное отображение электромагнитной структуры. 
В поле Top Boundary (верхняя граница) введите материал Aluminum, в поле Bottom 
Boundary (нижняя граница) введите ма

 На вкладке  мышкой по кнопке Insert. В столбце Name замените поя-
вившееся имя Trace1 на Alum, в столбце Thickness введите 0.02, в столбце Material Defini-
tion введите Aluminum, щёлкнув мышкой по этому полю. Снова щёлкните мышкой по 
кнопке Insert. В столбце Name введите имя материала Res, в столбце Thickness введите 
0.0003, в столбце Material Definition введите Resist, щёлкнув мышкой по 

Рис. 6.55
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6.2.3. Создание топологии. 
1. Щёлкните левой кнопкой мышки по значку Rectangle  на панели инструментов или 

выберите в меню Draw>Rectangle. 
2. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Tab на кла-

виатуре. Откроется диалоговое окно Enter Coordinates (Ввод координат). 
3. Введите 0 в поле x, введите 3.2 в поле y и нажмите OK. 
4. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter Coordinates. Уста-

новите флажок в переключателе Rel, чтобы активизировать относительные координаты. 
Введите 3 в поле dx, 0.5 в поле dy и нажмите OK. Проводник прямоугольного сечения 
отображается в окне электромагнитной структуры. 

5. Повторите пункты с 1-го по 4-ый, но введите 3 в поле x, 3.25 в поле y, 0.5 в поле dx и 0.4 
в поле dy. 

6. Повторите пункты с 1-го по 4-ый, но введите 3.5 в поле x, 2.95 в поле y, 2 в поле dx и 1 в 
поле dy. 

7. Повторите пункты с 1-го по 4-ый, но введите 5.5 в поле x, 3.25 в поле y, 0.2 в поле dx и 
0.4 в поле dy. 

8. Повторите пункты с 1-го по 4-ый, но введите 5.7 в поле x, 2.5 в поле y, 2 в поле dx и 1.9 в 
поле dy. 

9. Повторите пункты с 1-го по 4-ый, но введите 7.7 в поле x, 3.25 в поле y, 0.2 в поле dx и 
0.4 в поле dy. 

10. Повторите пункты с 1-го по 4-ый, но введите 7.9 в поле x, 2.95 в поле y, 2 в поле dx и 1 в 
поле dy. 

11. Повторите пункты с 1-го по 4-ый, но введите 9.9 в поле x, 3.25 в поле y, 0.5 в поле dx и 
0.4 в поле dy. 

12. Повторите пункты с 1-го по 4- ите 10.4 в поле x, 3.2 в поле y, 3 в поле dx и 0.5 

6.2.4. 

 не отобразится квадрат, и щёлкни-
те левой кнопкой мышки, чтобы зафиксировать 
порт. 

4. Дважды щёлкните левой кнопкой мышки по пор-
ту 1. Откроется окно свойств порта (рис. 6.56). В 
поле Ref. Plane Distance введите расстояние 1 
mm, на которое нужно сдвинуть референсную 
плоскость. Нажмите OK. 

5. Снова щёлкните левой кнопкой мышки по значку 
Edge Port на панели инструментов и установите 
порт 2 на выходной проводник. Сдвиньте рефе-
ренсную плоскость на 1 мм, как описано в п.4. 

6.2.5. Назначение материала проводникам. 
1. Щёлкните левой кнопкой мышки по 

окну топологии, чтобы сделать его ак-
тивным. 

2. Нажмите клавишу Shift и щёлкните ле-
вой кнопкой мышки поочерёдно по 
всем проводникам (кроме резисторов), 
чтобы выделить их. Затем щёлкните по 
любому выделенному проводнику пра-
вой кнопкой мышки и выберите Shape 
Properties.. Откроется окно Properties 
(рис. 6.57). 

3. В поле EM Layer введите 2, в поле Ma-
terial введите 1/2oz Cu, щёлкая мыш-

ый, но введ
в поле dy. 

Добавление портов и установка референсных плоскостей. 
1. Щёлкните левой кнопкой мышки по входному 

проводнику, чтобы выделить его. 
2. Щёлкните левой кнопкой мышки по значку Edge 

Port на панели инструментов. 
3. Поместите курсор на левый край входного про-

водника, пока

Рис. 6.56

кой по кнопке в правом конце этих по-
лей, отметьте Conductor и нажмите 
OK. 

4. Повторите пункты 2 и 3 для всех рези-
сторов топологии аттенюатора, но в 

поле Material введите Res. 

Рис. 6.57 
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енюатора показан на рис. 6.58. 

6.2.6. 

роекта. На рабочем поле откроется окно уравнений Output Equations. 

Окончательный вид структуры атт

Создание выходных параметров и уравнений. 
Рис. 6.58

1. Дважды щёлкните левой кнопкой мышки по группе Output Equations (Выходные уравнения) в 
окне просмотра п

2. Выберите в меню Draw>Add Output Equation или щёлкните по значку Output Equation  на 
панели инструментов. Откроется 
диалоговое окно Measurements 
(Измеряемые величины). В тек-
стовом поле Variable name (Имя 
переменной) введите S11, в спи-
ске Measurement Type отметьте 
Port Parameters, в списке Meas-
urement отметьте S, в поле Data 
Source Name введите atr20, щёл-
кая по кнопке справа от этого по-
ля, введите 1 в оба поля To Port 
Index и From Port Index, щёлкая 
по кнопкам
установите

 справа от этих полей, 
 переключатель Mag в 

ключателе dB, 

В окне уравнений 

 выражение 
 

S11=atr20: |S(1,1)| 
 

Щёлкните левой кнопкой мыш
для S11. 
3. Снова выберите в меню Draw>A

Variable name введите S21, в списке
Measurement отметьте S, в поле Da
этого дите 2 в поле To Po  

 

поле ввода с курсором в виде крестика. Дв
уравнения и щёлкните левой кнопкой мышки. 

 
S21=atr20: |S(2,1)]| 

 
Щёлкните левой кнопкой мышки в любом

для S21. 
4. Выберите в меню Draw>Add Equation или щёлкните

tion

области Complex Modifier, сни-
мите галочку в пере
если она установлена, нажмите 
OK (рис.6.59). 
появится поле ввода с курсором в 
виде крестика. Двигая мышку, ус-
тановите это поле в верхней части 

опкой мышки. Появится
Рис. 6.59 

окна уравнений и щёлкните левой кн

ки в любом месте окна уравнений за пределами выражения 

dd Output Equation. В открывшемся окне в текстовом поле 
 Measurement Type отметьте Port Parameters, в списке 

ta Source Name введите atr20, щёлкая по кнопке справа от 
rt Index и 1 в поле From Port Index, щёлкая по кнопкам

тель Mag в области Complex Modifier, снимите
 поля, вве

справа от этих полей, установите переключа
галочку в переключателе dB, если она установлена, нажмите OK. В окне уравнений появится 

игая мышку, установите это поле ниже предыдущего 
Появится выражение 

 месте окна уравнений за пределами выражения 

 левой кнопкой мышки по значку Equa-
  на панели инструментов. 

5. Переместите курсор в окно уравнений. В этом
гая мышкой, ниже предыдущего уравнения
ровать. 

6. Введите в поле вода уравнение: 
 

KstU=(1+S11)/(1-S11) 
 

и щёлкни опкой мышки вне это
7. Снова щёлкн кнопкой мышки по значку

дущих уравнений. 

 окне появится поле ввода. Установите его, дви-
 левой кнопкой и щёлкните  мышки, чтобы зафикси-

те левой кн
ите левой 

го поля или нажмите клавишу Enter. 
 Equation на панели инструментов и помес-

тите новое поле ниже преды
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Ldb=20*log10(1/S21) 

 
и щёлкните левой кнопкой мышки вне этого поля или нажмите клавишу Enter. 
уравнения будут выглядеть, как показано на рис. 6.60. 
 частот для моделирования. 

кнопкой мышки щёлкните по подгруппе atr20 в группе EM Structures и выберите 
 всплывающем меню я диалоговое окно Options. 

сти окна. 

5. Введите 4 в поле Start (Начало), ведите 18 в 
(Шаг). 

6. Нажмите Apply (Применить). В окне списка Cu
ется частотный диапазон и частотные точки с шаг

7. Нажмите OK. 
6.2.8. Создание графика, добавление измеряемых

1. Щёлкните по значку Add New Graph на панели
2. Введите имя графика, например, Graph 1 в поле

tangular (Прямоугольный) в области Graph Type

quation Name выбе-
рите Ldb и нажмите Apply. Нажмите 
OK. 

значку Analyze на панели инструмен-

формат данных, сохра-
няемых в файле, напри-
мер, Mag/Ang. 

менить это имя или со-
хранить файл в другой 
папке, щёлкните по кноп-
ке Set file name. В от-

не укажите 

 
файла или согласитесь с 

8. Введите в поле вода уравнение: 

Добавленные 
6.2.7. Определение

1. Правой 
Options во

Рис. 6.60 

. Откроетс
2. Щёлкните панель Frequencies (Частоты) в верхней ча
3. Снимите галочку (если она стоит) на переключателе Use Project Frequency (Использовать 

частоты проекта), чтобы локальные частоты имели преимущество перед глобальными час-
тотами проекта. 

4. Установите GHz в поле Data Entry Units, щёлкая по стрелкам справа от этого поля. 
поле Stop (Конец) и введите 1 в поле Step 

rrent Range (Текущий диапазон) отобража-
ом, которые вы только что определили. 

 величин и анализ. 
 инструментов. 
 Graph name (Имя графика), выберите Rec-

 (Тип графика) и нажмите OK. 
3. Щёлкните правой кнопкой мышки по 

подгруппе Graph 1 в окне просмотра 
проекта и выберите Add Measure-
ment. 

4. Выберите Output Equations в списке 
Measurement Type. В окне списка 
Equation Name выберите KstU, 
щёлкнув по кнопке справа. Отметьте 
переключатель Mag в области Com-
plex Modifier. Уберите галочку в окне 
dB, если она установлена. Нажмите 
Apply. 

5. В окне списка E

6. Щёлкните левой кнопкой мышки по Рис. 6.61 

тов. Результаты анализа отображаются на графике рис. 6.61. 
6.2.9. Вывод результатов в файл. 

1. Щёлкните правой кнопкой мышки по группе Output Files (Выходные файлы). 
2. Выберите Add Output File, откроется окно New Output File, показанное на рис. 6.62. От-

метьте Port Parameter и нажмите OK. 
3. В открывшемся окне рис. 6.63 выберите S Parameter в области Data Type (Тип данных). В 

области Format выберите 

4. В поле File Name ото-
бражается имя файла по 
умолчанию, причём файл 
будет сохранён в той же Рис. 6.62 папке, где находится про-
ект, если нажать кнопку 
OK. Если вы хотите из-

крывшемся ок
папку, где сохранить 
файл, и наберите имя

Рис. 6.63
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предлагаемы ь. Обратите внимание, что расширение 
файла должно быть s2p, где 2 указывает на количество портов. 

5. Нажмите OK в le. В группе Output Files появится имя сохраняемого 
, н

ve Office для таких 

 можно 

 

к-
 создаётся. Таб-

 для этих слоёв 
 создаются. Поэ  

й кнопкой 

прочесть

DXF Options отметьте 
l chars in 

 

экспорт
ните
тро
не
Ex

(ри

Aut
будет

рис. 6.66. Обратите внимание, что экспортирована только топология
мости можно экспортировать не только одну топологию проводников
всю плату нужно также нанести слой черчения, который в файле defau
по умолчанию) определён для экспорта, но не влияет на результаты анализа
черчения Error. 

м по умолчанию. Нажмите Сохранит

 окне Output Data Fi 
о файла на диске файл ещё не сохранён. 

6. Щёлкните по значку Analyze, чтобы сохранить файл на диске. 
6.2.10. Экспорт топологии в DXF файл. 

П  ри создании топологии в электромагнитной структуре мы использовали материалы 1/2oz Cu и 
Res. Этим материалам не назначено слоёв для черчения и для них нет таблиц соответствия слоёв. В этом 

icrowaслучае M
материал

Рис. 6.64 

ов автоматически создаёт 
слои черчения. В нашем случае были 
созданы слои черчения с именами 
+LAY_2_1/2oz Cu_COND (что
расшифровать как слой черчения на 
2-м слое диэлектрика, материал 1/2oz 
Cu, проводник), и
+LAY_2_Res_COND (см. рис. 6.57). 
Но lpf файл автоматически не реда
тируется и новый не
лицы соответствия
также не тому, если
просто экспортировать топологию в 
dxf файл, щёлкнув право
мышки по имени электромагнитной 
структуры в окне просмотра проекта 
и выбрать Export Layout, то dxf файл 
будет создан. Но AutoCAD  
его не сможет и выдаст сообщение, 
что в файле имеется строка с недо-
пустимым именем слоя. Чтобы уст-
ранить эту проблему, нужно вклю-
чить опцию исправления имени сло-
ёв, которая отключена по умолчанию. 
Чтобы сделать это: 

1. Выберите в меню Op-
tions>Layout Options. 
Откроется окно опций 
топологии (рис. 6.64). 

2. Откройте вкладку Ex-
port/LPF. В области 

Remove illega
layer names (Удалить
недопустимые символы 
в именах слоёв) и на-
жмите OK. 

Теперь можно выполнять 
 топологии. Для этого щёлк-

 правой кнопкой по имени элек-
магнитной структуры Atr20 в ок-

 просмотра проекта и выберите 
port Layout. В открывшемся окне Рис. 6.65 

установите тип файла DXF(DXF 
Flat, *.dxf) и нажмите Сохранить 

с. 6.65). 
Топология, загруженная в 

oCAD из созданного dxf файла, 
 выглядеть, как показано на 

 без контура платы. При необходи-
, но и контур платы. Для этого на 
lt.lpf (этот файл загружен в проект 

. Таким слоем является слой 

Рис. 6.66 



Щёлкните левой кнопкой 
мышки по значку Rectangle на па-
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угол корпуса электромагнитной 
ры, нажмите левую кнопку 

мышки и переместите курсор на 

акт

мышкой после каждого перемещения на 0.6 вправо, на 0.2 вниз, на
здесь дважды щёлкните левой кнопкой мышки. Щёлкните по зн
Щёлкая мышкой по значку Paste на панели инструментов и затем, щ
развернуть скопированный реперный знак соответствующим обра ы знаки  
остальных углах созданного прямоугольника. 

Выберите в меню Options>Layout Options и на вкладке Layout F
Height введите высоту шрифта 0.6 мм и нажмите OK. Выберите в меню
на то место в электромагнитной структуре, где должен быть текст, и щёлкните
ся поле введите нужный текст, например Attenuator, щёлкните мышкой

По умолчанию вновь создаваемым топологическим элементам
черчения Copper. Проверьте это, щёлкнув по реперному знаку или тексту
правой кнопкой и выбрав Shape Properties. В противном случае назначьте
тельно нажав клавишу Shift и щёлкая мышкой по реперным знакам и 
тромагнитная структура будет выглядеть, как показано на рис. 6.69. 

Выполните экспорт созданной электромагнитной структуры. 
как показано на рис. 6.70. 

акт

угол созданного прямоугольника и щёлкните левой кнопкой мышк
мышкой после каждого перемещения на 0.6 вправо, на 0.2 вниз, на
здесь дважды щёлкните левой кнопкой мышки. Щёлкните по зн
Щёлкая мышкой по значку Paste на панели инструментов и затем, щ
развернуть скопированный реперный знак соответствующим обра ы знаки  
остальных углах созданного прямоугольника. 

Выберите в меню Options>Layout Options и на вкладке Layout F
Height введите высоту шрифта 0.6 мм и нажмите OK. Выберите в меню
на то место в электромагнитной структуре, где должен быть текст, и щёлкните
ся поле введите нужный текст, например Attenuator, щёлкните мышкой

По умолчанию вновь создаваемым топологическим элементам
черчения Copper. Проверьте это, щёлкнув по реперному знаку или тексту
правой кнопкой и выбрав Shape Properties. В противном случае назначьте
тельно нажав клавишу Shift и щёлкая мышкой по реперным знакам и 
тромагнитная структура будет выглядеть, как показано на рис. 6.69. 

Выполните экспорт созданной электромагнитной структуры. 
как показано на рис. 6.70. 

нели инструментов. Установите 
курсор мышки на верхний левый 

структу

правый нижний угол корпуса, от-
пустите кнопку. Весь прямоуголь-
ник корпуса будет выделен. Щёлк-
ните по выделенному прямоуголь-
нику правой кнопкой мышки, выбе-
рите Shape Properties и в открыв-
шемся окне введите Error в поле 
Drawing Layer, оставив значения 
остальных полей по умолчанию 
(рис. 6.67). Нажмите OK. 

Щёлкните по значку Ana-
lyze, чтобы убедиться, что хар е-
ристики структуры не изменились. 

Выполните экспорт, как 
описано выше. Теперь топология, 
загруженная в AutoCAD, будет вы-
глядеть, как показано на рис. 6.68.  

При необходимости на соз-
данном слое Error можно нанести 
дополнительные топологические 
элементы, например реперные знаки 
и строки текста. 

Щёлкните мышкой по знач-
ку Polygon на панели инструментов. 
Установите курсор на левый верхний 
. Затем передвигайте курсор, щёлкая 

 0.4 влево, на 0.4 вниз, на 0.2 влево и 
ачку Copy на панели инструментов. 
ёлкая правой кнопкой мышки, чтобы 
зом, установите репернн е  на

 
остальных полей по умолчанию 
(рис. 6.67). Нажмите OK. 

Щёлкните по значку Ana-
lyze, чтобы убедиться, что хар е-
ристики структуры не изменились. 

Выполните экспорт, как 
описано выше. Теперь топология, 
загруженная в AutoCAD, будет вы-
глядеть, как показано на рис. 6.68.  

При необходимости на соз-
данном слое Error можно нанести 
дополнительные топологические 
элементы, например реперные знаки 
и строки текста. 

Щёлкните мышкой по знач-
ку Polygon на панели инструментов. 
Установите курсор на левый верхний 
и. Затем передвигайте курсор, щёлкая 
 0.4 влево, на 0.4 вниз, на 0.2 влево и 
ачку Copy на панели инструментов. 
ёлкая правой кнопкой мышки, чтобы 
зом, установите репернн е  на

Рис. 6.67 

Рис. 6.68 

угол созданного прямоугольника и щёлкните левой кнопкой мышки

ont открывшегося окна в поле 
 Draw>Text, переместите курсор 

 мышкой. В образовавшее-

ont открывшегося окна в поле 
 Draw>Text, переместите курсор 

 мышкой. В образовавшее-
 вне поля текста. 
 и для текста назначается слой 

 левой кнопкой мышки и затем 
 этот слой вручную, предвари-

тексту, чтобы выделить их. Элек-

В AutoCAD она будет выглядеть, 

 вне поля текста. 
 и для текста назначается слой 

 левой кнопкой мышки и затем 
 этот слой вручную, предвари-

тексту, чтобы выделить их. Элек-

В AutoCAD она будет выглядеть, 

Другой способ экспорта электромагнитных структур при установках по умолчанию будет рас-
смотрен в следующем примере. 

Другой способ экспорта электромагнитных структур при установках по умолчанию будет рас-
смотрен в следующем примере. 

Рис. 6.69 Рис. 6.70 
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6.3 Моделирование микрополоскового двухсекционн
мощности. 

Создайте новый проект и сохраните его, присвоив имя Divid
Создайте электромагнитную структуру, как описано в приме , е
На вкладке Enclosure окна свойств электромагнитной струк

ле Y_Dim введите 5.1, в поле Grid_X введите 0.1 и в поле Grid_Y вв
На вкладке Material Defs для области Dielectric Definition

0.0001 в поле TanD. Для области Conductor Definitions, щёлкая мы
риалы проводника Aluminum и Resist, как описано в примере 6.2. 

На вкладке Materials щёлкните мышкой по кнопке Insert. В
ся имя Trace1 на Alum, в столбце Thickness введите 0.02, в столбце
num, щёлкнув мышкой по этому полю. Снова щёлкните мышкой по
дите имя материала Res, в столбце Thickness введите 0.00025, в стол
sist, щёлкнув мышкой по этому полю. 

Все остальные параметры на всех вкладках окна свойств э
такие же, как и в примере 6.2. 
6.3.1. Создание топологии входного проводника. 

1. Щёлкните по значку View Area на панели инструмент
возле левого кр ы хорошо была видна сетка. 

2. Выберите в меню Draw>Polygon (Чертить>Многоугольник) и е 
мышки по значку Polygon

ого делителя 

er, как описано в примере 6.2. 
ре 6.2 присвоив й имя Div. 
туры в поле X_Dim введите 10, в по-
едите 0.05. 
s введите 10.55 в поле Er, введите 
шкой по кнопке Add, добавьте мате-

 столбце Name замените появившее-
 Material Definition введите Alumi-
 кнопке Insert. В столбце Name вве-
бце Material Definition введите Re-

лектромагнитной структуры введите 

 
ая так, чтоб

ов и выделите среднюю часть платы 
Это облегчит черчение. 

ли щёлкнит левой кнопкой 
  на панели инструментов

3. Переместите курсор в окно электромагнитной структу
пуса примерно в центре по ширине корпуса и щёлкни -
фиксировать начало рисунка топологии. 

4. Не нажимая кнопки мышки, двигайте курсор вправо
dy:0. Щёлкните левой кнопкой мышки, чтобы зафикси

5. Нажмите клавишу Tab, в открывшемся окне в поле d
нажмите OK. 

6. Продолжайте аналогично: 
o двигайте раво, пока будет dx:0.1 dy:0; 

 двигайте из, пока будет dx:0 dy:-0.15; 

dx:0.1 dy:0; 

. 
ры, поместите его на левый край кор-
те левой кнопкой мышки, чтобы за

 так, чтобы было отображено dx:2, 
ровать эту точку. 
x введите 0.3, в поде dy введите 0.15, 

 курсор вп
 курсор внo

o двигайте курсор влево, пока будет dx:-0.1 dy:0; 
o нажмите клавишу Tab, в открывшемся окне в поле dx введите -0.4, в поде dy введите -

0.25, нажмите OK; 
o нажмите клавишу Tab, в открывшемся  окне в поле dx введите 0.4, в поде dy введите -

0.25, нажмите OK; 
o двигайте курсор вправо, пока будет 
o двигайте курсор вниз, пока будет dx:0 dy:-0.15; 
o двигайте курсор влево, пока будет dx:-0.1 dy:0; 
o нажмите клавишу Tab, в открывшемся окне в поле dx введите -0.3, в поде dy введите 

0.15, нажмите OK; 
o двигайте курсор влево, пока будет dx:-2 dy:0 и здесь дважды щёлкните левой кнопкой 

мышки; чтобы замкнуть контур. 
7. Щёлкните левой кнопкой мышки по входному проводнику, чтобы его выделить, если он не 

выделен. 
8. Щёлкните по значку Measure  на панели 

инструментов, измерьте расстояния от верхне-
го края проводника до верхнего края корпуса и 
от нижнего края проводника до нижнего края 
корпуса. Эти расстояния должны быть одина-
ковыми и равными 2.3 мм. В противном случае 
поместите курсор на созданный проводник, 
нажмите левую кнопку мышки и, двигая про-
водник, поместите его симметрично относи-
тельно стенок корпуса. 

Полученная топология входного проводника показана на рис. 6.71. 
Примечание. Если дважды щёлкнуть левой кнопкой по проводнику, в срединах ограничиваю-

щих проводник линиях появятся тёмно-синие ромбики, а в углах – тёмно-синие квадратики. Поместив 
курсор на такой ромби ратик так, чтобы он отображался в виде дв лки, можно, нажав 
левую кнопку

 к этой вершине. Если при перемещении вершины нажать кла-
вишу Shift, то будет перемещаться только вершина. 

Рис. 6.71 

к или квад
, двигать л

ойной стре
м, редакти мышки инию или угол топологии и, таким образо ровать топологию. 

Если установить курсор на вершину многоугольника и перемещать её с нажатой кнопкой мышки, то бу-
дет перемещаться и сторона, прилегающая
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кните левой кнопкой мышки по значку  на панели инструментов. 
естите курсор в окно электромагнитной структуры и нажмите клавишу Tab на клавиа-

льные координаты. Вве-

урсор в поле электромагнитной струк-

значку Paste на панели инст-

сор в поле электромагнитной 
структуры и подключите 

делителя. 

6.3.3. 

ку Zoom Area на панели инструментов и выделите 

ентов. 

3 в поле x, введите 3.1 в поле y и нажмите OK. Нажмите клавишу Tab сно-
реключателе Rel, чтобы активизировать относительные коорди-

 OK. 
н, щёлкните по значку Copy и затем по 
значку Paste на панели инструментов. 

магнитной структуры и подключите 

нижнему углу нижнего проводника де-
ителя. Должна получиться топология, 
показанная на рис. 6.73. 
Щёлкните левой кнопкой мышки по 

тов. 

угол верхнего выходного проводника, 

рсор на 0.5 мм влево, щёлкните левой кнопкой мышки, переместите курсор на 0.3 
мм вниз и дважды щёлкните левой

8. Выделите созданный треугольник, 
местите курсор на выделенный прямо

 созданную топологию. Для 

6.3.2. Создание топологии проводников плеч делителя. 
1. Щёл Rectangle
2. Пом

туре. Откроется диалоговое окно Enter Coordinates. 
3. Введите 2.4 в поле x, введите 2.95 в поле y и нажмите OK. 
4. Нажмите клавишу Tab снова, чтобы открыть диалоговое окно Enter Coordinates. Устано-

вите флажок в переключателе Rel, чтобы активизировать относите
дите 2.2 в поле dx, и -0.15 в поле dy и нажмите OK. 

5. Выделите созданный проводник, если он не выделен, щёлкните по значку Copy и затем по 
значку Paste на панели инструментов. Переместите к
туры и подключите скопированный проводник к нижнему плечу делителя. 

6. Повторите пункты с 1-го по 4-ый, но введите 4.6 в поле x, введите 2.8 в поле y, 2.7 в поле 
dx, 0.3 в поле dy. 

7. Выделите созданный проводник, если он не выделен, щёлкните по значку Copy и затем по 

рументов. Переместите кур-

скопированный проводник к 
нижнему плечу Рис. 6.72 

Должна получиться топология, показанная на рис. 6.72. 
Создание топологии выходных проводников. 

1. Щёлкните левой кнопкой мышки по значку Auto View на панели инструментов, чтобы ото-
бразить всю плату. 

2. Щёлкните левой кнопкой мышки по знач
правую часть обоих последних проводников делителя так, чтобы была видна сетка. 

3. Щёлкните левой кнопкой мышки по значку Rectangle на панели инструм
4. Поместите курсор в окно электромагнитной структуры и нажмите клавишу Tab на клавиа-

туре. Введите 7.
ва. Установите флажок в пе
наты. Введите 0.5 в поле dx, и 2 в поле dy и нажмите

5. Выделите созданный проводник, если он не выделе

Переместите курсор в поле электро-

скопированный проводник к правому 

л

6. 
значку Polygon на панели инструмен-

7. Поместите курсор на правый нижний 

щёлкните левой кнопкой мышки, пере-
местите ку

Рис. 6.73 

 кнопкой мышки. 
если он не выделен. Выберите в меню Edit>Mirror, по-

угольник, нажмите левую кнопку мышки и вращайте 
мышкой созданную копию, пока не полу-
чите зеркальное отображение треугольни-
ка для соединения нижних проводников, и 
щёлкните левой кнопкой мышки. Затем 
поместите созданный треугольник так, 
чтобы соединить нижние проводники, как 
показано на рис. 6.74. 

9. Выделите всю
этого установите курсор левее и выше соз-
данной электромагнитной структуры, на-
жмите левую кнопку мышки и перемести-
те курсор правее и ниже электромагнитной 
структуры так, чтобы вся топология попа-

ла в образовавшийся прямоугольник. Или выберите в меню Edit>Select All. 

Рис. 6.74 
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му проводнику и выберите Shape 
. 

 на панели инструментов. 
ажмите клавишу Tab на клавиа-

 переключателе Rel, введите 0.3 в поле 

ть их. Щёлкните правой кнопкой мышки по любому выделенному рези-

жмите OK. 
6.3.5. Добавление портов и установка референсных п

Добавьте порты к входному проводнику, и затем к верхнему
как описано
ренсные пло

ая на рис. 6.75. 
пределение частот для модели-

в пр иске Measurement Type, S в спи-

метьте dB и Mag, нажмите Apply. Затем выберите 3 в
OK. 

Создайте прямоугольный график Graph 2 и доб
В окне Add Measurement выберите Port Parameter в 

 в поле From 

окне Add Measurement вы-

10. Щёлкните правой кнопкой мышки по любому выделенно
Properties. В открывшемся окне в поле Material введите 1/2oz Cu и нажмите OK

6.3.4. Создание топологии резисторов. 
1. Щёлкните левой кнопкой мышки по значку Rectangle
2. Поместите курсор в окно электромагнитной структуры и н

туре. Откроется диалоговое окно Enter Coordinates. 
3. Введите 4.5 в поле x, введите 2.1 в поле y и нажмите OK. 
4. Нажмите клавишу Tab снова. Установите флажок в

dx, 0.9 в поле dy и нажмите OK. 
5. Повторите пункты с 1-го по 4-ый, но введите 7.2 в поле x, введите 2.1 в поле y, 0.1 в поле 

dx, 0.9 в поле dy. 
6. Нажмите клавишу Shift и щёлкните левой кнопкой мышки поочерёдно по обоим резисто-

рам, чтобы выдели
стору и выберите Shape Properties. В открывшемся окне в поле Material введите Res и на-

лоскостей. 
 и нижнему выходным проводникам, 
 в примере 6.2 и сдвиньте их рефе-
скости на 1 мм внутрь электромаг-

нитной структуры. Должна получиться тополо-
гия, показанн
6.3.6. О
рования. 

Определите частоты для моделирования, 
как описано в примере 6.2, но введите 4 в поле 
Start, 18 в поле Stop и 1 в поле Step. 
6.3.7. Создание графиков, добавление 
измеряемых величин и анализ. 

Создайте прямоугольный график Graph 1 и добавьте к нему измеряемые величины, как описано 
имере 6.2. В окне Add Measurement выберите Port Parameter в сп

Рис. 6.75 

ске Measurement, Div в поле Data Source Name, 2 в поле To Port Index, 1 в поле From Port Index, от-
  поле To Port Index и нажмите Apply. Нажмите 

авьте к нему следующую измеряемую величину. 
списке Measurement Type, S в списке Measure-

ment, Div в поле Data 
Source Name, 3 в поле To 
Port Index, 2
Port Index, отметьте dB и 
Mag, нажмите Apply. На-
жмите OK. 

Создайте прямо-
угольный график Graph 3 и 
добавьте к нему следующую 
измеряемую величину. В 

берите Linear в списке 
Measurement Type, VSWR в 
списке Measurement, Div в 
поле Data Source Name, 1 в 
поле Port Index, снимите 
отметку dB. Нажмите Apply. 
Введите 2 в поле Port Index 
и нажмите Apply. Введите 3 
в поле Port Index и нажмите 
Apply. Нажмите OK. 

Щёлкните левой 
кнопкой мышки по значку 
Analyze на панели инстру-
ментов. Выберите в меню 
Window>Tile Vertical. Ре-
зультаты анализа отобража-
ются на графиках рис. 6.76. Рис. 6.76 
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ктромаг-
топологии при установках по умолчанию может быть 

рументов. Откроется пустое окно 

 введите множитель 0.5, чтобы размер ячеек 

ольник со сторонами, равными сторонам корпуса электромагнитной 

 dy введите 5.1, нажмите OK. 
 топологию и щёлкни-

щёлкните по значку  на панели инст
созданный прямоугольник.  

6. По умолчанию слой черчения для всех эл
именем Error. Пользуясь тем, что dxf фай  о материале 
топологических элементов, мы для экспо
ментам слой черчения, который уже имеет

Copper

 прямо-

кнопкой мышки и выберите Shape 

жмите O
логия, по

7. В Micro
которая 
элементы
процессе  нашем случае 

нежелательно ть 
ты п
лител
обход т
едини
это д
струк
Shift
рёдно
теля, 
щёлк

6.3.8. Экспорт топологии в DXF файл. 
едыдущем примере экспорт топологии выполнялся непосредственно из окна элеВ пр

нитной структуры. Другим вариантом экспорта 
предварительное копирование в окно топологии схемы. 

1. Щёлкните мышкой по значку Add New Schematic и создайте схему с именем 
Div_Schematic. Откроется пустое окно схемы. 

2. Щёлкните мышкой по значку View Layout на панели инст
топологии схемы. 

3. В поле Grid Spacing на панели инструментов
сетки сделать равным 0.05 мм. 

4. Создайте прямоуг
структуры. Для этого щёлкните мышкой по значку Rectangle на панели инструментов. По-
метите курсор в окно топологии схемы и нажмите клавишу Tab. В открывшемся окне в по-
ля x и y ведите 0, нажмите OK и затем клавишу Tab. В открывшемся окне в поле dx введи-
те 10, в поле

5. Сделайте активным окно электромагнитной структуры, выделите всю
те по значку Copy на панели инструментов. Сделайте активным окно топологии схемы и 

Paste рументов. Вставьте скопированную топологию в 

ементов топологии при копировании назначен с 
л не содержит никакой информации
рта можем назначить всем топологическим эле-
ся в lpf файле. В файле default.lpf такими слоями 

являются слои Error и . По-
этому можно оставить для всех эле-
ментов слой Error. Но для удобства 
отображения назначим элементам то-
пологии делителя слой Copper. Уста-
новите курсор левее и выше
угольника топологии, нажмите левую 
кнопку мышки и переместите курсор 
правее и ниже топологии, но не правее 

правого края платы, чтобы выделить только всю топологию без платы. Щёлкните правой 
Рис. 6.77

Properties. В открывшемся окне в по-
ле Draw Layers введите Copper и на-

K. Должна получиться топо-
казанная на рис. 6.77. 
wave Office имеется опция, 
позволяет объединить все 
 топологии в один элемент в 
 экспорта. В

Рис. 6.78 

 объединя элемен-
роводников и резисторов де-
я. Поэтому эту функцию не-
имо отключи ь. Можно объ-
ть проводники делителя, но 
нужно с елать до экспорта 
туры. Нажмите клавишу 

 и щёлкните мышкой пооче-
 по всем проводникам дели-
чтобы выделить их. Затем 
ните по значку Union  на 
и инструментов. Топология 
 иметь вид рис. 6.78. 
рите в меню Options>Layout 
ns. На вкладке Expo

панел
будет

8. Выбе
Optio r
открыв
лочку
shape
Optio

9. Выбе
В от

тип файла DXF(DX xf) и нажмите Сохранить. 

t/LPF 
шегося окна снимите “га-

” возле опции Union layout 
s в области Layout Export 
ns (рис. 6.79) и нажмите OK. 
рите в меню Layout>Export. 
крывшемся окне установите 

Рис. 6.79 

F Flat, *.d
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В AutoCAD топология из созданного DXF 

В Microwa
эле  DXF файлов, будем использовать файл, создан-

Project, и сохраните его под 

я соз-

файла будет выглядеть, как показано на рис. 6.80. 
В этом примере в окне редактора тополо-

гии схемы вначале создавался прямоугольник, по-
крытый слоем черчения, чтобы записать в DXF 
файл размеры платы. На этом слое вы можете в 
редакторе топологии схемы добавить различные 
дополнительные топологические элементы, как 
описано в предыдущем примере. Если нужно за-
писать в DXF файл только топологию делителя, 
заполненного прямоугольника создавать не нужно, 
а просто скопировать топологию делителя. 

Импорт топологии из DXF файла. 
ve Office 2009, в отличие от 7-ой версии, топологию можно импортировать непосредственно в 

ктромагнитную структуру. Т.к. в каталоге AWR нет

Рис. 6.80 

6.3.9. 

ный в этом примере. 
1. Создайте новый проект, вы-

брав в меню File>New 

именем Divider-Import, вы-
брав в меню File>Save Project 
As. 

2. Щёлкните правой кнопкой 
мышки по группе EM Struc-
tures в окне просмотра проек-
та и выберите Import DXF. В 
открывшемся окне найдите 
файл Div_Schmatic и загрузи-
те его в проект. Откроется ок-
но с запросом, какие единицы 
измерения использовать. Вве-
дите mm и нажмите OK. В 
следующем окне будет сооб-
щение, какие слои будут сге-
нерированы автоматически. 
Нажмите OK. Откроется окно 
New Div_Schmatic (рис. 6.81). 
В этом окне введите им

Рис. 6.81 

Рис.6.82 

даваемой структуры или ос-
тавьте по умолчанию. От-
метьте AWR EMSight Simu-
lator и нажмите Create. Им-
портированная структура по-
казана на рис. 6.82. Создан-
ный по умолчанию корпус 
больше импортированной 
структуры. 

3. Щёлкните по значку Substrate 
Information на панели инст-
рументов. Откроется окно 
свойств электромагнитной 
структуры. 

4. На вкладке Enclosure введите 
10 в поле X_Dim, 5.1 в поле 
Y_Dim, 0.1 в поле Grid_X и 
0.05 в поле Grid_Y. На всех 
вкладках окна свойств элек-
тромагнитной структуры вве-
дите те же параметры, которые 
были введены в начале этого 
примера. Структура может вы-
глядеть, как показано на рис. 
6.83. Т.е. импортированная то-
пология может не совпадать с 
созданным корпусом. 

Рис.6.83 
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5. 
 

но-
стью размеров в AutoCAD и в Microwave 

8. 

части
9. Дважды

ля
ке

10. Нажмите
эту
точка
тральной

11. Установите
верхней стороны верхнего проводника делителя так
стрелки. Нажмите левую кнопку мышки, нажмите кла
0.05 мм вниз, чтобы ширина проводника была 0.15 мм

12. Аналогично  нижнюю сторону нижнего пр
дет выгляд азано на рис. 6.86. 

13. Выделите проводники топологии, кроме резисторов
кой мышки и, выбрав Shape Properties, установите
Аналогично резисторам назначьте материал Res. Устан

Теперь можно определить частоты, создать графики и выполнять
Другой способ импорта топологии заключается в том, что

вать в редактор топологического чертежа Artwork Editor, затем 
тромагнитной структуры. Т.к. импортируемый файл не содержит
лирования электромагнитной структуры (номера слоя модели, мате

форму. В этом пр
торый можно применить для простой структуры, имеющей только

1. Откройте менеджер топологии, щёлкнув мышкой о 
на проекта. 

2. Щелкните шки по Cell Li-
braries

3. В открыв
торый нужно
будет Div_Sc
окно с запросо
пользуются
нажмите
тором сооб

Установите курсор выше и левее тополо-
гии, переместите курсор правее и ниже

Рис. 6.84 

топологии так, чтобы вся топология попа-
ла в образовавшийся прямоугольник, от-
пустите кнопку мышки. 

6. Установите курсор на топологию, нажми-
те левую кнопку мышки и переместите 
топологию в корпус (рис. 6.84). 

7. Проводники в первой секции делителя 
импортированы с ошибкой (ширина верх-
него проводника 0.2, а нижнего – 0.1 мм). 
Возможно, это связано с различной точ

Office или по другой причине. В таких 
случаях требуется редактирование топо-
логии. 
Щёлкните по значку View Area на панели 
инструментов и увеличьте отображение 

 делителя, указанной на рис. 6.84. 
 щёлкните по проводнику делите-

. Установите курсор на квадратик в точ-
 разветвления проводника так, чтобы он 

Рис. 6.85 

отображался в виде перекрещенных стре-
лок (рис. 6.85). 

 левую кнопку мышки и сместите 
 точку виз на 0.05 мм (dy:-0.05), чтобы 

 разветвления располагалась по цен-
 оси входного проводника. 

 курсор на ромбик посередине 
, чтобы он отображался в виде двойной 
вишу Shift и сдвиньте эту сторону на 
. 

оводника на 0.5 мм вниз. Топология бу-

, щёлкните по проводнику правой кноп-
 слой 2 и назначьте материал 1/2 oz Cu. 

овите порты. 
 моделирование. 

 сначала топологию нужно импортиро-
копировать и вставить в редактор элек-
 информации, необходимой для моде-
риала и т.д.), программе нужно ука-

имере рассмотрим метод импорта, ко-
 один или немного слоёв. 
панели Layout в левом нижнем углу ок-

 правой кнопкой мы
F

Рис. 6.86 

 сдвиньте
еть, как пок

зать, как обрабатывать каждую топологическую 

 и выберите Import DX  Library. 
шемся окне импорта найдите файл, ко-

 импортировать (в нашем случае это 
hematic) и откройте его. Откроется 
м, какие единицы измерения ис-

 в файле (рис. 6.87). Введите mm и 
 OK. Откроется следующее окно, в ко-

щается, какие слои будут созданы ав-
томатически (рис. 6.88), 
нажмите OK. В окне 
менеджера топологии 
появится имя библиоте-
ки элементов 
Div_Schematic (с указа-
нием пути к DXF файлу) 
и в этой библиотеке бу-
дет ячейка с таким же 
именем (рис. 6.89). 

Рис.6.87 

Рис.6.89Рис. 6.88
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4. Дважды щёлкните мышкой по имени яче ейся библиотеке элементов. Откро-
ется окно редактора ячейки с импорти

оекта. Откроется 

е GHz, в 

рументов и создайте электро-
м структуру с именем Div_E

9. Щёлкните по знаку Substrate Information
корпуса и материалов, как описано выше

10. Щёлкните по значку Paste на панели
корпус. Электромагнитная структура буде

11. Выделите все проводники топологии, кроме
правой кнопкой мышки и, выбрав Shape
ал 1/2 oz Cu. Аналогично резисторам назначьте  порты. 

Откройте окно просмотра проекта, щёлк
экрана. Теперь мо елить частоты, создать гр

Заметим,  способе импортирования
 

у, если в электромагнитную структуру топология импортирована с ошибкой (или 

6.4. 
ванно

1. Выберите File>New Project (Файл
2. Выберите File>Save Project As (

ется диалоговое окно Save As. 
3. Наберите NO и нажмите Сохр
4. Выберите в меню Options>Projec

tions в левом окне просмотра 
5. На вкладке Global Units этого окн

дите mm и нажмите OK. 
6.4.2. Добав оёв черчения и у

Ввести все необходимые слои для чер
создания электромагнитных структур, чтобы не возникло проблем с
структурах. 

Щёлкните мышкой по панели Layout в левом нижнем углу окн
менеджера топологии. В верхней части окна менеджера топологии в гр
ёв) отображается загруженный LPF файл. По умолчанию это default.lpf
имени Default этого файла. Откроется окно (рис. 6.91) с перечнем слоёв
файле. Альтернативно это окно можно вызвать, выбрав в меню Options>Dr

йки в появивш
рованной топологией (рис. 6.90). 

5. Выберите в меню Options>Project 
Options или дважды щёлкните 
мышкой по Project Options в левом 
окне просмотра пр
диалоговое окно Project Options. 

6. На вкладке Global Units этого окна 
в поле Frequency введит
поле Length type введите mm и на-
жмите OK. 

7. Выберите в меню Edit>Select All, 
чтобы выделить всю топологию и 
затем щёлкните по значку Copy на 
панели инструментов, чтобы скопи-
ровать топологию. 

 на панели инст
Рис. 6.90 

8. Щёлкните по значку Add New EM Structure
M. 

 на панели инструментов. Определите параметры 
. 

агнитную 

 инструментов и вставьте скопированную структуру в 
т выглядеть, как показано на рис. 6.90. 

 резисторов, щёлкните по любому проводнику 
 Properties, установите слой 2 и назначьте матери-

 материал Res. Установите
нув мышкой по панели Project в левой нижней части 

афики и выполнять моделирование. 
, ошибок при импорте топологии не было. 

жно опред
что в этом

Замечание. При импорте dxf-файла непосредственно в электромагнитную структуру, автомати-
чески топология импортируется одновременно и в редактор Artwork Editor. Причём иногда им-
порт в электромагнитную структуру не производится, но топология появляется в Artwork 
Editor. Поэтом
вовсе не импортирована), её можно вместо редактирования просто удалить и скопировать из 
Artwork Editor. 

Моделирование микрополоскового двухсекционного симметриро-
го направленного ответвителя. 
В этом примере введём новые слои для черчения электромагнитной структуры и таблицы соот-

ветствия слоёв. Как видно из предыдущих примеров, это не обязательно делать для достаточно простых 
структур. Но для многослойных структур с большим количеством топологических элементов этот метод 
может быть более предпочтительным. Здесь мы рассмотрим только саму идею на простом примере 
структуры с двумя слоями диэлектрика (т.е. всего будет три слоя вместе со слоем воздуха). 
6.4.1. Создание нового проекта. 

>Новый проект) в выпадающем меню. 
Файл>Сохранить проект как) в выпадающем меню. Откро-

анить. 
s или дважды щёлкните мышкой по Projt Option ect Op-

проекта. Откроется диалоговое окно Project Options. 
а в поле Frequency введите GHz, в поле Length type вве-

становка таблиц соответствия слоёв. 
чения на соответствующих слоях диэлектрика лучше до 

 их установкой в уже созданных 

а проекта, чтобы открыть окно 
уппе Layer Setup (Установка сло-

. Дважды щёлкните мышкой по 
 черчения, имеющихся в LPF 
awing Layers. 

ление сл
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не отк
o 

чения в 

o 
o 
o 

o ёлкнув мышкой в этом столбце, можно выбрать тип линии и её цвет для черче-

-
ких форм. 

необходимые 
свойства нового слоя в остальных столбцах. 

 в строке Copper 

тельное окно рис. 6.92. В верхней 
части этого окна можно определить 

о умол-

слой будем использовать для черче-
на нижнем 

Под слоем Copper появится слой 

вать медные проводники на 2-м слое, т.е. на верхнем слое диэлектрика. 

При открытии окна обычно сразу открыта папка General (Общие) в левой части окна. Если она 
рыта, щёлкните по ней мышкой, чтобы открыть. Эта папка содержит три типа слоёв: 

ing Layer 2d – слои черчения для двухмерного представления структуры; 

Рис. 6.91

Draw
o Drawing Layer 3d – слои для трёхмерного отображения структуры; 
o Drill Hole Layers – слои для черчения отверстий. 

В правой части окна на странице Drawing Layer 2d Properties (Свойства слоёв черo 
двухмерном представлении) имеются следующие столбцы: 
Name – имя слоя; 
Visible (Видимость) – если отмечено, слой будет отображаться в структуре; 
Cloak (Скрыть) – если отмечено, слой не будет отображаться для черчения в нижней части окна 
менеджера топологии при черчении топологических элементов в окне топологии схемы (не пу-
тайте с окном черчения электромагнитной структуры); 
Line – дважды щ
ния топологических элементов; 

o Fill (Заполнение) – дважды щёлкнув мышкой в этом столбце, можно выбрать тип и цвет запол
нения (штриховки) вычерчиваемых топологичес

o Show Fill (Показать заполнение) – если отмечено, топологическая форма в окне топологии схе-
мы будет отображаться заполненной, в противном случае будет отображаться только её контур. 

o Freeze (Закрепить) – если отмечено, слой будет закреплён. 
Чтобы добавить новый слой черчения, щёлкните мышкой по кнопке New Layer в правой части 

окна. Появится новая строка с именем Layer1 (новый слой устанавливается после того слоя, который 
отмечен в окне). Переименуйте этот слой, введя новое имя в столбце Name, и установите 

1. Дважды щёлкните
в столбце Fill. Откроется дополни-

тип заполнения, а в нижней – цвет. 
Оставьте тип заполнения п
чанию, отметьте красный цвет. Этот 

ния медных проводников 
слое диэлектрика, т.е. на 3-м слое. 

2. Щёлкните по кнопке New Layer. 

Layer1. Переименуйте этот слой в 
Copper1. Отметьте Visible. Дважды 
щёлкните в столбце Fill и выберите 

красный цвет для заполнения. Снова щёлкните в столбце Fill и выберите тип заполнения, 
отличный от заполнения слоя Copper. Отметьте Show Fill. На этом слое будем вычерчи-

Рис. 6.92
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3. Щёлкните по кнопке New Layer. Под слоем Copper1 появится слой Layer1. Переиме-
нуйте этот слой в Res. Отметьте Visible. Дважды щёлкните в столбце Fill и выберите тип 
и цвет для заполнения. Отметьте Show Fill. На этом слое будем вычерчивать резисторы. 

4. У нас будет два слоя диэлектрика, поэтому потребуется два слоя платы. Отметьте слой 
Board и щёлкните по кнопке New Layer. Переименуйте новый слой в Board 1. Для слоёв 
платы отметьте Visible, и Show Fill. Дважды щёлкните мышкой в столбце Fill и выберите 
сплошное заполнение (чёрный квадратик в левом верхнем углу верхней части выпадаю-
щего окошка на рис. 6.92) и белый цвет в нижней части окошка. Обычно эти значения 
установлены по умолчанию. Слои платы используем только для наглядного отображения 
структуры при её трёхмерном отображении. Для создания электромагнитной структуры и 
анализа они не требуются. Окно свойств слоёв для 2-х мерного черчения будет выгля-
деть, как показано на рис. 6.93. 

5. Щёлкните мышкой по EM Layer Mappings. Откроется окно для установки соответствия 
слоёв черчения (Drawing Layer) и слоёв электромагнитной структуры (EM Layer). Эта 

Рис. 6.93

таблица соответствия устанавливает, какие слои черчения можно использовать для за-
данного слоя диэлектрика (рис. 6.94). 

Рис. 6.94
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 Copper 1 установите второй слой диэлектрика, введя 2 в 

 

тировать контур платы отметьте также Board. Снимите отметки у остальных слоёв. В 
столбце File Layer указывается, под каким именем каждый слой будет записан в DXF 
файл. Обычно это не имеет значения и можно оставить имена слоёв в файле по умолча-
нию. Но при необходимости вы можете присвоить свои имена. Если предполагается вы-
полнить экспорт топологии со всех слоёв или нескольких, то нужно создать таблицы для 
каждого экспортируемого слоя. Щёлкните правой кнопкой мышки в левой части окна и 
выберите New DXF File Export Mapping. В левой части окна появится имя новой табли-
цы FileMap1 (DXF). В правой части окна щёлкните по кнопке Uncheck All, чтобы снять 
отметки у всех слоёв, и затем отметьте Copper1 и Board1 (рис. 6.95). 

8. Нажмите OK. 

Заметим, что все указанные установки должны быть сделаны до создания электромагнитной 
структуры. Если в проекте требуется создать несколько электромагнитных структур с различными уста-
новками, нужно сделать установки для всех предполагаемых структур. 

Теперь создадим электромагнитную структуру. 
6.4.3. Создание электромагнитной структуры. 

1. Щёлкните левой кнопкой мышки по значку Add New EM Structure

6. Для слоя черчения Copper установите третий слой диэлектрика, введя 3 в столбце EM 
Layer. Для слоя черчения
столбце EM Layer. Для слоя черчения Res установите третий слой диэлектрика, введя 3 
в столбце EM Layer. Для слоя черчения перемычки Via установите третий слой диэлек-
трика, введя 3 в столбце EM Layer, отметьте столбец Via и в столбце Via Extent введите
1. Это будет означать, что перемычка начинается на слое 3 и её протяжённость будет 
вниз на один слой. 

7. Щёлкните мышкой по папке File Export Mappings и затем по DXF (DXF). В открывшей-
ся таблице определяется, какие слои должны быть записаны в DXF файл при экспорте 
топологии в этом формате. Эту таблицу будем использовать для экспорта топологии с 
третьего слоя диэлектрика. Поэтому отметьте слои Copper, Res и Via. В этом случае бу-
дет экспортироваться только топология проводников без контура платы. Чтобы экспор-

Рис. 6.95

  на панели инстру-
ментов. 

2. Наберите no в поле Enter a name for the EM Structure, отметьте AWR EMSight Simulator 
и нажмите Create. На рабочем поле откроется окно элек-
тромагнитной структуры. 

3. Щёлкните мышкой по значку Substrate Information на 
панели инструментов. На вкладке Enclosure открывшего-
ся окна в поле X_Dim введите 10, в поле Y_Dim введите 
5, в поле Grid_X и в поле Grid_Y введите 0.05. 

4. На вкладке Material Defs в области Dielectric Definitions 
для диэлектрического слоя Diel_1 введите Er=10.5, 
TanD=0.0001. Для области Conductor Definitions щёлк-
ните мышкой по кнопке Add, чтобы добавить материал 
проводника. Откроется дополнительное диалоговое окно 
Add Conductor (рис. 6.96). В поле Name нужно ввести 

имя материала проводника, а в по ctivity(S/m) его проводимость. Или можно вы-
Рис. 6.96 

ле Condu



брать материал из имеющихся материалов по умолчанию. Для этого щёлкните мышкой по 
кнопке в правом конце поля и выберите Copper. 
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при черчении в двухмерном отображении топологии. 

7. На вкладке Materials для
введите 0.005, в столбце
полю. Щёлкните мышк Insert. В столбце Name замените появившееся имя 
Trace1 на Resist, в столбце
те Resist, щёлкнув мышкой
6.99. 

8. На вкладке EM Layer Mapping слоёв ди-
рика. Это соответс
о устанавливается 

6. На вкладке Dielectric Layers для слоя 1 в колонке Thickness введите 6, в колонке Material 
Definition введите Air, щёлкнув левой кнопкой мышки по этому полю, в колонке Draw 
Scale введите 1. Для слоя 2 в колонке Thickness введите 0.5, в колонке Material Definition 
введите Diel_1, щёлкнув левой кнопкой мышки по этому полю, в колонке Draw Scale вве-
дите 4, чтобы удобнее было просматривать трёхмерное отображение электромагнитной 

7. На вкладке Materials для
введите 0.005, в столбце
полю. Щёлкните мышк Insert. В столбце Name замените появившееся имя 
Trace1 на Resist, в столбце
те Resist, щёлкнув мышкой
6.99. 

8. На вкладке EM Layer Mapping слоёв ди-
рика. Это соответс
о устанавливается 

Нажмите OK. Аналогично добавьте материал Resist с 
проводимостью 67000 (рис. 6.97). 

5. В столбце Color для проводника Copper дважды 
щёлкните мышкой и выберите красный цвет. Для 
Resist выберите чёрный цвет. Этими цветами будут 
отображаться соответствующие элементы топологии 

Вкладка Material Defs будет выглядеть, как показано 
на рис. 6.98. 

ставить) и для нового слоя 3 введите такие же па-
раметры, как и для слоя 2. 

ка Material Defs будет выглядеть, как показано 
на рис. 6.98. 

структуры. Щёлкните по кнопк ставить) и для нового слоя 3 введите такие же па-
раметры, как и для слоя 2. 

Рис. 6.97 

6. На вкладке Dielectric Layers для слоя 1 в колонке Thickness введите 6, в колонке Material 
Definition введите Air, щёлкнув левой кнопкой мышки по этому полю, в колонке Draw 
Scale введите 1. Для слоя 2 в колонке Thickness введите 0.5, в колонке Material Definition 
введите Diel_1, щёлкнув левой кнопкой мышки по этому полю, в колонке Draw Scale вве-
дите 4, чтобы удобнее было просматривать трёхмерное отображение электромагнитной 
структуры. Щёлкните по кнопке

Рис. 6.98 

 Insert (Ве Insert (В

 имеющего по умолчанию материала 1/2oz Cu в столбце Thickness 
 Material Definition введите Copper, щёлкнув мышкой по этому 
ой по кнопке 

 имеющего по умолчанию материала 1/2oz Cu в столбце Thickness 
 Material Definition введите Copper, щёлкнув мышкой по этому 
ой по кнопке 

Рис. 6.99

 Thickness введите 0.00025, в столбце Material Definition введи-
 по этому полю. Окно будет выглядеть, как показано на рис. 

 устанавливается соответствие слоёв черчения и 

 Thickness введите 0.00025, в столбце Material Definition введи-
 по этому полю. Окно будет выглядеть, как показано на рис. 

 устанавливается соответствие слоёв черчения и 
элект
тельн
элект
тельн

твие мы уже установили выше (рис. 6.94), однако здесь дополни-
соответствие между слоями и материалами. В столбце Material для 

слоёв Copper, Copper 1 и Via введите материал 1/2oz Cu, щёлкая мышкой по этому столб-

твие мы уже установили выше (рис. 6.94), однако здесь дополни-
соответствие между слоями и материалами. В столбце Material для 

слоёв Copper, Copper 1 и Via введите материал 1/2oz Cu, щёлкая мышкой по этому столб-
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6.100. 
9. Нажмите OK. 

2. Щёлкните левой кноп-
кой мышки по значку 
Rectangle

цу. Для слоя Res введите материал Resist.. Окно будет выглядеть, как показано на рис. 

6.4.4. Создание топологии. 
1. В поле EM Layer (Слой электромагнитной структуры) менеджера топологии введите 3. В поле 

Material введите 1/2oz Cu. Отметьте Conductor. Электромагнитная структура будет выгля-
деть, как показано на рис. 6.101. В нижней части окна менеджера топологии отображается 
структура слоёв и слой, на котором будет выполняться черчение. 

Рис 6.100

  на панели 
инструментов или вы-
берите в меню 

окно электромагнит-

Coordinates. 
4. Введите 0 в поле x, 

введите 1.65 в поле y и 
нажмите OK. Нажмите 
клавишу Tab снова, 
чтобы открыть диало-
говое окно Enter Co-
ordinates. Установите 
флажок в переключа-
теле Rel, чтобы акти-

 

показано на рис. 6.102. 

Draw>Rectangle. 
3. Поместите курсор в 

ной структуры и на-
жмите клавишу Tab на 
клавиатуре. Откроется 
диалоговое окно Enter 

визировать относительные координаты. Введите 3.2 в поле dx, введите 0.45 в поле dy и нажми-
те OK. Проводник прямоугольного сечения отображается в окне электромагнитной структуры. 

5. Повторите пункты с 2-го по 4-ый, но введите 3,2 в поле x, 2,85 в поле y, 2,15 в поле dx и 0.3 в

Рис. 6.101

поле dy. 
6. Щёлкните левой кнопкой мышки по значку 

Copy и затем по значку Paste на панели инст-
рументов. Скопированный проводник под-
ключите к нижнему входному проводнику 
так, чтобы верхние границы совпадали, как 

Рис. 6.102
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инструментов. Поместите курсор на пра-
вый верхний угол первого верхнего про-
водника и щёлкните левой кнопкой мыш-
ки, чтобы зафиксировать эту точку (рис. 
6.103). Переместите курсор на правый 
нижний угол первого верхнего провод-
ника и щёлкните мышкой. Переместите 
курсор на левый нижний угол второго 
верхнего проводника и щёлкните мыш-
кой. Переместите курсор на левый 
верхний угол второго верхнего провод-
ника и щёлкните мышкой. Нажмите 
клавишу Tab, введите -0.3 в поле dx, 
введите 0.35 в поле dy и нажмите OK. 
Должна получиться топология, пока-
занная на рис. 6.104. 

9. Нажмите клавишу Shift и щёлкните 
левой кнопкой мышки по изгибу и под-
ключённому к нему нижнему проводни-
ку, чтобы выделить их. Выберите в меню 
Edit>Mirror, поместите курсор на выде-
ленные проводники, нажмите левую 
кнопку мышки и, вращая проводники 
мышкой, создайте их зеркальное ото-

6.105). 
10. Установите курсор на скопированные 

проводники, нажмите левую кнопку 
мышки
воднику

11. Повторите
введите 
в поле dx

12. Щёлкните
инструментов
вый нижний
водника
мышки, 
нижний 
ника и щёлкните
переместите
угол верхн
ника и дважды
мышки (

13. Повтор ый, но 
введите
поле dx

14. Щёлкните
инструментов
правый

кните левой кнопкой мышки, переместите курсор на левый верхний угол 

 щёлкните левой кнопкой мышки (рис. 6.108). 

ий угол вновь созданного проводника и щёлкните левой кнопкой мышки, перемес-
тите курсор на нижний угол горизонтального проводника и дважды щёлкните левой кнопкой 
мышки (рис. 6.109). 

7. Повторите пункты с 2-го по 4-ый, но введите 5.65 в поле x, 2,55 в поле y, 2,15 в поле dx и 0.25 в 
поле dy. 

8.  Щёлкните по значку Polygon на панели 

бражение так, чтобы можно было под-
ключить их к нижнему проводнику (рис. 

Рис. 6.103 

Рис. 6.104 

Рис. 6.105 

Рис. 6.106

 и подключите их нижнему про-
 (рис. 6.106). 

 пункты с 2-го по 4-ый, но 
2.75 в поле x, 3.15 в поле y, 0.45 
 и 1.85 в поле dy. 
 по значку Polygon на панели 

. Поместите курсор на ле-
 угол вновь созданного про-

 и щёлкните левой кнопкой 
переместите курсор на правый 
угол вновь созданного провод-

 левой кнопкой мышки, 
 курсор на левый нижний 
его горизонтального провод-

 щёлкните левой кнопкой 
рис. 6.107). 
ите пункты с 3-го по 4-

Рис. 6.107

Рис. 6.108

 7.8 в поле x, 0 в поле y, 0.45 в 
 и 2.15 в поле dy. 

 по значку Polygon на панели 
. Поместите курсор на 

 верхний угол вновь созданного 
проводника и щёл

Рис. 6.109

вновь созданного проводника и щёлкните левой кнопкой мышки, переместите курсор на верх-
ний угол горизонтального проводника и дважды

15. Повторите пункты с 2-го по 4-ый, но введите 7.8 в поле x, 2.8 в поле y, 0.45 в поле dx и 0.5 в 
поле dy. 

16. Щёлкните по значку Polygon на панели инструментов. Поместите курсор на правый нижний 
угол вновь созданного проводника и щёлкните левой кнопкой мышки, переместите курсор на 
левый нижн



 119

е 7.8 в поле x, 3.45 в поле y, 0.45 в поле dx и 0.5 в поле dy. 
18. Создайте резистор. В окне менеджера то

пункты с 2-го по 4-ый, но введите 7.95 в по
(рис. 6.110). 

1 и отметьте Via. Щёлк-

ры на 

на созданную перемычку и, 
 поправить положение пер

ите мышкой по входно
лить его. 
установите
кость на 
проводни

Щёлкните 
росмотреть 3-х ме

(рис. 6.113). Если неко утся не на третьем слое, выделите их в 
электромагнитной

Shape Properties и в поле EM Lay

6.4 ие графика и добавление
1. Щёлкните по кнопке Project
2. Щёлкните по значку Add New Gra
3. Введите имя графика, например me (Имя графика), выберите Tabu-

lar (Таблица) в области Gr
4. Щёлкните левой кнопкой мыш тов. 
5. Выберите Port Parameter

Data Source Name, введите

.6. Определение частот для моделирования и ана-

1. 

поле
введите

2. Щёлкните
нели
таблице

17. Создайте контактную площадку для заземления резистора. Повторите пункты с 2-го по 4-ый, 
но введит

пологии в поле Material введите Resist. Повторите 
ле x, 3.25 в поле y, 0.15 в поле dx и 0.25 в поле dy 

19. Создайте межслойную перемычку для 
заземления резистора. В окне менед-
жера топологии в поле Material вве-
дите Copper
ните по значку Ellipse на панели ин-
струментов. Переместите курсор в ок-
но электромагнитной структу
0.1 мм правее и ниже верхнего левого 
угла, нажмите левую кнопку мышки и 
двигайте мышку по диагонали вправо 
и вниз пока смещения координат бу-

, как показано на рис. 6.111. Установив курсор 
двигая мышкой с нажатой левой кнопкой, мож-
емычки. 
му горизонтальному проводнику, чтобы выде-

Щёлкните мышкой по значку Edge Port на панели инструментов, 
 порт на входе ответвителя и сдвиньте его референсную плос-

1 мм вглубь структуры. Аналогично установите порты на выходные 
ки, как показано на рис. 6.112. 
правой кнопкой мышки по значку New Schematic 3D View, чтобы 
рное изображение и убедиться, что топология создана правильно 

торые проводники окаж

Рис. 6.110 
дут равны dx:0.25 и dy:-0.25

но
20. Щёлкн

п

Рис. 6.111  структуре рис. 6.112, щёлкните правой кнопкой мышки, выберите 
er введите 3. 

.5. Создан  измеряемых величин. 
, чтобы в левом окне открыть окно просмотра проекта. 

ph на панели инструментов. 
, Graph 1 в поле Graph na

Рис. 6.112 
Рис. 6.113 

aph Type (Тип графика) и нажмите OK. 
ки по значку Add Measurement на панели инструмен

 в списке Meas. Type, S в списке Measurement, All Sources в поле 
 2 в поле To Port Index, 1 в поле From Port Index, нажимая на 

стрелки, справа от этих полей, отметьте Mag и dB в облас-
ти Complex Modifier, нажмите Apply. 

6. Введите 3 в поле To Port Index и нажмите Apply. 
7. Нажмите OK. 

6.4
лиз. 

Дважды щёлкните левой кнопкой мышки по Project Op-
tions в окне просмотра проекта. На вкладке Frequencies в 

 Start введите 4, в поле Stop введите 16, в поле Step 
 1. Нажмите Apply и OK. 

 левой кнопкой мышки по значку Analyze на па-
 инструментов. Результаты анализа отображаются в 

 рис. 6.114. Рис. 6.114 



6.4.7. Экспорт топологии в DXF файл из окна электромагнитной структуры. 
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кт пропустите. Если кро-

анн  до-

панели инструментов, установите 
курсор на верхний левый угол 
корпуса и щёлкните мышкой. За-
тем перемещайте курсор, щёлкая 
каждый раз мышкой в следую-
щем порядке: на 0.5 вправо, по 
диагонали на -0.5 вниз и влево и 
здесь дважды щёлкните мышкой. 
Скопируйте выделенный репер-
ный знак, щёлкнув по значку 
Copy на панели инструментов. 
Щёлкая по значку Paste на пане-
ли инструментов м, щёлкая 
правой к шки, чтобы 

нуть скопированный эле-
рные знаки 
рис. 6.116). 

значку 

а проек-
 в меню 

Имя файла введите no1. В поле Тип файла, щёлк-

слоя. Нажмите Сохранить выглядеть, как показано 
на

1. Если нужно экспортировать толь-
ко топологию без контура платы, 
этот пун
ме топологии нужно экспортиро-
вать и контур платы, тогда нане-
сите на электромагнитную струк-
туру слой платы. Для этого щёлк-
ните по значку Rectangle на пане-
ли инструментов, установите кур-
сор мышки на верхний левый угол 
электромагнитной структуры, на-
жмите левую кнопку мышки и пе-
реместите курсор по диагонали на 
правый нижний угол электромаг-
нитной структуры, отпустите 
кнопку мышки. Созданный пря-
моугольник должен точно совпа-
дать с корпусом и быть выделен-
ным. Щёлкните по созданному 
прямоугольнику правой кнопкой 

мышки и выберите Shape Properties. В поле Drawing 
Layer введите Board (рис. 6.115) и нажмите OK. 
Щёлкните мышкой за пределами электромагнитной 
структуры. На созд

Рис. 6.115 

Рис. 6.116

ой плате можно начертить
полнительные топологические элементы, например, 
реперные знаки. В окне менеджера топологии в поле 
EM Layer введите 3, в поле Material введите 1/2oz CU, 
отметьте Conductor. Щёлкните по значку Polygon на 

 и зате
нопкой мы

развер
мент, установите репе
на все углы корпуса (
Откройте окно просмотра проек-
та и сделайте активным окно 
графика. Щёлкните по 
Analyze, чтобы убедиться, что на 
результаты анализа добавленные 
элементы топологии практически 

не повлияли. 
2. Щёлкните правой кнопкой мышки по имени элек-

тромагнитной структуры no в окне просмотр

Рис. 6.117 

та и выберите Export Layout. Или выберите
Layout>Export>Layout. В открывшемся окне (рис. 
6.117) выберите папку для размещения файла. В поле 

нув по кнопке в правом конце этого поля, выберите 
таблицу соответствия для экспорта DXF(DXF Flat, 
*dxf), которую мы ранее определили для третьего 

. В AutoCAD сохранённая топология будет 

Рис. 118

 рис. 6.118. 
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Теперь нанесём топологические формы на второй слой диэлектри
вспомогательные топологические элементы (реперные знаки 

1. Сделайте активным окно электромагнитной струк
нели инструментов, установите курсор мышки 
структуры, нажмите левую кнопку мышки и перем о диагонали на правый ниж-
ний угол электромагнитной структуры, отпустите
должен точно совпадать с корпусом и быть выделенным
угольнику правой кнопкой мышки и выберите Shape Proper
те Board1 и нажмите OK. 

ки. В появившемся поле ввода наберите Directional Coupler
6. Полученная структура показана на рис. 6.119, на рис

6.4.9. Экспорт топологии со второго слоя диэлектрика
структуры. 

Щёлкните
электромагни
и выберите 
out>Export>
файла no2, 
соответствия

6.4.10. Создание схемы с электром
Создадим простую схему с электромагнитной
MTRACE2 (элемент трассировки) на входе

1. Щёлкните мышкой по значку Add
Schematic 1. 

6.4.8. Черчение топологических элементов на 2-м слое диэлектрика. 
ка. На этот слой мы нанесём только 
).и текст  

туры. Щёлкните по значку Rectangle на па-
на верхний левый угол электромагнитной 
естите курсор п
 кнопку мышки. Созданный прямоугольник 

. Щёлкните по созданному прямо-
ties. В поле Drawing Layer введи-

2. Откройте окно менеджера топологии. 
В поле EM Layer введите 2, в поле 
Material введите 1/2oz CU. Опреде-
лённый для второго слоя диэлектрика 
слой черчения Copper1 будет исполь-
зоваться автоматически. Отметьте 
Conductor. 

3. Щёлкните по значку Polygon на пане-
ли инструментов. Установите курсор 
на верхний левый угол корпуса и 
щёлкните левой кнопкой мышки. За-
тем перемещайте курсор мышки, 
щёлкая мышкой после каждого пере-
мещения, следующим образом: на 0.5 
вправо, на -0.2 вниз, на -0.3 влево, на -
0.3 вниз, на -0.2 влево и здесь дважды 
щёлкните мышкой, чтобы замкнуть 
полигон. Щёлкните по значку Copy на 
панели инструментов. Щёлкая по 
значку Paste на панели инструментов 
и щёлкая правой кнопкой, чтобы раз-
вернуть скопированные формы, уста-
новите остальные реперные знаки, как 
показано на рис.6.119. 

4. Выберите в меню Options>Layout 
Options и на вкладке Layout Font от-
крывшегося окна опций топологии 
установите высоту шрифта Height 
равной 0.3 mm. Нажмите OK. 

5. Выберите в меню Draw>Text, помес-
тите курсор в удобное место на струк-
туре и щёлкните левой кнопкой мыш-

. 
. 6.120 – её трёхмерное отображение. 

 из окна электромагнитной 

 правой кнопкой мышки по имени 
тной структуры в окне просмотра проекта 

Export Layout, или выберите в меню Lay-
Layout. В открывшемся окне введите имя 
в поле Тип файла введите имя таблицы 
 для второго слоя FileMap1 (DXF Flat, 

*.dxf) и нажмите Сохранить. В AutoCAD экспортиро-
ванная топология второго слоя диэлектрика будет вы-

Рис.6.119 

Рис. 6.120 

глядеть, как показано на рис. 6.121. 
 
 

агнитной структурой. 
 структурой в качестве подсхемы. Просто добавим элемент 

 электромагнитной структуры. 
 New Schematic на панели инструментов и создайте схему 

Рис. 6.121 
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те окно просмот-

к

окне свойств элемента введите W=0.45 и на-

5. 

7.

Как видно из результатов анализа, электрические
решающего устройства. Однако если планируются какие-
схемы, например просмотр трёхмерного отображения топол
позаботиться, чтобы и геометрические соединения были
топологические элементы для элементов схемы располагались
установлены опции для трёхмерного отображения тополо

Выберите в меню Options>Drawing Layers. В
General и щёлкните мышкой по Drawing Layer 3d. Откро
бражения рис. 6.124. 

а положительным числом, она 

начальной Z-координаты. Заметим, что эти данные влияют только на правиль-

окне свойств элемента введите W=0.45 и на-

5. 

7.

Как видно из результатов анализа, электрические
решающего устройства. Однако если планируются какие-
схемы, например просмотр трёхмерного отображения топол
позаботиться, чтобы и геометрические соединения были
топологические элементы для элементов схемы располагались
установлены опции для трёхмерного отображения тополо

Выберите в меню Options>Drawing Layers. В
General и щёлкните мышкой по Drawing Layer 3d. Откро
бражения рис. 6.124. 

а положительным числом, она 

начальной Z-координаты. Заметим, что эти данные влияют только на правиль-

2. Щёлкнув мышкой по панели Elements в левом

Рис. 6.122 

нижнем углу проекта, открой
ра элементов. 

3. Щёлкните мыш ой по группе Subcircuits и 
перетащите в окно схемы подсхему no. 

4. Раскройте группу Microstrip, щёлкните мыш-
кой по подгруппе Lines, перетащите элемент 
MTRACE2 в окно схемы и подключите его к 
узлу 1 подсхемы no. Дважды щёлкните мыш-
кой по элементу MTRACE2, в открывшемся 

мы подсхему no. 
4. Раскройте группу Microstrip, щёлкните мыш-

кой по подгруппе Lines, перетащите элемент 
MTRACE2 в окно схемы и подключите его к 
узлу 1 подсхемы no. Дважды щёлкните мыш-
кой по элементу MTRACE2, в открывшемся 

жмите OK. 
В окне просмотра элементов щёлкните мыш-
кой по группе Substrates и перетащите в окно 
схемы элемент подложки MSUB. Дважды 
щёлкните мышкой по этому элементу, в от-
крывшемся окне свойств введите Er=10.5, 
H=0.5, T=0.005, Tand=0.0001, ErNom=10.5 и 

жмите OK. 
В окне просмотра элементов щёлкните мыш-
кой по группе Substrates и перетащите в окно 
схемы элемент подложки MSUB. Дважды 
щёлкните мышкой по этому элементу, в от-
крывшемся окне свойств введите Er=10.5, 
H=0.5, T=0.005, Tand=0.0001, ErNom=10.5 и 
нажмите OK. 

6. Щёлкните мышкой по значку Port на панели 
инструментов и подключите порт ко входу 
схемы. Аналогично подключите порты к уз-
лам 2 и 3 подсхемы no, щёлкая правой кноп-
кой мышки, чтобы развернуть порты соот-
ветствующим образом. Должна получиться 
схема, показанная на рис. 6.122. 

 Щёлкните мышкой по значку Analyze на па-
нели инструментов. Результаты анализа по-
казаны на рис. 6.123. 

 соединения в схеме выполнены правильно для 
то другие действия, кроме выполнения анализа 

огии или экспорт топологии, необходимо 
 сделаны правильно и чтобы соответствующие 

 на нужных слоях. Для этого должны быть 
гии схемы. 

 

нажмите OK. 
6. Щёлкните мышкой по значку Port на панели 

инструментов и подключите порт ко входу 
схемы. Аналогично подключите порты к уз-
лам 2 и 3 подсхемы no, щёлкая правой кноп-
кой мышки, чтобы развернуть порты соот-
ветствующим образом. Должна получиться 
схема, показанная на рис. 6.122. 

 Щёлкните мышкой по значку Analyze на па-
нели инструментов. Результаты анализа по-
казаны на рис. 6.123. 

 соединения в схеме выполнены правильно для 
то другие действия, кроме выполнения анализа 

огии или экспорт топологии, необходимо 
 сделаны правильно и чтобы соответствующие 

 на нужных слоях. Для этого должны быть 
гии схемы. 

 

Рис. 6.123 

 левой части открывшегося окна раскройте папку 
ется окно установки опций трёхмерного ото-

 левой части открывшегося окна раскройте папку 
ется окно установки опций трёхмерного ото-

В столбце Z-Position задаётся начальная Z-координата положения каждого слоя черчения. В столбце 
Thickness задаётся толщина каждого слоя черчения. Если толщина задан
В столбце Z-Position задаётся начальная Z-координата положения каждого слоя черчения. В столбце 
Thickness задаётся толщина каждого слоя черчения. Если толщина задан

Рис. 6.124

отсчитывается вверх от начальной Z-координаты. Если же толщина задана отрицательным числом, она 
отсчитывается вниз от 
отсчитывается вверх от начальной Z-координаты. Если же толщина задана отрицательным числом, она 
отсчитывается вниз от 
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ность трёхмерного отображения структуры и
тельно должны совпадать с реальными данными. 

Board отображает нижний (третий) слой м его начальную Z-координату 
равную нулю, а толщину направим вниз и оп
определим начальную Z-координату также равну

Перемычка Via должна проходить че

аться на третьем слое. Поэтому у 

дината должна быть равна 0.5, 

олбце, тем 

end введите 0.5, для 

ов. Трёхмерное отображение струк-
туры по

ии электромагнитной структуры в схему в качестве подсхемы. 
6.4.11. Редактирование топологии схемы. 

Сделайте активным окно то-
пологии схемы. Это окно не отобра-
жается в окне просмотра проекта. 
Сделать его активным можно, щёлк-
нув по этому окну мышкой. Если окно 
топологии схемы закрыто другими 
окнами, щёлкните по имени этого ок-
на в строке заголовков открытых окон 

на рабочем поле (рис. 6.127). 
Создайте в элементе трассировки MTRACE2 два изгиба на 90 градусов. Для этого дважды 

щёлкните мышкой по элементу топологии MTRACE2. Элемент будет выделен, в центре и по краям поя-
вятся синие ромбики. Установите курсор мышки на ромбик в правом конце элемента в месте соединения 
элемента трассировки со входом ответвителя так, чтобы курсор отображался в виде двойной стрелки, и 
дважды щёлкните левой кнопкой мышки, чтобы активизировать режим трассировки. Переместите кур-
сор влево на dx=-2.0 мм и щёлкните левой кнопкой мышки. Переместите курсор мышки вверх на 1.0 мм 

и щёлкните левой кнопкой мышки. Пе-
реместите курсор влево на dx=-2.0 мм и 
дважды щёлкните левой кнопкой мыш-
ки. Выберите в меню Edit>Select All и 
затем щёлкните мышкой по значку 

 не влияют на результаты анализа. Поэтому они не обяза-

 диэлектрика. Определи
ределим равную -0.5. Для второго слоя диэлектрика Board1 

ю нулю, а толщину определим равную 0.5. 
рез третий слой диэлектрика, поэтому её параметры долж-

ны быть такими же, как и у Board, 
т.е. Z-координата равна 0 и толщи-
на равна -0.5. 

Слои проводников Copper 
и резистора Res должны распола-
г
них Z-координата должна быть 
равна 0, а толщину определим 
0.005 и 0.00025 соответственно. 

Слои проводников 
Copper1 должны располагаться на 
втором слое. Поэтому у них Z-
коор
а толщину определим 0.005. 

Столбец Opaque (непро-
зрачность) для наших слоёв должен 
быть отмечен. В столбце Blend 
устанавливается степень непро-
зрачности (в пределах 0 – 1). Чем 
меньше число в этом ст
более прозрачен слой. Для слоёв 
Copper, Copper1, Res и Board в 
столбце Bl
слоя Board1 введите 0.2. 

Сделайте окно схемы ак-
тивным и щёлкните по значку 
View Layout на панели инстру-

ментов. Полученная топология показана на рис. 6.125. 
Щёлкните по значку View 3D Layout на панели инструмент

Рис. 6.125 

Рис. 6.126 

казано на рис. 6.126. 
Обратите внимание, что отрезки линий от портов до референсных плоскостей автоматически 

удалены при добавлен

Рис. 6.127 

Snap Together на панели инструмен-
тов, чтобы упорядочить топологию. 
Должна получиться топология, пока-
занная на рис. 6.128. 

Сделайте активным окно схе-Рис. 6.128 



мы Schematic 1 и обратите внимание, что параметр L элемента MTRACE2 изменился в соответствии с 
выполненным изменением топологии. 
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е мышкой 

одника до правого 
кр

м  еди
топологи. В этом можно убедиться, если щёлкнуть мышкой по любо
нитной структуры. Будут выделены все элементы топологии на все
дельные элементы топологии электромагнитной структуры в окне т
можно сделать только в окне топологии электромагнитной структур росто 
дважды щёлкните мышкой по топологии электромагнитной структуры в окне

В верхней части нитной структуры находится п
(реперными знаками и текстом). Чтобы иметь возможность редактиро

е, чтобы 
выд

те левую кнопку мышки и 

(рис. 6.130). 

нижней плате. Ус-
тановите курсор мышки на 
р

чтобы выделить все эти элементы. Установите курсор на любо
кнопку мышки и верните эту плату с её элементам на прежнее м  
тромагнитной структуры. Дв ните мышкой по верхней 
ромбики верхней и нижней стороны платы, совместите эти стороны со стор нижней  

Теперь нужно отредактировать размеры плат и положение реперных знаков. Сделайте активным 
окно топологии схемы. 

Щёлкнит
по значку Measure на панели 
инструментов и измерьте 
расстояние от начала входно-
го пров
ая электромагнитной 

структуры dx (рис. 6.129). 
Это расстояние определяет 
необходимую длину нижней 
платы Board (в нашем случае 
13 мм. 

Топология электромагнитной структуры вставлена в топологию схе ы как один ный элемент 
му элементу топологии электромаг-
х слоях. Поэтому редактировать от-
опологии схемы не получится. Это 
ы. Чтобы открыть это окно п

Рис. 6.129

 топологии схемы. 
лата Board1 со своими элементами 
вать нижнюю плату, верхнюю пла-

ту с её элементами необходи-
мо временно сдвинуть в сто-
рону. Нажмите клавишу Shift 
и поочерёдно щёлкните по 
реперным знакам и тексту, 
находящимся на верхней пла-
те, и по самой плат

электромаг

елить все эти элементы. 
Установите курсор на любой 
выделенный элемент, нажми-

сдвиньте плату в сторону 

Дважды щёлкните 
мышкой по 

Рис. 6.130 

омбик посередине верхней 
стороны платы так, чтобы он 
отображался в виде двойной 
стрелки, нажмите левую кноп-
ку мышки и сдвиньте эту сто-
рону до положения референс-
ной плоскости порта 2. Анало-
гично сдвиньте нижнюю стону 
платы до положения референс-
ной плоскости порта 3. Левую 
сторону платы сдвиньте влево 
на 3 мм так, чтобы длина платы 
бала равна 13 мм (рис. 6.131). 

Щёлкая по реперным 
знакам, принадлежащим ниж-
ней плате, чтобы выделить их, 
поместите реперные знаки по 
углам отредактированной пла-
ты. Топология будет выглядеть, 
как показано на рис. 6.132. 

Нажмите клавишу Shift 
мся на верхней плате, и по самой плате, 
й выделенный элемент, нажмите левую 
есто, совместив плату с корпусом элек-
плате и, 

Рис. 6.131 

Рис. 6.132 
и поочерёдно щёлкните по реперным знакам и тексту, находящи

ажды щёлк устанавливая курсор мышки на 
онами  платы. Затем
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тированной платы. Переместите текст на отре-

тура будет выгля  рис. 
6.133. 

Откройте 
логия схемы буде к
рис. 6.134. 

Щёлкните
Трёхмерное отобр е топ
дет, как на рис. 6.1

Если нужно экспортировать топологию с верхнего слоя, в открыв
введите FileMap1 (DXF Flat *dxf). В AutoCAD топология будет выглядеть

подложки STACKUP, который можно и а
гослойных электромагнитных структур
использованию lpf-файлов. В проекте та
быть несколько. Чтобы они были доступ
ных структур в редакторе электрома
STACKUP должны быть помещены в гло
Рассмотрим пример перехода копланарн
гой. Структура подложки будет такой, 
верхнем диэлектрике с Er=3.0 (т.е. на с

й линии. Выходной отрезок коплан
ней плоскости нижнего диэлектрика с E
5). Нижняя часть слоя 2 и верхняя часть

плоскостями. Эти слои можно использовать, например, для построения и 
элементами, типа диодов или микросхем. Мы эти слои использовать не будем
Выберите в меню File>New Project. Затем выберите File>Save Project A
под именем CPW-CPW. 
Однако прежде чем создавать элемент STACKUP, определим слои черч
ков на диэлектрических слоях. 

Выберите в меню Options>Drawing Layers. Откроется диалогов
Обычно по умолчанию открывается вкладка Drawing Layer 2d Proper
черчения). Если это не та  по Drawing Layer 2d в группе General в в

переместите реперные знаки на углы отредак-

Рис. 6.133 

дактированную плату. Электромагнитная струк-
деть, как показано на

окно топологии схемы. Топо-
т выглядеть, ка  показано на 

 по значку View 3D Layout. 
ажени ологии схемы бу-
35. 

6.4.12. Экспорт топологии в DXF файл из окна топологии схемы. 
Рис. 6.134 Рис. 6.135 

Сделайте активным окно топологии схемы и выберите в меню Layout>Export. Если нужно экс-
портировать топологию с нижнего слоя структуры, в открывшемся окне в поле Тип файла введите DXF 
(DXF Flat *dxf). В AutoCAD топология будет выглядеть, как показано на рис. 6.136. 

шемся окне в поле Тип файла 
, как показано на рис. 6.137. 

Рис. 6.136 Рис. 6.137 

6.5. Моделирование межслойного перехода. 
В этом примере рассмотрим использование элемента многослойной 

спользов ть при создании мно-
. Это альтернативный способ 
ких элементов подложек может 
ны при построении многослой-
гнитной структуры, элементы 
бальные определения. 
ой линии с одного слоя на дру-
как показано на рис. 6.138. На 
лое 2) создадим отрезок копла-
арной линии создадим на ниж-

r=3.0 (т.е. создать нужно на слое 
 слоя 4 должны быть земляными 
 цепей управления различным

. 

Слой 1 Воздух 

Слой 2 Er=3.0

Слой 3 Er=4.6 

Слой 4 Er=3.0 

Слой 5 Воздух 
нарно

Рис. 6.138 

s и сохраните проект, например, 

ения (Drawing Layer) проводни-

ое окно Drawing Layer Options. 
ties (Свойства двумерного слоя 

к, щёлкните ерхней части левого ок-
на. В списке слоёв в столбце Name щёлкните по слою Copper. Щёлкните по кнопке New Layer в верхней 
правой части окна. В столбце Name под отмеченным слоем Copper появится новый слой с именем по 
умолчанию Layer1. Переименуйте этот слой в Copper1. Снова щёлкните по кнопке New Layer и анало-
гично добавьте слой Copper2. Снова щёлкните по кнопке New Layer и аналогично добавьте слой 
Copper3.  
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Щёлкните по слою Via и добавьте слои Via1, V
ремычек. 

Дважды щёлкните в столбце Fill (Заполнить) в с ы ве
например, красный (цвет меди). Снова щёлкните по этом
те эту операцию для слоёв Copper1, Copper2 и Copper е для слоёв Via, Via1, Via2 и Via3. Тип 
заполнения лучше выбрать различный, чтобы легче было отли
можно выбрать тип линий, которыми будет выполняться
ных слоёв столбец Show Fill (Показывать заполнение). чения будет выглядеть, как пока-
зано на рис. 6.139. Нажмите OK. 

 определения). Откроется пустое ьных определений. 
Откройте окно просмотра элементов, щёлкнув по копке Elements в 

части левого окна щёлкните по группе 
части левого окна найдите элемент 

STAC
и, не 
ний. 
щёлкн

 свойств 

ите Diel1, в поле Er вве-

0.0013 (рис. 6.141), нажмите OK. 

Diel2, в поле Er введите 4.6, в поле TanD введите 0.003 (рис. 

по умолчанию). 

ia2 и Via3, как описано выше, для черчения пе-

троке Copper и в берите ц т заполнения слоя, 
у столбцу и выберите тип заполнения. Повтори-

3, а такж
чать слои в структуре. В столбце Line 

 черчение и цвет линий. Отметьте для добавлен-
Окно слоёв чер

Теперь создадим элемент подложки STACKUP.  
В окне просмотра проекта дважды щёлкните по Global Definitions 

Рис.6.139

(Глобальные  окно глобал

нижней части левого окна. В верхней 
Substrates (Подложки). В нижней 

KUP, установите на него курсор мышки, нажмите левую кнопку мышки 
отпуская кнопки, перетащите этот элемент в окно глобальных определе-
Отпустите кнопку мышки, поместите элемент в любом месте окна и 
ите левой кнопкой мышки, чтобы закрепить его (рис. 6.140). 

Дважды щёлкните по 
элементу STACKUP. Откро-
ется диалоговое окно

 6Рис. .140 

этого элемента. 
На вкладке Material 

Defs этого окна в области 
Dielectric Definitions щёлк-
ните по кнопке Add. Откро-
ется дополнительное окно 
Add Dielectric. В поле Name 
введРис. 6.141 Рис. 6.142
дите 3, в поле TanD введите 

Снова щёлкните по кнопке Add. В поле Name введите 

6.142), нажмите OK. 
В области Conductor Definitions щёлкните по кнопке 

Add. Откроется дополнительное окно Add Conductor (рис.6.143). 
В поле Name введите Copper (Медь), в поле Conductivity (S/m) 
введите 5.88e7, нажмите OK. 

Дважды щёлкните в столбце Color в строке Copper и из-
мените цвет проводника, например на красный цвет (или оставьте 

Рис. 6.143 



Вкладка Material Defs окна свойств элемента будет выглядеть, как показано на рис. 6.144. 
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 столбце Thickness введите толщину слоя 0.254. В 
столбце Material Definition щёлкн le введите 5. 

Снова щёлкните по кнопк
Толщину этого слоя введ
столбце Draw Scale введи

Снова щёлкните п
Для этого слоя введите так

Снова щёлкните п
Для этого слоя введите так

Вкладка Dielectric

Откройте вкладку Dielectric Layers. По умолчанию на этой вкладке должен быть один слой воз-
духа (Air). В столбце Thickness (толщина) измените толщину слоя на 4. В столбце Draw Scale (Масштаб 
черчения) введите 0.5 (это влияет только на отображение структуры в трёхмерном изображении). 

Щёлкните по кнопке Insert, появится

Рис. 6.144

 слой 2. В
ите мышкой и введите Diel1. В столбце Draw Sca
е Insert, появится слой 3 с такими же параметрами, как и для слоя 2. 

ите 1. В столбце Material Definition щёлкните мышкой и введите Diel2. В 
те 2. 
о кнопке Insert, появится слой 4 с такими же параметрами, как и для слоя 3. 
ие же параметры, как и для слоя 2. 
о кнопке Insert, появится слой 5 с такими же параметрами, как и для слоя 4. 
ие же параметры, как и для слоя 1. 
 Layers окна свойств элемента будет выглядеть, как показано на рис. 6.145. 

Рис. 6.145
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енем 

 

ычерчи-
вать ме

а, необходимые для выполнения чертежа, т.е. тип, цвет, толщину линии, а 
также т

rial Defs и Materials. 

я этого слоя материал Copper. Окно будет 
выгляде

Откройте вкладку Materials. Щёлкните по кнопке Insert. Появится новый материал с им
Trace1. Измените это имя на Copper. Введите толщину 0.017. В столбце Material Defiition по умолча-
нию будет Perfect Conductor. Щёлкните в этом столбце мышкой и введите Copper. Вкладка Materials
окна свойств элемента будет выглядеть, как показано на рис. 6.146. 

Откройте вкладку EM Layer Mapping (Соответствие электромагнитных слоёв). 
Рис. 6.146

В столбце Drawing Layer перечислены слои черчения полосок, которые доступны в проекте. Мы 
будем использовать только слои Copper, Copper1, Copper2 и Copper3, которыми мы будем в

дные проводники на соответствующих слоях диэлектрика (EM Layer) и слои Via, Via1, Via2 и 
Via2 – перемычки (переходы) между слоями. Здесь нужно не путать слой черчения с материалом. Слой 
черчения имеет только свойств

ип и цвет заполнения начерченного проводника. Эти свойства определяются в окне опций слоёв 
(рис. 6.139). Свойства материала определены на вкладках Mate

По умолчанию для слоя Copper обычно назначается слой 2. Оставьте это значение. Дважды 
щёлкните в столбце Material для слоя Copper и назначьте дл

ть, как показано на рис. 6.147. 

Рис. 6.147
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черчения не назначены (в столбце EM Layer введено None). 
Щёлкните в столбце EM Layer в строке слоя Copper1 и назначьте слой 3. Затем щёлкните в 

столбце Material и назначьте материал Copper. 
Аналогично для слоя Copper2 назначьте слой диэлектрика 4 и материал Copper. Для слоя Cop-

per3 назначьте слой диэлектрика 5 и материал Copper. 
Слой Via будем использовать для создания перемычки между слоями 2 и 3. Поэтому назначьте 

слой 2. В столбце Via Extent (Протяжённость перемычки) оставьте 1,отметьте столбец Via и назначьте 
материал Copper. 

Слой Via1 будем использовать для создания сквозной перемычки между слоями 2 и 5, замы-
кающей все заземлённые слои, а также для создания межэтажного перехода копланарной линии. Поэто-
му назначьте слой 2. В столбце Via Extent введите 3 (т.е. перемычка должна пройти через 3 слоя), от-
метьте столбец Via и назначьте материал Copper. 

Слой Via2 будем использовать для создания перемычки между слоями 4 и 5. Поэтому назначьте 
слой 4. В столбце Via Extent введите 1, отметьте столбец Via и назначьте материал Copper. 

Слой Via3 будем использовать для создания перемычки между слоями 3 и 4. Поэтому назначьте 
слой 3. В столбце Via Extent введите 1, отметьте столбец Via и назначьте материал Copper. 

Окончательный вид вкладки EM Layer Mapping будет выглядеть, как показано на рис. 6.148. 

Параметры на остальных вкладках 
можно оставить по умолчанию. Нажмите 
OK. 

Можно также закрыть окно Global 
Definition. 

Теперь можно создавать электро-
магнитную структуру. 

Щёлкните по значку Add New EM 
Structure на панели инструментов или вы-
берите в меню команду Project>Add EM 
Structure>New EM Structure. Откроется 
окно New EM Structure (рис. 6.149). В по-
ле Enter a name for EM Structure введите 
имя структуры, например, CPW_CPW. В 
области Initialization Options отметьте 
From Stackup. В поле Use Stackup должно 
появиться имя элемента подложки SUB1. 
Если в проекте определено несколько эле-
ментов Stackup, то в этом поле нужно оп-

ределить необходимый элемент для каждой созд ектромагнитной структуры. 

Обратите внимание, в левом окне отображается наша структура, и на каком слое диэлектрика 
будет вычерчиваться отмеченный металлический слой Copper. 

Для добавленных слоёв Copper1, Copper2, Copper3, Via1, Via2 и Via3 слои диэлектрика для 

Рис. 6.148

аваемой эл
Рис. 6.149 
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отметьте AWR EMSight Simulators. Нажмите Create (Создать). 
Откроет

пус) в группе CPW_CPW в левом окне про-
смотра 

 Y_Dim введите ширину корпуса 2,8 mm, размер яче-
ек сетки

. 

введите 2, щёлкнув 
по кнопке в пра-
вом конце этого 

курсор на левый верхний угол корпуса, нажмите левую кноп
диагонали, образуя прямоугольник, пока возле курсора не ото

Обратите внимание, в окне менеджера топологии от
этом окне указаны слой диэлектрика, на котором выполняетс
териал создаваемого проводника, но не указан слой черчен
заданием слоя диэле териала. При желании убедит

В области Select a simulator 
ся пустое окно электромагнитной структуры и в левом окне просмотра проекта появится группа 

с именем CPW_CPW создаваемой структуры. 
Щёлкните по значку Substrate Information (Информация о подложке) на панели инструментов 

или дважды щёлкните мышкой по подгруппе Enclosure (Кор
проекта. Откроется окно свойств корпуса рис. 6.150. На вкладке Enclosure этого окна в столбце 

Value для X_Dim введите длину корпуса 5 mm, для
 по осям GridX и Grid_Y введите 0.1 mm. Остальные значения оставьте по умолчанию. Вкладка 

Enclosure должна выглядеть, как показано на рис. 6.150

При желании можете просмотреть остальные вкладки окна и убедиться, что все значения уста-
новлены в соответствии с определённым элементом STACKUP. 

Нажмите OK. 
В левом окне откройте менеджер топологии, щёлкнув по кнопке Layout в нижней части левого 

окна. В окне ме-
неджера топологии 
в поле EM Layer 

Рис. 6.150

поля. В поле Ma-
terial введите 
Copper, щёлкнув 
по кнопке в пра-
вом конце этого 
поля. Отметьте 
Conductor. Щёлк-
ните по значку 
Rectangle на пане-
ли инструментов 
или выберите в 
меню Draw> Rec-
tangle. Установите 

ку и перемещайте курсор вправо и вниз по 
бразятся dx:5.0 и dy:-0.9 (рис. 6.151). 
ображается вид создаваемой структуры. В 
я черчение проводников (EM Layer) и ма-
ия. Этот слой определяется автоматически 
ься в правильности выбранного слоя черче-

ния можно сначала о созданному проводнику левой кнопкой мышки, затем щёлкнуть правой 

Рис. 6.151

ктрика и ма
щёлкнуть п
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кнопкой и выбрать Shape Properties (Свойства формы). Откроется окно свойств (рис. 6.152), в котором 
на вкладке Layout указан и слой черчения Copper в поле Drawing layer. 

Убедиться в правильности создаваемой структуры можно также, просмотрев трёхмерное ото-
бражение созданной структуры. Щёлкните по значку View EM 3D Layout на панели инструментов или 

выберите в меню View> View 3D 

 

 
 
 
 

шки и, не отпуская кнопки и п
курсор вправо и вниз, создайте проводник копланарной линии длиной 2.8 мм и шир 6 
между этим проводником и заземляющими проводниками должен быть равен 0.2 мм ук а
выглядеть, как показано на рис. 6.154. 

Создадим земляную плоскость на 3-ем слое. В окне менеджера топологии в п
дите 3. Щёлкните по значку Rectangle на панели инструментов. Установите курсор
угол структуры, нажмите левую кнопку мышки и переместите курсор на нижний прав
отпустите кнопку. 

В созданной земляной плоскости нужно создать отверстие под правым краем
нарной линии. Через это отверстие должна пройти перемычка на будущий нижний от
линии так, чтобы перемычка не была замкнута на землю. 

Щёлкните по созданной земляной плоскости в любом свободном месте, где 
ников, чтобы выделить эту плоскость, если она не выделена. Щёлкните по значку Not
форме) на панели инструментов. Установите курсор на верхний правый угол прово

л
л
к
к
и

Рис. 6.152 

EM Layout (рис. 6.153). 
Щёлкните левой кнопкой

мышки по созданному проводни-
ку, чтобы выделить его (если не
выделен). Щёлкните по значку
Copy, затем щёлкните по значку
Paste на панели инструментов и
установите скопированный про-
водник к нижней части корпуса. 

Щёлкните по значку Rec-
tangle на панели инструментов. Установите курсор на левую сторону корпуса на две ячейки сетки ниже 
верхнего заземлённого проводника. Нажмите левую кнопку мы

Рис.6.153 Рис. 6.154

еремещая 
иной 0. мм. Зазор 
 и стр тур  будет 

оле EM Layer вве-
 на верхний левый 
ый угол структуры, 

 проводника копла-
резок копланарной 

нет других провод-
ch Shape (Выемка в 
дника копланарной 
инии, нажмите 
евую кнопку мыш-
и, переместите 
урсор на 0.6 влево 
 на 0.6 вниз, отпус-
тите кнопку. Струк-
тура должна выгля-
деть, как показано 
на рис. 6.155. Трёх-
мерное отображение 
созданной структу-
ры показано на рис. 
6.156. Рис. 6.156Рис. 6.155 



Создадим заземляющие перемычки на заземлённых проводниках диаметром 0.3 мм с расстояни-
ем между их центрами 1 мм. Чтобы точнее установить перемычки, щёлкните по значку Substrate Infor-

mation на панели инструментов и измените размер ячеек сетки Grid_X и 
Grid_Y на 0.05. 

В левом окне менеджера топологии в поле EM Layer установите 2 и 
отметьте Via. 

Щёлкните по значку Ellipse на панели инструментов или выберите в 
меню Draw>Ellipse. Поместите курсор на верхний заземлённый проводник 
вблизи левого нижнего угла, нажмите левую кнопку мышки, и перемещайте 
мышку, пока отобразятся dx:0.3 и dy:0.3 (рис. 6.157). Установите курсор на 
созданную перемычку, нажмите левую кнопку мышки и установите перемычку 
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так, чтобы расстояние от центра перемычки до левого края корпуса было 0.5 
мм, а расстояние до нижнего края заземлённого проводника было 0.3 мм. 

При выделенной перемычке щёлкните по значку Copy на панели инст-
рументов. Затем, щёлкая по значку 
Paste на панели инструментов, устано-
вите перемычки на расстоянии 1 мм 
между их центрами и на одинаковом 
расстоянии до нижнего края верхнего 
заземленного проводника. Должно по-
лучиться 5 перемычек. 

Щёлкая по значку Paste на па-

 

друг

сор 
туры
кноп
мест
ниже
тите
элем
всех
лены
знач
инст

нели инструментов, установите второй ряд перемычек так, чтобы расстояние от левого края корпуса до 
центра первой перемычки и расстояния между перемычками в этом ряду было 1 мм. Расстояние между 
осевыми линиями перемычек, расположенных в двух рядах, должно быть 0.3 мм. Верхний заземлённый 
проводник с перемычками будет выглядеть, как показано на рис. 6.158. 

Выделите все перемычки и щёлкните по значку Copy и затем по значку Paste на панели инстру-
ментов, переместите курсор в окно электромагнитной структуры, два раза щёлкните правой кнопкой 
мышки, чтобы развернуть скопированные перемычки на 180 градусов, и поместите их на нижнем зазем-
лённом проводнике симметрично относительно расположения перемычек на верхнем заземлённом про-
воднике. Структура должна выглядеть, как показано на рис. 6.159. Трёхмерное отображение созданной 
структуры показано на рис. 6.160 

Теперь создадим нижнюю часть структуры. Сделать это можно таким же способом, как описано 
выше. Например, в менеджере топологии в поле EM Layer ввести слой 4 и на нём создать земляную
плоскость с прямоугольным отверстием в ней напротив отверстия в земляной плоскости на слое 3 и с 
такими же размерами. Затем на слое 5 создать элементы копланарной линии. И, наконец, создать пере-
мычки со слоя 4 на слой 5. 

Мы это сделаем 
им способом. 

Установите кур-
левее и выше струк-
, нажмите левую 
ку мышки и пере-
ите курсор правее и 
 структуры, отпус-

 кнопку мышки. Все 
енты структуры на 
 слоях будут выде-
. Щёлкните по 
ку Copy на панели 
рументов. Щёлкните 

Рис. 6.158 

Рис. 6.159 Рис. 6.160 

Рис. 6.161 

Рис. 6.157 

Рис. 162
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уры и два 
раза щёлкните правой кнопкой м
скопированную топологи
структуры. Исходная и ск
6.162. 

пированная структура 

м 
г

по значку Zoom Out на панели инструментов, чтобы уменьшить отображение структуры. Щёлкните по 
значку Paste на панели инструментов, переместите курсор в окно электромагнитной структ

ышки, чтобы развернуть копию топологии на 180 градусов. Поместите 
ю на свободном месте, например, чуть выше имеющейся электромагнитной 
опированная структуры и их трёхмерное отображение показаны на рис. 6.161 и 

Как видим, ско-

находится на том же 
уровне, что и первона-
чальная. 

Щёлкните левой 
кнопкой мышки по зем-
ляной плоскости на ско-
пированной структуре 
где-нибудь на свободно
месте от дру их провод-
ников, чтобы выделить 
её (рис. 6.163), и затем 
щёлкните по значку 
Move Down (Перемес-

тить вниз) 

Рис. 6.164Рис.6.163 

 на панели инструментов, чтобы понизить эту плоскость на один слой (рис. 6.164). Как вид-
но на рисунке, земляная пл ь находится на нужном уровне. оскост

Щёлкните левой кнопкой мышки на свободном месте в окне электромагнитной структуры, что-
бы снять выделение земляной плоскости. Нажмите клавишу Shift и щёлкните по очереди по всем пере-
мычкам на скопированной структуре, чтобы выделить их (рис.6.165). Перемычки нужно понизить на два 

по одникам 
копланарной линии на 

слоя. Поэтому щёлкните по значку Move Down на панели инструментов два раза. Трёхмерное отображе-
ние показано на рис. 
6.166, перемычки пе-
реместились на нуж-
ный уровень. 

Щёлкните ле-
вой кнопкой мышки на 
свободном месте в окне 

электромагнитной 
структуры, чтобы снять 
выделение перемычек. 
Нажмите клавишу Shift 
и щёлкните  очереди 

 
в корпус. 

Установите курсор мышки левее и выше скопированной структуры, 
мышки и переместите курсор правее и ниже скопированной структуры, отпуст
новите курсор на выделенную структуру, нажмите левую кнопку мышки и пере
пус. Щёлкнит  свободном месте, чтобы снять в е. Структур

 по
всем пров

Рис. 6.166Рис. 6.165 
скопированной струк-
туре, чтобы выделить 
их (рис. 6.167). Эти 
проводники нужно 
понизить на три слоя, 
поэтому щёлкните по 
значку Move Down 
на панели инстру-
ментов три раза. 
Трёхмерное отобра-
жение показано на 
рис. 6.168, проводни-
ки копланарной ли-
нии переместились на 
нужный уровень. Те-
перь осталось только 
переместить скопи-
рованную структуру

нажмите левую кнопку 
ите кнопку мышки. Уста-
местите структуру в кор-
а будет выглядеть так же, е мышкой на ыделени

Рис. 6.168
Рис. 6.167 
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в 
ии. 

Трёхм

о

ых плоскостях ближе к 

п м с
няющей отрезки копланарной линии, создать сквозные перемычки, соединяющи
землённые слои. 

В окне менеджера топологии в поле EM Layer введите 3, отметьте Via, 
Щёлкните по значку Ellipse на панели инструментов. Установите курсор на ближ

п
в
с те левую 
кнопку м  
п
м
мычку
ы диам
0.
Ус
вно
мы

ранее созданной перемычкой
слойному переходу во втором

Аналогично создайте ем
им и 4-ым слоями в месте ра  пер
ки, ближайшей к межслойном  
ряду снизу. Структура будет в
но на рис. 6.173, а её трёхме
рис. 6.174. 

Создайте порты на вх
ры. Щёлкните по входному п
ной линии, чтобы выделить её

Edge Port на панели инструментов или выберите в меню D dge Port. 
левый край в оводника так, чтобы появился маленький оугольник, 
Будет создан  по этому порту мышкой, установите курсор на прав

как и раньше (рис. 
6.169), т.к. элементы 
топологии в нижней 
части располагаются 
под такими же элемен-
тами в верхней части и 
не видны двухмер-
ном отображен

ерное отображе-
ние созданной струк-
туры показан  на рис. 
6.170. 

Теперь созда-
дим переход между 
двумя отрезками ко-
планарной линии, рас-
положенными на раз-
ных слоях. 

В окне менед-
жера топологии от-
метьте Via, в поле EM 
Layer введите 2, в по-

ле Extent введите 3, щёлкнув по кнопке в правом конце этого поля. Щёлкните по значку Ellipse на пане-
ли инструментов, установите курсор в области квадратного отверстия на землян
левому нижнему углу, нажмите левую кнопку мышки, двигайте мышку так, чтобы отобразились смеще-
ния координат dx:0.3 и dy:0.3. Установите курсор на созданную перемычку, нажмите левую кнопку 
мышки и поместите перемычку по центру квадратного отверстия. Структура будет выглядеть, как пока-

 с ере ычкой, оеди-
е все металлические за-

в поле Extent введите 1. 
айшую к межслойному 
ереходу перемычку во 
тором ряду перемычек 
верху. Нажми

зано на рис. 6.171, а её трёхмерное отображение – на рис. 6.172. 
Для повышения качества работы межслойного перехода, можно рядом

ышки и, не от-
уская кнопки и двигая 
ышку, создайте пере-

 между 3-им и 4-
м слоями етром 
3 мм (dx:0.3 и dy:0.3). 
тановите курсор на 
вь созданную пере-
чку и совместите её с 
, ближайшей к меж-

 ряду сверху. 
 пер ычку между 3-
сположения емыч-
у переходу во втором 
ыглядеть, как показа-
рное отображение на 

оде и выходе структу-
роводнику копланар-
. Щёлкните по значку 
Установите курсор на 
и щёлкните мышкой. 
ую сторону порта так, 

чтобы курсор отображался в виде двойной стрелки. Нажмите левую кнопку мышки и сдвиньте рефе-
ренсную плоскость вправо на 1 мм. 

raw>Add E
 прямходного пр

 порт 1. Щёлкните

Аналогично установите 2-ой порт на правый край выходного проводника копланарной линии и 
сдвиньте референсную плоскость влево на 1 мм. 

Структура будет выглядеть, как показано на рис. 6.175. 

Рис.6.170Рис.6.169 

Рис.6.171 Рис. 6.172

Рис. 6.173 Рис. 6.174

Рис.6.175 



Откройте окно просмотра проекта, щёлкнув по кнопке Project в левой нижней
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на. 
Дважды щёлкните по Project Options в окне просмотра проекта. На в

крывшегося окна опций проекта отметьте Replace (Заменить), в поле Start (GHz)
(GHz) введите 18, в поле Step (GHz) введите 2, нажмите Apply и OK. 

Щёлкните по значку Add New Graph на панели инструментов или выберите
Add Graph. В открывшемся окне введите имя графика, например, LdB, отметьте

lar и нажмите OK. 
Откроется пустое окн

смотра про ппе Grap
с именем графика LdB. Щёл
мышки по этому имени и вы
ment. В открывшемся окне 
области Measurement Type о
ters, в области Measurement 
Port Index введите 2, в поле F
те 1, отметьте Mag и dB, нажм

Теперь можно выполн а
Поскольку структура довольн
достаточно мощный компью
время анализа, увеличим разм
те активны электро
Щёлкните по значку Substrate In  

Качество перехода можно улучшить, если рядом с перех дом авить
ремыкающие все е проводники. 

В окне просмотра проекта установите курсо

 

 части левого ок-

кладке Frequencies от-
 введите 1, в поле Stop 

 в меню Project> 
 тип графика Rectangu-

о графика и в окне про-
hs появится подгруппа 
кните правой кнопкой 
берите Add Measure-
измеряемых величин в 
тметьте Port Parame-
отметьте S, в поле To 
rom Port Index введи-
ите Apply и OK. 
ить ан

екта в гру

лиз структуры. 
о сложная, потребуется 
тер. Чтобы сократить 
ер ячеек сетки. Сделай-
магнитной структуры. 

formation на панели
м окно 

инструментов и верните прежние значения размеров 
ячеек сетки Grid_X=0.1 и Grid_Y=0.1. 

Сделайте активным окно графика и щёлкни-
те по значку Analyze на панели инструментов или выберите в меню Simulate> Analyze. Рассчитанный 
график показан на рис. 6.176. 

Рис.6.176

о  доб  сквозные перемычки, пе-

р на имя электромагнитной структуры CPW_CPW, 
нажмите левую кнопку мышки и переместите кур-
сор на группу EM Structures, отпустите кнопку. 
Будет создана копия структуры CPW_CPW_1. 

Откройте окно менеджера топологии. В 
поле EM Layer введите 2, отметьте Via и в поле 
Extent введите 3. 

Рис. 6.178Рис. 6.177

заземлённы

Щёлкая по значку Ellipse на панели инст-
рументов, создайте четыре дополнительные пере-
мычки диаметром 0.3 мм вблизи межслойного пе-
рехода, как показано на рис. 6.177 и 6.178. 

Откройте слева окно просмотра проекта и
сделайте активным окно графика. Щёлкните по 
значку Analyze на панели инструментов. Рассчи-
танные графики показаны на рис. 6.179. 

 
 
 

 
Рис. 6.179 
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ние (AXIEM) 

. Основные особенности AXIEM. 

моме
гут быть
Диэл
в пло
нет б

выше бесконечного полупространства. Полупростр
ник с потерями или идеальный проводник, но может
во над диэлектрическими слоями обычно является
ником. 

Формы проводников в AXIEM должны бы
одник

щине одного или нескольких слоёв. Нет никаких о
не обязательно должны точно вписываться в геом
может содержать проводники и перемычки. Перемы
равна толщине одного или нескольких слоёв. Т.к. о
черчивать перемычки, используя толстые проводн
обрабатывают пер толстые проводники, и

поверхностях позволяет выполнить точный анализ толстых проводников, даже если толщина больше 
ширины проводника. 

По умолчанию AXIEM моделирует проводники с нулевой толщиной. Но для точного определе-
ния связи между близко расположенными проводниками нужно учитывать толщину проводников. Чтобы 
при анализе учитывалась толщина проводников, нужно отключить установки по умолчанию. Это можно 
сделать как для всей структуры, так и для отдельных топологических форм. Чтобы учитывать толщину 
всех проводников в структуре, щёлкните правой кнопкой по имени структуры в окне просмотра проекта 
и выберите Options. В окне Options откройте вкладку Mesh. Снимите отметку в Use default properties и 
затем снимите “галочку” в Model as zero thickness. Чтобы учитывать толщину только некоторых про-
водников в структуре, выделите эти проводники, щёлкните правой кнопкой мышки по любому из них и 
выберите Shape properties. В окне Properties откройте вкладку Mesh. Снимите отметку в Use default 
properties и затем снимите “галочку” в Model as zero thickness. Убедиться, что толщина проводников 

установлена, можно просмотрев трёхмерное отображение 
структуры. Можно отключить установку по умолчанию и 
для всего проекта, выбрав ns>Default EM 

вается о
напряж
жду краем
конечно
земляно
при анализе
ляной п
мости 
щёлкни
tributes

й

 

Такой порт представляет собой узкий зазор меж-

7. Электромагнитное моделирова

7.1
В отличие от EMSight в AXIEM для анализа используется смешанная сетка с прямоугольными и 

треугольными ячейками. 
Решающее устройство AXIEM использует метод 

нтов для расчета токов на проводниках, которые мо-
 расположены на различных слоях диэлектриков. 

ектрические слои имеют бесконечную протяжённость 
скости X-Y, как показано на рис. 7.1. Т.е. в AXIEM 
оковых стенок. Диэлектрические слои располагаются 
анство ниже диэлектр

Рис. 7.1

ических слоёв обычно провод-
 быть и свободным пространством. Полупространст-

 свободным пространством, но может быть и провод-

ть планарными в плоскости X-Y и могут иметь тол-
ов ограничений нет. Толщина может быть равна тол-
граничений на встраивание проводников в сетку (они 
етрическую сетку, как в EMSight). Модель в AXIEM 
чки всегда направлены вниз и их длина должна быть 
граничений на толщину проводников нет, можн

щину в направлении оси Z. На толщину пров

о вы-
ики. Однако есть опции сетки, которые по разному 
меющие такую же толщину. 

Для анали  использует сетку на всех поверхностях проводника, включая боковые сто-
роны. При анализе рассчитываются токи в направлении X, Y и Z. Способность определять токи на всех 

Options. 
Для возбуждения структуры могут использоваться 

емычки и 
за AXIEM

в меню Optio

различные типы портов. Самым простым и часто исполь-
зуемым портом является порт края Edge Port. Устанавли-

н точно так же, как и в EMSight. По умолчанию 
ение для возбуждения структуры определяется ме-

 проводника, на котором установлен порт и бес-
й земляной плоскостью или бесконечностью, если 
й плоскости нет. Это может вносить погрешность 

. В этом случае лучше соединить порт с зем-
лоскостью ниже или выше проводника, в зависи-
от моделируемой структуры. Для этого дважды 
те по порту. Откроется окно Properties/Port At-
 (рис. 7.2). В поле Explicit Ground Reference (Яв-
ная связь с зем

Рис. 7.2

лё ) введите Connect to lower (со-
единить вниз) или Connect to upper (соединить 
вверх). Автоматически будет добавлена металли-
ческая полоска от

Рис.7.3 
Рис

 края проводника до земляной
плоскости и возле порта появится обозначение 
земли (рис.7.3). Трёхмерное отображение струк-
туры будет иметь вид, показанный на рис. 7.4. 

. 7.4
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ду верти
ородность этого порта 

не велика и обычно сдвиг референсной 
плоскости не требуется. Исключить влия-
ние неоднородности на результаты анали-
за можно процедурой исключения неод-
нородности порта (de-embedding). 

Иногда пользователь может оп-
ределить землёй для порта не земляную 
плоскость, а другой проводник, располо-
женный на другом слое (рис. 7.5). В таком 
случае процедура de-embedding не исклю-
чает неоднородность порта. 

Порты края могут быть располо-
жены на любых проводниках, даже если 
. На рис. 7.6 показана конфигурация без 
цедуру исключения неоднородности de-

Дифференциальные порты – это группа портов, в которой определён один порт с положительной 
клеммой и один или несколько портов с отрицательной клеммой, которые имеют тот же номер порта, что 
и положительная клемма. Дифференциальные порты могут быть установлены, например, в компланар-
ном волноводе (рис. 7.7) или в зазоре линии передачи (рис.7.8). Если используются дифференциальные 
порты, в Explicit Ground Reference можно установить только None. Чтобы определить порт с отрица-
тельной клеммой, дважды щёлкните по порту и в поле Port Number в окне рис. 7.2 введите отрицатель-

ное число. 
Многоконтактные порты – 

это порты с одинаковыми номера-
ми. Такие порты обычно исполь-
зуются для подключения одного 
элемента, например, источника к 
нескольким портам (рис. 7.9). В 
Explicit Ground Reference для 
этих портов можно установить 
любой тип заземления. 

Внутренний порт между 
двумя проводниками показан на рис. 7.10. Этот порт создаёт очень маленький зазор между проводника-
ми, через который производится возбуждение. 

Свойства портов можно редактировать после их установки в электромагнитной структуре. Для 
этого дважды щёлкните по порту, чтобы открыть окно его свойств (рис.7.2). Редактирование произво-

дится так же, как и в EMSight. Нужно не забывать, что уста-

запретить редактировать только порты, щёлкните по кнопке 
Check All, чтобы убрать все отметки в окне, затем отметьте 
EM ports. 

кальной полоской и земляной плоскостью, к которому приложено напряжение для возбуждения 
структуры. Неодн

Земля в бесконеч-
ности 

Рис. 7.6 Рис. 7.5 

эти проводники соединены друг с другом или перекрываются
земляной плоскости. Этот порт не может использовать про
embedding. 

Рис. 7.8 

Рис. 7.7 

Рис. 7.10Рис. 7.9 

новки Excitation и Impedance не влияют на вычисление S-
параметров. Эти параметры всегда вычисляются только на 
сопротивление портов 50 Ом. Можно выделить несколько 
портов, чтобы сразу отредактировать параметры всей группы 
выделенных портов. 

Вы можете также запретить редактирование установ-
ленных портов. Щёлкните правой кнопкой мышки в окне 
электромагнитной структуры и выберите Restrict Selection. 
Откроется окно рис. 7.11, в котором нужно отметить те эле-
менты, которые нужно запретить редактировать. Если нужно 

Рис.7.11 
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Свойства всех установленных портов можно отредактировать и в одном окне. При активном ок-
не элек  окно ЕМ Ports 
Propert а в этом окне вы 

 редактировать, в топологии этот порт выделяется 
еняется. Увеличивается отображение той области 

структу

 вниз). Тогда редактируемый

ого порта можно толь-
ко инди

1. Single Line (Одиночная линия); 

можность использования этого метода 

Couple
низких

жет ис
друг к
Для ис
порту, 

Properties  Port Group в поле Type введите
7.14). 

тромагнитной структуры выберите в меню Edit>Port Properties. Откроется
ies (рис. 7.12), в котором можно отредактировать свойства любого порта. Когд

щёлкаете в любом месте строки порта, который хотите
синим цветом и масштаб отображения структуры изм

ры, где расположен редактируемый порт. Но при этом само окно может закрывать редактируе-
мый порт. Можно попробовать сместить окно так, чтобы видеть все порты до начала редактирования 
(например, сместить окно  порт всегда будет виден. 

При установке портов, им автоматически присваиваются номера по порядку. Если вы затем из-
мените номер порта, например, чтобы сделать дифференциальные порты, или в процессе моделирования 
удалите какой-то порт, порядок их нумерации будет нарушен. Вы можете перенумеровать порты снова 
по порядку, выбрав в меню Edit>Re-number Ports. При этом если несколько портов имеют одинаковый 
номер, при перенумерации их номера остаются одинаковыми. Изменить номер так

Рис. 7.12

видуально, дважды щёлкнув по порту. 
Для исключения неоднородности 

порта в AXIEM используется три метода: 

2. Coupled Line (Связанные ли-
нии); 

3. Mutual Groups (Взаимные 
группы). 

Метод Single Line автоматически 
используется для портов края в одиноч-
ных линиях с любым типом заземления, 
для которых возможен процесс исключе-
ния неоднородностей порта (de-
embedding). 

Метод Coupled Line использует-
ся автоматически, если линии передачи 
расположены близко друг к другу. Воз-

также определяется автоматически в за-
висимости от расстояния между линиями. 

Связанные линии могут располагаться на разных слоях. 
Референсные плоскости на каждой отдельной линии 
могут быть сдвинуты на различные расстояния от пор-
та. Вы можете отменить использование этого метода. 
Для этого выберите в меню Options>Default EM Op-
tions. В окне EM Options на вкладке AXIEM имеется 
поле ввода Coupled ratio (рис. 7.13), в которое вводится 
коэффициент связи, определяющий максимальное рас-
стояние между линиями, при котором они считаются 
связанными. Чтобы отменить использование метода 

d Line, установите Coupled Ratio в 0. На очень 
 частотах этот метод не используется. 
Метод Mutual Groups (Взаимные группы) мо-
пользоваться, если порты расположены близко 
 другу и сами порты могут соединяться вместе. 
пользования этого метода дважды щёлкните по 
который нужно включить в группу. В окне 

 Mutual, в поле Name введите имя группы (рис. 

Рис. 7.13 

в области
Рис.7.14 
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Обычно взаимные порты используются, когда в схеме
использовались в электромагнитном моделировании. На рис. 
со всех четырёх сторон окружён топологическими формами, к
ные структуры. Сам же полевой транзистор не может быть вкл

Топология электромагнитной структуры, которую нуж

этому есть ситуации, когда недопустимо использовать метод Mutual Groups. 
Самый простой пример – неоднородность изгиба (рис.7.17). В этом примере ме-
таллическая полоска порта 1 будет продлена вправо, а металлическая полоска 
порта 2 – вниз. В результате получим перекрываю еталлические полос-
ки, что приведёт к погрешности в результатах анализа. Чтобы исключить ошиб-

анализа в этом примере, нужно добавить референсные плоскости так, чтобы 

отметьте Debug EM, в области ent должно быть 
EM_DEEMBED_MESH, в поле Port Number введ
порта, нажмите Apply и OK. Откройте тр
Будет отображаться количество линий, соо

неоднородности, установленному для этого порта. Если используется
 используется метод Coupled Line для двух

две линии. Если используется метод Mutual Groups, будет показан
включено в группу. 

M
исклю  для всех 
портов. Вы мо

Для этого дважды щёлкните по порту 

 правой кнопкой мышки по имени 

На низких частотах этот стандарт не используется. 
 нужно соединить компоненты, которые не 
7.15 показан полевой транзистор, который 
оторые моделируются как электромагнит-
ючён в электромагнитное моделирование. 
но моделировать, показана на рис. 7.16 

Для большей точности анализа порт

Рис.7.15 Рис. 7.16

ы соединены с нижней землёй. В этом случае расстояние до 
земли близко к расстоянию между портами и, следовательно, между портами есть связь. Метод Mutual 

Groups может удалить влияние этой связи из результатов анализа. 
Методы исключения неоднородности портов, созданные для взаимных 

групп, удлиняют металлические полоски по проводнику внутрь структуры. По-

щиеся м

Рис. 7.17 ки 
порты были обособленными и не влияли друг на друга (рис. 7.18). 

После установки портов вы можете просмотреть стандарты исключе-
ния неоднородности портов. Это позволяет проверить правильность установ-
ки метода исключения неоднородностей. Щёлкните правой кнопкой мышки 
по электромагнитной структуре в окне просмотра проекта и выберите Add 
Annotation. В открывшемся окне (рис. 7.19) в области Measurement Type 

Measurem
ите номер интересующего 

ёхмерное отображение структуры. 
тветствующее методу исключения 
 метод Single Line, будет показана 
 связанных линий, будут показаны 
о столько линий, сколько портов 

По умолчанию AXIE  включает 
чение неоднородностей

Рис. 7.18 

только одна линия. Если

жете отключить исключе-
ние неоднородности для любого порта. 

левой кнопкой мышки или щёлкните по 
порту левой кнопкой мышки, затем – 
правой кнопкой мышки и выберите 
Shape Properties, снимите “галочку” в 
de-embedding в открывшемся окне. Мож-
но отключить исключение неоднородно-
стей для всех портов в структуре. Щёлк-
ните
структуры в окне просмотра проекта и 
выберите Options. В открывшемся окне 
на вкладке AXIEM снимите “галочку” в 
de-embedding ports. 

Рис. 7.19 



Во время выполнения анализа вы можете 
видеть тип исключения неоднородностей для каж-
дого порта в окне Simulation (рис. 7.20), в котором 
отображается ход выполнения анализа. Эту же ин-
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формы. 
Чт

выберите
кройте вклад
здесь опции
структур
туры вы можете из
кой мышк
проекта, вы
опции буд
форм в стр

кой-то конкретной формы, щёлкните по этой форме левой кноп те
кой и выберите Shape Properties. В окне свойств откройте вк
properties и определите свои опции. 

Встраивание сетки зависит от многих установок. 
В диалоговом окне ENCLOSURE устанавливается р

электромагнитной структуры по осям X и Y (Grid_X и Grid_Y
мер ячеек сетки. 

Форма ячеек в сетке еляется макси

определяемый максимальной частотой. 

формацию можно видеть и в отчёте после выполнения анализа (рис. 7.21). 
AXIEM автоматически создаёт сетку, состоящую из прямоугольных и треугольных ячеек. Сетка 

может также встраиваться и в боковую поверхность проводника, что позволяет учесть его толщину (рис. 
7.22). Вы можете контролировать встраивание 

Рис.7.20 Рис. 7.21 

сетки как для всей структуры, так и отдельно для каждой 

обы определить опции встраивания сетки, 
  в меню Options>Default EM Options и от-

ку Mesh в окне опций. Установленные 
 будут действовать для всех создаваемых 

 в AXIEM. Но для любой созданной струк-
менить их, щёлкнув правой кноп-

и по имени структуры в окне просмотра 
брав Options и открыв вкладку Mesh. Эти 
ут действовать для всех топологических 
уктуре. Чтобы установить опции для ка-
кой мышки, затем щёлкни  правой кноп-
ладку M

Рис.7.22 

esh, снимите флажок Use default 

азмер геометрической сетки для создания 
), который определяет минимальный раз-

мальной частотой, заданной для анализа, или частотой 
для создания сетки Meshing Frequency. Щёлкни-
те правой кнопкой по имени структуры в окне 
просмотра проекта и выберите Options. На 
вкладке Frequencies по умолчанию включена 
опция Use Maximum Frequency (рис. 7.23), при 
которой для формирования сетки используется 
максимальная частота для анализа. Вы можете 
отключить эту опцию и ввести желаемую частоту 
в поле Meshing Frequency. Эта частота должна 
быть выше максимальной частоты, установлен-
ной для анализа. Эта особенность может быть 
по

 опред

лезна, если в процессе моделирования предпо-
лагается расширить диапазон в сторону более 
высоких частот. Если вы после выполнения ана-
лиза добавите новую частоту выше максималь-
ной частоты, которая использовалась для созда-
ния сетки, то, возможно, анализ будет выполнен 
повторно на всех частотах, т.к. изменится размер 

сетки, 
Рис. 7.23 
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 влияют не только значения Grid_X, Grid_Y 
и заданн

ки. При
В поле Max aspect ratio (Максимальный коэффициент стороны) устанавливается коэффициент, 

определяющий возможный максимальный размер 
ячеек. Максимальный размер ячеек получается умно-
жение размера, определённого в Grid_X и Grid_Y, на 
этот коэффициент. Если включена опция Use edge 
meshing, то вдоль краёв проводника создаётся узкая 
сетка, ширина ячеек которой определяется делением 
максимального размера на коэффициент Max aspect 
ratio. Значение этого коэффициента должно быть в 
пределах 1 – лчанию значение равно 10 и 
не рекоменд авливать больше 20. 

Very High (самое высокое) 

если в области Mesh Fea
ка не бу ваться
ми проводниками нет связ
добавочной погрешности а множи-
телем к значениям Grid_X и Grid
разному для сеток с высок
равно 1 и изменять его не р

Однозначных реко
емлемой точностью при м
вание с более грубой сетко  п е о
встраива у до вып

П е анали

2. Максим

В
используе
этих этапа

М
делением 
ratio. 

П
верхней и
ны толст
структура
ках, отсут
не вносит
можете со оль боковой сторо-
ны, отключив опцию No edge meshing when using 
thickness в окне Mesh Options (рис. 7.25). 

На возможную величину встраиваемых ячеек сетки
ая максимальная частота. 
В окне Options (щёлкнуть правой кнопкой мышки по имени структуры в окне просмотра проек-

та и выбрать Options) на вкладке Mesh (рис. 7.24) в области Meshing Density имеются опции плотности 
сетки Low (Низкая), Normal (Нормальная), High (Высокая), которые также влияют на размер ячеек сет-

 установке No Variable Mesh все ячейки сетки имеют одинаковый (минимальный) размер. 

 1000. По умо
уется устан

На вкладке Mesh окна EM Options имеется 
опция Decimation (Прореживание), значение которой 
можно выбрать от None (никакого прореживания) до 

Если в окне рис. 7.24 щёлкнуть по кнопке 
Advanced Axiem Mesh Options, откроется окно до-
полнительных опций сетки рис. 7.25, влияющих на 
встраивание сетки в структуру. Обычно установки по 

 подходят для различных структур. Но иногда их полезно изменить. Например, 
tures включить опцию Exclude the top surface mesh of thick conductors, то сет-
 в верхнюю поверхность толстого проводника. Если между связанными толсты-
и по оси Y,то это приведёт к меньшему времени анализа при незначительной 
нализа. В области Mesh Size опция Mesh size relative to grid является 

Рис.7.24
умолчанию в этом окне

дет встраи

_Y, изменяя плотность сетки. Причём это изменение действует по-
ой и низкой плотностью. По умолчанию значение Mesh size relative to grid 
екомендуется. 
мендаций, как выбрать все эти установки, чтобы получить результаты с при-
инимальном времени анализа, нет. Рекомендуется только начинать моделиро-
й и затем ереходить к более м лкой. В любом случае полезно просм треть 
олнения анализа. 
за решающее устройство сначала определяет максимальный размер ячеек сет-

ки, используя описанные выше установки, в два этапа: 
1. Максимальный размер ячеек определяется, исходя из максимальной частоты для определения 

размеров сетки Meshing Frequency и плотности сетки Meshing Density, определяющей коли-
чество ячеек на длину волны. 

емую сетк
ри запуск

альный размер ячеек определяет-
ся умножением Grid_X, Grid_Y на Max 
aspect ratio и на значение Mesh size rela-
tive. 
 качестве максимального размера сетки 
тся меньшее значение, полученное в двух 
х. 
инимальный размер ячейки определяется 
максимального размера на Max aspect 

о умолчанию узкие ячейки сетки на 
 на нижней стороне вдоль боковой сторо-
ого проводника не создаются. Когда 
 моделируется с токами на боковых стен-
ствие узких ячеек вдоль боковой стороны 
 существенной погрешности в анализ. Вы 
здать узкие ячейки вд

Рис. 7.25 
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Опция Minimal Z Meshing установлена по умолчанию
ли это возможно. Эту опцию можно отключить в ок
будет вести себя так же, как и вдоль осей X и Y. 

Опция Mesh using geometric progression соз
направлении от боковой стороны проводника к центру. По умолчанию эта опция отключена. Включить 
её можно в окне Mesh Options. На рис. 7.26 показана структура с выключенной опцией Mesh using 
geometric progression, а на рис. 7.27 – с включенной. 

Опция Edge Mesh 
Vias создаёт узкие ячейки 
сетки вдоль краёв перемыч-
ки, что повышает точность 
моделирования перемычек. 
По умолчанию она отключе-

 и в EMSight, введено усовер-
). По умолчанию эта опция 
 желании её можно отклю-

чить. Для этого выберите в меню Op-
tions>Default EM Options. В открывшемся 
окне на вкладке AXIEM снимите отметку в 
Enable AFS. Опция будет отключена для 
всех структур в проекте. Можно отклю-

ию только для кон-
ктуры в проекте. Для этого 

7.28) на вкладке AXIEM отключи-

выполнения итерации, анализ

из будет выполняться не более чем в 40 точках. 
В остал . После выполнения анализа вы може-

быть по
Доступны следующие опции AFS, которые мо

опций: 
• Tol (dB). Эта опция задаёт допуск на погрешно
велико, частотных точек, в которых выполняет
анализа уменьшится, но точность будет хуже. 
может иметь “ложную сходимость”. Устанавли
В процессе выполнения анализа можно наблюд
са Simulation. Сначала AFS должен выполнить
является сообщение, подобное рис. 7.29. 
В выделенной строке приводится количество т
ство заданных точек и ошибка сходимости. Есл
итерации сходится. В конце строки имеются с
точках, когда очередная проверка сходимости з
сходимости и звёздочка заменяется буквенным
сходимости меньше установленного допуска. 
окно будет выглядеть, как показано на рис. 7.30
Эта же инфо  в файле отчё

 и уменьшает число ячеек вдоль оси Z, ес-
не Mesh Options. В этом случае сетка вдоль оси Z 

даёт сетку, размер ячеек у которой увеличивается в 

чить/включи
кретной стру

Рис. 7.26 Рис. 7.27

на. Включить её можно в окне Mesh Options. 
Для ускорения анализа электромагнитных структур в AXIEM, как

шенствованное свиппирование частоты (Advanced Frequency Sweep – AFS
включена. При

ть эту опц

щёлкните правой кнопкой мышки по имени 
структуры в окне просмотра проекта и вы-
берите Options. В открывшемся окне (рис. 

те/включите Enable AFS. Если эта опция 
включена, анализ выполняется только в 
некоторых частотных точках, в остальных 
точках результаты получаются интерполя-
цией. Количество заданных частотных то-
чек в этом случае мало влияет на время 
выполнения анализа. Поэтому можно зада-
вать большое количество точек, например, 
несколько сотен. Если точек очень мало и 

 выполняется во всех заданных точках. Если для ана-
лиза задано очень много частотных точек, нужно ограничить количество точек, в которых будет выпол-
няться анализ, установив требуемое значение Max # sim pts. Например, если установить 100 частотных 
точек для анализа и установить Max # sim pts=40

Рис. 7.28 

очно для их недостат

, то анал
ьных точках результат будет определяться аппроксимацией

те добавить новые частотные точки и повторить анализ. Для получения результатов в новых точках ис-
пользуются уже полученные результаты, и повторный анализ не выполняется, если вы не добавили час-
тот выше максимальной частоты предыдущего анализа. Если такая частота добавлено, анализ может 

вторён полностью, т.к. изменится размер встраиваемой сетки. 
жно определить на той же вкладке AXIEM окна 

сть интерполяции в дБ. Если значение Tol (dB) не 
ся анализ, будет меньше и, соответственно, время 
Кроме того, если этот допуск слишком мал, AFS 
вать этот допуск меньше 5 дБ не рекомендуется. 
ать процесс сходимости AFS в окне хода процес-
 анализ в пяти точках, после чего в этом окне по-

очек, в которых выполнен анализ, общее количе-
и в этой строке ошибка сходимости 0, то процесс 
кобки со звёздочками. При анализе в следующих 
аканчивается, в этой строке отображается ошибка 
 символом. Анализ заканчивается, когда ошибка 
После выполнения анализа на последней частоте 
. 
та, и её всегда можно просмотреть после оконча-

ния анализа. 
рмация запоминается



Max # sim pts. Алгоритм AFS выбирает точки для анализа из заданных частотных точек. В этой 
опции вы можете ограничить макси

Рис. 7.29 Рис. 7.30

мальное количество выбираемых точек, в которых будет проводиться 
анализ. 

 

ную приходится очень редко, например, если по каким

7.2. Моделирование направленного от
В этом примере рассмотрим моделирование направл

водников в EMSight и AXIEM для сравнения.  
Создайте новый проект и сохраните его под 

Options (Options>Project Options) в поле Frequenc
нажмите OK. 
7.2.1. Создание электромагнитной структу

1. Щёлкните левой кнопкой мышки по значку e

sure от-
крывшегося окна в поле X_Dim вве-

дите 9.6, в поле Y_Dim введите 4, в поле Grid_X введите 0.15 и в поле Grid_Y введите 0.015. 
Будет выведено окно рис. 7.32 с предупреждением «При этих значениях необходимо округлить 
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В области Configure Options For нахо-
дятся три кнопки, определяющие режим анали-
за: Fastest (Самый быстрый, за счёт уменьше-
ния точности анализа), Reset Defaults (Восста-
новить по умолчанию) и Most Accurate (Самый 
точный, за счёт увеличения времени анализа). 
При нажатии на одну из этих кнопок изменяют-
ся значения некоторых опций, которые сразу же 
отображаются в окне. Но, при необходимости, 
значения этих опций можно изменить и вруч-
ную. 

AXIEM имеет несколько решающих 
устройств для прямых вычислений (Direct) и 
для итерационных вычислений (Iterative). Пря-
мые вычислители используются, если требуется 
выполнить анализ во всех точках (AFS отклю-
чено). Итерационные вычислители используют-
ся при включённом AFS. Установить требуемое
решающее устройство можно в поле Solver type 

(рис. 7.31). По умолчанию в этом поле установлено значение Auto configure. При этом AXIEM автома-
йство. Подбирать решающее устройство вруч-

Рис. 7.31 

тически подбирает наиболее подходящее решающее устро
-то причинам итерационный процесс не сходится. 

ветвителя. 
енного ответвителя с учётом толщины про-

именем NO-t. На вкладке Global Units окна Project 
y введите GHz, в поле Length type введите mm и 

ры. 
 Add N w EM Structure на панели инструментов. 

2. Наберите NO_EMSight в поле Enter 
a name for the EM Structure, от-
метьте AWR EMSight Simulator и 
нажмите Create. На рабочем поле 
откроется окно электромагнитной 
структуры. 

3. Щёлкните мышкой по значку Sub-
strate Information на панели инст-
рументов. На вкладке Enclo

Рис. 7.32 
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 число ячеек сетки. Вы можете отве-

tric Definitions для диэлектрического слоя Diel_1 
введите Er=10, TanD=0.0001. В столбце Color для проводника введите 1 
ните мышкой и выберите красный цвет. 

5. На вкладке Dielectric Layers для слоя 1 в колонке Thickness вве
Thickness введите 0.5. Нажмите OK. 

7.2.2. Созд ологии. 
1. Щёлкните  кнопк ку Rectangle на панели и

Tab

открыть диалоговое окно Enter Coordinates. Введи
нажмите OK. Проводник прямоугольного сечени
структуры. 

4. Повторите пункты 1 и 2. Введите 1.95 в поле x, введ
клавишу Tab снова, чтобы открыть диалоговое окн
введите 0.3 в поле dy и нажмите OK. 

5. Щёлкните по значку Copy и затем по значку Paste 
рованный проводник ниже предыдущего так, чтобы

6. Повторите пункты 1 и 2. Введите 7.65 в поле x, введ
клавишу Tab снова. Введите 1.95 в поле dx, введите

7. Повторите пункты 1 и 2. Введите 1.5 в поле x, введ
вишу Tab снова. Введите 0.45 в поле dx, введите 1.9

8. Щёлкните по значку Copy и затем по значку Paste 
пированный проводник к правому нижнему углу ни
го подключения увеличьте отображение правой час

9. Щёлкните по значку Polygon на панели инструмен
угол первого вертикального проводника и щёлкни
верхний угол вертикального проводника и щёлкнит
левый угол нижнего горизонтального проводника и

10. Аналогично второй вертикальный прово
ком. 

плоскость на 1 мм. 

остальные порты, как по-

1

ис. 7.33. 
7.2.3. Д

1.

2.

размер сетки или корпуса. Размер корпуса будет округлён к ближайшему целому числу для 
этой сетки. Вы согласны с таким изменением?». Т.е. размер корпуса (в данном случае – длина) 
выбран так, что по этому размеру не укладывается целое
тить Нет и затем вручную изменить размер ячеек сетки или размер корпуса. Или нажать Да и 
довериться автоматическому округлению. Нажмите Да. Размер Y_Dim получит размер 4.005 
мм. 

4. На вкладке Material Defs в области Dielec
oz Cu, дважды щёлк-

дите 6, для слоя 2 в колонке 

ой мышки по знач нструментов. 
2. Поместите курсор в окно электромагни

ание топ
 левой

тной структуры и нажмите клавишу  на клавиатуре. 
Откроется диалоговое окно Enter Coordinates. 

3. Введите 0 в поле x, введите 2.325 в поле y и нажмите OK. Нажмите клавишу Tab снова, чтобы 
те 1.96 в поле dx, введите 0.45 в поле dy и 
я отображается в окне электромагнитной 

ите 2.325 в поле y и нажмите OK. Нажмите 
о Enter Coordinates. Введите 5.7 в поле dx, 

на панели инструментов. Поместите скопи-
 зазор между ними был равен 0.03 мм. 
ите 2.325 в поле y и нажмите OK. Нажмите 
 0.45 в поле dy и нажмите OK. 
ите 0 в поле y и нажмите OK. Нажмите кла-
95 в поле dy и нажмите OK. 
на панели инструментов и подключите ско-
жнего проводника ответвителя. Для точно-
ти топологии. 
тов. Установите курсор на верхний левый 
те мышкой. Переместите курсор на правый 
е мышкой. Переместите курсор на нижний 

 дважды щёлкните мышкой. 
дник с нижним горизонтальным проводни-

11. Щёлкните по входному проводнику, чтобы выделить его. Щёлкните по значку Edge Port и ус-
тановите порт на левой 
стороне входного провод-
ника. Дважды щёлкните 
по установленному порту 
и в поле Ref. Plane Dis-
tance введите 1, чтобы 
сдвинуть референсную 

соедините 

12. Аналогично установите 

казано на рис. 7.33. Обра-
тите внимание, что если 

установлен порт 3 и в нём сдвинута референсная плоскость, то при установке порта 4 рефе-
ренсная плоскость будет сдвинута на ту же величину автоматически. 

Рис.7.33 

3. Выделите всю топологию, щёлкните по любому выделенному проводнику правой кнопкой 
мышки и выберите Shape Properties. В поле Material введите 1/2oz Cu и нажмите OK. Струк-
тура будет выглядеть, как показано на р
обавление частот, создание графика и анализ. 
 Дважды щёлкните по Project Options в окне просмотра проекта и откройте вкладку Frequen-

cies. Отметьте Replace, в поле Start (GHz) введите 3, в поле Stop (GHz) введите 7, в поле Step 
(GHz) введите 0.1, нажмите Apply и OK. 

 Щёлкните по значку Add New Graph на панели инструментов. Введите имя графика LdB в по-
ле Graph name, выберите Rectangular  в области Graph Type и нажмите OK. 
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3.

Sources в поле Data Source Name, 2 в поле To Port Index, 1 в поле From Port Index, отметьте 
Mag и dB, нажмите Apply. Затем выбе-
рите 3 в поле To Port Index и нажмите 
Apply. Нажмите OK. 

4. Выберите в меню Options>Default EM 
Options. В открывшемся окне отметьте 
Enable AFS, чтобы включить улучшен-
ное изменение частоты для всех струк-
тур в проекте, использующих EMSight и 
нажмите OK. 

5. Щёлкните по значку Analyze на панели 
инструментов. По полученному графику 
щёлкните правой кнопкой мышки и вы-
берите Properties. Для оси x снимите 
отметку Auto. divs и в поле Step введите 
0.5. Для оси Left 1 установите шаг 1. 
Нажмите Apply и OK. Полученный гра-
фик показан с. 7.34. 

 анали ht считает проводники 
 учитывается

гих микрополосковых структур это не вносит заметной по
ных линиях зазор мал и соизмерим с толщиной проводни
венной. Учесть толщину проводника в EMSight можно т
с толщиной, равной толщине проводника, и на нём созд
над первым. 
7.2.4. Создание “толстого” проводника в EMS

1. Установите курсор мышки на имя структуры в 
мышки и переместите курсор на EM Strictures, 
туры. Переименуйте созданную копию в NO_EM

н

2. 

 верхнем слое. Это произошло из-за того, что для них 
ь этот слой ста третьим. Чтобы 

вернуть проводники 

туры, выделите все 

 Щёлкните по значку Add New Measurement на панели инструментов. В окне Add Measure-
ment выберите Port Parameter в списке Measurement Type, S в списке Measurement, All 

При
 на ри

зе EMSigРис.7.34 
 только при расчёте потерь. Для мно-

грешности. Однако, если, например, в связан-
ка, то погрешность анализа может быть сущест-
олько, создав дополнительный слой диэлектрика 
ать второй такой же проводник, расположенный 

ight. 
окне просмотра проекта, нажмите левую кнопку 
чтобы создать копию электромагнитной струк-
Sight_t (это можно сделать сразу же после ко-
пирования или позднее, но тогда нужно будет 
щёлк

бесконечно тонкими. Заданная толщина проводников

уть правой кнопкой мышки по имени 
скопированной структуры и выбрать Rename 
EM Structure). 
Щёлкните по значку Substrate Information на 
панели инструментов. В окне свойств на 
вкладке Dielectric Layers отметьте слой 1 и 
щёлкните по кнопке Insert. Появится слой 2 с 
такими же параметрами, как и слой 1. Изме-

ните толщину этого слоя на 0.015, в столбце Draw Scale введите 20, чтобы удобнее было про-
сматривать трёхмерное отображение (рис.7.35). Нажмите OK. 

3. Щёлкните по значку View EM 3D Layout. Трёхмерное отображение структуры показано на рис. 
7.36. Как видно, проводники оказались на

Рис. 7.35 

осталась действовать установка черчения на втором слое, а тепер

на нижний слой, сде-
лайте следующее. 
Сделайте активным 
окно двухмерного 
отображения струк-

проводники и щёлк-
ните по значку Move 
Down на панели ин-
струментов. Трёх-
мерное отображение 
структуры будет, как 
на рис. 7.37. Теперь 
проводники распо-
ложены на нижнем 
слое. 

4. Сделайте активным окно двухмерного отображения структуры. Откройте окно менеджера топо-
логии. В поле EM Layer введите 2, в поле Material введите 1.2oz Cu и отметьте Conductor. 

Рис 7.37Рис.7.36
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трёхмерное отображение будет, как показано на рис. 7.38. 

структуры и выберите Add Annotation. В открыв-

M, в области Measurement отметьте EM_Mesh в поле 
EM Simulation Document введите имя структуры 

 трёхмерном 

8. Проводники ответви-

оях, 

иал, по-

дников. Пере-

В поле
введите
Щёлкните 
струментов

 на левом конце одного из проводников, расположенно
ну перемычки сделайте равными 0.3 мм (рис. 7.41). 

9. Скопируйте созданную перемычку и установите перемычки
ремычки по длине проводников, примерно на равных расстояниях
бражение полученной структуры показано на рис. 7.43. 

10. Откройте окно просмотра проекта и сделайте активным окно
lyze на панели инструментов. Полученный график показан 
учёт толщины даё чный результат, показывая более

5. Щёлкните по значку Rectangle на панели инструментов, начертите прямоугольник точно над 
одним из проводников ответвителя, точно такой же по размерам, как и проводник, расположен-

ный на нижнем слое. Скопируйте созданный проводник и 
расположите его над вторым проводником ответвителя. 
Двухмерное отображение структуры при этом не изме-
нится, т.к. верхние проводники закрывают нижние. А 

6. Сделайте активным окно скопированной структуры. 
7. Щёлкните правой копкой мышки по имени скопирован-

ной 
шемся окне в области Measurement Type отметьте Planar 
E

NO_EMSight_t. Нажмите Apply и OK. На
отображении структуры будет показана встраиваемая для 
анализа сетка (рис. 7.39а и 7.39б). Сетка – прямоугольная 

Рис. 7.38 и наклонная сторона изгиба аппроксимируется ломаной 
линией. Очевидно, в 
нашем случае это не 
должно оказывать за-
метного влияния на 
результаты расчёта. 

теля, расположенные 
на разных сл
должны иметь одина-
ковый потенц

этому их нужно соединить перемычками, 
имитирующими толщину прово

Рис. 7.39а Рис. 7.39б

мычка не обязательно должна быть по всей 
длине проводников, т.к. EMSight не учитывает 
горизонтальные токи в перемычках. Предпо-
лагается, что ток на перемычке постоянный и 
течёт в вертикальном направлении. Поэтому 
достаточно установить перемычки на краях 
проводников и несколько перемычек по длине 
на расстоянии между ними меньше 1/8 длины 
волны. Откройте окно менеджера топологии. 

 EMLayer введите 2, в поле Material 
 1/2oz Cu и отметьте Via (рис. 7.40). 

по значку Rectangle на панели ин-
 и создайте прямоугольную пере-
го на верхнем слое. Ширину и дли-

 на краях проводников и по две пе-
 (рис. 7.42). Трёхмерное ото-

 графика. Щёлкните по значку Ana-
на рис. 7.44. Из графика видно, что 

 сильную связь между близко рас-

мычку
Рис.7.40 Рис. 7.41

т более то
положенными проводниками в связанных линиях. 

Рис. 7.42 Рис. 7.43
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доходить до края 

крывшемся тьте AWR AXIEM и нажмите 

берите Shape Properties. Откро-

жет вызвать дополнительную 

родность порта
процедурой ис
сдвига референ
этого можно выпо
референсной пло
нашем случае 
дут отличаться

5. Щёлкните по 
Трёхмерное от
туры показано
полоски портов
полосками и землян
узкий зазор, к 
буждающее напр

6. Щёлкните право
созданной структуры

 

Замечание. Порт можно установить только на 
проводник, расположенный на одном слое. Т.е. 
перед нашими “толстыми” проводниками обяза-
тельно должны быть отрезки линии, располо-
женные на нижнем слое. Кроме того, проводники 
на верхнем слое не должны 
корпуса, т.е. не должны быть замкнуты на кор-
пус. В нашем случае эти условия выполняются. 
7.2.5. Создание электромагнитной 
структуры для AXIEM. 

1. В окне просмотра проекта установите 
курсор мышки на имя структуры 
NO_EMSight, нажмите левую кнопку 
мышки и переместите курсор на EM 
Structures. 

2. Переименуйте скопированную структуру 
в NO_AXIEM. 

3. Щёлкните по имени скопированной 
кнопкой мышки и выберите Set Simulator. В от-

Рис. 7.44 
структуры в окне просмотра проекта правой 

окне отме
 EMSight,

OK. Структура будет выглядеть точно так 
же, как и для  за исключением того, что отсутствуют стенки корпуса. 

4. Нажмите клавишу Shift и щёлк-
ните поочерёдно по все портам, 
чтобы выделить их. Щёлкните 
правой кнопкой мышки по лю-
бому выделенному порту и вы-

ется окно свойств. Обратите 
внимание на поле Explicit 
Ground Reference (Ссылка на 
явную землю). В этом поле сто-
ит значение None. При этом 
значении считается, что земля 
находится в бесконечности, что 
мо
погрешность при анализе. Что-
бы избежать этого, нужно ука-
зать ссылку на землю, которой 
может быть верхняя или нижняя 
земляные плоскости. Для нашей 

структуры нужно указать нижнюю земляную пластину, относительно которой нужно подать на-
пряжение для возбуждения линии. Введите в поле Explicit Gr

Рис. 7.45 

ound Reference значение Connect 
to lower (подключить к низу), как показано на рис. 7.45. Кроме того, в поле Ref. Plane Distance 

можно установить 0, чтобы удалить сдвиг 
референсной плоскости. В AXIEM неодно-

 мала и может быть исключена 
ключения (de-embedding) без 
сной плоскости. Для проверки 

лнить анализ со сдвигом 
скости и без этого сдвига. В 

результаты практически не бу-
. Нажмите OK. 
значку View EM 3D Layout. 
ображение полученной струк-
 на рис. 7.46. Вертикальные 
 означают, что между этими 

ой плоскостью имеется 
которому прикладывается воз-
яжение. 
й кнопкой мышки по имени 

 в окне просмотра про-
Рис. 7.46 

екта и выберите Add Annotation. В открывшемся окне в области Measurement Type отметьте
Planar EM, в области Measurement отметьте EM_MESH_F, нажмите Apply и OK. Откройте 
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tions 

7.2.6. Учёт толщины
1. Создайте

структуры
её в EM_A

2. На точность -
ет тольк
связанных
толщину 
ните мышк
связанной

EM_MESH_F, нажмите Apply и OK. От-

а на рис. 7.50. 

вается количество просчитанных частотных 
точек из общего количества заданных точек (в скобках). В 
этой же стоке указывается
(Ошибка сходимости
AXIEM использует 
Если значение Convergenc
процесс итерации сходи
этой строке указывается
и величина ошибки 
ся, когда эта ошибка 
нию -30 дБ). Рассчитанный
Из графиков видно, чт

сильную связь, чем анализ в EMSight. Очевидно, это более 
щины проводников учтено точнее. 

трёхмерное отображение структуры. 
Встроенная в структуру сетка показана на рис. 
7.47. Обратите внимание, в изгибы полоски 
встроены треугольные ячейки сетки. 

7. По умолчанию AXIEM считает проводники 
бесконечно тонкими. Оставьте пока значение 
толщины проводников по умолчанию. 

Рис. 7.47 

Выберите в меню Options>Default EM Op
и в открывшемся окне на вкладке на вкладке 
AXIEM отметьте Enable AFS (обычно эта 
опция включена по умолчанию). 

8. Щёлкните по значку Analyze на панели 
инструментов. Рассчитанный график 
показан на рис. 7.48. Как видно из гра-
фиков, полученный результат хорошо 
совпадает с аналогичным результатом 
анализа в EMSight. 

 проводников. 
 копию электромагнитной 

 EM_AXIEM и переименуйте 
XIEM_t. 

 анализа существенно влия
о учёт толщины проводников в 

 линиях. Поэтому установим 
только для этих линий. Щёлк-
ой по одному из проводников 

 линии и затем, нажав клави-
шу Shift, щёлкните по другому провод-
нику, чтобы выделить оба проводника в 
связанной линии. Щёлкните правой 
кнопкой мышки по любому выделенно-

му проводнику и выберите Shape Proper-
ties. В открывшемся окне на вкладке 
Mesh снимите “галочку” в Use project de-
faults и затем снимите “галочку” в Model 
as zero thickness (рис. 7.49). Нажмите 
OK. 

3. Щёлкните правой кнопкой мышки по 
имени структуры EM_AXIEM_t в окне 
просмотра проекта и выберите Add An-
notation. В открывшемся окне в области 
Measurement Type отметьте Planar EM, 
в области Measurement отметьте 

Рис. 7.48 

кройте трёхмерное отображение структу-
ры. Встроенная в структуру сетка показа-
н

4. Откройте окно графиков и щёлкните по значку Analyze на панели инструментов. Во время вы-
полнения анализа обратите внимание на окно процесса анализа Simulation. После выполнения 

расчета в 5-ти точках в этом окне появляется строка, в ко-
торой указы

Рис. 7.49 

 значение Convergence error 
). Поскольку включена опция AFS, 
итерационное решающее устройство. 

e error равно нулю, значит, 
тся (рис. 7.51). В дальнейшем в 
 количество просчитанных точек 

итерации. Процесс анализа закончит-
станет меньше заданной (по умолча-

 график показан на рис. 7.52. 
о AXIEM показывает заметно более 
точный результат, т.к. влияние тол-

Рис. 7.50 



Рис. 7 51 . Рис. 7.52

7.3. Моделирование широкополосного фильтра-лесенки. 
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В этом примере рассмотрим полный цикл моделиро

14 – 18 ГГц. 
Создайте новый проект и сохраните его под именем F1

ject Options (Options>Project Options) в поле Frequency введите
нажмите OK. 
7.3.1. Синтез фильтра. 

Воспользуемся тем, что в мастере синтеза фильтров имеется
ры такого типа. 

1. Раскройте группу Wizards в окне просмотра проекта и
sis Wizard. В открывшемся окне нажмите Далее. 

2. В следующем окне отметьте Bandpass и нажмите Далее
3. В следующем окне отметьте Chebashev и нажмите Дал
4. В следующем окне введите параметры, определяющие

7.53, 
5. В следующем

Half-W

7. В следующем окне отметьте Microstrip и
8. В следующем окне рис. 7.54 вводятся пар

strate Selection можно ввести имя материала
кнопке в конце этого поля. Оставьте знач
введём вручную. Имя Name также можно
поле Tand введите 0.0001, в поле H введ

вания фильтра с боковыми электромагнит-

наторный фильтр с полосой пропускания 

4-18. На вкладке Global Units окна Pro-
 GHz, в поле Length type введите mm и 

 возможность синтезировать фильт-

 дважды щёлкните по AWR Filter Synthe-

. 
ее. 

 полосу пропускания, как показано на рис. 
и нажмите Далее. 

 окне отметьте Parallel Coupled 
ave Resonators (Параллельно связан-

ные полуволновые резонаторы) и нажмите Да-
лее. 

6. В следующем окне устанавливаются мини-
мально допустимые ширина проводника и ве-
личина зазора между проводниками. По умол-
чанию эти значения равны 0.0005 мм. Эти зна-
чения явно нереализуемые. Можно ввести ми-
нимальные реализуемые значения, но при этом 
есть риск попасть в область ограничений син-
теза, при котором синтез просто не сработает и 
придётся начинать всё сначала. Поэтому часто 
лучше оставить эти значения по умолчанию, а 
приемлемые значения ширины проводнико

ными связями в EMSight и AXIEM для сравнения. 
Требуется спроектировать микрополосковый 5-ти резо

в и 
зазора между ними можно затем установить 
при настройке фильтра. Нажмите Далее. 

 нажмите Далее. 
аметры подложки. В поле Predefined Microstrip Sub-

 подложки из имеющихся в списке, щёлкнув по 
ение этого поля по умолчанию, а параметры подложки 

ть по умолчанию. В поле 

Рис. 7.53

 остави Er введите 10.73, в 
ите 0.5 и в поле T введите 0.005. В поле Metal Selection 

введите Copper, щёлкнув по кнопке в правом конце этого поля. Нажмите Далее. 
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9. В следующем окне рис. 7.55 можно оста
разработки (Design Name) также можно
тере синтеза фильтров. Оставьте включённо
чтобы можно было выполнить оптимизацию ю Create 
Graph (Создать график) и тип графика
ку в Input Return Loss (S11), чтобы созда

10. В следующем окне нажмите Готово. 

Дело в том, что мастер синтеза фильтров
MSTEPX$, но Х-модели для Er=10.73 в Microwave 
модель. Но проще взять готовую модель с близким
погрешности. Кроме того, всё равно структуру
нии. Ближайшая модель имеется для Er=10.2, 
элементу подложки MSUB и введите ErNom=10

12. Щёлкните по значку Analyze на панели инстр

вить имя схемы (Schematic Name) по умолчанию. Имя 
 оставить по умолчанию, оно будет отображаться в мас-

й по умолчанию опцию Include Optimization Coals, 
 фильтра. Оставьте отметку по умолчани

 Rectangular. Введите имя графика LdB и снимите отмет-
ть только график прямых потерь S21. Нажмите Далее. 

11. Если теперь щёлкнуть по значку Analyze на панели
Рис. 7.54 

 инструментов, анализ выполняться не будет. 
 для скачков сопротивления вставил Х-модель 

Office нет. Можно, конечно, создать такую 
 значением Er. Это не внесёт существенной 

 будем уточнять в электромагнитном моделирова-
её и будем использовать. Дважды щёлкните по 
.2. Синтезированная схема показана на рис. 7.56. 

Рис. 7.55 

ументов. 
Рис. 7.56 

Рассчитанный график показан на рис. 7.57. Он получился сдвинутым по частоте. Попробуем оп-
тимизировать структуру. 

Рис. 7.57 Рис. 7.58 
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Выберите в меню Simulate>Optimize. 
В открывшемся окне Optimizer оставьте все значения по умолчанию и нажмите Start. Оптими-

зированный график показан на рис. 7.58. 
Щёлкните по значку Add New Graph на панели и создайте прямоугольный график KctU. До-

бавьте к этому графику измеряемую величину VSWR. Щёлкните по значку Analyze на панели инстру-
ментов. Щёлкните по графику правой кнопкой мышки и выберите Properties. В открывшемся окне 
свойств на вкладке Axes для оси x снимите “галочки” в Auto limits и в Auto divs. В поля Min и Max вве-
дите 13 и 19 соответственно, в поле Step введите 0.5. Для оси Left 1 сделайте то же самое, но в поля Min 
и Max введите 0 и 10, в поле Step введите 0.5. 

Чтобы отобразить границы полосы пропуска-
ния, можно установить вертикальные маркеры. Чтобы 
их лучше было видно, измените шрифт для маркеров. В 
окне свойств графика откройте вкладку Fonts. Щёлкните 
по кнопке Markers. Установите размер шрифта 20, от-
метьте “жирный” и измените цвет на “Красный”, на-
жмите OK и затем Apply. 

Чтобы установить вертикальные маркеры, 
щёлкните в окне графика пр й кнопкой мышки и вы-
берите Add Vertical L er. Установите маркеры 
на 14 и 18 ГГц. Полученный график показан на рис. 7.59. 

, чтобы обеспечить 

тромагнитной структуре. Считая, 
 

 

Теперь можно создавать 
электромагнитную структуру. Но 

шемся окне на вкладке Frequencies введит
ГГц. Нажмите Apply и OK. 

2. Щёлкните по имени схемы и выберите Op
faults и нажмите OK. 

3. Щёлкните правой кнопкой мышки по 
просмотра проекта и выберите Properties
те All Sources, нажмите OK. То же самое

4. Добавим к схеме входной и выходной по
можно определить, что ширина 50-тиомн

 
 

вает подключе-
ние входного проводника к проводнику первых связанных линий в топологии так, чтобы нижняя 
сторона входного проводника совпала с нижней стороной верхней линии в первом элементе 
MCFIL. Аналогично добавьте такие же элементы на выходе фильтра (можно копированием, 

 аво
ine Mark

Полосу можно несколько расширить
некоторый запас по полосе, и улучшить расчетное со-
гласование фильтра. 

Щёлкните по значку Tune на панели инстру-
ментов. Пользуясь инструментом подстройки, можно 
подстроить характеристику фильтра, и затем получен-

ные размеры округлить так, чтобы 
они были кратными сетке в элек-

что ячейки структуры будут иметь
размер 0.5 мм, можно получить 
размеры, показанные на рис. 7.60 и
график, показанный на рис. 7.61. 

сначала заменим частотные точки 
для анализа (мастер синтеза устано-
вил их очень часто) и свойства из-
меряемой величины, чтобы можно 
было на одном графике наблюдать 
характеристики всех создаваемых в 
проекте структур. 

1. Дважды щёлкните по Pro-
ject Options в окне про-
смотра проекта. В открыв-

е частотный диапазон от 10 до 22 ГГц с шагом 0.5 

tions. На вкладке Frequencies отметьте Use project de-

имени измеряемой величины Filter: DB(|(S21)|) в окне 
. В открывшемся окне в поле Data Source Name введи-
 сделайте для графика VSWR. 
дводящие проводники. Выбрав в меню Tools>TXLine, 
ой линии равна примерно 0.45 мм. Сделайте активным 

курсор мышки на первый порт, нажмите левую

Рис. 7.59

Рис. 7.60 Рис. 7.61

окно схемы. Нажмите клавишу Ctrl, установите 
кнопку мышки и сдвиньте порт в сторону, прервав его связь со схемой. Аналогично сдвиньте
второй порт. Откройте окно просмотра элементов. Раскройте группу Microstrip и отметьте 
Junctions. Найдите элемент MSTEPX$ и подключите его ко входу фильтра. Отметьте подгруппу 
Lines в окне просмотра элементов. Найдите элемент MLIN и подключите его к добавленному 
элементу MSTEPX$. Дважды щёлкните по элементу MLIN, введите ширину проводника 
W=0.45 и длину L=3. Нажмите OK. Дважды щёлкните по элементу MSTEPX$ и для значения 
смещения Offset введите –abs(W@2-W@1)/2. Это значение смещения обеспечи



чтобы их не редактировать). Подключите сдвинутые порты ко входу и выходу фильтра. Полу-
ченная схема показана на рис. 7.62. 

Рис. 7.62 
5. Щёлкните по значку Analyze на панели инструментов и убедитесь, что характеристика не изме-

нилась. 
7.3.2. Создание электромагнитной структуры в EMSight. 

1. При активном окне схемы щёлкните по значку View Layout на панели инструментов. Топология 
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будет выглядеть, как показано на рис. 7.63. 

результатам измерения определяем, что длина корпуса может быть 15.8 мм, а ширина 5.85 мм. 
3. Щёлкните по значку Add New EM Structure. В открывшемся окне введите имя структуры 

Fil_EMSight, отметьте AWR EMSight Simulator и нажмите Create. 
4. Щёлкните по значку Substrate Information на панели инструментов. На вкладке Enclosure от-

крывшегося окна введите X_Dim=15.8, Y_Dim=5.85, Grid_X=0.05 и Grid_Y=0.05. На вкладке 
Material Defs для слоя Diel_1 введите Er=10,73, TanD=0.0001. Дважды щёлкните по столбцу 
Color для проводника 1 oz Cu и отметьте красный цвет. На вкладке Dielectric Layers для перво-
го слоя введите толщину 6, для второго слоя введите толщину 0.5 и масштаб отображения Draw 
Scale равным 4. Нажмите OK. 

5. Откройте окно топологии схемы, щёлкнув по имени Filtr:2 в строке заголовков окон на рабочем 
поле. Выделите всю топологию и щёлкните по кнопке Copy на панели инструментов. 

6. Откройте окно электромагнитной структуры, щёлкнув по имени Fil_EMSidht в строке заголов-
ков окон на рабочем поле. Щёлкните по значку Paste на панели инструментов и вставьте скопи-
рованную топологию в корпус так, чтобы расстояние от входного проводника до верхнего края 
корпуса и расстояние от выходного пр о нижнего края корпуса было одинаковым (1.0 

еличину этого несовпадения и соответст-
 

ному проводнику, чтобы выделить его. Щёлкните по значку Edge Port и уста-
новите порт на входном проводнике. Аналогично установите порт на выходном проводнике. 
Сдвиньте референсные плоскости портов на 1.0 мм вглубь корпуса. Выделите всю топологию, 
щёлкните правой кнопкой мышки по любому выделенному проводнику и выберите Shape Prop-
erties. В открывшемся окне в поле Material введите 1/2 oz Cu и нажмите OK. Электромагнитная 
структура будет выглядеть, как показано на рис. 7.64. 

результатам измерения определяем, что длина корпуса может быть 15.8 мм, а ширина 5.85 мм. 
3. Щёлкните по значку Add New EM Structure. В открывшемся окне введите имя структуры 

Fil_EMSight, отметьте AWR EMSight Simulator и нажмите Create. 
4. Щёлкните по значку Substrate Information на панели инструментов. На вкладке Enclosure от-

крывшегося окна введите X_Dim=15.8, Y_Dim=5.85, Grid_X=0.05 и Grid_Y=0.05. На вкладке 
Material Defs для слоя Diel_1 введите Er=10,73, TanD=0.0001. Дважды щёлкните по столбцу 
Color для проводника 1 oz Cu и отметьте красный цвет. На вкладке Dielectric Layers для перво-
го слоя введите толщину 6, для второго слоя введите толщину 0.5 и масштаб отображения Draw 
Scale равным 4. Нажмите OK. 

5. Откройте окно топологии схемы, щёлкнув по имени Filtr:2 в строке заголовков окон на рабочем 
поле. Выделите всю топологию и щёлкните по кнопке Copy на панели инструментов. 

6. Откройте окно электромагнитной структуры, щёлкнув по имени Fil_EMSidht в строке заголов-
ков окон на рабочем поле. Щёлкните по значку Paste на панели инструментов и вставьте скопи-
рованную топологию в корпус так, чтобы расстояние от входного проводника до верхнего края 
корпуса и расстояние от выходного пр о нижнего края корпуса было одинаковым (1.0 

еличину этого несовпадения и соответст-
 

ному проводнику, чтобы выделить его. Щёлкните по значку Edge Port и уста-
новите порт на входном проводнике. Аналогично установите порт на выходном проводнике. 
Сдвиньте референсные плоскости портов на 1.0 мм вглубь корпуса. Выделите всю топологию, 
щёлкните правой кнопкой мышки по любому выделенному проводнику и выберите Shape Prop-
erties. В открывшемся окне в поле Material введите 1/2 oz Cu и нажмите OK. Электромагнитная 
структура будет выглядеть, как показано на рис. 7.64. 

2. Щёлкая по значку Measure на панели инструментов, измерьте длину и ширину топологии. По re на панели инструментов, измерьте длину и ширину топологии. По 
Рис. 7.63

оводника доводника д
мм). Если топология не совпадает с сеткой, измерьте в
венно сдвиньте топологию, используя координатный ввод
мм). Если топология не совпадает с сеткой, измерьте в
венно сдвиньте топологию, используя координатный ввод с клавиатуры, нажав левую кнопку
мышки и затем клавишу Tab. 

7. Щёлкните по вход

 с клавиатуры, нажав левую кнопку
мышки и затем клавишу Tab. 

7. Щёлкните по вход

Рис. 7.64
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8. елайте активным окно графика LdB. Щёлкните правой 

urce Name введите All Sources и нажмите OK. 
9. 

не. 
Выберите в меню Options>Layout Options

tion snap angle введите угол поворота 0.1 deg, чтобы можно было по
жмите OK. Эта опция работает в окне топологии схемы и в окне ред
не электромагнитной структуры редактора EMSight. Поэтому нуж
структуру и назначить для анализа симулятор AXIEM. Или сначала с
логии схемы. Воспользуемся вторым способом. 

Созданная ранее схема Filter нам больше не понадобится. 
проект (щёлкните правой копкой мышки по имени схемы в окне прос
Schematic). Заодно удалите цели оптимизации в группе Optimizer G
Synthesis Wizard. 

Теперь отредактируем топологию. 
1. Создайте пустую схему Schematic 1. 
2. Щёлкните по значку View Layout, чтобы открыт
3. В поле Grid Spacing на панели инструментов в

сетку для черчения (рис. 7.67). 
4. Откройте окно электромагнитной структуры, вы  

их. 
5. Откройте окно топологии схемы и вставьте

следите, чтобы, й мере, верхняя сторо

Откройте окно просмотра проекта, сд
кнопкой мышки по имени измеряемой величины этого графика в окне просмотра проекта и вы-
берите Properties. В поле Data So
Откройте окно свойств графика и установите по оси x шаг, равный 1, по оси Left 1 шаг, равный 
0.5. В опциях проекта добавьте частоты 13.75 и 18.25 ГГц. Щёлкните по значку Analyze на пане-
ли инструментов. Полученные графики показаны на рис. 7.65 и 7.66. Редактировать электромаг-
нитную структуру не требуется. 

Теперь развернём резонаторы так, чтобы входной и выходной проводники были на одном уров-

. В открывшемся окне на вкладке Layout в поле Rota-
ворачивать проводники плавно. На-
актора AXIEM, но не работает в ок-
но скопировать электромагнитную 
копировать топологию в окно топо-

Удалите её, чтобы не загромождать 
мотра проекта и выберите Delete 

oals и Design в группе AWR Filter 

ь пустое окно топологии схемы. 
ведите 0.1, чтобы получить мелкую 

делите все проводники и скопируйте

Рис. 7.65 Рис. 7.66

 в него скопированную топологию. Про-
на входного проводника совпадала с 

сеткой. В противном случае сдвиньте топологию, используя ввод с клавиатуры, так, чтобы такое 
совпадение было. Слой для черчения проводников здесь значения не имеет. Можно оставить по 

 Рис. 7.67 по крайне

умолчанию или назначить любой слой (щёлкнуть правой кнопкой мышки по выделенным про-
водникам и выбрать Shape Properties). 

6. Прежде чем разворачивать проводники, необходимо объединить проводники в каждом резона-
торе, чтобы при повороте не возникло разрывов по центру резонаторов из-за погрешностей вы-
числения углов при повороте. Выделите все проводники резонаторов, кроме подводящих про-
водников и щёлкните по значку Union на панели инструментов. 

7. Чтобы точнее установит выходной проводник фильтра, можно создать временный длинный про-

водник, соприкасающийся с верхней стороной входного проводника, щёлкнув по значку Rectan-
gle на панели инструментов. Топология должна выглядеть, как показано на рис. 7.68. 

Рис. 7.68
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вверх к дополнительному проводнику. 
9. Выделите все проводники фильтра, кроме входного и выходного. Щёлкните правой кнопкой 

мышки по любому выделенному проводнику и выберите Rotate. Установите курсор на нижний 
правый угол входного проводника, нажмите левую кнопку мышки и вращайте проводники так, 

тпустите кнопку. 

точка поворота совпадает с правым нижним углом 
входного проводника (рис. 7.70). В противном случае 
сдвиньте соответственно повёрнутые проводники (они 
все должны быть выделенными). 

11. Увеличьте отображение проводников на выходе фильт-
ра. Верхний угол нижнего проводника в последних свя-
занных линиях может немного не доходить до выходно-
го проводника или располагаться несколько выше. В та-
ком случае дважды щёлкните по нижнему проводнику 

 получилось длина 16.2 мм и ширина – 
1.65 мм. Размеры корпуса возьмём 16.2х5. 

Теперь можно создавать электромагнитную структуру с развёрнутыми проводниками. Чтобы не 
вводить свойства корпуса новой структуры, сделайте копию имеющейся, щёлкнув по ней правой кноп-
кой мышки и выбрав Duplicate EM Structure. Переименуйте созданную копию структуры в 
Fil_EMSight_Rotate. Удалите все проводники из структуры. Щёлкните по значку Substrate Information 
и на вкладке Enclosure введите X_Dim=16.2 и Y_Dim=5.0. 

Откройте окно топологии схемы и скопируйте топологию. Затем откройте окно структуры 
Fil_EMSight_Rotate и вставьте скопированную топологию так, чтобы она располагалась по центру кор-
пуса, и начало входного проводника точно о с левым краем корпуса. Увеличьте отображение 
правого конца структуры и, если край выходног водника не совпадает с краем корпуса, измерьте 

8. Щёлкните мышкой по выходному проводнику, чтобы выделить его, и, нажав левую кнопку 
мышки, переместите это проводник 

чтобы правый верхний угол нижнего проводника в по-
следних связанных линиях
проводника (рис. 7.69), о

 коснулся дополнительного 

10. Увеличьте отображение в точке поворота и убедитесь, 
что 

связанных линий и продлите (или укоротите) этот про-
водник (рис. 7.71). 

12. Щёлкните мышкой по дополнительному проводнику и 
удалите его, нажав клавишу Delete. 

13. Выделите входной проводник и соединённый с ним про-
водник первых связанных линий. Щёлкните по значку 
Union на панели инструментов, чтобы объединить эти 
проводники. 

14. Увеличьте отображение соединения выходного провод-
ника с наклонным проводником фильтра (т.е. область, 
показанную на рис. 7.71). Щёлкните по выходному про-
воднику, чтобы выделить его, и сдвиньте этот проводник 
вправо так, чтобы его вершина совпала с верхней вер-

шиной нижнего проводника последних связанных линий. 
15. Выделите выходной проводник и соединённый с ним проводник последних связанных линий. 

Щёлкните по значку Union на панели инструментов, чтобы объединить эти проводники. Полу-
ченная топология фильтра показана на рис. 7.72. 

Напомним, что все эти операции можно выполнить и в редакторе AXIEM. 
Измерьте длину и ширину полученной топологии. У нас

 совпадал
о про

Рис. 7.69

Рис. 7.70 

Рис. 7.71 

Рис. 7.72 
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rties. В открывшемся окне в поле EM Layer введите 2, в поле 
Material введите 1/2oz Cu и нажмите OK. 

Установите порты на входе и выходе структуры. Установите сдвиг референсных плоскостей на 
1.0 мм. Структура будет выглядеть, как показано на рис. 7.73. 

Удалите временно созданную схему. С ней удалится и 
топология схемы. 

Щёлкните по имени структуры Fil_EMSight_Rotate в 
окне просмотра проекта и выберите Options. В открывшемся 
окне на вкладке EMSight отметьте S и нажмите OK. 

кта и выберите Add Annotation. В открывшемся окне в области Measurement Type отметьте Planar 

сравнению с характеристикой фильтра с прямыми 
резонаторами (красная кривая). Очевидно, аппрокси-

формы проводников прямоугольными ячейка-
ли-

 фильтра с наклонными резонаторами, получен-

полнялся в корпусе такой же ширины и с активной 

вшемся окне в поле Explicit Ground Reference введите 

Connect to lower и нажмите OK. Аналогично отредактируйте порт 2. Созданная структура пока-
зана на рис. 7.76. 

4. Щёлкните правой кнопкой мышки по имени созданной структуры в окне просмотра проекта и 
выберите Add Annotation. В открыв-
шемся окне в области Measurement 
Type отметьте Planar EM, в области 

ображение 
структуры, щёлкнув по значку View EM 

-

rties. В открывшемся окне в поле EM Layer введите 2, в поле 
Material введите 1/2oz Cu и нажмите OK. 

Установите порты на входе и выходе структуры. Установите сдвиг референсных плоскостей на 
1.0 мм. Структура будет выглядеть, как показано на рис. 7.73. 

Удалите временно созданную схему. С ней удалится и 
топология схемы. 

Щёлкните по имени структуры Fil_EMSight_Rotate в 
окне просмотра проекта и выберите Options. В открывшемся 
окне на вкладке EMSight отметьте S и нажмите OK. 

кта и выберите Add Annotation. В открывшемся окне в области Measurement Type отметьте Planar 

ку Analyze на панели инструментов. 

сравнению с характеристикой фильтра с прямыми 
резонаторами (красная кривая). Очевидно, аппрокси-

формы проводников прямоугольными ячейка-
ли-

 фильтра с наклонными резонаторами, получен-

полнялся в корпусе такой же ширины и с активной 

вшемся окне в поле Explicit Ground Reference введите 

Connect to lower и нажмите OK. Аналогично отредактируйте порт 2. Созданная структура пока-
зана на рис. 7.76. 

4. Щёлкните правой кнопкой мышки по имени созданной структуры в окне просмотра проекта и 
выберите Add Annotation. В открыв-
шемся окне в области Measurement 
Type отметьте Planar EM, в области 

ображение 
структуры, щёлкнув по значку View EM 

величину, на которую выходной проводник не достаёт до края корпуса или выходит за край. Дважды 
щёлкните по выходному проводнику, установите курсор мышки так, чтобы он отображался в виде двой-
ной стрелки, нажмите левую кнопку мышки, затем клавишу Tab и в поле dx введите измеренную вели-
чину (если проводник выходит за край корпуса, то dx должно быть отрицательным). Кроме того, убеди-
тесь, что входной и выходной проводники совпадают с сеткой. 

Выделите всю топологию структуры. Щёлкните по любому выделенному проводнику правой 
кнопкой мышки и выберите Shape Prope

чину (если проводник выходит за край корпуса, то dx должно быть отрицательным). Кроме того, убеди-
тесь, что входной и выходной проводники совпадают с сеткой. 

Выделите всю топологию структуры. Щёлкните по любому выделенному проводнику правой 
кнопкой мышки и выберите Shape Prope

Рис. 7.73

Рис. 7.74 Enable AFEnable AF
Щёлкните правой кнопкой мышки по имени структуры Fil_EMSight_Rotate в окне просмотра 

прое
Щёлкните правой кнопкой мышки по имени структуры Fil_EMSight_Rotate в окне просмотра 

прое
EM, в области Measurement отметьте EM_MESH, 
нажмите Apply и OK. 

Щёлкните по значку View EM 3D Layout. 
Встроенная сетка показана на рис. 7.74. 

Откройте окно графика и щёлкните по знач-

EM, в области Measurement отметьте EM_MESH, 
нажмите Apply и OK. 

Щёлкните по значку View EM 3D Layout. 
Встроенная сетка показана на рис. 7.74. 

Откройте окно графика и щёлкните по знач-
ку Analyze на панели инструментов. 

Рассчитанный график показан на рис. 7.75. 
Характеристика фильтра с развёрнутыми резонато-
рами (синяя кривая) сдвинута вниз по частоте по 

Рассчитанный график показан на рис. 7.75. 
Характеристика фильтра с развёрнутыми резонато-
рами (синяя кривая) сдвинута вниз по частоте по 

мация мация 
ми сетки несколько увеличивает электрическую дми сетки несколько увеличивает электрическую д
ну резонаторов. Для сравнения показана характери-
стика
ну резонаторов. Для сравнения показана характери-
стика
ная в IE3D (коричневая кривая). В IE3D анализ вы-ная в IE3D (коричневая кривая). В IE3D анализ вы-

AEC. 
ерь создадим структуру для AXIEM. 

1. Создайте копию структуры Fil_EMSight_Rotate и переименуйте её в Fil_AXIEM_Rotate. 
2. Щёлкните правой кнопкой мышки по имени созданной структуры в окне просмотра проекта и 

выберите Set Simulator. В открывшемся окне отметьте AWR AXIEM и нажмите OK. 
3. Дважды щёлкните по порту 1. В откры

AEC. 
ерь создадим структуру для AXIEM. 

1. Создайте копию структуры Fil_EMSight_Rotate и переименуйте её в Fil_AXIEM_Rotate. 
2. Щёлкните правой кнопкой мышки по имени созданной структуры в окне просмотра проекта и 

выберите Set Simulator. В открывшемся окне отметьте AWR AXIEM и нажмите OK. 
3. Дважды щёлкните по порту 1. В откры

Рис. 7.75 
ТепТеп

Рис. 7.76

Measurement отметьте EM_MESH_F. 
Нажмите Apply и OK. 

5. Откройте трёхмерное от

Measurement отметьте EM_MESH_F. 
Нажмите Apply и OK. 

5. Откройте трёхмерное отРис. 7.77. 
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нтов. Графики пока-

ная в EMSight, несколько сдвинута
падают в полосе пропускания. 

ка, полученная в AX
отсутствием боковых стенок в

7.4. Пример “неудачного” 
AXIEM расширяет возмо

структуры, точный анализ которых  
при установке опций для анализа 
нию не всегда обеспечивают точные резу
вания фильтра-лесенки с полосой проп

Созданная при моделировании в Micro-
wave Office топология фильтра показана на рис. 
7.80. Расстояние от платы до верхней крышки кор-
пуса 4 мм. 

На графике рис. 81 показано сравнение 
, используя EMSight 

нию не всегда обеспечивают точные резу
вания фильтра-лесенки с полосой проп

Созданная при моделировании в Micro-
wave Office топология фильтра показана на рис. 
7.80. Расстояние от платы до верхней крышки кор-
пуса 4 мм. 

На графике рис. 81 показано сравнение 
, используя EMSight 

3D Layout на панели инструментов. Встроенная сетка показана на рис. 7.77. 
6. Откройте окно графика и щёлкните по значку Analyze на панели инструме

заны на рис. 7.78 и 7.79 (оранжевая кривая).  

7. Как видно из графиков, только характеристика фильтра с развёрнутыми резонаторами, получен-
 вниз по частоте. Все остальные характеристики неплохо сов-

Однако на частотах ниже и выше границ полосы пропускания ха-
IEM, отличается от остальных характеристик. Это объясняется 

 AXIEM. 

моделирования. 

Рис. 7.79 Рис. 7.78 

рактеристи

жности моделирования в Microwave Office и позволяет моделировать 
ызывает затруднения. Однако нужно в EMSight в  быть внимательным

в AXIEM и учитывать особенности топологии. Установки по умолча-
льтаты. Для примера кратко рассмотрим результаты моделиро-

ускания 16 – 16,5 ГГц на материале R03003 толщиной 0.254 мм. 

гии. Установки по умолча-
льтаты. Для примера кратко рассмотрим результаты моделиро-

ускания 16 – 16,5 ГГц на материале R03003 толщиной 0.254 мм. 

Рис. 7.80

анализа в Microwave Officeанализа в Microwave Office
(синяя кривая), и в IE3D (красная кривая). В Mi-
crowave Office использовалась сетка с размером 
(синяя кривая), и в IE3D (красная кривая). В Mi-
crowave Office использовалась сетка с размером 
ячеек Grid_X и Grid_Y = 0.05 мм. С меньшей сет-
кой компьютер считать отказался (не хватило па-
мяти и свободного места на диске). Сдвиг характе-
ристики вниз по частоте в результатах EMSight 
обусловлен аппроксимацией проводников ячейка-

п

ячеек Grid_X и Grid_Y = 0.05 мм. С меньшей сет-
кой компьютер считать отказался (не хватило па-
мяти и свободного места на диске). Сдвиг характе-
ристики вниз по частоте в результатах EMSight 
обусловлен аппроксимацией проводников ячейка-

пми рямоугольной сетки, которая увеличивает 
длину резонаторов. По этой же причине ширина 
полосы пропускания может отличаться от реаль-
ной. 

ми рямоугольной сетки, которая увеличивает 
длину резонаторов. По этой же причине ширина 
полосы пропускания может отличаться от реаль-
ной. 

Рис. 7.81 
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ство (Approx Open на вкладке Dielec-

Была сделана попытка имитировать боковые 
стенки корпуса установкой узких перемычек между 
верхней и нижней земляными плоскостями вдоль 
топологии фильтра (рис. 7.83). Полученная характе-
ристика показана на рис. 7.84. 

Затем были установлены узкие перемычки 
между верхней и нижней земляными плоскостями, 
которые имитируют переднюю и заднюю стенки 
рпуса (рис. 7.85). Полученная характеристика по-

Ни одна из характеристик не приблизилась
Причина в том, что для анализа использо

подобной структуры не являются оптимальными. 

Во-первых, о размерах ячеек сетк ализе в AXIEM использовались размеры ячеек 

вать наклонные резонаторы. В AXIEM такая мелкая сетка практи-

время расчета и 
водника 0.6 мм мо
расположено две 
водника и плюс 
сетка достаточна, ты (размер ячеек 
составит почти

Затем для моделирования был назначен AXIEM. Тип портов выбран Connect to lower, нижняя 
плоскость – идеальный проводник. 

Полученные характеристики показаны на 
рис. 7.82. Коричневая кривая, когда верх – свобод-
ное простран
tric Layers окна свойств корпуса). Малиновая кри-
вая, когда верх – идеальный проводник. 

ко
казана рис. 7.86. 

 к результатам, полученным в IE3D. 
вались установки опций по умолчанию, которые для 

Рис. 7.82 

Рис. 7.83 Рис. 7.84 

и. При ан
Рис. 7.86 Рис. 7.85 

Grid_X=0.025 и Grid_Y=0.025. Такие мелкие ячейки оправданы в EMSight, чтобы точнее аппроксимиро-

чески не увеличивает точность анализа, но на много увеличивает 
требуемое количество памяти. При ширине про-
жно взять размер ячеек 0.1 мм. При этом будет 
треугольные ячейки по ширине наклонного про-
ячейки вдоль края проводника (рис. 7.87). Такая 
чтобы получить точные результа

 сотую часть от длины волны). Рис. 7.87 
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кнопкой мышки по 

accuracy = Very high (рис. 7.88). 

одников лучше считать равной нулю. На вк h окна опций нужно 

лосах заграждения. Это объясняется отсутствием боко-
вых стенок. 

Выполнив анализ структуры с боковыми стенками и с верхней крышкой, получаем характери-
стику, показанную на рис. 7.91. Она уже х падает с результатами IE3D. 

Если учесть толщину проводников (снять о
7.89), то получаем характеристику, показанную на р красной линией. Характеристика сдвинута 

Во-вторых, в окне опций электромагнитной структуры (щёлкнуть правой 
имени структуры в окне просмотра проекта и выбрать Options) на вкладке AXIEM нужно установить 
опции Matrix entry accuracy = High+ и Compression 

В IE3D анализ выполнялся без учёта толщины проводников. Поэтому для более точного сравне-
ния результатов тол

Рис. 7.89 Рис. 7.88 

ладке Mesщину пров
снять отметку в Use project defaults и отметить опции Model as zero thickness, чтобы толщина провод-
ников была нулевой, и Use edge meshing, чтобы создать узкие ячейки вдоль края проводника (рис. 7.89). 

Полученные при таких установках характеристики структуры с верхней крышкой и без неё (верх 
– свободное пространство) показаны на рис. 7.90. Кривые хорошо совпадают с результатами анализа в 
IE3D в полосе пропускания, но отличаются в по

Рис. 7.90 Рис. 7.91 

орошо сов

тметку опции Model as zero thickness в окне рис. 
ис. 7.92 

Рис. 7.93Рис. 7.92
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вниз по
трическая длина больше из-за краевых эффектов и с

Если кроме боковых стенок, создать переднюю и за
теристика с учётом толщины проводника будет как н

 
 
 
 

 частоте и полоса пропускания шире. Это и следовало ожидать, т.к. у толстых проводников элек-
вязь между резонаторами сильнее. 

днюю (как на рис. 7.85), то расчётная харак-
а рис. 7.93 (тонкая коричневая линия). 
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8.1. Общие положения. 
Под экстракцией (извлечением) понимается создание электромагнитной структуры из одного 

или нескольких элементов схемы или топологии схемы. Имя созданной электромагнитной структуры 
отображается в окне просмотра проекта в группе EM Structures. Затем эта структура передаётся решаю-
щему устройству для электромагнитного анализа. Результаты анализа извлечённой структуры замещают 
модели элементов схемы, включённых в экстракцию. Т.е. созданная электромагнитная структура как бы 
встраивается в схему в качестве подсхемы вместо элементов, включённых в экстракцию. 

Экстракция не гарантирует получения точных результатов, потому что схема и её топология не 
всегда точно отражают реальную топологию устройства. Но она может повысить точность анализа и уп-
ростить создание электромагнитной структуры по сравнению с её созданием вручную. Однако экстрак-
цию лучше не использовать, если нет уверенности, что топология элементов схемы с хорошей точностью 
отражает реальную топологию устройства. 

При использовании экстракции необходимо соблюдать осторожность. Например, если в тополо-
гии схемы имеется тонкая линия, то можно получить разомкнутую цепь (решающее устройство может 
“не заметить” тонкую линию). Если имеются перекрывающие элементы топологии схемы, можно полу-
чить короткое замыкание. 

Прежде чем экстракцию, необходимо в схему или в гл ределения добавить 
ные определения, 

он буде

кройте 

устройства и процесса экстракции. В окне свойств элемента EXTRACT имеются такие же вкладки, как и 
в окне свойств электромагнитной структуры. Т.е. ряд опций можно установить и в окне свойств элемен-
та, и в окне свойств электромагнитной структуры. Если эти опции имеют различные значения, то пред-
почтение отдаётся опциям элемента EXTRACT, которые отменяют действие опций, установленных в 
окне свойств электромагнитной структуры. Если всё же необходимо использовать значения опций, уста-
новленных в окне свойств электромагнитной структуры, установите в элементе EXTRACT параметр 
Override_Options в No. 

Чтобы определить элемент схемы для экстракции, в окне схемы дважды щёлкните по элементу 
схемы или щёлкните по нему правой кнопкой мышки и выберите Properties, чтобы открыть диалоговое 
окно Element Options. На вкладке Model Options в области EM Extraction Options отметьте Enable и в 
поле Group name введите новое имя группы, в которую будет входить извлекаемая структура, или, ис-
пользуя раскрывающееся меню, выберите любое имя из имён, уже определённых в элементе EXTRACT. 

Вы можете выбрать несколько элементов в схеме и включить экстракцию для всех выбранных 
элементов сразу. Для этого выделите все элементы, дважды щёлкните мышкой по любому элементу и 
отметьте Enable. 

Элементы акции можно выбирать аналогичным о  окне топологии схемы 
). Часто это более удобно, поскольку этот способ позволяет определить элементы, которые 

находят
вспомогательные топологические элементы, не связанные со схемой. Это элементы, начерченные в окне 
топологии вручную (например, реперные знаки или текст). 

Процесс экстракции можно отменить, щёлкнув правой кнопкой мышки по элементу EXTRACT 
и выбрав Toggle Enable. В этом случае каждый элемент схемы, выбранный для экстракции, ведёт себя 
так, как будто экстракции не было. Это даёт возможность видеть влияние экстракции на результаты мо-
делирования. 

Частоты для анализа извлечённой электромагнитной структуры берутся из той схемы, из кото-
рой извлекается структура. Причём изменить эти частоты в опциях извлечённой структуры нельзя, это 
можно сделать только в опциях элемента EXTRACT. Однако делать это не рекомендуется, т.к. возник-
нет дополнительная погрешность анализа на не совпадающих частотах для схемы и для извлечённой 
структуры. Частоты для анализа в опциях схемы могут быть изменены. Однако если это сделано после 
выполнения первого анализа, то частоты для извлечённой структуры автоматически не изменяются. Это 
нужно сделать вручную в опциях элемента EXTRACT до выполнения анализа на новых частотах. 

До выполнения анализа желательно просмотреть извлекаемую электромагнитную структуру, 
чтобы проверит ность создаваемой топологии. Щёлкните пр кой мышки по элементу 

лкнуть правой кнопкой 
мышки по имени схемы в окне просмотра проекта и выбрать Add Extraction. Эта команда создаёт элек-

8. Использование экстракции 

элемент многослойной подложки STACKUP. Если этот элемент поместить в глобаль
 начинать обальные оп

т доступен для всех электромагнитных структур, создаваемых в проекте. Этот элемент использу-
ется для определения слоёв диэлектрика и проводников. Если в проекте должно быть несколько элемен-
тов с разным количеством слоёв, то нужно добавить несколько элементов STACKUP. 

Кроме того, в схему должен быть добавлен элемент EXTRACT. В окне просмотра проекта рас-
группу Simulation Control и переместите в окно схемы этот элемент. Элемент EXTRACT опре-

деляет решающее устройство (симулятор), которое должно использоваться для анализа извлечённой 
электромагнитной структуры, имя для извлекаемой структуры и ряд опций для выбранного решающего 

(Layout View
 для экстр бразом и в

ся близко друг к другу. При использовании топологии схемы в экстракцию можно включить 

EXTRACT в окне схемы и выберите Add Extraction. Альтернативно можно щё
ь правиль авой кноп
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тромагн

. 
1. 

3. Откройте окно просмотра эле-
ментов. Раскройте группу Micro-
strip и из подгруппы Lines по-
местите в окно схемы элемент 
короткозамкнутого отрезка линии 
MLSC. Добавьте порт на входе 
схемы (рис. 8.1). 

4. Дважды щёлкните по элементу 
MLSC и введите W=0.5 mm и 
L=5 mm. 

5. Добавьте в схему элемент под-
ложки MSUB. Дважды щёлкните 
по этому элементу и введите 
Er=9.8, H=0.5 mm, T=0.005 mm, 
Tand=0.0001 и ErNom=9.8. 

оты для анализа от 2 до 18 ГГц с шагом 1 

 нему комплексную переменную S11. 
График показан на рис. 8.2. 

щёлкните по этому элементу, чтобы открыть 
же, как и у элемента MSUB. 

UP в области Dielectric Definitions до-
=9.8 и TanD=0.0001 (рис. 8.3). В области 

Conductor Definitions добавь-
те материал Copper (рис. 8.4) 
и установите для него крас-
ный цвет. 

2. На вкладке Dielectric Layers 
для слоя 1 (Air) введите тол-
щину (Thickness) 6. Добавьте 
слой 2, для которого введите 
толщину 0.5 и тип диэлектри-
ка (Material De…) – Diel1 
(рис. 8.5). 

3. На вкладке Materials до-
бавьте материал с именем 
Copper и определите для не-
го тип материала Copper в 
столбце Material De… Па-
раметры на остальных 
вкладках оставьте по умол-
чанию. 
В окне просмотра элементов 

щёлкните по Simulation Control и добавьте к схеме элемент EXTRACT. 
Дважды щёлкните по элементу EXTRACT. 

1. На вкладке окна Parameters свойств для EM_Doc введите “MLin_EM”. Это будет имя извле-
чённой электромагнитной структуры, которое будет отображаться в окне просмотра проекта. 

2. Для Simulator введите EMSight. По умолчанию здесь стоит {Choose} (Выбирать). Щёлкните по 
этому значению мышкой, затем щёлкните по появившейся кнопке в правом конце поля и выбе-
рите EMSight. 

3. Введите размеры ячеек геометрической сетки X_Cell_Size=0.1 и Y_Cell_Size=0.1. 
4. Введите смещение референсной плоскости для портов 1 mm. 
5. Для STACKUP введите “SUB2” аналогично вводу для Simulator. 

итную структуру с именем, установленным в элементе EXTRACT, из выбранных в схеме эле-
ментов для экстракции. Если в схеме нет выбранных для экстракции элементов, ничего не создаётся. 

Рассмотрим простой пример экстракции короткозамкнутого отрезка микрополосковой линии. 
8.1.1. Моделирование короткозамкнутого отрезка микрополосковой линии

Создайте новый проект с именем Short-Line. 
2. Создайте схему с именем MLin. 

Рис. 8.1 Рис. 8.2

6. Дважды щёлкните по Project Options и введите част
ГГц. 

7. Создайте график Smith Char с именем S11 и добавьте к
8. Щёлкните по значку Analyze на панели инструментов. 

Теперь подготовим схему для экстракции. 
Добавьте к схеме элемент подложки STACKUP и дважды 
окно свойств. Параметры этого элемента должны быть такими 

1. На вкладке Material Defs окна свойств элемента STACK
бавьте слой диэлектрика Diel1, для которого введите Er

Рис. 8.4Рис. 8.3 

Рис. 8.5 
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6. Остальные параметры на этой вкладке и на всех других вкладках оставьте по умолчанию. На-

 

 

жмите OK. 

Полученная схема показана на рис. 8.6. 
Включите элемент MLSC в экстракцию. Для этого дважды щёлкните по элементу MLSC и на

вкладке

Рис. 8.6 Рис. 8.7

 Model Options в области EM Extraction Options отметьте Enable. Выполните анализ схемы. 
Характеристика показана на рис. 8.7. Вместо короткозамкнутой линии для извлечённой структуры полу-
чили характеристику разомкнутой линии. 

В окне просмотра элементов в группе EM Structures появилась извлечённая электромагнитная 
структура MLin_EM. Откройте окно этой структуры. Вместо короткозамкнутого отрезка в электромаг-
нитной структуре мы получили разомкнутый отрезок (рис. 8.8). Процедура экстракции не знает, как 
осуществляется заземление в этой схеме. 

Рис. 8.8

Обратите внимание, что общая длина проводника равна 6 мм (5 мм – заданная длина элемента 
MLSC и 1 мм – заданное смещение референсной плоскости). Также обратите внимание, что длина и ши-
рина корпуса выбраны автоматически. 

Заменим в схеме элемент MLSC элементом MLIN 

Рис. 8.9 
Рис. 8.10 

с такими же значениями W и L и с землёй на правом кон-
це (рис. 8.9). 

Дважды щёлкните по элементу MLIN и включите 
его в экстракцию, как описано выше. Поскольку мы не
изменили имя извлекаемой структуры в элементе 
EXTRACT, извлечённая ранее структура будет заменена 
новой. 

В этом случае элемент земли не имеет поставлен-
ного ему в соответствие топологического элемента. Про-
цесс экстракции видит, что к правому концу элемента 
MLIN подключен другой элемент с неизвестной тополо-
гией и просто устанавливает второй порт для подключе-
ния элемента. В результате получаем отрезок линии, на-
груженный на согласованное сопротивление на входе и 
выходе (рис. 8.10). График извлечённой структуры сосре-
доточен вблизи единицы на диаграмме Смита (рис. 8.11). Рис. 8.11



Добавим в схему элемент перемычки VIA перед 
элементом земли. 
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 на рис. 
ды щёлкните по этому элементу и включите его в 
ю на вкладке Model Options. На вкладке Parame-

ters введите D
Щёлкните

тов. Анализ выполняться
туса, что неверный

Извлечённая
трёхмерное отображ

Топология авильно, но до-
бавлен порт 2,

Имеется 
 – использовать мо

 

схему VIA, как 

щем
С
электромагнитной структуры и 

щёлкнув по значку Substrate Informa-

-

метрам, установленным в элементах 

Из приведённого примера хо-
но, что прежде чем выполнять 

анализ, нужно просмотреть извлекае-
мую структуру, чтобы оценить её соот-
ветствие реальной топологии. Рассмот-
рим следующий простой пример. 

В окне просмотра элементов щёлкните по Intercon-
nects и добавьте элемент VIA в схему, как указано
8.12. Дваж
экстракци

=0.5, H=0.5 и T=0.005. 
 по значку Analyze на панели инструмен-

 не будет с сообщением в окне ста-
 порт 2. 

 структура показана на рис. 8.13, а её 
ение на рис. 8.14. 

 структуры извлечена пр
 которого не должно быть. 

два способа, чтобы правильно решить по-
дель VIA1P. ставленную задачу. Самый простой способ

 8Рис. .12

Откройте окно просмотра элементов, в схеме удалите элемент VIA и землю. Вместо удалённых 
элементов вставьте элемент VIA1P (рис. 8.15). Дважды щёлкните по элементу VIA1P и введите такие же
параметры, как и для элемента VIA. 

Выполните анализ, полученные графики показаны на рис. 8.16. 
Другой 

способ заключает-
ся в том, чтобы 
создать отдельную 
схему заземлённой 
перемычки и вста-
вить её в нашу 
схему в качестве 
подсхемы. 

Создайте 

показано на рис. 
8.17 и вставьте её в 
схему MLin в ка-
честве подсхемы 
(рис. 8.18). Дваж-
ды щёлкните по 

 будет таким же, как и в предыду-
 случае. 

элементу подсхемы SUBCKT и включите её в экстракцию. Результат

делав активным окно извле-
чённой 

tion на панели инструментов, чтобы 
открыть окно свойств корпуса, вы мо
жете убедиться, что все параметры соз-
данного корпуса соответствуют пара-

STACKUP и EXTRACT. 

рошо вид

Рис. 8.17. 

Рис. 8.18 

Рис. 8.13 
Рис. 8.14 

Рис. 8.16 Рис. 8.15 
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у, показанную на рис. 8.19. 
Для элементов STACKUP и 

EXTRACT введите такие же парамет-
ры, как в предыдущем примере. 

Замечание. При указанных 
установках в элементе EXTRACT 
размеры корпуса устанавливаются 
автоматически. При желании эти раз-
меры вы можете задать вручную. Для 
этого в окне свойств элемента 
EXTRACT на вкладке Parameters 
щёлкните по кнопке Show Secondary и 
введите нужные значения 
X_Dimension и Y_Dimension. 

Выделите все элементы схемы 
и назначьте их для экстракции. Щёлк-
ните п пкой мышки по имени 
схемы в окне просмотра проекта и вы-

имя извлекаемой структуры. Дважды щёлк-

что созданная структура не соответствует 
действительности. 

Чтобы исправить её, откройте окно 
схемы и щёлкните по значку View Layout. 
Топология будет иметь такой же вид, как на 
рис. 8.20. 

Выделите все элементы топологии 
и щёлкните по значку Snap Together на 
панели инструментов. Элементы будут со-
единены правильно. 

Откройте окно схемы, щёлкните 
правой кнопкой по элементу EXTRACT и 
выберите Add Extraction. Извлечённая то-
пология будет иметь вид, показанный на 
рис. 8.21. Эта структура уже пригодна для 
выполнения анализа. 

В этом примере использовался симулятор EMSight. Если предполагается использовать AXIEM, 
необходимо указать, какого типа порты должны быть установлены. 

Сделайте коп . Дважды щёлкните по элементу EXTRACT и замените значение Simula-

, чтобы выделить его. 
Выберите в меню Draw>Extraction Port и уст
Дважды щёлкните по установленному

ence введите Connect to lower, в поле Ref. Pla нажмите OK. Аналогично установи-
те порт на выходе структуры. 

Щёлкните правой кнопкой по элеме
структура показана на рис. 8.22, а её трёхмерн а

8.1.2. Моделирование разомкнутого шлейфа. 
Создайте схем

Рис. 8.19 равой кно

берите Add Extraction. Или щёлкните по элементу EXTRACT правой кнопкой мышки и выберите Add 
Extraction. 

В окне просмотра проекта появится 

ните по этому имени, чтобы открыть окно 
электромагнитной структуры. Она может 
иметь вид, показанный на рис. 8.20. Ясно, 

Рис. 8.20 

Рис. 8.21

ию схемы
Sight на значение Simulator= AXIEM. 
Щёлкните по значку View Layout на панели инструментов. 
Щёлкните по входному проводнику

ановите порт на входе структуры. 
 порту. В открывшемся окне в поле Explicit Ground Refer-
ne Distance введите 1, 

нту EXTRACT и выберите Add Extraction. Извлечённая 
ое отображение н  рис. 8.23. 

tor=EM

Рис. 8.22 Рис. 8.23 
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Если в топологии предполагается выполнит
пологии схемы до выполнения экстракции. 

Рассмотрим следующий простой пример. 
8.1.3. Моделирование разветвителя

Создайте схему рис. 8.24. 

ить в экстракцию 

Щёлкните по знач-

н

 

Together на панели инстру-
ментов. Топология будет 
иметь вид, показанный на 
рис. 8.25. 

Дважды щёлкните 
по верхнему топологиче-
скому элементу MTRACE2. 
На элементе появятся ром-
бики для выполнения трас-
сиро

ы щёлкните 

8.26. По окончании трас-
сировки дважды
ните 
Анало
трасси
элеме
Воспо
дой Snap Together
бы с
водни
пология
рис. 8.

менты
для 
тим, 

ты можно бы  не в топологии, а в схеме. 
В ок тра проекта щёлкните правой кнопкой  по имени схем

 
для нескольких различных элементов или групп элементов схемы
ции нескольких различных элементов в различные электромагни
элементы на физической плате должны быть разнесены достаточ
связи. 

Для выполнения нескольких экстракций из одной схемы, 
ментов EXSTRACT, сколько предполагается выполнить экстра
быть определено индивидуальное имя извлекаемой структуры (E
(Name) в соответствующем элементе EXSTRACT. 

Например, чтобы извлечь структуры входного и выходн
нужно добавить в эту схему три элемента EXSTRACT.  

В первом из этих элементов должно быть, напри
Name=”EM_Extract1”. Во втором – EM_Doc=”EM_Extract_Doc
– EM_Doc=”EM_Extract_Doc3” и Name=”EM_Extract3”. Щёл

опкой мышки и выбирая Add Extraction, мы получим
линий (элементов MLIN). Вид схемы и извлечённые электромагни

ь трассировку проводников, это нужно сделать в то-

. 

Допустим, нужно 
включ
элемент MTEE$ и два эле-
мента MTRACE2. 

ку View Layout на панели 
инструме тов, чтобы от-
крыть топологию схемы. 
Выделите всю топологию и
щёлкните по значку Snap 

вки. 
Дважд

по нижнему ромбику и, 
двигая мышку и щёлкая 

левой кнопкой в местах изгиба проводника, выполните трассировку этого элемента, как показано на рис. 

 щёлк-
кнопкой мышки. 
гично выполните 
ровку нижнего 
нта MTRACE2. 
льзуйтесь коман-

, что-
оединить все про-
ки. Получится то-

, показанная на 
26. 
Выделите эле-

, предназначенные 
экстракции. Заме-
что эти же элемен-

ы и выберите Add 
Extraction. Извлечённая структура показана на рис. 8.27. 

Из одной и той  же схемы можно выполнить несколько экстракций электромагнитных структур
. Необх

Рис. 8.24 

Рис. 8.26 Рис. 8.25 Рис. 8.27

ло выделить
не просмо  мышки

одимым условием для экстрак-
тные структуры является то, что все эти 
но далеко, чтобы между ними не было 

в этой схеме должно быть столько эле-
кций. Для каждой экстракции должно 
M_Doc) и индивидуальное имя группы 

ых элементов MLIN в схеме рис. 8.24, 

мер. EM_Doc=”EM_Extract_Doc1” и 
2” и Name=”EM_Extract2”. В третьем 
кая по каждому элементу EXSTRACT 
 извлечённые структуры трёх отрезков 
тные структуры показаны на рис. 8.28. 

правой кн



Рис. 8.28
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8.2. Настройка, оптимизация и статистический

тистический анализ извлечённых электромагнитных структу
тур тесно связана с элементами схемы, то при изменении п
изменяются и параметры извлекаемой электромагнитной ст
настройку только параметры элементов схемы, которые мо
Например, толщину диэлектрика или диэлектрическую прон
8.2.1. Моделиров ступенчатого делителя
Требуется спроектировать 3-х ступенчатый делитель мощн
R04003C толщиной 0.305 мм. Зазор между линиями выходны
Создайте новый проект с именем Div4-12. 
Вначале создайте электромагнитную структуру входного раз

1. Щёлкните мышкой по значку Add New EM Structure
2. Создайте электромагнитную структуру с именем Co

Simulator. 
3. Щёлкните по значку Substrate Information, чтобы 

 1 введите толщину 4 и материал 
. Для слоя 2 введите толщину 

1. Нажмите 

Теперь создадим электрическую схему делителя. 
1. В окне просмотра проекта дважды щёлкните по Global Definitions, чтобы открыть окно глобаль-

ных переменных. 
2. В окне просмотра элементов раскройте группу Substrates и перетащите элемент STACKUP в 

окно глобальных определений. 
3. Дважды щёлкните по элементу STACKUP, чтобы открыть окно его свойств. 
4. На вкладке Material Defs в области Dielectric Definitions добавьте слой диэлектрика Diel_1 с па-

рам =3.38 и TanD=0.0027. В области Conductor Definitions добавьте  Copper 
с параметром Sigma=58800000. 

 анализ. 
При использовании экстракции имеется возможность выполнять настройку, оптимизацию и ста-

р. Поскольку топология извлечённых струк-
араметров элементов схемы соответственно 
руктуры. В этой версии можно включать в 
гут быть включены в процесс экстракции. 
ицаемость включать в настройку нельзя. 
 мощности. ание 3-х 
ости в диапазоне 4 – 12 ГГц на материале 
х плеч делителя должен быть 0.2 мм. 

ветвителя. 
 на панели инструментов. 

upler и выберете симулятор AWR EMSight 

открыть окно свойств создаваемой структу-
ры. 

4. На вкладке Enclosure введите 
X_Dim = 2.5, Y_Dim = 1.8, Grid_X = 
0.05 и Grid_Y = 0.05. 

5. На вкладке Material Defs. для ди-
электрического слоя Diel_1 введите 
Er = 3.38, TanD = 0.0027. 

6. На вкладке Dielectric Layers для 
слоя
Air
0.305 и материал Diel_
OK. 

7. Щёлкните по значку Polygon на па-
нели инструментов и создайте элек-
тромагнитную структуру, показан-

ную на рис. 8.29. 

Рис. 8.29 

етрами Er  материал
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ной 0.305 и материалом Diel_1. 
ials добавьте материал Copper с параметрами 

и Material De…=Copper. 
ите OK. Теперь окно глобальных определений можно закрыть. 

 схему с именем Divider. 
9. В окне просмотра элементов раскройте группу s п

окно схемы подсхему Coupler. Дважды щёлкн
в окне свойств откройте вкладку Symdol. В сп ите и от-
метьте символ SPLIT2@system.syf и нажмите

Coupler будет вы
8.30. 

10. В окне просмотра т
Microstrip и зате
Перетащите элем
его рядом с элеме

11. Раскройте группу
окно схемы элеме
развернув на 90 г дом с элементом 
MCLIN. 

12. Раскройте группу
мент MTEEX$ в мы и по
его плечом 3 к вер э е
Аналогично к ни
подключите второ

13. Соедините элементы, как

к
 ск

ну
н

15. по

16. 
создайте схему, как показано на рис. 8.33, и установите порты. 

 можно определить, что четверть длины волны на 

дующие переменные: L1=5.8, L2=5.8, L3=5.8, 

 OK. Теперь окно глобальных определений можно закрыть. 
 схему с именем Divider. 

9. В окне просмотра элементов раскройте группу s п
окно схемы подсхему Coupler. Дважды щёлкн
в окне свойств откройте вкладку Symdol. В сп ите и от-
метьте символ SPLIT2@system.syf и нажмите

Coupler будет вы
8.30. 

10. В окне просмотра т
Microstrip и зате
Перетащите элем
его рядом с элеме

11. Раскройте группу
окно схемы элеме
развернув на 90 г дом с элементом 
MCLIN. 

12. Раскройте группу
мент MTEEX$ в мы и по
его плечом 3 к вер э е
Аналогично к ни
подключите второ

13. Соедините элементы, как

к
 ск

ну
н

15. по

16. 
создайте схему, как показано на рис. 8.33, и установите порты. 

 можно определить, что четверть длины волны на 

дующие переменные: L1=5.8, L2=5.8, L3=5.8, 

На вкладке Dielectric Layers для слоя 1 с материалом Air введите толщину слоя 4. Добавьте 
слой 2 с толщи

5. 

6. На вкладке Mater
Thickness=0.018 

7. Нажм
8. Создайте8. Создайте

Рис. 8.30 

 Subcircuit  и еретащите в 
ите по элементу подсхемы и 
иске символов найд

 OK. 

 Subcircuit  и еретащите в 
ите по элементу подсхемы и 
иске символов найд

 OK. Элемент подсхемы 
глядеть, как показано на рис. 

 элемен ов раскройте группу 
м подгруппу Coupled Lines. 
ент MCLIN и расположите 
нтом подсхемы. 
 Components, перетащите в 
нт TFR и расположите его, 
радусов, ря

Элемент подсхемы 
глядеть, как показано на рис. 

 элемен ов раскройте группу 
м подгруппу Coupled Lines. 
ент MCLIN и расположите 
нтом подсхемы. 
 Components, перетащите в 
нт TFR и расположите его, 
радусов, ря

 Junctions, перетащите эле-
 окно схе дключите 
хнему концу лем нта TFR. 
жнему концу элемента TFR 
й элемент MTEEX$. 

 Junctions, перетащите эле-
 окно схе дключите 
хнему концу лем нта TFR. 
жнему концу элемента TFR 
й элемент MTEEX$. Рис. 8.31 

 показано на рис. 
8.31. 

14. Выделите все элементы 
схемы, кроме элемента 
подсхемы ка  показано 
на рис. 8.31, и опируй-
те их, щёлк в по значку 
Copy на па ели инстру-
ментов. 
Щёлкните  значку 
Paste на панели инстру-
ментов и подключите 
скопированную часть 
схемы к уже имеющейся, 
как показано на рис. 8.31. 
Действуя аналогично, 

 показано на рис. 
8.31. 

14. Выделите все элементы 
схемы, кроме элемента 
подсхемы ка  показано 
на рис. 8.31, и опируй-
те их, щёлк в по значку 
Copy на па ели инстру-
ментов. 
Щёлкните  значку 
Paste на панели инстру-
ментов и подключите 
скопированную часть 
схемы к уже имеющейся, 
как показано на рис. 8.31. 
Действуя аналогично, 

Рис. 8.31 

17. Добавьте к схеме элемент подложки MSUB. Дважды щёлкните по этому элементу и введите па-
раметры Er=3.38, H=0.305, T=0.018, Rho=0.7118, TanD=0.0027 и ErNom=3.38, нажмите OK. 

18. Добавьте к схеме переменные. В Tools>TXLine

17. Добавьте к схеме элемент подложки MSUB. Дважды щёлкните по этому элементу и введите па-
раметры Er=3.38, H=0.305, T=0.018, Rho=0.7118, TanD=0.0027 и ErNom=3.38, нажмите OK. 

18. Добавьте к схеме переменные. В Tools>TXLine

Рис.8.33

8 ГГц примерно 5.8 мм, а ширина проводника примерно 0.6 мм. Поэтому, щёлкая по значку 
Equation на панели инструментов, введите сле
8 ГГц примерно 5.8 мм, а ширина проводника примерно 0.6 мм. Поэтому, щёлкая по значку 
Equation на панели инструментов, введите сле
W1=0.3, W2=0.4, W2=0.5, RS1=100, RS2=200 и RS3=400. 

19. Дважды щёлкните по первому элементу MCLIN и введите параметры W=W1, S=0.2 и L=L1. 
Аналогично для второго элемента MCLIN введите параметры W=W2, S=0.2 и L=L2. Для 
третьего элемента MCLIN введите параметры W=W3, S=0.2 и L=L3. Для четвёртого элемента 
MCLIN введите параметры W=0.6, S=0.2 и L=2. Для первого элемента TFR введите параметры 

W1=0.3, W2=0.4, W2=0.5, RS1=100, RS2=200 и RS3=400. 
19. Дважды щёлкните по первому элементу MCLIN и введите параметры W=W1, S=0.2 и L=L1. 

Аналогично для второго элемента MCLIN введите параметры W=W2, S=0.2 и L=L2. Для 
третьего элемента MCLIN введите параметры W=W3, S=0.2 и L=L3. Для четвёртого элемента 
MCLIN введите параметры W=0.6, S=0.2 и L=2. Для первого элемента TFR введите параметры 
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W=0.2, L=0.2 и RS=RS1. Для второго элемента TFR введите параметры W=0.2, L=0.2 и 
RS=RS2. Для третьего элемента TFR введите параметры W=0.2, L=0.2 и RS=RS3. 

20. Щёлкните по значку Tune Tool и назначьте для настройки все введённые переменные. Должна 
получиться схема, показанная на рис. 8.34. 

е Frequencies введите частоты от 3 до 13 ГГц с 
шагом 1 ГГц. 

ямоугольный график 

ели 

ли ин-
лните настройку схемы. На-

и значениях пе-

до
ных ть сетку с 

ния
мента
но  не связаны, потребуется три 

2. В окне просмотра элементов щёлкните 
по группе Simulation Control и перета-

3. Дважды щёлкните по элементу 

этого элемента. 
s введите парамет-

tor=EMSight, X_Cell_Size=0.05, 
Y_Cell_Size=0.05, STACKUP=”SUB1”, 

Рис. 8.34 

Выполним анализ и настройку схемы. 
Дважды щёлкните по Project Options и на вкладк

Щёлкните по значку Add New Graph на панели инструментов и создайте пр
с именем LdB. 

Щёлкните по значку Add New Measurement на панели инструментов. В области Measurement 
Type отметьте Port Parameters, в области Measurement отметьте S, в поле Data Source Name введите 
Divider, в поле To Port Index введите 2, в поле From Port Index введите 1, отметьте Mag и dB и нажми-
те Apply. В поле To Port Index введите 3 и нажмите Apply. В поле From Port Index введите 2, нажмите 

Apply и OK. 
о значку Analyze на панЩёлкните п

инструментов. Полученный график показан на 
рис. 8.35. 

Щёлкните по значку Tune на пане
струментов и выпо
пример, полученный график пр
ременных, указанных на рис. 8.36, показан на 
рис. 8.37. 

Здесь размеры округлены с точностью 
 0.05, чтобы для извлекаемых электромагнит-

 структур можно было использова

Рис. 8.36 

Рис. 8.35 
размером ячеек 0.05 мм. 

Теперь подготовим схему для выполне-
 экстракции. В неё включим первые три эле-

 MCLIN. Т.к. эти элементы непосредствен-
 друг с другом

элемента EXTRACT с разными параметрами. 
1. Сделайте активным окно схемы и от-

кройте окно просмотра элементов. 

щите в схему элемент EXTRACT. 

EXTRACT, чтобы открыть окно свойств 

4. На вкладке Parameter
ры EM_DOC=”CLIN1”, 
NAME=”EM_EXTRACT1”, Simula-

Рис. 8.37 
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данный элеме
5. Вставьте

EM_DOC=”
6. Вставьте IN3”, 

NAME=
7. Дважды

Extraction Op
8. Аналогично

XTRACT2

и должна выглядеть, 
Чтобы просмо

щёлкните правой 
EXTRACT и выберите
те и с двумя другими
просмотра проек
три электромагнитные
CLIN2 и CLIN3. 

Откройте окн
Analyze на панели инстр
показан на рис. 8.39. 

 2 и 3 де-
м LdBm и 

добавьте к нему измеряемые величины S21 и S31 в dB 
для схемы Divider. 

Чтобы просмотреть согласование по входу и 
выходам, создайте ещё один график с именем KstU. До-
бавьте к нему измеряемые величины VSWR(1), 
VSWR(2) и VSWR(3), выбрав тип измеряемой величины 
Linear и измеряемую величину VSWR. В поле Port In-
dex введите 1, в поле Sweep Freq (FDOC) введите Use 
for x-axis, не забудьте снять отметку в Mag и dB, на-
жмите Apply. Затем в поле Port Index введите 2 и на-

ите Apply. В поле Port Index введите 3, нажмите Ap-

Extension=0.5. Остальные параметры оставьте по умолчанию и нажмите OK. Скопируйте соз-
нт в буфер обмена. 

 скопированный элемент и измените имена извлекаемой структуры и группы на 
CLIN2”, NAME=”EM_EXTRACT2”. 

 ещё один скопированный элемент и измените имена на EM_DOC=”CL
”EM_EXTRACT3”. 
 щёлкните по первому элементу EXTRACT. На вкладке Model Options в области EM 

tions отметьте Enable и в поле Group name введите EM_Extract1, нажмите OK. 
 сделайте активными второй и третий элементы EXTRACT и введите имена 

 и EM_EXTRACT3 соответственно. EM_E

Теперь схема готова к выполнению экстракции 
как показано на рис. 8.38. 
треть извлекаемые структуры, 

кнопкой по первому элементу 
 Add Extraction. Это же сделай-

тами экстра

Рис. 8.38 

 элемен кции. В окне 
та в группе EM Structures появятся 

 структуры с именами CLIN1, 

о схемы и щёлкните по значку 
ументов. Полученный график 

отериЧтобы лучше видеть п  в плечах
лителя, создайте ещё один график с имене

Рис. 8.39 

жм
ply и OK. Полученный график показан на рис. 8.40. 

Щёлкнув по значку Tune на панели инструмен-
тов, можно выполнять настройку схемы. Поскольку при 
изменении значения любой переменной выполняется 
новый электромагнитный анализ, занимающий довольно 
продолжительное время, процедура ручной настройки 
для такой схемы не очень удобна. 

Назначим переменные для оптимизации. 
Откройте окно схемы. Щёлкните по переменной 

L1=5.2 правой кнопкой мышки и выберите Properties. В 
открывшемся окне Edit Equation отметьте Optimize и 

Рис. 8.40
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овите преде-

менения 0.35 и 0.25. Для переменной W2 установите 
пределы изменения 0.45 и 0.35. Для переменной W3 установите пределы изменения 0.55 и 0.45. 

Для переменной RS1 установите пределы изменения 120 и 80. Для переменной RS2 установите 
пределы изменения 230 и 170. Для переменной RS3 установите пределы изменения 450 и 350. 

Теперь нужно добавить цели оптимизации. 
Щёлкните правой кнопкой мышки по Optimizer Goals и выберите Add Optimizer Goal. Введите 

цель для потерь между плечами 1 и 2. В списке измеряемых величин отметьте Divider:DB(|S2,1|) в об-
ласти Goal Type отметьте Meas=Goal. В поле Start введите 4, сняв отметку в Min. В поле Stop введите 
12, сняв отметку в Max. В поле Goal start введите -3.2 (с учётом некоторых потерь в проводниках). На-
жмите OK. 

Снова щёлкните правой кнопкой мышки по Optimizer Goals и выберите Add Optimizer Goal. 
Добавьте цель с такими же параметрами для измеряемой величины Divider:DB(|S3,1|). 

Добавьте цель для измеряемой величины Divider:DB(|S3,2|), т.е. для развязки выходных плеч. В 
области Goal Type отметьте Meas<Goal. В поле Goal start введите -17. Диапазон в этой и всех следую-
щих целях вводите всё тот же от 4 до 12 ГГц. 

вьте цель для согласования по входу, т.е. 
для измеряемой величины Divider:VSWR(1). В облас-

введите 1.1. 

по выходам Divider:VSWR(2) и Divider:VSWR(3). 

нажмите

по
Пр
ни

по
ре

 

ённых структур и измеря
что размеры тополо ились в соответствии с и
тим, что измерять нужно расстояние между референсн  
порта до референсной плоскости при экстракции добавляется
мента этой линии в схеме. 

Выполненный вариант экстракции не является е
Включим в экстракцию все элементы схемы раз
Удалите из схемы два последних элемента EXT  

CLIN2 и CLIN3. Дважды щёлкните по оставшему
ните EM_Dok=”CLIN1” на Name=”Div” и ”EM_E

Нажмите клавишу Shift и, щёлкая левой кнопкой
последнего элемента MCLIN), выделите их. Дважды 
щёлкните правой кнопкой мышки по любому выделен
шемся окне на вкладке Model Options отметьте Ena
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менения 0.35 и 0.25. Для переменной W2 установите 
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цель для потерь между плечами 1 и 2. В списке измеряемых величин отметьте Divider:DB(|S2,1|) в об-
ласти Goal Type отметьте Meas=Goal. В поле Start введите 4, сняв отметку в Min. В поле Stop введите 
12, сняв отметку в Max. В поле Goal start введите -3.2 (с учётом некоторых потерь в проводниках). На-
жмите OK. 

Снова щёлкните правой кнопкой мышки по Optimizer Goals и выберите Add Optimizer Goal. 
Добавьте цель с такими же параметрами для измеряемой величины Divider:DB(|S3,1|). 

Добавьте цель для измеряемой величины Divider:DB(|S3,2|), т.е. для развязки выходных плеч. В 
области Goal Type отметьте Meas<Goal. В поле Goal start введите -17. Диапазон в этой и всех следую-
щих целях вводите всё тот же от 4 до 12 ГГц. 

вьте цель для согласования по входу, т.е. 
для измеряемой величины Divider:VSWR(1). В облас-

введите 1.1. 
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ни
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ре

 

Открывая о ённых структур и измеря
что размеры тополо ились в соответствии с и
тим, что измерять нужно расстояние между референсн  
порта до референсной плоскости при экстракции добавляется
мента этой линии в схеме. 

Выполненный вариант экстракции не является е
Включим в экстракцию все элементы схемы раз
Удалите из схемы два последних элемента EXT  

CLIN2 и CLIN3. Дважды щёлкните по оставшему
ните EM_Dok=”CLIN1” на Name=”Div” и ”EM_E

Нажмите клавишу Shift и, щёлкая левой кнопкой
последнего элемента MCLIN), выделите их. Дважды 
щёлкните правой кнопкой мышки по любому выделен
шемся окне на вкладке Model Options отметьте Ena

 

Constrain, в поле Upper bound введите верхний предел изменения переменной 6, в поле Lower bound 
введите нижний предел изменения переменной 4.5, нажмите OK. Для переменной L2 устан

d введите верхний предел изменения переменной 6, в поле Lower bound 
введите нижний предел изменения переменной 4.5, нажмите OK. Для переменной L2 устан
лы изменения 5.5 и 4.5. Для переменной L3 установите пределы изменения 5 и 4. 

Для переменной W1 установите пределы из
лы изменения 5.5 и 4.5. Для переменной L3 установите пределы изменения 5 и 4. 

Для переменной W1 установите пределы из

ДобаДоба

ти Goal Type отметьте Meas<Goal. В поле Goal start ти Goal Type отметьте Meas<Goal. В поле Goal start 

Аналогично добавьте цели для согласования Аналогично добавьте цели для согласования 

Группа Optimizer Goals в окне просмотра 

проекта будет выглядеть, как показано на рис. 8.41. 
Откройте окно графика KstU и выберите в 

меню Simulate>Optimize. В открывшемся окне 
 S

Группа Optimizer Goals в окне просмотра 

проекта будет выглядеть, как показано на рис. 8.41. 
Откройте окно графика KstU и выберите в 

меню Simulate>Optimize. В открывшемся окне 
 Start. Начнётся процесс оптимизации. 
График KstU (рис. 8.42) и другие графики 

сле выполнения оптимизации изменились мало. 
оизошла

tart. Начнётся процесс оптимизации. 
График KstU (рис. 8.42) и другие графики 

сле выполнения оптимизации изменились мало. 
оизошла даже небольшая разбалансировка деле-
я. 

Откройте окно схемы Divider. Полученные 
сле оптимизации параметры связанных линий и 
зисторов показаны на рис. 8.43. 

 даже небольшая разбалансировка деле-
я. 

Откройте окно схемы Divider. Полученные 
сле оптимизации параметры связанных линий и 
зисторов показаны на рис. 8.43. 

 
я размеры связанных линий, можете убедиться, 
зменением параметров элементов MCLIN. Заме-
ыми плоскостями, т.к. при

 
я размеры связанных линий, можете убедиться, 
зменением параметров элементов MCLIN. Заме-
ыми плоскостями, т.к. при

Рис. 8.41 

Рис. 8.43

Рис. 8.42 
Открывая окна извлеч

гии измен
кна извлеч
гии измен

 экстракции отрезки от
 к длине линии, указанной в свойствах эле-

динственным и, видимо, не самым удачным.  
ветвителя, кроме резисторов. 
RACT и все три извлечённых структуры CLIN

 экстракции отрезки от
 к длине линии, указанной в свойствах эле-

динственным и, видимо, не самым удачным.  
ветвителя, кроме резисторов. 
RACT и все три извлечённых структуры CLIN1,

ся элементу EXTRACT и на вкладке Parameters заме-
Name=”EM_Extract”. 

1,
ся элементу EXTRACT и на вкладке Parameters заме-

Name=”EM_Extract”. xtract1” на 
 мышки по всем элементам разветвителя (кроме 

щёлкните по любому выделенному элементу или 
ементу и выберите Properties. В отк

xtract1” на 
 мышки по всем элементам разветвителя (кроме 

щёлкните по любому выделенному элементу или 
ементу и выберите Properties. В откному эл рыв-

ble и в поле Group name введите EM_Extract. 
Щёлкните правой кноп-

кой 

ному эл рыв-
ble и в поле Group name введите EM_Extract. 

Щёлкните правой кноп-
кой мышки по элементу
EXTRACT и выберите Add Ex-
traction. Извлечённая структура 
будет выглядеть, как показано 
на рис. 8.44. 

мышки по элементу
EXTRACT и выберите Add Ex-
traction. Извлечённая структура 
будет выглядеть, как показано 
на рис. 8.44. Рис. 8.44 



Щёлкните по значку Analyze на панели инструментов. Полученные характеристики практически 
не отличаются от предыдущих. 

Выберите в меню Simulate>Optimize и нажмите 
Start.  

 171

ристики незначительно.  

ая по элементам резисторов, выделите их. 
у выделенному элементу резистора и выберите Properties. 
 в поле Group name введите EM_Extract. Верните прежние 
были кратными 0.05 мм. 

Щёлкните правой кноп-
кой мышки по элементу 
EXTRACT и выберите Add Ex-
traction. Извлечённая структура 
Div будет выглядеть, как пока-
зано на рис. 8.46. Однако анали-
зировать её нельзя. При извле-
чении проводников им присваи-
вается материал с идеальной 
проводимостью (Perfect Con-

ductor). Так было и во всех случаях, приведённых выше. Для резисторов присвоен неизвестный матери-
ал (Material undefined). В этом случае анализ будет выполняться так, будто резисторов нет, и результат 
будет неверным. Можно в извлечённой структуре добавить материал резисторов и отредактировать со-

 будет извлечена снова с прежни-
я передачи извлекаемым структурам па-

раметров материала проводников. 
Однако извлечённую в этом варианте экстракци

электромагнитной структуры, не связанной со сх
Для создания такой структуры, откройте окно сх

кнопкой мышки и выберите Toggle Enable, чтобы ь

резки линий до референсных плос-

ентам MTEEX$, расположенные 

водники так, чтобы между ними не было зазоров
показано на рис. 8.47. Обратите внимание, что э
которые видны на  при большом увели стора. Передвигать резисторы нуж-
но с этими площ кройте окно структуры Cou
щёлкнув по значку Copy на панели инструмент
ную структуру и подключите её ко входу делит о а
удалось только после нескольких попыток. При
вставки скопированной структуры в окно, созда
удалять и начинать копирование и вставку снач
чёнными структурами ещё не доработана. На в
1.0 мм и шириной 0.6 мм. 

Измените размеры корпуса, чтобы в
Y_Dim=2.4). 

На вкладке Material Defs свойств корпуса в обл
Res1, Res2 и Res3 с сопротивлением на квадрат
в столбце Name добавьте Res1, Res2 и Res3 с ма

Выделите всю топологию созданной ст
выделенному элементу и выберите Shape Prope
те Copper, чтобы всем элементам, включая обкл едь. 

Щёлкните по первому резистору левой кнопк берите 
Shape Properties и в поле Material введите Res1. Анало
Res2 и для третье ра – материал Res3. 

В данном случае оптимизация изменила характе-

Полученные после оптимизации параметры свя-
занных линий и резисторов показаны на рис. 8.45. Рис. 8.45 

В экстракцию можно включить и резисторы. 
Откройте окно схемы. Нажмите клавишу Shift и, щёлк

Щёлкните правой кнопкой мышки по любом
На вкладке Model Options отметьте Enable и
значения переменным (рис. 8.36), чтобы они 

Рис. 8.46 

ответственно извлечённую структуру. Но в процессе анализа структура
ми параметрами. К сожалению, в экстракции нет механизма дл

и структуру можно использовать для создания 
емой, чтобы не рисовать её вручную. 

емы, щёлкните по элементу EXTRACT правой 
 отключит  экстракцию. 

Извлечённую структуру 
нужно отредактировать. Откройте 
окно структуры Div. Удалите все 
порты и примыкающие к ним от-

костей. Удалите топологические 
элементы, соответствующие эле-
м
над резисторами. Сдвиньте про-

. Сдвиньте резисторы так, чтобы они располагались, как 
лементы TFR имеют небольшие контактные площадки, 
чении элемента рези

Рис. 8.47 

 структуре
адками. От pler, выделите эту структуру и скопируйте её, 

ов. Откройте окно структуры Div, вставьте скопирован-
еля, как п казано н  рис.8.47. Заметим, что сделать это 

 щелчке по значку Paste на панели инструментов, вместо 
валась новая структура Copper_1, которую приходилось 
ала. Возможно, процедура экстракции и работа с извле-
ыходах делителя добавьте отрезки проводников длиной 

писать в него полученную структуру (X_Dim=18.3, 

асти Impedance Definitions добавьте материалы 
 100, 200 и 400 Ом соответственно. На вкладке Materials 
териалами в столбце Material De… Res1, Res2 и Res3. 
руктуры, щёлкните правой кнопкой мышки по любому 
rties. В поле EM Layer введите 2, в поле Material введи-
адки резисторов назначить материал м

ой мышки и затем правой кнопкой. Вы
гично для второго резистора назначьте материал 

го резисто



Щёлкните по значку Analyze на панели инструментов. Полученные графики показаны на рис. 
8.48 и 8.49. 
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Требуется спроектировать полосовой фил  R03003 толщиной 0.254 мм на чет-
вертьволновых короткозамкнутых шлейфах в диапазоне 5 

С помощью инструмента Tools>TXLine ей 
частоте 8 ГГц при а 0.6 мм и длина четвертьволн

Использу е, создадим предварител
1. Создайте н

11. 
2. Щё ли 

инструмент
3. В о

str
схе мент MLIN. Затем раскройте подгруппу 
Junctions, перетащите
те 
2 элементы 
MLIN, как оказано на рис. 8.50 

4. В окне просмотра элементов раскройте группу Inter-
connects, перетащите в окно схемы элемент VIA1P и 
подключите его, как показано на рис. 8.50. 

5. Выделите все элементы схемы, кроме первого элемен-
та MLIN, и скопируй лкнув по значку Copy 

на панели инс ументов. 
6. Щёлкая по te, создайте схему с восемью ре

9. 
параметры введите для последнего элемента MLIN. 

10. Дважды щёлкните по второму элементу MLIN и введите параметры
ные параметры введите для предпоследнего восьмого элемента 

11. Дважды щёлкните по третьему элементу MLIN и введите пар
гичные параметры в  седьмого элемента MLIN. 

 остальных элементов MLIN введите параметры W=0.6

8.2.2. Моделирование фильтра на короткозамкнутых шлейфах. 
ьтр на материале

– 11 ГГц. 
определяем, что ширина полоски в МПЛ на средн

Рис. 8.48 Рис. 8.49 

мерно равн
я эти данны

ового отрезка – примерно 6 мм. 
ьную схему с восемью шлейфами. 

овый проект и сохраните его с именем F5-

лкните по значку Add New Schematic на пане
ов и создайте схему с именем Fil. 

кне просмотра элементов раскройте группу Micro-
ip и затем подгруппу Lines. Перетащите в окно 
мы эле

 элемент MTEEX$ и подключи-
его к правому концу элемента MLIN. К контактам 
и 3 элемента MTEEX$ подключите 

п

те их, щё
тр

значку Pas

Рис. 8.50 

зонаторами, как показано на рис. 8.51 
7. Добавьте к схеме элемент подложки MSUB. Дважды щёлкните по этому элементу и на вкладке 

Parameters введите Er=3.0, H=0.254, T=0.018, TanD=0.0013 и ErNom=3.0. 

8. Добавьте к схеме переменные W1=0.6, W2=0.6, W3=0.6, LS=6, LL1=6, LL2=6, и LL3=6. 
Дважды щёлкните по первому элементу MLIN и введите параметры W=0.6 и L=2. Аналогичные 

 W= 10.6 и L=LL . Аналогич-
MLIN. 
аметры W=0.6 и L=LL2. Анало-

12. Для всех  и L=LL3. 

Рис.

ведите для
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 и L=LS. 
14. S. 
15. Для всех остальных шлейфов введите парамет
16. Для всех элементов VIA1P введите па
17. Добавьте порты на входе и выходе схемы, щёл

Часть созданной схемы показана на рис. 8.52 

мышки, в
бавьте еди

Оп
до 14 ГГц 

Щ
нели инст
казан на ри

Те

  l  l

13. Для первого и последнего шлейфов введите параметры W=W1
Для второго и предпоследнего шлейфов введите параметры W=W2 и L=L

ры W=W3 и L=LS. 
раметры D=0.3, H=0.254 и T=0.017. 

кая по значку Port на панели инструментов.  

Щёлкнув по значку Add New Graph на панели инструментов, создайте прямоугольный график с 
именем LdB. Щёлкните по имени графика в 
окне просмотра проекта правой кнопкой 

ыберите Add Measurement и до-
ницу измерения S21 в dB. 
ределите частоты для анализа от 3 
с шагом 0.5 мм. 
ёлкните по значку Analyze на па-
рументов. Полученный график по-
с. 8.53 
перь подготовьте схему к экстрак-

ции. 
1. Добавьте к схеме элемент 

STACKUP. Дважды щёлкните по 
этому элементу. На вкладке Material 
Defs в области Dielectric Definitions 
добавьте слой Diel_1 с параметрами 
Er=3 и TanD=0.0013. На вкладке Di-
electric Layers для слоя 1 введите 

 
добавьте слой Diel_1 с параметрами 
Er=3 и TanD=0.0013. На вкладке Di-
electric Layers для слоя 1 введите 
толщину 4. Добавите слой 2 с Thick-

ness=0.254 и Material De…=Diel_1. На вкладке Materia s добавьте слой с именем Copper тол-
толщину 4. Добавите слой 2 с Thick-

ness=0.254 и Material De…=Diel_1. На вкладке Materia s добавьте слой с именем Copper тол-
щиной 0.0017 и материалом Copper. Нажмите OK. 

2. Добавьте в схему элемент EXTRACT. Дважды щёлкните по этому элементу и на вкладке Pa-
rameters введите EM_Doc=”F5_11”, Simulator=EMSight, X_Cell_Size=0.1, Y_Cell_Size=0.1, 

щиной 0.0017 и материалом Copper. Нажмите OK. 
2. Добавьте в схему элемент EXTRACT. Дважды щёлкните по этому элементу и на вкладке Pa-

rameters введите EM_Doc=”F5_11”, Simulator=EMSight, X_Cell_Size=0.1, Y_Cell_Size=0.1, 
Extension=0.5. Остальные параметры оставьте по умолчанию и нажмите OK. 

3. Выделите все элементы схемы. Дважды щёлкните по любому выделенному элементу схемы и на 
вкладке Model Options отметьте Enable, нажмите OK. 

4. по на , о

Extension=0.5. Остальные параметры оставьте по умолчанию и нажмите OK. 
3. Выделите все элементы схемы. Дважды щёлкните по любому выделенному элементу схемы и на 

вкладке Model Options отметьте Enable, нажмите OK. 
4. по на , оЩёлкните  значку View Layout  панели инструментов чтобы открыть кно топологии схе-

мы. Если соединения элементов в топологии отображаются неверно, выделите все элементы то-
пологии схемы и щёлкните по значку Snap Together на панели инструментов, чтобы исправить 
отображение топологии. 

Щёлкните  значку View Layout  панели инструментов чтобы открыть кно топологии схе-
мы. Если соединения элементов в топологии отображаются неверно, выделите все элементы то-
пологии схемы и щёлкните по значку Snap Together на панели инструментов, чтобы исправить 
отображение топологии. 

Рис. 8.52

Рис. 8.53 
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5. 
 Extraction, чтобы просмотреть извлечённую электромагнитную структуру. Она должна вы-

глядеть, как показано на рис. 8.54. 

мизации. Выберите в меню View>Variable 
Browser. В откр  окне со списком 

троки с переменны-
 схему LL1, LL2, LL3, 

метьте столбцы Optimize и Con-

ия значений 
 переменных 

Lower=0.3. Окно будет выглядеть, как по-

Добавьте цели оптимизации. В начале добавьте цель оптимизации в полосе пропускания. Щёлк-
ните правой кнопкой мышки по Optimizer Goals в окне просмотра проекта и выберите Add Optimizer 
Goal. В списке Measurement отметьте Fil:DB|(S(2,1)|), отметьте Meas>Goal, снимите отметку в Min и в 
поле Start введите 5, снимите отметку в Max и в поле Stop введите 11, в поле Goal start введите -0.2. 
Нажмите OK. 

Теперь введите цели оптимизации в полосах заграждения. Щёлкните правой кнопкой мышки по 
Optimizer Goals в окне просмотра проекта и выберите Add Optimizer Goal. В списке Measurement от-
метьте Fil:DB|(S(2,1)|), отметьте Meas<Goal, снимите отметку в Max и в поле Stop введите 4, в поле 

il:DB|(S(2,1)|), отметьте Meas<Goal, сними-

timize. Нажмите Start в 

е оптимизации значения переменных 

Откройте окно схемы, щёлкните правой кнопкой мышки по элементу EXTRACT и выберите 
Add

Щёлкните по значку Analyze на 
панели инструментов. Полученный график 
показан на рис. 8.55. 

Подготовьте переменные к опти-

Рис. 8.54

ывшемся
найдите спеременных 

ми, добавленными в
W1,W2, W3 и LS. Для всех этих перемен-
ных от
strained. Для переменных LL1, LL2, LL3 и 
LS ведите пределы изменен
Upper=6.2 и Lower=5.5. Для
W1,W2 и W3 введите Upper=1 и 

Рис. 8.55 казано на рис. 8.56. Закройте окно. 

Рис. 8.56

Goal start введите -25. Нажмите OK. 
Снова щёлкните правой кнопкой мышки по Optimizer Goals в окне просмотра проекта и выбе-

рите Add Optimizer Goal. В списке Measurement отметьте F
те отметку в Min и в поле Start введите 12, в поле Goal start введите -25. Нажмите OK. 

Выберите в меню Simulate>Op
открывшемся окне. 

Полученные посл
показаны на рис. 8.57. Рис. 8.57 
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ав Properties, измените 
е пропускания. 

8.58 и 8.59. 

Можно изменять параметры и вручную. В этом случае нельзя редактировать извлечённую струк-
туру, т.к. извлечённая структура определяется параметрами 
элементов с и новом анализе будет извлечена преж-

цессе экстракци
При значениях параметров, показанных на рис. 8.

8.61 и 8.62. 

Создайте график VSWR и, щёлкнув правой кнопкой по графику и выбр
свойства графика так, чтобы удобнее наблюдать характеристику согласования в полос

Полученные после оптимизации характеристики показаны на рис. 

Рис. 8.59 Рис. 8.58 
Согласование в полосе пропускания можно ещё улучшить. Можно попытаться выполнить ещё 

новую оптимизацию, выбрав другой метод оптимизации. Можно попробовать подстроить, используя 
инструмент настройки. Для этого при открытом окне схемы щёлкните по значку Tune Tool на панели 
инструментов и назначьте для настройки все переменные в схеме. Выполнять настройку не очень удоб-
но, т.к. смещение любого движка на инструменте настройки приводит к новому анализу, который длится 
довольно долго, т.к. выполняется электромагнитный анализ. 

хемы и пр
няя структура. Нужно изменять параметры элементов в схеме, 
параметры структуры будут изменены автоматически в про-

и. 
60, расчётные характеристики имеют вид рис. 

Рис. 8.60 

 
 

Рис. 8.61 Рис. 8.62 
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